SolidWorks Modeler Getting Started Guide

© 2010 Desktop EDA
# Table of Contents

<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Foreword</td>
<td>1</td>
</tr>
<tr>
<td>Part I Introduction</td>
<td>2</td>
</tr>
<tr>
<td>Part II How the Product Works</td>
<td>4</td>
</tr>
<tr>
<td>Part III Is the Product Installed Properly?</td>
<td>6</td>
</tr>
<tr>
<td>1 If you cannot see the Toolbar</td>
<td>9</td>
</tr>
<tr>
<td>Part IV Setting Up Your PCB Document</td>
<td>11</td>
</tr>
<tr>
<td>1 Defining the Board Outline</td>
<td>11</td>
</tr>
<tr>
<td>2 Using SolidWorks Parts</td>
<td>13</td>
</tr>
<tr>
<td>3 Setting Up For Auto Parts</td>
<td>14</td>
</tr>
<tr>
<td>Part V Creating An Assembly</td>
<td>19</td>
</tr>
<tr>
<td>1 Panel Settings</td>
<td>19</td>
</tr>
<tr>
<td>2 Export to SolidWorks</td>
<td>20</td>
</tr>
<tr>
<td>Part VI Updating a PCB from SolidWorks</td>
<td>24</td>
</tr>
<tr>
<td>1 Making Changes in SolidWorks</td>
<td>24</td>
</tr>
<tr>
<td>2 Updating the PCB</td>
<td>25</td>
</tr>
<tr>
<td>Part VII Starting a PCB Design in SolidWorks</td>
<td>29</td>
</tr>
<tr>
<td>1 Creating the Board Outline Part</td>
<td>29</td>
</tr>
<tr>
<td>2 Creating the Assembly</td>
<td>37</td>
</tr>
<tr>
<td>3 Importing Data from the SolidWorks</td>
<td>40</td>
</tr>
<tr>
<td>Part VIII Modeling Traces in SolidWorks</td>
<td>43</td>
</tr>
<tr>
<td>1 Checking that the Tracks can be Outlined</td>
<td>45</td>
</tr>
<tr>
<td>2 Creating the PCB Part With Traces</td>
<td>45</td>
</tr>
<tr>
<td>Index</td>
<td>0</td>
</tr>
</tbody>
</table>
1 Introduction

The SolidWorks Modeler is a powerful tool enabling you to create a SolidWorks Assembly from your PCB document. This product uses SolidWorks installed on your PC to create a SolidWorks Assembly.

This document guides you through the process of creating a SolidWorks Assembly of a PCB and introduces some of the bi-directional features. It also provides an example of how to start a PCB design in SolidWorks.

Use this guide in conjunction with the files provided in the folder called Demos which is in the directory where this product is installed.

We suggest that you get to know how the product works using this guide. Once you are comfortable with the concepts, you can move on to your own PCB’s.

More detailed information on the features of this product is provided in the Help. You can access Help via the Help menu in the PCB Editor or via the Help button in the product toolbar. In the process of working through the Getting Started topics, when you reach the end of a window, click on this button at the top of the window to move on to the next topic.

If you want to go back, click on this button at the top of the window.
2 How the Product Works

When you run the ‘Create Assembly’ command, if SolidWorks is already running, the program connects to it, if not, SolidWorks is launched and it runs in background mode.

The product then performs the following actions:
1. A SolidWorks part is created containing the PCB outline extruded to the thickness of the PCB. Holes are also added as Cuts.
2. A SolidWorks part is created for each PCB component that does not have a corresponding part in the SolidWorks part folders.
3. A SolidWorks assembly with the same name as the PCB is created
4. The PCB Outline part is added followed by SolidWorks parts for each PCB component.

When you choose the 'Import from SolidWorks" command, the following actions are performed:
1. The program connects to SolidWorks and opens an Assembly with the same name as the PCB
2. The PCB Board Shape is updated
3. Mounting Moles in the PCB are moved to line up with Mounting Holes defined in the Assembly
4. Components are moved to line up with corresponding Parts in the Assembly.

This product requires that SolidWorks is installed on the same PC as Altium Designer. If this is inconvenient for your company, consider the alternative approach of using IDF files. Contact Desktop EDA for more information.
3 Is the Product Installed Properly?

Once the product is installed, the following menu items should be added to the Altium Designer menu system:

**File Menu**

- Save Design Workspace As...
- AutoCAD 3D Modeler
- SolidWorks 3D Modeler (V7)
- IDF Modeler
- Fabrication Outputs
- Assembly Outputs
- Page Setup...
- Print Preview...
- Print...
- Default Prints...
- Smart PDF...
- Import Wizard
- Recent Documents

**Tools Menu**

- SW Modeler (V7) Tools
- Desktop EDA Utility Preferences...
- Edit Heights...
- Check Outline
- Check For Outlining
- List 3D Part Usage
- Show Placement Differences
- SW Modeler Preferences...
- Run Width DRC
- Load BOM Configs
- Load 3D Model from Xref
- Create Variant Configurations
- Outline to Assembly

**Help Menu**
Panel

The Product panel allows you to access all commands on its various tabs. This panel can be displayed by pressing the PCB button in the Status bar to display the list of panels available on the PCB editor. Choose SolidWorks as shown:

This displays the Panel shown below:
Is the Product Installed Properly?

This toolbar is also added.

If you cannot see this Toolbar
3.1 If you cannot see the Toolbar

If you cannot see the toolbar while in the PCB editor, do the following:

Exit the Altium Designer application and go to the directory shown in the image below and delete the file called DXP.RAF.

For Windows Vista: `c:\Users\AppData\Roaming\Altium Designer <Ad Version>`

Launch Altium Designer and this toolbar should be visible in the PCB editor.
4 Setting Up Your PCB Document

The following sections describe the set up requirements in your PCB document.

Open the PCB named Demo\Contoller\Pcb\Controller.pcbDoc and use this in the following topics.

4.1 Defining the Board Outline

You have the choice of either using the Board Shape or a shape made up of Tracks and Arcs drawn on a mechanical layer to define the shape of the PCB in the 3D environment.

You tell the program which method you are using by going to the Board Outline drop down list in the Options tab of the Panel as shown:

If you choose Board Shape, then that is all you need to do.

If the PCB has "cut outs", you can other either use Altium Regions defined as Board Cutouts (if you choose the Board Shape option) or you can define shapes on the mechanical layer you use as the Board Outline layer.

We will choose Board Shape for this example.

You can define Mounting Holes by placing multi-layer Pads and assigning their designators with the prefix "MH" and setting a hole size. (this prefix can be changed by setting the MH Prefix field in the Panel).

This PCB has two mounting holes as shown. Mounting Holes are always added exported whereas other holes are exported if the appropriate check boxes are checked. Only Mounting Holes can be imported from SolidWorks.
This above PCB produces a part in SolidWorks like this:
4.2 Using SolidWorks Parts

If you have SolidWorks parts that model your PCB parts, the program uses them. Otherwise, it automatically creates parts using Bodies or geometry extracted from the PCB component.

There are a number of methods available to associate a SolidWorks part with a PCB part. You determine the method by a setting in the Part Selection section of the Panel as shown.
For this exercise, choose Footprint. This causes the program to search for a Part with the filename that is the same as the footprint name. If a Footprint name contains characters that are not allowable in a filename, that character is replaced by an underscore. See the table below for examples.

<table>
<thead>
<tr>
<th>Footprint Name</th>
<th>Part name that is searched for</th>
</tr>
</thead>
<tbody>
<tr>
<td>Dip14</td>
<td>Dip14.sldprt</td>
</tr>
<tr>
<td>DB37RA/F</td>
<td>DB37RA_F.sldprt</td>
</tr>
<tr>
<td>RAD0.2</td>
<td>RAD0.2.sldprt</td>
</tr>
</tbody>
</table>

The program searches the folders listed in the Part Folders field for parts with the same name as the Footprint name assigned to Components in the PCB.

To add folders to the Part Folders field, click on the Browse button above the Part Folders field. This displays a dialog box that allows you to browse to Folders. For this example, browse to:

C:\Program Files\Altium Designer Summer 09\SwModelerV8\Demos\Controller\SwParts

Hint: Double click on the Part Folders field opens an Explorer window allowing you to review the contents of the folder.

### 4.3 Setting Up For Auto Parts

If there is no SolidWorks part in the Part Folders for any component on your PCB, the program creates one.

The Auto Parts section of the Option tab of the Panel allows you to control how Auto Parts are created.
If the Use Bodies check box is checked and the Component contains Bodies, then these are used to create the Auto Part.

If Use Component Outlines is checked, the layer selected in the Component Outline Layer drop down list is searched for an enclosed shape. If one is found, this is used to define the shape of the Auto Part.

If there is a shape found, or if Use Component Outlines is not checked, the Silk Screen layer is checked for an enclosed shape. If one is found, this is used.

If all of the above fail to provide data to create an Auto Part, a shape is created from the bounding rectangle of the component, ignoring Designator and Comment text.

The enclosed shape is extruded by the Height assigned to the component to create the Auto Part.

You can edit the values of Components using the Height Editor. You can display the Height Editor by clicking on the Height Editor button on the Height Editor tab of the Panel.

This displays the Height Editor that lists the Footprints on the PCB. A column is provided for entering heights. The current units setting determines the units of the height values (i.e. mils or mm). The program uses this value to set the extrusion height that SolidWorks uses when creating the part.
When you edit a height entry, every footprint on the PCB with that footprint name is updated with the height value.

**Note:** You can also edit component heights by double clicking on a component and editing the Height property.

Pressing the Colors button in the Auto Parts section displays the Auto Parts Settings dialog box. This allows you to associate a color with a Designator prefix. This allows SolidWorks to assign colors to parts based on their Designator prefix. E.g. all capacitors will display in the color you associate with the letter C.
<table>
<thead>
<tr>
<th>Item</th>
<th>Color</th>
</tr>
</thead>
<tbody>
<tr>
<td>Pcb</td>
<td></td>
</tr>
<tr>
<td>Copper</td>
<td></td>
</tr>
<tr>
<td>Overlay</td>
<td></td>
</tr>
<tr>
<td>Keepout</td>
<td></td>
</tr>
<tr>
<td>Rules</td>
<td></td>
</tr>
<tr>
<td>J</td>
<td></td>
</tr>
<tr>
<td>C</td>
<td></td>
</tr>
<tr>
<td>Y</td>
<td></td>
</tr>
<tr>
<td>X</td>
<td></td>
</tr>
<tr>
<td>U</td>
<td></td>
</tr>
<tr>
<td>R</td>
<td></td>
</tr>
<tr>
<td>Q</td>
<td></td>
</tr>
<tr>
<td>D</td>
<td></td>
</tr>
<tr>
<td>PrePreg</td>
<td></td>
</tr>
</tbody>
</table>
5 Creating An Assembly

This topic guides you through the process of creating the Assembly.

5.1 Panel Settings

Set up the Panel tabs as shown below.
5.2 Export to SolidWorks

Launch SolidWorks and arrange the windows such that you can see both the Altium Designer and the SolidWorks applications.

Click on the Create Assembly button.

Watch the Altium Design status bar for progress messages and also watch the SolidWorks window. You will see the Assembly being built.

You should see a PCB similar to that shown in the screen shot below.

Review the Message Panel in Altium Designer - this displays a log of the assembly creation
Set to the Settings tab of the Panel and check the Auto Parts Only check box.

Choose Create Assembly again.

This time, the program will create parts and then build the assembly.

You should see a PCB similar to that shown in the screen shot below. The parts used are Auto
Parts created from the Bodies in the PCB components.
6 Updating a PCB from SolidWorks

This topic guides you through the process of Updating your PCB from SolidWorks.

6.1 Making Changes in SolidWorks

In the assembly ControllerWithBodies.sldasm', perform the following:

1. In the Feature Manger, expand the entry for the part named PCB by clicking on the plus sign.
2. Edit the sketch named PCBOutlineSketch by right clicking on the entry in the Feature Manager and choose Edit Sketch
3. "Stretch" a line defining on the the left side of the PCB
4. Exit this sketch (right click in the Sketch and choose Exit).
5. Right Click on the Crystal part and choose Float (if it is Fixed)
6. Left Click and hold on a Part and move it.

Now your assembly should look like this:
6.2 Updating the PCB

Go to the Altium Designer window and ensure that the ControllerWithBodies.pcbdoc is open.

Choose the Import Board Outline from SolidWorks command
You should then see the Board Outline shape change.

Choose the Synchronize PCB Component Locations from SolidWorks as shown:

The PCB should now look like this:
7 Starting a PCB Design in SolidWorks

This section guides you through the process of creating a PCB Assembly in SolidWorks from which you define the PCB Board Outline and PCB Component Locations. Once this is in place you can create create the PCB in Altium Designer.

The PCB Tools are provided to allow you to start a design in SolidWorks.

The features described in this chapter are part of the PCB Tools. These commands are accessed from the PCB Tools tab of the Panel.

7.1 Creating the Board Outline Part

Create a new SolidWorks Part then select the Front plane and create a sketch. Define the shape of the PCB by drawing lines and arcs to form an enclosed shape. Define enclosed shapes within the shape of the PCB to define "cut outs".

The example below is the part Demo\StartInSw\BoardOutlineSketch.sldprt
Select the Sketch in the Feature Manager

Invoke the menu item: Insert>Boss/Base>Extrude..

Extrude the Sketch (Insert>Boss/Base>Extrude..) using Direction 1, press the Reverse Direction button and set the Extrude Depth to 1.00mm as shown below. The Extrude Depth determines the thickness of the PCB.
Choose the PCB Tools part command Assign PCB Outline

This adds attributes to the Board Outline extrusion, sets the Board Outline color and adds the plane that is used to align the hole sketches.
Select the plane named HolePlane in the feature manager and insert a Sketch (Insert>Sketch). Place circles in the Sketch to define the locations of the plated Mounting Holes.
Cut the Sketch (Insert->Cut->Extrude..) and choose the settings Through All for Direction 1 and Direction 2 as shown below.
Choose the PCB Tools part command Assign Hole Features

This displays the Define Board Outline Hole Features dialog box. In the row for Plated Mounting Holes, click in the right hand column to display any Cut features in the Part - choose the Cut that was previously created.

The Cut feature is renamed as required and is assigned the color associated with copper features.
Save the Part.

To confirm that features in the part have been created correctly, choose the command Tools>PCB Tools>Show Part Features

This displays a list of PCB Features from the current Part as shown:

If you do not need to add Parts to your design, bypass the next topic and go to the topic Importing Data From SolidWorks.
7.2 Creating the Assembly

If you plan to add Parts to the design, then you will need to create an Assembly. If the only data required in Altium Designer is related to the Board Outline part, it is not necessary to create an Assembly.

Create a new assembly and choose the PCB Tools Assembly command: Place Outline Part. A browse dialog box displays. Browse to the PCB Outline part you created and press the Open button. This places the part as required and adds attributes.
Choose the PCB Tools Assembly command: Place Top Part. A browse dialog box displays.

Browse to the directory C:\Program Files\Altium Designer Summer 09\SwModelerV8
`\Demos\Controller\SwParts` and choose the part `DB37RA_F.sldprt` and press the Open.

The part is placed at 0,0. Move it to the required location.
Choose the PCB Tools Assembly command: Assign Part Data. The Assign Part Data dialog box displays.

Enter J1 in the right hand column to assign the designator J1 to the connector you placed.

Save the Assembly using the same filename as your PCB with the SolidWorks assembly extension.

To confirm that the features in the Assembly have been created correctly, choose the Check PCB Assembly command.

This displays a list of PCB features in the Assembly as shown:

7.3 Importing Data from the SolidWorks

Open the Board Outline part so that is it the active document in SolidWorks.

In Altium Designer, choose the command File>New PCB from SolidWorks.

The program will then go to the active document in SolidWorks and create a PCB from this document.
Alternatively, if you have created an Assembly:

In Altium Designer, create a PCB document with the same name as the Assembly.

Use the Panel commands below:

To get the Board Outline into your PCB, choose the command Import Board Outline

To get the Mounting Holes into your PCB, choose the command Import Mounting Holes.

To get parts into your PCB, it is recommended that you use the Altium Design command Design->Import Changes to get the PCB components into the PCB document. Then, choose the command Synchronise Component Locations With SolidWorks Parts. This moves the components in the PCB document with the same designator to the corresponding location in SolidWorks.
8 Modeling Traces in SolidWorks

The section guides you through the process of creating an assembly that includes Copper traces. The same procedure can be applied to Silk Screens and Polygons.

The image below shows the relevant Panel settings.
8.1 Checking that the Tracks can be Outlined

The traces are modeled in SolidWorks by creating an enclosed shape around all Tracks and Pads that are to be modeled and creating a Boss Extrude from that shape. SolidWorks requires that the shape is perfectly enclosed otherwise the Extrusion process fails. We call the process of creating the shape Outlining.

The Outlining process works by pouring a polygon with zero clearance around the objects to be Outlined and then extracting the Outline shape from the Polygon. Under some circumstances, the Polygon command does not create a perfectly enclosed shape. For this reason, the Outlining Check command is provided.

For examples of where the Polygon pouring will fail to create perfect shapes, see this topic in the SolidWorks Modeler help: Possible Causes of Outlining Errors.

The Outlining Check commands are provided to allow you to check that the layers on your PCB can be Outlined. This command goes through all the processes that the Create Assembly command does except sending the shapes to SolidWorks.

For this example, click on the Outlining Check command and choose Top Tracks. After this has run, choose Bottom Tracks. If there are outlining errors, details are written to the Messages Panel. You can double click on the lines in the message Panel to zoom to the area where the problem exists.

See the topic on correcting outlining problems for the procedure to follow. If there are no outlining errors, a message confirming this displays in the Messages Panel.

8.2 Creating the PCB Part With Traces

Choose the Create PCB Part command - this creates the Board Outline part without creating the Assembly.

This Part will look like this:
Alternatively, you could choose the Update to SolidWorks commands. This add features to the existing Board Outline Part.