KB: Publicación del proyecto vacía debido a la configuración de la ruta de salida

Altium Designer Altium Designer
Si la publicación de un proyecto se completa, pero genera un paquete de publicación vacío o no genera el contenido esperado del OutJob, es posible que la ubicación de salida configurada esté impidiendo que los datos de publicación se escriban correctamente. Esto puede ocurrir cuando la ruta de salida (Output Path) o la ruta del registro ECO (ECO Log Path) apunta a una ubicación inaccesible o situada en una unidad distinta de la del proyecto local. Actualizar estas rutas para que apunten a una carpeta accesible en la misma unidad que el proyecto local puede permitir que Project Releaser genere los archivos de publicación esperados.

Detalles de la solución

La versión publicada del proyecto aparece vacía tras completarse el proceso

La publicación de un proyecto puede completarse correctamente, pero el paquete generado aparece vacío o faltan las salidas personalizadas de OutJob esperadas.

Altium Designer Server Release workflow on Review Data step, listing included outputs: source data, fabrication data, assembly data for no variant, and assembly data for a TEST variant, each with status indicators and Explore/Details links.

Los archivos de salida no se pueden escribir correctamente

Se sospecha que este problema está relacionado con el directorio de salida configurado. Si Altium no puede acceder a la ubicación de salida especificada o escribir en ella de forma fiable, es posible que los archivos de la publicación no se generen en la ubicación esperada. Como estos ajustes de ruta se guardan en el proyecto, el problema puede persistir hasta que se actualice la configuración.

Utilice ubicaciones de salida accesibles para el proyecto

  • Cambie la ruta de salida a una carpeta local.
  • Utilice una ubicación de salida a la que pueda acceder el usuario actual.
  • Asegúrese de que Output Path y ECO Log Path estén ubicados en la misma unidad que el proyecto local.
  • Verifique que existan las configuraciones de OutJob necesarias y que estén configuradas correctamente.

Actualice la configuración de la ruta de salida

  1. Abra el proyecto.
  2. Haga clic con el botón derecho en el proyecto y seleccione Explore; después, anote la ubicación del archivo del proyecto.

    Altium Designer Projects panel context menu with Explore selected, opening Windows File Explorer to the BOM Testing project folder at C:\Users\Public\Documents\Altium\BOM Testing.

  3. Abra Project Options seleccionando Project » Project Options, o haga clic con el botón derecho en el proyecto en el panel Projects y seleccione Project Options.

    Altium Designer Project menu open, showing project management commands and the Project Options entry selected, indicating the path to access project settings for BOM Testing.PrjPcb.

  4. Seleccione la pestaña Options.
  5. Actualice Output Path y ECO Log Path para que apunten a carpetas de la misma unidad que el proyecto local.

    Altium Designer Options dialog for a PCB project, showing Output Options with Output Path and ECO Log Path set to local folders for BOM Testing, along with netlist, cross‑reference, and annotation settings.

  6. Guarde los cambios.
  7. Vuelva a ejecutar la publicación del proyecto.

Referencias

AI-LocalizedLocalizado por IA
Si encuentra un problema, seleccione el texto/imagen y presioneCtrl + Enterpara enviarnos sus comentarios.
Contents
Was this article helpful?