KB: Rilascio del progetto vuoto causato dalla configurazione del percorso di output

Altium Designer Altium Designer
Se il rilascio di un progetto viene completato ma produce un pacchetto di rilascio vuoto o non genera i contenuti OutJob previsti, il percorso di output configurato potrebbe impedire la corretta scrittura dei dati di rilascio. Questo può accadere quando il percorso di output (Output Path) o il percorso del registro ECO (ECO Log Path) punta a una posizione non accessibile o situata su un’unità diversa da quella del progetto locale. Impostando questi percorsi su una cartella accessibile nella stessa unità del progetto locale, è possibile consentire al Project Releaser di generare i file di rilascio previsti.

Dettagli della soluzione

Il rilascio del progetto risulta vuoto dopo il completamento

Il rilascio di un progetto può essere completato correttamente, ma il pacchetto di rilascio generato risulta vuoto oppure mancano gli output personalizzati OutJob previsti.

Altium Designer Server Release workflow on Review Data step, listing included outputs: source data, fabrication data, assembly data for no variant, and assembly data for a TEST variant, each with status indicators and Explore/Details links.

Impossibile scrivere correttamente i file di output

Si sospetta che questo problema sia legato alla directory di output configurata. Se Altium non riesce ad accedere o a scrivere in modo affidabile nella posizione di output specificata, i file di rilascio potrebbero non essere generati nella posizione prevista. Poiché queste impostazioni dei percorsi sono memorizzate nel progetto, il problema può persistere finché la configurazione non viene aggiornata.

Utilizzare posizioni di output del progetto accessibili

  • Impostare il percorso di output su una cartella locale.
  • Utilizzare una posizione di output accessibile all'utente corrente.
  • Assicurarsi che Output Path e ECO Log Path si trovino sulla stessa unità del progetto locale.
  • Verificare che le configurazioni OutJob richieste esistano e siano configurate correttamente.

Aggiornare la configurazione del percorso di output

  1. Aprire il progetto.
  2. Fare clic con il pulsante destro del mouse sul progetto e selezionare Explore, quindi prendere nota della posizione del file di progetto.

    Altium Designer Projects panel context menu with Explore selected, opening Windows File Explorer to the BOM Testing project folder at C:\Users\Public\Documents\Altium\BOM Testing.

  3. Aprire Project Options selezionando Project » Project Options, oppure fare clic con il pulsante destro del mouse sul progetto nel pannello Projects e selezionare Project Options.

    Altium Designer Project menu open, showing project management commands and the Project Options entry selected, indicating the path to access project settings for BOM Testing.PrjPcb.

  4. Selezionare la scheda Options.
  5. Aggiornare Output Path e ECO Log Path in modo che puntino a cartelle sulla stessa unità del progetto locale.

    Altium Designer Options dialog for a PCB project, showing Output Options with Output Path and ECO Log Path set to local folders for BOM Testing, along with netlist, cross‑reference, and annotation settings.

  6. Salvare le modifiche.
  7. Eseguire nuovamente il rilascio del progetto.

Riferimenti

AI-LocalizedLocalizzato tramite A
Se trovi un problema, seleziona il testo/l’immagine e premi Ctrl + Enter per inviarci il tuo feedback.
Contents
Was this article helpful?