KB: Linee della griglia non visibili nel layout PCB

Altium Designer Altium Designer
Se le linee o i punti della griglia non sono visibili nell'editor PCB, il problema potrebbe dipendere dalle impostazioni di utilizzo della griglia, dalla visibilità globale delle griglie, dalla configurazione di visualizzazione o dalle impostazioni del colore della griglia. La visibilità della griglia è controllata dalle relative impostazioni Comp e Non Comp, dall'opzione globale Show Grid e dalle impostazioni di visualizzazione Fine e Coarse. In alcuni casi, una griglia può continuare a influire sull'aggancio degli oggetti anche quando non è visualizzata. Questo articolo spiega come verificare la configurazione della griglia, ripristinarne la visibilità e regolare le opzioni di visualizzazione per renderla visibile nell'area di lavoro del layout PCB.

Dettagli della soluzione

Le linee della griglia non sono visibili

La griglia dell'editor PCB non è visibile anche se è stata configurata e il documento PCB è aperto. Le linee o i punti della griglia previsti potrebbero non essere visualizzati durante le normali operazioni di modifica, durante lo spostamento dei componenti o in entrambe le situazioni. Gli oggetti potrebbero comunque agganciarsi alla griglia anche quando questa non è visualizzata.

La visualizzazione della griglia è controllata da più impostazioni

La visibilità della griglia dipende da più impostazioni. Una griglia può essere nascosta in base alla configurazione di Comp e Non Comp, all'opzione globale Show Grid o alle singole impostazioni di visualizzazione. Se sia Comp che Non Comp sono disabilitati, la griglia non è visibile, ma può comunque essere applicata in base alle impostazioni correnti del comportamento di aggancio. Una griglia non sarà visibile neanche se entrambe le opzioni di visualizzazione Fine e Coarse sono impostate su Do Not Draw. Colori della griglia con un contrasto insufficiente possono rendere difficile distinguere una griglia visualizzata.

Verificare le impostazioni di visibilità e visualizzazione

  • Assicurarsi che Non Comp sia abilitato per la griglia interessata se questa deve essere visibile durante le normali operazioni di modifica.
  • Se la griglia deve essere visibile durante lo spostamento dei componenti, assicurarsi che Comp sia abilitato per la griglia interessata.
  • Assicurarsi che l'opzione globale Show Grid sia abilitata.
  • Configurare almeno una delle opzioni di visualizzazione Fine o Coarse in modo che utilizzi Lines o Dots e non sia impostata su Do Not Draw.
  • Verificare che i colori configurati per la griglia siano chiaramente visibili sullo sfondo dell'area di lavoro.
  • Se la griglia è visibile ma difficile da distinguere, passare dallo stile a linee a quello a punti o viceversa.

Controllare la configurazione della griglia

  1. Aprire il documento PCB.
  2. Se necessario, annullare le selezioni esistenti utilizzando Shift+C.
  3. Aprire il pannello Properties.
  4. Verificare che il pannello sia in modalità Board .
  5. Selezionare la scheda General e individuare la sezione Grid Manager.
  6. Individuare la griglia interessata. La griglia predefinita è denominata Global Board Snap Grid.
  7. Verificare che Non Comp sia abilitato se la griglia deve essere visibile durante le normali attività di modifica.
    Properties panel, Grid Manager section showing Global Board Snap Grid with Comp and Non Comp options enabled.
  8. Aprire il pannello View Configuration. Premere Ctrl+D per aprire il pannello con la scheda View Options visualizzata, oppure premere L per aprirlo con la scheda Layers & Colors visualizzata.
  9. Selezionare la scheda View Options.
  10. Nella sezione General Settings, verificare che Show Grid sia abilitato.
    View Configuration panel, View Options tab, showing General Settings with Show Grid enabled.
  11. Se la griglia non è ancora visibile, tornare a Properties » Board » General » Grid Manager.
  12. Fare doppio clic sulla griglia interessata oppure premere Ctrl+G mentre il cursore è posizionato sull'area della griglia nell'editor PCB.
  13. Nella finestra di dialogo dell'editor della griglia, controllare le impostazioni Display.
  14. Verificare che le opzioni di visualizzazione Fine e Coarse non siano impostate su Do Not Draw.
  15. Se necessario, controllare le impostazioni dei colori della griglia utilizzando i controlli dei colori disponibili.
    Cartesian Grid Editor dialog showing Global Board Snap Grid display settings, with Fine and Coarse grid styles set to Lines and Multiplier set to 10x Grid Step.
  16. Se il problema si verifica solo durante lo spostamento dei componenti, verificare in Properties » Board » General » Grid Manager che Comp sia abilitato per la griglia interessata. 

Note aggiuntive

La griglia predefinita Global Board Snap Grid esiste sempre e si applica all'intero spazio di progettazione, sebbene venga visualizzata solo all'interno del contorno della scheda. La griglia può essere modificata, ma non può essere rinominata, eliminata o disabilitata. La sua priorità è fissa al livello più basso.

Riferimenti

AI-LocalizedLocalizzato tramite A
Se trovi un problema, seleziona il testo/l’immagine e premi Ctrl + Enter per inviarci il tuo feedback.