Altium Designer Documentation

Management of a Specific Project in Altium NEXUS Server

Modified by Jason Howie on Jul 12, 2021
All Contents

Parent page: Managed Projects

The Altium NEXUS Server provides an advanced, manufacturing orientated CAD-centric view of the project, encompassed in the browser interface Projects Management page. This management interface offers Design, Manufacturing and BOM view options:

  • Design – display and navigate source project design documents, view design object properties and place review comments. This view uses the Web Review interface. The view is for the latest version of the source project data, rather than a specified release from that project, and so could be considered to be a work-in-progress (WIP) view.
  • BOM – view the source project's Bill Of Materials information.
  • Manufacturing – view the releases for the project. Access is provided for opening a specific Release, which will be presented on a separate tab through a Manufacturing Portal. From this portal you can view and navigate the released Assembly and Fabrication data, inspect the BOM, and ultimately download the data into a manufacturing Build Package.
  • Activities – view active or closed Process workflow Activities that apply to the current project.

The Projects Management page is opened from the NEXUS server's Projects page by selecting the required project and choosing the Open option from the menu, or by double or single -clicking on the project title – in detailed () and preview () view list modes, respectively. The page will open in a new browser tab.

Accessing the CAD-centric Projects Management page for a project.

The Projects Management page also can be accessed from within the NEXUS design client. For the active managed project, use the Project » Show in Web Browser command, from the main menus. Alternatively, right-click on the entry for the project in the Projects panel and choose the Show in Web Browser command from the context menu. When browsing the project through the NEXUS Explorer panel – configured in its default Project View rather than Classic View – access to the Projects Management page is made by clicking the button.

The following sections take a closer look at the four views into the project design and its data, presented on the Projects Management page.

Design

Related page: Web Review

The Design view provides interactive visual access to the project's design documents, property data for objects within those documents, and the ability to collaboratively comment on definable document locations. This view is for the latest version of the source project data, rather than a specified release from that project, and so could be considered to be a work-in-progress (WIP) view.

The Design view utilizes Altium's Web Review functionality to provide an immersive and interactive experience for reviewing the source schematic and PCB documents in your design project. Shown here is a schematic – hover over the image to see the PCB.

Based on an advanced web graphics engine and interface – Web Review – you are provided with all the features needed to locate and visually inspect the design and its objects. The view also includes fully rendered 2D and 3D PCB layout views, object search and select capabilities, and tree-based design document navigation. Its additional information pane provides an interface to the active Comments system – which dynamically interacts with the design space – and a comprehensive properties listing for any selected design object.

See the Web Review page for more information on the Design view functions.

BOM

The BOM view allows you to interactively examine work-in-progress (WIP) BOM data extracted from the design documents, including entries for Manufacturer and Supplier parts data derived from a project's populated ActiveBOM document (where available). When an ActiveBOM document is part of the design project, each BOM part entry () will include the primary Manufacturer part () and Supplier part () information in a hierarchical view – select an entry to see further details in the side pane.

The BOM view enables you to examine the BOM data for the latest version of the source (WIP) project data.

When your design uses managed components, an indicator is used (to the left of the component designator entry) to reflect the revision status of that component:

– Current (the latest revision of the component is being used).

– Historical (a previous revision of the component, and not the latest, is being used).

Note that the BOM in this view is for the latest version of the source project data, rather than a specified release from that project.
Projects that do not include part Manufacturer and Supply data (such as when an ActiveBOM document is not available) show BOM entries and data only.

Manufacturing

The Manufacturing view allows you to view project data packages released from the design space, which can be individually opened for examination as interactive Fabrication, Assembly and BOM views.

The view's Releases listing includes project release packages generated from the design space (see Releasing a Design), where each package incorporates the released Source, Fabrication and Assembly data. Released packages can be opened for detailed inspection through a dedicated Manufacturing Portal browser tab, accessed from the Open option of a release entry's ellipsis menu (•••). The sections below outline the manufacturing portal features.

The Manufacturing view gives you access to the released data packages, and the ability to open a package for closer inspection through a dedicated Manufacturing Portal.

Manufacturing Portal

An opened project release is presented in a new Manufacturing Portal browser tab and incorporates further sub-views:

  • Fabrication – the PCB fabrication view applies the Web Review interface to show a 2D rendering of the board layout. Standard review features include Layer Visibility selection, Comment markup, object search and object property data.

  • Assembly – the PCB assembly view applies the Web Review interface to show a 3D rendering of the board layout. The view may be zoomed, panned and angled to provide a realistic graphical view into the PCB and its constituent objects.

  • BOM – the BOM view provides a grid style listing of parts included in the design, which when selected populate the side information pane with property data for that part. BOM data is extracted from the design source data or an ActiveBOM document if included in the project. In the latter case, each BOM part entry () will include the primary Manufacturer part () and Supplier part () information in a hierarchical view, as available from the ActiveBOM document – select an entry to see further details in the side pane.

Build Package

Each of the above sub-views in the Manufacturing Portal includes the option to download a Build Package for the currently opened project release, which can then be passed to manufacturing to fabricate and assemble the board. Click the button to download the collated Build Package as a Zip archive that contains individual Zip archives for the packages included in the release.

Example showing a downloaded Build Package for a project release currently being inspected through the Manufacturing Portal.

Activities

The Activities view provides a detailed overview of the Processes associated with the project, and the current state of their progress – represented as a user-highlighted task step in their workflow diagrams. Use the Active/Closed menu options in the page header to list current or completed project activities, and the upper Search field to filter the listing by an expression contained in any column field (except dates).

Along with an annotated graphic representing the flow and state of an activity (Diagram tab), the view also includes a Data tab that lists parametric data relating to the activity (associated users, project information, etc), and a History tab showing the sequence of workflow events (start, preparation, task completion, etc).

Project activities are typically invoked in the NEXUS design client by selecting an available process from the Project » Activities menu. The activity is then assigned to an available project and data, a user for review, and if required, a nominated user as a review coordinator. Tasks are automatically created for those users, and will appear in their NEXUS client Tasklist panel and on the server's Tasks page.

Project activities, such as Ad-hoc, Milestone and Handoff Reviews, are enabled and configured by a server administrator on the Processes Management page (Admin – Processes). In the above Activities view, administrators also may cancel (Terminate) an active process, or download a CSV file that includes all listed activities.
Found an issue with this document? Highlight the area, then use Ctrl+Enter to report it.

お問合せ

お近くの営業所にお問合せください。

We're sorry to hear the article wasn't helpful to you.
Could you take a moment to tell us why?
200 characters remaining
You are reporting an issue with the following selected text
and/or image within the active document:
Altium Designer 無償評価版
Altium Designer 無償評価版
Altium Designerを使用していますか?

弊社の営業担当より詳細情報をご案内しますので、アルティウムジャパン までお問い合わせください。.
Copyright © 2019 Altium Limited

評価版ライセンスが必要な理由を下記から選択してください。

弊社の営業担当より詳細情報をご案内しますので、アルティウムジャパン までお問い合わせください。.
Copyright © 2019 Altium Limited

その場合、評価版ライセンスは不要です。

ボタンをクリックして、最新のAltium Designerインストーラをダウンロードしてください。

Altium Designerインストーラをダウンロードする

弊社の営業担当より詳細情報をご案内しますので、アルティウムジャパン までお問い合わせください。.
Copyright © 2019 Altium Limited

Altium Designerの新規ライセンスのお見積もりをご希望の場合、下記のフォームに入力してください。

プライバシーポリシーに同意の上、[ダウンロード]をクリックしてください。ご登録いただきましたメールアドレスにメールマガジンが送信されます。メール配信の停止は、メール内の​通知設定​​でお手続きいただけます。

Altium Designerサブスクリプションをご利用中の場合、評価版ライセンスは不要です。

お客様がAltium Designerサブスクリプションの有効なメンバーではない場合、下記のフォームに入力して無償評価版をダウンロードしてください。

プライバシーポリシーに同意の上、[ダウンロード]をクリックしてください。ご登録いただきましたメールアドレスにメールマガジンが送信されます。メール配信の停止は、メール内の​通知設定​​でお手続きいただけます。

Altium Designerを評価する理由を下記から選択してください。

弊社の営業担当より詳細情報をご案内しますので、アルティウムジャパン までお問い合わせください。.
Copyright © 2019 Altium Limited

無償評価版を使用するには、下記のフォームに入力してください。

プライバシーポリシーに同意の上、[ダウンロード]をクリックしてください。ご登録いただきましたメールアドレスにメールマガジンが送信されます。メール配信の停止は、メール内の​通知設定​​でお手続きいただけます。

Great News!

Valid students can get their very own 6-month Altium Designer Student License for FREE! Just fill out the form below to request your Student License today.

プライバシーポリシーに同意の上、[ダウンロード]をクリックしてください。ご登録いただきましたメールアドレスにメールマガジンが送信されます。メール配信の停止は、メール内の​通知設定​​でお手続きいただけます。

その場合、Altium Designerビューワーの無償ライセンス(有効期間6か月)をダウンロードできます。

下記のフォームに入力してライセンスをリクエストしてください。

プライバシーポリシーに同意の上、[ダウンロード]をクリックしてください。ご登録いただきましたメールアドレスにメールマガジンが送信されます。メール配信の停止は、メール内の​通知設定​​でお手続きいただけます。

素晴らしいですね。アルティウムではモノづくりに最適なプログラムを提供しています。

Upverterは、コミュニティ主導型の無償プラットフォームで、お客様のような作り手の要求に合わせて設計されています。

試してみる場合、こちらをクリック してください。

弊社の営業担当より詳細情報をご案内しますので、アルティウムジャパン までお問い合わせください。.
Copyright © 2019 Altium Limited

その場合、Altium Designerビューワーの無償ライセンス(有効期間6か月)をダウンロードできます。

下記のフォームに入力してライセンスをリクエストしてください。

プライバシーポリシーに同意の上、[ダウンロード]をクリックしてください。ご登録いただきましたメールアドレスにメールマガジンが送信されます。メール配信の停止は、メール内の​通知設定​​でお手続きいただけます。