Altium Designer Documentation

Bezier

Modified by Jason Howie on Aug 30, 2017
All Contents

Parent page: Schematic Objects

A placed Bezier curve.

Summary

A Bezier curve is a non-electrical drawing primitive. It is a free-form curved line that can be placed on a schematic sheet. The curve is defined by a series of vertex points that 'pull' the line into a curved shape.

Availability

Beziers are available for placement in both Schematic and Schematic Library Editors:

  • Schematic Editor - the following commands are available:
    • Choose Place » Drawing Tools » Bezier from the main menus.
    • Click the  button on the Utility Tools drop-down () of the Utilities toolbar.
    • Right-click and choose Place » Drawing Tools » Bezier from the context menu.
  • Schematic Library Editor - the following commands are available:
    • Choose Place » Bezier from the main menus.
    • Click the  button on the Utility Tools drop-down () of the Utilities toolbar.
    • Right-click and choose Place » Bezier from the context menu.

Placement

After launching the command, the cursor will change to a cross-hair and you will enter Bezier placement mode. Placement is made by performing the following sequence of actions:

  1. Click or press Enter to anchor the starting point for the curve.
  2. Move the cursor and click or press Enter to place a series of vertex points to define the curve. As you move the cursor the curve will be continually redrawn to indicate how it would look if you placed a vertex at the cursor position.
  3. After placing the final vertex point, right-click or press Esc to complete placement of the curve.
  4. Continue placing further Bezier curves, or right-click or press Esc to exit placement mode.

The minimum number of vertices required to define a bezier curve is 4 points. After 4 clicks the Bezier no longer appears attached to the cursor, however, if you continue to click then the last vertex on the just-defined Bezier will be used as the first vertex on the next Bezier. If you right-click once after finishing the first 4-point Bezier you will terminate the current Bezier placement, but remain in Bezier placement mode ready to start a new one. 

Additional actions that can be performed during placement are:

  • Press the Tab key to access an associated properties dialog, from where properties for the Bezier can be changed on-the-fly.
  • Press the Alt key to constrain the direction of movement to the horizontal or vertical axis, depending on the initial direction of movement.

While attributes can be modified during placement (Tab to bring up associated properties dialog), bear in mind that these will become the default settings for further placement unless the Permanent option on the Schematic – Default Primitives page of the Preferences dialog is enabled. When this option is enabled, changes made will affect only the object being placed and subsequent objects placed during the same placement session.

Graphical Editing

This method of editing allows you to select a placed Bezier object directly in the workspace and change its size and/or shape, graphically.

When a Bezier object is selected, the following editing handles are available:

A selected Bezier curve.

  • Click and drag an editing handle to "bend" the curve.
  • Click anywhere on the Bezier – away from editing handles – and drag to reposition it. While dragging, the Bezier can be rotated (Spacebar/Shift+Spacebar) or mirrored (X or Y keys to mirror along the X-axis or Y-axis respectively).

If attempting to graphically modify an object that has its Locked property enabled, a dialog will appear asking for confirmation to proceed with the edit. If the Protect Locked Objects option is enabled on the Schematic – Graphical Editing page of the Preferences dialog, and the Locked option for that design object is enabled as well, then that object cannot be selected or graphically edited. Double click on the locked object directly and disable the Locked property or disable the Protect Locked Objects option, to graphically edit the object.

Non-Graphical Editing

The following methods of non-graphical editing are available:

Via an Associated Properties Dialog

Dialog page: Bezier

This method of editing uses the Bezier dialog to modify the properties of a Bezier object.

The Bezier dialog.

The Bezier dialog can be accessed prior to entering placement mode, from the Schematic – Default Primitives page of the Preferences dialog. This allows the default properties for the bezier object to be changed, which will be applied when placing subsequent beziers.

During placement, the dialog can be accessed by pressing the Tab key.

After placement, the dialog can be accessed in one of the following ways:

  • Double-clicking on the placed Bezier curve.
  • Placing the cursor over the Bezier curve, right-clicking and choosing Properties from the context menu.
  • Using the Edit » Change command and clicking once over the placed bezier object.

Via an Inspector Panel

Panel pages: SCH Inspector, SCHLIB Inspector, SCH Filter, SCHLIB Filter

An Inspector panel enables the designer to interrogate and edit the properties of one or more design objects in the active document. Used in conjunction with appropriate filtering - by using the applicable Filter panel, or the Find Similar Objects dialog - the panel can be used to make changes to multiple objects of the same kind, from one convenient location.

Via a List Panel

Panel pages: SCH List, SCHLIB List, SCH Filter, SCHLIB Filter

List panel allows the designer to display design objects from one or more documents in tabular format, enabling quick inspection and modification of object attributes. Used in conjunction with appropriate filtering - by using the applicable Filter panel, or the Find Similar Objects dialog - it enables the display of just those objects falling under the scope of the active filter – allowing the designer to target and edit multiple design objects with greater accuracy and efficiency.

 

Found an issue with this document? Highlight the area, then use Ctrl+Enter to report it.

お問合せ

お近くの営業所にお問合せください。

You are reporting an issue with the following selected text
and/or image within the active document:
Altium Designer 無償評価版
Altium Designer 無償評価版
Altium Designerを使用していますか?

弊社の営業担当より詳細情報をご案内しますので、アルティウムジャパン までお問い合わせください。.
Copyright © 2019 Altium Limited

評価版ライセンスが必要な理由を下記から選択してください。

弊社の営業担当より詳細情報をご案内しますので、アルティウムジャパン までお問い合わせください。.
Copyright © 2019 Altium Limited

その場合、評価版ライセンスは不要です。

ボタンをクリックして、最新のAltium Designerインストーラをダウンロードしてください。

Altium Designerインストーラをダウンロードする

弊社の営業担当より詳細情報をご案内しますので、アルティウムジャパン までお問い合わせください。.
Copyright © 2019 Altium Limited

Altium Designerの新規ライセンスのお見積もりをご希望の場合、下記のフォームに入力してください。

プライバシーポリシーに同意の上、[ダウンロード]をクリックしてください。ご登録いただきましたメールアドレスにメールマガジンが送信されます。メール配信の停止は、メール内の​通知設定​​でお手続きいただけます。

Altium Designerサブスクリプションをご利用中の場合、評価版ライセンスは不要です。

お客様がAltium Designerサブスクリプションの有効なメンバーではない場合、下記のフォームに入力して無償評価版をダウンロードしてください。

プライバシーポリシーに同意の上、[ダウンロード]をクリックしてください。ご登録いただきましたメールアドレスにメールマガジンが送信されます。メール配信の停止は、メール内の​通知設定​​でお手続きいただけます。

Altium Designerを評価する理由を下記から選択してください。

弊社の営業担当より詳細情報をご案内しますので、アルティウムジャパン までお問い合わせください。.
Copyright © 2019 Altium Limited

無償評価版を使用するには、下記のフォームに入力してください。

プライバシーポリシーに同意の上、[ダウンロード]をクリックしてください。ご登録いただきましたメールアドレスにメールマガジンが送信されます。メール配信の停止は、メール内の​通知設定​​でお手続きいただけます。

Great News!

Valid students can get their very own 6-month Altium Designer Student License for FREE! Just fill out the form below to request your Student License today.

プライバシーポリシーに同意の上、[ダウンロード]をクリックしてください。ご登録いただきましたメールアドレスにメールマガジンが送信されます。メール配信の停止は、メール内の​通知設定​​でお手続きいただけます。

その場合、Altium Designerビューワーの無償ライセンス(有効期間6か月)をダウンロードできます。

下記のフォームに入力してライセンスをリクエストしてください。

プライバシーポリシーに同意の上、[ダウンロード]をクリックしてください。ご登録いただきましたメールアドレスにメールマガジンが送信されます。メール配信の停止は、メール内の​通知設定​​でお手続きいただけます。

素晴らしいですね。アルティウムではモノづくりに最適なプログラムを提供しています。

Upverterは、コミュニティ主導型の無償プラットフォームで、お客様のような作り手の要求に合わせて設計されています。

試してみる場合、こちらをクリック してください。

弊社の営業担当より詳細情報をご案内しますので、アルティウムジャパン までお問い合わせください。.
Copyright © 2019 Altium Limited

その場合、Altium Designerビューワーの無償ライセンス(有効期間6か月)をダウンロードできます。

下記のフォームに入力してライセンスをリクエストしてください。

プライバシーポリシーに同意の上、[ダウンロード]をクリックしてください。ご登録いただきましたメールアドレスにメールマガジンが送信されます。メール配信の停止は、メール内の​通知設定​​でお手続きいただけます。