Altium Designer Documentation

Text String

Modified by Jason Howie on Apr 11, 2017

Parent page: Schematic Objects

A placed Text String.

Summary

A text string (also referred to as an annotation) is a non-electrical drawing primitive. It is a single line of free text that can be placed on a schematic sheet. Uses might include section headings, revision history, timing information or some other descriptive or instructive text.

Availability

Text strings are available for placement in both Schematic and Schematic Library Editors, by:

  • Choosing Place » Text String from the main menus.
  • Clicking the  button on the Utility Tools drop-down () of the Utilities toolbar.

Placement

After launching the command, the cursor will change to a cross-hair and you will enter text string placement mode. A text string will appear "floating" on the cursor.

  1. Position the object and click or press Enter to effect placement.
  2. Continue placing further text strings, or right-click or press Esc to exit placement mode.

Additional actions that can be performed during placement are:

  • Press the Tab key to access an associated properties dialog, from where properties for the text string can be changed on-the-fly.
  • Press the Alt key to constrain the direction of movement to the horizontal or vertical axis, depending on the initial direction of movement.
  • Press the Spacebar to rotate the text string anti-clockwise or Shift+Spacebar for clockwise rotation. Rotation is in steps of 90°.
  • Press the X or Y keys to mirror the text string along the X-axis or Y-axis respectively.
A newly placed text string will initially have default text of Text. Change the text to that required, using one of the editing techniques described later in this document.

While attributes can be modified during placement (Tab to bring up associated properties dialog), bear in mind that these will become the default settings for further placement unless the Permanent option on the Schematic – Default Primitives page of the Preferences dialog is enabled. When this option is enabled, changes made will affect only the object being placed and subsequent objects placed during the same placement session.

Graphical Editing

This method of editing allows you to select a placed text string object directly in the workspace and change its location graphically. Text strings can only be adjusted with respect to their size by changing the size of the font used (accessed through the Annotation dialog). As such, editing handles are not available when the text string object is selected:

A selected Text String.

  • Click anywhere inside the dashed box and drag to reposition the text string as required. While dragging, the text string can be rotated (Spacebar/Shift+Spacebar) or mirrored (X or Y keys to mirror along the X-axis or Y-axis respectively).
  • The text for a text string object can be edited in-place by:
    1. Single-clicking the text string to select it.
    2. Single-clicking again (or pressing the Enter key) to enter the in-place editing mode. Sufficient time between each click should be given to ensure the software does not interpret the two single-clicks as one double-click (which would open the text string's properties dialog).
    3. To finish editing in-place text, press the Enter key, or use the mouse to click away from the text string.
This feature is only available provided the Enable In-Place Editing option is enabled on the Schematic – General page of the Preferences dialog.

If attempting to graphically modify an object that has its Locked property enabled, a dialog will appear asking for confirmation to proceed with the edit. If the Protect Locked Objects option is enabled on the Schematic – Graphical Editing page of the Preferences dialog, and the Locked option for that design object is enabled as well, then that object cannot be selected or graphically edited. Double click on the locked object directly and disable the Locked property or disable the Protect Locked Objects option, to graphically edit the object.

Non-Graphical Editing

The following methods of non-graphical editing are available:

Via an Associated Properties Dialog

Dialog page: Annotation

This method of editing uses the Annotation dialog to modify the properties of a text string object.

The Annotation dialog.

The Annotation dialog can be accessed prior to entering placement mode, from the Schematic – Default Primitives page of the Preferences dialog. This allows the default properties for the text string object to be changed, which will be applied when placing subsequent text strings.

During placement, the dialog can be accessed by pressing the Tab key.

After placement, the dialog can be accessed in one of the following ways:

  • Double-clicking on the placed text string object.
  • Placing the cursor over the text string object, right-clicking and choosing Properties from the context menu.
  • Using the Edit » Change command and clicking once over the placed text string object.

Via an Inspector Panel

Panel pages: SCH Inspector, SCHLIB Inspector, SCH Filter, SCHLIB Filter

An Inspector panel enables the designer to interrogate and edit the properties of one or more design objects in the active document. Used in conjunction with appropriate filtering - by using the applicable Filter panel, or the Find Similar Objects dialog - the panel can be used to make changes to multiple objects of the same kind, from one convenient location.

Via a List Panel

Panel pages: SCH List, SCHLIB List, SCH Filter, SCHLIB Filter

List panel allows the designer to display design objects from one or more documents in tabular format, enabling quick inspection and modification of object attributes. Used in conjunction with appropriate filtering - by using the applicable Filter panel, or the Find Similar Objects dialog - it enables the display of just those objects falling under the scope of the active filter – allowing the designer to target and edit multiple design objects with greater accuracy and efficiency.

Special Strings

While text string objects can be used to place user-defined text on a schematic sheet, it's not just user-defined text that can be placed. To assist in producing documentation, the concept of "special strings" is used. These act as placeholders for design or system information that is to be displayed on the Schematic at the time of output generation.

Default sets of predefined special strings are provided for use with new schematic documents. But the designer can also add their own custom special strings by defining additional parameters at the document-level (for use on current schematic only) or project-level (available for use across all schematic sheets and PCB documents in the project). Parameters can also be added to a variant, in the Edit Project Variant dialog.

Parameters have a hierarchy, which means you can create a parameter with the same name at different levels of the project, each having different values. Altium Designer resolves this in the following way:

  1. Variant (highest priority)
  2. Schematic document
  3. Project

That means the parameter value defined in the schematic document overrides the value defined in the Project options, and the value defined in the variant overrides the value defined in the schematic document. Note that schematic-level parameters are not available on the PCB or in the BoM. For these types of output you should use project or variant parameters.

Placing a Special String

To use a special string on a schematic, simply place a text string object and set its text to be one of the special string names.

On a schematic sheet, special strings are characterized by the prefix '=' (e.g. =CurrentTime, =CurrentDate, etc). The list of available special strings – both predefined and custom – can be seen by clicking the drop-down arrow associated to the Text field, in the Annotation dialog.

Parameters defined at the variant level are not listed. Such a parameter can be referenced using the special string notation (i.e. =<VariantParameterName>). The value of the parameter will only be displayed when the associated variant for which it is defined, is made the current variant.

Accessing special strings for a placed text string object.

The values of some special strings can only be viewed when the relevant output is generated. Most special strings can be viewed directly on-screen however, by enabling the Convert Special Strings option, on the Schematic – Graphical Editing page of the Preferences dialog.

Schematic Predefined Special Strings

The following are the predefined special strings available for use on a schematic document. The majority of these link to default parameter information defined for the active document on the Parameters tab of the Document Options dialog (Design » Document Options).

  • =Address1 – displays the value specified for the default document-level parameter Address1.
  • =Address2 – displays the value specified for the default document-level parameter Address2.
  • =Address3 – displays the value specified for the default document-level parameter Address3.
  • =Address4 – displays the value specified for the default document-level parameter Address4.
  • =Application_BuildNumber – displays the version and build for the current Altium Designer installation
  • =ApprovedBy – displays the value specified for the default document-level parameter ApprovedBy.
  • =Author – displays the value specified for the default document-level parameter Author.
  • =CheckedBy – displays the value specified for the default document-level parameter CheckedBy.
  • =CompanyName – displays the value specified for the default document-level parameter CompanyName.
  • =CurrentDate – the current date, automatically calculated from the user's system settings and in the format dd/mm/yyyy, updated upon editing the schematic or on refresh/redraw. Example: 22/09/2015.
  • =CurrentTime – the current time, automatically calculated from the user's system settings and in the format h:mm:ss AM/PM, updated upon editing the schematic or on refresh/redraw. Example: 2:39:47 PM.
  • =Date – used to display static date information. Displays the value specified for the default document-level parameter Date. Unlike the =CurrentDate special string, which is automatically calculated and presented in a set format, the user can enter static date information in any format they like.
  • =DocumentFullPathAndName – used to display the full path and name of the document into which the string is placed. Example: C:\MyTestDesign\PSU.SchDoc.
  • =DocumentName – used to display the schematic's file name only (without the file path). Example: PSU.SchDoc.
  • =DocumentNumber – displays the value specified for the default document-level parameter DocumentNumber. The source parameter can also be updated through the Sheet Numbering For Project dialog, when using the Tools » Number Schematic Sheets command.
  • =DrawnBy – displays the value specified for the default document-level parameter DrawnBy.
  • =Engineer – displays the value specified for the default document-level parameter Engineer.
  • =ImagePath – displays the value specified for the default document-level parameter ImagePath.
  • =Item – the Item that the generated data relates to (e.g. D-810-2000). The data will be used to build that Item.
  • =ItemAndRevision – the Item and specific revision of that Item that the generated data relates to, in the format <Item ID>-<Revision ID> (e.g. D-810-2000-01.A.1). The data will be used to build that specific revision of that particular Item.
  • =ItemRevision – the specific revision of the Item that the generated data relates to (e.g. 01.A.1). The data is stored in that Item Revision within the target Altium Vault.
  • =ItemRevisionBase – the Base Level portion of an Item Revision's naming scheme (e.g. 1).
  • =ItemRevisionLevel1 – the Level 1 portion of an Item Revision's naming scheme (e.g. A).
  • =ItemRevisionLevel1AndBase – the Level 1 and Base Level portions of an Item Revision's naming scheme (e.g. A.1).
  • =ItemRevisionLevel2 – the Level 2 portion of an Item Revision's naming scheme (e.g. 01).
  • =ItemRevisionLevel2AndLevel1 – the Level 2 and Level 1 portions of an Item Revision's naming scheme (e.g. 01.A).
  • =ModifiedDate – the modified date stamp of the schematic, automatically populated. Example: 23/09/2015.
  • =Organization – displays the value specified for the default document-level parameter Organization.
  • =PCBConfigurationName – the name of the data set from which the output has been generated, as defined in the Release view (Project Releaser).
  • =ProjectName – displays the actual name of the project (including extension). For example, for a project with filename MyPCB.PrjPcb, this special string will display MyPCB.PrjPcb.
  • =Revision – displays the value specified for the default document-level parameter Revision.
  • =Rule – displays the value specified for the default document-level parameter Rule. The value for this parameter will initially be Undefined Rule (appearing as * on the schematic). Double-click on the parameter value to access the ability to define a rule type and edit its constraint(s).
  • =SheetNumber – the sheet number of the current schematic. This value is calculated when using the following commands from the Tools menu:
    • Number Schematic Sheets – the assigned sheet number, in the Sheet Numbering For Project dialog, will be entered into the value for the default document-level parameter SheetNumber. The special string, when used on the Editor tab view of the schematic sheet will source its information from here.
    • Annotate Compiled Sheets – the assigned compiled sheet number, in the Annotate Compiled Sheets dialog, will be displayed when viewing the string on the Compiled tab view of the schematic. The option to display the expanded compiled names of the Sheet Number object must be enabled, in the Compiled Names Expansion section, on the Schematic – Compiler page of the Preferences dialog.
  • =SheetTotal – the sheet total for the project. This value is calculated when using the following commands from the Tools menu:
    • Number Schematic Sheets – the sheet total, in the Sheet Numbering For Project dialog, will be entered into the value for the default document-level parameter SheetTotal. The special string, when used on the Editor tab view of the schematic sheet will source its information from here.
    • Annotate Compiled Sheets – the sheet total, source from the number of sheets listed in the Annotate Compiled Sheets dialog, will be displayed when viewing the string on the Compiled tab view of the schematic. The option to display the expanded compiled names of the Sheet Number object must be enabled, in the Compiled Names Expansion section, on the Schematic – Compiler page of the Preferences dialog.
  • =Time – used to display static time information. Displays the value specified for the default document-level parameter Time. Unlike the =CurrentTime special string, which is automatically calculated and presented in a set format, the user can enter static time information in any format they like.
  • =Title – displays the value specified for the default document-level parameter Title.
  • =VariantName - displays the variant from which output has been generated. This follows the entry for the current variant (presented and changed through the Variants toolbar). If the base design is used to generate the output, the value will simply be [No Variations].
  • =VersionControl_ProjFolderRevNumber – the current revision number of the Project, which is incremented whenever a full commit of the project (i.e. including the project file) is performed. Version control must be used for this string to contain any information.
  • =VersionControl_RevNumber – the current revision number of the document. Version control must be used for this string to contain any information.

Remember that the full list of special strings available in the Annotation dialog will also include any derived from user-defined document-level and project-level parameters. Parameters defined at the variant-level are not listed.

Special Strings for use with Component Parameters

Several additional special strings (or special interpretations of existing ones) are available when defining component parameters. In each case, the special string is entered as the value for a parameter.

  • =CurrentFootprint – displays the name of the currently assigned footprint for the component, as defined in the Models region of the associated Component Properties dialog.
  • =Comment – displays the value appearing in the component's Comment field, as defined in the Properties region of the associated Component Properties dialog.
  • =Description – displays the value appearing in the component's Description field, as defined in the Properties region of the associated Component Properties dialog.
  • =<ParameterName> – displays the value defined for a specified component parameter. Enter the actual name of a component parameter as the special string name – so for a component parameter named PowerRating, simply enter =PowerRating. When defining the Comment property for a component, the associated drop-down field will be populated with special strings for all existing component parameters – enabling quick use of any defined parameter's value for the Comment.

 

Found an issue with this document? Highlight the area, then use Ctrl+Enter to report it.

お問合せ

お近くの営業所にお問合せください。

You are reporting an issue with the following selected text
and/or image within the active document:
Altium Designer 無償評価版
Altium Designer 無償評価版
Altium Designerを使用していますか?

弊社の営業担当より詳細情報をご案内しますので、アルティウムジャパン までお問い合わせください。.
Copyright © 2019 Altium Limited

評価版ライセンスが必要な理由を下記から選択してください。

弊社の営業担当より詳細情報をご案内しますので、アルティウムジャパン までお問い合わせください。.
Copyright © 2019 Altium Limited

その場合、評価版ライセンスは不要です。

ボタンをクリックして、最新のAltium Designerインストーラをダウンロードしてください。

Altium Designerインストーラをダウンロードする

弊社の営業担当より詳細情報をご案内しますので、アルティウムジャパン までお問い合わせください。.
Copyright © 2019 Altium Limited

Altium Designerの新規ライセンスのお見積もりをご希望の場合、下記のフォームに入力してください。

プライバシーポリシーに同意の上、[ダウンロード]をクリックしてください。ご登録いただきましたメールアドレスにメールマガジンが送信されます。メール配信の停止は、メール内の​通知設定​​でお手続きいただけます。

Altium Designerサブスクリプションをご利用中の場合、評価版ライセンスは不要です。

お客様がAltium Designerサブスクリプションの有効なメンバーではない場合、下記のフォームに入力して無償評価版をダウンロードしてください。

プライバシーポリシーに同意の上、[ダウンロード]をクリックしてください。ご登録いただきましたメールアドレスにメールマガジンが送信されます。メール配信の停止は、メール内の​通知設定​​でお手続きいただけます。

Altium Designerを評価する理由を下記から選択してください。

弊社の営業担当より詳細情報をご案内しますので、アルティウムジャパン までお問い合わせください。.
Copyright © 2019 Altium Limited

無償評価版を使用するには、下記のフォームに入力してください。

プライバシーポリシーに同意の上、[ダウンロード]をクリックしてください。ご登録いただきましたメールアドレスにメールマガジンが送信されます。メール配信の停止は、メール内の​通知設定​​でお手続きいただけます。

Great News!

Valid students can get their very own 6-month Altium Designer Student License for FREE! Just fill out the form below to request your Student License today.

プライバシーポリシーに同意の上、[ダウンロード]をクリックしてください。ご登録いただきましたメールアドレスにメールマガジンが送信されます。メール配信の停止は、メール内の​通知設定​​でお手続きいただけます。

その場合、Altium Designerビューワーの無償ライセンス(有効期間6か月)をダウンロードできます。

下記のフォームに入力してライセンスをリクエストしてください。

プライバシーポリシーに同意の上、[ダウンロード]をクリックしてください。ご登録いただきましたメールアドレスにメールマガジンが送信されます。メール配信の停止は、メール内の​通知設定​​でお手続きいただけます。

素晴らしいですね。アルティウムではモノづくりに最適なプログラムを提供しています。

Upverterは、コミュニティ主導型の無償プラットフォームで、お客様のような作り手の要求に合わせて設計されています。

試してみる場合、こちらをクリック してください。

弊社の営業担当より詳細情報をご案内しますので、アルティウムジャパン までお問い合わせください。.
Copyright © 2019 Altium Limited

その場合、Altium Designerビューワーの無償ライセンス(有効期間6か月)をダウンロードできます。

下記のフォームに入力してライセンスをリクエストしてください。

プライバシーポリシーに同意の上、[ダウンロード]をクリックしてください。ご登録いただきましたメールアドレスにメールマガジンが送信されます。メール配信の停止は、メール内の​通知設定​​でお手続きいただけます。