Altium NEXUS Documentation

Design Variants

Modified by Phil Loughhead on May 23, 2019

Concept image of three variants of a Smart Watch

When a product needs to be designed and produced as a number of variations of that product, say where each has different options or capabilities, the ability to implement Design Variants avoids the need to create a unique version of the design for each variation.

In practice, a Design Variant uses the same base design, but the PCB assembly is loaded with the set of components specified by the variation. A variation may then be nominated when generating the design’s manufacturing output (BOM, P&P, Assembly drawings, etc), which will in turn determine how the product is assembled.

The ability to create variations of the same base design adds significant flexibility to how PCB projects are created in Altium NEXUS. Using Variants, you can define any number of variations of the board design, where each component may be configured as:

  • Fitted to the board.
  • Not fitted to the board.
  • Fitted to the board, but with modified component parameters, such as its value.
  • A completely different component, as an alternative replacement part.

Design Variants that use any of these types of variations are all referred to as Assembly Variants, as they only impact on the assembly process – in this case, all variants share the same fabricated bare board.

Altium NEXUS also supports variations to component overlay information on the PCB, such as changing a component’s Comment for example. Such a variation requires the production of two overlay screens, which results in the manufacture of two different bare boards. This type of variant is referred to as a Fabrication Variant.

Design Variants are managed, created and edited in Altium NEXUS's Variant Management dialog, which is accessed from the Projects » Variants option on the main menu.

Logical and Physical Components

It is helpful to understand that there are essentially two types of components in Altium NEXUS; logical components and physical components. The distinction is that components placed on the schematic sheet are logical components, where each is a conceptual entity that represents the physical component that is ultimately mounted on the assembled PCB.

While this one-to-one, logical-to-physical model works well for a simple design, it cannot support some of Altium NEXUS's more powerful features. Examples of this are multi-channel designs, where a section of circuitry is 'stamped out' as many times as required, and variants, where a single design can be implemented with different components fitted to each variation of the board design. Such features require the ability for one logical component to represent multiple physical components.

Altium NEXUS delivers this one-to-many capability through its compiler technology. When the logical design is compiled, each physical component is instantiated in memory, ready for transfer to the board design workspace.

To cater for situations where access to the physical components is required at a schematic level, such as when defining design variations, the physical design is also made available in the schematic editor through tabs located at the bottom of the schematic sheet. Here, the left-most Editor tab selects the (normal) captured logical design, and the other 'compiled' tabs represent the equivalent physical design as it will be transferred to the PCB design workspace – note that the schematic under a compiled tab is read-only.

Working in the physical design view of the Schematic editor, with a specific variant The schematic editor's physical design view. The dim level for the uneditable objects is set in the Schematic – Compiler page of the Preferences dialog.

To examine design variations, you must compile the design; select the required variant in the Projects panel; and switch to the compiled tab of the schematic. The compiled tab displays a different Active Bar at the top of the workspace, which includes variant-specific buttons. These buttons are only available when a variant is selected in the Projects panel.

Note that when you switch to a compiled tab the available menu entries will change, reflecting the commands that can be run when you are viewing the physical design. Click on the logical design tab at the bottom of the schematic sheet to return to the standard editing menus.

Types of Variations

The Variants feature, as the name implies, creates variations of the original, or ‘base’, PCB design. Once this base design has been established, Variants are established in the variant manager by configuring the board components to be: Fitted; Fitted with varied parameters; Not Fitted; or to use an Alternate Part.

Fitted

'Fitted' is the default state of a component before any variations are applied – if it is Fitted, then it is not varied. All components default to Fitted when a new variation is created in the Variant Management dialog (see below), which represents a Fitted component state as an empty cell.

Fitted with Varied Parameter(s)

The variant definition process allows a component to have any of its parameters varied. Modifying the value of a parameter is a local variation and will only affect the output documentation – the original schematic, and the component whose parameter is being varied, are not modified in any way. In the image below, C8 has the Value parameter varied, and this variation is indicated by the italic font used to display its value string.

Not Fitted

When a component is set to Not Fitted it still exists on the schematic and will be transferred to the PCB (so the footprint can be placed), but it is removed from the appropriate output documentation, such as the BOM. The way in which Not Fitted components are presented in the documentation can be configured, for example, set as marked with a cross on the schematic and in PCB drawing outputs – see the Variant Options dialog, accessed from the Drawing Style button in the Variant Management dialog.

  Variants, example of when parts are not fitted, or have a varied parameter
With the selected variation (BGA); C4 and C6 are fitted, C5 and C7 are not fitted, and C8 is fitted, but with a varied parameter value.

Alternate Part

A variation can also be set to an entirely different component, as an Alternate Part. When the compiled tab is selected in the schematic editor, the alternate part will be shown when changing between Variants. For this type of variation the alternate part must share the same set of schematic pins, placed in the same locations, as the base part. This is an essential requirement to ensure that the connectivity remains valid when the design is compiled. Hover the cursor over the image below to show the alternate parts for R3 and Q1 in the TSOP variant.

Variants, example of an alternate part
Q1 is an NPN transistor in the BGA variant, and a JFET in the TSOP variant (hover the mouse over the image to show the TSOP) – note that the same pins are used in each case.

There are two ways an Alternate Part is handled on the PCB:

  • If the footprint is the same – if the chosen Alternate Part has the same footprint name as the base part, then only one instance of that footprint will be transferred to the PCB. As multiple footprints can be assigned to a component, you should ensure that the correct footprint is selected in the Variant Management dialog for each variant.
  • If the footprint changes – if the chosen Alternate Part has a different footprint name from the base part, then both footprints are transferred to the PCB. You must then decide how to position the two footprints on the PCB. Note that both footprints will have the same designator, as only one or the other component is ever fitted. The animation below shows how this situation could be handled when one variant has BGA SRAM, and the other variant has TSOP SRAM.

Changing the Type of Component

The ability to select an alternate part is not restricted to choosing the same type of component, so you can, for example, have a base component that is a resistor, then define an alternate part that is a capacitor. It is important to be aware of the consequences of this type of alternate part:

  • Designator – there is only one designator for each logical, base component, and it is this designator that is used for all variants. If a resistor is swapped for a capacitor for example, you might want to consider using a special designator prefix to indicate this, such as R_C, or R-C.
  • Pins – the alternate component must have the same number of pins as the base component, and these pins must be in the same location and of the same electrical type. A warning will appear if these conditions are not met.

Multi-channel Designs

Main article: Multi-Sheet and Multi-Channel Design

Multi-channel design allows the designer to nominate a single schematic sheet, or a tree of sheets, to be repeated – effectively stamping out this section of the design multiple times. Manual copying and pasting is not required since the software manages the stamping-out process, while the designer simply defines the annotation method used to identify the repeated components.

In Altium NEXUS multi-channel designs, the ability to replace a base component with a completely different component is supported for a selected variant.

Demonstration video, two assembly variations of the same boardIn the animation the BGA variant has two SRAM fitted, while the TSOP variant has four SRAM fitted. This is achieved by Not Fitting one of the two memory channels in the BGA variant.

In terms of channels:

  • A variant can have components varied across all channels, which includes the variations of; components Fitted/Not Fitted, specific component parameters varied, or Alternate Parts chosen.
  • For a specific channel in a multi-channel design, components may be varied as; Fitted/Not Fitted, or with varied parameters.

Supported Variations Summary

Variation Type Applied to all Channels Within a Specific Channel
Fitted/Not Fitted Supported Supported
Varied Parameters Supported Supported
Alternate Part Supported Not Supported

The basic rule is that if you choose to use an Alternate Part, it must be used in all channels.

Creating and Configuring a Variant

Variants are created and configured in the Variant Management dialog. To open the dialog, select Variants from the Project menu (shortcut: C, V).

The dialog has two main regions:

  • The upper Components for project region, which lists all of the components in the base design, and if applicable, columns for the applied Variants.
  • The lower Component Parameters region, which details all of the parameters of the component(s) currently selected in the upper region, and if applicable, columns for the applied Variants.

Variant Management dialog, no variants defined
Variants are created and configured in the Variant Management dialog.

Double-click on a component in the Variant Management dialog to jump to that component on the schematic, or select Cross Probe from the right-click context menu.

Creating a New Variant

Click the Add Variant button button in the Variant Management dialog to create a new variant of the base design. The Edit Project Variant dialog will open, enter a name for the variant in the Description field and click OK. The other options in this dialog are discussed in more detail later.

The Add Variant button includes a dropdown menu that provides access to the Clone Selected Variant command (available when an existing Variant is selected). Cloning is a quick and easy way to define a number of variants that are very similar.

An additional column will then appear on the right of the Variant Management dialog, with the new Variant name as the column title. All the cells will be empty, where an empty cell indicates that this component is Fitted and unchanged from the base design. The components can now be configured for the new variant. The image below shows a project that has had two variants created, BGA and TSOP.

Variant Management dialog, two variants defined
Highlighted region 1 in the image details the components in the base design, region 2 details the components in the BGA variant and region 3 details the components in the TSOP variant.

To make a variant the active selection, click its variant name in the column header, or click in any of that variant's cells.

The Variant Management dialog includes a number of interface features that assist the display of useful information. These are configured via the right-click context menu.

Right-click context menu, Variant Management dialog

Useful commands include:

  • Columns:
    • Hierarchy Path column – shows the location of the component in the design hierarchy.
    • Original Library Link column – details where the base component was sourced from.
  • Set Selected As - submenu used to choose the type of variation (Fitted, Not Fitted, Alternate). Can be used instead of clicking on the Ellipsis control used to configure a variation control in the component cell. Only available when you right-click on a Variant's component cell. 
  • Only Show Varied Parameters - only display components that have some form of variation applied, in the Variant Management dialog.
  • Filter - submenu that gives control of which types of variations are displayed in the Variant Management dialog (Varied Parameters, Not Fitted, Alternate). Works well in combination with the Only Show Varied Parameters command.

Varied parameters – a parameter that is varied from the base design is shown in bold in the Variant Management dialog, making it easy to visually identify.

Defining Component Variations

Once the Variant itself has been created, the state of each component is ready to be varied. This can be done by clicking the component cell in the variant column to reveal the Ellipsis control used to configure a variation control, or by right-clicking to access the context menu Set Selected As sub-menu.

The Ellipsis control used to configure a variation control opens the Edit Component Variation dialog which (along with the  Set Selected As sub-menu) offers three choices:

  • Fitted – The original component as used in the base design is also fitted/used in this variant of that design. For a newly added variant, all components are fitted by default, and the cells for these fitted components are empty. Note that individual parameters can also be varied for a fitted component, by simply typing in a new parameter value in the dialog's Parameters region for that Variant.
  • Not Fitted – The original component as used in the base design is not fitted/used in this variant of that design. For a Not Fitted component status, the cell displays the text Not Fitted and the dialog's lower Parameters region will be blank.
  • Alternate Part – This option allows a different (alternate) part to be selected. Once that part is chosen, the cell displays the alternate part's Library Link. The lower Component Parameters region of the dialog will display all of the parameters in the alternate part.

If the Ellipsis control used to configure a variation control is used to open the Edit Component Variation dialog, the dialog will include controls to switch between Fitted, Not Fitted, or Alternate Part. If the right-click Set Selected As sub-menu is used to open the dialog these choices are not included, as that choice is made in the sub-menu instead.

Standard Windows multi-select techniques are supported. Use these to select and configure multiple components simultaneously.

Choosing an Alternate Part

When the Alternate Part option is selected in the Edit Component Variation dialog, the dialog expands to include controls used to browse and locate the required alternate part component. All of Altium NEXUS's component storage models are supported, such as independent libraries, database libraries, as well as server-based components (as shown in the example below).

After selecting an alternate part, the software checks for pin-compatibility between the selected alternate component and the original base design component. To be pin-compatible, the alternate must have the same number of pins as the original component, and those pins must be identical in their location and electrical type – the graphical primitives used in the symbols for the two components are not required to match.

If the software detects that the alternate component is not pin-compatible, a Confirm dialog must be dismissed before the replacement is accepted. In this case you need to be mindful of the potential impact on the wiring, and that an error violation may be encountered when performing a subsequent compilation of the design.

Variant Management, configuring an Alternate Part variation
The example of an Alternate Part variation.

The newly applied alternative component can be checked back in the editor workspace. In the applicable schematic sheet for that component, switch to the compiled tab view and then select the required variant in the Variants section of the project, in the Projects panel.

The Schematic Editor will use the symbol graphics for the alternate component, however if the component is pin-compatible and graphically similar there may be little noticeable change.

To help make it easy to visually identify varied components, the color and font of varied parameters (such as the component comment string), can also be varied. This is configured in the Variant Options dialog – click the Drawing Style button in the Variant Management dialog to open the dialog. Note the green italic font used for the alternate component in the animation below .

Demonstration video, displaying parameter variationsGraphically identifying the varied component - in this example both variants use the same component symbol, but in the BGA variant uses a different size SRAM.

If an alternate component is not already used in some part of the design, the symbol graphics for the alternate component are stored in the project folder as a dedicated file type: [ProjectName].PrjPcbVariants. Using the .PrjPcbVariants file keeps the project independent from the source libraries that were used to create the design. Note that Parameters changes for the alternate components defined in the Variant Management dialog are saved in the project file itself.

Symbol Display Mode

If a base component uses a graphical display mode other than the default Normal Mode, and it also has an alternate component defined in a variant, then the alternate component will attempt to use the same graphical display mode. Conversely, if the alternate component does not include this graphical display mode, then the Normal mode is used.

Part view Modes are defined in the Schematic Library Editor with the Component Display Mode commands, and are selected for a placed component in the Graphical section of the Properties panel, as shown below. In this example the base part symbol uses Mode, Alternate 1.

Schematic component properties, selecting an Alternate graphical mode
An Alternate Part will attempt to use the same graphical display mode number as the base part.

Altium NEXUS supports several ways of storing and working with components, including the use of a DBLink file with the project. A DBLink file is an interface between the components on the schematic and a company database.

Rather than just creating a reference from each component to a specific database record (as is typically done when you place a component from a DBLib-type library), the DBLink model relies on the designer initiating a query action based on one or more component parameters. The software then searches the database for a record with fields that contain matching values, and when a match occurs, other field values from that record (such as the Part Number) can be returned to the Altium NEXUS component. The component parameter-to-database field mapping is defined in the DBLink document, as is the target database.

Learn more about Working with Database Libraries

In a design that does not use Variants, the query action is performed via the Update Parameters from Database command, and can also be performed during BOM generation by enabling the Include Parameters from Database option (see below), to extract BOM-specific component data, such as price.

For a design that includes Variants, the parameters used to query the database are varied in the Variant Management dialog. Since those parameter values only exist in the Variant Management dialog, the Update Parameters from Database command is not used to retrieve database information – instead the parameters are extracted from the database when the BOM is being generated.

Display of Variant Manager data

The Variant Management dialog includes features to help control the amount of data displayed, which is particularly useful when working on a large design.

  • To remove columns that are not of interest, right-click in upper part of the dialog and use the Columns option in the context menu to toggle the visibility of any column.
  • To display only those components being varied, right-click in the upper part of the dialog and select Only Show Varied Components option from the context menu.
  • When the the Only Show Varied Components mode has been selected, right-click again and configure the Filter options. In the image shown below, the Filter has been configured to display only those components that use Alternate Parts.
  • To change the order of the listed Variants, select and drag a variant column heading to a new location. Use this in combination with the Fit to Width checkbox to position and size the variant of interest.

Variant Management dialog, filtering to only show Alternate Part variations
The Variant Management dialog, with columns hidden and a filter applied to only show components that use an Alternate Part.

Display of Variants in design documents

The way in which varied components are presented in Schematic design documents (and PCB outputs) is configured in the Variant Options dialog. Those settings subsequently affect how the component variations are presented in printed or PDF outputs, and in PCB drawing type outputs such as Assembly drawings. To access the Variant Options dialog, click the Drawing Style button at the bottom of the Variant Management dialog, after selecting a cell in the relevant variant column.

Variant Options dialog, configuring the display of changed parametersUse the Variant Options dialog to configure how variants are presented on the schematic and in PCB drawing outputs.

Resetting and Updating Variant Data

Design variations setup in the Variant Management dialog are ultimately saved in the project file. This includes the Not Fitted state, local parameter variations to a Fitted component, and the parameter values of Alternate Parts. The actual Alternate Parts are stored in a [ProjectName].PrjPcbVariants file. The Variant Management dialog includes commands for resetting parameters and updating components, which helps to ensure that they are in sync with the source component libraries.

Updating a Varied Parameter

Parameters modified locally in the Variant Management dialog can be restored to their original value by right-clicking on the modified parameter (shown in bold) in the Variant Parameter list, and then choosing Reset Selected from the context menu – as shown below. Note that multiple parameters can be selected at once then reset in a single action, or Reset All used to reset all parameters for that component.

Variant Management, reseting a changed parameter
Modified parameter(s) can have their value(s) restored using the Reset Selected command.

Updating an Alternate Part Parameter

If a library component that is used as an Alternate Part has had parameters changed in the library, then you to can bring those changes directly into the variant definitions in your project by right-clicking in that Variant's Parameter list and selecting Update Values from Library from the menu (as shown below). Note that this updates the parameters, if you need to update the graphic, use the technique described below.

Variant Management, updating component parameter values from a library, running the command
If an Alternate Part component has been modified in the library, use the Update Values from Library command to refresh the copy used in the project.

Following the Update Values from Library command, browse to and locate the component in the source library or Managed Component Server (via the Browse Libraries dialog or the Server content Explorer) and click OK to open the Update Project Variants From Library dialog. Select/deselect the Parameters from Library Component and Variants to Update, then click OK to complete the update process.

Variant Management, updating component parameter values from a library, selecting the required parameters
Updating a varied component from the source library. Here you configure which parameters are updated, and to which variant the updates are applied.

All parameters are listed on the left of the Update Project Variants From Library dialog – if required, any parameter can be deselected to exclude it from the update process. On the right of the dialog, the target Project Variant can be changed (Project Variant To Update) – this will default to select the Variant that was selected when the Update Values from Library command was activated.

Note that this parameter update process brings parameter values directly from the library into the Variant Management dialog, and does not update the copy of the component that is stored in the [ProjectName].PrjPcbVariants file. If you later perform one of the Reset commands to reset parameter values, which retrieves values from the PrjPcbVariants file, it may revert a parameter value to an earlier value and overwrite any current changes. To ensure that this cannot happen, update the component in the PrjPcbVariants file using the process described below.

Completely updating an Alternate Part

If the source component for an Alternate Part has been edited in its library, it can be updated in the design by running the Update from Library Wizard.

Launched from the Tools menu in the Schematic Editor, the Wizard includes an option to Include Variants. When this option is enabled, the component list will expand to include any components that have been used as Alternate Parts. Check the components in the list to be updated, and then complete the Wizard to update the required parts from the source.

Variant Management, completely updating an alternate part from a library
To fully update an Alternate Part, including its graphic, enable the Include Variants checkbox and enable the part to be updated.

If there have been changes made to library components used in the base design, these are also updated in the usual way:

  • via the Schematic editor Tools » Update from Library command
  • or the Schematic Library editor Tools » Update Schematics command.

Change multiple Parameters for multiple Components

The Variant Management dialog supports multi-select, which means that any number of components can be selected simultaneously in the upper (Component) part of the dialog, and then updates performed on any number of parameters selected in the lower (Parameters) part of the dialog. The dialog also offers Filters (via the right-click context menu), to further refine selection and the displayed data.

By way of example, to reset the manually-varied parameters for all components, in all variants:

  1. In the upper (Component) part of the dialog, use the Only Show Varied Components right-click menu option in combination with the right-click Filter options to only Show Fitted with Varied Parameters. The component list should now display only those components that have manually varied parameters.
  2. Right-click in the component list and choose Select All from the context menu. All components currently displayed in the upper part of the dialog will be selected.
  3. Then right-click in the lower (Parameters) part of the dialog and choose Select All from that context menu. All parameters for all components will now be selected. Note that the Select Column command could have been chosen instead, which would allow an action (such as Reset) to be applied to the components in a specific Variant (column).
  4. Right-click again in the parameters list and choose Reset Selected from the context menu. Hover the cursor over the image below to show steps 2, 3 and 4.

Variant Management dialog, filtering to show varied parameters, then resetting varied parameters
Resetting all manually varied parameters, for all components, in all variants. Hover the cursor over the image to show steps 2, 3 and 4.

If you have been experimenting with the Filter options and have applied different filters, you may need to reset the filter before attempting another update. To do this, disable the Only Show Varied Components option to clear the filter system, then re-apply it and clear the Filter options as required.

Working with Variant Parameters

Altium NEXUS supports Parameters at various levels of a project. For example, document-level parameters can be added to each schematic sheet in the Parameters tab of the Schematic editor Properties panel (available when nothing is selected). Project-level parameters can also be added to a project in the Parameters tab of the Options for Project dialog (Project » Options). Further to this, parameters can also be added to a Variant via the Edit Project Variant dialog. In the Variant Management dialog, select the variant column and click the Edit Variant button to open this dialog.

Parameters included at various level in a project exist in a hierarchy, which means you can in fact create a parameter with the same name at different levels in the project, where each has a different value. Altium NEXUS resolves this situation using priorities, in the following way:

  1. Variant (highest priority)
  2. Schematic document
  3. Project

This arrangement means that the parameter value defined in a schematic document overrides the value defined in the Project options, and the parameter's value defined in a Variant overrides the value defined in the schematic document. Note that schematic-level parameters are not available on the PCB or in the BOM – for these types of output, project or variant parameters should be used.

In the images below, a Parameter called ProjectTitle has been defined for the project, and also for each variant. The animation shows the behavior on the PCB as the Variants selector is used to show the base design, then each variant.

Variant parameters, where to define them and understanding their order of precedence
A ProjectTitle parameter added to the project (via the Options for Project dialog) has also been added to each design Variant, but with a different Value in each case.

Note the Allow variation of fabrication outputs option in the Edit Project Variation dialog; enable this when the project must support varied fabrication detail, such as variant-specific silkscreen generation.

Demonstration video, variant parameters A special string .ProjectTitle has been placed on the PCB overlay, which is automatically linked to project and variant parameters of the same name.

Working With Variants in the Schematic Editor

Altium NEXUS's schematic editor includes a range of features that provide full visibility of component variations during the schematic capture process, as described below.

Examine Varied Components

As previously outlined, the actions to examine variant detail on the schematic are:

  • If not already compiled, recompile the project.
  • Select the required variant in the Variants section in the Projects panel.
  • Select the named compiled tab located at the bottom of the schematic sheet.
  • Components varied on the sheet will then be displayed, in the style configured in the Variant Options dialog.

Examining the varied components on the schematic
Select the variant and then the compiled sheet to view the components that are varied on a schematic sheet (identified by their varied parameters).

Selecting Variant Components from the Schematic

As opposed to scrolling through and selecting components from the list in the Variant Management dialog, it can be more convenient to make specific selections directly on the schematic. To do so, select the component(s) on the sheet, then right-click and select Part Actions » Variants from the context menu.

Modifying the variant properties of components selected on the schematic
Here, two components (LEDs) have been selected on the compiled tab of the schematic for the BGA variant – the right-click Variant command will open just those components in the Variant Management dialog.

Note that the right-click Part Actions sub-menu also includes commands to Toggle Fitted/Not Fitted, and to Choose Alternate Part.

The Variants command on the right-click menu (above) will open the Variant Management dialog, where only the selected components will be listed. The required variations can then be performed as usual, and OK clicked to apply those variations to the design.

Variant Management dialog, opened to display only the components selected on the schematic
Here, the Variant Management dialog has been opened from two selected components on the schematic sheet, and therefore includes just those two (LED) components.

This selection technique can be used when first setting up component variations, or when an existing component variation needs to be modified. In addition to only presenting the selected component(s) in the Variant Management dialog, if a variant is currently selected in the Variants toolbar (say BGA) then only that variant will be presented, as shown above – irrespective of how many variants might actually be defined for the project.

Graphically Editing Component Variations

Component Variants can also be created and edited by working directly in the schematic at a symbol level. Note that the Schematic Editor must be in compiled variant view (as selected by the lower tab), and the required variant selected in the Projects panel.

A command is provided to quickly toggle the Fitted or Not Fitted state of a component for the variant design. Launch this command using the Toggle Fitted State button button on the Variant Active Bar (visible when a variant is selected in the Projects panel). This will change the cursor to a cross-hair, where clicking on a component will cause it to toggle between the Fitted and Not Fitted states – the related entry in the Variants Manager dialog reflects any changes that are made.

The component’s fitted state will be graphically indicated as defined in the Variant Options dialog (accessed from the Drawing Style button, click to open the Variant Options dialog button in the Variants Management dialog).

Graphically editing component variationsToggle a specific component's fitted state directly on the schematic.

Graphical Parameter Editing

Changes can be made directly to a displayed component variant parameter by selecting the parameter text, and then clicking the text a second time to enable editing mode. Any changes made will be adopted by that component’s entry in the Variants Manager dialog.

Note that a component’s parameter visibility is configured in the component’s Properties for Schematic Component dialog when the schematic is in standard Edit mode (as opposed to the compiled document view).

Graphically editing parameter variationsSelect a parameter, then click a second time to enable direct editing.

A variant parameter may also be directly edited in the Parameter Variation dialog, which is opened by double clicking on the parameter text. As usual, this function is only available when in the compiled schematic view, and any changes made will also register in the Variant Manager dialog.

Editing parameter variations in the Parameter Variation dialogWhen in the compiled view, double click on a variant parameter access editing in the Parameter Variation dialog.

Graphical Designator Editing

To change a component's physical designator, directly within the compiled document view of a source schematic, simply click once on the designator to focus it, then click again to begin editing. Note that in-place designator editing is only possible when the Enable In-Place Editing option is enabled in the Schematic – General page of the Preferences dialog ( Click the Gear icon to open the Preferences dialog ).

Graphically editing a component designatorSelect the designator, then click a second time to enable direct editing.

In-place editing of designators is essentially a graphical shortcut to defining a Locked Physical Designator, which can also be defined in the Physical Component Properties dialog (double click on the component) or Designator Annotation dialog (double click on the designator).

The Physical Component Properties dialog gives access to designator editing and annotation options for variants  The Designator Annotation dialog also gives access to designator editing and annotation options for variantsBoth the associated component and designator dialogs provide access to designator editing and annotation options.

In terms of component annotation, these dialogs offer the same content. Use the Annotate options to specify either:

  • A custom designator, using the Lock Physical Designator option and entering the new designator. This is the option that is set when graphically editing a designator, as outlined above.
  • A designator generated using a specified Naming Scheme. In this case, enable the Apply Naming Scheme option and use the Annotate Options button to access the Board Level Annotation Options dialog. From here, you can either choose a predefined naming scheme, or specify your own, custom scheme. The Physical designator will be generated based on the logical designator information and the specified naming scheme.

Refer to Annotating the Components for detailed information on Annotation and Naming Schemes.

The options defined in the Board Level Annotation Options dialog, when defining a naming scheme, are global to the project and override the naming scheme defined on the Multi-Channel tab of the Options for Project dialog (Project » Project Options).

Working with Variants in the PCB Editor

In Altium NEXUS's PCB editor all of the component footprints, for all variants, are always shown. This is necessary because all footprints, for all assembly variations, must be fabricated as part of the bare board. It is the loading of components during the assembly process that then determines which variant is being built.

Because all footprints are always visible on the PCB, it can be difficult to know which components belong to which variant. Like the schematic editor, the PCB editor includes a Variants toolbar which can be used to switch between variants. However the only visible clue to tell if a particular component is fitted or not fitted in that variant, is if the component includes a 3D Body model – the body will appear/disappear to indicate whether the component is fitted or not fitted. This visual behavior is much more easily sen when the PCB is in 3D Layout Mode, as demonstrated in the animated image below.

Alternate Part PCB design

There is only one type of variation that affects component placement in the PCB design process – when an Alternate Part is specified, and that Alternate Part uses a different footprint from the base design. In this situation two footprints must be placed on the board.

There are different ways that these two footprints might be positioned, such as:

  • The footprints are placed next to one another.
  • The smaller footprint is placed inside the larger footprint, as shown in the animation below, where an SRAM component can is available in either a TSOP package or a BGA package.
  • The footprints are exactly stacked (placed one on top of the other). For example, when the footprints are identical but they have different 3D models, and therefore must have different footprint names. This is also shown in the image below, where two LED footprints are stacked for both DS1 and DS2.

Demonstration video, how varied components, that use different footprints, can be placed on the board A simple animation showing how Alternate Parts that use different footprints can be positioned on the board.

PCB components that share the same footprint but different 3D models, can be stacked on the board
The two instances of LED DS1 use exactly the same footprint pattern (but have different 3D models in each variant) and can therefore be stacked.

Altium NEXUS includes design rule checking support for stacked alternate components, so no additional design rules are required. The alternate parts share the same component UID, however the software is aware that they are alternate parts and can prevent the rules engine flagging stacked or overlapping alternate-part footprints.

Variant Output Generation

Assembly variants affect all output documentation that include detail about the purchase or loading of components. This includes:

  • Bill Of Materials (using ActiveBOM or directly via the Report Manager)
  • Schematic Prints
  • PCB Prints
  • PCB 3D Prints
  • PCB 3D Videos
  • Assembly Drawings
  • Pick and Place files
  • Test Point Report

Fabrication variants also affect the following outputs:

  • Gerber overlay layers
  • ODB++ overlay layers

Selecting the Variant for Output

If you are running a command from the schematic editor or PCB editor, such as a schematic printout or Gerber files generated directly from the PCB editor, the output will be generated based on the variant currently selected in the Projects panel.

Select the variant in the Projects panel before generating output from the schematic or PCB editor menusOutput generated directly from the schematic or PCB editor menus is based on the variant selected in the Projects panel.

If the output is generated via another interface, for example the Report Manager or an OutputJob, it will include a Variant selector.

Output interfaces, such as the Report Manager or the OutputJob editor, include variant selection featuresRight-click in the Report Manager to switch from one variant to another.

Working with Variants in the OutputJob Editor

Main article: Preparing Multiple Outputs in an OutputJob

There are two approaches to configuring an OutputJob file to support variants:

  • Choose a single variant for the whole OutputJob file - use this when you prefer to use a separate OutputJob for each variant, or
  • Choose a different variant for each output - use this when you have a single OutputJob configured to generate outputs for multiple variants.

The option is selected in the Variant Choice region of the OutputJob editor. When the second option is enabled the required variant must be selected for each output that supports Variant-type output, as shown in the image below.

In the OutputJob editor you can select a variant for all jobs in the file, or individually select the variant for each job
An OutputJob where the Choose a different variant option is selected, and outputs for both variants have been set up for each Job in the OutputJob file.

If the first 'blanket' approach is used, then every output file that is variant-specific will automatically be configured for that variant. The advantage of this option is that the variant does not need to be specifically selected, whereas the disadvantage is that an OutputJob file is required for each variant in the design.

If Fabrication Variants need to be generated from the design, enable the Allow variation of fabrication outputs option in the Edit Project Variant dialog (see Working with Variant Parameters, above). If an output job has a variant nominated for a fabrication output, and that variant does not have the option enabled, the job's variant name will be displayed in red.

Note that the red variant name is simply a warning flag, and the variant-specific output files will still be generated. If a fabrication variant is not required, ensure that the Variant dropdown menu for that output job is set to [No Variations] – in this mode the output will be generated from the base design.

See Preparing Multiple Outputs in an OutputJob for more information on Variants in Output Jobs

Working with Variants in ActiveBOM

Main article: BOM Management with ActiveBOM

Although a BOM can be generated directly from the schematic or from an OutputJob file, the recommended approach is to use ActiveBOM. Beyond the components fitted to the board, ActiveBOM allows additional components and BOM-specific data to be added directly in ActiveBOM, for example; yet-to-be-detailed parts, fasteners, the blank board, or the mounting glue. Custom columns can also be added, including a specific Line number column, which supports both auto and manual numbering, with full copy/paste support.

For design components that include manufacturer information, ActiveBOM can use the Altium Cloud Services to access detailed and up-to-date supply chain information. This support extends beyond components placed from a managed content server, also supporting Supplier-linked parts, as well as parts that already have suitable manufacturer details in their parameters.

ActiveBOM supports variants in the following ways:

  • Display the BOM for a specific variant in Base view mode or Flat view mode
  • Option to include the Not Fitted items in the BOM Items list
  • Display a consolidated list of all parts used in all variants, in Consolidated view mode
  • Define manual solutions for both base components and varied components

ActiveBOM includes a consolidated view mode, use this to include all parts used in all variants, into a single BOMActiveBOM includes a consolidated view mode, allowing a single bom to detail the parts in all variants.

Learn more about working with variants in ActiveBOM

Variant Errors

Variant settings are stored in the project file (*.PrjPcb), and this data is read, analyzed and loaded into the Variant Management dialog when that dialog is opened. If issues are detected when the data loads, such as any mismatches between component designators or component UIDs, an Information dialog will open to outline the problem.

Information dialog, detailing detected variant errors
Resolve designator and UID mismatches before continuing with the design process.

Component UID mismatches are automatically resolved, and these corrections will be retained when the project is saved. Duplicate designators must be corrected at the schematic level. To resolve these, recompile the project and check the Messages panel for warning/error details.

Found an issue with this document? Highlight the area, then use Ctrl+Enter to report it.

お問合せ

お近くの営業所にお問合せください。

You are reporting an issue with the following selected text
and/or image within the active document:
Altium Designer 無償評価版
Altium Designer 無償評価版
Altium Designerを使用していますか?

弊社の営業担当より詳細情報をご案内しますので、アルティウムジャパン までお問い合わせください。.
Copyright © 2019 Altium Limited

評価版ライセンスが必要な理由を下記から選択してください。

弊社の営業担当より詳細情報をご案内しますので、アルティウムジャパン までお問い合わせください。.
Copyright © 2019 Altium Limited

その場合、評価版ライセンスは不要です。

ボタンをクリックして、最新のAltium Designerインストーラをダウンロードしてください。

Altium Designerインストーラをダウンロードする

弊社の営業担当より詳細情報をご案内しますので、アルティウムジャパン までお問い合わせください。.
Copyright © 2019 Altium Limited

Altium Designerの新規ライセンスのお見積もりをご希望の場合、下記のフォームに入力してください。

プライバシーポリシーに同意の上、[ダウンロード]をクリックしてください。ご登録いただきましたメールアドレスにメールマガジンが送信されます。メール配信の停止は、メール内の​通知設定​​でお手続きいただけます。

Altium Designerサブスクリプションをご利用中の場合、評価版ライセンスは不要です。

お客様がAltium Designerサブスクリプションの有効なメンバーではない場合、下記のフォームに入力して無償評価版をダウンロードしてください。

プライバシーポリシーに同意の上、[ダウンロード]をクリックしてください。ご登録いただきましたメールアドレスにメールマガジンが送信されます。メール配信の停止は、メール内の​通知設定​​でお手続きいただけます。

Altium Designerを評価する理由を下記から選択してください。

弊社の営業担当より詳細情報をご案内しますので、アルティウムジャパン までお問い合わせください。.
Copyright © 2019 Altium Limited

無償評価版を使用するには、下記のフォームに入力してください。

プライバシーポリシーに同意の上、[ダウンロード]をクリックしてください。ご登録いただきましたメールアドレスにメールマガジンが送信されます。メール配信の停止は、メール内の​通知設定​​でお手続きいただけます。

アルティウムでは、学生の方や教育機関を対象とした特別価格ライセンスを提供しています。アカデミックライセンスの詳細については、こちらをクリック してください。.

また、下記のフォームに入力して無償評価版をリクエストしていただくことも可能です。

プライバシーポリシーに同意の上、[ダウンロード]をクリックしてください。ご登録いただきましたメールアドレスにメールマガジンが送信されます。メール配信の停止は、メール内の​通知設定​​でお手続きいただけます。

その場合、Altium Designerビューワーの無償ライセンス(有効期間6か月)をダウンロードできます。

下記のフォームに入力してライセンスをリクエストしてください。

プライバシーポリシーに同意の上、[ダウンロード]をクリックしてください。ご登録いただきましたメールアドレスにメールマガジンが送信されます。メール配信の停止は、メール内の​通知設定​​でお手続きいただけます。

素晴らしいですね。アルティウムではモノづくりに最適なプログラムを提供しています。

Upverterは、コミュニティ主導型の無償プラットフォームで、お客様のような作り手の要求に合わせて設計されています。

試してみる場合、こちらをクリック してください。

弊社の営業担当より詳細情報をご案内しますので、アルティウムジャパン までお問い合わせください。.
Copyright © 2019 Altium Limited

その場合、Altium Designerビューワーの無償ライセンス(有効期間6か月)をダウンロードできます。

下記のフォームに入力してライセンスをリクエストしてください。

プライバシーポリシーに同意の上、[ダウンロード]をクリックしてください。ご登録いただきましたメールアドレスにメールマガジンが送信されます。メール配信の停止は、メール内の​通知設定​​でお手続きいただけます。