Altium NEXUS Documentation

Working with a Board Region Object on a PCB in Altium NEXUS

Modified by Shinichi Kawaguchi on Jun 29, 2021

親ページ: PCB Objects

2 つのボードカットアウトを備えた従来のリジッド基板のボードリジョン。

概要

ボードリジョンは、ユーザ定義の PCB 領域であり、固有のレイヤ構成を割り当てることができます。PCB は、単一のボードリジョン (従来のリジッド基板用) 、または複数のボードリジョン (リジッドフレキシブル基板用) で構成することもできます。ボードリジョンの全体的な外縁は、Board Shape を定義します。

Rigid-Flex は積極的に開発しています。Rigid-Flex 2モードへ切り換えるには、Advanced Settings ダイアログ で以下のオプションを有効にします:

  • PCB.RigidFlex2.0基板プランニング モードで Rigid-Flex2 機能が有効になります。以前のバージョンの Altium NEXUS では、このオプションは Legacy.PCB.RigidFlex と呼ばれていたことに注意してください。名称の変更に伴い、動作も変更しました。古いオプションを有効にすると古いモード (Rigid-Flex1.0) が復元され、新しいオプションを有効にすると新しいモード (Rigid-Flex2.0) が有効になります。
  • PCB.RigidFlex.SubstackPlanning - レイヤ構成マネージャで Board ビューが有効になります。

 Rigid-Flex Design の詳細をご覧ください

使用方法

ボードリジョンは、表示モードを 基板プランニングモード (View » Board Planning Mode、またはショートカット 1 を押します) に設定して定義します。

配置

この動画では、選択したオブジェクトからボードシェープを作成し、スライスして 3 つの領域を作成する方法を示しています。
それから、選択したオブジェクトから 3 つのボードリジョンを定義する別の方法を示します。

ボードリジョンは、基板プランニングモード で配置、および変更します:

  1. View » Board Planning Mode を選択して (または、ショートカット 1 を押して) 基板プランニングモード にします。デフォルトの既存のボードリジョンは、緑色の四角形として表示されます。
  2. Place » Board Region を選択して、新しい領域を配置します (または、Active Bar ボタンをクリックします)。
  3. カーソルを置き、クリックしてボードリジョンの開始頂点を決めます。ボードリジョンは、リジョンやポリゴンのような多角形オブジェクトであり、同じ配置プロセスです。
  4. カーソルを移動して、2 番目の頂点を配置します。デフォルトの動作では、クリックするたびに 2 つのエッジを配置でき、それらの間にユーザ定義のコーナー形状を配置します。スペースバーを押してコーナーの方向を切り換えできます。コーナーモードの変更の詳細については、以下の配置モードの項目を参照してください。
  5. 引き続きマウスを移動し、クリックして頂点を配置し、ボードリジョンの全体的な形状を定義するために必要なエッジを作成します。
  6. 最後の頂点を配置した後、右クリック、または Esc キーを押して、ボードシェープの定義を完了します。最後に配置した箇所を始点に接続することによって自動で形状が作成されるため、ボードシェープを手動で完了する必要はありません。
  7. ボードリジョンは、固有に識別するために名称が付けられます。Board Region モードの Properties パネル にある Name 欄に適切な名称を入力します (プロパティをパネルに表示するには、デザインスペースでボードリジョンを選択する必要があります)。
  8. ボードリジョンには、レイヤ構成が割り当てられている必要があります。新しいボードリジョンが作成されると、Board Layer Stack と言う名称のデフォルトのレイヤ構成が割り当てられます。Board Region モードの Properties パネルで、必要なレイヤ構成を割り当てます。レイヤ構成は、レイヤ構成マネージャ で定義し、名称を付けます。
  9. 最終的な PCB に複数のボードリジョンが必要な場合、引き続き追加の領域を定義します。
  • 各リジョンには、Region Name - Layer Stack Name の形式でリジョン名とそれに割り当てられたレイヤ構成の名称を示すラベルが表示されます。ボードリジョンの名称は、Board Region モードの Properties パネルで設定し、レイヤ構成の名称は、レイヤ構成マネージャで設定します。
  • 必要なボードシェープを構築するために、任意の数のボードリジョンを配置できます。Board Regions can overlap, note that this does not define the distance that one region intrudes into its neighbor region, that is defined as part of the layer stack configuration in the Layer Stack Manager.
  • ボードリジョンを削除するには、それを選択してからキーボードの Delete キーを押します。ボードリジョンは、少なくとも 1 つ存在する必要があり、最後のボードリジョンは削除できません。
  • ボードリジョンは描画するだけでなく、プリミティブから作成することもできます。詳細については、このページの Converting between 2D Drawing Primitives and Board Definition Objects の項目を参照してください。
  • ボードリジョンは、3D モードで Create Board Region from 3D Body コマンドを使用して、3D 外形オブジェクトから作成することもできます。
  • ボードリジョンの配置中、カーソルはカーソルスナップ設定によって制約されます。これには、現在のスナップグリッド、スナップに使用できるオブジェクト、ワークスペースガイド、および軸スナップ設定が含まれます。これらの機能を使用して、必要な形状を作成できます。

 Understanding the Snap Behavior の詳細をご覧ください。

配置モード

ボードシェープを再定義する場合、5 つのコーナーモードがあり、そのうちの 4 つにはコーナー方向サブモードもあります。再定義中:

  • Shift+スペースバーを押して、5 つのコーナーモードを切り換えできます。
  • スペースバーを押して、2 つのコーナー方向サブモードを切り換えできます。
  • いずれかのアークコーナーモードの場合は、 キーを押したままにしてアークを縮小するか、 キーを押したままにしてアークを拡大できます。Shiftキーを押しながら押すと、アークのサイズをより大きく変更できます。
  • ショートカットキー 1 を押して、クリックごとに 2 つのエッジを配置するか、クリックごとに 1 つのエッジを配置するかを切り換えできます。2 番目のモードでは、破線のエッジはルックアヘッドセグメントと呼ばれます (以下の最後の画像に示されているように)。
  • Backspace キーを押して、最後の頂点を削除できます。

Shift+スペースバー を押して 5 つのコーナーモードを切り換え、ショートカット 1 を押して 2 つのエッジ、または 1 つのエッジの配置かを切り換えできます。

ボードカットアウト リジョンの作成

基板内部にカットアウトを作成するには、ボードカットアウト リジョンを配置します (Place » Define Board Cutout、またはアクティブバー ボタンをクリックします)。ボードカットアウトもポリゴン オブジェクトであるため、ボードリジョンと同じ配置プロセスです。以下の画像は、2 つのボードカットアウトがあるボードリジョンを示しています。これらは、製造時に基板の穴になります。

ボードリジョンに配置したボードカットアウトは、完成した基板の穴になります。

ボードリジョンのスライス

既存のボードリジョンは、2 つの別々のボードリジョンにスライスできます。リジョンをスライスするには以下を行います (基板プランニングモード で):

  • Design » Slice Board Region コマンドを選択します (または、アクティブバー ボタンをクリックします)。
  • スライスの動作はトラック (または、ポリゴン境界) の配置動作と同じで、5 つのコーナーモードがあります。Shift+スペースバーを押してコーナーモードを切り換え、スペースバーを押してコーナーの方向を切り換えできます。
  • スライスは、ボードリジョンのエッジ、または外側で開始、および終了する必要があります。
  • 右クリックしてスライス コマンドを終了すると Confirm ダイアログが表示され (以下に示すように)、Yes をクリックするとボードリジョンが 2 つのボードリジョンに分割されます。
  • 必要に応じて、ボードリジョンを移動、または再形成し、Properties パネルで適切な NameLayer Stack を割り当てます。

上の動画  は、ボードシェープをスライスして、リジッドフレキシブル設計に必要な 3 つのボードリジョンを作成する方法を示しています。

2D 描画プリミティブと基板定義オブジェクト間の変換

ボードシェープとその形状に必要なボードリジョンを定義するための一般的な方法は、機構 CAD パッケージから描画をインポートすることです。例えば、DWG ファイルの機構的な詳細をインポートして、ボードシェープ、ボードシェープ内のリジョン、およびリジッドフレキシブル設計の場合、フレキシブル領域の折り曲げライン等を定義するラインを mechanical layer に配置できます。

このソフトウェアには、2D 描画プリミティブから基板定義オブジェクト (リジョン、カットアウト、折り曲げライン) を作成するのに役立つ多数のコマンドや、基板定義オブジェクトを描画プリミティブへ変換するコマンドが含まれています。

オブジェクト 選択した 2D 描画プリミティブから 基板デザイン オブジェクトから
ボードリジョン Create Board Region from Selected Objects
( Design » Board Shape サブメニュー)
Explode Region to Free Primitives
ボードカットアウト Create Board Cutout from Selected Primitives Explode Board Cutout to Free Primitives
折り曲げライン Convert Selected Line to Bend Line Explode Bend Line

注釈:

  • 両方向のコマンドは、関連する View モードの Tools » Convert サブメニューで使用できます (Design » Board Shape サブメニューにある Create Board Region from Selected Objects コマンドは除いて)。
  • 2D 描画プリミティブを基板定義オブジェクトに変換するには、ビューを 2D レイアウト モード に切り換えます。
    • コマンドを実行する前に、プリミティブを選択する必要があります。
    • プリミティブは、リジョン、またはカットアウトを作成するために閉じた形状を形成する必要があります。この形状の要件の詳細については、下の警告ボックスを確認してください。
  • 基板定義オブジェクトを 2D 描画オブジェクトへ変換するには、ビューを 基板プランニング モード に切り換えます。
    • これらのコマンドでは、オブジェクトを事前に選択する必要はありませんが、オブジェクトがすでに選択されている場合は、選択したオブジェクトに作用します。
    • 複数のボードリジョンが存在する場合、プリミティブに展開されるとリジョンは消えます。ボードリジョンが 1 つだけの場合、プリミティブが作成され、選択したボードリジョンが残ります (常に、1 つのボードリジョンが存在する必要があります)。
    • 2D 描画オブジェクトは、Board Shape レイヤに作成されます。このレイヤタイプのレイヤが基板に存在しない場合、レイヤタイプが Board Shape に設定されたメカニカルレイヤが追加されます。Mechanical Layer と Layer Type の詳細をご覧ください。

 Board Shape の詳細をご覧ください

ライン (トラック) とアークで構成された外形に基づいて多角形を作成する全てのコマンドは、選択したオブジェクトの中心線をたどって形状を見つけようとします。1 つのトラック/アーク セグメントの終わりの座標が次のトラック/アーク セグメントの座標と正確に一致しない場合、境界識別アルゴリズムは失敗し、失敗した場所を示すメッセージが表示されます。次に、代わりにトレース アルゴリズムを使用することを提案します。トレース アルゴリズムはトラック/アーク オブジェクトの外縁に従うため、形状は中心線から作成されたものとわずかに異なることに注意してください。デザインでこの違いの影響を考慮できる場合にのみ、このオプションを選択してください。

グラフィカル編集

関連するアーティクル: Editing Polygonal Objects

ボードリジョン (および、ボードカットアウト) は多角形オブジェクトであり、他の全ての多角形オブジェクトと同じ方法で形状を変更できます。ポリゴン オブジェクトの編集について覚えておくべき点は以下です:

  • ポリゴンの頂点、またはエッジをクリックしてドラッグする時、sliding、breaking、incurvating の 3 つの再形成モードを利用できます (Shift+スペースバーを押して、ドラッグしながらモードを切り換えできます)。現在のモードは、ステータスバーとヘッドアップ ディスプレイに表示されます。
  • カーソルスナップの動作は、現在のカーソルスナップ設定 (現在のスナップグリッド、スナップのためのオブジェクト、ワークスペース ガイド、軸スナップ設定等) によってコントロールされます。これらの機能を使用して、必要な形状を作成できます。Understanding the Snap Behavior の詳細をご覧ください。

グラフィカルでない編集

グラフィカルでない編集方法は、以下です:

Properties パネル経由の編集

Properties ページ: Board Region Properties

この編集方法では、Board Region ダイアログや Properties パネルを使用して、ボードリジョン オブジェクトのプロパティを変更できます。

  左の Board Region ダイアログと、右の Board Region モードの Properties パネル

配置中に Tab キーを押して、Board Region モードの Properties パネルを表示できます。ボードリジョンが配置されると、全てのオプションが表示されます。

配置後、Board Region ダイアログは以下の方法で表示できます:

  • 配置したボードリジョン オブジェクトをダブルクリックします。
  • ボードリジョン オブジェクトの上にカーソルを置き、右クリックして、メニューから Properties を選択します。

配置後、Board Region モードの Properties パネルは、以下のいずれかの方法で表示できます:

  • Properties パネルがすでにアクティブになっている場合、ボードリジョン オブジェクトを選択します。
  • ボードリジョン オブジェクトを選択した後、デザインスペースの右下にある Panels ボタンから Properties パネルを選択、またはメインメニューから View » Panels » Properties を選択します。

Preferences ダイアログの PCB Editor - General page ページで Double Click Runs Interactive Properties オプションが無効 (デフォルト) の場合、プリミティブをダブルクリックするか、選択したプリミティブを右クリックして Properties を選択すると、ダイアログが表示されます。Double Click Runs Interactive Properties オプションを有効にすると、Properties パネルが表示されます。

ダイアログとパネルのオプションは同じですが、オプションの順序と配置が若干異なる場合があります。

Ctrl+Q を押して、パネルで現在、使用されている測定単位をメートル系 (mm) とインチ系 (mil) 間で切り換えできます。これは、パネルでの測定値の表示にのみ影響し、基板で指定した測定単位は変更されません。これは、編集デザインスペースでオブジェクトが選択されていない場合、Properties パネルの Units 設定で設定します。

Found an issue with this document? Highlight the area, then use Ctrl+Enter to report it.

お問合せ

お近くの営業所にお問合せください。

We're sorry to hear the article wasn't helpful to you.
Could you take a moment to tell us why?
200 characters remaining
You are reporting an issue with the following selected text
and/or image within the active document:
Altium Designer 無償評価版
Altium Designer 無償評価版
Altium Designerを使用していますか?

弊社の営業担当より詳細情報をご案内しますので、アルティウムジャパン までお問い合わせください。.
Copyright © 2019 Altium Limited

評価版ライセンスが必要な理由を下記から選択してください。

弊社の営業担当より詳細情報をご案内しますので、アルティウムジャパン までお問い合わせください。.
Copyright © 2019 Altium Limited

その場合、評価版ライセンスは不要です。

ボタンをクリックして、最新のAltium Designerインストーラをダウンロードしてください。

Altium Designerインストーラをダウンロードする

弊社の営業担当より詳細情報をご案内しますので、アルティウムジャパン までお問い合わせください。.
Copyright © 2019 Altium Limited

Altium Designerの新規ライセンスのお見積もりをご希望の場合、下記のフォームに入力してください。

プライバシーポリシーに同意の上、[ダウンロード]をクリックしてください。ご登録いただきましたメールアドレスにメールマガジンが送信されます。メール配信の停止は、メール内の​通知設定​​でお手続きいただけます。

Altium Designerサブスクリプションをご利用中の場合、評価版ライセンスは不要です。

お客様がAltium Designerサブスクリプションの有効なメンバーではない場合、下記のフォームに入力して無償評価版をダウンロードしてください。

プライバシーポリシーに同意の上、[ダウンロード]をクリックしてください。ご登録いただきましたメールアドレスにメールマガジンが送信されます。メール配信の停止は、メール内の​通知設定​​でお手続きいただけます。

Altium Designerを評価する理由を下記から選択してください。

弊社の営業担当より詳細情報をご案内しますので、アルティウムジャパン までお問い合わせください。.
Copyright © 2019 Altium Limited

無償評価版を使用するには、下記のフォームに入力してください。

プライバシーポリシーに同意の上、[ダウンロード]をクリックしてください。ご登録いただきましたメールアドレスにメールマガジンが送信されます。メール配信の停止は、メール内の​通知設定​​でお手続きいただけます。

Great News!

Valid students can get their very own 6-month Altium Designer Student License for FREE! Just fill out the form below to request your Student License today.

プライバシーポリシーに同意の上、[ダウンロード]をクリックしてください。ご登録いただきましたメールアドレスにメールマガジンが送信されます。メール配信の停止は、メール内の​通知設定​​でお手続きいただけます。

その場合、Altium Designerビューワーの無償ライセンス(有効期間6か月)をダウンロードできます。

下記のフォームに入力してライセンスをリクエストしてください。

プライバシーポリシーに同意の上、[ダウンロード]をクリックしてください。ご登録いただきましたメールアドレスにメールマガジンが送信されます。メール配信の停止は、メール内の​通知設定​​でお手続きいただけます。

素晴らしいですね。アルティウムではモノづくりに最適なプログラムを提供しています。

Upverterは、コミュニティ主導型の無償プラットフォームで、お客様のような作り手の要求に合わせて設計されています。

試してみる場合、こちらをクリック してください。

弊社の営業担当より詳細情報をご案内しますので、アルティウムジャパン までお問い合わせください。.
Copyright © 2019 Altium Limited

その場合、Altium Designerビューワーの無償ライセンス(有効期間6か月)をダウンロードできます。

下記のフォームに入力してライセンスをリクエストしてください。

プライバシーポリシーに同意の上、[ダウンロード]をクリックしてください。ご登録いただきましたメールアドレスにメールマガジンが送信されます。メール配信の停止は、メール内の​通知設定​​でお手続きいただけます。