Creating the Schematic Symbol

Modified by Rob Evans on Oct 24, 2018
このページは、サポート対象外となったAltium Vaultについて紹介しています。Altium Vaultとそのコンポーネント管理機能は Altium Concord Proに移行しました。

The schematic symbol typically includes a shape that can reflect the function of the component and one or more pins. How a component is represented, i.e., the look of the symbol and arrangement of component pins, is up to the designer. This should be done to comply with the requirements of your organization and the design standards you choose to adopt. One component symbol can represent the entire physical component, or the component can be defined by multiple sub-parts where each sub-part represents some logical entity within the physical component (e.g., each AND gate in a quad AND gate component, or the coil and contact sets in a relay). This type of component is also called a multi-part component.

Schematic symbols are created by placing drawing objects to represent the component body and pins that represent the physical pins on the actual component. Schematic symbols are created in a Schematic Library in Altium Designer's Schematic Library editor and have the file extension *.SchLib. Any number of component symbols can be created in a schematic library. The organization of symbols into libraries should suit both the requirements of the company and the type of Altium Designer component library in which the symbol is destined to reside.

Regardless of how the models and component definitions are stored, once the component is placed onto the schematic, it then becomes a unified design component. The symbol will appear on the schematic; when it is edited, it shows the full set of component properties, including links to other domain models and its list of component parameters.

The physical component that is mounted on the completed printed circuit board is represented in Altium Designer in a variety of ways. On the schematic, the component is represented by a logical symbol. During SPICE simulation, a SPICE model is used, and on the PCB design, it is represented by its footprint. In Altium Designer, each of these representations is referred to as a Domain Model and each unified Altium Designer component is then the sum of its domain models.

The schematic symbol is one of the domain models that, together with the other domain models, defines the unified design component. The schematic symbol actually has a dual nature: it can operate as a simple domain model, created in the library editor as nothing more than a graphical shape and a set of pins, and it can also be used as the actual unified design component having other domain models, such as the PCB footprint linked to it in the library editor. The mode that each designer uses will depend on how they store and organize their components. Altium Designer has a number of ways of organizing and storing components, including:

  • Simple schematic and PCB libraries
  • Integrated libraries
  • Database libraries
  • Vaults

Preparing the Workspace

The default drawing sheet for a new component is an E-sized sheet. You should always zoom in so that the grid is easily visible before placing objects. The sheet size is configured on the Library Editor Options tab Schematic Library Options dialog (Tools » Document Options).

Use the Library Editor Options tab of the Schematic Library Options dialog to set the sheet size.

Always draw the component symbol close to the sheet origin (the center of the sheet).

The default units for schematic and schematic library grids are imperial, including the DXP Defaults option. Since all Altium components are designed on this imperial grid, it is important to appreciate the impact of deciding to switch to a metric sheet grid as it becomes difficult to correctly wire to components created on different grids. Note that imperial grids can be used with metric sheet sizes, such as A3, so it is not necessary to change to a metric grid when working with metric-sized sheets. The units for the current sheet are defined in the Units tab of the Schematic Library Options dialog (Tools » Document Options).

Use the Units tab of the Schematic Library Options dialog to set the units for the current sheet.

Units for new sheets (schematic and library) are defined in the Schematic – Default Units page of the Preferences dialog.

Objects are placed on the current snap grid. The current grid is displayed at the bottom of the workspace on the left-hand end of the Status bar.

Press the G key to cycle the snap grid through the available settings. Available settings can be edited in the Schematic – Grids page of the Preferences dialog.

Use the Schematic – Grids page of the Preferences dialog to define the snap grid settings.

Typically, objects and pins are placed on a grid of 10 or 5, with strings being the only object needing to be placed on a grid of 1.

Creating the Schematic Symbol

After setting up the workspace options as required, the next step is to capture the graphical representation of the component – to create the symbol graphics that will represent that component when placed on a schematic sheet. It is important to decide upon a standard for the graphical schematic symbols by which to adhere. This will provide a formal template when designing the symbol graphics and result in a guaranteed level of consistency. Altium's design methodology follows standard IEEE315, which not only covers the most common circuit elements, but also clearly defines how semiconductor elements can be combined to symbolize any number of silicon device types.

The body of the symbol is created by placing graphical design objects in the schematic library editor workspace by using the Place menu or the Utilities bar. Double-click the placed schematic symbol to open a dialog to further define each shape.

Altium Designer includes a variety of closed symbol shapes including rectangle, polygon, ellipse, and pie as shown below. 

            

Line-type shapes include arc, line/polyline and Bezier. Lines/polylines can include arrow heads and tails. Double-click to open a dialog to define the heads and tails. A Bezier is placed as a set of four points. 

The default settings for the properties of all objects, such as line width and color, are defined in the Schematic – Default Primitives page of the Preferences dialog.

Use the Schematic - Default Primitives page of the Preferences dialog to define default settings for all schematic symbols.

Object properties can also be edited during placement. Press the Tab key to edit the properties while the object is floating on the cursor before placement. Note that edits made during placement become the new default unless the Permanent checkbox is enabled in the Schematic - Default Primitives page of the Preferences dialog.

Editing the Schematic Symbol

To move an object after placement, click and hold the object then move the object to the desired location using the mouse.

To resize an object after placement, click once on the object to select it and display the editing handles then click and hold on a handle to resize the object. For a Bezier, click on an end point to select it.

Adding and Removing Vertices from Polylines

Vertices (editing handles) can be added to and removed from a polyline. Select the polyline, click and hold on a line or vertex then press Insert or Delete to add or remove a vertex.

Adding Pins to the Symbol

It is the component pins that give the component its electrical properties and define connection points on the component for directing signals in and out. A pin is placed to represent each pin on the actual physical component.

A pin can be placed in the workspace using one of the following methods. In each case, the pin appears floating on the cursor held by the electrical end. Rotate and/or flip the pin as required and click to effect placement.

  • Using the Place » Pin command (or shortcut P, P).
  • Clicking the   button on the design object drop-down of the Utilities toolbar.
  • Clicking the Add button in the Pins region of the SCH Library panel.

Use the Add button in the Pins region of the SCH Library panel to place a pin.

Press Tab to edit the pin properties before placement. Numerical values will auto-increment on subsequent pin placements. Auto-increment behavior is configured in the Auto-Increment During Placement settings in the Schematic – General page of the Preferences dialog. Use negative values to auto-decrement.

Use the Schematic - General page of the Preferences dialog to define auto-increment behavior. 

During placement or whenever a pin is moved, the pin is held by the electrical end (also called the hot end of the pin). The pin must be positioned so that the electrical end is away from the component body. Press the spacebar to rotate a pin while it is being moved.

Pins also can be placed to represent electro-mechanical points on the component, such as the tab on a voltage regulator.

A pin has a number of properties including a Display Name and a Designator. It is the pin Designator that is used to match the symbol pin to the PCB footprint pad. The default distance that the pin's Designator and Display Name appear from the end of the pin is a system-wide setting for the Schematic and Schematic Library editor. Configure the Pin Margin on the Schematic – General page of the Preferences dialog. Individual settings for the Pin Name and Pin Designator position and font can be used by configuring the pin properties.

A pin has an Electrical Type that is used by Altium Designer's electrical rules check system to verify that pin-to-pin connections are valid. Set this to suit the electrical type of that component pin.

The default pin length should suit the chosen snap grid (typically 10 or 5). The default length is 30; typical lengths are 20 or 30.

Graphical Symbols can be added to different positions of the Pin to represent electrical information from the pin.

Using the Schematic Library Panel to Create Schematic Symbols

Components are created with the design objects in the Schematic Library Editor. Components can be copied and pasted from one schematic library to another or from the Schematic Editor to the Schematic Library Editor.

A common approach to symbol creation is to copy a component from an existing schematic library. To do this:

  1. Open the source schematic library and the SCH Library panel (click the SCH button at the bottom-right of Altium Designer then select SCH Library from the pop-up menu).

Use the SCH Library panel to copy a component from an existing library.

  1. Select the required component(s). Use standard Windows multi-select techniques to select multiple components.
  2. Right-click on a selected component then choose Copy from the floating context menu.
  3. Open the target schematic library, right-click anywhere in the list of components in the SCH Library panel then choose Paste from the menu.

To create a new schematic symbol library:

  1. Click File » New » Library » Schematic Library. An empty document called Schlib1.SchLib is created, displaying a blank component called Component_1.
  2. Click File » Save As and rename and save the new schematic library document to a suitable location with an appropriate filename. 

Use the SCH Library panel to review and manage component symbols in an open schematic library. If the panel is not currently visible, click the SCH button at the bottom right of the workspace and select SCH Library to open it.

Defining Symbol Properties

Symbol properties, such as the name of this symbol, are edited in the Library Component Properties dialog. Double-click on the component name in the SCH Library panel or click Tools » Component Properties to open the dialog.

The Schematic Symbol Properties variation of the Library Component Properties dialog

  • The symbol's name is defined in the Symbol Reference field.
  • If the component symbol is being created purely as a domain model, then only the following properties need to be configured:
    • Default Designator - enter the required designator prefix followed by a ?.
    • Default Comment - if the symbol is generic, such as resistor, capacitor or transistor, you can leave this blank. If it is a dedicated symbol for a specific component, edit to reflect the comment string required on the schematic. Be aware that the comment string is also passed to the PCB.
    • Description - this string is helpful when component searches are performed.
  • If the component symbol is for a multi-part component or for any part that is different from other parts, such as a power block, it is a good idea to enable the Locked option to lock the part number. This stops Altium Designer from swapping this part with another part in the same component during design annotation. As an example, you do not want to swap a gate with a power block.
  • If the component symbol is not a purely domain model, additional parameters should be added. For generic symbols, the Default Comment can be used to add the specific value (depending on the workflow/library concept). Also, additional information about the component can be added in the Parameters region.
  • Type defines what type of component this symbol represents. Non-standard components, such as a company logo (Graphical) or a heatsink (Mechanical) can be created as schematic symbols and placed into a project.

The task of creating a component library symbol and its pin data has become an increasingly involved undertaking as components have advanced in complexity. With current large scale BGA devices requiring the placement and configuration of hundreds of pins for example, substantial time and effort is often required to create viable component symbols.

Schematic Symbol Generation Tool

To ease the workload associated with creating component symbols, Altium Designer offers an advanced Schematic Symbol Generation Tool based on a symbol wizard interface and pin editor dialog. This features automatic symbol graphic generation, grid pin tables and smart data paste capabilities.

The Schematic Symbol Generation Tool is provided as an Altium Designer software extension, which is automatically installed with Altium Designer. The extension appears under the Extension Manager’s Installed tab. 

To create a new component symbol using the Schematic Symbol Generation Tool, first add a new library component using the Add button in the Component section of the SCH Library panel. The new symbol then can be developed through the Symbol Generation Tool (Tools » Symbol Wizard) which opens the Symbol Wizard dialog.

The Symbol Wizard dialog

The dialog's Settings options determine the basic configuration for the symbol, including its layout style and number of pins.

The Pin layout style allows you to choose from a set of predefined symbol patterns, where the pin positioning is automatically assigned. Use the drop-down menu to select the preferred arrangement – the result will be visible in the Preview image and the Side column settings in the Pin data table.

Found an issue with this document? Highlight the area, then use Ctrl+Enter to report it.

お問合せ

お近くの営業所にお問合せください。

You are reporting an issue with the following selected text
and/or image within the active document:
Altium Concord Pro 無償評価版

フォームにご入力ください。