KB: 관리되는 프로젝트의 폴더 경로 위치 변경

A365 A365
[Why] 마스터 서버 프로젝트를 기본 위치가 아닌 다른 로컬 폴더로 가져오거나, 프로젝트를 마스터 서버로 다시 저장(Push)하기 전에 로컬 프로젝트 폴더의 위치를 변경해야 할 수 있습니다. [What] 프로젝트의 로컬 저장 경로는 환경 설정에서 기본값을 변경할 수 있으며, File » New » Project 또는 File » Open Project 대화 상자에서 프로젝트별로 다른 경로를 지정할 수도 있습니다. 또한 프로젝트 폴더를 로컬에서 다른 위치로 이동한 경우, 프로젝트를 열 때 새 폴더 경로를 확인하는 메시지가 표시됩니다. [How] 기본 로컬 저장 경로인 C:\Users\Public\Documents\Altium은 Preferences » Data Management » Design Repositories » Properties에서 변경할 수 있습니다. 또한 새 프로젝트를 생성하거나 서버에서 프로젝트를 가져올 때마다 원하는 로컬 경로를 직접 지정할 수도 있습니다. 이미 프로젝트 폴더를 다른 위치로 이동한 경우에는 File » Open Project » Browse를 선택한 후 새 위치의 *.PrjPCB 파일을 열면, 프로젝트의 로컬 저장소 경로를 새 위치로 업데이트할 것인지 묻는 메시지가 표시됩니다.

솔루션 세부 정보

먼저, 웹 브라우저에서 설정한 서버 측 프로젝트 폴더 위치는, 로컬 작업 폴더의 경로와는 별개이며 서로 영향을 주지 않습니다.
*참고 가이드
Altium 365 워크스페이스의 프로젝트 | 사용자 매뉴얼 | 문서

image.png

새 프로젝트를 생성하거나 서버의 프로젝트를 처음 가져올 때 기본 로컬 저장 경로는 C:\Users\Public\Documents\Altium입니다.
이 경로는 Preferences → Data Management → Design Repositories → Properties에서 변경할 수 있습니다.

*참고 가이드
https://www.altium.com/kr/documentation/altium-designer/accessing-defining-managing-system-preferences#!design_repositories:~:text=existing%20design%20repository.-,Properties,-%2D%20click%20to%20open

또한 프로젝트를 생성하거나 서버에서 프로젝트를 가져올 때마다, 원하는 로컬 경로를 직접 지정할 수도 있습니다.
*참고 가이드
https://www.altium.com/kr/documentation/altium-designer/opening-project#!opening-a-workspace-
project:~:text=shared%20with%20you.-,You,-have%20the%20option


이미 로컬 프로젝트를 수정한 상태에서 해당 변경 사항을 서버와 동기화해야 하고, 동시에 로컬 저장 위치도 변경하려는 경우,.git 및 .gitignore를 포함한 프로젝트 폴더 전체를 Windows 탐색기에서 원하는 위치로 이동합니다.

폴더를 이동한 후, Altium Designer에서 File → Open Project → Browse를 선택한 다음, 새 위치의 *.PrjPCB 파일을 열면 프로젝트의 로컬 저장소 경로를 새 위치로 업데이트할 것인지 묻는 메시지가 표시됩니다. (아래 사진 참고)

image.png

만약 문제가 있으시다면, 텍스트/이미지를 선택하신 상태에서 Ctrl + Enter를 누르셔서 저희에게 피드백을 보내주세요.