AltiumLive 2018
University Day

Instructor
Derek Jackson CID+
Product Expert
Altium Designer Best Practices

A look at best practice in Altium Designer.
Communication

1. Assembly House
2. Fab Houses
3. EE, PCB designers, CAD Department
   1. Add notes into your schematics (Place » Note / Text Frame).
   2. Add notes on your Mechanical Layers in PCB.
4. Datasheets
5. Web Forums
6. Peers
7. Technical Support
Altium Designer Best Practices

2. Standardization

1. Designs and Projects Using Templates
2. Standardize libraries
3. Naming conventions
Altium Designer Best Practices

Organization

1. Libraries
   a. Usage and location.
   b. Component Parameters
2. Supplier Links
   a. Add a manufacturer / mfg part number parameter to your components
3. Template locations.
4. Design locations
4

Backups

1. Use Version Control
2. Make backups
3. Save Often
Know the tool

Most of us wear many hats.

However, we might also work with other departments/teams or, may not use the same documents in AD every day, e.g., working on the schematic portion for several weeks before moving to PCB, so the day in and out can be forgotten.

The following slides contain a number of notes I made of tidbits I remembered during my working on a project, although it may not be fully comprehensive, hopefully there is something that you may find beneficial. It is up to you to dig in and create your own best practices that best suit you needs.
Pieces: PCB Kitchen

Breakdown of sections covered:
- Altium Live
- System Level
- Schematic
- Library
- PCB
- Fabrication / Assembly
Altium Live:

The first thing to know is how to find help. There are several resources available: Forums, Documentation, Support, and Resources (and Web searches)
Altium Live:

Documentation: (Help » Exploring Altium Designer or F1)
- All documentation is online.
- Select the your Altium Designer Version
- Click the magnifying glass to enter search keywords, or use sidebar to navigate.

Web Search:
Search Online, and bookmark useful entries. In Google, enter “Altium” in double quotes plus any keywords. Or, use your favorite browser search engine.
Altium Live:

Support:

(“Altium Live: Resources » Support”)

After searching, if you still need help and cannot find the answers, enter a Support Cases online.

If you have entered a case and have posted in the community forums about the same issue, make sure to add your forum link in your case.
Support:

Bug Crunch / Ideas:

If it results in being a feature request or a bug, search in the Bug / Ideas section and vote or enter a new item.

This is a community driven area that R&D references when they are trying to decide on what issues/requests they will fix, so your vote really does help (although it may appear otherwise).
Support:

Bug Crunch / Ideas:

Make sure to update your support case with the BC or Idea link so it can be linked and added to the internal R&D ticket.

If there is a similar report, click the vote button.
Support:

Bug Crunch/Idea Comments:

Make sure to read through the comments on reported Bugs/Ideas and give a thumbs up / down, as there may be a workaround, or the command was being used incorrectly.
System Requirements:
https://www.altium.com/documentation/18.0/display/ADES/Altium+Designer+-+-+(System+Requirements)

Video Card DirectX gaming style Video Card
  More RAM (4-64Gb)
  * Be mindful of Power requirements
  * Read reviews on cards if using 4K
  Which card?
    Fast frequency, minimum 700GFlops
    AMD Radeon RX Vega (10+TeraFlops)
    Nvidia GeForce GTX 1070/1080 (boasts 6.5/8.9 TeraFlops)

System RAM
  More is better, minimum is 4Mb. 16/32Mb+ preferred if you run other memory hungry applications concurrently.

CPU
  Faster CPU speed is better.

Hard Drives
  SSD is better for overall system performance
Altium Designer Best Practices

System:

Panels
With a document in focus, press the K key to access to panels selection on your cursor. The Panel button can also be pressed. All panels are available from ‘Views » Panels’. Save/Reset panel layouts in the ‘Preferences » System » View’. Save, Load, restore panel configurations here.

Project Panel
The Project Panel populates with components & Nets sections. These are searchable as well as document names by typing in the search field for schematics for selected project.
System:

Panels

Navigator Panel: Use in conjunction with the Project Nets/Components section. After a compilation, open the navigator panel to navigate to nets or components.

Use the Flattened Hierarchy section to see all nets, otherwise, select by schematic document. **Alt+Click** to navigate to both Sch and PCB simultaneously.
System:

Design Workspace (*.DsnWrk)

It is important to Save your Design Workspace. If not saved, the workspace behaves as a virtual workspace, saving the projects that are loaded ONLY when exiting Altium Designer.

The Design Workspace appears at the top of the Projects Panel. Using ‘File » New » Design Workspace’ will close out all open projects. The new workspace will be a virtual one, not saved as a file until manually saved using the ‘Save Workspace As’ command. Opening the saved Workspace will load all associated project with it. Once saved, the workspace will save with the ‘File » Save All’ command.

Project Packager:

Right-click on a project to create a time stamped archive of your project. You can also include output and history files, and can find tune which files get added. In order to archive the entire workspace archived, the workspace must have been saved previously.
Altium Designer Best Practices

System:

Shortcuts

Carl Schattke said in last year's Altium Live 2017, “know them, learn them, and use them!”

In Altium Designer, in the search field, type in Shortcuts (shows for selected document type). Or, enter in ‘Shortcuts keyword’ to narrow down the display).
Altium Designer Best Practices

System:

Shortcuts

Additionally, all shortcuts are displayed in Altium Live. [https://www.altium.com/documentation/18.1/display/ADES/Altium+Designer+-+(Shortcut+Keys)](https://www.altium.com/documentation/18.1/display/ADES/Altium+Designer+-+(Shortcut+Keys))

(On the Web page, under Shortcut Listings, under each editor type are a number of key combinations, such as Ctrl+D to access the View Configuration panel in PCB).
System:

Accelerator Keys
In menus, the underlined letter can be pressed directly for the menu to pop onto your cursor.

Subsequent keystrokes will select the additional submenu or command.

For example Pressing **U**, then **M** will start the Interactive Multi-Routing command.
Altium Designer Best Practices

System:

Preferences
The mighty O key: Document specific links to most common preferences or panels.
Altium Designer Best Practices

System:

Preferences

Importing / Exporting Preferences will also load in your menu customizations, including shortcuts.

- The Search Field allows searching for keywords in preferences.
- **Autosave**: “Data Management » Backup”. The default is off. Be in the habit of saving often. Enable this option just in case you forget.
- **File Locking**: “Data Management » File Locking”. In a shared environment, enabling this in the preferences will only allow the document to be opened in read only mode by other designers.
System:

Active Bar vs the P (Place) key:

- Active Bar settings are per document.
- Bar entries can be modified (right-click on menu bar and select Customize)
- Active Bar can be turned off (Preferences: System » General » Advanced » UI.UseActiveBar)
  - If disabling the ActiveBar, copy the selection filter to your menu bar first (in PcbDoc, SchDoc, Pcb/SchLib editors). The selection icon gets a green dot on it when a filter is applied.
  - To Copy: right-click next to the menu items and select customize.
    - Start Dragging then before releasing, press the Ctrl button so it makes a copy instead of moving when you release it.

- A clear button can also be copied in a similar fashion by temporarily enabling the Standard Toolbars (Sch: from Schematic Standard, Pcb: PCB Standard, Lib: Sch / Pcb Lib Standard)
**System:**

**Templates:**

‘Preferences » Data Management » Templates’

Set a custom path **OUTSIDE** the version specific folder of Altium Public folders. Any custom templates, files or modification in this location will be completely deleted in the even of a complete uninstall of Altium Designer.
Altium Designer Best Practices

**System:**

**Templates:**

Schematic templates. These define the current schematic document’s title bar and allows adding custom document parameters.

Using schematic templates can help standardize information provided on your schematics.

Schematic templates can be updated and reapplied to schematic documents.
System:

Templates:

Project templates.

“File » New » Project...” invokes the project Wizard. The Wizard will take a selected template, and clone it in the specified location with the given name. This defines a starting project and can include one or more schematics and pcb documents.

Several templates are provided as examples at Altium Live’s Design Template Design Resource section. Download and modify to fit your requirements.
System:

Templates:

Use the Project Options’ “Options” tab to setup template locations that are specific to the project. Enter the path location in the “Schematic Template Location” field.
Altium Designer Best Practices

System:

Version Control:
SVN or GIT (Git is available in AD18 revision and later). Both can be used with either a Local or Remote repository.

For GIT, there is no added extension, just checkout the project from your NEXUS Server, or from a GIT repo using your favorite GIT client, and Altium Designer will recognize it is in GIT.

For SVN, configure the repository in “Data Management » Design Repositories”.

System:

Storage Manager: Access from Panels button. This panel shows commits as well as the local save history for a selected document.

In the Storage Manager, you can compare document revisions, either in VCS or in Local History by Select two revisions and right-click to compare differences.

Make sure to purge your local history once in awhile, especially if you save often. Adding comments to files in the history, you can exclude commented history files from being purged.
System:

Troubleshooting:
Hold the Ctrl key while starting Altium Designer (this can help resolve crashes on startup by preventing open documents from reload).

Uninstalling:
For troubleshooting, for worst case scenario when Altium Designer just will not start, try uninstalling just the preferences (this will reset all preferences back to the defaults). If possible, when Altium Designer is running, export preferences first.
**System:**

**Troubleshooting:**

**Projects:**
Ensure all design files are part of a project and don’t end up in Free Documents (If a document was opened, and the project was not saved when Altium Designer restarted.

Free Documents are for opened files that are not in a project and when closed, these are removed from the workspace.

Projects specify ERC checking, ECO, output path locations.
Schematics not in a project will have their ECO checks all default to error.
System:

Registered File Types: Register/unregister Altium Designer to open specific file types.

Or, if multiple versions are installed, register the filetypes within the version you wish to be the default editor by checking/unchecking the checkbox next to the extension.
Schematic:

Units: In Schematic, mils/inches are best, don’t try metric (which is fine in PCB / PCB Library).

Dragging:
Hold CTRL key while dragging non-electrical schematic objects, such as text or component designators, to move by the smallest unit (10mil).

Grids:
Don’t use a 10mil grid for schematic design. Altium’s schematic components have a pin-to-pin spacing of 100mil.

Project Compilation:
Errors and warnings, in the Message Panel, right-click cross probe to errors. Remember, the Message panel only auto opens for errors, not warnings. ALWAYS double-check the Message Panel, and read ALL warning messages.
Schematic:

Unconnected pins:
Place NoERC on all no-connect pins. ‘Place » Directives » Generic NoERC’, or right-click on the message in the Message Panel and add a Specific No ERC to the pin.

In the Project Options, set the Connection Matrix for ALL unconnected pins to Warnings.

This is especially important if you have imported a design in order to verify connectivity
Schematic:

Smart Paste:
(pasting as other objects), for example, pasting a bus net label as wires, ports and net labels.

Placement “inherit”:
Use Insert key when placing Nets, and Ports when hovering over an existing text object to pick up the name.

Buses:
Ensure net labels are placed on a Bus, and that they have the format: 
NETNAME[StartIndex#..EndIndex#]
Schematic:

Hierarchal Design:
- Sheet symbols can be used in both Flat and Hierarchical designs.
- For hierarchical designs, you can include sheets without sheet entries, such as the SL_Power as shown in the image.
- Power Ports: Don’t put ports on power ports (localization). These are global by default.
- Decide up front if you are using Flat or Hierarchical vs Multi-Channel before PCB transfer, otherwise, it is difficult to match-up component links after parts are on the PCB.
- All Sheet symbols need unique designators (currently, this is a manual process).
Altium Designer Best Practices

Schematic:

Annotation:
Leaving designators ending in a question mark ?, e.g., U?.
Annotate with ‘Tools > Annotate > Annotate Schematics Quietly...’. This will assign available designators.
Full Annotation control is set in the ‘Tools » Annotate » Annotate Schematics...’.

Board Level Annotation:
Requires annotation at both schematic level and in Board Annotation Manager. This uses an external .ANNOTATION file. Ensure no duplicate designators in schematics prior to running.
Do not invoke this command unless you read about it first here. There is a lot of good information on annotation in that link, so it is worthwhile to review the entire page.
**Schematic:**

**Rule Directives in the schematic:** (can only specify Unary targets, binary assumes second object is All)

- **Width (Place » Directives » Parameter Sets).** Make sure to select the Pcb Stackup to target specific layers.
- **Differential Pairs (requires end in _N and _P to differentiate).** In AD18.1.6, “Diff Pair Classes in Schematics” was introduced in the directive settings!
Schematic:

Net Classes:
(Use blankets **Place » Directives » Blankets** for assigned nets in a grouped area). ‘**Place » Directive » Parameter Set**’ to place on a wire or blanket to assign associated net to the assigned class. The blanket is the dashed line around the net labels to be included in the class. The Netclass will transfer to the Pcb doc as shown.

To Ensure your net classes transfer to the PCB, ensure that the option is enabled in the project options, under the Class Generation tab: **User Net Classes**, as we will see on the next slide.
Schematic:

Component Classes: Can be defined in the schematic, but require a Class_Name parameter. Classes are automatically generated per page, but sub classes can be made with parameters.

Harness Classes: Enable the ‘Generate Net Classes for Named Signal Harnesses’ to create classes for each named harness used in your schematics.
Net Colors: (these sync with the PCB). Helpful to track nets, and component orientation in PCB. Define in either the Schematic or the PCB. From the Schematic, use ‘View » Set Net Colors’. From the PCB, use the PCB Panel’s Net section. Coloring ground can be very useful when orienting your coupling caps, as the default color is defined by the layer color (see all the power pads at a glimpse).
Schematic:

Moving Components: (that have been transferred to PCB): Use Edit » Refactor » Move Selected Subcircuit To Different Sheet. Cut and Paste will change the Unique ID. Although the default ECO option when updating the PCB will try and resync these using designators, if the designators have changed, it may result in your components getting ripped up and re-added off the board.

Component Links:
Although the ECO will check if your schematic and PCB components are in sync, best practice is to manually check once in a while using ‘Project » Component Links’ from the PCB. When syncing, enable both Designator and footprint (comment can be helpful as well to ensure a correct match).
Altium Designer Best Practices

Schematic:

Page Numbering: Perform ‘Tools » Annotation » Number Schematic Sheets’ to ensure all sheets have unique page numbers (just a necessary step).

Placement: When moving objects with the mouse, for auto scroll, use the arrow keys and hold Shift to move x10 speed in either SCH or PCB).

Mechanical items:
Place mechanical / fiducial / mounting holes / test points / and the PCB item on schematics

Place these on a schematic as a component to include them in the Bill of Materials. Set the Component Type to Mechanical if you only want them to be included in the BOM, and not added to the PCB.
Schematic:

Design Reuse:
- Device Sheets:
  (also called Managed Sheets if used in conjunction with the Altium Vault / NEXUS Server). Using Managed sheets is a good way to reuse a verified schematic document. The sheet does not live in your project, but is compiled into your project. Set the location of the Managed Sheet in the preferences under ‘Data Management » Device Sheets’.
Schematic:

Design Reuse:
- Device Sheets (Cont):
  place in the schematic similarly to a sheet symbol. Compiling pulls the sheet into your project as read-only, so it is necessary to use Board Level Annotation to annotate.
Schematic:

Design Reuse:
- Device Sheets (Cont):

  Manage the Sheet Symbol properties from the Properties panel.
Schematic:

Design Reuse:
When compiling your project, device sheets automatically sync with source.

It is more advantageous to use managed sheets in conjunction with the NEXUS server, as the sheets don’t automatically update unless purposely, where regular device sheets update automatically to sync with changes made to them.

To freeze a Device Sheet for a particular project, use ‘Edit » Refactor’ to convert it to a regular schematic sheet.
Schematic:

Footprint Manager: ‘Tools » Footprint Manager’. Verify footprints are available and which libraries these are found in.

This helps ensure that libraries are configured correctly before sending them to the PCB or the PCB Designer.
Schematic:

Footprint Manager (Cont):

Footprint locations can also be modified in the Footprint Manager dialog by clicking Edit. This is useful if the design engineer used libraries configured with a path different to your configuration.

In the PCB Library section of the footprints properties, the option for Any can be selected, however, best practice is to specify a library name to help reduce the chance of the footprint from getting pulled from the wrong library.
Schematic:

Supplier Management: Create a ‘File » ActiveBom Document’ early on in the design cycle.

Suppliers are pulled from Altium’s online supplier database, Ciiva.

This can give a glimpse on available supplier stock. This is a live document and will pull in new components as you build your design.

Note: Only one ActiveBom is allowed per project, so if you don’t see if listed under File » New, chances are you already have one created for the project.
Libraries:

Best practice is to use an Altium Vault / NEXUS Server, as this allows Revision management. This is a purchased product to be used with Altium Designer / NEXUS. The Server uses a one to many approach for component management, where a single graphical symbol can be used in multiple components.

Database Libraries, DbLibs, have a similar approach of one to many, whereas regular libraries are one to one. A one to many, for example, one resistor symbol representing hundreds of resistor components. Database libraries are the approach when transferring library components to a NEXUS server. DbLibs connect to any ODBC compliant database.

Library Types:

- Regular Schematic (*.SchLib) and Footprint (*.PcbLib)
- Database (*.DbLibs)
- Integrated (*.IntLibs)

Integrated Libraries are a compiled, read-only files that combine several regular SchLib and PcbLibs into one file. Note, however, each footprint must have a referencing schematic component in order to be accessed.
Libraries:

Virtual Libraries:

- Create a virtual library that references your own Vault components (NEXUS Server), or Altium Content Vault components.

- Just add the folders you wish to include in the library by selecting the Install from server... selection.
Libraries:

Symbols / Footprints: Where do you find them?
- Altium Content Vault / Altium Live
- Legacy Integrated Libraries
- Searching Manufacturer Web:
  - Downloaded supported CAD reference designs as-libraries can be generated from schematics or PCBs. ‘Design » Make Library’
  - Sometimes Altium libraries are available for download
- Octopart (click CAD Models from search and download if available)
- IPC Footprint Wizard
  (Use Batch spreadsheets and save copy.)
- Schematic Symbol Wizard
- Other 3rd party sites / tools
  (always validate any downloaded library before use)
Libraries:

3D Models: (a must for every footprint)
It is easy to create extruded models. Or have your CAD department provide a nice step model or download from the Web.

- Clearance checking: The 3D body is used for component to component clearance.
- The extruded or step model is used for both vertical and horizontal clearance based on the step models shape.
- Easily created from bounding shapes in the Pcb Library editor using ‘Tools » Manage 3D Bodies for...’
Libraries:

3D Models (Continued):

If a 3D Body (model) is not attached to your footprint, the entire bounding area is used. This area is calculated from all pad objects and silk screen layers and can larger than expected, especially for odd shaped footprints.

- Use the IPC Wizard in a Pcb Library and enable the option to create a Step model.

- Download models from Web sites such as: 3D-Content Central, GrabCAD
**PCB:**

Top 5 items to know: [https://resources.altium.com/pcb-design-blog/top-pcb-design-guidelines-every-pcb-designer-needs-to-know](https://resources.altium.com/pcb-design-blog/top-pcb-design-guidelines-every-pcb-designer-needs-to-know)

**Selection Filter:**
- Green indicator shows there is a filter applied
- Filter menu still available with right click.
- The Filter also has a clear button which can be accessed directly or copied onto your toolbar if not using the filter toolbar.

**PCB Panel:**
- Used to navigate / zoom / select items in your PCB (use DIM with [ ] keys to increase / decrease intensity)
- For components, right-click in the primitives section to enable more primitive displays.
- Good method for manually assigning nets to objects in the case of updating footprints from libraries containing new primitives, these don’t always get updated.
  - Alternate methods for net propagation is using ‘Design > Netlist > update free primitives from component pads’
  - Configure Physical Nets is another option, but EXTREME caution needs to be used, as you can rename nets unintentionally, so if you use it, make sure you look at every single proposed change.

**Dragging in PCB:** Use the **CTRL** key to override snap when dragging. (**Shift+E** to toggle Hotspot snap settings).
PCB:

ECO:
Make sure you look at the proposed changes when you execute an ECO on your PCB Design, ‘Design » Update PCB Document’.

Un-check anything you don’t want added, changed, modified, or removed. Right-click in a section and select ‘Disable All of Same Kind’ to disable all entries for that section.
PCB:

Project » Component Links:

As mentioned before, **always** double-check to ensure all placed components are matched up and in the rightmost section.

These can be matched manually, enable comment and footprint check-boxes (unless footprint has changed in schematic symbol).

This is automatically checked during the ECO. I prefer to select Manual and visually verify what is getting linked.
PCB:

Rules:

Rules & Violations Panel: Use to easily run DRC checks and find errors.

Use the PCB Rules & Violations to quickly find DRC errors. Right-click on a rule, or a rule class and run just that rule. This is a great time saver when only one rule needs to be checked rather than running a full DRC check using 'Tools » Design Rule Check'.

Best practice is to start checking design rules early and keep them in check throughout the design cycle. DO NOT disable rules in the PCB Rules & Violations Panel, this should only be done in the Design Rule Check Dialog.
Altium Designer Best Practices

**PCB:**

**Rules:**

When defining rules, ‘Design » Rules’, target component or net classes, not a specific designator or net.

Changing a net name in your design **DOES NOT** update the rule to reflect the new name. Using a Net Class, unless the net class name changes, the net class will always encompass the targeted nets in the rule.
Altium Designer Best Practices

PCB:

Colors:
As mentioned before, using Net Colors greatly enhances the visibility of net locations in the PCB.

Enable the Net color Override in the PCB Panel by checking the box to the right of the Net name is order to override the layer color for that net.
**PCB:**

**Layer sets:** (L) **View Configuration Panel.** Use to quickly turn on / off layers (auto mirror displayed layers can be enabled also). Clicking the LS button at the lower right of the Pcb workspace allows selection from available Layer Sets.

Create and save your own Layer Sets to quickly enable only the layers you need to work on or that are related to a specific net routing.
PCB:

View Configurations: ‘(L) » View Options’ Save your Draft / Transparent settings.

- Create View Configurations to quickly apply the saved settings in your View Configuration Panel. Some available settings are available as examples, such as ‘Altium Transparent 2D’.
- Once you have set the object visibility (unclick the eyeball to hide objects), set the Transparency slider, and checked the box for objects to display in Draft, save your settings in a custom configuration.
- Other useful settings to enable are:
  - Repeated net labels on tracks

Mask and Dim Settings allow you to adjust the mask applied from a filter. With the a PCB document selected, change the intensity of dimmed/masked objects using the ([ , ] shortcuts).
Altium Designer Best Practices

PCB:

Other useful commonly used commands to help productivity:

- Measure selected: to display length of selected tracks. (Use xSignals for more accurate calculations).
- Hiding Connections: Hide nets with lots of connections, like ground, to speed up net analysis delays (improved in 18).
- Moving components: Connections lines are hidden for more than 50 pad components, change in advanced preferences. This controls the dynamic connections and is useful for moving and orienting components.
  - Press **Space bar** to rotate component while moving
  - Press the **L key** to flip from Top to Bottom.

Deleting tracks: Press **Ctrl+backspace** to extend delete selection (deletes selected track and selects adjacent segments).

Selection: Press **Tab** to extend a selection of a selected track. Press Tab again to extend selection to pads and opposite multiple layers.

Picking up net: Paste a via onto a track end, the via picks up the net of the track.
PCB:

Polygons: always repour (or not) user preference (Preferences » PCB Editor » Repour Polygons After Modification’).

Use ‘Tools » Polygon Pours » Shelve’ (to temporarily hide polygons for moving objects/routing an area that may be obscured. Use the Polygon Manager to manage pours. Click the Auto Generate button to order the pours based on size (smallest to largest). A must if working with an imported board.

Use the Auto Assign Name option to auto name polygons. This will use the layer and net name. Control the naming scheme option at the bottom of Properties Panel when nothing is selected.
PCB:

**Dimensions:** Best practice is to ALWAYS add dimensions to your board (on a mechanical layer), especially for the board shape. Don’t assume the Fab knows, otherwise, you might unexpectedly get back the wrong board size.

**Unions:** Use to lock objects relative to each other. (view unions in PCB Panel’s Union section).

**Zooming:** Since you mostly right-mouse to drag and pan your PCB workspace, to zoom, keep the right-mouse pressed and press and simultaneously click and hold the Left mouse. Once the cursor changes, move your mouse up/down to zoom in and out. (Same operation as Control+Right-mouse-button, or easiest way to zoom is to just press the Center Mouse button, and move the mouse up or down to zoom in/out).
Altium Designer Best Practices

PCB:

Routing:

Enable Clearance Boundaries for better visual of routable spaces.

Press the tilde key, ~, to get a list of shortcuts during an active command.

Pay attention to route mode in the Heads up display, also at the bottom of the workspace.
Altium Designer Best Practices

PCB:

Locking:
- Components:
  Lock all components after placement, prior to routing to prevent accidental movement
- Routing:
  Once a route is finalized, lock it down (use the Tab extend method or Filter Panel).

Use the filter panel to select items to lock, then use the Properties panel to lock. Example filter:

```
((IsPad Or IsVia Or (IsArc Or IsTrack) And Not InPoly) And IsFree Or (IsVia Or (IsArc Or IsTrack) And Not InPoly) And InAnyNet) And IsElectrical
```
Altium Designer Best Practices

**PCB:**

**2D / 3D:**
Check how you board looks in 3D often. Selected objects in 2D carry to the 3D mode. Use **Shift+S** for single layer mode to view layers in 3D. Switching between 2D and 3D (2 and 3 key), to keep current zoom, hold CTRL+ALT and the mode, e.g., **CTRL+ALT+3**.

**3D Projection mode:**
In the View Configuration panel, in the View Options tab, set Projection to Orthographic which helps flatten out the board.

**3D Component View:** Quickly show / hide 3D component by pressing **Shift+Z**
Fabrication & Assembly:

Draftsman: Fabrication and Assembly. Allows creating templates board data is loaded into. The templates can be updated and then reapplied to a draftsman document, giving an advantage over using mechanical layers in the Pcb document, which are static.

When updating the Draftsman template, in the properties panel, be mindful of the option for current page vs all pages in upper right (represented by an arrow with either one page or stacked pages).
Fabrication & Assembly:

Camtastic verification:
Once Gerber / ODB++ files are generated, they are then loaded into a CAM document for viewing. (If using an Outjob, the Output Container must be edited to specify which document types to Auto Load)

Use the Camtastic panel to inspect the layers:
Select a layer and press the left arrow to isolate it.
Press the Up and Down arrows to navigate through each layer, in turn, each layer is automatically isolated.

Don’t be like that guy who said he accidentally exported his fab notes to all layers (even signals), and his FAB didn’t report it.

The Gerber Exporter does not do any type of check on exported Gerber files.
An IPC-356 is recommended for loading, and after a net extraction, can be used to rename nets to match the Pcb.
Fabrication & Assembly:

PDF: Concatenating multiple files. Use expressions and special strings in the names. Just add an equal sign in the beginning of the name.

For example, in the Output Container, entering: `=Projectname + '_' + 'AssemblyDrawing.pdf'` will automatically be converted, and a preview displayed.

Separate Fabrication and Assembly into different output jobs. Although not a requirement, can help to organize output types, and if used in conjunction with the Altium Vault / Nexus Server, this is a requirement for project release.

If you are not using the Vault / NEXUS Server, you can still run the release manager to generate all outputs in your OutJobs.
Fabrication & Assembly:

Bill of Materials – Best practice is to setup and use BOM Templates.

The Template can be setup to suit your required formatting. Take advantage of project parameters to include these in your output.

Use your ActiveBOM to drive the settings for your BOM data by setting the data source in your Output Job file.
Fabrication & Assembly:

Lastly, a reference to a really great presentation on creating successful PCB manufacturing documentation from Altium Live’s 2017 presentation by Julie Ellis - [Creating Documentation for Successful PCB Manufacturing](#)
AltiumLive 2018 DEMO
AltiumLive 2018
Questions?