AltiumLive 2018 University Day

Instructor
John Watson CID
Senior PCB Engineer Legrand North America

Welcome
Configuration and Use of Project and Output Template

Walks through the setup and use of templates for projects, including schematic, PCB and Project templates.
Agenda

• Introduction
• Why use Templates/Parameters
• PCB Project Walk through
• Project Parameters
• Creating PCBA Variants
• Design Templates
• Putting it all together
• Conclusion
Why use Templates and Parameters?

- Standardizes the design process & Document
- Not having to enter the same information in multiple docs
- Reduces mistakes & errors
- Live update of some information
PCB Project Walk through - EXAMPLE

PCB (Bare Board) SINGLE DESIGN
PCB Project Walk through - EXAMPLE

PCB (Bare Board) SINGLE DESIGN

PARAMETERS
- PCB Name
- PCB Part Number
- PCB Revision
PCB Project Walk through - EXAMPLE

PARAMETERS
- PCB Name
- PCB Part Number
- PCB Revision

Fabrication Data
PCB Project Walk through- EXAMPLE

PCB (Bare Board) SINGLE DESIGN

PARAMETERS
- PCB Name
- PCB Part Number
- PCB Revision

INFO
- Bare PCB
- 12345
- 1.A.

Fabrication Data
PCB Project Walk through- EXAMPLE

PCB (Bare Board) SINGLE DESIGN

PCB Name
PCB Part Number
PCB Revision

INFO
- Bare PCB
- 12345
- 1.A.

Fabrication Data

Variants #1

PCBA (Assembly) MULTI-DESIGN
PCB Project Walk through - EXAMPLE

PCB (Bare Board) SINGLE DESIGN

PCBA (Assembly) MULTI-DESIGN

PARAMETERS
- Variant Name
- Variant Part Number
- Variant Revision

INFO
- Bare PCB
- 12345
- 1.A.

Fabrication Data

Variant #1
PCB Project Walk through - EXAMPLE

PCB (Bare Board) SINGLE DESIGN

Variant #1

Variant #2

PCBA (Assembly) MULTI-DESIGN

Variant #1

Variant #2

PARAMETERS
- Variant Name
- Variant Part Number
- Variant Revision

INFO
- Bare PCB
- 12345
- 1.A.

Fabrication Data
PCB Project Walk through- EXAMPLE

PCB (Bare Board) SINGLE DESIGN

INFO
- Bare PCB

PCB Part Number - 12345
PCB Revision - 1.A.

PARAMETERS
- PCB Name
- PCB Part Number
- PCB Revision

Fabrication Data

PCBA (Assembly) MULTI-DESIGN

Variant #1

PARAMETERS
- Variant Name
- Variant Part Number
- Variant Revision

Data

Variant #2

PARAMETERS
- Variant Name
- Variant Part Number
- Variant Revision

Data

Variant #3

PARAMETERS
- Variant Name
- Variant Part Number
- Variant Revision

Data

INFO
- PCB Name
- PCB Part Number
- PCB Revision

Fabrication Data
PCB Project Walk through- EXAMPLE

PCB (Bare Board) SINGLE DESIGN

PCB Name
- Bare PCB
PCB Part Number
- 12345
PCB Revision
- 1.A.

PCBA (Assembly) MULTI-DESIGN

Variant #1

PARAMETERS
- Variant Name
- 54321-01
- Variant Part Number
- 54321-01
- Variant Revision
- 1.A.

INFO
- Variant #1

Variant #2

PARAMETERS
- Variant Name
- 54321-02
- Variant Part Number
- 54321-02
- Variant Revision
- 1.A.

INFO
- Variant #2

Variant #3

PARAMETERS
- Variant Name
- 54321-03
- Variant Part Number
- 54321-03
- Variant Revision
- 1.A.

INFO
- Variant #3

Fabrication Data

Variant #1 Data

Variant #2 Data

Variant #3 Data
PCB Project Walk through Deliverables

Fabrication Data (BARE PCB)
- PCB
- Fabrication Drawing
- Output Job File (Fabrication Data)
  - Gerbers
  - IPC-2581
  - ODB++ File
  - PCB Prints
  - NC Drill File
PCB Project Walk through Deliverables

**Fabrication Data (BARE PCB)**
- PCB
- Fabrication Drawing
- Output Job File (Fabrication Data)
  - Gerbers
  - IPC-2581
  - ODB++ File
  - PCB Prints
  - NC Drill File

**PCBA Data (ASSEMBLY)**
- Assembly Drawing
- Bill of Material (BOM)
- ActiveBOM
- Output Job File (Assembly Data)
  - Solder Paste Mask
  - Pick and Place Report
  - Test Point Report
- Schematic
PCB Project Walk through Deliverables

Fabrication Data (BARE PCB)
- PCB
- Fabrication Drawing
- Output Job File (Fabrication Data)
  - Gerbers
  - IPC-2581
  - ODB++ File
  - PCB Prints
  - NC Drill File

PCBA Data (ASSEMBLY)
- Assembly Drawing
- Bill of Material (BOM)
- ActiveBOM
- Output Job File (Assembly Data)
  - Solder Paste Mask
  - Pick and Place Report
  - Test Point Report
- Schematic

One Document left out: Schematic
PCB or PCBA Document?
Design Templates/Parameter Overview

**Templates**
- Document Templates:
  - Schematic
  - Draftsman Templates (Fab & Assy)
  - Bill of Material
  - Output Job Files

**Parameters**
Instead of specific Information Data Pointers are placed in.
- Types of Parameters
  - System
  - Project
  - PCB
  - Component Parameters
  - User Defined

**Design Development Resources**
Items that can be used in templates
- Layer Stackup
- Component Templates
- Project Templates.

**Fabrication Data (BARE PCB)**
- PCB
- Fabrication Drawing
- Output Job File (Fabrication Data)
  - Gerbers
  - IPC-2581
  - ODB++ File
  - PCB Prints
  - NC Drill File

**PCBA Data (ASSEMBLY)**
- Schematic
- Assembly Drawing
- Bill of Material (BOM)
- ActiveBOM
- Output Job File (Assembly Data)
  - Solder Paste Mask
  - Pick and Place Report
  - Test Point Report
  - Schematic
Creating and setting up - Schematic Template

Schematic Blank Template

1. Start with a blank sheet or a previous Template.
2. Can be selected under page options - Template, Standard or Custom Sheet.
3. Can either show or not the Margins and Zones.
Creating and setting up- Schematic Template

Placing the title Block

1st Option
Manually Drawing
Using the Graphic Tools

2nd Option Automatic Title Block
Standard

3rd Option- Use the Schematic Title Block Library

C:\Users\Public\Documents\Altium\AD18\Templates
File: Schematic Title Blocks
List of many Title blocks:
Creating and setting up - Schematic Template

Command: Project>Project Options>Parameters

Setting up our first USER PARAMETERS

Walk through Example

<table>
<thead>
<tr>
<th>PARAMETERS</th>
<th>INFO</th>
</tr>
</thead>
<tbody>
<tr>
<td>PCB Name</td>
<td>- Bare PCB</td>
</tr>
<tr>
<td>PCB Part Number</td>
<td>- 12345</td>
</tr>
<tr>
<td>PCB Revision</td>
<td>- 1.A.</td>
</tr>
</tbody>
</table>

Value is left blank will be filled in when the project is created
**Configuration and Use of Project and Output Template**

**Creating and setting up - Schematic Template**

**Command:** Project>Variants>Add Variant

**Setting up Variant Parameters**

1. Variants are created from the Schematic
2. To create the Variants must have at least a single component on the Template.
3. Add Variant
Creating and setting up - Schematic Template

Command: Project>Variants>Add Variant>Add

Setting up Variant Parameters

1. A detailed description of Variant is highly recommended
2. <Add> Adds a Parameter Property to that variant
3. Remembering our PCB Walk through
   Needed the following information:

Value is left blank will be filled in when the project is created
Creating and setting up - Schematic Template

Command: Project>Variants>Add Variant>Clone Selected Variant

Cloning Variants

1. With a completed Variant it is easy to add additional ones.
2. Select the completed Variant and Select Clone Selected Variant.
3. Required to place a new Description for each one.

Parameter Names should remain the same
Creating and setting up - Schematic Template

Command: Project>Project Options>Parameters

Completed setup of 3-Variants

Good practice to place several Variants in the template.
Creating and setting up - Schematic Template

Finishing the Schematic Template:

Blank Sheet with ANSI Title Block
Creating and setting up - Schematic Template

Finishing the Schematic Template: Available Parameters

<table>
<thead>
<tr>
<th>Parameters</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Address1</td>
<td>ItemRevision</td>
</tr>
<tr>
<td>Address2</td>
<td>ItemRevisionBase</td>
</tr>
<tr>
<td>Address3</td>
<td>ItemRevisionLevel1</td>
</tr>
<tr>
<td>Address4</td>
<td>ItemRevisionLevel1AndBase</td>
</tr>
<tr>
<td>Application Build Number</td>
<td>ItemRevisionLevel2</td>
</tr>
<tr>
<td>ApprovedBy</td>
<td>ItemRevisionLevel2AndLevel1</td>
</tr>
<tr>
<td>Author</td>
<td>ModifiedDate</td>
</tr>
<tr>
<td>CheckedBy</td>
<td>Organization</td>
</tr>
<tr>
<td>CompanyName</td>
<td>PCBConfigurationName</td>
</tr>
<tr>
<td>CurrentDate</td>
<td>ProjectName</td>
</tr>
<tr>
<td>CurrentTime</td>
<td>Revision</td>
</tr>
<tr>
<td>Date</td>
<td>Rule</td>
</tr>
<tr>
<td>DocumentFullPathAndName</td>
<td>SheetNumber</td>
</tr>
<tr>
<td>DocumentName</td>
<td>SheetTotal</td>
</tr>
<tr>
<td>DocumentNumber</td>
<td>Time</td>
</tr>
<tr>
<td>DrawnBy</td>
<td>Title</td>
</tr>
<tr>
<td>Engineer</td>
<td>VariantName</td>
</tr>
<tr>
<td>Image Path</td>
<td>VersionControl_PrfolderRevNumber</td>
</tr>
<tr>
<td>Item</td>
<td>VersionControl_RevNumber</td>
</tr>
<tr>
<td>ItemAndRevision</td>
<td></td>
</tr>
</tbody>
</table>
Creating and setting up - Schematic Template

Finishing the Schematic Template entering Parameters:

Blank Sheet with ANSI Title Block
Enter Data: Place > Text String
Select the desired Parameter.

Place > Drawing
Tools > Graphic
Creating and setting up - Schematic Template

Finishing the Schematic Template entering Parameters:

<table>
<thead>
<tr>
<th>Schematic</th>
<th>=VariantName</th>
</tr>
</thead>
<tbody>
<tr>
<td>Size</td>
<td>FCSM No.</td>
</tr>
<tr>
<td>B</td>
<td></td>
</tr>
</tbody>
</table>

Each Schematic will be unique based on the Variant used. So Variant Parameters are used:

- VariantName
- VariantNumber
- VariantRev
Creating and setting up - Schematic Template

Finishing the Schematic Template entering Parameters:

Multiple Parameters can be placed into a single text field
Syntax:

' of ' = Text
SheetNumber & SheetTotal
Parameters
All joined to together by +
(Plus sign)
Creating and setting up - Schematic Template

Finishing the Schematic Template entering Parameters:

Multiple Parameters can be placed into a single text field
Syntax:
'
of
'
= Text
SheetNumber & SheetTotal Parameters
All joined together by +
(Plus sign)

When done File > Save As > Advance Schematic Template (*.schdot)

Revision Control Parameters
For an SVN Design Repository
VersionControl_PrjFolderRevNumber
VersionControl_RevNumber
Project @5487
Document @5489
The PCB and Parameters

Since the PCB design will be a single Output. Will not have any Variant Parameters.

With the adding of the Draftsman feature, it is no longer needed to have so much information on the PCB layout.

Many very good parameters available Benefit many of these are updated automatically.
### Creating Draftsman SHEET Template

The information contained in this drawing is the sole property of Legrand. Any reproduction in part or as a whole without the written permission of Legrand is prohibited.

<table>
<thead>
<tr>
<th>Parameters Draftsman Sheet Template</th>
</tr>
</thead>
<tbody>
<tr>
<td>Arc_Count</td>
</tr>
<tr>
<td>BOMPageNumber</td>
</tr>
<tr>
<td>BOMTotalPages</td>
</tr>
<tr>
<td>Component_Count</td>
</tr>
<tr>
<td>Computer_Name</td>
</tr>
<tr>
<td>CurrentDate</td>
</tr>
<tr>
<td>CurrentTime</td>
</tr>
<tr>
<td>Date</td>
</tr>
<tr>
<td>DocumentFullPathAndName</td>
</tr>
<tr>
<td>DocumentName</td>
</tr>
<tr>
<td>DocumentScale</td>
</tr>
<tr>
<td>DocumentUnits</td>
</tr>
<tr>
<td>Fill_Count</td>
</tr>
<tr>
<td>FootprintName</td>
</tr>
<tr>
<td>Hole_Count</td>
</tr>
<tr>
<td>Item</td>
</tr>
<tr>
<td>ItemRevision</td>
</tr>
<tr>
<td>ItemRevisionBase</td>
</tr>
<tr>
<td>ItemRevisionLevel1</td>
</tr>
<tr>
<td>ItemRevisionLevel2</td>
</tr>
<tr>
<td>ModifiedDate</td>
</tr>
<tr>
<td>Net_Count</td>
</tr>
<tr>
<td>Pad_Count</td>
</tr>
</tbody>
</table>

- Project: =Project_Name
- PCBA Name: =Variant_Name
- Size: B
- PCB Number: =PCBNumber
- PCBA Number: =PCBNumber|VariantName
- Revision: =PCBRevNumber
- Repository Revisions: Document:
- Date Last Modified: 5/3/2018
Creating Draftsman Sheet Template

Configuration and Use of Project and Output Template

The Sheet template created in the first part is used.
Creating Draftsman Fabrication Template

The Sheet template created in the first part is used.

<table>
<thead>
<tr>
<th>Parameters Draftsman Doc Template</th>
</tr>
</thead>
<tbody>
<tr>
<td>ApprovedBy</td>
</tr>
<tr>
<td>ApprovedByManufacturer</td>
</tr>
<tr>
<td>Author</td>
</tr>
<tr>
<td>BOMPageNumber</td>
</tr>
<tr>
<td>BOMTotalPages</td>
</tr>
<tr>
<td>CheckedBy</td>
</tr>
<tr>
<td>CompanyName</td>
</tr>
<tr>
<td>ComponentName</td>
</tr>
<tr>
<td>CurrentDate</td>
</tr>
<tr>
<td>CurrentTime</td>
</tr>
<tr>
<td>Date</td>
</tr>
<tr>
<td>DocumentFullPathAndName</td>
</tr>
<tr>
<td>DocumentName</td>
</tr>
<tr>
<td>DocumentNumber</td>
</tr>
<tr>
<td>DocumentScale</td>
</tr>
<tr>
<td>DocumentUnits</td>
</tr>
<tr>
<td>DrawnBy</td>
</tr>
<tr>
<td>Engineer</td>
</tr>
<tr>
<td>FootprintName</td>
</tr>
</tbody>
</table>
Creating Draftsman Fabrication Template - Fabrication Notes

1. SPECIFICATIONS:
   1.1 Fabricated per IPC-R2-276, IPC-650A, Type 2, Class 2, latest revisions.
   1.2. Inspect per IPC-A-600, Class 2 latest revision.
   1.3. This drawing is to be used in conjunction with the providedgerber and drill data when applicable.

2. MATERIAL:
   2.1. Copper clad plastic sheet per IPC-4101 type GPN FR-4 (ROHS Compliance REQUIRED), UL Flammability 94V-0, Tg of 170°C or higher T6 of 340°C or greater
   2.2. Specific Material Shall be:
       - FP211/A2 / S1130
       - S11001/T-690°C/FK-160A/KS120B/FR-3160C
       - S114/1 / H140 / S1440 / 30440 / NY1140
       - S1141/K9/3040 / KS1200/U-1000C/T / 380°C/NY2150
       - S1170/KS-4140/K1000-2/1000C/NY2170
       - H140W / S5215 Hologen-free
       - H1600 / S1600 / S3116 High CT
   2.3. Glass Transition Temperature [Tg] will be 170°C or higher
   2.4. Decomposition Temperature [TD] will be 340°C or greater
   2.5. Overall PCB Laminate thickness to be 0.062 +/- 0.007
   2.6. PCB is Multi-Layer of 4 Layers
   2.7. Finished Copper weight on all layers shall be 1 Oz. Copper.

3. FINISH:
   3.1. PCB Plating:
       - ROHS Hut air solder leveling (HASL)
       - Immersion Tin
       - Immersion Silver
       - Electroless nickel immersion gold (ENIG)
       - Others
   3.2. PCB MARKING:
       - 3.2.1. Supplier to place
       - 3.2.2. Flammability rating marking of 94V-0 to be place in silkscreen on Component Side
       - 3.2.3. All PCB Markings to be in Non-Conductive White Enamel Ink
   3.3. Finished boards shall not have nicks, scratches, voids, exposed copper, poor plating, or modified holes.
   3.4. Outer layer trace width minimum is 0.006".
   3.5. No solder bleeding pads allowed.

4. CONTROLLED IMPEDANCE
   4.1. Not applicable.

5. REGISTRATION
   5.1. All layers to be within 0.005 of true position unless otherwise specified.

6. HOLES
   6.1. All holes are finished sizes.
   6.2. All holes to be within 0.003 from true position unless otherwise specified.
   6.3. Plate holes thru w/ copper 0.0010 min to 0.002 max thicknesses.
   6.4. An NC drill file has been supplied.
   6.5. See hole schedule for additional requirements.

7. FINGERS:
   7.1. None

8. SOLDERMASK:
   8.1. Soldermask over bare copper both sides using Green photo imageable Soldermask 0.003 max thickness.

9. SILKSCREEN:
   9.1. Silkmask on both side using white non-conductive epoxy or equivalent.
   9.2. No Silkmask is allowed on Bare Copper.
   9.3. Registration to be within 0.0010 from true position and must be a minimum of 3mm away from fiducial marks.
   9.4. Silkmask must pass peel test.

10. ELECTRICAL TEST
    10.1. Testing is required Test continuity on all bare tabs using bed of nail fixture or flying probe from the farthest extent of each trace using both sides if required.
    10.2. Adjacent traces must have a minimum surface resistance of 2.5M Ohms at 10V.
    10.3. Comparative Tracking Index (CTI) will be 100 CTK175
    10.4. Connectivity must match C08++ or IPC-D-356A Natfai.

11. CLEANLINESS
    11.1. Boards shall be free of fiber glass dust or any other foreign material.

12. PACKAGING
    12.1. Bag and tag with part number and revision on each lot.
    12.2. There shall be a max of 25 units per package, individually wrapped and shipped in cardboard cartons with sufficient surrounding material to prevent damage during shipping.

13. QC INSPECTION
    13.1. Confirm part number and/or ordering number.

14. Dimensions are in mm/mil
Creating Draftsman Assembly Template

The Sheet template created in the first part is used.

For Reference Files see:
a. Printed Circuit Board =VariantName =PCBNumber r=PCBRev
b. Schematic =VariantName =PCBANumber=VariantNumber r=VariantRev .SCHDOC
c. Part List: =VariantName =PCBANumber=VariantNumber r=VariantRev _BOM.XLS
Bill of Material Templates

In Excel-
- Must match the Parameter. Any Parameter information can be used in the BOM Template.
- Very common to have a library of BOM templates for various types of Output.
- Syntax- Column= <Fills in parameter information for each component
- For Example:
  Column=Designator  Will be filled with Designator information
Output Job Template

1. Common Release Directories
2. Data Organized into Container Type
3. The use of Parameters to name the specific Output Files

How to use Parameters in Output Files

Instead of specific information, use information parameters:

Parameters are setup throughout our design and Variants.

Syntax:

=VariantName+'-'+PCBANumber+''+VariantNumber+'-r'+VariantRev+'_'+OutputName

Example:

Parameter Information Joiner Text information
Creating a Project Template

Configuration and Use of Project and Output Template

- Schematic Sheets
- Fabrication Template
- Printed Circuit Board
- Layer Stackup
- BOM Template
- Assembly Template
- Fabrication Output Job File
- Assembly Output Job File
- ActiveBOM

Designer Preferences
AltiumLive 2018 Questions?