ALTIUMLIVE 2018:
3 hidden library attributes,
Filtering BOMs,
Adding daughter boards,
Running DRC in 3D.

Randy Burcham
IOTA Engineering
PCB Designer
David Rappaport

San Diego
October 3rd
Outline

1. 3 hidden attributes that you can add to your Altium Master libraries
2. How to add and use them to existing libraries
3. How to use them and extract BOMs
4. How to filter them using the Excel Auto BOM Filter template
5. A simple method to add a 3D model of daughter boards
6. How to run the DRC in 3D
Topics Covered

1. Why do we need to use hidden parameters in our library parts?
2. What hidden parameters would be helpful and why?
3. How can we add hidden parameters to existing libraries?
4. How can hidden parameters be used in our schematics?
5. How can hidden parameters in our library help filter BOMs?
6. How can we filter BOMs that Altium outputs?
7. How you can easily create and add daughter boards to main boards?
8. How you can run DRC in 3D on the main board to check for clearances?
Why do we need to use hidden parameters in our library parts? I.E. One BOM may not rule them all.

1. Some companies need a simplified BOM for their purchasing department.

2. Some companies need to one BOM for the SMT parts and another for the Thru-holed parts when they fabricate their PCBAs.

3. Some companies need a way to tell which parts are and are not to be installed in both the schematic and the BOMs.
What are the 3 Hidden parameters?

What hidden parameters would be helpful and why?

1. N/A - in both the Name and Value fields.
   A. Placeholder for schematic symbols that are not to be assembled,
   B. N/A is used with the reference designator in the schematic and for
      the filtering of BOMs.

2. Tech - in the Name field and either SMT or Thru in the Value field.
   A. This parameter is used in the filtering of BOMs when your company
      needs separate BOMs for assembly.

3. Unfitted - in the Name field and ? in the Value field.
   A. This parameter is also used in the filtering of BOMs and with the N/A
      parameter.
   B. This parameter can also be used with the Variants Sub-routine.
Part 1

1. Open the library, to the schematic,

2. You can add 2 parts to the beginning of your library.

3. In the first part, you will add the parameter with the name of N/A and the Value of N/A,

4. You will also add the parameter with the name of Tech and the Value of SMT,

5. Then you will add the parameter with the name of Unfitted and the Value of ?,

6. Do a File, Save All,

7. Do a copy/paste of this part and rename the new part and change the Value from SMT to Thru,

8. Do another File, Save All.
Part 2

1. From the schematic library, pull down the Tools menu and click on the Parameter Manager and click Ok,
2. Highlight the new N/A parameter in the N/A column, do a copy,
3. Highlight the rest of the N/A column and paste to fill the rest of the N/A column and click Yes,
4. Highlight the new SMT parameter in the Tech column, do a copy,
5. Highlight the rest of the SMT parts in the Tech column and paste to fill the rest of the SMT parts and click Yes,
6. Repeat for the Thru parameter in the Tech column, do another copy,
7. Highlight the rest of the Thru parts in the Tech column and paste to fill the rest of the Thru parts and click Yes,
8. Highlight the new ? parameter in the Unfitted column, do a copy,
9. Highlight the rest of the Unfitted parameter and paste to fill the rest of the Unfitted column and click Yes,
10. Click on the Validate Changes tab in the bottom left, then click on the Execute Changes tab and close,
11. To check your results, click on 1 of the other SMT parts and make sure that all of the added properties are correct,
12. If there are problems, go back and fix them, do a Save All,
13. Then click on 1 of the other Thru parts and make sure that all of their added properties are also correct,
14. If there are problems, go back and fix them, if not do a Save All, and re-compile the library.

Please note, if you have big libraries all of this will take some time.
How can hidden parameters be used in our schematics?

When you have a part that is not to be assembled

1. You copy the reference designator and paste it into the Value field of the Unfitted parameter,

Note, The reference designator and the Value field of the Unfitted parameter need to match each other.

2. You can turn off the visibility for the parts other parameters,

3. Turn on the visibility on the N/A,

4. Then place the N/A where you want it.
Generating the Master BOM

1. After the design is done, open the schematic,
2. Pull down the Reports menu and select the Bill of Materials option,
3. Turn on and setup the order of... LibRef, Quantity, Designator, Tech, Description, Unfitted
4. Choose the output name of the BOM file in the Export Field,
5. Make sure to add the extension, If you do not do this, you will end up with a test file.
6. Click the Save button.
1. Review the master BOM output

2. Cross check any information in the Unfitted column for reference designators that are different than what is shown in the Reference Designator column, IE. C4 in the list C1, C27, C44.

3. Look in the Unfitted column for any [NoValue] and remove them,

4. Save the changed file.
How can we filter BOMs that Altium outputs?

1. Open the Excel Auto BOM Filter template,
2. Open the Excel master BOM as well,
3. Excluding the first row, highlight and copy all rest of the used data from the master BOM,
4. Paste the data into box A2 of the Auto BOM Filter template,
5. Review the results and be amazed.
6. You can Copy/Paste the data from the Auto BOM Filter template for the various BOMs that you need.
### How can we filter BOMs that Altium outputs?

Continued

<table>
<thead>
<tr>
<th>AVL CONTAINS ALL INFORMATION</th>
<th>Rev-XX</th>
<th>ENTER BOM PN - SMT</th>
<th>PCR#</th>
<th>XXXXXXXX - XX</th>
</tr>
</thead>
<tbody>
<tr>
<td>PART NUMBER</td>
<td>QTY</td>
<td>ITEM / LOC</td>
<td>FROM</td>
<td>DESIGNATOR</td>
</tr>
<tr>
<td>-----------------</td>
<td>-----</td>
<td>-------------</td>
<td>------</td>
<td>------------</td>
</tr>
<tr>
<td>70590-000-A</td>
<td>1</td>
<td>R34</td>
<td></td>
<td></td>
</tr>
<tr>
<td>70590-100-A</td>
<td>1</td>
<td>R26</td>
<td></td>
<td></td>
</tr>
<tr>
<td>70590-332-A</td>
<td>2</td>
<td>R31, R32</td>
<td></td>
<td></td>
</tr>
<tr>
<td>70591-205-A</td>
<td>2</td>
<td>R21, R26</td>
<td></td>
<td></td>
</tr>
<tr>
<td>70591-560-A</td>
<td>2</td>
<td>R22, R25</td>
<td></td>
<td></td>
</tr>
<tr>
<td>70592-100-A</td>
<td>1</td>
<td>R19</td>
<td></td>
<td></td>
</tr>
<tr>
<td>70593-139-A</td>
<td>1</td>
<td>R29</td>
<td></td>
<td></td>
</tr>
<tr>
<td>70593-301-A</td>
<td>1</td>
<td>R17</td>
<td></td>
<td></td>
</tr>
<tr>
<td>70593-499-A</td>
<td>3</td>
<td>R18, R27, R28</td>
<td></td>
<td></td>
</tr>
<tr>
<td>70594-100-A</td>
<td>1</td>
<td>R24</td>
<td></td>
<td></td>
</tr>
<tr>
<td>70600-100-A</td>
<td>1</td>
<td>R14</td>
<td></td>
<td></td>
</tr>
<tr>
<td>70606-100-A</td>
<td>1</td>
<td>R12</td>
<td></td>
<td></td>
</tr>
<tr>
<td>70609-432-A</td>
<td>1</td>
<td>R15</td>
<td></td>
<td></td>
</tr>
<tr>
<td>70620-301-A</td>
<td>1</td>
<td>R41</td>
<td></td>
<td></td>
</tr>
<tr>
<td>70620-365-A</td>
<td>1</td>
<td>R11</td>
<td></td>
<td></td>
</tr>
<tr>
<td>70621-499-A</td>
<td>1</td>
<td>R16</td>
<td></td>
<td></td>
</tr>
<tr>
<td>70622-349-A</td>
<td>4</td>
<td>R5, R6, R7, R8</td>
<td></td>
<td></td>
</tr>
<tr>
<td>70622-562-A</td>
<td>4</td>
<td>R1, R2, R3, R4</td>
<td></td>
<td></td>
</tr>
<tr>
<td>70623-301-A</td>
<td>1</td>
<td>R9, R10</td>
<td></td>
<td></td>
</tr>
<tr>
<td>70624-310-A</td>
<td>5</td>
<td>R35</td>
<td></td>
<td></td>
</tr>
<tr>
<td>70649-68150-B</td>
<td>2</td>
<td>D1, D2</td>
<td></td>
<td></td>
</tr>
<tr>
<td>73418-018-T</td>
<td>2</td>
<td>D0, D4</td>
<td></td>
<td></td>
</tr>
<tr>
<td>74418-150-A</td>
<td>2</td>
<td>Q6, Q8</td>
<td></td>
<td></td>
</tr>
<tr>
<td>74431-200-A</td>
<td>1</td>
<td>Q9</td>
<td></td>
<td></td>
</tr>
<tr>
<td>74445-040-D</td>
<td>1</td>
<td>Q4</td>
<td></td>
<td></td>
</tr>
<tr>
<td>74450-102-B</td>
<td>1</td>
<td>D1</td>
<td></td>
<td></td>
</tr>
<tr>
<td>74490-800-B</td>
<td>1</td>
<td>D81</td>
<td></td>
<td></td>
</tr>
<tr>
<td>74495-700-A</td>
<td>3</td>
<td>G3, G4</td>
<td></td>
<td></td>
</tr>
<tr>
<td>74512-130-A</td>
<td>3</td>
<td>D5, D6, D7</td>
<td></td>
<td></td>
</tr>
<tr>
<td>7815-090-Y</td>
<td>1</td>
<td>C9</td>
<td></td>
<td></td>
</tr>
<tr>
<td>7815-330-Y</td>
<td>1</td>
<td>C16</td>
<td></td>
<td></td>
</tr>
<tr>
<td>8200-202-Y</td>
<td>1</td>
<td>C20, C21</td>
<td></td>
<td></td>
</tr>
<tr>
<td>8310-005-D1</td>
<td>1</td>
<td>T2</td>
<td></td>
<td></td>
</tr>
<tr>
<td>8311-228-B-Ax1</td>
<td>1</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>8300-005-D1</td>
<td>1</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>NOT POPULATED</td>
<td>0</td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
Setting up an Assembly Library

1. Make or open a separate library for your Assembly designs,
   This will become a very large library very fast and you do not want it to conflict with your main library or libraries.

2. After you have completed the design for the daughter board,

3. Open the daughter board design and pull down the File menu from the top,

4. Select the Export sub-menu and slide right, then select the Step 3D sub-menu,

5. Chose the name for the daughter card assembly and put it into the File Name box,
   Make sure that you include the step extension and make a note of the data path.

6. Click on the OK tab,

7. After the script is run, click the OK tab to get out,

8. Do a File, Save All from the top menu.
Creating the Assembly PCB footprint

1. Open up your both parts of your Assembly Library,
2. Create a new footprint in the Assembly PCB Library,
3. Place a pad at the X 0, Y 0,
   Make sure that the pad and drill are the correct size for the assembly.
4. With the Properties window open, pull down the Place tab at the top,
5. Slide down to the 3D Body tab and click on it,
6. Click on Generic tab in the Properties tab and then click on the Choose tab in the 3D Model Type section,
Creating the Assembly PCB footprint continued

7. Navigate to the daughter card database, select the step file and click Open,
8. Rotate and position the 3D image so that the Pin 1 is positioned in the center of pin 1,
9. Select the pad and copy it, then Paste it onto all of the other pins positions,
   If you setup the grid for the pin to pin spacing, you can set the pins faster.
10. Renumber the other pins to match the connector that is on the daughter card,
11. From the PCB Library menu, highlight the footprint,
12. Add the an outline of the board and connector to the top silkscreen layer,
   The 2 outlines will help place and show where the daughter board goes.
13. Right mouse click and rename the footprint to the name and description of the assembly footprint,
14. Do a File, Save All from the top menu.
Creating the Assembly SCH symbol

1. From the SCH portion of your Assembly Library,
2. Either copy/paste an existing part or create a new one,
3. Make sure that you have all of the required pins for the interface with the main board,
4. Name the pins with the signal names that were used from the daughter board interface,
5. From the PCB portion of the Assemble Library, Highlight the footprint that you will use with the new part and make a copy of its name,
6. Switch back to the schematic portion of your Assembly Library,
7. Double click on the part number to open the Properties menu,
8. Click on the Add tab of the Footprint section,
9. Either Paste in the Name of the footprint or navigate using the Browse tab to select the footprint,
10. Click on the OK tab to set it and pull down the Project menu from the top,
11. Click on the Compile Integrated Library,
12. if problems fix them or review the parts and verify that the new part was added to the Assembly Library.
13. Do a File, Save All.
Adding the Daughter board to the Main board

1. Open the main board project file and its SCH file,
2. Navigate to your Assembly Library and add the schematic symbol for the daughter board to your main design schematic,
3. Do a File Save All from the top menu,
4. From the top, pull down the Project menu and click on the Compile PCB Project,
5. From the top, pull down the Design menu and click on the Update PCB Document,
6. Select the desired Component Links,
7. Click on the Perform Update tab and click Ok,
8. Validate Changes and Execute Changes and click Close,
9. Position the daughter board where you want it.
Running a 3D DRC between the main PCB and any daughter cards

1. Place the daughter board in the position on the main board,

2. Setup your Main board Design Rules for the Placement Component Clearance spacing,
   This gives you the 3D clearance between the Daughter and the Main board.

3. From the top menu, select the Tools and pull down the Reset Error Markers,

4. Now from the top menu, run the Tools Design Rule Check and click on Run Design Rule Check,

5. Look and repair any conflicts that you find,

6. Do a File, Save All.
Key take-aways, Running 3D DRCs

1. You can add and use hidden parameters in your library parts to help filter BOMs.

2. You can hide or keep parameters hidden in your schematics to help explain which parts are or are not to be used.

3. The hidden parameter Unfitted is compatible with the Variants Sub-routine.

4. You can do copy/paste and rename in the schematic part of the library.

5. You can use Tools, Parameter Manager to globally edit and update the SCH library.

6. Due to the use of mixed technologies, few BOMs can be used for everything.

7. You may need 1 BOM for the assembly of all SMT components on a PCBA, another for the Thru-Holed components on the same PCBA and you may need to divide, subtract or cross reference Not/Assembled (N/A) parts.

8. Altium Designer can output a master BOM that can be separated into all of the BOMs talked about above.

9. You can use the Excel Auto BOM Filter template to do the filtering.

10. You can simply create Sub-Assemblies of daughter cards and add them into main PCB designs.

11. You can run a 3D DRC to verify that there are not any conflicts between the main PCB and any daughter cards.
Questions?

Comments?

Thank You and Muchas Gracias