KB: Release de projeto vazio causado pela configuração do caminho de saída

Altium Designer Altium Designer
Se a liberação de um projeto for concluída, mas produzir um pacote de liberação vazio ou não gerar o conteúdo esperado do OutJob, o local de saída configurado pode estar impedindo que os dados da liberação sejam gravados corretamente. Isso pode ocorrer quando o Caminho de saída ou o Caminho do log de ECO aponta para um local inacessível ou situado em uma unidade diferente daquela em que está o projeto local. Atualizar esses caminhos para uma pasta acessível na mesma unidade do projeto local pode permitir que o Project Releaser gere os arquivos de liberação esperados.

Detalhes da solução

A liberação do projeto parece vazia após a conclusão

A liberação de um projeto pode ser concluída com sucesso, mas o pacote de liberação gerado parece vazio ou as saídas personalizadas esperadas do OutJob estão ausentes.

Altium Designer Server Release workflow on Review Data step, listing included outputs: source data, fabrication data, assembly data for no variant, and assembly data for a TEST variant, each with status indicators and Explore/Details links.

Não é possível gravar os arquivos de saída com sucesso

Suspeita-se que este problema esteja relacionado ao diretório de saída configurado. Se o Altium não conseguir acessar ou gravar de forma confiável no local de saída especificado, os arquivos da liberação podem não ser gerados no local esperado. Como essas configurações de caminho são armazenadas no projeto, o problema pode persistir até que a configuração seja atualizada.

Use locais de saída do projeto acessíveis

  • Atualize o caminho de saída para uma pasta local.
  • Use um local de saída acessível ao usuário atual.
  • Certifique-se de que Output Path e ECO Log Path estejam na mesma unidade que o projeto local.
  • Verifique se as configurações necessárias do OutJob existem e estão configuradas corretamente.

Atualize a configuração do caminho de saída

  1. Abra o projeto.
  2. Clique com o botão direito do mouse no projeto e selecione Explore; em seguida, anote o local do arquivo do projeto.

    Altium Designer Projects panel context menu with Explore selected, opening Windows File Explorer to the BOM Testing project folder at C:\Users\Public\Documents\Altium\BOM Testing.

  3. Abra Project Options selecionando Project » Project Options, ou clique com o botão direito do mouse no projeto no painel Projects e selecione Project Options.

    Altium Designer Project menu open, showing project management commands and the Project Options entry selected, indicating the path to access project settings for BOM Testing.PrjPcb.

  4. Selecione a aba Options.
  5. Atualize Output Path e ECO Log Path para que apontem para pastas na mesma unidade que o projeto local.

    Altium Designer Options dialog for a PCB project, showing Output Options with Output Path and ECO Log Path set to local folders for BOM Testing, along with netlist, cross‑reference, and annotation settings.

  6. Salve as alterações.
  7. Execute novamente a liberação do projeto.

Referências

AI-LocalizedLocalizado por IA
Caso encontre um problema, selecione o texto/imagem e primaCtrl + Enterpara nos enviar o seu feedback.
Contents
Was this article helpful?