KB: Linhas de grade não visíveis no layout da PCB

Altium Designer Altium Designer
Se as linhas ou os pontos da grade não estiverem visíveis no editor de PCB, o problema pode estar relacionado às configurações de finalidade da grade, à visibilidade global da grade, à configuração de exibição ou às configurações de cor da grade. A visibilidade da grade é controlada pelas configurações Comp e Non Comp da grade, pela opção global Show Grid e pelas configurações de exibição Fine e Coarse da grade. Em alguns casos, uma grade pode continuar influenciando o encaixe dos objetos mesmo quando não está sendo exibida. Este artigo explica como verificar a configuração da grade, restaurar sua visibilidade e ajustar as opções de exibição para torná-la visível na área de trabalho de layout da PCB.

Detalhes da solução

As linhas da grade não estão visíveis

A grade do editor de PCB não está visível, embora uma grade tenha sido configurada e o documento de PCB esteja aberto. As linhas ou os pontos esperados da grade podem não aparecer durante as operações normais de edição, durante a movimentação de componentes ou em ambas as situações. Os objetos ainda podem se ajustar à grade mesmo quando ela não é exibida.

Várias configurações controlam a exibição da grade

A visibilidade da grade depende de várias configurações. Uma grade pode ficar oculta com base em sua configuração de Comp e Non Comp, na opção global Show Grid ou em suas configurações individuais de exibição. Se Comp e Non Comp estiverem desativados, a grade não ficará visível, mas ainda poderá ser aplicada de acordo com as configurações atuais de ajuste à grade. Uma grade também não ficará visível se as opções de exibição Fine e Coarse estiverem ambas configuradas como Do Not Draw. Cores de grade com contraste insuficiente podem dificultar a visualização de uma grade exibida.

Verifique as configurações de visibilidade e exibição

  • Certifique-se de que Non Comp esteja ativado para a grade em questão se ela precisar ficar visível durante as operações normais de edição.
  • Se a grade precisar ficar visível durante a movimentação de componentes, certifique-se de que Comp esteja ativado para a grade em questão.
  • Certifique-se de que a opção global Show Grid esteja ativada.
  • Configure pelo menos uma das opções de exibição Fine ou Coarse para usar Lines ou Dots, e não Do Not Draw.
  • Verifique se as cores configuradas para a grade estão claramente visíveis em relação ao fundo da área de trabalho.
  • Se a grade estiver visível, mas for difícil distingui-la, alterne o estilo de exibição da grade entre linhas e pontos.

Revise a configuração da grade

  1. Abra o documento de PCB.
  2. Limpe as seleções existentes usando Shift+C, se necessário.
  3. Abra o painel Properties.
  4. Verifique se o painel está no modo Board .
  5. Selecione a guia General e localize a seção Grid Manager.
  6. Localize a grade em questão. A grade padrão se chama Global Board Snap Grid.
  7. Verifique se Non Comp está ativado caso a grade precise ficar visível durante as atividades normais de edição.
    Properties panel, Grid Manager section showing Global Board Snap Grid with Comp and Non Comp options enabled.
  8. Abra o painel View Configuration. Pressione Ctrl+D para abrir o painel com a guia View Options exibida ou pressione L para abri-lo com a guia Layers & Colors exibida.
  9. Selecione a guia View Options.
  10. Na seção General Settings, verifique se Show Grid está ativado.
    View Configuration panel, View Options tab, showing General Settings with Show Grid enabled.
  11. Se a grade ainda não estiver visível, retorne a Properties » Board » General » Grid Manager.
  12. Clique duas vezes na grade em questão ou pressione Ctrl+G enquanto o cursor estiver posicionado sobre a região da grade no editor de PCB.
  13. Na caixa de diálogo do editor de grade, revise as configurações de Display.
  14. Verifique se as opções de exibição Fine e Coarse não estão definidas como Do Not Draw.
  15. Revise as configurações de cores da grade, se necessário, usando os controles de cores disponíveis.
    Cartesian Grid Editor dialog showing Global Board Snap Grid display settings, with Fine and Coarse grid styles set to Lines and Multiplier set to 10x Grid Step.
  16. Se o problema ocorrer apenas durante a movimentação de componentes, verifique em Properties » Board » General » Grid Manager se Comp está ativado para a grade em questão. 

Observações adicionais

A Global Board Snap Grid padrão sempre existe e se aplica a todo o espaço de projeto, embora seja exibida apenas sobre o contorno da placa. A grade pode ser modificada, mas não pode ser renomeada, excluída nem desativada. Sua prioridade é fixada no nível mais baixo.

Referências

AI-LocalizedLocalizado por IA
Caso encontre um problema, selecione o texto/imagem e primaCtrl + Enterpara nos enviar o seu feedback.