Altium Designer Documentation

Часто задаваемые вопросы по Altium 365

Created: 23.04.2020 | Updated: 05.06.2021

Содержание

Полное содержание
Для получения дополнительных ответов на вопросы, которые у вас могут возникнуть касательно Altium 365, посмотрите Базу знаний Altium, содержимое которой обновляется в соответствии с вопросами, ежедневно поступающими в службу поддержки.

Общие вопросы

Что такое Altium 365? Это продукт или платформа?

Altium 365 – это облачная платформа инфраструктуры, используемая для размещения приложений Altium в облаке. Это платформа, а не продукт, соответственно, вы не можете купить или загрузить Altium 365. Altium 365 является, своего рода, операционной системой для облачных приложений Altium. Подобно тому, как Windows позволяет запускать программные приложения на вашем локальном компьютере, так платформа Altium 365 позволяет запускать продукты Altium в облаке.

Какие продукты Altium запускаются в Altium 365 на сегодняшний день?

На сегодняшний день, в Altium 365 доступны Altium 365 Workspace и Altium 365 Viewer. Со временем будут добавлены другие продукты.

Доступ к Altium 365 Workspace является частью плана подписки Altium Subscription. Планы подписки Standard и Pro предоставит вам возможность активировать один Altium 365 Workspace для компании, который является облачным сервером, размещенным на платформе Altium 365.

Как мне получить доступ к Altium 365?

Altium 365 – это платформа, а не продукт. Платформа Altium 365 обеспечивает взаимодействие с различными продуктами и службами. Существует три уровня доступа к платформе Altium 365 и ее службам:

Personal – для тех, кто хочет использовать возможности совместной работы, предоставляемые Altium 365, без необходимости в подключении к Workspace, где хранятся данные. Поддерживается постоянное хранение "слепков" проектов (из различных ECAD-систем) и производственных данных Gerber в платформе Altium 365, с возможностью их публикации кому угодно для комментирования и добавления пометок. Существует также веб-доступ к проектам, находящимся в разработке (для просмотра и комментирования), которые были опубликованы за пределы Workspace.

Нужна регистрация на AltiumLive, но не активный план подписки Altium Subscription. Нет настоящей интеграции с Altium Designer, функциональные возможности доступны в основном через веб-браузер.

  • Standard – для тех, кто хочет использовать все преимущества глобальной публикации Altium 365 и удобство хранения проектов и компонентов в едином Workspace компании, но без формализации и структурирования проектных данных. Предлагается возможность хранения и публикации динамических проектов с кем угодно для просмотра и комментирования или редактирования и использования простой облачной библиотеки компонентов. Также включена поддержка совместного проектирования ECAD-MCAD.

    Нужна регистрация на AltiumLive и Altium Designer с активным планом подписки Standard. Функциональные возможности доступны из Altium Designer и через веб-браузер.

  • Pro – для тех, кто хочет использовать все возможности формализации и структурирования проектных данных и всё, что может предложить платформа Altium 365. Все ваши управляемые данные создаются и хранятся в едином Workspace компании. Предлагается возможность хранения и публикации динамических проектов с кем угодно для просмотра и комментирования или редактирования. Также включена расширенная поддержка совместного проектирования ECAD-MCAD. Становятся доступными дополнительные службы и возможности, приобретенные с Concord Pro, в том числе полностью управляемые компоненты с их валидацией и контролем применяемости, шаблоны компонентов, управляемые файлы OutJob и запросы компонентов.

    Нужна регистрация на AltiumLive и Altium Designer с активным планом подписки Pro. Функциональные возможности доступны из Altium Designer и через веб-браузер.

Кроме того, вы можете использовать Altium 365 через отдельное средство просмотра Altium 365 Viewer, которое обеспечивает бесплатный просмотр и публикацию проектов электроники (на определенный срок) через веб-браузер. Нет необходимости в загрузке, установке и регистрации на AltiumLive.

Нет ограничения на доступ к интерфейсу платформы Altium 365 через веб-браузер. Доступ к Workspace через веб-интерфейс или из MCAD-системы бесплатен. План подписки Altium Subscription нужен только в том случае, если вы хотите подключаться к Altium 365 (и, в частности, к Altium 365 Workspace) из Altium Designer.
Чтобы увидеть подробный список того, что доступно в планах подписки Standard/Pro, посмотрите Полное сравнение планов.

Какова стоимость доступа к Altium 365?

Altium 365 – это платформа, а не продукт. Соответственно, нет платы за Altium 365, поскольку платформа не является тем, что можно приобрести. Использование, или точнее доступ к Altium 365 основан на вашем взаимоотношении с Altium. См. предыдущий вопрос о том, как получить доступ к Altium 365.

Как мои данные защищены в Altium 365?

Перейдите на страницу Безопасность в Altium 365.

Как мне получить доступ к своим данным Altium 365 офлайн?

Altium 365 – это платформа, а не продукт. Здесь нет данных для доступа к ним. Тем не менее, данные из вашего Altium 365 Workspace (размещенного на платформе Altium 365) кэшируются локально, и они доступны вам в случае, если вы окажетесь офлайн. При открытии проектов из Workspace они локально копируются для офлайн-доступа. То же самое справедливо и для компонентов – панель Components кэширует все данные о компонентах, необходимые для локального размещения и ECO. Тем не менее, обратите внимание, что когда вы находитесь офлайн, новые компоненты/проекты не могут быть созданы в Workspace и проекты не могут быть зафиксированы в Workspace.

Где находится сервер? Будет ли запаздывание?

По всему миру есть четыре региональных сервера: в Азии, в Европе, на Западном побережье США, на Восточном побережье США.

Нужно ли мне загружать Altium 365?

Нет, Altium 365 – это облачная платформа, здесь ничего не нужно загружать.

Сколько пользователей может одновременно получить доступ к Workspace на Altium 365?

Нет ограничений на следующее:

  • Количество пользователей, которые могут подключаться к Workspace из веб-интерфейса.
  • Количество пользователей, которые могут подключаться к Workspace из Altium Designer (естественно, это количество ограничено числом лицензированных рабочих мест Altium Designer с активным планом подписки Altium Subscription).
  • Количество пользователей, которые могут быть добавлены в команду этого экземпляра Workspace.
  • Количество MCAD-инженеров, подключающихся и осуществляющих совместную работу над проектами, которые управляются экземпляром Workspace.

Все ли веб-браузеры поддерживаются для просмотра Altium 365?

Официально поддерживаемые веб-браузеры обозначены здесь.

Здесь регулярно упоминается термин Workspace. Что это?

Workspace является выделенным облачным сервером для всех ваших управляемых данных. Он обеспечивает бесшовную связь и механизмы передачи данных между областями проектирования, производства и поставки. Интерактивная совместная работа в ECAD с помощью браузера, для которой не нужны инструменты или знания о них для тех, кто использует этот сервер. Это взаимосвязь проектировщиков ECAD, отдела закупки и производителей печатных плат, которая делает их работу простой как никогда прежде. Это изолированная безопасная среда, где вы управляете составом участников, настройками, параметрами по умолчанию и т.д. Это расположение, где хранятся все ваши данные о проектах и компонентах. Управление доступом к Workspace осуществляется через приглашение людей в команду этого Workspace – как правило, это сотрудники организации.

Где размещаются Workspace?

Для построения платформы Altium 365 мы используем инфраструктуру Amazon AWS. По всему миру есть четыре региональных сервера: в Азии, в Европе, на Западном побережье США, на Восточном побережье США. При активации Workspace для своей организации вы можете выбрать, где он будет размещен. После того, как расположение выбрано, данные остаются в этом регионе, так что вы можете управлять их физическим расположением.

Есть ли какая-либо доступная документация по Altium 365?

При подключении к Workspace, страница Get Started интерфейса предоставляет доступ к руководству по быстрому началу работы с Altium 365. Также вам будут доступны дополнительные ресурсы:

  • Руководство Altium 365 Getting Started User Guide – доступно на сайте my.altium.com.
  • Полная техническая документация по Altium 365, главная страница которой находится здесь.

Каковы ограничения на хранение для Workspace на Altium 365?

Здесь нет каких-либо жестких ограничений, и действует справедливая политика использования. В случае чрезмерного использования сервиса и потребления ресурсов на уровне, значительно превышающем средний показатель, мы будем работать с вами индивидуально, чтобы найти решение.

Можно ли использовать Workspace на Altium 365 для выпуска проектных документов контрактному изготовителю или производителю печатных плат?

Вы можете отправить производителю пакет для производства (Manufacturing Package), созданный из определенного выпуска проекта, непосредственно через веб-интерфейс Workspace:

  1. Выпустите проект в Workspace с помощью средства Project Releaser Altium Designer.
  2. В веб-интерфейсе Workspace перейдите на страницу Projects, затем дважды щелкните ЛКМ по проекту, чтобы открыть страницу подробного управления этого проекта.
  3. Перейдите в представление Releases и нажмите кнопку того выпуска, который вы хотите отправить.
  4. Будет открыто окно Sending to Manufacturer, в котором вы можете настроить содержимое пакета и то, кому он будет отправлен.
Производитель получит email-приглашение для доступа к пакету на Altium 365. После того, как они нажмут кнопку в email, они будут отправлены на страницу Altium 365 Sign In (Вход в Altium 365). После входа они перейдут в просмотрщик Manufacturing Package Viewer с загруженным пакетом, который был опубликован. Если у производителя нет учетной записи AltiumLive, ему нужно сначала зарегистрировать ее, что можно сделать по ссылке на странице Altium 365 Sign In.

Сколько Workspace на Altium 365 может быть у моей компании?

На одну компанию может быть активирован один Altium 365 Workspace. Это обеспечит единый источник достоверных проектных данных – единое расположение для создания и хранения всех проектных данных компании (проекты, компоненты, шаблоны и т.д.) с высокой степенью целостности. Единый источник, к которому все инженеры могут обращаться за "строительными блоками", которые необходимы им для будущих проектов. Единый центральный узел проектирования, обеспечивающий глобальную совместную работу.

Какие версии Altium Designer поддерживаются?

Следуя лучшим в отрасли практикам в сфере безопасности и целостности данных, Altium 365 поддерживает TLS (Transport Layer Security – Протокол защиты транспортного уровня) 1.2. Поэтому для возможности подключения к Altium 365 Workspace из системы проектирования необходимо использовать Altium Designer 20.1.14 или более новую версию, которая включает в себя поддержку TLS 1.2. Всегда рекомендуется использовать самую новую версию Altium Designer.


Подключение к Workspace на Altium 365

Как мне активировать Workspace своей компании?

Если вы являетесь пользователем, добавленным Altium в аккаунт вашей компании, и у этого аккаунта есть лицензии Altium Designer с активной подпиской Altium Designer и у вашей компании еще нет активированного Workspace, вам будут даны инструкции для этого. Для этого существует несколько расположений с элементами управления:

Для возможности активировать и использовать Workspace для своей компании необходимо зарегистрироваться на AltiumLive и иметь активный план подписки Altium Subscription для Altium Designer. Если у вашей компании нет активного плана Altium Subscription для лицензий Altium Designer, вы будете уведомлены об этом и направлены на страницу https://www.altium.com/subscription для дополнительной информации.
  • Со страницы https://www.altium.com/subscription/start-now – следуйте инструкции по входу в учетную запись Altium и активации Workspace компании. Если у вас нет учетной записи, вы зарегистрироваться отсюда и выбрать план подписки.
  • Со страницы altium.com/365-intro/workspace, где на любой странице доступен элемент управления для активации Workspace.
  • Из интерфейса платформы Altium 365 – в общем разделе Workspace, который представлен в персональном пространстве, доступен соответствующий элемент управления.
  • Со страницы профиля AltiumLive – элемент управления представлен в области Workspaces страницы.
  • Из Altium Designer – в большинстве функций, требующих подключения к Workspace, будет представлен элемент управления для его активации, если это необходимо.

В любом из этих мест нажмите по доступному элементу управления, чтобы начать процесс активации Workspace. Вы перейдете непосредственно на отдельную веб-страницу (https://www.altium.com/365-intro/activate-new) для этого. Процесс выполняется в несколько шагов:

  1. Введите желаемое название Workspace. По умолчанию это поле будет предварительно заполнено названием вашего аккаунта Altium.
  2. Из выпадающего списка выберите самое близкое к вам и вашей команде расположение. По умолчанию будет предварительно выбрано расположение на основе записи Country из контактной информации профиля AltiumLive.
  3. Добавьте опциональное описание.
  4. Выберите, хотите ли вы создавать в Workspace образец данных. Это может быть удобным, поскольку у вас будет набор проектов, компонентов и шаблонов, с помощью которых вы сможете изучить возможности Workspace. Для этого оставьте опцию Include sample data включенной.
  5. Нажмите .
  6. Нажмите Activate.
После активации Workspace для своей организации или добавления в команду Workspace вы сможете открыть веб-интерфейс этого Workspace непосредственно при входе в интерфейс платформы Altium 365 (https://365.altium.com).

Как подключиться к Workspace из Altium Designer?

  1. Сначала убедитесь, что вы вошли в свою учетную запись AltiumLive из Altium Designer. Для этого щелкните ЛКМ по элементу управления в верхней правой части главного окна приложения, затем выберите запись в соответствующем меню. Используйте открывшееся диалоговое окно Sign In для ввода своих учетных данных AltiumLive, затем нажмите . Либо войдите с помощью своей учетной записи Google® или Facebook® и свяжите эту учетную запись со своей учетной записью AltiumLive. Если у вас нет учетной записи AltiumLive, вы можете щелкнуть ЛКМ по элементу управления для ее создания.

    Если у вас план подписки Pro и в вашей организации настроен вход SAML Single Sign-On (SSO) с поставщиком идентификации (например, Okta®), вы можете войти в Altium 365 (а точнее, в AltiumLive) с его помощью, нажав кнопку .

    То, как вы можете осуществлять вход в учетную запись Altium своей организации, определяется администратором этой учетной записи на странице Authentication в Altium Dashboard. На этой странице администратор может настроить и включить SSO для AltiumLive (службу). Будет необходимо настроить SAML для вашего поставщика учетных записей (Identity Provider, IDP) путем загрузки файла Metadata XML, полученного от этого поставщика, либо настроив SSO-подключение вручную.
    Связанные учетные записи (Google® или Facebook®) будут приведены в списке на вашей странице профиля AltiumLive. Здесь доступны элементы управления для удаления связи с этими учетными записями, если необходимо.
  2. Далее нажмите в правой верхней части главного окна приложения. В открывшемся меню будет приведен список всех доступных вам Workspace, состоящий из двух разделов:
    • My Workspaces – Workspace, активированный вашей организацией, в который вы были добавлены как член команды. Обратите внимание, что для отдельной организации может быть активирован один Workspace.
    • Shared With Me – Workspace других организаций, в которые вы были приглашены и, соответственно, в которые вы были добавлены как член команды.

    Щелкните ЛКМ по записи определенного Workspace, к которому вы хотите подключиться.

Для получения более подробной информации перейдите на страницу Доступ из Altium Designer.

Как подключиться к своему Workspace из веб-браузера?

Веб-интерфейс Workspace является, по сути, составной частью общего интерфейса платформы Altium 365. Быстро получить доступ к этому интерфейсу можно следующими способами:

  • Откройте интерфейс платформы Altium 365 через прямой URL: https://365.altium.com. Войдите с помощью своих учетных данных AltiumLive либо с помощью своего аккаунта Google® или Facebook® и свяжите этот аккаунт со своей учетной записью AltiumLive. Если у вас нет учетной записи AltiumLive, вы можете щелкнуть ЛКМ по элементу управления для ее создания.

    Если у вас план подписки Pro и в вашей организации настроено использование SAML в качестве технологии единого входа (Single Sign-On, SSO) с поставщиком учетных записей (например, Okta®), то вы можете войти в Altium 365 (или, точнее, в AltiumLive) с его помощью, нажав кнопку .

    То, как вы можете осуществлять вход в учетную запись Altium своей организации, определяется администратором этой учетной записи на странице Authentication в Altium Dashboard. На этой странице администратор может настроить и включить SSO для AltiumLive (службу). Будет необходимо настроить SAML для вашего поставщика учетных записей (Identity Provider, IDP) путем загрузки файла Metadata XML, полученного от этого поставщика, либо настроив SSO-подключение вручную.
    Связанные учетные записи (Google® или Facebook®) будут приведены в списке на вашей странице профиля AltiumLive. Здесь доступны элементы управления для удаления связи с этими учетными записями, если необходимо.

    Будет представлен интерфейс платформы Altium 365. Запись вверху справа отображает, что вы в данный момент вошли в интерфейс, а также ваше изображение (если оно задано) и либо название активного Workspace (если вы вошли в Workspace) или My Personal Space (если вы вошли в персональное пространство). Щелкните ЛКМ по этой записи, чтобы вызвать меню, в котором представлен список доступных вам Workspace – щелкните ЛКМ, чтобы переключиться.

  • Войдите в AltiumLive, затем щелкните ЛКМ по своей фотографии/изображения в правой части верхнего баннера страниц веб-сайта altium.com. Будет открыто меню аккаунта AltiumLive, где доступен список доступных вам Workspace. Щелкните ЛКМ по названию определенного Workspace, который вы хотите вызвать. Будет открыт интерфейс платформы Altium 365 с загруженным Workspace, который был выбран.
  • Войдите в AltiumLive, откройте страницу своего профиля AltiumLive (с помощью URL: https://accounts.live.altium.com/), затем щелкните ЛКМ по названию определенного Workspace, который вы хотите вызвать. Будет открыт интерфейс платформы Altium 365 с загруженным Workspace, который был выбран.

Существуют ли какие-либо дополнительные требования к IT или документация по использованию синхронизации компонентов (PLM), например порты, или в целом по доступу к Workspace на Altium 365?

Всё, что необходимо, это доступ к Интернету и бесперебойный доступ к ресурсам altium.com по протоколу https (использующем порт 443). Мы можем проконсультировать вас, если вашему IT-отделу нужен определенный список доменных имен, диапазоны IP-адресов или если у вас сложные настройки прокси.

Также проверьте настройки файервола вашей компании. Должен быть разрешен доступ к следующим URL:

  • portal365.altium.com
  • *.api.altium.com

Следуя лучшим в отрасли практикам в сфере безопасности и целостности данных, Altium 365 поддерживает TLS (Transport Layer Security – Протокол защиты транспортного уровня) 1.2. Что касается Altium Designer, необходимо использовать версию 20.1.14 или более новую, которая включает в себя поддержку TLS 1.2.

Мы можем проконсультировать вас, если вашему IT-отделу нужен определенный список доменных имен, диапазоны IP-адресов или если у вас сложные настройки прокси.

Могу ли я изменить URL сервера для своего Workspace?

Да, это осуществляется на странице Admin - Settings - General веб-интерфейса Workspace, как показано на изображении ниже.

Обратите внимание, что эти изменения может выполнить только администратор, который также является владельцем Workspace, но не какой-либо другой администратор этого Workspace.

Почему я больше не могу подключиться к Altium 365 из Altium Designer?

Следуя лучшим в отрасли практикам в сфере безопасности и целостности данных, Altium 365 поддерживает TLS (Transport Layer Security – Протокол защиты транспортного уровня) 1.2. Поэтому для возможности подключения к Altium 365 Workspace из системы проектирования необходимо использовать Altium Designer 20.1.14 или более новую версию, которая включает в себя поддержку TLS 1.2.

Если вы используете Altium Designer версии более ранней, чем 20.1.14, то при попытке подключиться к Altium 365 Workspace появится следующая ошибка:

"An error occurred while making the HTTP request to https://xxx.365.altium.com/servicexxx. This could be due to the fact that the server certificate is not configured properly with HTTP.SYS in the HTTPS case. This could also be caused by a mismatch of the security binding between the client and the server."

Для обеспечения бесперебойного использования Altium 365 в своей компании:

  • Убедитесь, что используется версия Altium Designer 20.1.14 или более поздняя.
  • Проверьте настройки файервола своей компании. Должен быть разрешен доступ по следующим URL:
    • portal365.altium.com
    • *.api.altium.com

Компоненты

Как выгрузить существующие компоненты в Workspace?

Altium Designer обеспечивает простой процесс для быстрой миграции существующих библиотек в Altium 365 Workspace. Пользовательский интерфейс этого процесса – Library Migrator – представляет интуитивно понятный порядок действий, который мигрирует изначально выбранные библиотеки в Workspace. Средство Library Migrator позволяет обрабатывать все типы библиотек, связанных со старыми методологиями управления компонентами (SCHLIB, PCBLIB, INTLIB, DBLIB, SVNDBLIB), что делает его идеальным решением для быстрого создания набора управляемых компонентов предприятия и последующего использования всех преимуществ таких компонентов: высокая целостность данных, управление жизненными циклами, централизованное хранение и управление, изучение применяемости, простота повторного использования.

Управление жизненным циклом и контроль применяемости не доступны с планом подписки Standard.

Средство Library Migrator предлагает минималистический простой режим интерфейса (Simple), где выбранные файловые библиотеки компонентов мигрируют в серверные управляемые компоненты в один этап. При этом средство миграции берет на себя задачи классификации по типам, назначения целевых папок, добавления параметров и типов значений, а также передачи всех связанных данных. Также доступен расширенный режим интерфейса (Advanced), где доступен полный предварительный просмотр планируемой миграции библиотек и все соответствующие данные и настройки. И хотя миграция по умолчанию осуществляется в один клик, средство миграции также предлагает расширенные настройки в панели Properties для лучшего контроля на тем, как будет осуществлена миграция.

В серверные управляемые компоненты происходит миграция всей информации, которая присутствует в исходной библиотеке, со всеми доменными моделями (схемные символы, посадочные места, имитационные модели), параметрической информацией, назначенными вариантами выбора, файлами даташитов и т.д. При необходимости могут быть созданы шаблоны компонентов, которые можно изменить и использовать для последующих миграций библиотек. Если у изначальных компонентов определено множество посадочных мест, вы можете быть уверены, что мигратор библиотек перенесет эти модели и также сохранит текущее посадочное место по умолчанию. И если вы работаете только с библиотеками посадочных мест (т.е. вам необходимо только конструирование плат), средство Library Migrator поддерживает миграцию только таких библиотек. Либо средство миграции можно переключить в режим миграции только моделей, при котором модели указанных типов будут мигрированы из интегрированных библиотек и библиотек на основе баз данных. Библиотеки, которые включают в себя компоненты множества типов (монолитные библиотеки), также автоматически обрабатываются.

Вызов Library Migrator осуществляется через главное меню File в Altium Designer. Для получения более подробной информации перейдите на страницу Миграция существующих библиотек на сервер управляемых данных.

Как создать новый компонент в Workspace?

После подключения к Workspace новый компонент в нем может быть создан с помощью редактора Component Editor в режиме Single Component Editing, вызываемого по команде File » New » Component из любого редактора.

В рамках создания компонента вы можете не только создавать доменные модели, но также проводить поиск существующих физических компонентов и создавать на их основе новые управляемые компоненты непосредственно в Workspace.

Для получения более подробной информации перейдите на страницу Управляемые компоненты и Редактор Component Editor – режим Single Component Editing.

Могу ли добавлять даташиты в компоненты?

Безусловно. К компоненту могут быть прикреплены (выгружены в него) один или множество даташитов, т.е. по сути можно создать ссылку между компонентом и даташитами, при создании/редактировании этого компонента через Component Editor.

Существующему компоненту в Workspace один или множество даташитов могут быть прикреплены (выгружены в него) через панель Explorer в Altium Designer. При просмотре нужного компонента переключитесь на его аспектный вид Data Sheet.

Более простым методом прикрепления даташита к компоненту является перетаскивание мышью этого даташита из Проводника Windows в область Parameters (в редакторе Component Editor) или в специальную область аспектного вида Data Sheet (панель Explorer в Altium Designer). После перетаскивания файлы будут выгружены.

Как заменить существующие компоненты в проекте на компоненты из Workspace?

Для этого можно использовать Item Manager в Altium Designer, вызов которого осуществляется через меню Tools. Благодаря гибкой системе правил для определения подходящих компонентов в Workspace, Item Manager позволяет быстро и эффективно преобразовать текущий проект платы для использования в нем облачных компонентов.

Item Manager предоставляет две ключевые функции для компонентов и листов повторно используемых схем в проектах плат:

  • Миграция – прежде всего, доступен переход от использования в проекте компонентов и листов схем, основанных на традиционных неуправляемых файлах, до применения компонентов и листов, которые хранятся в Workspace. С этой точки зрения, Item Manager можно рассматривать как средство "преобразования для использования серверных данных".
  • Синхронизация – после того, как проект преобразован для использования компонентов и листов из Workspace, в диалоговом окне Item Manager вы можете легко синхронизировать объекты, используемые в проекте, с соответствующими исходными объектами на Workspace. С этой точки зрения, Item Manager можно рассматривать как средство "обновления данных с облака".
Для получения более подробной информации перейдите на страницу Управление объектами с помощью Item Manager.

Совместная работа

Как работать над проектами в Altium 365?

По сути, есть три способа работы над проектами:

  • Рекомендуемый и наиболее эффективный способ работы – это создание нового проекта непосредственно в подключенном Workspace. Если у вас есть существующий проект, вы можете перенести его в Workspace, сделав доступным онлайн и включив контроль версий. В любом случае, проект будет сохранен в Workspace, и он будет управляться его системой контроля версий. Это предоставит полные функциональные возможности управляемого проекта при работе над ним в Altium Designer. Только проекты, полностью управляемые Workspace, могут быть опубликованы множеству лиц на редактирование из Altium Designer.
  • Локальный проект, который не находится под контролем версий, может быть зарегистрирован в Workspace с помощью метода под названием Simple Sync (Простая синхронизация). Зеркальная копия проекта создается в Workspace и синхронизируется. Сохраненные локальные файлы автоматически синхронизируются со своими ответными частями в Workspace.
  • Локальный проект, который находится под управлением внешнего контроля версий, также можно зарегистрировать в Workspace с помощью простой синхронизации. Зеркальная копия проекта создается в Workspace и синхронизируется. После сохранения и фиксации изменений локальных файлов во внешнем репозитории эти изменения автоматически синхронизируются со своими ответными частями в Workspace.

Простая синхронизация позволяет использовать возможности совместной работы, доступные через платформу Altium 365, при этом сохраняя изначальный проект там, где он есть. Однако имейте в виду, что локальный проект (не под управлением внешней системы контроля версий) может быть изменен только одним лицом – владельцем этого проекта, т.е. тем, кто сделал его доступным онлайн в Workspace.

Для получения более подробной информации о проектах под управлением собственной системы контроля версий Workspace перейдите на страницу Управление проектами из Altium Designer. Для получения более подробной информации о простой синхронизации перейдите на страницу Обеспечение онлайн-доступа к существующему неуправляемому проекту.
Если проект находится под управлением внешней системы контроля версий, вы можете мигрировать его, чтобы он стал полностью управляемым проектом в Workspace, который содержит проектные файлы в собственном Git-репозитории сервера (по сути, этот процесс переключает проект на использование собственной системы контроля версий Workspace). Для получения более подробной информации перейдите на страницу Переход от внешней системы контроля версий к собственной системе контроля версий Workspace.

Какова разница между публикацией проекта кому-либо в команде и кому-либо вне команды?

Публикация участнику команды вашего Workspace предоставляет ему все функциональные возможности. Вы можете осуществить публикацию с предоставлением прав только на чтение или с полными правами на редактирование. В любом случае, этот пользователь сможет открыть проект в Altium Designer или через веб-интерфейс платформы Altium 365.

Публикация лицу вне вашей команды Workspace может быть осуществлена только для просмотра и комментирования либо для редактирования, без необходимости приглашать пользователя в команду. Это позволяет приглашенным участникам просматривать/редактировать (где это применимо) динамические проекты, без получения доступа ко всем проектным данным сервера.

  • Если предоставлен доступ только для просмотра, то приглашенные участники могут просматривать и комментировать проект из Altium Designer либо через интерфейс платформы Altium 365. При внесении в проект изменений пользователями с правами на редактирование и фиксации этих изменений они будут отображены у людей извне. Для просмотра опубликованного проекта через веб-интерфейс, откуда угодно, всё, что необходимо для получения доступа, это регистрация на AltiumLive.
  • Если приглашенному участнику были предоставлены права на редактирование проекта, то он сможет открыть и редактировать его из Altium Designer, что отлично подходит для внешних подрядчиков.

Пользователь, с которым вы поделились проектом, получит email-приглашение для доступа к нему через Altium 365. Он сможет просматривать и комментировать его, но вы также можете управлять тем, сможет ли этот пользователь загружать проект и делиться им с другими.

Публикацию проекта можно выполнить из Altium Designer или из веб-интерфейса платформы Altium 365. Для получения более подробной информации перейдите на страницу Публикация проекта из Altium Designer. Поддержка публикации проекта за пределы Workspace из Altium Designer (только для просмотра и комментирования) стала доступной в Altium Designer 20.1. Для публикации проекта за пределы Workspace для редактирования из Altium Designer и, соответственно, для открытия такого проекта для редактирования, необходим Altium Designer версии 20.2 или более новой.

Если мы сохраним компонент на сервер, будет ли он доступен только для нашей команды либо он будет доступен всем?

Это ваш личный Workspace, и только те, кто приглашен в Workspace, могут видеть его содержимое. Никто за пределами Workspace не увидит ваши данные, пока вы не решите опубликовать что-либо явным образом.

Как авторизовать сторонних участников на просмотр моих проектных данных в Altium 365?

Одним из наиболее мощных аспектов платформы инфраструктуры Altium 365 является поддержка совместной работы на глобальном уровне. В основе этого лежит поддержка платформой глобальной публикации (Global Sharing). С помощью Altium 365 вы можете без труда публиковать свои проекты в текущем состоянии руководству, отделу закупок или потенциальному производителю для простой интерактивной совместной работы с любого устройства. Данные можно опубликовать для кого угодно и из любой точки мира. Что и кому публиковать решаете вы. Здесь доступно следующее:

  • Публикация проектов электронных устройств и данных для производства через браузер с помощью бесплатного веб-средства Altium 365 Viewer. Этот уровень публикации поддерживает только просмотр проектов, но не их комментирование.
  • Публикация проектов в стадии разработки для тех, кто находится вне команды Workspace, только для просмотра и комментирования либо для редактирования, без необходимости приглашать пользователя в команду. Это позволяет приглашенным участникам просматривать/редактировать (если это применимо) динамические проекты, без получения доступа ко всем проектным данным сервера.
  • Публикация "слепков" проектов, загруженных в персональное пространство в платформе Altium 365, на постоянной основе, кому угодно. Этот уровень публикации поддерживает просмотр и комментирование опубликованного слепка, но имейте в виду, что это именно слепок – статичное состояние проекта в определенный момент времени, а не динамический проект.
  • Публикация проектных данных для участников вашей команды Workspace. Публикуйте проекты, папки и объекты нужным образом. Например, вы можете предоставить доступ к проекту с правами только на чтение, чтобы собирать комментарии и отзывы. Либо вы можете предоставить полные права на чтение/запись для глобальной совместной работы географически распределенной команды (с выполнением редактирования из Altium Designer).
  • Публикация выпущенных данных производителю с помощью определенного пакета Manufacturing Package, который производитель может изучить с помощью специального средства платформы Altium 365 Manufacturing Package Viewer без необходимости доступа к вашему Workspace, что позволит скрыть проектные данные. Производитель может загрузить Build Package и с его помощью изготовить печатную плату и печатный узел.
Публикацию проекта, будь то временная ссылка, слепок или динамический проект, можно выполнить непосредственно из Altium Designer. Поддержка публикации проекта за пределы Workspace из Altium Designer (только для просмотра и комментирования) стала доступной в Altium Designer 20.1. Для публикации проекта за пределы Workspace для редактирования из Altium Designer и, соответственно, для открытия такого проекта для редактирования, необходим Altium Designer версии 20.2 или более новой. Для получения более подробной информации перейдите на страницу Публикация проекта из Altium Designer.

Могу ли я разрешить сторонним участникам редактировать мои проектные данные?

Да. Публикация лицу вне вашей команды Workspace может быть осуществлена только для просмотра и комментирования либо для редактирования, без необходимости приглашать пользователя в команду. Это позволяет приглашенным участникам просматривать/редактировать (где это применимо) динамические проекты, без получения доступа ко всем проектным данным сервера.

  • Если предоставлен доступ только для просмотра, то приглашенные участники могут просматривать и комментировать проект из Altium Designer либо через интерфейс платформы Altium 365. При внесении в проект изменений пользователями с правами на редактирование и фиксации этих изменений они будут отображены у людей извне. Для просмотра опубликованного проекта через веб-интерфейс, откуда угодно, всё, что необходимо для получения доступа, это регистрация на AltiumLive.
  • Если приглашенному участнику были предоставлены права на редактирование проекта, то он сможет открыть и редактировать его из Altium Designer, что отлично подходит для внешних подрядчиков.

Пользователь, с которым вы поделились проектом, получит email-приглашение для доступа к нему через Altium 365. Он сможет просматривать и комментировать его, но вы также можете управлять тем, сможет ли этот пользователь загружать проект и делиться им с другими.

Публикацию проекта можно выполнить из Altium Designer или из веб-интерфейса платформы Altium 365. Для получения более подробной информации о первой варианте перейдите на страницу Публикация проекта из Altium Designer. Поддержка публикации проекта за пределы Workspace из Altium Designer (только для просмотра и комментирования) стала доступной в Altium Designer 20.1. Для публикации проекта за пределы Workspace для редактирования из Altium Designer и, соответственно, для открытия такого проекта для редактирования, необходим Altium Designer версии 20.2 или более новой.

Я сделал свой проект доступным онлайн – как мне удалить эту связь?

После того, как вы сделали неуправляемый проект доступным онлайн, элементы управления его доступностью онлайн и синхронизацией можно найти на вкладке General диалогового окна Project Options.

Если вы хотите остановить синхронизацию между локальным проектом и его управляемой копией, которая доступна онлайн в Workspace, нажмите кнопку . Будет открыто диалоговое окно Turn off project synchronization. Щелкните ЛКМ по опции Unlink, затем нажмите OK, чтобы вернуться в диалоговое окно Project Options. Локальный проект больше не будет связан с проектом в Workspace.

Это будет отражено в панели Projects после сохранения проекта, где проект будет представлен под записью активной группы проектов (*.DsnWrk), а не под записью активного Workspace. Сохранение необходимо, поскольку ссылки на проект в Workspace удаляются из файла проекта.

Сам проект в Workspace останется нетронутым – при выполнении этого действия он не будет удален.

Вы также можете использовать Project Packager, чтобы вновь получить несвязанный локальный проект. В области Managed Projects страницы Zip File Options мастера убедитесь, что включена опция Unlink project from the server during packaging. Информация о ссылке на зеркальный проект в Workspace, которая находится в файле проекта (*.PrjPcb), будет удалена в рамках процесса упаковки проекта.

У меня план подписки Standard – как я могу управлять правами доступа без использования ролей?

С планом подписки Standard нет поддержки ролей. По сути, есть два уровня определения прав доступа к Workspace и его содержимому (которые применимы к уровням Standard и Pro доступа к Altium 365):

  • Вы можете определить участника команды Workspace как администратора или как обычного пользователя. В первом случае, пользователь назначается в качестве участника роли Administrators. Это может выполнить администратор Workspace при приглашении этого лица в команду или в любой момент позже. У администраторов Workspace есть полный доступ ко всем данным в Workspace и права на их редактирование.
  • Для каждого из обычных участников команды вы также можете определить доступ к содержимому в Workspace. Workspace предоставляет следующие возможности публикации:
    • Публикация на уровне папки – предоставляет возможность управлять тем, кто может видеть определенные данные в Workspace, путем публикации серверных папок. Это позволяет управлять тем, могут ли другие пользователи просматривать папку и ее содержимое, либо также они могут редактировать ее (путем выпуска/фиксации/обновления проектных данных в ней). Единый Workspace может быть разделен на различные "области" данных, и с помощью управляемых на уровне папок прав доступа содержимое можно выборочно сделать видимым или скрытым для предоставления нужным людям нужного уровня доступа к нужным данным.
    • Публикация на уровне объектов – предоставляет возможность управлять тем, кто может видеть определенные объекты в опубликованной папке. Это следует воспринимать как более тонкий уровень публикации, по сравнению с более высоким уровнем, предоставляемым управлением доступа к папкам. Пользователь, у которого есть доступ к самой папке, сможет видеть/редактировать в этой папке (в соответствии с предоставленными правами) объекты, которые опубликованы для этого пользователя.
Элементы управления публикацией доступны в контекстном меню записи папки (или объекта) на странице Admin-Explorer веб-интерфейса Workspace, в виде команды Share Folder (или Share Item) контекстного меню. При их вызове будет открыто окно Share, в котором вы можете нужным образом изменить права доступа к папке/объекту. Для получения более подробной информации перейдите на страницу Управление структурой данных и доступом к ним.
Права доступа к папкам и объектам также можно определить в Altium Designer через панель Explorer. Для получения более подробной информации перейдите на страницу Управление доступом к данным на сервере.

Я являюсь членом команды, но я не вижу опубликованный проект на странице Shared with Me веб-интерфейса.

Член команды Workspace осуществляет доступ к проектам, которые были опубликованы для него, со страницы Projects веб-интерфейса Workspace.

Страница Shared with Me является не частью веб-интерфейса Workspace, а частью родительского интерфейса платформы Altium 365, в котором активный Workspace представлен в качестве его составной части. Эта страница доступна любому, кто осуществляет вход в платформу Altium 365 с помощью своих учетных данных AltiumLive. Иными словами, эту страницу можно открыть без доступа к Workspace.

На странице Shared with Me представлены следующие типы опубликованных данных, которые являются частью парадигмы глобальной публикации (Global Sharing) платформы Altium 365:

  • Опубликованные динамические проекты.
  • Опубликованные слепки проектов.
  • Опубликованные пакеты для производства.

Надежность

Что будет, если случится сбой платформы Altium 365?

Altium 365 резервируется облаком AWS еженедельно на уровне системы и каждые 24 часа на уровне индивидуальных резервных копий. Ваши данные кэшируются локально, так что при наихудшем варианте развития событий вы сможете продолжить большую часть своей работы (размещение, проектирование, трассировку), а затем после восстановления подключения зафиксировать данные на сервере.

Нет требования быть подключенным к платформе постоянно.

Как мои данные о компонентах защищены в Altium 365?

Перейдите на страницу Безопасность в Altium 365.

Что произойдет с моими данными, если я не обновлю план подписки Altium?

Если член команды Workspace попытается подключиться к Workspace, но план подписки Altium на его лицензию Altium Designer истекла, он будет уведомлен об этом при подключении. Ему будет предоставлен выбор временно подключиться к Workspace с полным доступом либо связаться с представителем Altium, чтобы обсудить возобновление подписки.

Если в аккаунте Altium вашей компании (в том, с которым связан ваш Workspace) нет лицензий Altium Designer с активной подпиской Altium Subscription, то Workspace перейдет в режим только на чтение. Все участники команды смогут просматривать существующие в Workspace данные и работать с ними, но они не смогут каким-либо образом изменять существующие данные либо создавать новые.

Если вы использовали уровень доступа Pro, где у вашего Workspace был набор функциональных возможностей, связанный с планом подписки Pro, обратите внимание, что после истечения представление Workspace будет ограничено тем, которое соответствует плану подписки Standard, и с доступом только на чтение для извлечения данных.

Кроме того, это использование существующих данных будет ограничено периодом, указанным в Политике хранения данных.

До этого момента данные могут быть извлечены следующим образом:

  • Экспортом компонентов в формат IntLib.
  • Извлечением проектов.
  • Загрузкой пакетов выпуска.
Для получения более подробной информации перейдите на страницу Извлечение данных после истечения подписки.

Как часто создаются резервные копии моего Concord Pro на Altium 365?

Они создаются каждые 24 часа.

Возможно ли экспортировать библиотеки компонентов из облака для офлайн-доступа к ним и для их резервного копирования?

Да, вы можете экспортировать библиотеки для их резервного копирования. Данные о компонентах автоматических кэшируются для офлайн-доступа в Altium Designer, вам не нужно беспокоиться об офлайн-доступе.

Можно создать резервную офлайн-копию?

На данный момент это не доступно. Мы автоматически резервируем ваши данные каждые 24 часа.

Я уже использую контроль версий (git, svn и т.д.) для хранения своих данных в облаке. Зачем мне нужен Workspace на Altium 365 и нужно ли мне уходить от своей текущей среды?

Вы можете продолжить использовать существующую локальную или облачную систему контроля версий, как и раньше, и просто регистрировать свои проекты (делать их доступными в Workspace). Это откроет вам большую часть функциональных возможностей Workspace, в зависимости от вашего плана подписки Altium:

  • Анализ применяемости
  • Веб-просмотр проектов
  • Взаимодействие с MCAD-системами (MCAD CoDesigner)
  • Комментирование и пометки
  • И многое другое...

Либо вы можете мигрировать проект, чтобы он стал полностью управляемым проектом в Workspace, который содержит проектные файлы в собственном Git-репозитории сервера (по сути, этот процесс переключает проект на использование собственной системы контроля версий Workspace). Для получения более подробной информации перейдите на страницу Переход от внешней системы контроля версий к собственной системе контроля версий Workspace.

Могу ли я поддерживать локальную копию данных о своих компонентах?

Можете, но делать это не рекомендуется. Это трудоемкий процесс. Большинство данных о компонентах кэшируются на каждой машине, подключаемой к Workspace (кроме динамических по своей природе данных: цен, состояний и т.д.).

У вас будет льготный период для извлечения данных из Workspace, если вы решите отказаться от сервиса.


Совместное проектирование ECAD-MCAD

Доступные функциональные возможности зависят от вашего уровня доступа к Altium 365, определяемого планом подписки Altium Subscription. Посмотрите Полное сравнение планов, чтобы увидеть различия.

Что такое Altium MCAD CoDesigner и чем он отличается от прочих способов совместной работы ECAD-MCAD?

MCAD CoDesigner позволяет обмениваться данными о плате между инженером-электроником и инженером-механиком без выполнения ручных операций над файлами. MCAD CoDesigner работает непосредственно с данными ECAD и MCAD через панель в Altium Designer (сторона ECAD) и плагина в MCAD-системе (сторона MCAD).

Главные преимущества MCAD CoDesigner по сравнению с традиционным обменом файлами:

  • Работает намного быстрее, чем обычный экспорт/импорт файлов.
  • Позволяет передавать больше проектных данных (форма платы с вырезами, компоненты, размещенные со стороны MCAD, медь, шелкография и т.д.).
  • Изменения могут быть применены выборочно. Управление этими изменениями применяются при каждой передаче данных (выполнении Pull).
  • Значительно упрощает синхронизацию изменений.

Более подробную информацию вы можете получить в технической документации.

Какие MCAD-системы поддерживаются?

На текущий момент официально поддерживаются следующие платформы и версии MCAD:

  • Dassault Systemes SOLIDWORKS® – версия 2018, 2019, 2020, 2021
  • Autodesk Inventor Professional® – версия 2019, 2020, 2021, 2022
  • PTC Creo Parametric® – 4.x, 5.x, 6.x, 7.x, 8.x
  • Autodesk Fusion 360®

Нужно ли приобретать дополнительные лицензии?

Использование возможностей совместного проектирования в ECAD-MCAD не требует дополнительного лицензирования для Altium Designer + Altium 365.

Какие типы печатных плат поддерживаются на текущий момент?

На текущий момент поддерживаются следующие типы печатных плат:

  • Обычные платы – со всеми поддерживаемыми MCAD-системами.
  • Гибко-жесткие платы – пока только для SOLIDWORKS и PTC Creo.
  • Варианты плат

Многоплатные проекты (Multi-board) на текущий момент не поддерживаются.

Возможно ли использовать модели компонентов в собственном формате MCAD?

Да. Во-первых, CoDesigner позволяет размещать ключевые компоненты со стороны MCAD и распознавать их на стороне ECAD (для всех поддерживаемых MCAD-систем, кроме Autodesk Fusion 360). Во-вторых, поддерживается автоматическое размещение моделей непосредственно из системы управления данными, используемых на стороне MCAD, для всех компонентов, которые пришли со стороны ECAD (доступно только для SOLIDWORKS и Creo).


Altium 365 Viewer

Как мне получить доступ к Altium 365 Viewer?

Вы можете открыть Altium 365 Viewer на веб-сайте Altium с помощью прямой ссылки: altium.com/viewer.

Какие САПР поддерживаются?

На текущий момент Altium 365 Viewer предлагает поддержку выгрузки и просмотра проектов в форматах Altium Designer, Autodesk® EAGLE™, KiCad® и CircuitStudio. Со временем будет добавлена поддержка дополнительных форматов. Вы можете проголосовать, поддержку какого формата проектов необходимо реализовать.

Поддерживаются ли данные для производства?

На текущий момент Altium 365 Viewer поддерживает выгрузку и просмотр данных для производства в форматах Gerber RS-274X и Gerber X2 (а также соответствующих данных автоматизированной сверловки).

Почему я не могу загрузить какие-либо выходные документы?

Эта возможность недоступна при использовании Altium 365 Viewer на сайте altium.com. Она доступна (и ее можно настроить) при встраивании Altium 365 Viewer на собственный веб-сайт.

Из встроенного просмотра вы можете сформировать и загрузить ряд различных выходных документов. На текущий момент поддерживаются исходные данные самого проекта, Gerber, IDFX, IPC2581, ODB++, STEP, PDF (распечатки схем, распечатки плат, распечатки PCB 3D и PDF 3D).

Что выгружается в Altium 365 Viewer?

С точки зрения проектов САПР, вы можете выгрузить весь проект (в архиве Zip, Rar или 7z) или отдельный проектный файл (документ схемы или платы). При выгрузке файла Zip, Rar или 7z следует учесть следующее:

  • Для проектов Altium Designer и CircuitStudio, архив Zip, Rar или 7z должен содержать в себе только один проект платы.
  • Для проектов EAGLE, архив Zip, Rar или 7z должен содержать в себе только один проект платы (т.е. файлы .sch и .brd только одного проекта).
  • Для проектов KiCad, архив Zip, Rar или 7z должен содержать в себе только один проект платы (т.е. файлы .pro, .sch, .kicad_pcb и .lib только одного проекта).
  • Altium 365 Viewer проигнорирует все файлы неподдерживаемых форматов в выгруженном архиве Zip, Rar или 7z. Это значит, что вы можете просто упаковать в архив Zip, Rar или 7z всю папку проекта и выгрузить ее.
Для проектов Altium Designer и CircuitStudio, файл проекта используется для определения порядка исходных документов схем. Если файл проекта не добавлен в архив Zip, Rar или 7z, будет создан файл по умолчанию, и документы схем будут добавлены без правил.
Zip-архив проекта платы Altium Designer можно быстро получить с помощью средства Project Packager.

С точки зрения файлов для производства, вы можете выгрузить полный набор файлов Gerber и данные для автоматизированной сверловки (в архиве Zip, Rar или 7z) либо отдельный файл Gerber. При выгрузке файла Zip, Rar или 7z следует учесть следующее:

  • В архиве должна быть только одна папка с файлами Gerber.
  • Файлы автоматизированной сверловки должны находиться в той же папке, что и файлы Gerber. Если эти файлы находятся в другой папке, они будут проигнорированы.
Вы можете выгрузить либо проект, либо файлы Gerber, но не все их одновременно. Если в одном архиве Zip/Rar/7z будут файлы проекта и файлы Gerber, то только проект будет обработан и представлен в Altium 365 Viewer.

Как встроить Altium 365 Viewer на собственный веб-сайт?

Altium 365 Viewer можно встроить на любую веб-страницу как iframe. Чтобы встроить средство просмотра, в раздел <head> веб-страницы необходимо добавить следующий код:

<script src="https://viewer.altium.com/client/static/js/embed.js"></script>

Этот код прикрепляет слушатели событий, используемые для корректной инициализации iframe. После этого необходимо добавить на страницу местозаменитель iframe:

<div id="my_viewer-frame_container"
    class="altium-ecad-viewer"
    data-project-src="http://example.com/mydesign.zip"
    style="border-radius: 0px 0px 4px 4px; height: 500px;
         border-style: solid; border-width: 1px;
         border-color: rgb(241, 241, 241);
         overflow: hidden; max-width: 1280px;
         max-height: 700px; box-sizing: border-box;">

</div>

Примечания:

  • class="altium-ecad-viewer" – нельзя менять, поскольку используется слушателями событий.
  • data-project-src – ссылка на проект или производственные данные, которые вы хотите показать. Это должна быть доступная ссылка на архив Zip, Rar или 7z с файлами проекта платы или данными для производства.
  • style – можно изменить в соответствии со своими предпочтениями представления.

Для получения более подробной информации перейдите на страницу Встраивание Altium 365 Viewer на собственный веб-сайт.

Обнаружили проблему в этом документе? Выделите область и нажмите Ctrl+Enter, чтобы оповестить нас.

Связаться с нами

Связаться с нашими Представительствами напрямую

We're sorry to hear the article wasn't helpful to you.
Could you take a moment to tell us why?
200 characters remaining
Вы сообщаете о проблеме, связанной со следующим выделенным текстом
и/или изображением в активном документе: