Altium Designer Documentation

Applying Color to the Nets

Последнее изменение: Tiffany Cullen; 06.12.2019

Parent page: Working Between the Schematic and the Board

As the design builds up it quickly becomes dense and detailed - the schematic busy with wiring and the board a maze of connection lines and routed nets. To help bring clarity and visibility, the designer can apply color to the schematic wiring, PCB connection lines, and routing. 

The ability to selectively override the color of specific nets is known as Net Color Override. Color can be applied to schematic nets and those color settings transferred to the PCB, or color settings can be applied directly in the PCB editor.

The image below shows a complex high-speed design using net color to help the designer easily identify groups of critical nets. Further down the page there is an image that shows the same board with and without color on the routed nets.

Net Color Override Net Colors have been applied to groups of critical nets on both the schematic and the board (image courtesy FEDEVEL Open Source, www.fedevel.com)

Toggle Net Color Override on or off in each editor with the F5 shortcut key.

Applying Color to the Schematic Nets

A highlight color can be applied to a net or a bus in the schematic editor using the commands in the View » Set Net Colors sub-menu, as shown in the image below. 

Net Color Override

Click on a pin, wire, bus or net identifier (net label, sheet entry, port, power port or offsheet connector) to apply the selected color to that net (or all the nets in a bus). The command remains active after clicking on the first net, ready to color subsequent nets in that same color, if required.

When a color is applied to a net or a bus, it overrides any previous color setting. Note that net color settings cannot be undone, to remove a color setting use the Clear Net Color command, or the Clear All Net Colors command (View » Set Net Colors sub-menu).

The color is automatically applied to all sections of the net, on all schematic sheets in the project. This occurs automatically when the background compiler updates the connectivity of each sheet.

To include color on a net or bus that connects two sheet symbols, include a net label on the net/bus running between the sheet symbols.

Color is not applied to a component pin or a power port, drag them apart to add a wire if there is no color showing on that section of net.

Where are the Color Settings for the Schematic Stored?

Because a net is a compiled object, determined from the current arrangement of wiring and net identifiers, the color setting for a net is not stored with the various objects placed on the sheets. The color settings are actually stored in the project file as a net-level setting, and are applied on each schematic sheet after it is opened and the background compiler has compiled that sheet.

Learn more about Creating Connectivity.

Transferring the Colors Between the Schematic and the PCB

Net colors can be transferred between the schematic and PCB editors (in both directions), via the Design » Update command.

If the colors are not transferring, check that the following options are enabled in the Options for Project dialog:

Applying Color to the PCB Nets

In the PCB editor a net has two representations; either as an unrouted connection line, or as a routed net defined by a series of track segments.

Net colors are always applied to the connection lines. Routed nets can be displayed either in layer color, or net color. The display of net colors in the PCB editor can be controlled at the individual net-level and also at the editor-level, more on this below.

Changing the Net Color in the PCB editor

When the design is transferred from the schematic into the PCB workspace, default color settings are applied to all nets. All of the net connection lines are assigned the default Connection Lines color, as defined in the System Colors section of the Layers & Colors tab of the View Configuration panel (L shortcut). Net colors defined in the schematic will override this default.

Alternatively, the net color can be selectively defined directly in the PCB panel, set to Nets mode:

  • To change the color of one or multiple nets, select the required nets in the panel, then right-click on a selected net and choose the Change Net Color command, as shown below, or
  • For an individual net, double-click the net name in the PCB panel to open the Edit Net dialog, where you can edit the connection line color.


In the PCB panel, right-click on selected nets to change the net color.

As shown in the image above, the net color is displayed in the PCB panel, behind the checkbox to the left of the net name.

The checkbox is used to apply the color to the routing - more on this below.

The list of nets can be sorted by clicking on any of the column headings, including the enable Color Override checkbox column.

Learn more about the Nets mode of the PCB panel.

Displaying the Net Color on Routed Nets

The default behavior for routed nets is to display them using the color of the layer that the routing objects have been placed on. You can also use the net color for routed nets, by enabling the Net Override Color feature for the required nets, and also for the PCB editor.

Net YOUT has override color enabled, resulting in the objects in that net being shown as a checkerboard.
Net YOUT_ALT has a color defined, but color override is not enabled.

To use the Net Color Override feature:

  1. Apply the required color to the net(s) - Right-click on the net (or selected nets) in the PCB panel and use the Change Net Color command, as discussed earlier on this page.
  2. Enable Color Override for the net(s) - color override is enabled for each net using the checkbox next to its name in the PCB panel, as shown for the net YOUT in the image above. The checkboxes can be toggled for multiple selected nets via the Right-click » Display Override » Selected On/Off commands.
  3. Configure the Color Override options - the net color overrides the layer color in accordance with the Color Override settings configured in the PCB Editor - Board Insight Color Overrides page of the Preferences dialog, as discussed below.
  4. Enable the Net Color Override feature - press F5 to globally toggle the Net Color Override feature on and off, or use the button in the View Options tab of the View Configuration panel.

How Color Override is Displayed

The PCB editor can display the override color in a variety of ways, including as a solid override of the chosen color, or in a number of different override patterns. This behavior is configured in the PCB Editor - Board Insight Color Overrides page of the Preferences dialog.

The Base Pattern option determines how the routing is displayed when you are zoomed in. The pattern options are included so that you can still see both the routing layer color and the override color. This is useful if you are tracing a net that is moving through the layers, and you also need to keep track of which layer it is currently on.

As you zoom out, this display behavior can be:

  • maintained as you zoom out (Base Pattern Scales), or
  • the pattern can fade away to restore the layer color (Layer Color Dominates), or
  • the override color can strengthen (Override Color Dominates).

Each of the Zoom Out Behavior options is useful in a different situation.


Use the Color Override feature to help routed nets stand out.

How each net that has the Net Color Override checkbox enabled is displayed in the workspace, depends on the current Color Override settings. The image above shows an example of this.

  • Zoomed in - any net with the Override Color checkbox enabled will display in the chosen Base Pattern. In the example image above it is a checkerboard mix of layer color and net color.
  • Zoomed out - the Zoom Out Behavior in the image above is for the override (net) color to dominate, as shown in the smaller image on the right.

The image below shows how well multiple sets of critical nets in a high-speed PCB design stand out once they have been identified using different colors. In this example the Zoom Out Behavior is set to Override Color Dominates. Hover the cursor over the image to show the same layer with Net Color Override disabled.

An excellent example of the net color override feature being used to easily identify classes of nets in a high speed design, hover to switch off the override feature.
(image courtesy FEDEVEL Open Source, www.fedevel.com)

 

Обнаружили проблему в этом документе? Выделите область и нажмите Ctrl+Enter, чтобы оповестить нас.

Связаться с нами

Связаться с нашими Представительствами напрямую

Вы сообщаете о проблеме, связанной со следующим выделенным текстом
и/или изображением в активном документе:
Бесплатная пробная версия Altium Designer
Бесплатная пробная версия Altium Designer
Давайте приступим. Для начала, Вы или Ваше предприятие уже используете Altium Designer?

Если Вы хотите поговорить с представителем, пожалуйста, свяжитесь с местным офисом Altium.
Copyright © 2019 Altium Limited

В таком случае, для чего Вам необходима пробная лицензия?

Если Вы хотите поговорить с представителем, пожалуйста, свяжитесь с местным офисом Altium.
Copyright © 2019 Altium Limited

Вам для этого не нужна пробная лицензия.

Нажмите кнопку ниже, чтобы загрузить установщик самой новой версии Altium Designer

Загрузить установщик Altium Designer

Если Вы хотите поговорить с представителем, пожалуйста, свяжитесь с местным офисом Altium.
Copyright © 2019 Altium Limited

Пожалуйста, заполните форму ниже, чтобы получить ценовое предложение.

Нажимая [Получить бесплатнную пробную версию], Вы соглашаетесь с нашей Политикой конфиденциальности. Вам могут приходить сообщения от компании Altium, и Вы можете изменить настройки уведомлений в любой момент.

Если Ваша подписка Altium активна, у Вас нет необходимости в пробной лицензии.

Если у Вас нет активной подписки Altium, пожалуйста, заполните форму ниже, чтобы получить пробную версию.

Нажимая [Получить бесплатнную пробную версию], Вы соглашаетесь с нашей Политикой конфиденциальности. Вам могут приходить сообщения от компании Altium, и Вы можете изменить настройки уведомлений в любой момент.

Для чего Вы хотите попробовать Altium Designer?

Если Вы хотите поговорить с представителем, пожалуйста, свяжитесь с местным офисом Altium.
Copyright © 2019 Altium Limited

Вы нашли нужное место! Пожалуйста, заполните форму ниже, чтобы начать использование пробной версии.

Нажимая [Получить бесплатнную пробную версию], Вы соглашаетесь с нашей Политикой конфиденциальности. Вам могут приходить сообщения от компании Altium, и Вы можете изменить настройки уведомлений в любой момент.

Отлично! Знаете ли Вы, что мы предлагаем для студентов специальные скидки на лицензии? Для получения более подробной информации нажмите здесь.

А пока что Вы можете запросить пробную лицензию, заполнив форму ниже.

Нажимая [Получить бесплатнную пробную версию], Вы соглашаетесь с нашей Политикой конфиденциальности. Вам могут приходить сообщения от компании Altium, и Вы можете изменить настройки уведомлений в любой момент.

Вы можете загрузить бесплатную лицензию средства просмотра Altium Designer Viewer сроком действия 6 месяцев.

Пожалуйста, заполните форму ниже, чтобы запросить эту лицензию.

Нажимая [Получить бесплатнную пробную версию], Вы соглашаетесь с нашей Политикой конфиденциальности. Вам могут приходить сообщения от компании Altium, и Вы можете изменить настройки уведомлений в любой момент.

Замечательно! Создавать новое - отличное занятие. У нас есть превосходная программа для Вас.

Upverter - бесплатная платформа, разработанная специально для любителей проектирования.

Нажмите здесь, чтобы попробовать!

Если Вы хотите поговорить с представителем, пожалуйста, свяжитесь с местным офисом Altium.
Copyright © 2019 Altium Limited

Вы можете загрузить бесплатную лицензию средства просмотра Altium Designer Viewer сроком действия 6 месяцев.

Пожалуйста, заполните форму ниже, чтобы запросить эту лицензию.

Нажимая [Получить бесплатнную пробную версию], Вы соглашаетесь с нашей Политикой конфиденциальности. Вам могут приходить сообщения от компании Altium, и Вы можете изменить настройки уведомлений в любой момент.