Altium Designer Documentation

Редактор Component Editor – режим Single Component Editing

Последнее изменение: Pavel Demidov; 26.10.2020

Главная страница: Управляемые компоненты

Определение/редактирование управляемого компонента осуществляется с помощью редактора Component Editor, который может работать в двух режимах: Single Component Editing (Редактирование одного компонента) и Batch Component Editing (Пакетное редактирование компонентов). Первый режим предоставляет удобный интерфейс для определения/редактирования отдельного компонента. Это режим по умолчанию при создании нового объекта компонента (Component Item) или при редактировании отдельной ревизии существующего объекта. Второй режим предоставляет интерфейс для определения/редактирования множества компонентов, но его также можно использовать для определения/редактирования отдельного компонента, если это необходимо.

В этом документе рассмотрена работа с редактором Component Editor в режиме Single Component Editing.

Доступ к Component Editor в этом режиме осуществляется при создании/редактировании компонента через панель Components или панель Explorer. Его также можно открыть напрямую с помощью команды File » New » Component главного меню.
Для получения более подробной информации по работе с редактором Component Editor в режиме Batch Component Editing перейдите на страницу Редактор Component Editor – режим Batch Component Editing Mode.

Обеспечение функциональных возможностей

Функциональные возможности Single Component Editing доступны через специально созданный для редактора Component Editor дополнительный программный модуль – Single Component Editor.

Дополнительный программный модуль Single Component Editor.

Эта функциональная возможность доступна, только когда дополнительный программный модуль Single Component Editor установлен в вашем экземпляре Altium Designer. Этот дополнительный программный модуль устанавливается по умолчанию вместе с системой, но в случае непреднамеренного удаления вы можете вернуться на вкладку Purchased страницы Extensions & Updates – для этого нажмите по элементу управления для текущего пользователя (например, ) вверху справа от рабочей области и выберите Extensions and Updates из меню.

Обзор интерфейса

Интерфейс редактора Component Editor в режиме Single Component Editing делится, по сути, на четыре главных области, показанные на изображении ниже и информация о которых приведена далее.

Редактор Component Editor в режиме Single Component Editing можно разделить на четыре ключевых области.

  1. Component (Компонент) – здесь вы определяете ключевые свойства компонента, в том числе его название (Name), описание (Description), уникальный идентификатор (Id), папку (Folder), тип (Type) и ссылку на какой-либо шаблон компонента (Component Template), если необходимо.
  2. Models (Модели) – здесь вы добавляете ссылки на выпущенные доменные модели, используемые компонентом.
  3. Parameters (Параметры) – здесь вы определяете набор параметров, которые будут применены к компоненту. Этот набор может включать в себя параметры из шаблона компонента, на который дана ссылка, а также дополнительные пользовательские параметры. Здесь также можно добавить ссылки на адреса веб-сайтов и даташиты.
  4. Part Choices (Варианты выбора компонента) – здесь вы можете осуществить поиск и добавить варианты выбора компонента (Part Choices) – физические компоненты, которые могут использоваться при изготовлении печатной платы и печатного узла.

Область Component

В этой области доступны элементы управления для определения следующих атрибутов компонента:

  • Name (Название) – отражает удобочитаемое с человеческой точки зрения название компонента. Этот системный параметр индексируется при поиске на сервере, и он обеспечивает удобный способ определения конкретных компонентов, что избавляет от необходимости запоминания их Item ID.

    При вводе названия появится список доступных компонентов производителей из локального каталога компонентов сервера управляемых данных. Вы можете выбрать запись для быстрого определения компонента: либо для его полного определения (использовать всю информацию), либо только параметров (использовать только параметры и варианты выбора компонента), либо только имени. Создание через поиск по компонентам производителей также доступно по нажатию кнопки в правой части поля. Для получения более подробной информации перейдите в раздел Создание компонента из Manufacturer Part Search.

    В это поле будет внесено значение по умолчанию для системного параметра Name, определенное в шаблоне компонента, на который указана ссылка.
  • Description (Описание) – отражает добавленное компоненту описание. Этот системный параметр индексируется при поиске на сервере.
    В это поле будет внесено значение по умолчанию для системного параметра Description, определенное в шаблоне компонента, на который указана ссылка. Также, если компонент был создан с помощью поиска по компонентам производителей и была выбрана опция Use all data, поле Description будет заполнено описанием из этого выбранного компонента.

Кроме того, при щелчке ЛКМ по Advanced Settings вы получите доступ к следующим параметрам:

  • Id (Идентификатор) – это поле используется для определения идентификатора выпущенного на целевой сервер объекта Component Item. Для нового компонента, создаваемого с помощью команды File » New » Component или панели Components, это поле будет заполнено в соответствии с шаблоном компонента, определенного для типа компонентов, который был выбран в диалоговом окне Create new component. Если шаблона не существует или если в этом диалоговом окне была выбрана запись <Undefined>, будет использоваться схема именования по умолчанию: CMP-{00000}. Для нового компонента, создаваемого через панель Explorer, это поле будет заполнено в соответствии со схемой именования по умолчанию, указанной для родительской папки компонента. Если для родительской папки назначен шаблон компонента, именование компонента будет взято из этого шаблона. Система автоматически назначит следующий доступный уникальный идентификатор на основе этой схемы, просканировав весь сервер и идентификаторы существующих объектов.

    Либо вы можете переопределить автоматически назначенный идентификатор компонента путем ввода нужного идентификатора непосредственно в поле Id. У вас всегда есть полный контроль на тем, как объекты сервера будут идентифицироваться.

    Это поле будет доступно только для чтения, если компонент был уже выпущен.
  • Folder (Папка) – используйте это поле для выпуска компонента в определенную папку на целевом сервере. Для нового компонента, создаваемого с помощью команды File » New » Component или панели Components, это поле будет заполнено в соответствии с шаблоном компонента, определенного для типа компонентов, который был выбран в диалоговом окне Create new component. Если шаблона не существует или если в этом диалоговом окне была выбрана запись <Undefined>, это поле будет пустым. Для нового компонента, создаваемого через панель Explorer, это поле будет заполнено в соответствии с родительской папкой этого компонента. У вас есть полный контроль над тем, где будет хранится компонент на целевом сервере. Для определения целевой папки вручную нажмите кнопку , чтобы открыть диалоговое окно Choose Folder. Найдите и выберите существующую папку или на лету создайте новую.
    Важно правильно определить папку для компонента, чтобы обеспечить его первоначальный выпуск в нужную целевую папку. Тем не менее, серверные объекты можно легко перемещать в любые папки после их выпуска, если в этом возникнет необходимость.
    Это поле будет доступно только для чтения, если компонент был уже выпущен.
  • Template (Шаблон) – это поле позволяет задать ссылку на определенный шаблон компонента (Component Template). Щелкните ЛКМ в этом поле, чтобы открыть список всех объектов шаблонов компонентов (Component Template Item), доступных в данный момент на активном сервере управляемых данных (на который осуществлен вход). Щелкните ЛКМ по какой-либо записи, чтобы создать ссылку на обозначенную (самую новую) ревизию этого объекта. Информация из шаблона будет добавлена в редактор Component Editor (Name, Description, формат именования Id, Folder, Type, Models и Parameters). Для получения более подробной информации перейдите в раздел Создание ссылки на шаблон компонента.
    Поддержка шаблонов компонентов не включена в Altium 365 Standard. Соответственно, при этом уровне доступа к Altium 365, данная функциональность не будет доступна при подключении к Altium 365 Workspace.
  • Type (Тип) – это поле позволяет задать тип компонента, которое является ключевым атрибутом, используемым для обеспечения целевого поиска по управляемым компонентам. При просмотре собственных управляемых компонентов с помощью панели Components, группирование управляемых компонентов по категориям (Categories) осуществляется на основе типа, заданного для каждого компонента. Щелкните ЛКМ по этому полю, чтобы открыть список определенных на данный момент типов компонентов и выбрать нужный. Определение типов осуществляется на уровне настроек. Нажмите кнопку в правой части поля, чтобы открыть страницу Data Management - Component Types диалогового окна Preferences, где вы можете задать этот список в соответствии со своими требованиями, путем добавления новых типов и подтипов или путем редактирования и удаления существующих типов.
    Также можно изменить тип одного или множества компонентов после их выпуска на совершенно другой тип, на лету. В панели Components или в панели Explorer выделите компоненты, которые вы хотите изменить, затем щелкните ПКМ и выберите команду Operations » Change Component Type из контекстного меню. Будет открыто диалоговое окно Choose component type, где вы можете выбрать новый тип компонента.
    В это поле будет внесено значение по умолчанию для параметра ComponentType, определенное в шаблоне компонента, на который указана ссылка, или тип компонента, выбранный в диалоговом окне Create new component, которое открывается при создании нового управляемого компонента с помощью команды File » New » Component.

Область Models

Эта область редактора используется для добавления ссылок на выпущенные доменные модели для их использования компонентом.

На самом базовом уровне, для компонента, используемого в проекте платы, необходимо представление в областях редактирования схемы и платы. Соответственно, компоненту необходимы схемный символ и посадочное место.

Область Models, предоставляющая элементы управления для определения моделей, необходимых для представления компонента на схеме, на плате и для имитатора.

Используйте сворачиваемые области ниже, чтобы узнать больше о работе с моделями.

Ссылки на нужные для компонента модели могут быть определены различными способами:

  • Выберите существующую модель. Щелкните ЛКМ по иконке выпадающего списка на кнопке под типом модели и выберите пункт Existing из меню. Выберите модель нужного типа в открывшемся диалоговом окне. Обратите внимание, что поле Revision State под изображением модели отразит текущее состояние жизненного цикла выбранной ревизии объекта модели и то, является ли она самой новой ревизией (Up to date) или нет (Out of date).
    Поддержка управления ревизиями не включена в Altium 365 Standard. Соответственно, при этом уровне доступа к Altium 365, состояние жизненного цикла не будет отображаться при подключении к Altium 365 Workspace.
    Обратите внимание, что кнопка является динамической, и она отразит команду (из меню), которая использовалась прошлый раз.

    Добавление существующей модели из диалогового окна.

  • Перетащите модель с зажатой ЛКМ непосредственно из панели Explorer.

    Добавьте одну или множество моделей путем их перетаскивания из панели Explorer.

  • Создайте новую модель вручную. Щелкните ЛКМ по иконке выпадающего списка на кнопке под типом модели и выберите пункт New из меню. Будет открыт соответствующий временный редактор для моделей этого типа, готовый к определению модели. Изначально модель будет названа в соответствии с названием определяемого в данный момент компонента – измените название необходимым образом. После определения модели сохраните и закройте редактор – ссылка на модель появится в области Models. Обратите внимание, что в поле Revision State под изображением модели будет показано Not released. При выпуске компонента новая модель будет автоматически выпущена на сервер в начальную ревизию нового объекта.

    Пример создания новой модели компонента вручную, в данном случае – схемного символа. Изначально символ был назван Diode_Schottky, в соответствии с родительским компонентом, но затем он был переименован в Diode_Schottky_Red. Обратите внимание, что модель не будет выпущена до выпуска родительского компонента.

  • Создайте новую модель с помощью мастера (только для символа или посадочного места). Щелкните ЛКМ по иконке выпадающего списка на кнопке под типом модели и выберите пункт Wizard из меню. Процесс схож для этих двух типов моделей, они лишь используют разные мастеры:
    1. Для символа будет открыт Symbol Wizard. Для посадочного места будет открыт IPC Compliant Footprint Wizard. Используйте соответствующий мастер для определения модели необходимым образом.
    2. После завершения работы мастера будет открыт временный редактор для соответствующего типа модели, где будет загружена сформированная мастером модель. Сформированная модель будет изначально названа в соответствии с именем определяемого в данный момент компонента – измените название необходимым образом. Сформированному посадочному месту будет задано название, указанное в мастере.
    3. Внесите дополнительные изменения, если это необходимо, затем сохраните и закройте редактор – ссылка на модель появится в области Models. Обратите внимание, что в поле Revision State под изображением модели будет показано Not released.
    4. При выпуске компонента новая модель будет автоматически выпущена на сервер в начальную ревизию нового объекта.

    Пример использования Symbol Wizard для создания нужного символа создаваемого/редактируемого компонента. Наведите курсор на изображение, чтобы увидеть пример использования IPC Compliant Footprint Wizard для создания модели посадочного места компонента.

  • Из шаблона. Если компонент ссылается на шаблон компонента, все заданные объекты моделей (как специальные параметры) в этом шаблоне (только SCHLIB и PCBLIB) будут переданы в область Models. Для получения более подробной информации перейдите в раздел Создание ссылки на шаблон компонента.
  • Из панели Manufacturer Part Search. Если компонент был создан через поиск по компонентам производителя и была выбрана опция Use all data, будут взяты модели, заданные для этого выбранного компонента. Если для компонента не задано моделей, останутся существующие модели. Для получения более подробной информации перейдите в раздел Создание компонента из Manufacturer Part Search.

Хранение новых моделей

Вы можете определить целевые папки по умолчанию, в которых должны быть созданы новые модели, или переопределить их для указания другой целевой папки, если это необходимо. Это обеспечивает гибкость и управление созданием и хранением моделей.

Определение целевой папки по умолчанию

Целевые папки по умолчанию для новых моделей определяются на странице Admin - Settings - Vault - Components в веб-интерфейсе Altium 365 Workspace или в веб-интерфейсе самоуправляемого Altium Concord Pro.

При внесении изменений в целевые папки по умолчанию нажмите кнопку Save в верхней правой части страницы.

Переопределение целевой папки по умолчанию

Новые модели, созданные при определении компонента через Component Editor в режиме Single Component Editing, будут сохранены на сервере в соответствии с заданными по умолчанию целевыми папками, как описано выше. Тем не менее, при необходимости вы можете переопределить настройку по умолчанию путем указания определенной папки, в которую должен быть сохранен созданный объект модели. Для этого нажмите вверху справа от изображения модели и выберите Select Target Folder из меню. Будет открыто диалоговое окно Choose Folder (по сути, усеченный аналог панели Explorer). Используйте его для выбора нужной целевой папки и нажмите OK.

Переопределите целевую папку по умолчанию для типа модели, выбрав другую папку.

Хотя компонент пока не выпущен, выбранная целевая папка будет представлена в текстовом виде над окном изображения модели. Это служит полезным напоминанием о том, где можно будет найти новую модель.

Хотя компонент пока не выпущен, будет представлена выбранная целевая папка.

Чтобы изменить модель, которая в данный момент используется компонентом (т.е. на которую ссылается компонент), нажмите вверху справа от ее изображения. Будет открыт соответствующий временный редактор для этой модели, готовый для внесения изменений в модель. Затем сохраните и закройте редактор – отредактированная модель будет отображена в области Models. При выпуске компонента, отредактированная модель будет автоматически выпущена на сервер в следующую ревизию ее родительского объекта.

Если на модель ссылается множество компонентов, будет открыто диалоговое окно, предупреждающее вас об этом и предлагающее различные опции. Вы можете создать копию модели (клонировать ее), чтобы изменения повлияли только на текущий компонент. Либо вы можете продолжить редактирование этой общей модели и позже обновить другие компоненты, которые ссылаются на эту модель. Либо вы можете отменить процесс редактирования.

Пример редактирования существующей модели, на которую ссылается компонент.

Чтобы изменить модель, нажмите вверху справа от ее изображения и выберите Select Model из меню. Используйте открывшееся диалоговое окно для поиска и выбора другого объекта модели или другой ревизии того же самого объекта модели.

Пример изменения символа, используемого для представления компонента.

Чтобы клонировать существующую доменную модель, на которую ссылается компонент, нажмите вверху справа от ее изображения и выберите Clone в меню. Будет открыт соответствующий временный редактор для этого типа моделей, где клонированная модель готова для внесения изменений необходимым образом (в том числе для изменения имени модели, чтобы ее можно было отличить от других моделей). Затем сохраните и закройте редактор – клонированная модель будет отображена в области Models. Обратите внимание, что в поле Revision State под изображением модели будет показано Not released. При выпуске компонента клонированная модель будет автоматически выпущена на сервер в начальную ревизию нового объекта.

Пример клонирования существующей модели. Это позволяет быстро создать новый объект модели на лету и использовать его для компонента и, таким образом, не изобретать велосипед.

Чтобы быстро перейти к модели в панели Explorer, нажмите вверху справа от изображения модели и выберите Show in Explorer из меню. В панели будет отображена эта модель (и ее ревизия).

Пример перехода к ревизии объекта модели в панели Explorer.

При фиксации/выпуске компонента на сервер, редактор Component Editor запускает валидацию – проверку правил компонента (Component Rule Check). Если в ходе этой проверки редактор обнаруживает, что подключенная модель находится не в самой новой ревизии, это нарушение будет отображено в диалоговом окне о сбое валидации, и информация о проблеме будет отображена в панели Messages. Информацию о состоянии ревизии можно найти под изображением ревизии объекта модели. Если доступна более новая ревизия объекта, это будет отражено в поле Revision State текстом Out of date справа от состояния жизненного цикла текущей ревизии. При ссылке на самую новую ревизию будет отображен текст Up to date.

Поддержка управления ревизиями не включена в Altium 365 Standard. Соответственно, при этом уровне доступа к Altium 365, состояние жизненного цикла не будет отображаться при подключении к Altium 365 Workspace.

Определение того, что модель не актуальна, в ходе автоматической валидации компонента в Component Editor.

Вы можете отменить выпуск и исправить проблемы либо проигнорировать нарушения и всё равно осуществить выпуск. Чтобы обновить ссылку для использования самой новой ревизии модели, нажмите вверху справа от изображения модели и выберите Update to Latest из меню.

Хотя валидация компонента автоматически проводится при выпуске, ее можно провести в любой момент вручную, запустив команду Tools » Component Rule Check из главного меню. Для получения более подробной информации о том, какие проверки проводятся и об их настройке, перейдите в раздел Запуск проверки правил компонента.

В то время как компонент может ссылаться на один схемный символ и на одну модель для имитатора, может быть задано любое количество ссылок на посадочные места. Это возможность полезна для тех, кто хочет создавать компоненты со ссылкой на три посадочных места, в соответствии с требованиями стандартов IPC для различных уровней плотности монтажа: L (минимум проводящего материала), M (максимум проводящего материала) и N (номинальное количество проводящего материала). Поэтому после определения ссылки на посадочное место, элемент управления Add Footprint всё ещё остается доступным. Посадочным местом по умолчанию является первое подключенное посадочное место, которое отличается иконкой в верхней левой части модели.

Вы можете задать другое посадочное место для использования в качестве модели по умолчанию, нажмите вверху справа от изображения модели и выберите Set Default из меню.

Компонент может ссылаться на множество посадочных мест. Посадочное место по умолчанию (выделено оранжевым прямоугольником) отличается иконкой в верхнем левом углу.

Для компонента, в который был добавлен как символ, так и посадочное место, поддерживается визуальный перекрестный переход между выводами символа и соответствующими контактными площадками посадочного места. Посадочное место должно быть отображено в 2D. Перекрестный переход является однонаправленным (только от выводов к контактным площадкам).

Перекрестный переход между выводами символа и контактными площадками 2D-посадочного места в редактируемом компоненте.

Чтобы удалить модель, нажмите вверху справа от изображения модели и выберите Remove из меню.

Область Parameters

Эта область редактора используется для добавления параметрических данных в компонент. Здесь могут быть вручную добавлены параметры трех типов:

  • Parameter (Параметр) – стандартный пользовательский параметр.
  • Link (Ссылка) – URL-адрес на страницу веб-сайта, например сайта производителя компонента, или на онлайн-даташит.
  • Datasheet (Даташит) – ссылка на даташит (в любом формате), который выгружен на сервер и на который ссылается компонент.

Область Parameters с элементами управления для добавления параметрических данных компонента.

Может быть добавлено любое необходимое количество параметров этого типа. Для этого в нижней части области щелкните ЛКМ по части кнопки для вызова выпадающего списка и выберите нужную запись из меню. Новый параметр будет добавлен в список следующим образом:

  • Parameter – будет добавлен ниже выделенной в данный момент записи в списке. Имя будет в формате по умолчанию Parameter n. Щелкните ЛКМ в поле Name для его изменения необходимым образом. Щелкните ЛКМ в поле Value и введите нужное значение.
  • Link – будет добавлено в конец списка. Щелкните ЛКМ в поле Name и введите нужное имя. Оно будет отображаться в контекстном подменю References при щелчке ПКМ по размещенному на листе схемы экземпляру компонента. Введите (или вставьте) URL-адрес целевой страницы в поле Value. Это значение станет гиперссылкой, с помощью которой можно будет осуществить доступ.
  • Datasheet – будет открыто стандартное для Windows диалоговое окно Open, с помощью которого можно найти и выбрать нужный даташит. Через это диалоговое окно может быть одновременно добавлено множество даташитов. Каждый даташит будет добавлен в конец списка. В качестве параметра Name будет изначально задано имя самого файла, и оно будет отображено в панели Explorer, а также в подменю References компонента после его размещения на листе схемы. Если необходимо, измените название на более подходящее. В качестве параметра Value будет имя и формат файла и его размер на диске. Это будет гиперссылкой для быстрого доступа к даташиту.
Нажмите непосредственно по кнопке (не открывая ее выпадающее меню) для добавления стандартного параметра. Чтобы удалить параметр, выберите его в списке (можно выбрать множество параметров для их удаления) и нажмите кнопку .
Область Parameters также может быть заполнена параметрическими данными из компонента, найденного через Manufacturer Part Search. Для получения более подробной информации перейдите на страницу Создание компонента из Manufacturer Part Search.

Добавление даташита с помощью перетаскивания с зажатой ЛКМ

Помимо добавления даташитов вручную через диалоговое окно Open, как упоминалось ранее, вы также можете добавить в компонент один или множество даташитов следующими способами:

  • Путем перетаскивания с зажатой ЛКМ из Проводника Windows в любое место области Parameters.

    Пример, демонстрирующий добавление даташита из локального диска с последующим редактированием локального заголовка главного даташита.

  • Путем перетаскивания с зажатой ЛКМ ссылки на даташит с веб-страницы во внешнем браузере в любое место области Parameters.

    Пример, демонстрирующий добавление даташита с веб-страницы.

Параметры шаблона

Если компонент ссылается на шаблон компонента (Component Template), то все параметры, заданные в этом шаблоне, будут взяты и добавлены в область Parameters.

Поддержка шаблонов компонентов не включена в Altium 365 Standard. Соответственно, при этом уровне доступа к Altium 365, данная функциональность не будет доступна при подключении к Altium 365 Workspace.

Пример параметров из объекта шаблона компонента, на который задана ссылка.

Замечания:

  • Стандартный параметр шаблона (не помеченный как только для чтения или как обязательный) можно отличить в области Parameters по иконке .
  • Параметр шаблона, помеченный как только для чтения (Read-only), можно отличить в области Parameters по иконке .
  • Параметр шаблона, помеченный как обязательный (Required), можно отличить в области Parameters по иконке .
  • Существующий пользовательский параметр с тем же именем, что и у параметра в подключенном объекте шаблона компонента, будет заменен на версию из шаблона. Существующее значение этого параметра будет сохранено (оно не будет перезаписано значением из шаблона).
  • Поля значений параметров шаблона, которые были помечены как только для чтения, не будут доступны для редактирования. Для всех прочих параметров шаблона, которые не были помечены как только для чтения, вы можете изменять значения необходимым образом.
  • Если параметр шаблона был помечен как обязательный, но в шаблоне ему не было задано значение, поле значения этого параметра будет содержать иконку , оповещающее о том, что для этого параметра необходимо задать значение. Вы не сможете выпустить компонент, пока не будут определены значения всех обязательных параметров.
Параметры шаблонов не могут быть удалены.

Поддержка единиц измерения параметров компонентов

Редактор Component Editor поддерживает единицы измерения параметров компонентов, которые определены в связанном шаблоне компонентов. Вы можете ввести значение параметра непосредственно в подходящее поле в одном из форматов, например 2.2k, 2k2, 4M, 2.5GHz, поскольку сервер управляемых данных может распознавать числовые значения таких записей.

Эта возможность шаблона компонентов обеспечивает целевой поиск с помощью функции поиска сервера – возможности, которая не только позволяет проводить поиск по типам компонентов, но также применять более интеллектуальный поиск. Благодаря параметрам компонентов с единицами измерения вы можете быстро задать поиск, чтобы найти, например, все конденсаторы емкостью от 47 мкФ до 220 мкФ.

Поддержка шаблонов компонентов не включена в Altium 365 Standard. Соответственно, при этом уровне доступа к Altium 365, данная функциональность не будет доступна при подключении к Altium 365 Workspace.
Параметры с единицами измерения также используются для умной фильтрации при поиске через собственный сервер управляемых данных с помощью панели Components.
Типы данных с единицами измерения для параметров компонентов могут быть заданы только в шаблоне компонентов.

Параметры компонентов из шаблона компонентов, на который задана ссылка, с единицами измерения.

При вводе значения параметра компонента, который использует типы данных с единицами измерения, нужно учитывать следующее:

  • Вы можете ввести значение в одном из следующих форматов:
    • Только числовое значение (например 10). Обратите внимание, что если у типа данных есть единица измерения, она будет применена автоматически. У таких типов единицы измерения отображены в скобках после имени.
    • Числовое значение в научном представлении (например 1e10, 1E6).
    • Числовое значение и единицы измерения (например 10F).
    • Числовое значение с префиксом (например 10k). Будут автоматически добавлены подходящие единицы измерения (где это применимо).
    • Числовое значение с префиксом и единицами измерения (например 10kF).
    • Числовое значение с префиксом в типовом инженерном формате (например 2k2, 2K2, 10r2, 10R2 для сопротивления). Значение будет автоматически нормализовано соответствующим образом (например 2K2 станет 2.2k).
  • Вы можете вводить префикс и/или единицы измерения с пробелом после числового значения или без него (например 10uF или 10 uF). Пробел будет автоматически удален.
Обратите внимание, что инженерные сокращения не зависят от регистра, поэтому ввод 2k2 эквивалентен вводу 2K2, а ввод 100R эквивалентен вводу 100r. Исключением являются префиксы M (мега) и m (милли).

Поддерживаются следующие типы данных с единицами измерения:

У большинства типов данных есть единицы измерения (отображены в скобках в шаблоне компонента). Они будут применены, если при вводе значения параметра не указаны единицы измерения.
  • Вольты (V)
  • Амперы (A)
  • Омы
  • Фарады (F)
  • Генри (H)
  • Ватты (W)
  • Герцы (Hz)
  • Градусы по Цельсию (C)
  • Децибелы (dB)
  • Проценты (%)
  • Метры (m)
  • Граммы (g)
  • Секунды (s)

В таблице ниже приведен список префиксов, поддерживаемых при вводе значения типа параметра с единицами измерения.

Префикс Название Значение (научное) Значение (обычное)
T тера 1012 1 000 000 000 000
G гига 109 1 000 000 000
M мега 106 1 000 000
k кило 103 1 000
m милли 10-3 1 / 1 000
u микро 10-6 1 / 1 000 000
n нано 10-9 1 / 1 000 000 000
p пико 10-12 1 / 1 000 000 000 000
f фемто 10-15 1 / 1 000 000 000 000 000
Обратите внимание, что некоторые префиксы или все префиксы могут быть не применимы, в зависимости от типа параметра. Например, префиксы не применимы к процентам. Система предупредит вас при недопустимом использовании префиксов.

При использовании параметра компонента с единицами измерения, введенное значение проверяется на соответствие указанному типу данных. Это обеспечивает использование корректных единиц измерения для этого типа данных. Например, у параметра типа Celsius не может быть значения 10V.

В редакторе Component Editor при вводе некорректного значения параметра будет открыто диалоговое окно, оповещающее о том, что запись не является корректным значением. Это также применимо при копировании и вставке значения между ячейками. Нажмите OK в диалоговом окне, чтобы вернуть предыдущее значение.


Валидация данных – в редакторе Component Editor есть функции, которые предупредят вас в случае несоответствия между значением, введенным для параметра с единицами измерения, и его типом данных.

Параметры на уровне объекта

Altium Designer (в сочетании с Altium 365 Workspace или самоуправляемым Altium Concord Pro) поддерживает концепцию параметров на уровне серверного объекта. Это параметры, которые добавлены в родительский Component Item и которые доступны всем его выпущенным ревизиям, без необходимости повторно выпускать новую ревизию объекта для применения этих параметров. Поэтому их часто называют динамическими параметрами (Dynamic Parameters). Эта функциональная возможность позволяет обновлять компонент без необходимости создавать новые ревизии компонентов, что, в свою очередь, повлияет на связанные проекты, в которых используются эти компоненты. Примером здесь может служить изменение параметра стоимости, которое применяется как бы динамически, на лету.

Эта функциональная возможность доступна при запуске через подключенную инстанцию корпоративной системы (или при использовании загрузчика CSV для самоуправляемого Concord Pro). При определении параметрических атрибутов через подходящий файл конфигурации вы можете задать, должен ли параметр быть передан в объект или ревизию, причем по умолчанию используется последний вариант. Для получения более подробной информации перейдите на страницу Синхронизация компонентов с корпоративными системами (Altium 365 Workspace) или Синхронизация компонентов с корпоративными системами (самоуправляемый Concord Pro).

Параметры на уровне объектов, или динамические параметры, можно просмотреть при редактировании ревизии объекта компонента. Обратите внимание, что они видимы только при использовании редактора Component Editor в режиме Single Component Editing.

Пример параметра на уровне объекта, который был добавлен в объект компонента и который доступен ревизиям этого объекта.

Обратите внимание, что такие параметры имеют другую иконку – – чтобы отличить их в области Parameters редактора. При наведении курсора мыши на иконку будет отображен текст Dynamic.

Область Part Choices

Эта область редактора используется для указания одного или нескольких вариантов выбора (Part Choices) компонента – "допустимые" компоненты от производителей, которые могут быть использоваться на собранной плате. Актуальные данные о цепочке поставок, в том числе производитель (и номер компонента производителя), поставщик (и номер компонента поставщика), описание, цена и доступность, берутся из локального каталога компонентов Part Catalog сервера управляемых данных и подходящего источника компонентов.

У каждого сервера управляемых данных есть собственный каталог компонентов Part Catalog. Это база данных каталога управляемых локальных компонентов, предназначенная для управления и отслеживания компонентов производителя и связанных с ними компонентов поставщика. Локальный каталог компонентов хранит объекты, представляющие компоненты производителя, а также один или несколько объектов, представляющих компоненты поставщика – инкарнации этих компонентов производителя, продаваемых поставщиком. Каждый компонент поставщика является ссылкой на объект в базе данных компонентов – либо в общей базе данных компонентов Altium Parts Provider (которая сама взаимодействует со включенными поставщиками и собирает компоненты от них), либо, для самоуправляемого Concord Pro, в подключенной локальной базе данных компонентов (на основе ODBC). Включите нужных поставщиков и задайте географические положения/валюты для Altium Parts Provider в области Part Providers веб-интерфейса сервера. Когда вы подключены к серверу управляемых данных из Altium Designer, область Altium Parts Options на странице Data Management - Parts Providers диалогового окна Preferences становится доступной только для чтения, с настройками, заданными на сервере. Для получения более подробной информации по управлению источником компонентов Altium Parts Provider для сервера перейдите на страницу Настройка источников компонентов (Altium 365 Workspace) или Настройка источников компонентов (самоуправляемый Altium Concord Pro).

Пример списка Part Choices для определяемого компонента, который содержит один компонент производителя.

Компонент производителя может быть добавлен в список вариантов выбора компонента двумя способами:

Чтобы вручную добавить вариант выбора компонента, нажмите кнопку в нижней части области. Будет открыто диалоговое окно Add Part Choices – найдите нужный компонент производителя, выберите компонент, затем нажмите кнопку OK. Щелкните ЛКМ по записи SPNs для компонента производителя (Supplier Part Numbers – номера компонентов поставщиков), чтобы увидеть доступных поставщиков этого компонента и определить, выбрали ли вы правильный компонент исходя из доступности, цены и т.д.

Если у компонента уже определены данные или если в списке уже есть варианты выбора компонента, будет открыто диалоговое окно Use component data. Используйте его, чтобы решить, как использовать результат – нужно ли заменить некоторые или все данные. Либо, если нужно лишь добавить компонент в список вариантов выбора, нажмите Skip.
В диалоговом окне отображаются результаты поиска по компоненту производителя, а соответствующие записи SPN отражают доступных поставщиков этого компонента. При выборе компонента, в список Part Choices добавляется именно компонент производителя. При использовании компонента производителя, а не определенного поставщика, будет добавлен один выбор Part Choice, в котором будут все решения, основанные на поставщиках этого компонента (которые настроены на вашем сервере управляемых данных как доступные для использования).

Создание варианта выбора компонента вручную – используйте диалоговое окно Add Part Choices для поиска нужного компонента производителя, выберите его запись и нажмите OK.

Чтобы удалить вариант выбора компонента, выберите его в списке и нажмите кнопку .

Part Choice содержит в себе различную информацию, которая представлена на изображении ниже и описание которой приведено далее.

Внутреннее строение Part Choice – запись может быть разделена на девять ключевых информационных составляющих.

  1. Изображение компонента
  2. Название производителя и номер компонента производителя. Это интерактивная ссылка на веб-сайт Octopart, где представлена подробная информация об этом компоненте производителя.
  3. Описание
  4. Запас. Эта запись отображает общую сумму доступных запасов от поставщиков, включенных в источнике Altium Parts Provider на сервере управляемых данных.
  5. Средняя цена за единицу. Эта запись будет отображена красным текстом, если цен нет или если цена = 0.
  6. Полоса жизненного цикла производителя. Наведите курсор мыши на полосу для отображения всплывающей подсказки. Она может быть в одном из четырех состояний:
    • Белая/Серая = По умолчанию, не известно или нет информации
    • Зеленая = Новый (New) или серийное производство (Volume Production)
    • Оранжевая = Не рекомендуется для новых проектов (Not Recommended for New Design)
    • Красная = Устарел (Obsolete) или окончание жизненного цикла (EOL)
    Статус жизненного цикла производителя создан для использования в качестве индикатора по ряду причин:
    1. Altium сопровождает базу данных миллионов компонентов, которые изготавливаются тысячами производителей компонентов. Поскольку нет какого-то одного унифицированного метода, используемого этими производителями, для отражения состояния жизненного цикла компонента, состояние основывается на информации, агрегированной от производителей, глобальных дистрибуторов и глобального анализа продаж.
    2. Компонент будет отображен как EOL или Obsolete, если есть по крайней мере один авторизованный дистрибутор или производитель, который подтвердил это состояние.
    3. Определение состояния Not Recommended for New Design осуществляется более сложным образом. Производители иногда просто сообщают, активен ли компонент или нет, и они могут заранее не предупредить, что компонент будет снят с производства или заменен. Соответственно, этот статус жизненного цикла не всегда совпадает со статусом, предоставленным производителем. Алгоритм определения состояния использует различную информацию, в том числе динамическую и историческую доступность запаса от различных дистрибуторов, для определения доступности компонента. Компоненты, которые постоянно недоступны (в то время как они были доступны в прошлом) или которые не могут быть получены в течение определенного периода времени после того, как были доступны ранее, в конечном итоге будут помечены как не рекомендуемые для новых проектов (если они не помечены как EOL или Obsolete).
    4. Смыслом индикатора жизненного цикла является обеспечение простой для понимания информацией, которая помогает вам принять более взвешенное решение по компоненту, путем подсветки тех компонентов, которые могут быть проблемными. Тем не менее, из-за большого объема данных и количества управляемых компонентов всегда существует вероятность отставания статуса Altium от актуального статуса производителя. Altium не может гарантировать точность статуса жизненного цикла. В случае каких-либо сомнений рекомендуется лишний раз узнать у производителя актуальную информацию о жизненном цикле.
  7. Даташит. Нажмите кнопку , чтобы открыть даташит от производителя на этот компонент. Все даташиты хранятся на веб-сайте Ciiva.
  8. Номера компонентов поставщиков (SPN). Отображает количество поставщиков (из тех, которые включены в источнике Altium Parts Provider на сервере), которые могут поставить этот компонент. Щелкните по ссылке, чтобы отобразить подробную информацию о поставщиках этого компонента, в порядке доступности и цены. Информация о каждом поставщике этого компонента представлена на плитке с цветным баннером. Информация по иконке и данным в плитках приведена ниже.
  9. Пользовательский ранг. Если доступно множество компонентов производителей, т.е. если добавлено множество вариантов выбора компонента и, соответственно, множество решений при использовании ActiveBOM (и документа BomDoc), эти решения будут автоматически ранжированы от высшего к низшему на основе доступности, цены и состояния жизненного цикла производителя компонента. Если вы хотите использовать решение более низкого ранга, например для использования определенного производителя, вы можете переопределить автоматическое ранжирование путем определения пользовательского ранга с помощью звездочки. Щелкните по нужному количеству звездочек, чтобы увеличить или уменьшить уровень ранга этого определенного варианта выбора компонента. Чтобы удалить ранг, нажмите справа от звездочек.

Основные сведения о плитках поставщиков
Существует большое количество информации, представленной в плитках SPN. Наведите курсор мыши на иконку или запись, чтобы отобразить всплывающую подсказку с более подробной информацией.

Плитка SPN включает в себя подробную информацию о доступности компонента у этого конкретного поставщика.

  1. Баннер плитки, отображающий название поставщика, где цвет баннера обозначает следующее:
    • Зеленый = Наилучший выбор
    • Оранжевый = Приемлемо
    • Красный = Сомнительно
  2. Номер компонента поставщика (ссылки на этот компонент на веб-сайте поставщика)
  3. Код страны поставщика (согласно ISO alpha 2)
  4. Источник информации о компоненте (обычно Altium Parts Provider). Цвет означает:
    • Светло-серый = по умолчанию; обновлено менее одной недели назад
    • Оранжевый = 1 неделя < последнее обновление < 1 месяц назад
    • Красный = последнее обновление > 1 месяц назад
  5. Объем запаса; отображается красным цветом, если запасы не доступны.
  6. Цена за единицу; отображается красным цветом, если цена не доступна. Цена за единицу включает в себя иконку валюты. Валюта определяется географическим положением поставщика.
  7. Упаковка поставляемых компонентов. Например Tr означает Tray (Паллета).
  8. Доступные цены в зависимости от размера партии, с минимальным размером заказа.

Для ускорения создания управляемого компонента, Altium Designer поддерживает поиск по физическим компонентам от производителей, обеспечиваемый функциональными возможностями Manufacturer Part Search, с последующим добавлением этого компонента (или части информации о нем) в редактор Component Editor. Таким образом, вы можете быстро определить новый управляемый компонент для его добавления на сервер управляемых данных без необходимости в создании этого компонента с нуля. Нет необходимости изобретать велосипед, поскольку могут быть взяты все данные этого компонента: его название, описание, параметры, даташиты, варианты выбора и все модели.

К этой возможности можно получить доступ различными способами. Используйте сворачиваемые области ниже для дальнейшего изучения.

Общее замечание – если в компоненте еще не определено никаких данных, все доступные для этого компонента данные будут загружены с помощью этой функциональной возможности. Если компонент частично определен, вам будет предоставлен выбор, как использовать данные из выбранного компонента – использовать ли все данные (название, описание, параметры, модели и варианты выбора), только его параметры (название, параметры и варианты выбора, при этом не затрагивать описание, даташиты и модели) или только название (не затрагивая остальные записи).

Поле Name обеспечивает два метода доступа к функциональной возможности Manufacturer Part Search:

  • Непосредственный ввод – при вводе строки в поле Name появится список с соответствующими компонентами производителей (производитель будет обозначен справа). Выберите какой-либо компонент, чтобы использовать его.

    Начните вводить название нужного компонента производителя и выберите соответствующую запись из появившегося списка. На изображении показаны все данные этого компонента, добавленные в Component Editor.

  • С помощью диалогового окна Manufacturer Part Search – нажмите кнопку в правой части поля, чтобы открыть диалоговое окно Manufacturer Part Search. Найдите нужный компонент производителя, выберите запись и нажмите кнопку OK.
    Диалоговое окно используется тем же самым образом, что и панель Manufacturer Part Search или диалоговое окно Add Part Choices. Для получения более подробной информации перейдите по этим ссылкам.
    Результаты поиска в диалоговом окне приводятся по компонентам производителей, где соответствующие записи SPN отражают доступных поставщиков этого компонента. При выборе компонента именно компонент производителя используется для создания нового компонента. С точки зрения варианта выбора компонента, при его создании на основе компонента производителя, а не определенного поставщика, вы получите один Part Choice со всеми решениями, основанными на поставщиках этого компонента (которые настроены как доступные для использования через сервер управляемых данных). Импорт параметров осуществляется в соответствии с настройками Parameter Import Options, которые определяются на странице Data Management - Parts Providers диалогового окна Preferences.

    Используйте диалоговое окно Manufacturer Part Search, чтобы найти нужный компонент производителя, выберите его и нажмите OK. На изображении показаны все данные этого компонента, добавленные в Component Editor.

Доступ к функциональной возможности Manufacturer Part Search можно получить, выбрав команду Tools » Create from Part Search из главного меню. Либо используйте сочетание клавиш Shift+Ctrl+M. Будет открыто диалоговое окно Manufacturer Part Search. Найдите нужный компонент, выберите его запись и нажмите кнопку OK.

Диалоговое окно используется тем же самым образом, что и панель Manufacturer Part Search или диалоговое окно Add Part Choices. Для получения более подробной информации перейдите по этим ссылкам.
Результаты поиска в диалоговом окне приводятся по компонентам производителей, где соответствующие записи SPN отражают доступных поставщиков этого компонента. При выборе компонента именно компонент производителя используется для создания нового компонента. С точки зрения варианта выбора компонента, при его создании на основе компонента производителя, а не определенного поставщика, вы получите один Part Choice со всеми решениями, основанными на поставщиках этого компонента (которые настроены как доступные для использования через сервер управляемых данных). Импорт параметров осуществляется в соответствии с настройками Parameter Import Options, которые определяются на странице Data Management - Parts Providers диалогового окна Preferences.

Используйте диалоговое окно Manufacturer Part Search для поиска нужного компонента производителя, выберите его и нажмите OK. На изображении показаны все данные этого компонента, добавленные в Component Editor.

Можно также выбрать компонент и загрузить его данными путем добавления Part Choice вручную. Нажмите кнопку в нижней части области Part Choices, чтобы открыть диалоговое окно Add Part Choices. Оно очень похоже на диалоговое окно Manufacturer Part Search. Найдите нужный компонент производителя, выберите запись и нажмите кнопку OK . Для нового компонента, без каких-либо данных, вся информация из выбранного компонента будет добавлена в Component Editor.

Найдите Part Choice и добавьте все связанные с этим компонентом данные в Component Editor, определив таким образом компонент.

Если у компонента уже есть какие-либо данные или если в списке уже есть варианты выбора компонента, будет открыто диалоговое окно Use component data. Используйте его для того, чтобы решить, как использовать результат: заменить какие-либо или все существующие данные либо, чтобы лишь добавить компонент в список вариантов выбора, нажмите Skip.

Запуск проверки правил компонента

При фиксации/выпуске компонента на сервер, редактор Component Editor запускает валидацию – Component Rule Check. Эту функциональную возможность можно запустить в любой момент вручную, выбрав команду Tools » Component Rule Check из главного меню (перед этим убедитесь, что компонент сохранен).

Команда также доступна в главном меню File редактора.

Подобно тому, как для проекта платы существует валидация, позволяющая найти различные нарушения в проекте, в редакторе Component Editor есть средство валидации компонента (Component Validator). Все найденные нарушения отображаются в панели Messages.

Обнаружение проблем в компоненте перед его выпуском/фиксацией на сервере.

Средство Component Validator проверяет компонент и его модели на ряд потенциальных проблем с помощью встроенных проверок, а также набора типов нарушений, которые могут быть заданы пользователем на глобальном уровне.

Все встроенные проверки нарушений, приведенные ниже, имеют тип отчета (Критическая ошибка):

  1. Компонент не ссылается на какие-либо модели.
  2. Для компонента не указана целевая папка на сервере управляемых данных.
  3. У компонента нет уникального идентификатора.

Настройка пользовательских проверок осуществляется на странице Data Management - Component Rule Checks диалогового окна Preferences.

Пользовательские проверки, которые можно определить на уровне глобальных настроек, для их использования средством Component Validator.

При сбое встроенной проверки или нарушении пользовательской проверки с уровнем Error или выше компонент не будет выпущен.

О подключенных имитационных моделях

Связанная страница: Управляемые имитационные модели

Помимо объектов символа и посадочного места, компонент может также ссылаться на объект имитационной модели. Добавление ссылки на модель этого типа аналогично добавлению символа и посадочного места, за исключением того, что нет варианта создания такой модели с помощью мастера, так что для получения информации об этом вернитесь в предыдущие разделы. Здесь мы рассмотрим включение параметров для имитатора на уровне компонента, а также настройку сопоставления выводов.

Добавление параметров для имитатора на уровне компонента

При использовании имитационной модели для компонента в проекте, параметры, специфичные для этой модели, могут быть заданы на двух различных уровнях:

  • Параметры на уровне модели – определяются в самой имитационной модели (в файле SimModel) и выпускаются с этим определением в ревизию подключенного объекта имитационной модели.
  • Параметры на уровне компонента – определяются в компоненте (здесь – в редакторе Component Editor) и выпускаются с этим определением в ревизию связанного объекта компонента.
Параметры на уровне компонента используются в качестве параметров, общих для множества моделей, либо если проектировщику нужно, чтобы эти параметры были видимы или доступны для редактирования на схеме (например, номинал, частота и т.п.).

Добавление параметров на уровне компонента осуществляется в области Parameters редактора Component Editor. Важно отметить, что имена параметров должны быть теми же самыми, что и у параметров, заданных на уровне модели. Чтобы увидеть параметры на уровне модели и, соответственно, параметры, которые могут быть добавлены на уровень компонента (и их имена), нажмите View Parameters под окном предварительного просмотра имитационной модели.

Откройте параметры на уровне имитационной модели, чтобы увидеть, какие параметры можно добавить на уровень компонента, и имена этих параметров.

С доступными параметрами на уровне модели вы можете добавить любой из этих параметров на уровень компонента. Для этого нажмите кнопку в нижней части области Parameters. В список будет добавлена запись нового параметра. Измените его имя необходимым образом, помня о том, что оно должно в точности совпадать с именем соответствующего параметра на уровне модели.

Добавьте параметры, относящиеся к имитации, на уровень компонента. Обратите внимание, что два параметра уже доступны: Area Factor и Temperature – они предоставлены шаблоном компонента, на который сделана ссылка.

При размещении в проекте экземпляра выпущенного компонента, у параметра для имитации может быть значение на уровне компонента, отличное значения этого же параметра на уровне модели. При формировании списка цепей, параметр на уровне компонента имеет приоритет.
Для некоторых встроенных моделей SPICE3f5, при вводе значения параметра на уровне компонента будет переопределен соответствующий параметр, указанный в подключенном файле модели (*.mdl). Например, для полупроводникового конденсатора указание параметра Width на уровне компонента переопределит значение, указанное для параметра DEFW в соответствующем файле модели. Если параметр указан на уровне компонента для модели подцепи, то это значение переопределит значение, указанное для него в подключенном файле подцепи (*.ckt).

Сопоставление выводов

После того, как была указана ссылка на нужную имитационную модель, необходимо убедиться, что выводы компонента, заданные для схемы, корректно сопоставлены с выводами имитационной модели.

Эта функциональная возможность не доступна в режиме Single Component Editing – вам необходимо переключиться в режим Batch Component Editing (Tools » Switch to Batch Editor).

После переключения редактора Component Editor в режим Batch Component Editing, сопоставление осуществляется в диалоговом окне Pin Mapping. Чтобы открыть его, щелкните ПКМ по записи имитационной модели компонента и выберите команду Operations » Edit Pin Mapping из контекстного меню. Для каждого вывода схемы используйте доступное выпадающее меню, чтобы изменить соответствующим образом запись Model Pin. Если компонент является многосекционным, проверьте сопоставление для каждой секции. После этого вы можете вернуться обратно в режим Single Component Editing (Tools » Switch to Single Component Editor) или начать выпуск компонента из режима Batch Component Editing.

Обеспечение корректного сопоставления выводов схемы и выводов модели.

Для многосекционных компонентов, возможность исключить какую-либо секцию из анализа также определяется в диалоговом окне Pin Mapping.
Для встроенных моделей SPICE3f5 и поддерживаемых моделей PSpice, функцию каждого вывода в модели можно найти в разделе основной формы этой модели, в руководстве пользователя SPICE 3f5. Для моделей подцепи, производитель обычно добавляет комментарии для каждого вывода модели, описывая их функции. Если никаких комментариев нет, то назначение выводов модели, как правило, совпадает с таковой для физического устройства. В этом случае ознакомьтесь с даташитом на это устройство.
Обнаружили проблему в этом документе? Выделите область и нажмите Ctrl+Enter, чтобы оповестить нас.

Связаться с нами

Связаться с нашими Представительствами напрямую

We're sorry to hear the article wasn't helpful to you.
Could you take a moment to tell us why?
Вы сообщаете о проблеме, связанной со следующим выделенным текстом
и/или изображением в активном документе:
Бесплатная пробная версия Altium Concord Pro

Заполните форму ниже, чтобы получить бесплатную пробную версию Altium Concord Pro