Altium Designer Documentation

Определение ограничений конструкции – Правила проектирования_AD

Последнее изменение: Pavel Demidov; 29.05.2021
Полное содержание

Главная страница: Определение требований к конструкции

Редактор плат использует концепцию правил проектирования для определения требований к конструкции. В совокупности эти правила формируют "набор инструкций", которым должен следовать редактор плат. Он определяет все аспекты конструирования: ширина трассировки, зазоры, стили термобарьеров, стили переходных отверстий и т.д., и многие правил можно отслеживать в режиме реального времени благодаря динамической проверке правил проектирования (Design Rule Checker – DRC).

Правила проектирования применяются к определенным объектам иерархически. Например, существует правило зазора для всей платы, правило зазора для класса цепей и еще одно правило для контактных площадок в этом классе. Используя приоритеты правил и их область действия, редактор плат может определить, какое правило применяется к тому или иному объекту конструкции.

С помощью тщательно проработанного набора правил проектирования вы можете успешно завершить конструкцию платы, требования к которой могут изменяться и зачастую ужесточаться. Кроме того, поскольку работа редактора плат основана на правилах, то потратив время на задание правил перед конструированием, вы сможете эффективно приступить к работе и быть уверенным в том, что система помогает обеспечивать соответствие конструкции техническим требованиям.

Для получения более подробной информации о проверке заданных правил проектирования перейдите на страницу Проверка правил проектирования.

Основы системы правил редактора плат

В основе системы правил Altium Designer лежит несколько фундаментальных принципов, которые отличают ее от других систем правил, используемых в других средствах проектирования плат:

  • Правила и объекты разделены – правило не является атрибутом объекта, а добавляется к общему набору правил, после чего применяется к объектам согласно его области действия. Это позволяет применять правила ко множеству объектов и изменять их ограничения и область действия при необходимости. Изменять правила на уровне отдельных объектов было бы неэффективно.
  • Область действия правила задается запросом – вместо использования набора статичных, предопределённых вариантов области действия правил, вы используете гибкую систему запросов для определения того, к каким объектам будет применено правило. Это позволяет точно задавать область действия каждого правила.
  • Правила для любых случаев проектирования – для различных наборов объектов можно задать множество правил одного типа, что обеспечивает полный контроль над ограничениями конструкции. Например, можно применить разные правила ширины трасс для цепей, находящихся на разных слоях.
  • У каждого правила есть приоритет – какой-либо объект может попадать в область действия нескольких правил одного типа, созданных для общих и более специфичных ситуаций. Для разрешения подобных ситуаций используются приоритеты. Система проверяет правила от более высокого приоритета к более низкому и применяет первое правило, область действия которого соответствует проверяемому объекту.
  • Существует два типа правил – унарные правила (которые определяют необходимое поведение объекта) и бинарные (которые определяют взаимодействие между парой объектов).

Определение правил проектирования и управление ними

Определение правил проектирования и управление ними осуществляется в диалоговом окне PCB Rules and Constraints Editor или в редакторе ограничений Constraints Editor ([Constraints]).

Диалоговое окно PCB Rules and Constraints Editor

Диалоговое окно разделено на две части:

  • В дереве слева приведен список различных категорий правил. Раскройте категорию, чтобы увидеть отдельные доступные типы правил. Раскройте тип правила, чтобы увидеть все правила этого типа, которые определены в данный момент.
  • В правой части диалогового окна представлена информация касательно того, что в данный момент выбрано в дереве – сводка по определенным правилам выделенного типа или категории правил, все определенные правила или, если выделено конкретное правило, ограничения этого правила.


Диалоговое окно PCB Rules and Constraints Editor – центр управления правилами проектирования

Создание нового правила

Чтобы добавить новое правило проектирования через диалоговое окно PCB Rules and Constraints Editor, перейдите к нужному типу правил в дереве слева, выделите его и нажмите кнопку New Rule под списком правил либо щелкните ПКМ по нужному типу правил и выберите команду New Rule из контекстного меню.

Новое правило будет добавлено в дерево, а также появится в списке правил этого типа.


Пример создания нового правила проектирования

При создании нового правила ему будет задано имя по умолчанию на основе типа этого правила. Если правило с таким именем уже существует, ему будет задано имя с увеличенным числовым суффиксом (т.е. Width_1, Width_2 и т.д.).

Чтобы открыть область действия и ограничения правила, щелкните ЛКМ по этому правилу в дереве слева или дважды щелкните ЛКМ по правилу в сводке. Основная часть диалогового окна изменится, предоставив доступ к элементам управления для определения области действия и ограничений этого правила.


Доступ к элементам управления правила, в том числе его области действия и ограничениям.

Для полного определения нового правила:

  • Задайте правилу осмысленное имя, чтобы сделать правило опознаваемым.
  • Определите область действия правила путем выбора опций из выпадающих меню или ввода запроса (или запросов – для бинарных правил).
  • Задайте ограничения правила.
  • Задайте приоритет правила.

Использование мастера Rule Wizard для создания нового правила

Новое правило можно создать с помощью мастера Design Rule Wizard. Его можно открыть непосредственно с помощью команды Design » Rule Wizard или нажав кнопку Rule Wizard в нижней части диалогового окна PCB Rules and Constraints Editor.

Используйте страницы мастера для создания нового правила проектирования:

  1. Выберите нужного типа правила и определение для него осмысленного имени (и комментария, если необходимо).
  2. Определите области действия правила. Вы сможете далее уточнить область действия с помощью Query Builder, встроенного в мастер.
  3. Определите приоритета правила.
Если на финальной странице мастера включен параметр Launch main design rules dialog, то после нажатия кнопки Finish будет открыто диалоговое окно PCB Rules and Constraints Editor. Это диалоговое окно можно использовать для редактирования ограничений нового правила.


Используйте мастер Design Rule Wizard для последовательного создания правила.

Дублирование существующего правила

Для быстрого создания копии существующего правила используйте функцию дублирования. Доступ к этой функции можно получить двумя способами:

  • Используйте дерево слева, чтобы перейти к существующему правилу, щелкните ПКМ и выберите команду Duplicate Rule из контекстного меню.
  • Перейдите к нужному типу правил в дереве слева, в сводном списке справа выделите правило, которое нужно скопировать, и нажмите кнопку Duplicate Rule под списком.


Упростите создание подобных правил с помощью функции дублирования правил.

Скопированному правилу будет задано то же самое имя, что и у изначального правила, с добавлением суффикса (например, _1). Определение правила (область действия, ограничения и т.д.) будет таким же, что и у изначального правила. Новому правилу будет задан следующий более низкий приоритет по сравнению с изначальным правилом. Например, если у изначального правила был приоритет 1, то дубликату будет задан приоритет 2.

Определение области действия правила

Главная страница: Определение области действия правил проектирования

Чтобы система правил знала, к каким объектам следует применять то или иное правило, ей необходимо знать область действия этого правила, т.е. степень его применения. Определение области действия правила осуществляется в диалоговом окне PCB Rules and Constraints Editor путем настройки параметров Where the Object Matches.

Правилам проектирования по умолчанию и новым правилам задана область действия по умолчанию All, что означает, что правило будет применяться ко всем объектам на плате. Простую область действия правила можно быстро настроить с помощью выпадающего меню.

Опции области действия любого правила не ограничены только предопределенным списком вариантов – область действия правила можно задать более точно с помощью ввода так называемого запроса (Query).

Чтобы ввести запрос, сначала выберите в выпадающем списке Where the Object Matches опцию Custom Query. Будет показан запрос, используемый в данный момент для этого правила.

Запрос, по сути, является инструкцией системе, которая определяет, к каким объектам следует применять правило. Запросы записываются с помощью ключевых слов. Подобно тому, как запрос можно записать в панели Filter для поиска определенного набора объектов, запрос также можно записать для определения объектов, к которым будет применено правило. Пример:

InNet('VBAT') And OnLayer('Bottom Layer')

Если этот запрос использовать в качестве области действия для правила Width, то при трассировке цепи и переключении на нижний слой ширина трассы автоматически изменится на ту, которая указана в ограничениях правила. Также при проведении проверки правил проектирования, трассировка цепи VBAT на нижнем слое должна иметь указанную ширину, либо эта трассировка будет помечена нарушением.

В зависимости от того, является ли правило унарным или бинарным, необходимо определить одну или две области действия соответственно.

Узнайте больше об Определении области действия правил

Если в запросе существует ошибка синтаксиса, то правило будет помечено как некорректное и оно будет выделено в диалоговом окне PCB Rules and Constraints Editor красным цветом, как в дереве слева, так и в сводном списке (категории правил или типа правил), в котором это правило присутствует. Кроме того, текст типа правил и категории правил также будет отображен красным цветом в дереве слева. Поэтому если вы свернули область дерева, в котором находится некорректное правило, вы все равно будете предупреждены об этом на более высоком уровне иерархии. Если вы попробуете закрыть диалоговое окно, появится сообщение с предупреждением. Область действия правила с синтаксической ошибкой может значительно замедлить динамическую и пакетную проверку правил – убедитесь, что исправлены все области действия правил, которые синтаксически некорректны.

Варианты определения области действия

Простые варианты определения области действия правила доступны для быстрого формирования запросов. Выберите один из вариантов в первом выпадающем списке и, если необходимо, используйте последующие выпадающие списки для выбора подходящей цели, например, цепи, слоя, посадочного места, корпуса и т.д. Доступные варианты области действия зависят от типа правила.

Быстрое создание запроса с помощью простых вариантов области действия

Если вы определяете область действия правила с помощью простых вариантов, запрос всё равно создается. Запрос можно увидеть, выбрав Custom Query в первом выпадающем списке.

Вариант Custom Query позволяет создать собственный, возможно, более сложный и более конкретный запрос. Вы можете ввести собственный запрос в качестве области действия правила непосредственно в области запроса справа. Либо вы можете использовать функции, доступные для упрощения составления логического выражения запроса: Query Builder и Query Helper. Эти функции могут быть очень полезными, когда вы не знаете точно синтаксис запроса или доступные для использования ключевые слова.

Используйте вариант Custom Query для составления более сложного выражения запроса.

Query Builder является более простым средством составления запросов, которое использует подходящие типы и значения и позволяет только создавать запросы с помощью соответствующих "строительных блоков". Для создания более сложных конструкций запросов, с полным синтаксисом ключевых слов и операторов, используйте Query Helper.

Определение приоритетов правил

Для упрощения процесса определения правил и управления ними, идея заключается в определении общих правил, которые охватывают широкие требования, и последующем их переопределении более специфичными правилами для конкретных ситуаций. Чтобы это было возможно, необходимо задать приоритеты правил, чтобы указать, какое из них необходимо использовать, когда объект попадает в область действия множества правил одного типа.

Например, для определения наиболее часто используемой в плате ширины трассировки вы определяете одно правило, которое применяется ко всем цепям на плате. Затем это правило можно переопределить для какой-то конкретной цепи (или класса цепей) путем добавления другого правила того же типа, но с более высокими приоритетом.

Другим примером может быть требование к паяльной маске – вы можете определить одно правило маски, которое применяется ко всем контактным площадкам и переходным отверстиям на плате, затем вы можете переопределить его правилом для контактных площадок в посадочных местах определенного типа. Далее это правило для конкретного посадочного места можно переопределить правилом для конкретной контактной площадки в этом посадочном месте, если это необходимо.

Важным аспектом управления правилами является определение соответствующих приоритетов. При создании нового правила, ему по умолчанию задается наивысший приоритет. Используйте кнопку Priorities в нижней части диалогового окна PCB Rules and Constraints Editor для настройки приоритетов в диалоговом окне Edit Rule Priorities.


Изменяйте приоритеты правил в диалоговом окне Edit Rule Priorities.

Изначально в этом диалоговом окне будет приведен список всех правил того типа, который выделен в диалоговом окне PCB Rules and Constraints Editor. Используйте поле Rule Type для изменения типа правила и, соответственно, списка правил, заданных в этом типе. Правила отображаются в порядке текущих приоритетов – от 1 (наивысший приоритет) и далее по убыванию. Чтобы изменить порядок приоритетов, выделите правило и используйте кнопки Increase Priority и Decrease Priority.

Может быть задано множество правил одного типа, и может оказаться так, что объект конструкции попадает в область действия более чем одного правила. В этом случае, возникает конфликт. Все конфликты разрешаются настройкой приоритетов. Система проверяет правила от более высокого приоритета к более низкому и применяет первое правило, область действия которого соответствует проверяемому объекту.

Изменение существующих правил

Конечно, правила можно изменить в любой момент. Чтобы создать финальный рабочий набор правил, зачастую необходимо вносить множество изменений. Как правило, это включает в себя изменение области действия для обеспечения того, чтобы к объектам конструкции применялись необходимые правила. Выберите существующее правило в диалоговом окне PCB Rules and Constraints Editor и внесите требуемые изменения в его область действия и ограничения.

Изменения, внесенные в существующие правила, выделяются в древовидной структуре и в соответствующем сводном списке. Названия таких правил выделяются жирным шрифтом и символом звездочки справа от названия. Звездочка используется для того, чтобы показать, что правило является измененным существующим правилом, а не новым правилом (которое отображается только жирным шрифтом, без звездочки).

Пример существующего правила, которое было изменено. Символ звездочки и выделение жирным шрифтом названия правила используются для пометки изменения.

При создании нового правила определенного типа ему автоматически присваивается приоритет 1. Если существуют другие правила этого типа, их приоритеты понижаются на единицу. Они будут считаться измененными, даже если их область действия/ограничения не были изменены. Поэтому все такие существующие правила этого типа будут отображены как измененные (выделены жирным шрифтом и звездочкой).

Пометка некорректных правил

Если система обнаружит, что правило не корректно (например, есть проблемы с выражением запроса для области действия или значение ограничения не допустимо), то оно будет помечено как некорректное. Такие правила выделяются в диалоговом окне PCB Rules and Constraints Editor красным цветом, как в дереве слева, так и в любых сводных списках (категории правил или типа правил), в которых это правило присутствует. Поэтому если вы свернули область дерева, в котором находится некорректное правило, вы все равно будете предупреждены об этом на более высоком уровне иерархии. Если вы попробуете закрыть диалоговое окно, появится сообщение с предупреждением.


Пример пометки системой некорректного правила проектирования, в этом случае – ошибочное выражение запроса области действия.

Отключение правил

В системе проектирования плат, работа которой основана на правилах, нередко необходимо создавать обширный и всеобъемлющий набор правил, который позволит успешно задать ограничения платы. По той или иной причине, в процессе проектирования может понадобиться отключить некоторые правила – возможно, они не применимы к текущей плате, либо их необходимо временно отключить для снижения нагрузки на проверку правил проектирования (и таким образом повысить его производительность). Если правило может понадобиться в будущем и его нужно сохранить, его лучше отключить.

Чтобы отключить правило, переключите соответствующий параметр Enable в одном из соответствующих сводных списков в правой части диалогового окна PCB Rules and Constraints Editor. Отключенное правило будет выглядеть как "обесцвеченное".


Пример отключенных правил, отображенных серым шрифтом в сводном списке.

Правила также можно включать и отключать непосредственно из панели PCB Rules And Violations. Переключите параметр правила On. В диалоговом окне PCB Rules and Constraints Editor у правила будет отображено соответствующее значение параметра Enable.

Удаление правил

Чтобы удалить отдельное правило проектирование в диалоговом окне PCB Rules and Constraints Editor:

  • Используйте дерево слева, чтобы найти нужное существующее правило, щелкните ПКМ по нему и выберите команду Delete Rule из контекстного меню.
  • Перейдите к определенному типу правил в дереве слева, затем выберите правило, которое нужно удалить, в сводном списке справа. Нажмите кнопку Delete Rule(s) под списком.

Имя правила будет выделено жирным шрифтом, и оно будет зачеркнуто, чтобы обозначить, что это правило будет удалено при применении изменений.


Удаление отдельного правила

Если определенное правило проектирования не нужно, но может понадобиться в будущем, то вместо удаления вы можете отключить правило. Для этого переключите соответствующий параметр Enable у правила в одном из соответствующих сводных списков в правой части диалогового окна PCB Rules and Constraints Editor.
За один раз из сводного списка можно удалить множество правил. Для этого выделите правила, которые необходимо удалить (поддерживаются стандартные сочетания клавиш Shift+ЛКМ и Ctrl+ЛКМ), затем нажмите кнопку Delete Rule(s) под списком.

При создании нового документа платы у многих типов правил создаются правила по умолчанию. Аналогичным образом, если все правила какого-либо из этих типов удалены, правило по умолчанию будет добавлено повторно при следующем открытии диалогового окна PCB Rules and Constraints Editor. Либо правила по умолчанию можно создать снова нажатием кнопки Create Default Rules в нижней части диалогового окна.

Редактор ограничений

Редактор ограничений – пользовательский интерфейс в представлении документа, который предлагает альтернативный подход к просмотру, созданию и управлению правилами проектирования, которые используются в документах плат. Редактор ограничений разделен на шесть доступных для выбора разделов, в порядке возрастающего приоритета: Nets (Цепи), Diff Pairs (Дифференциальные пары), xSignals (Объекты xSignal), Polygons (Полигоны), Components (Компоненты) и Advanced (Расширенные). Первые пять разделов (от Nets до Components) представляют объектный вид правил, в то время как раздел Advanced применим к более сложным правилам (которые обычно используют запросы), которые не могут быть представлены в виде упрощенных правил, ориентированных на объекты.

Для вызова редактора ограничений нажмите кнопку Switch to Document View в диалоговом окне PCB Rules and Constraints Editor.

Нажмите кнопку Switch to Dialog View в панели Properties редактора, чтобы вернуться в диалоговое окно PCB Rules and Constraints Editor.

Некоторые преимущества использования этого редактора:

  • Использование интерфейса в виде вкладки документа, а не модального диалогового окна, означает, что редактор плат и связанные с ним функциональные возможности остаются активными и доступными.
  • Переход от определения области действия правил на основе запросов к сопоставлению по применяемому типу объектов упрощает создание ограничений.
  • Приоритеты правил определяются автоматически, на основе естественной иерархии проектных объектов.
  • Интерактивная валидационная проверка правил для обнаружения общих ошибок синтаксиса, назначения и определения области действия.

Типы правил

В редакторе ограничений существующие правила, которые используют более сложные выражения запросов в своей области действия, называются Advanced Rules (или пользовательскими правилами), а прочие, более простые правила преобразуются в Basic Rules – правила, основанные на типе проверяемых проектных объектов.

Большинство правил в расширенном формате (на основе запросов) можно преобразовать в более простые базовые правила путем перетаскивания правила с зажатой ЛКМ в список Basic Rules и с помощью команды Move Custom Rule to Basic из контекстного меню расширенного правила. При конвертации, область действия расширенного правила, составленная на основе запросов, будет преобразована в определение типа объекта базового правила.

Приоритеты правил

В общем случае, приоритеты правил обрабатываются системой автоматически. Приоритеты обозначены расположением кнопок правил в интерфейсе, где приоритет правил возрастает слева направо – цепи (Nets) имеют самый низкий приоритет.

  • Расширенные (пользовательские) правила имеют более высокий приоритет перед базовыми объектными правилами. Их порядок можно изменить вручную в разделе Advanced путем их перетаскивания вверх и вниз с зажатой ЛКМ.
  • И наоборот, базовым правилам автоматически назначаются приоритеты на основе типов объектов, как это обозначено разделами объектов (от Nets до Components) в интерфейсе документа.
  • В каждом разделе объектных (базовых) правил, приоритет задан в порядке от All (наименьший) до классов объектов и объектов (наивысший), и таким образом, правила с областью действия All, которые были преобразованы в базовые правила, будут иметь наименьший приоритет.
  • Чтобы задать явный приоритет для базового правила, щелкните ПКМ по правилу и выберите команду Move Basic Rule to Advanced, затем вручную задайте его положение в разделе Advanced. Это применимо к правилам, у которых задана область действия, отличная от All – например, в разделе Nets, правило с указанной областью действия Net Class или Net может быть преобразовано (перемещено) в расширенные правила.

Новое пользовательское правило

Создание нового правила в режиме по умолчанию Advanced редактора (который обозначен кнопкой ) похоже на создание правила в диалоговом окне PCB Rules and Constraints Editor. Для этого выберите Add Custom Rule из контекстного меню (или из меню кнопки ), при необходимости задайте область действия на основе запроса () и введите ограничения в таблице или в графическом представлении в нижней части.

Чтобы упростить повторяющийся процесс создания расширенных/пользовательских правил, редактор ограничений позволяет сохранять области действия на основе запросов в библиотеке запросов Scopes Library (через меню ). Библиотека представлена в панели Properties, где можно импортировать, экспортировать и управлять пользовательскими запросами для их повторного использования в других пользовательских правилах. Использование в правиле области действия из библиотеки обозначается иконкой в столбце Object Match правила.

  • Когда область действия из библиотеки задана правилу, вы можете использовать меню поля Object Match, чтобы удалить запись области действия (Clear Scope) или вернуть область действия к его формату на основе запроса (Detach Scope).
  • Также обратите внимание, что саму библиотеку Scopes Library можно экспортировать в XML-файл пользовательских запросов, который затем можно использовать для наполнения библиотеки запросов в другой установке Altium Designer.
  • Перетащите с зажатой ЛКМ правило в другое место в списке, чтобы изменить его приоритет. Пользовательские правила обладают наивысшим приоритетом. Обратите внимание, что порядок приоритетов базовых правил определяется автоматически по их естественной иерархии.
  • Выберите File » Save to PCB, чтобы сохранить файл документа ограничений в проекте платы.

Перекрестный переход

Редактор ограничений включает в себя функцию перекрестного перехода, которая отображает область действия правила путем подсветки цепи и соединений в соответствующем документе платы. Чтобы осуществить перекрестный переход для какого-либо правила в таблице редактора, щелкните ПКМ по этому правилу и выберите команду Cross Probe из контекстного меню либо выберите команду Cross Probe из меню кнопки расширенного правила.

Задайте настройки представления перекрестного перехода (опции Zoom и Select) в разделе Cross Probe View Settings панели Properties. Для сброса подсветки перекрестного перехода используйте опцию Clear Filter редактора плат.

Режимы ограничений проектных объектов

Для создания правил с использованием упрощенного подхода, ориентированного на проектные объекты, выберите кнопку подходящего режима над таблицей правил, чтобы переключиться из расширенного режима по умолчанию. Концептуально эти режимы представляют более интегрированный интерфейс правил, который ориентирован на ограничение того, как проектные объекты могут использоваться, а не на создание хрупких правил проектирования. Последовательность этих кнопок связана с возрастающей сложностью объектов (и приоритетом правил), от базовых цепей и классов (Nets) до унифицированных компонентов (Components) и расширенных правил (Advanced).

В режиме Advanced () правила сгруппированы по типу, как, например, базовые правила Via и Width, которые показаны на изображениях ниже. Более специфичные правила создаются путем добавления новых правил и/или добавлением элементов языка запросов.

И наоборот, ориентированные на объекты разделы (от Nets до Components) организуют правила по проектным объектам (например, цепи) или классам (например, классы цепей), и таким образом обеспечивают непосредственное отображение того, как правила применяются к плате. Чтобы увидеть правила, применяемые к типу объектов, выберите объект или класс в левом столбце, чтобы увидеть связанные правила, либо выберите All, чтобы увидеть правила, связанные с типом объектов. В примере ниже показаны правила, связанные с цепями ().

При использовании подхода, ориентированного на проектные объекты, например, когда выбран тип объектов Nets, как показано ниже, базовые правила Via и Width интегрируются в единую составную запись. В таблице также доступны средства для добавления дополнительных ограничений объектов (цепей) и их классов.

Для добавления более специфичных ограничений в этом примере необходимо выделить только эту цепь (Net) или класс цепей (Net Class) и ввести подходящие значения в ячейки, которые соответствуют нужному типу ограничений. На изображении ниже показано, что для цепей Power (заданных классом) допустимо использование переходных отверстий большего размера, а для цепи 5V – использование трасс с увеличенной максимальной шириной. По сути, в едином простом табличном представлении заданы четыре правила – ограничение ширины цепи 5V, ограничение ширины для всех остальных цепей, ограничение размера переходных отверстия для цепей Power и ограничение размера переходных отверстия для всех остальных классов цепей.

Используйте кнопку , чтобы добавить вариацию выбранному в данный момент правилу. В примере, показанном на изображении ниже, дополнительное правило для цепи 5V задает предпочтительную ширину на слое Bottom.

Обратите внимание, что доступность типов правил в таблице задается доступными столбцами, которые, в свою очередь, включаются в списке Rule Visibility в панели Properties. Например, при включении строки Clearance в списке Rule Visibility, в тип объектов Nets будет добавлен столбец Clearance, как показано ниже. Добавление правила для зазоров будет включать в себя лишь ввод цепи или класса и нужных параметров зазора.

Валидация правил

Корректность всех активных правил можно проверить в разделе Rules/Constraints Checks панели Properties, нажав кнопку . Будет выполнена проверка на вероятные ошибки, такие как дубликаты правил, правила с одинаковой областью действия и различными значениями, правила с перекрывающимися элементами классов (например, цепи) и правила с некорректными областями действия. Строки типов нарушений можно раскрывать для отображения правил с этими нарушениями, при выборе которых будет открыто определенное правило.

Нарушения правил

Включенные правила применяются к текущей конструкции платы с помощью различных механизмов, таких как динамическая онлайн-проверка правил проектирования, пакетная проверка правил проектирования и выборочный запуск из панели PCB Rules And Violations. Нарушения этих правил, т.е. выход за пределы указанных ограничений, отображаются графически на плате, в панели и отчетах, а также в виде предупреждающих иконок в самом редакторе ограничений. Кроме того, нарушения можно просмотреть, проанализировать и исправить, когда редактор ограничений открыт, благодаря его интерфейсу в виде вкладки документа (а не диалогового окна).

Проверка применения правил

В зависимости от конструкции платы, необходимо создать определенное количество правил, с областью действия различной сложности. Зачастую полезно проверить, что заданные правила действительно применяются к нужным объектам. Если позаботиться об этом на этапе определения правила, то можно сэкономить время и усилия на отслеживание нарушений, вызванных некорректной областью действия правила.

По сути, существует два метода проверки области действия правила – выбор объекта и проверка того, какие правила к нему в данный момент применены, и выбор правила и обзор объектов, которые попадают в его область действия.

Со стороны объекта

Вы можете быстро получить информацию о том, какие унарные правила применены к какому-либо объекту, размещенному в конструкции. Наведите курсор на объект, щелкните ПКМ по нему и выберите команду Applicable Unary Rules. Будет проведен анализ все заданных правил проектирования, которые могут быть применены к выбранному объекту, и их список будет приведен в диалоговом окне Applicable Unary Rules.

Правила проектирования, применяемые к отдельному объекту – унарные правила

Рядом с каждым правилом в списке в этом диалоговом окне присутствует либо галочка (), либо перекрестие (). Галочка указывает на то, что у этого правила самый высокий приоритет из всех применимых правил проектирования того же типа – это правило применяется в данный момент. Правила с более низким приоритетом того же типа отображаются ниже, с перекрестием, которое указывет на то, что эти правила также применимы, но поскольку они не являются правилами с наиболее высоким приоритетом, они не применяются в данный момент.

Правила, которые могут быть применены к объекту, но отключены в данный момент, также отображаются с перекрестием и выделяются зачеркиванием.

Аналогичным образом, вы можете получить информацию о бинарных правилах проектирования, которые применяются между двумя размещенными объектами. Наведите курсор на любой объект, щелкните ПКМ и выберите команду Applicable Binary Rules. Далее выберите два объекта в конструкции платы. Будет открыто диалоговое окно Applicable Binary Rules, в котором будут показаны все бинарные правила, применяемые между этими объектами.

Правила проектирования, применяемые между двумя объектами – бинарные правила

Со стороны правила

Если вместо того, чтобы просматривать правила, применяемые к объекту (или между двумя объектами), удобнее выбрать правило и увидеть, к каким объектам оно применяется, используйте панель PCB Rules And Violations. В панели приведены все заданные в текущем документе правила. Можно отобразить все правила или правила какого-то определенного типа (тип правил будет отображаться здесь, если в активном документе есть хотя бы одно правило этого типа). При нажатии по определенному правилу в разделе Rules панели будет применен фильтр с правилом в качестве области действия фильтра. Фильтр пройдут только те объекты, которые попадают в область действия правила. С помощью подсветки Mask (или Dim) вы можете быстро увидеть объекты, к которым применяется правило (используйте выпадающее меню в верхней части панели).

Пример использования панели PCB Rules And Violations для проверки объектов, к которым применяется выбранное правило.

Если в качестве метода подсветки в панели задано Mask, настройте уровень маскирования, применяемого к объектам, которые не попадают в область действия активного фильтра, с помощью ползунка Masked Objects, который находится в разделе Mask and Dim Settings вкладки View Options панели View Configuration. Если в качестве метода подсветки в панели задано Dim, настройте уровень затенения, применяемого к объектам, которые не попадают в область действия активного фильтра, с помощью ползунка Dimmed Objects , который также находится на вкладке View Options панели View Configuration.

Другим подходом к проверке объектов, к которым применяется правило, является использование функции Test Query в диалоговом окне PCB Rules and Constraints Editor.

Экспорт и импорт правил

Правила проектирования можно экспортировать из диалогового окна PCB Rules and Constraints Editor и импортировать в него. Это позволяет сохранять и загружать предпочтительные правила между различными проектами.

  • Для экспорта – щелкните ПКМ где-либо в дереве в левой части диалогового окна и выберите команду Export Rules. Будет открыто диалоговое окно Choose Design Rule Type, в котором вы можете выбрать, какие правила необходимо экспортировать. В открывшемся диалоговом окне Export Rules to File укажите название файла .rul и место его сохранения. Экспортируемые правила будут сохранены в файле правил платы (*.rul).
  • Для импорта – щелкните ПКМ где-либо в дереве в левой части диалогового окна и выберите команду Import Rules. Будет открыто диалоговое окно Choose Design Rule Type, в котором вы можете выбрать, какие правила необходимо импортировать. В открывшемся диалоговом окне Import File укажите файл .rul для импорта.
При импорте, если правила выбранного типа уже существуют, будет предложено удалить существующие правила перед импортом. Нажмите Yes, чтобы удалить все существующие правила этого типа и заменить их правилами из файла .rul. Нажмите No, чтобы сохранить существующие правила. Тем не менее, если у существующих и импортируемых правил совпадают имена, импортируемые правила перезапишут существующие.

Отчеты о правилах проектирования

Из диалогового окна PCB Rules and Constraints Editor можно сформировать отчет по заданным в данный момент правилам проектирования. Отчет может включать в себя все категории правил, определенную категорию правил или определенный тип правил. Отчет можно сформировать следующими способами:

  • Открыть нужный сводный список, щелкнуть ПКМ и выбрать команду Report из контекстного меню или нажать кнопку Report под списком.
  • Щелкнуть ПКМ по нужному пункту в дереве и выбрать команду Report из контекстного меню.

Будет открыто диалоговое окно Report Preview с загруженным соответствующим отчетом. Используйте это диалоговое окно, чтобы проверить отчет с помощью различных элементов управления страницей/масштабом перед экспортом отчета в файл или его печатью.

Формирование отчета о правилах проектирования.

Определение правил проектирования в схеме

Ограничения (правила) проектирования можно определить до этапа конструирования платы путем добавления в исходные документы схем директив Parameter Set с настроенными правилами. Область действия соответствующего правила проектирования, которое будет создано при передаче проекта в документ платы, определяется объектом, которому назначен параметр. В таблице ниже приведены поддерживаемые параметры на схеме и соответствующие области действия правил платы.

Добавьте правило к объекту... Из... Для правила платы с областью действия...
Wire (Провод) панели Properties (при просмотре свойств выделенного объекта Parameter Set), после размещения на проводе объекта Parameter Set с помощью команды Place » Directives » Parameter Set. Цепь
Bus (Шина) панели Properties (при просмотре свойств выделенного объекта Parameter Set), после размещения на шине объекта Parameter Set с помощью команды Place » Directives » Parameter Set. Класс цепей
Harness (Жгут) панели Properties (при просмотре свойств выделенного объекта Parameter Set), после размещения на жгуте объекта Parameter Set с помощью команды Place » Directives » Parameter Set. Класс цепей
Blanket (Полотно) панели Properties (при просмотре свойств выделенного объекта Parameter Set), после размещения на краю Blanket объекта Parameter Set с помощью команды Place » Directives » Parameter Set. Добавьте класс с необходимым именем, чтобы создать класс цепей для всех цепей, покрываемых объектом Blanket. Этот класс будет использоваться для области действия правила. Класс цепей

В каждом случае, метод добавления основанного на правиле параметра один и тот же:

  1. Добавьте параметр в качестве правила.
  2. Выберите тип правила, который необходимо использовать.
  3. Настройте ограничения для правила выбранного типа.
При добавлении правил проектирования объектам на схеме каждому правилу присваивается уникальный ID. Те же самые ID присваиваются соответствующим правилам проектирования, создаваемым в плате. Благодаря этому ID, можно изменять ограничения правила на стороне схемы или на стороне платы и затем передавать эти изменения через синхронизацию.

Узнайте больше об объектах Parameter Set.

Посмотрите пример использования директивы Differential Pair вместе с объектом Blanket для определения правил проектирования на схеме.

Обнаружили проблему в этом документе? Выделите область и нажмите Ctrl+Enter, чтобы оповестить нас.

Связаться с нами

Связаться с нашими Представительствами напрямую

We're sorry to hear the article wasn't helpful to you.
Could you take a moment to tell us why?
200 characters remaining
Вы сообщаете о проблеме, связанной со следующим выделенным текстом
и/или изображением в активном документе:
Бесплатная пробная версия Altium Designer
Бесплатная пробная версия Altium Designer
Давайте приступим. Для начала, Вы или Ваше предприятие уже используете Altium Designer?

Если Вы хотите поговорить с представителем, пожалуйста, свяжитесь с местным офисом Altium.
Copyright © 2019 Altium Limited

В таком случае, для чего Вам необходима пробная лицензия?

Если Вы хотите поговорить с представителем, пожалуйста, свяжитесь с местным офисом Altium.
Copyright © 2019 Altium Limited

Вам для этого не нужна пробная лицензия.

Нажмите кнопку ниже, чтобы загрузить установщик самой новой версии Altium Designer

Загрузить установщик Altium Designer

Если Вы хотите поговорить с представителем, пожалуйста, свяжитесь с местным офисом Altium.
Copyright © 2019 Altium Limited

Пожалуйста, заполните форму ниже, чтобы получить ценовое предложение.

Нажимая [Получить бесплатнную пробную версию], Вы соглашаетесь с нашей Политикой конфиденциальности. Вам могут приходить сообщения от компании Altium, и Вы можете изменить настройки уведомлений в любой момент.

Если Ваша подписка Altium активна, у Вас нет необходимости в пробной лицензии.

Если у Вас нет активной подписки Altium, пожалуйста, заполните форму ниже, чтобы получить пробную версию.

Нажимая [Получить бесплатнную пробную версию], Вы соглашаетесь с нашей Политикой конфиденциальности. Вам могут приходить сообщения от компании Altium, и Вы можете изменить настройки уведомлений в любой момент.

Для чего Вы хотите попробовать Altium Designer?

Если Вы хотите поговорить с представителем, пожалуйста, свяжитесь с местным офисом Altium.
Copyright © 2019 Altium Limited

Вы нашли нужное место! Пожалуйста, заполните форму ниже, чтобы начать использование пробной версии.

Нажимая [Получить бесплатнную пробную версию], Вы соглашаетесь с нашей Политикой конфиденциальности. Вам могут приходить сообщения от компании Altium, и Вы можете изменить настройки уведомлений в любой момент.

Great News!

Valid students can get their very own 6-month Altium Designer Student License for FREE! Just fill out the form below to request your Student License today.

Нажимая [Получить бесплатнную пробную версию], Вы соглашаетесь с нашей Политикой конфиденциальности. Вам могут приходить сообщения от компании Altium, и Вы можете изменить настройки уведомлений в любой момент.

Вы можете загрузить бесплатную лицензию средства просмотра Altium Designer Viewer сроком действия 6 месяцев.

Пожалуйста, заполните форму ниже, чтобы запросить эту лицензию.

Нажимая [Получить бесплатнную пробную версию], Вы соглашаетесь с нашей Политикой конфиденциальности. Вам могут приходить сообщения от компании Altium, и Вы можете изменить настройки уведомлений в любой момент.

Замечательно! Создавать новое - отличное занятие. У нас есть превосходная программа для Вас.

Upverter - бесплатная платформа, разработанная специально для любителей проектирования.

Нажмите здесь, чтобы попробовать!

Если Вы хотите поговорить с представителем, пожалуйста, свяжитесь с местным офисом Altium.
Copyright © 2019 Altium Limited

Вы можете загрузить бесплатную лицензию средства просмотра Altium Designer Viewer сроком действия 6 месяцев.

Пожалуйста, заполните форму ниже, чтобы запросить эту лицензию.

Нажимая [Получить бесплатнную пробную версию], Вы соглашаетесь с нашей Политикой конфиденциальности. Вам могут приходить сообщения от компании Altium, и Вы можете изменить настройки уведомлений в любой момент.