Altium Designer Documentation

Перекрестный переход и перекрестное выделение_AD

Altium Designer предлагает эффективные функциональные возможности перекрестного перехода и перекрестного выделения для быстрой навигации между схемой и платой проекта. Функции перекрестного перехода (Cross-Probing) и перекрестного выделения (Cross Selecting) являются мощными инструментами поиска, которые позволяют находить объекты в других редакторах путем выбора объекта в текущем редакторе.

При перекрестном переходе вы указываете объект в текущем документе, чтобы перейти к его соответствующей ответной части в целевом документе. Полная поддержка перекрестного перехода доступна между редактором схем и редактором плат для документов, компонентов, шин, цепей и выводов/контактных площадок. Буквально в один клик вы можете выбрать поддерживаемый объект в одном из редакторов, чтобы подсветить его в обоих редакторах.

Перекрестное выделение позволяет выделить объекты в исходном документ и, если команда перекрестного выделения включена, те же самые объекты будут выделены в целевом документе.

Унифицированная модель данных и компиляция проекта

Унифицированная модель данных (Unified Data Model, UDM) автоматически создается в оперативной памяти компьютера. Она моделирует все аспекты проекта, в том числе компоненты, связность, посадочные места и т.д. Именно унифицированная модель данных обеспечивает работу перекрестного перехода между различными доменами проекта. Функции перекрестного перехода используют автоматическую компиляцию, что обеспечивает использование самых новых данных модели. Динамическую компиляцию также можно выполнить в любое время вручную с помощью команды Project » Validate PCB Project. Эта функция проверяет унифицированную модель данных на логические, электрические и графические ошибки в соответствии с настройками компилятора.

До версии Altium Designer 20.0, для формирования единой модели данных проект было необходимо компилировать вручную. Теперь модель данных проекта инкрементально обновляется после каждого действия пользователя благодаря динамической компиляции, что формирует то, что называется динамической моделью данных (Dynamic Data Model, DDM). Не нужно выполнять компиляцию проекта вручную, поскольку она выполняется автоматически. Модель связности проекта инкрементально обновляется после каждого действия пользователя благодаря динамической компиляции.

Настройка документа

Для использования многих функциональных возможностей перекрестного перехода и перекрестного выделения (или для упрощения работы с ними) необходимо, чтобы одновременно отображались документы схемы и платы. Для этого вы можете выполнить одно из следующих действий:

  • Щелкните ПКМ по вкладке документа и выберите Split Vertical или Split Horizontal, в зависимости от ваших предпочтений отображения.

    Чтобы закрыть разделенный вид, щелкните ПКМ по вкладке документа и выберите Merge All.
  • Если вы используете больше одного монитора, вы можете перетащить с зажатой ЛКМ вкладку документа на другой монитор.

Перекрестный переход

Вызов перекрестного перехода осуществляется из редактора схем или редактора плат с помощью команды Tools » Cross Probe или нажатием кнопки в панели инструментов Standard редактора.

Объекты в целевом документе, к которым осуществляется перекрестный переход, будут отображены в соответствии с настройкой затенения (Dimming), заданной на странице System - Navigation диалогового окна Preferences. Затенение не будет применяться к документу, из которого осуществляется перекрестный переход.
Для выполнения перекрестного перехода необходимо, чтобы документы схемы и платы проекта были открыты в качестве вкладок в главном окне приложения.

Существует два режима перекрестного перехода: непрерывный режим и режим скачка. Эти режимы рассмотрены в следующих разделах.

Непрерывный режим перекрестного перехода

Непрерывный режим позволяет остаться в исходном документе при перекрестном переходе к другим объектам в целевом документе. Для использования этого режима откройте документ схемы и документ платы рядом друг с другом в главном окне приложения.

После запуска команды перекрестного перехода (Tools » Cross Probe) курсор примет вид перекрестия для выбора объекта, к которому вы хотите перейти. Наведите курсор на нужный объект в рабочей области и щелкните ЛКМ или нажмите клавишу Enter. Соответствующий объект будет подсвечен в целевом документе.

Перекрестный переход из исходного документа (например, схемы) с подсветкой соответствующего объекта (на плате).Перекрестный переход из исходного документа (например, схемы) с подсветкой соответствующего объекта (на плате).

Вы можете продолжить осуществлять перекрестный переход к другим объектам либо щелкнуть ПКМ или нажать Esc, чтобы выйти.

При использовании непрерывного режима, если вы не открыли документы схемы и платы рядом друг с другом, вам понадобится сделать документ платы активным, чтобы увидеть результат перекрестного перехода.
При многократном использовании перекрестного перехода в непрерывном режиме будет отображен/подсвечен только последний выбранный объект. Фильтрация перекрестного перехода не является накопительной.

Режим скачка перекрестного перехода

Режим скачка позволяет вам осуществить перекрестный переход к отдельному объекту и сделать целевой документ активным.

После запуска команды перекрестного перехода (Tools » Cross Probe) курсор примет вид перекрестия для выбора объекта, к которому вы хотите перейти. Наведите курсор на нужный объект в рабочей области и щелкните ЛКМ с зажатой клавишей Ctrl или используйте сочетание клавиш Ctrl+Enter. Соответствующий объект будет подсвечен в целевом документе, который станет активным.

Перекрестный переход из других мест в системе

Перекрестный переход также можно выполнить в некоторых дополнительных местах системы, которые позволяют использовать перекрестный переход в процессе создания проекта без необходимости использования команды Tools » Cross Probe.

Перекрестный переход в диалоговом окне Engineering Change Order

Вы можете осуществить перекрестный переход из диалогового окна Engineering Change Order, щелкнув ПКМ, чтобы вызвать команду перекрестного перехода для определения положения исходного компонента на схеме или целевого компонента в плате, как показано на изображении ниже.

Перекрестный переход в диалоговом окне Differences between

Диалоговое окно Differences between можно использовать для перекрестного перехода к выбранному компоненту на схеме или на плате. Дважды щелкните ЛКМ по строке компонента, чтобы перейти к нему на схеме или на плате.

Вызов диалогового окна Differences between осуществляется из диалогового окна Choose Documents To Compare (которое открывается с помощью команды Project » Show Differences). Это диалоговое окно используется для выбора двух документов/наборов документов для сравнения. Обычно это схема проекта и плата. Вы также можете использовать это диалоговое окно для сравнения любых двух документов, включив опцию Advanced Mode. Например, вы можете сравнить список цепей с платой или плату с другой платой. Когда документы выбраны, нажмите OK. Если существуют различия, будет открыто диалоговое окно Differences between, где вы можете исследовать эти различия.

Перекрестный переход из диалогового окна Variant Management

Вы можете использовать диалоговое окно Variant Management, чтобы осуществить перекрестный переход к выбранному компоненту на схеме или на плате. Дважды щелкните ЛКМ по компоненту в диалоговом окне Variant Management или щелкните ПКМ и выберите команду Cross Probe.

Перекрестный переход в панели Differences

Чтобы осуществить перекрестный переход к схеме или плате из панели Differences (нажмите кнопку Explore Differences в диалоговом окне Differences between, чтобы открыть панель), дважды щелкните ЛКМ по строке в панели.

Перекрестный переход в документе BomDoc

Перекрестный переход также можно выполнить из документа BomDoc. В документе BomDoc щелкните ПКМ, выберите команду Cross Probe и в подменю укажите, к какому объекту вы хотите перейти.

Перекрестное выделение

Эта функциональная возможность позволяет осуществлять динамическое двунаправленное перекрестное выделение компонентов. Она используется для выделения соответствующих объектов в документах схем и плат. Иными словами, при выделении объекта в документе платы тот же самый объект будет выделен в исходном документе схемы, и наоборот.

Для вызова этой функции выполните следующее:

  • Выберите Tools » Cross Select Mode в главном меню. Эта команда включает и отключает функциональную возможность, и состояние команды отображается в меню Tools. Если перекрестное выделение включено, то вокруг иконки Cross Select Mode в меню Tools отображается синий квадрат, как показано на изображении ниже.

    Функция Cross Select Mode в меню Tools отключена (слева) и включена (справа).
    Функция Cross Select Mode в меню Tools отключена (слева) и включена (справа).

  • Включите или отключите опцию Cross Selection на странице System - Navigation диалогового окна Preferences.
  • Нажмите Shift+Ctrl+X.
При включении команды Cross Select Mode из меню Tools в редакторе схем или плат она будет включена в обоих редакторах.

Когда команда Cross Select Mode включена, щелкните ЛКМ для выделения одного или множества объектов в рабочей области. Те же самые объекты будут выделены в соответствующем документе.

Целевой документ не станет активным, поэтому настоятельно рекомендуется, чтобы исходный и целевой документы были открыты рядом друг с другом.
Работа перекрестного выделения определяется настройками в разделе Cross Select Mode страницы System - Navigation диалогового окна Preferences.

Выделение компонентов на плате из схемы

Вы можете осуществлять перекрестное выделение между компонентами в одном или множестве исходных документов схемы и соответствующими посадочными местами компонентов в документе платы активного проекта. Например, это может быть полезным при выделении набора компонентов в исходных документах для быстрого создания нового класса компонентов в документе плате.

Чтобы использовать эту функциональную возможность:

  • Откройте целевой документ платы.
  • Выделите нужные компоненты в исходных документах схемы.
  • Выберите команду Tools » Select PCB Components.
Эту возможность также можно использовать, выбрав команду Part Actions » Select PCB Components из контекстного меню, когда курсор мыши наведен на выделенный компонент (или на один из выделенных компонентов). Если с помощью этого способа осуществляется перекрестное выделение одного компонента, он не обязательно должен быть выделен на схеме.

После запуска команды станет активным документ платы проекта. Все посадочные места соответствующих компонентов, которые былм выделены на схеме, будут выделены и приближены (но не маскированы) в рабочей области документа платы.

Поскольку целевая плата станет активным документом, настоятельно рекомендуется, чтобы исходные документы схемы и целевой документ платы были открыты рядом друг с другом.

Для создания нового класса компонентов после выделения компонента или множества компонентов на плате с помощью команды Select PCB Components выполните следующее:

  1. Выберите команду Design » Classes, чтобы открыть диалоговое окно Object Class Explorer.
  2. Щелкните ПКМ по Component Classes в левом столбце и выберите Add Class. Введите нужное имя нового класса.
  3. С помощью кнопки между разделами Non-Members и Members диалогового окна добавьте нужные выделенные компоненты в правый столбец.
  4. Нажмите Cancel, чтобы закрыть диалоговое окно Object Class Explorer и вернуться в рабочую область.
Обнаружили проблему в этом документе? Выделите область и нажмите Ctrl+Enter, чтобы оповестить нас.

Связаться с нами

Связаться с нашими Представительствами напрямую

We're sorry to hear the article wasn't helpful to you.
Could you take a moment to tell us why?
200 characters remaining
Вы сообщаете о проблеме, связанной со следующим выделенным текстом
и/или изображением в активном документе: