Altium Designer Documentation

Реструктуризация проекта_AD

Последнее изменение: Pavel Demidov; 08.07.2020

Главная страница: Подробнее о схемах

В традиционном понимании, рефакторинг – это процесс реструктуризации существующего проекта (или программного кода) без изменения функциональности этого проекта (или кода). С точки зрения проектирования плат, существуют различные ситуации, когда инструменты реструктуризации могут быть полезными и своевременными:

  • Компонент устарел, и его необходимо заменить функционально эквивалентной схемой (перейти).
  • Проект необходимо преобразовать в схему для использования в более крупном проекте (перейти).
  • Существующий лист схемы необходимо преобразовать в лист устройства для повторного использования в будущих проектах (перейти).
  • Существующий лист устройства необходимо локализовать и изменить для текущего проекта (перейти).
  • Участок схемы необходимо переместить на другой лист (перейти).

Altium Designer предлагает ряд функциональных возможностей, который в совокупности составляют инструменты реструктуризации (рефакторинга) проекта.

Преобразование компонента в символ листа

Эта возможность идеально подходит в случаях, когда существующий компонент устарел и его необходимо заменить функционально эквивалентной схемой, заданной на отдельном листе.

Щелкните ПКМ по компоненту и выберите команду Part Actions » Convert Part To Sheet Symbol из контекстного меню, чтобы преобразовать символ компонента в символ листа. Связность сохраняется, поскольку входы в лист называются в соответствии с изначальными названиями выводов, а типы входа/выхода (I/O Type) задаются в соответствии с электрически типами изначальных выводов.

Обозначение (Designator) символа листа изначально задается в соответствии позиционным обозначением исходного компонента, а имя файла (File Name) – в соответствии с комментарием компонента.

Преобразование компонента в символ листаПреобразование существующего компонента в символ листа.

Если нужный дочерний лист существует, измените File Name символа листа, чтобы он указывал на этот лист. В противном случае, подчиненный лист можно быстро создать, щелкнув ПКМ по символу листа и выбрав команду Sheet Symbol Actions » Create Sheet From Sheet Symbol. В этом случае, в новом подчиненном листе будут размещены порты, соответствующие входам в лист символа листа, и в нем можно формировать эквивалентную схему.

Команда Convert Part To Sheet Symbol также доступна из меню Tools » Convert.

Передача компонента в новый подчиненный лист

Чтобы достичь того же конечного результата другим и, возможно, более быстрым способом, щелкните ПКМ по нужному компоненту и выберите команду Part Actions » Push Part To Sheet. По сути, произойдет следующая последовательность действий:

  1. Компонент будет скопирован.
  2. Изначальный компонент будет преобразован в символ листа с обозначением (Designator), заданным в соответствии с обозначением изначального компонента, и именем файла (File Name), заданным как <КомментарийИзначальногоКомпонента>.SchDoc. Опять же, имена входов в лист и их тип I/O Type отражают соответствующие свойства изначального компонента.
  3. Из символа листа будет создан новый лист схемы, названный в соответствии со значением свойства File Name символа.
  4. В центр листа будет добавлена копия изначального компонента, с размещенными портами, соответствующими входам в лист символа листа и соединенными с выводами компонента.

Вы можете удалить компонент и заменить его нужной функционально эквивалентной схемой.

Команда Push Part To Sheet быстро преобразует изначальный компонент в символ листа, затем добавляет копию этого компонента на новый лист, на который ссылается этот символ.

Преобразование компонента в порты

Эта возможность идеально подходит в тех случаях, когда необходимо преобразовать отдельный существующий проект, например плату источника питания, в схему, которая будет использоваться в более крупном проекте платы. Возможно, так будет уменьшены затраты на производство. Это процесс обратный тому, что был описан в предыдущем разделе, где компонент заменялся схемой более низкого уровня. Здесь, напротив, схема подключается к проекту более высокого уровня, что делает ее доступной для подключения к точке на более высоком уровне иерархии.

Щелкните ПКМ по компоненту и выберите команду Part Actions » Convert Part To Ports из контекстного меню. Символ компонента будет преобразован в набор портов. Связность сохраняется, поскольку порты называются в соответствии с изначальными названиями выводов, а типы входа/выхода (I/O Type) задаются в соответствии с электрически типами изначальных выводов.

Используйте команду Convert Part To Ports, чтобы быстро заменить компонент портами, с помощью которых можно быстро включить схему в проект более высокого уровня.

Вставка схемы в иерархию завершается добавлением символа листа в нужный лист более высокого уровня. Для этого необходимо выполнить следующее:

  1. Сделайте нужный родительский лист активным.
  2. Используйте команду Design » Create Sheet Symbol From Sheet.
  3. Выберите документ, в котором содержатся созданные из компонента порты, в диалоговом окне Choose Document to Place.
  4. Символ листа появится под курсором – расположите его в нужном месте и щелкните ЛКМ, чтобы выполнить размещение.

Символ листа будет ссылаться на дочерний лист (через свойство File Name), и его входы в лист будут соответствовать портам на дочернем листе.


Используйте команду Create Sheet Symbol From Sheet, чтобы быстро добавить символ листа и, соответственно, включить схему в иерархию проекта.

Преобразование листа схемы в лист устройства

На определенном этапе у концепции повторного использования проектных данных повышается уровень абстракции. Если остановиться на уровне компонентов, то создание проектов с одинаковыми участками функциональности, например USB-интерфейсом или регулятором напряжения, превратится в изобретение велосипеда. И здесь станут полезными листы устройств – листы схем, разработанные для определенной функциональности. Их использование сокращает риски, связанные с традиционным подходом копирования и вставки. Кроме того, они устраняют необходимость в повторении определенных участков схем, когда они добавлены на уровень проектных данных, которые можно использовать в будущих проектах.

Редактор схем в своем наборе инструментов реструктуризации предлагает возможность быстро преобразовать существующий стандартный лист схемы в лист устройства для его повторного использования в других проектах.

Для повышения степени целостности проектных данных и оптимизации их повторного использования, а также для управления ревизиями и жизненным циклом и контроля использования рассмотрите выпуск листов схем на сервер управляемых данных. Эти проектные элементы, которые называются управляемыми листами схем, становятся доступны всем проектировщикам в компании, и они предлагают высококачественные "строительные блоки" более высокого уровня для повторного использования в будущих проектах. Проектировщик, подобно тому, как он берет готовые компоненты, повторно использует эти управляемые листы в качестве составных частей более крупного проекта. Для получения более подробной информации перейдите на страницу Управляемые листы схем.

Чтобы преобразовать существующий лист схемы в лист устройства:

  1. Найдите символ листа, ссылающийся на нужный лист, на соответствующем родительском листе в иерархии проекта.
  2. Выделите символ листа и выберите команду Edit » Refactor » Convert Selected Schematic Sheet To Device Sheet из главного меню. Будет открыто диалоговое окно Convert Schematic Sheet to Device Sheet. Выберите целевое расположение, в котором будет храниться новый лист устройства, а также область действия преобразования, т.е. нужно ли обновлять текущий символ листа или все соответствующие символы листов в рабочей области или в активном проекте. Последний вариант может быть особенно полезным в многоканальном проекте, где существует несколько экземпляров схемы.

    Укажите опции преобразования в диалоговом окне Convert Schematic Sheet to Device Sheet.

    Нажмите кнопку в правой части поля, чтобы открыть диалоговое окно Choose Device Sheet Folder со списком всех определенных на текущий момент папок листов устройств. Для добавления новой папки нажмите кнопку Device Sheet Folders в нижней части диалогового окна, чтобы открыть диалоговое окно Device Sheet Folders. Либо задайте папки листов устройств на странице Data Management - Device Sheets диалогового окна Preferences.
  3. Нажмите OK. Символ листа будет преобразован в символ листа устройства, а схема будет перемещена в указанное расположение листов устройств.

В отличие от обычного копирования и вставки, реструктуризация поддерживает уникальные идентификаторы на схемах (в том числе символов листов и символов листов устройств), что обеспечивает непрерывную связь этих схем с их физическими экземплярами в редакторе плат.

Преобразование листа устройства в лист схемы

Листы устройств позволяют сформировать участок схемы и повторно использовать его в других проектах. Тем не менее, может возникнуть необходимость изменить существующий участок схемы для определенного проекта. Вместо изменения самого листа устройства редактор схем позволяет создать копию листа устройства, что сделает его схему доступной на обычном листе схемы. Это позволит внести в локальную копию изменения в соответствии с требованиями текущего проекта и оставить исходный лист устройства нетронутым.

Для преобразования существующего листа устройства в лист схемы выполните следующее:

  1. Найдите символ листа устройства, который ссылается на нужный лист устройства.
  2. Выделите символ листа устройства и выберите команду Edit » Refactor » Convert Device Sheet To Schematic Sheet из главного меню. Будет открыто диалоговое окно Convert Device Sheet to Schematic Sheet. Выберите целевое расположение, в котором будет храниться новый лист схемы, а также область действия преобразования, т.е. нужно ли обновлять текущий символ листа устройства или все соответствующие символы листов устройств в рабочей области или в активном проекте.

    Укажите опции преобразования в диалоговом окне Convert Device Sheet to Schematic Sheet.

    По умолчанию директорией Target Schematic Sheet Location является та, в которой находится активный проект. Название листа задается в соответствии со свойством File Name символа листа устройства. Нажмите кнопку в правой части поля, чтобы открыть диалоговое окно Open, в котором вы при необходимости можете изменить, где и под каким именем будет сохранена схема.
  3. Нажмите OK. Символ листа устройства будет преобразован в символ листа, и копия листа устройства будет сохранена в указанном расположении локально как обычный (незащищенный от изменений) лист. Символ листа будет ссылаться на этот локальный лист.

    Нет необходимости проводить повторную компиляцию активного проекта, поскольку это выполняется автоматически, и новый лист схемы будет отображен в панели Projects.

    После преобразования локальный лист схемы заменит лист устройства в панели Projects.

Перемещение выделенного участка цепи на другой лист

По мере развития проекта, может возникнуть необходимость в перемещении содержимого исходных листов схем, которые составляют этот проект. Например, если лист стал перегружен, то определенную часть схемы может разместить на отдельном листе, чтобы улучшить читаемость схемы.

Еще одним инструментом реструктуризации является возможность выделения одного или множества объектов на листе и перемещение этого набора выделенных объектов на другой лист. Для этого необходимо выполнить следующее:

  1. Выделите участок схемы, который нужно переместить.
  2. Щелкните ПКМ и выберите команду Edit » Refactor » Move Selected Subcircuit to Different Sheet из контекстного меню. Будет открыто диалоговое окно Choose Destination Document – используйте его, чтобы указать целевой лист схемы.

    Если выделенный участок схемы нужно перенести на совершенно новый лист, сначала создайте и сохраните схему, чтобы она появилась в диалоговом окне Choose Destination Document.

    Переместите часть проекта на другой лист схемы.

  3. Нажмите OK. Выбранный лист станет активным, и выделенный участок схемы появится под курсором.
  4. Расположите схему на листе нужным образом и щелкните ЛКМ, чтобы выполнить размещение. После размещения этот участок схемы будет удален из изначального листа.
  5. При размещении на новом листе добавьте символ листа на соответствующую родительскую страницу, чтобы лист был корректно добавлен в иерархию проекта.
Обнаружили проблему в этом документе? Выделите область и нажмите Ctrl+Enter, чтобы оповестить нас.

Связаться с нами

Связаться с нашими Представительствами напрямую

We're sorry to hear the article wasn't helpful to you.
Could you take a moment to tell us why?
200 characters remaining
Вы сообщаете о проблеме, связанной со следующим выделенным текстом
и/или изображением в активном документе:
Бесплатная пробная версия Altium Designer
Бесплатная пробная версия Altium Designer
Давайте приступим. Для начала, Вы или Ваше предприятие уже используете Altium Designer?

Если Вы хотите поговорить с представителем, пожалуйста, свяжитесь с местным офисом Altium.
Copyright © 2019 Altium Limited

В таком случае, для чего Вам необходима пробная лицензия?

Если Вы хотите поговорить с представителем, пожалуйста, свяжитесь с местным офисом Altium.
Copyright © 2019 Altium Limited

Вам для этого не нужна пробная лицензия.

Нажмите кнопку ниже, чтобы загрузить установщик самой новой версии Altium Designer

Загрузить установщик Altium Designer

Если Вы хотите поговорить с представителем, пожалуйста, свяжитесь с местным офисом Altium.
Copyright © 2019 Altium Limited

Пожалуйста, заполните форму ниже, чтобы получить ценовое предложение.

Нажимая [Получить бесплатнную пробную версию], Вы соглашаетесь с нашей Политикой конфиденциальности. Вам могут приходить сообщения от компании Altium, и Вы можете изменить настройки уведомлений в любой момент.

Если Ваша подписка Altium активна, у Вас нет необходимости в пробной лицензии.

Если у Вас нет активной подписки Altium, пожалуйста, заполните форму ниже, чтобы получить пробную версию.

Нажимая [Получить бесплатнную пробную версию], Вы соглашаетесь с нашей Политикой конфиденциальности. Вам могут приходить сообщения от компании Altium, и Вы можете изменить настройки уведомлений в любой момент.

Для чего Вы хотите попробовать Altium Designer?

Если Вы хотите поговорить с представителем, пожалуйста, свяжитесь с местным офисом Altium.
Copyright © 2019 Altium Limited

Вы нашли нужное место! Пожалуйста, заполните форму ниже, чтобы начать использование пробной версии.

Нажимая [Получить бесплатнную пробную версию], Вы соглашаетесь с нашей Политикой конфиденциальности. Вам могут приходить сообщения от компании Altium, и Вы можете изменить настройки уведомлений в любой момент.

Great News!

Valid students can get their very own 6-month Altium Designer Student License for FREE! Just fill out the form below to request your Student License today.

Нажимая [Получить бесплатнную пробную версию], Вы соглашаетесь с нашей Политикой конфиденциальности. Вам могут приходить сообщения от компании Altium, и Вы можете изменить настройки уведомлений в любой момент.

Вы можете загрузить бесплатную лицензию средства просмотра Altium Designer Viewer сроком действия 6 месяцев.

Пожалуйста, заполните форму ниже, чтобы запросить эту лицензию.

Нажимая [Получить бесплатнную пробную версию], Вы соглашаетесь с нашей Политикой конфиденциальности. Вам могут приходить сообщения от компании Altium, и Вы можете изменить настройки уведомлений в любой момент.

Замечательно! Создавать новое - отличное занятие. У нас есть превосходная программа для Вас.

Upverter - бесплатная платформа, разработанная специально для любителей проектирования.

Нажмите здесь, чтобы попробовать!

Если Вы хотите поговорить с представителем, пожалуйста, свяжитесь с местным офисом Altium.
Copyright © 2019 Altium Limited

Вы можете загрузить бесплатную лицензию средства просмотра Altium Designer Viewer сроком действия 6 месяцев.

Пожалуйста, заполните форму ниже, чтобы запросить эту лицензию.

Нажимая [Получить бесплатнную пробную версию], Вы соглашаетесь с нашей Политикой конфиденциальности. Вам могут приходить сообщения от компании Altium, и Вы можете изменить настройки уведомлений в любой момент.