Altium Designer Documentation

Листы устройств

Последнее изменение: Pavel Demidov; 07.07.2020

Главная страница: Повторное использование проектных данных

Существуют веские причины для повторного использования участков схем из существующих проектов. Проект проверен, соответственно, его разработка завершена. Это экономит время, это может помочь сократить номенклатуру компонентов и это позволяет вашей проектной команде сосредоточиться на разработке новых идей и изделий.

Проектировщики – умные люди, они уже постоянно повторно используют существующие проекты. Это может быть проверенная схема, которую они воссоздают или, возможно, копируют из существующего проекта, либо существующий лист схемы, на который добавляют ссылку в новом проекте.

Листы устройств упрощают процесс проектирования, предоставляя проектировщикам готовые строительные блоки, которые можно повторно использовать в различных проектах. Символы листов устройств размещаются и задаются схожим с компонентами образом. Они работают так же, как символы листов и документы схем, но они не добавляются в проекты в явном виде.

Листы устройств

Листы устройств являются строительными блоками, разработанными для их повторного использования в различных проектах. Как правило, они содержат в себе предопределенные участки схем, которые используются во множестве проектов, например, цепи питания.


Один лист устройства может использоваться во множестве проектов.

Листы устройств создаются и хранятся как обычные документы схем в специальной папке листов устройств. Они не добавляются в проект в качестве документов, а размещаются и задаются подобно компонентам. Листы устройств включаются в иерархию проекта, и в панели Projects они отличаются от стандартных документов схем другой иконкой.

По умолчанию листы устройств доступны только для чтения. Это означает, что все проектировщики могут быть уверены, что эти листы завершены и готовы к использованию, и это также гарантирует, что никто в команде не сможет случайно изменить их. Поскольку они доступны только для чтения, ни позиционные обозначения компонентов, ни номера листов схем не могут быть изменены.

Основным отличием между листом устройства и обычным листом схемы является то, что у системы есть дополнительные функциональные возможности для управления аннотированием компонентов и нумерацией листов схем, когда проект содержит в себе листы устройств.

Листы устройств и управляемые листы

При изучении повторного использования проектных данных вы можете встретить термины Листы устройств и Управляемые листы. С точки зрения того, что они предлагают проектировщику, они очень похожи между собой, поскольку они все обеспечивают простой механизм повторного использования проектных данных, а также поддерживают аннотирование компонентов и нумерацию листов схем на уровне проекта.

Их отличие заключается в том, что листы устройств должны управляться проектировщиком, т.е. проектировщик управляет доступом к документу, его ревизиями, жизненным циклом и т.д.

Управляемый лист является, по сути, листом устройства, который хранится на сервере управляемых данных. В этом случае, все задачи управления документом выполняются сервером, в том числе управление доступом к документу, его историей и жизненным циклом.

► Узнайте больше об Управляемых проектах.

► Узнайте больше о Работе с сервером управляемых данных.

Включение поддержки листов устройств

  1. С помощью Проводника Windows создайте папку в подходящем расположении, где будут храниться листы устройств. Если нужно, вы можете создать главную папку Device Sheets с подпапками в соответствии с требованиями своей компании, например Data Conversion, Power и т.д.

  2. Главная папка листов устройств задается на странице Data Management - Device Sheets диалогового окна Preferences, как показано ниже. Включите опцию Include Sub-folders (Включать подпапки), если нужно.

Создание листов устройств

Листом устройства может быть любой обычный лист схемы, в том числе схема, которая содержит символы листов, ссылающиеся на другие листы схем. Именно тот факт, что он размещен как лист устройства из соответствующей папки, указывает системе, что эта схема является листом устройства, что необходимо применить опции управления листами устройств, заданные в диалоговом окне, и что они должны обрабатываться специальными командами аннотирования компонентов и нумерации листов.

По умолчанию листы устройств доступны только для чтения. Сложностью при работе с листами устройств является не то, что они защищены от изменения, а завершение проекта, которое необходимо выполнить после проектирования, т.е. нумерация листов и аннотирование компонентов.

Перед копированием или перемещением схемы в папку хранения листов устройств следует выполнить некоторые подготовительные действия:

  • Воспринимайте лист устройства как завершенную часть работы. Убедитесь, что применен корректный шаблон, с требуемыми аннотациями компании и заданными специальными строками.
  • Использование систематической схемы именования листов устройств поможет организовать листы устройств в диалоговом окне Select Device Sheet.
  • Аннотируйте схему листа устройства (Tools » Annotation » Annotate Schematics) перед ее помещением в папку листов устройств. Одни проектировщики используют простую, плоскую схему нумерации компонентов, другие добавляют суффикс для отражения назначения этого участка схемы. После завершения проекта все листы и компоненты в проекте могут быть перенумерованы.

Использование листа устройства в проекте

Лист устройства используется в проекте путем размещения символа листа, который его представляет. Для этого:

  1. Запустите команду Place » Device Sheet Symbol.
  2. Будет открыто диалоговое окно Select Device Sheet. Дерево слева отображает вложенную структуру папки, выбранной на странице Data Management - Device Sheets диалогового окна Preferences. Все листы схем, найденные в выбранной папке, будут перечислены в правой части диалогового окна, как показано ниже.

    Выберите нужную папку листов устройств слева, затем лист устройства справа.

  3. Выберите нужный лист устройства и нажмите OK. Вы вернетесь в редактор схем, и к курсору будет прикреплен символ листа этого листа устройства, как показано ниже.


    Размещенный символ листа устройства.

  4. Щелкните ЛКМ, чтобы разместить символ листа (на изображении выше показан размещенный символ листа). Обратите внимание, что символ листа устройства отличается от символа листа, который ссылается на обычный лист схемы, скругленными углами и символом рециркуляции. Вы можете беспрепятственно изменять размер размещенного символа и перемещать входы в лист.
  5. Обратите внимание, что для представления листа устройства используется другая иконка, отличная от обычного листа схемы.

    Лист устройства будет показан в иерархии проекта со специальной иконкой листа устройства.

Символу листа устройства будет присвоено обозначение U_<ИмяФайлаЛистаУстройства>. Измените его, если необходимо.

Теперь вы можете добавить линии связи к листу устройства, таким же образом, как и для стандартного листа устройства. Поддерживаются все стандартные возможности определения связей, такие как метки цепей, порты и входы в лист, порты питания и сигнальные жгуты.

► Узнайте больше о Создании связности.

Свойства листа устройства


Лист устройства, доступный только для чтения. Обратите внимание, что у вкладки Editor под рабочей области есть суффикс (ReadOnly), что означает, что вы просматриваете лист устройства, который нельзя изменить. Также существует опция для отображения водяного знака Read Only и водяного знака листа устройства (рециркуляция).

После размещения символа листа устройства откройте сам лист устройства, чтобы увидеть его графические свойства. Листы устройств по умолчанию настроены на доступ только для чтения, что задано в области Options страницы Data Management - Device Sheets диалогового окна Preferences. Обратите внимание, что опция Read-Only не зависит от отображения водяного знака Read Only. Посмотрите на вкладку Editor под рабочей областью, чтобы увидеть, доступен ли лист только для чтения (как показано выше).

Редактирование листа устройства

Вы можете изменять листы устройств одним из двух способов: либо непосредственно в проекте, либо из исходного документа схемы в папке листов устройств.

Изменение листов устройств непосредственно в проекте

Для изменения листов устройств непосредственно в проекте:

  • Нажмите в верхней правой части окна, чтобы открыть диалоговое окно Preferences.
  • Перейдите на страницу Data Management - Device Sheets.
  • Снимите флажок Make Device Sheets in Projects Read-Only, затем нажмите OK.

Задайте опции листов устройств нужным образом. Обратите внимание, что это настройки среды, что означает, что они будут применены ко всем листам устройств во всех проектах, редактируемым в этой установке системы.

Вы обратите внимание, что после включения возможности редактирования листов устройств водяной знак Read Only пропадает и у вкладки Editor больше нет суффикса (ReadOnly).

Использовать такой к редактированию листов устройств не рекомендуется, поскольку все листы устройств станут доступны для редактирования в этой установке системы.

Редактирование листа устройства из папки листов устройств

Для изменения листов устройств из папки листов устройств:

  • Закройте все открытые проекты, которые ссылаются на лист устройства. Вы не сможете открыть лист устройства как исходный документ схемы, если открыт какой-либо проект, который ссылается на этот лист устройства.
  • Используйте команду File » Open, чтобы открыть лист устройства из исходного документа в папке листов устройств. Лист будет открыт как стандартный документ схемы, без каких-либо водяных знаков.
  • Выполните необходимые изменения, сохраните их и закройте лист устройства.
Обратите внимание, что после изменения листа устройства все проекты, ссылающиеся на него, также будут обновлены.
Такой подход к изменению листов устройств является рекомендуемым.

Иерархический проект с листами устройств

Лист устройства может содержать символы листов устройств, но лист устройства не может быть листом верхнего уровня в проекте. При использовании листов устройств нет ограничений на глубину иерархической структуры.

Для подготовки иерархических листов устройств:

  • Подготовьте и сохраните все необходимые дочерние документы схем как листы устройств в папке листов устройств.
  • Разместите символы листов устройств в родительской схеме и сохраните ее в папке листов устройств.


Эта схема является листом устройства, и в ней также размещен символ листа устройства, который ссылается на дочерний лист устройства.

Листы устройств также можно использовать в многоканальном проекте, что позволяет повторить участок схемы без его копирования/вставки.

► Узнайте больше о Многолистовых и многоканальных проектах.

Реструктуризация проекта с листами устройств

Главная страница: Реструктуризация проекта

Процесс проектирования зачастую не упорядочен, проектировщик может формулировать идеи одновременно для множества частей проекта, формируя эти части по мере развития своих идей. Это значит, что схемы могут стать перегруженными и плохо организованными. Хотя вы можете вырезать, копировать и вставлять содержимое схем для реструктуризации проекта, если не всегда является лучшим подходом.

Почему так? При размещении компонента ему назначает уникальный идентификатор, и этот идентификатор автоматически сбрасывается при вырезании/копировании и вставке компонента. Такое управление уникальными идентификаторами служит для того, чтобы обеспечить использование в проекте лишь одного экземпляра каждого идентификатора, поскольку он является ключевым полем, которое связывает компонент на схеме с компонентом на плате. Подход с вырезанием/копированием/вставкой подходит, если проект не был передан в редактор плат, но в противном случае лучше использовать инструменты реструктуризации.

Перемещение подцепи на другой лист

Самым простым способом перемещения участка схемы с одного листа на другой является его выделение и запуск команды Edit » Refactor » Move Selected Subcircuit to Different Sheet. Будет открыто диалоговое окно Choose Destination Document, где вы выбираете целевой лист и нажимаете OK. Будет открыт выбранный лист, где под курсором будут отображены выбранные объекты, готовые к размещению.


Выделенную часть схемы можно легко переместить на другой лист в проекте с помощью команды Move Selected Subcircuit to Different Sheet.

Команды реструктуризации поддерживают:

  • Преобразование существующей схемы в лист устройства.
  • Преобразование листа устройства в обычный лист схемы.
  • Перемещение участка схемы на другой лист.
  • Преобразование компонента в символ листа.

► Узнайте больше о Реструктуризации проекта.

Аннотирование компонентов и листов

Чтобы гарантировать целостность схемы, используемой в листе устройства, этот лист не следует редактировать в обычном процессе проектирования. Это значит, что номер листа и позиционные обозначения не следует изменять на листе. Как же тогда пронумеровать все листы в проекте и аннотировать все компоненты?

Эти задачи управляются двумя командами: листы нумеруются с помощью команды Annotate Compiled Sheets, а компоненты аннотируются с помощью команды Board Level Annotation. Номер листа и позиционные обозначения хранятся в отдельном файле <НазваниеПроекта>.annotation.

Средствам аннотирования компонентов необходимо знать порядок, в котором следует обрабатывать листы схем. По этой причине лучше нумеровать листы перед аннотированием компонентов.

Аннотирование скомпилированных листов устройств

Главная страница: Нумерация листов

Команда Tools » Annotation » Annotate Compiled Sheets, дополняющая возможность аннотирования на уровне платы, используется для нумерации листов устройств уникальным образом без изменения исходных схем. Как и при аннотировании компонентов, номера листов хранятся в файле <НазваниеПроекта>.annotation.

Замечания по нумерации листов:

  • Листы можно пронумеровать в соответствии с порядком, в котором они отображены в панели Projects. Этот порядок можно изменить в панели Projects путем перетаскивания мышью. Сохраните проект после изменения порядка, чтобы новый порядок, который будет использовать диалоговое окно аннотирования, был отражен в файле проекта. Обратите внимание, что изменение порядка путем перетаскивания мышь не поддерживается для листов устройств.
  • Пронумеруйте схемы, не являющиеся листами устройств, с помощью команды Tools » Annotation » Number Schematic Sheets. Нажмите F1 в диалоговом окне, чтобы узнать больше о доступных опциях и элементах управления.
  • Затем перенумеруйте все листы, в том числе листы устройств, с помощью команды Tools » Annotation » Annotate Compiled Sheets.
  • Диалоговые окна нумерации поддерживают непосредственный ввод значений. Иногда такой подход может быть эффективным.
  • У многих диалоговых окон есть кнопки двойного назначения, например кнопка Annotate Sheet (показана выше):
    • Нажмите по стрелке на кнопке, чтобы отобразить опции аннотирования и задать их нужным образом.
    • Затем нажмите по основной области кнопки, чтобы выполнить нумерацию в соответствии с заданными опциями.

► Узнайте больше об Аннотировании скомпилированных листов.

Аннотирование компонентов

Главная страница: Аннотирование компонентов

Для определения уникальных позиционных обозначений компонентов в проекте система включает в себя возможность аннотирования на уровне платы. Эта команда не изменяет исходные листы схем, а хранит в себе данные о сопоставлении каждого логического позиционного обозначения на схеме с физическим позиционным обозначением, которое появится на плате. Это сопоставление позиционных обозначений хранится в файле <НазваниеПроекта>.annotation. Существует широкий набор опций аннотирования, доступный в диалоговом окне Board Level Annotate.


Аннотирование на уровне платы позволяет повторно аннотировать завершенный проект путем определения уникальных физических обозначений для всех компонентов.

Замечания по работе с аннотирование на уровне платы, относящиеся к изображению выше:

  • Позиционные обозначения должны быть определены для всех компонентов схемы перед запуском команды аннотирования на уровне платы с помощью команды Tools » Annotation » Annotate Schematics. Эта обеспечит доступность исходных данных схемы, в том числе опций упаковывания для многосекционных компонентов, в качестве входных данных для аннотирования на уровне платы.
  • Аннотирование на уровне платы выполняется запуском команды Tools » Annotation » Board Level Annotate.
  • На изображение выше активна вкладка Editor схемы. Эта вкладка всегда показывает логические позиционные обозначения в их стандартном размере, в то время как физические обозначения показаны как верхние надписи. На скомпилированной вкладке схемы (U_CVE в этом примере), наоборот, физические обозначения будут показаны в их стандартном размере, а логические – как верхние надписи. Это настраивается на странице Schematic - Compiler диалогового окна Preferences, как показано ниже.

  • По умолчанию в редакторе плат отображаются физические позиционные обозначения. Это можно изменить в панели Properties в режиме Board, как показано ниже (этот режим отображается, когда в рабочей области платы нет выделенных объектов).

► Узнайте больше об Аннотировании на уровне платы.

Устранение проблем

Если вы открыли проект, содержащий в себе листы устройств, и расположение этих листов устройств не задано, вы увидите диалоговое окно со списком листов устройств, которые не могут быть найдены.

Если вы нажмете Yes, будет открыта область папок листов устройств страницы Data Management - Device Sheets диалогового окна Preferences. Возможно, не была включена опция Include Sub-Folders. В противном случае, добавьте новый путь, если листы устройств, используемые в проекте, хранятся в другом месте.

Обнаружили проблему в этом документе? Выделите область и нажмите Ctrl+Enter, чтобы оповестить нас.

Связаться с нами

Связаться с нашими Представительствами напрямую

Вы сообщаете о проблеме, связанной со следующим выделенным текстом
и/или изображением в активном документе:
Бесплатная пробная версия Altium Designer
Бесплатная пробная версия Altium Designer
Давайте приступим. Для начала, Вы или Ваше предприятие уже используете Altium Designer?

Если Вы хотите поговорить с представителем, пожалуйста, свяжитесь с местным офисом Altium.
Copyright © 2019 Altium Limited

В таком случае, для чего Вам необходима пробная лицензия?

Если Вы хотите поговорить с представителем, пожалуйста, свяжитесь с местным офисом Altium.
Copyright © 2019 Altium Limited

Вам для этого не нужна пробная лицензия.

Нажмите кнопку ниже, чтобы загрузить установщик самой новой версии Altium Designer

Загрузить установщик Altium Designer

Если Вы хотите поговорить с представителем, пожалуйста, свяжитесь с местным офисом Altium.
Copyright © 2019 Altium Limited

Пожалуйста, заполните форму ниже, чтобы получить ценовое предложение.

Нажимая [Получить бесплатнную пробную версию], Вы соглашаетесь с нашей Политикой конфиденциальности. Вам могут приходить сообщения от компании Altium, и Вы можете изменить настройки уведомлений в любой момент.

Если Ваша подписка Altium активна, у Вас нет необходимости в пробной лицензии.

Если у Вас нет активной подписки Altium, пожалуйста, заполните форму ниже, чтобы получить пробную версию.

Нажимая [Получить бесплатнную пробную версию], Вы соглашаетесь с нашей Политикой конфиденциальности. Вам могут приходить сообщения от компании Altium, и Вы можете изменить настройки уведомлений в любой момент.

Для чего Вы хотите попробовать Altium Designer?

Если Вы хотите поговорить с представителем, пожалуйста, свяжитесь с местным офисом Altium.
Copyright © 2019 Altium Limited

Вы нашли нужное место! Пожалуйста, заполните форму ниже, чтобы начать использование пробной версии.

Нажимая [Получить бесплатнную пробную версию], Вы соглашаетесь с нашей Политикой конфиденциальности. Вам могут приходить сообщения от компании Altium, и Вы можете изменить настройки уведомлений в любой момент.

Great News!

Valid students can get their very own 6-month Altium Designer Student License for FREE! Just fill out the form below to request your Student License today.

Нажимая [Получить бесплатнную пробную версию], Вы соглашаетесь с нашей Политикой конфиденциальности. Вам могут приходить сообщения от компании Altium, и Вы можете изменить настройки уведомлений в любой момент.

Вы можете загрузить бесплатную лицензию средства просмотра Altium Designer Viewer сроком действия 6 месяцев.

Пожалуйста, заполните форму ниже, чтобы запросить эту лицензию.

Нажимая [Получить бесплатнную пробную версию], Вы соглашаетесь с нашей Политикой конфиденциальности. Вам могут приходить сообщения от компании Altium, и Вы можете изменить настройки уведомлений в любой момент.

Замечательно! Создавать новое - отличное занятие. У нас есть превосходная программа для Вас.

Upverter - бесплатная платформа, разработанная специально для любителей проектирования.

Нажмите здесь, чтобы попробовать!

Если Вы хотите поговорить с представителем, пожалуйста, свяжитесь с местным офисом Altium.
Copyright © 2019 Altium Limited

Вы можете загрузить бесплатную лицензию средства просмотра Altium Designer Viewer сроком действия 6 месяцев.

Пожалуйста, заполните форму ниже, чтобы запросить эту лицензию.

Нажимая [Получить бесплатнную пробную версию], Вы соглашаетесь с нашей Политикой конфиденциальности. Вам могут приходить сообщения от компании Altium, и Вы можете изменить настройки уведомлений в любой момент.