Altium Designer Documentation

Управляемые шаблоны компонентов

Последнее изменение: Pavel Demidov; 27.10.2020
Полное содержание

Главная страница: Работа с управляемыми компонентами

Поддержка шаблонов компонентов не включена в Altium 365 Standard. Соответственно, при этом уровне доступа к Altium 365, данная функциональность не будет доступна при подключении к Altium 365 Workspace.

Для упрощения создания управляемых компонентов, Altium Designer в сочетании с сервером управляемых данных поддерживает использование шаблонов компонентов (Component Templates). Подобно тому, как шаблоны схем можно использовать для предварительного определения информации на листах схем, которые ссылаются на эти шаблоны, управляемый компонент ссылается на шаблон компонентов, который предоставляет заранее определенные настройки для их использования этим компонентом.

Так, в частности, шаблоны компонентов были разработаны с учетом информации о параметрах. Это позволяет в едином расположении определить набор параметров, которые станут доступны в компоненте, ссылающемся на этот шаблон. С помощью шаблона вы можете управлять тем, какие из этих параметров должны быть видимы, задать значения по умолчанию и даже обозначить параметры как обязательные. Чтобы обеспечить соответствие, во время выпуска компонента осуществляются валидационные проверки.

Указанные значения по умолчанию для многих настроек в шаблоне могут быть заблокированы для доступа к ним только на чтение, либо их можно выборочно задать как доступные для переопределения проектировщиком в процессе создания управляемого компонента.

Эти объекты создаются непосредственно на сервере. После того, как объект шаблона компонентов создан (и данные выпущены в ревизию этого объекта) и состояние его жизненного цикла задано на том уровне, при котором этот объект можно использовать на уровне проектов, его можно повторно использовать при создании одного или множества управляемых компонентов.

Тип папки

При создании папки, в которой будут храниться объекты шаблонов компонентов, вы можете указать тип этой папки. Это не имеет отношения к содержимому папки – выпуск шаблона компонентов всегда осуществляется в соответствующий объект шаблона компонентов (Component Template Item). Таким образом вы лишь обеспечиваете визуальную подсказку о том, что хранится в папке, что может быть полезными при поиске определенного содержимого на сервере. Чтобы указать, что папка используется в качестве контейнера для объектов символов, задайте ее тип (Folder Type) как Component Templates при определении свойств папки в диалоговом окне Edit Folder.


Определение типа папки, т.е. ее планируемого использования, предоставляет визуальную индикацию содержимого этой папки при просмотре данных на сервере.

Другим важным аспектом родительской папки является используемая для нее схема именования объектов (Item Naming Scheme), которая определяет формат уникального идентификатора каждого объекта, создаваемого в этой папке. Доступны несколько примеров схем по умолчанию, использующих краткий код для папок каждого типа (CTC для наборов шаблонов компонентов) или для содержимого каждого типа (CMPT для шаблонов компонентов):

  • $CONTENT_TYPE_CODE-001-{0000} – например, CMPT-001-0001.
  • $CONTENT_TYPE_CODE-001-{A00} – например, CMPT-001-A01.
  • $FOLDER_TYPE_CODE-001-{0000} – например, CTC-001-0001.
  • $FOLDER_TYPE_CODE-001-{A000} – например, CTC-001-A001.

Используя схему именования по умолчанию, система автоматически назначит следующий уникальный идентификатор на основе этой схемы, просканировав весь сервер и идентификаторы существующих объектов. Это может значительно сэкономить время при создании объектов шаблонов компонентов вручную.

Для папки также можно определить пользовательскую схему путем ее ввода в поле, с переменной частью в фигурных скобках (например, CMP-TMP-{0000}).


Схема именования объектов родительской папки применяется к уникальным идентификаторам всех объектов, которые создаются в этой папке.

Схему Item Naming Scheme, примененную к родительской папке, можно в любой момент изменить. Измененная схема будет применяться ко всем создаваемым далее в этой папке объектам.

Тип объекта

При создании целевого объекта шаблона компонентов, в котором будет храниться шаблон компонентов, убедитесь, что в диалоговом окне Create New Item его тип содержимого (Content Type) определен как Component Template. Если вы создаете объект в папке с типом Component Templates, то объект этого типа будет доступен в контекстном меню при создании объекта.


Создание объекта символа в папке Component Templates. Нужный тип содержимого (Content Type) доступен в контекстном меню.

При определении объекта шаблона компонентов убедитесь, что указан тип управления жизненным циклом для его использования с этим объектом и схема именования ревизий этого объекта.

Управление тем, какие типы объектов могут использовать конкретное определение жизненных циклов или схему именования ревизий, осуществляется на глобальном уровне в диалоговом окне Content Types, при определении схемы. Схемами по умолчанию, которые назначаются объекту шаблона компонентов, являются Generic Lifecycle и 1-Level Revision Scheme.

После того, как шаблон компонентов был выпущен в начальную ревизию объекта шаблона компонентов, эти схемы не могут быть изменены для этого конкретного объекта.

Укажите нужные схемы в диалоговом окне Create New Item с помощью полей Lifecycle Definition и Revision Naming Scheme соответственно.

Если включена опция для управления использованием определений жизненных циклов и схем именования ревизий по типу содержимого и для типа Component Template Item не задано использование конкретного определения/схемы, то это определение/схема будет не доступно в соответствующем выпадающем списке.


Выбор определения жизненного цикла и схемы именования ревизий для создаваемого вручную объекта.

Придерживаясь стандартных схем именования ревизий и определений жизненных циклов для различных типов проектных объектов на сервере управляемых данных, вы обеспечите понятное и надежное управление этими объектами.
Хорошей идеей является добавление названия и описания в определение объекта. Эта информация используется при поиске на сервере и позволяет быстро идентифицировать, что предлагает тот или иной объект шаблона компонентов.

Выпуск шаблона компонентов

Связанная страница: Прямое создание и редактирование объектов на сервере

До сих пор рассматривалась поддержка объекта шаблона компонентов на сервере с точки зрения соответствующих типов папки и объекта. Выпуск определенного шаблона компонентов в ревизию такого объекта может быть выполнен удобным способом.

Шаблон компонентов может быть отредактирован и выпущен в начальную ревизию нового объекта шаблона компонентов с помощью прямого редактирования, поддерживаемого сервером. Прямое редактирование избавляет от ограничений отдельных исходных данных под контролем версий. Вы можете просто изменить объект поддерживаемого типа с помощью временного редактора, в который загружена самая новая версия исходных данных непосредственно с сервера. По завершении редактирования, сущность выпускается (или выпускается повторно) в последующую запланированную ревизию родительского объекта, и временный редактор закрывается. Нет файлов на вашем жестком диске, не нужно задаваться вопросом о том, работаете ли вы с корректными и самыми новыми данными, нет необходимости в обслуживании отдельного программного обеспечения для контроля версий. Всем этим управляет сервер, с высокой степенью целостности, для значительного ускорения внесения изменений в данные.

После создания объекта шаблона компонентов вы можете изменить его и выпустить шаблон компонентов в начальную ревизию этого объекта. Для этого включите опцию Open for editing after creation в нижней части диалогового окна Create New Item (опция включен по умолчанию). Объект будет создан, и откроется временный редактор шаблонов компонентов, с документом .CMPT в качестве активного документа в главном окне приложения. Этот документ будет назван в соответствии с объектом-ревизией, в формате <Объект><Ревизия>.CMPT (например CMPT-001-0001-1.CMPT).


Пример редактирования начальной ревизии объекта шаблона компонентов непосредственно с сервера управляемых данных. Временный редактор шаблонов компонентов предлагает документ для определения шаблона компонентов.

Используйте документ для определения шаблона компонентов необходимым образом. Для получения более подробной информации перейдите в раздел Определение шаблона.

При прямом редактировании есть три элемента управления, доступных в панели быстрого доступа (Quick Access Bar, в верхней левой части окна приложения) или в панели инструментов Component Template Standard:

  • Save Active Document (Сохранить активный документ). Используйте эту кнопку, чтобы сохранить все изменения документа. Это позволит вам сохранить текущие изменения и позже вернуться к внесению дальнейших изменений перед выпуском на сервер управляемых данных.
  • Save to Server (Сохранить на сервере). Используйте эту кнопку, чтобы выпустить (по сути, сохранить и выпустить) определенный шаблон компонентов на сервер управляемых данных в начальную (запланированную) ревизию целевого объекта шаблона компонентов. Будет открыто диалоговое окно Edit Revision, в котором вы можете изменить название и описание и добавить информацию о выпуске. После выпуска документ и редактор будут закрыты. Документ *.CMPT, содержащий в себе исходный шаблон компонентов, будет сохранен в ревизию соответствующего объекта.
  • Cancel Editing (Отменить редактирование). Используйте эту кнопку, если вы хотите отменить редактирование. Документ и редактор будут закрыты, и в целевой объект шаблона компонентов ничего не будет выпущено.

Эти элементы управления также доступны в качестве команд главного меню File: Save (сочетание клавиш Ctrl+S), Save to Server (сочетание клавиш Alt+Ctrl+S) и Cancel Edit.

Выпущенные данные, сохраненные на сервере, состоят из исходного шаблона компонентов, определенного в файле шаблона компонентов (<Объект><Ревизия>.CMPT).

Пример определенного шаблона компонентов, выпущенного на сервер.

Редактор шаблонов компонентов (CMPT)

Сам шаблон компонентов определяется с помощью редактора шаблонов компонентов (Component Template Editor). Этот временный редактор становится доступным благодаря специальному расширению Component Template Editor.

Расширение Component Template Editor.

Редактор шаблонов компонентов доступен только тогда, когда для вашего экземпляра Altium Designer установлено расширение Component Template Editor. Это расширение устанавливается по умолчанию вместе с системой, но в случае непреднамеренного удаления вы можете вернуться на вкладку Purchased страницы Extensions & Updates – для этого нажмите по элементу управления для текущего пользователя (например, ) вверху справа от рабочей области и выберите Extensions and Updates из меню.

Определение шаблона

Интерфейс редактора шаблона компонентов делится, по сути, на две главных области, показанные на изображении ниже и информация о которых приведена далее.

Редактор шаблона компонентов делится можно разделить на две ключевых области.

  1. Верхняя область – для определения настроек (жизненный цикл, именование, настройки папки) на уровне компонентов, которые будут ссылаться на этот шаблон.
  2. Нижняя область – для определения параметров компонентов, которые будут ссылаться на этот шаблон.

Определение настроек компонентов

В верхней части редактора определяются значения по умолчанию следующих свойств компонентов:

  • Lifecycle Definition – выберите определение жизненного цикла, которое будет применяться к компоненту, создаваемому с помощью этого шаблона. В выпадающем списке приведены все определения, заданные на сервере и доступные для использования объектом компонента (Component Item).
  • Revision Naming – выберите схему именования ревизий, которая будет применяться к компоненту, создаваемому с помощью этого шаблона. В выпадающем списке приведены все схемы, заданные на сервере и доступные для использования объектом компонента (Component Item).
Если настройка для управления использованием определений жизненных циклов и схем именования ревизий по типу содержимого включена для всех определений/схем и для типа объектов компонентов не задано использование какого-либо определения/схемы, то это определение/схема не будет доступна в соответствующем выпадающем списке.
  • Component Naming – используйте это поле для определения схемы именования объектов для компонентов, создаваемых с помощью этого шаблона. Это обеспечит использование уникального идентификатора для итогового объекта компонента на сервере. Эта запись будет использоваться в качестве шаблона для автоматического именования компонента в его соответствующем поле Id (при использовании редактора компонентов в режиме Single Component Editing) или в поле Item ID (при использовании редактора компонентов в режиме Batch Component Editing). Система автоматически назначит следующий уникальный идентификатор на основе этой схемы, просканировав весь сервер и идентификаторы существующих объектов. Схемой именования объектов по умолчанию является CMP-{00000}, но вы можете, конечно, создать собственную схему, введя ее в это поле, с переменной частью в фигурных скобках (например, CMP-001-{0000}).
  • Default Folder – укажите папку по умолчанию на целевом сервере, в которой будет храниться выпущенный объект компонента. Для этого нажмите кнопку Choose, чтобы открыть диалоговое окно Choose Folder (аналог панели Explorer), где вы можете найти и выбрать существующую папку на сервере или создать новую папку на лету.
Поле, которое позволило бы задать целевой сервер, отсутствует, поскольку будет использоваться тот же сервер, в котором хранится ревизия объекта шаблона компонентов.
Настройка Allow override каждого из этих свойств позволяет независимо управлять тем, может ли пользователь их изменять (настройка включена) или нет (настройка отключена) при определении компонента в редакторе Component Editor. Обратите внимание, что это применяется только при использовании редактора в режиме Batch Component Editing, где свойства определяются в диалоговом окне Document Options и значения по умолчанию применяются к каждому новому определению компонента, которое добавляется. После применения, целевая папка и идентификатор компонента можно изменить на лету, если это необходимо.

При указании ссылки на шаблон, записи, указанные в этой области, используются для предварительного заполнения соответствующих полей в редакторе Component Editor (где это применимо):

  • Режим Single Component Editing – поля Id и Folder, в разделе Advanced Settings области Component.
  • Режим Batch Component Editing – на вкладке Document Options диалогового окна Document Options и, как следствие, поля Item ID и FolderPath, в разделе Component области определений компонентов.

При указании ссылки на шаблон, записи используются для предварительного заполнения соответствующих полей при редактировании компонента в редакторе Component Editor в режиме Single Component Editing (слева) и в режиме Batch Component Editing (справа).

Определение параметров

В нижней части редактора осуществляется определение и управление параметрами, которые станут доступными для компонента, ссылающегося на этот шаблон.

Пример параметров, определенных в шаблоне компонентов.

Системные параметры по умолчанию

При создании нового объекта шаблона компонентов включен ряд системных параметров, которые показаны на изображении ниже и информация о которых приведена далее.

Системные параметры по умолчанию, включенные в новый объект шаблона компонентов.

  • ComponentType – этот параметр позволяет указать тип компонента. Это упрощает целевой поиск с помощью расширенного поиска на сервере, который позволяет искать не только по типам компонентов, но и осуществлять более интеллектуальный поиск благодаря поддержке параметров компонентов с единицами измерения. При просмотре собственных управляемых компонентов с помощью панели Components, группирование управляемых компонентов по категориям (Categories) осуществляется на основе параметров ComponentType компонентов. Щелкните ЛКМ по соответствующему полю Default Value, затем нажмите кнопку , чтобы открыть диалоговое окно Choose component type. Используйте его для выбора нужного типа компонентов, затем нажмите OK – выбранный тип будет добавлен в качестве значения параметра ComponentType в главной таблице параметров.
    В диалоговом окне Choose component type отражен набор типов компонентов, определенных на странице Data Management - Component Types диалогового окна Preferences. Нажмите кнопку в нижней части диалогового окна Choose component type, чтобы открыть эту страницу настроек, где вы можете определить этот список в соответствии со своими требованиями путем добавления новых типов и подтипов, либо путем изменения и удаления существующих типов.

    Пример шаблона компонентов с параметром ComponentType, которому задано значение Diodes.

    У этого параметра задан тип данных ComponentType, и его нельзя изменить. Также параметр ComponentType нельзя скопировать или удалить.
  • SCHLIB и PCBLIB – эти параметры позволяют указать соответственно объект символа и объект посадочного места. Щелкните ЛКМ в соответствующем поле Default Value, затем нажмите кнопку , чтобы открыть диалоговое окно для выбора нужного объекта модели.
    Вы выбираете именно объект модели, а не определенную ревизию этого объекта. Таким образом, компонент, который использует этот шаблон, будет использовать самую новую ревизию выбранного объекта модели.

    Укажите в шаблоне объекты символа и посадочного места.

    У этих параметров заданы типы данных SCHLIB и PCBLIB соответственно, и их нельзя изменить. Также эти параметры нельзя скопировать или удалить.
  • Name и Description – эти параметры позволяют указать соответственно название и описание компонента. Введите нужные строки в соответствующее поле Default Value параметра.

    Укажите в шаблоне параметры Name и Description.

    У этих параметров задан тип данных Text, и его нельзя изменить. Также эти параметры нельзя скопировать или удалить.

Добавление нового пользовательского параметра

Чтобы добавить в список новый пользовательский параметр, нажмите кнопку (или используйте команду Add из контекстного меню) – параметр будет добавлен вниз текущего списка.

Пример добавления в шаблон нового пользовательского параметра.

Для каждого параметра в таблице представлена следующая информация:

  • Name – используйте это поле, чтобы задать название параметра. Как правило, это осмысленное имя, которое отражает назначение этого параметра. При первоначальном добавлении параметрам задаются названия по умолчанию (Parameter, Parameter 1, Parameter 2 и т.д.).
  • Type – тип параметра. Изначально в этой записи задано Text, но поддерживается набор типов данных с единицами измерения, а также тип PCBLIB, который служит для определения множества посадочных мест.
  • Visible – если эта настройка включена (что является состоянием по умолчанию для нового параметра), то соответствующая настройка Show параметра будет включена при редактировании одного или множества компонентов в редакторе Component Editor (настраивается в режиме Batch Component Editing). Это, в свою очередь, управляет отображением соответствующего столбца этого параметра в нижней области редактора Component Editor, где представлены сами определения компонентов. Это свойство ни на что не влияет при определении компонента в режиме Single Component Editing редактора.
  • Read Only – включите этот параметр, чтобы сделать параметр доступным только для чтения. При редактировании компонента, который ссылается на шаблон, значение этого параметра не будет доступно для редактирования.
  • Required – включите эту настройку, чтобы сделать параметр "обязательным". При редактировании компонента, который ссылается на шаблон, у этого параметра должно быть определено значение, в противном случае выпуск компонента будет не возможен. В редакторе Component Editor такой параметр можно отличить по красной границе вокруг ячейки значения (в режиме Batch Component Editing) или по наличию иконки (в режиме Single Component Editing), если значение не введено.
  • Default Value – используйте это поле, чтобы ввести значение параметра по умолчанию.
    Если параметр помечен как обязательный (включена настройка Required) и он был задан как доступны только для чтения (включена настройка Read Only), то необходимо ввести значение по умолчанию. В противном случае, при редактировании компонента, который ссылается на шаблон, параметр будет помечен как не имеющий значения, но отредактировать его будет нельзя, поскольку он является доступным только для чтения.
  • Description – добавьте описание параметра, например его описание.

Список параметров также поддерживает простые операции копирования и вставки, что позволяет дублировать один или несколько существующих пользовательских параметров. Вставленные параметры будут добавлены вниз списка.

Поддерживаются стандартные сочетания клавиш для копирования (Ctrl+C) и вставки (Ctrl+V), и эти команды также доступны доступны в контекстном меню. Для операций копирования и вставки можно выбрать множество пользовательских параметров с помощью стандартных сочетаний Ctrl+ЛКМ и Shift+ЛКМ.
Чтобы удалить один или множество параметров из списка, выберите их, затем нажмите кнопку или используйте команду Remove из контекстного меню.

Порядок столбцов можно настроить. Зажмите ЛКМ на заголовке столбца и перетащите его в горизонтальном направлении в новое положение. Корректное положение подсвечивается вертикальными позиционными стрелками.

Ширину столбца можно изменить путем перетаскивания с зажатой ЛКМ разделителя с правой стороны заголовка столбца.

Параметры могут быть отсортированы по определенному столбцу щелчком ЛКМ по заголовку этого столбца. Щелкните ЛКМ один раз, чтобы отсортировать по возрастанию (на основе содержимого этого столбца). Щелкните ЛКМ еще раз, чтобы отсортировать по убыванию.

Вы можете задать сортировку по множеству столбцов. Когда параметры уже отсортированы по определенному столбцу, используйте Shift+ЛКМ для другого столбца, чтобы задать "сортировку более низкого уровня" по содержимому этого столбца.

Чтобы удалить сортировку по столбцу, используйте Ctrl+ЛКМ на его заголовке.

Типы данных параметров компонентов с единицами измерения

Редактор шаблонов компонентов позволяет в явном виде задавать типы данных параметров компонентов, определенных в шаблоне компонентов (*.CMPT). Кроме того, эти типы данных учитывают единицы измерения, с поддержкой распространенных префиксов единиц измерения. Таким образом, вы можете ввести значение параметра в одном из форматов, например 2.2k, 2k2, 4M, 2.5GHz, и сервер управляемых данных сможет распознавать числовые значения таких записей.

Эта возможность шаблона компонентов обеспечивает целевой поиск с помощью функции расширенного поиска сервера – возможности, которая не только позволяет проводить поиск по типам компонентов, но также применять более интеллектуальный поиск. Благодаря параметрам компонентов с единицами измерения вы можете быстро задать поиск, чтобы найти, например, все конденсаторы емкостью от 47 мкФ до 220 мкФ.

Параметры с единицами измерения также используются для умной фильтрации при поиске через собственный сервер управляемых данных с помощью панели Components.

Используйте сворачиваемые области ниже, чтобы узнать больше о параметрах с единицами измерения.

При определении пользовательского параметра в шаблоне компонента поддерживаются следующие типы данных с единицами измерения:

У большинства типов данных есть единицы измерения (отображены в скобках). Они будут применены, если при вводе значения параметра не указаны единицы измерения.
  • Вольты (V)
  • Амперы (A)
  • Омы
  • Фарады (F)
  • Генри (H)
  • Ватты (W)
  • Герцы (Hz)
  • Градусы по Цельсию (C)
  • Децибелы (dB)
  • Проценты (%)
  • Метры (m)
  • Граммы (g)
  • Секунды (s)

В таблице ниже приведен список префиксов, поддерживаемых при вводе значения типа параметра с единицами измерения.

Префикс Название Значение (научное) Значение (обычное)
T тера 1012 1 000 000 000 000
G гига 109 1 000 000 000
M мега 106 1 000 000
k кило 103 1 000
m милли 10-3 1 / 1 000
u микро 10-6 1 / 1 000 000
n нано 10-9 1 / 1 000 000 000
p пико 10-12 1 / 1 000 000 000 000
f фемто 10-15 1 / 1 000 000 000 000 000
Обратите внимание, что некоторые префиксы или все префиксы могут быть не применимы, в зависимости от типа параметра. Например, префиксы не применимы к процентам. Система предупредит вас при недопустимом использовании префиксов.

При добавлении в шаблон параметра (нажмите в области Parameters), используйте соответствующее поле Type, чтобы выбрать нужный тип данных с единицами измерения из выпадающего списка.

Выбор поддерживаемого типа данных с единицами измерения для пользовательского параметра в шаблоне компонента. В этом примере задан тип параметра Ampere.

При вводе значения параметра компонента, который использует типы данных с единицами измерения (в качестве значения по умолчанию Default Value в шаблоне компонента или в качестве обязательного значения в определении компонента), нужно учитывать следующее:

  • Вы можете ввести значение в одном из следующих форматов:
    • Только числовое значение (например 10). Обратите внимание, что если у типа данных есть единица измерения, она будет применена автоматически. У таких типов единицы измерения отображены в скобках после имени.
    • Числовое значение в научном представлении (например 1e10, 1E6).
    • Числовое значение и единицы измерения (например 10F).
    • Числовое значение с префиксом (например 10k). Будут автоматически добавлены подходящие единицы измерения (где это применимо).
    • Числовое значение с префиксом и единицами измерения (например 10kF).
    • Числовое значение с префиксом в типовом инженерном формате (например 2k2, 2K2, 10r2, 10R2 для сопротивления). Значение будет автоматически нормализовано соответствующим образом (например 2K2 станет 2.2k).
  • Вы можете вводить префикс и/или единицы измерения с пробелом после числового значения или без него (например 10uF или 10 uF). Пробел будет автоматически удален.
Обратите внимание, что инженерные сокращения не зависят от регистра, поэтому ввод 2k2 эквивалентен вводу 2K2, а ввод 100R эквивалентен вводу 100r. Исключением являются префиксы M (мега) и m (милли).

При использовании параметра компонента с единицами измерения, введенное значение проверяется на соответствие указанному типу данных. Это обеспечивает использование корректных единиц измерения для этого типа данных. Например, у параметра типа Celsius не может быть значения 10V.

Валидация осуществляется во всех случаях, когда используется параметр компонента с типом данных с единицами измерения и задано значения этого параметра:

  • При задании значения по умолчанию для параметра в шаблоне компонента.
  • При задании значения параметра при определении компонента в редакторе Component Editor.
  • При настройке диапазона поиска на основе значения параметра, в рамках сохраненной схемы поиска.

Пример работы валидации данных в редакторе шаблонов компонентов.

Определение множества посадочных мест

Редактор шаблонов компонентов также поддерживает определение множества посадочных мест в шаблоне компонента. Может быть указано любое количество ссылок на посадочные места, и это будет полезной возможностью для тех, кто хочет создавать компоненты с тремя посадочными местами, в соответствии с требованиями IPC для различных уровней плотности монтажа: L (минимум меди), M (максимум меди) и N (номинальное, или среднее количество меди).

Чтобы добавить в шаблон дополнительное определение модели компонента, нажмите , чтобы добавить новый параметр, затем выберите запись PCBLIB из выпадающего меню, связанного с полем Type.

Задайте новый параметр в качестве определения модели посадочного места, задав его тип (Type) как PCBLIB.

Название параметра изменится с Parameter на PCBLIB n, где n – это следующее доступное целое число, которое позволит отличать между собой различные модели посадочных мест (PCBLIB 1, PCBLIB 2 и т.д.). При определении компонента, когда посадочные места переносятся в редактор компонентов, модель посадочного места по умолчанию отличается иконкой вверху слева от окна предварительного просмотра модели (в режиме Single Component Editing) и записью PCBLIB (default) в области Required Models/Parameters (в режиме Batch Component Editing).

Пример компонента, определенного в редакторе компонентов (режим Single Component Editing) с помощью шаблона компонентов. В шаблоне определено три модели посадочных мест, которые перенесены в определение компонента. Обратите внимание, что запись модели PCBLIB в шаблоне используется в качестве модели посадочного места по умолчанию (отличается иконкой вверху слева) при определении компонента. Наведите курсор мыши на изображение, чтобы увидеть этот же компонент, определяемый в редакторе компонентов в режиме Batch Component Editing. В этом случае, посадочное место по умолчанию обозначается PCBLIB (default).

Повторное использование объекта управляемого шаблона компонентов

Использование ревизии объекта шаблона компонентов, то есть создание ссылки на шаблон из ревизии объекта компонента, может быть выполнено следующими способами.

Компонент может одновременно ссылаться только на один шаблон компонентов.

При создании нового компонента

При создании нового компонента с помощью команды File » New » Component главного меню вы можете выбрать шаблон в диалоговом окне Create new component.

Быстрая настройка ссылки на объект шаблона компонентов из списка всех доступных шаблонов при создании нового компонента.

Вручную из редактора Component Editor

Повторное использование ревизии объекта шаблона компонентов из редактора Component Editor зависит от режима работы редактора.

В режиме Single Component Editing

При редактировании отдельного компонента в этом режиме редактора Component Editor выберите нужный шаблон компонентов из выпадающего меню, связанного с полем Template, которое находится в группе Advanced Settings в области Component редактора. Будет приведен список названий всех объектов шаблонов компонентов, доступных на том же сервере управляемых данных, где находится сам объект компонента, с самыми новыми ревизиями, указанными в скобках. Выберите нужный шаблон, чтобы применить его.

Быстрая привязка объекта шаблона компонентов из меню всех доступных шаблонов при редактировании ревизии объекта компонентов с помощью редактора Component Editor в режиме Single Component Editing.

В режиме Batch Component Editing

Существует два способа применить ревизию объекта шаблона компонентов для редактируемой ревизии объекта компонента:

  • Из вкладки Template диалогового окна Document Options (Edit » Document Options). Нажмите кнопку Choose справа от поля Item Revision. Будет открыто диалоговое окно Choose Item (аналог панели Explorer). Используйте его, чтобы найти и выбрать ревизию нужного объекта шаблона компонентов. После нажатия OK, будет создана ссылка между ревизией объекта компонента и целевой ревизией объекта шаблона компонентов. Эта ссылка будет отображена на вкладке Template диалогового окна Document Options.

    Создание вручную ссылки из компонента на ревизию объекта шаблона компонентов на целевом сервере.

    Используемый объект шаблона компонентов можно изменить в любой момент – нажмите Choose и выберите ревизию другого объекта шаблона компонентов.
    Состояние связанной ревизии объекта шаблона компонентов отражено на вкладке Template диалоговому окна Document Options. Если доступна более новая ревизия связанного объекта, нажмите кнопку , чтобы использовать эту более новую ревизию.
  • Из меню Add, связанного с областью Required Models/Parameters редактора Component Editor. В подменю Templates приводится список названий всех объектов шаблонов компонентов, доступных в данный момент на том же сервере управляемых данных, в котором находится сам объект компонента, с указанием в скобках их самых новых ревизий. Щелкните ЛКМ по записи, чтобы создать ссылку на самую новую ревизию этого объекта шаблона компонентов. Опять же, верификацию ссылки можно увидеть на вкладке Templates диалогового окна Document Options.

    Быстрая привязка к объекту шаблона компонентов из меню всех доступных шаблонов.

Наследование из серверной папки компонентов

Вы можете задать, чтобы объект шаблона компонентов автоматически использовался всеми объектами компонентов (и их всеми ревизиями), которые хранятся в папке компонентов на сервере.

Объект шаблона компонентов по умолчанию может быть определен только папке с типом Components.

Укажите нужный шаблон с помощью поля Component Template при определении свойств папки в диалоговом окне Edit Folder. В связанном с полем выпадающем списке приводится список названий всех объектов шаблонов компонентов, доступных в данный момент на том же сервере управляемых данных, где находится сама папка компонентов, с указанием в скобках их самых новых ревизий. Выберите запись, чтобы создать ссылку на самую новую ревизию этого объекта шаблона компонентов для всех объектов компонентов, которые созданы в этой папке.

Укажите объект шаблона компонентов для его применения ко всем объектам компонентов, созданных в родительской папке компонентов.

Чтобы не использовать эту функциональную возможность, оставьте/задайте в поле Component Template значение None.

Если шаблон компонентов выбран на уровне папки, по умолчанию этот же шаблон будет использоваться при создании объектов компонентов в дочерних подпапках. Это упрощает быстрое наследование шаблонов всеми объектами в дочерних папках.

При выпуске ревизии объекта компонента, она будет, по сути, закреплена на определенной ревизии шаблона компонентов. Тем самым будет создана сильная ссылка на эту ревизию, если она не будет изменена вручную.

Влияние использования шаблона компонентов на модели и параметры компонента

При редактировании ревизии объекта компонента и ревизии объекта шаблона компонентов, с которым она связана, в редакторе Component Editor в отношении моделей и параметров произойдет следующее:

  • Модели, определенные в связанном шаблоне, будут добавлены в область Models (режим Single Component Editing) и область Model Links (режим Batch Component Editing).
  • Будет сохранена существующая связанная модель, и компонент сохранит использование этой модели, если она не будет целенаправленно изменена вручную.
  • Параметры, определенные в связанном шаблоне, будут добавлены в область Parameters (режиме Single Component Editing) и область Required Models/Parameters (режим Batch Component Editing).

    Пример параметров после привязки ревизии объекта шаблона компонентов при использовании редактора Component Editor в режиме Single Component Editing (слева) и в режиме Batch Component Editing (справа).

    Все параметры, поступившие из связанного объекта шаблона компонентов, отличаются иконкой (Single Component Editing) и иконкой (режим Batch Component Editing). Кроме того, только для режима Batch Component Editing, опция Show для каждого параметра из шаблона будет соответствовать состоянию соответствующей опции Visible в шаблоне.
    Параметры из шаблонов не могут быть удалены.
    Вы можете беспрепятственно добавлять дополнительные пользовательские параметры необходимым образом.
  • Все существующие пользовательские параметры с теми же именами, что и у параметров в связанном объекте шаблоне компонентов, будут заменены их версиями из шаблона. Все существующие значения таких параметров будут сохранены, а не перезаписаны значениями из шаблона.
  • Только в режиме Batch Component Editing, параметры из шаблона, которые были заданы как видимые, будут сгруппированы в области определений компонентов редактора, с текстом заголовка Template Parameters.

    Пример параметров из шаблона в области, где определяются сами компоненты, при использовании редактора Component Editor в режиме Batch Component Editing.

  • Поля значений параметров из шаблонов, которые были помечены как только для чтения, будут не доступны для редактирования. Для всех прочих параметров из шаблонов, которые не были помечены как только для чтения, вы можете беспрепятственно изменять значения необходимым образом.
    Когда редактор Component Editor находится в режиме Single Component Editing, параметры из шаблона, доступные только для чтения, будут отличаться в области Parameters иконкой .
  • Если параметр из шаблона был помечен как обязательный, но ему не было задано значение в шаблоне, поле этого значения будет отображено с красной границей (в режиме Batch Component Editing) или будет содержать иконку (в режиме Single Component Editing), что просигнализирует вам о том, что необходимо указать значение этого параметра. Вы не сможете выпустить компонент, пока не будут определены значения для всех обязательных параметров.
    В редакторе Component Editor в режиме Single Component Editing обязательные параметры из шаблона отличаются в области Parameters иконкой .

Повторный выпуск объекта шаблона компонентов

На любом этапе вы можете вернуться к любой ревизии объекта шаблона компонентов на сервере и напрямую отредактировать ее. Щелкните ПКМ по ревизии и выберите команду Edit из контекстного меню. Будет открыт временный редактор с шаблоном, содержащимся в открытой на редактирование ревизии. Внесите необходимые изменения, затем выпустите документ в следующую ревизию объекта.

Щелкните ПКМ по записи верхнего уровня самого объекта, чтобы изменить самую новую ревизию этого объекта.


Доступ к команде для запуска прямого редактирования существующей ревизии объекта шаблона компонентов.

Загрузка выпущенных данных

Чтобы загрузить данные, сохраненные в ревизию объекта шаблона компонентов, щелкните ПКМ по этой ревизии в панели Explorer и выберите команду Operations » Download из контекстного меню. Файл шаблона компонентов будет загружен в подпапку выбранной директории, названную в соответствии с идентификатором ревизии объекта. Этот файл можно найти здесь в папке Released.

Запустите команду Download из записи верхнего уровня самого объекта шаблона компонентов, чтобы загрузить файл шаблона компонентов, который хранится в самой новой ревизии этого объекта.
Нажмите кнопку Explore в диалоговом окне Download from Server, чтобы быстро открыть папку загрузки.

Обратимое удаление

При использовании Altium 365 Workspace в качестве сервера управляемых данных, доступны гибкие функциональные возможности для удаления объекта шаблона компонентов непосредственно из Altium Designer, из панели Explorer. Щелкните ПКМ по строке объекта в панели и выберите команду Delete Item из контекстного меню. Будет открыто диалоговое окно Delete Items для подтверждения удаления. Будет выполнено обратимое удаление, где объект будет перемещен в область Trash в Workspace. Эта область является, по сути, корзиной, в которую можно переместить (через обратимое удаление) любой управляемый объект в Workspace. Эта область изолирована от остальной части Workspace.

С помощью обратимого удаления, вы можете удалить используемый объект.
Множество объектов шаблонов компонентов можно удалить в одно действие. Выберите все нужные объекты с помощью стандартных сочетаний клавиш (Shift+ЛКМ, Ctrl+ЛКМ), щелкните ПКМ и выберите команду Delete Items из контекстного меню.

Обратимое удаление объекта шаблона компонентов. Объект будет перемещен в область Trash в Workspace.

Чтобы начать удаление, нажмите кнопку . Объект будет удален, и диалоговое окно Deletion Summary подтвердит успешное удаление. Если при удалении возникнет какая-либо проблема, вы будете оповещены об этом.

Все объекты, удаленные таким образом, можно найти на странице Trash веб-интерфейса Workspace. Обратите внимание, что вы можете просматривать только те объекты, которые вы сами удалили. Администраторы смогут увидеть полное содержимое страницы Trash, т.е. все объекты, которые были обратимо удалены.

Что следует иметь в виду касательно обратимо удаленных объектов:

  • Объект станет недоступным в системе проектирования и в веб-интерфейсе.
  • Везде, где использовался объект, будет отражено, что он был удален.
  • Объект можно восстановить или удалить полностью со страницы Trash. Полное удаление возможно только в том случае, если он не используется родительским объектом.
Обратите внимание, что если вы обратимо удалили объект, т.е. переместили его в область Trash, вы можете создать новый объект с тем же именем. Если вы затем восстановите изначальный объект, будет взято изначальное имя и к нему будет добавлен целочисленный суффикс, чтобы обеспечить уникальность имен в Workspace.
Обнаружили проблему в этом документе? Выделите область и нажмите Ctrl+Enter, чтобы оповестить нас.

Связаться с нами

Связаться с нашими Представительствами напрямую

We're sorry to hear the article wasn't helpful to you.
Could you take a moment to tell us why?
Вы сообщаете о проблеме, связанной со следующим выделенным текстом
и/или изображением в активном документе:
Бесплатная пробная версия Altium Concord Pro

Заполните форму ниже, чтобы получить бесплатную пробную версию Altium Concord Pro