Altium Designer Documentation

Управляемые компоненты

Последнее изменение: Pavel Demidov; 26.10.2020

Главная страница: Работа с управляемыми компонентами

Когда все необходимые доменные модели созданы и выпущены на сервер управляемых данных, вы можете определить компоненты и выпустить на сервер для их повторного использования в проекте. Предприятие может создать набор объектов компонентов (Component Items, или управляемых компонентов), находящихся под управлением ревизий и жизненных циклов, для их использования проектировщиками.

В этом документе описан сбор необходимых частей данных для определения и выпуска компонентов на сервер управляемых данных.

Необходимые доменные модели (как правило, это схемный символ и посадочное место) могут быть также созданы на лету в процессе определения самого компонента. Это осуществляется с помощью элементов управления, доступных в области Models редактора Component Editor, когда он используется в режиме Single Component Editing.
В компонент может быть добавлена информация о реальных, физических компонентах, для создания компонента, который объединяет области проектирования и цепочки поставок, т.е. для создания по-настоящему унифицированного компонента. Для этого необходимо, чтобы в компонент были добавлены варианты выбора компонента (Part Choices). Это процесс указания "реального" компонента(-ов), которые могут использоваться при изготовлении печатного узла. Варианты выбора компонентов могут быть добавлены при определении компонента, до его выпуска на сервер, и их можно изменить в любой момент после выпуска путем редактирования управляемого компонента. Варианты выбора компонентов также могут быть добавлены за рамками редактирования самого компонента. Для получения более подробной информации перейдите на страницу Добавление информации о цепочке поставок в управляемый компонент.
Хотя термин “управляемые компоненты” просто означает компоненты, которые хранятся на сервере, существуют различия в функциональных возможностях, связанных с управляемыми компонентами при использовании Altium 365 Workspace, в зависимости от уровня доступа: Altium 365 Standard или Altium 365 Pro. Например, в Altium 365 Standard нет функциональности для управления жизненным циклом или контролем применяемости. В этом отношении, их можно рассматривать как более легкую форму компонентов – без сложного управления ими, но всё же доступные в облаке (в вашем Workspace). Там, где есть различия между двумя уровнями доступа к Altium 365, будет дано соответствующее примечание.

Объекты компонентов создаются непосредственно на сервере. После того, как объект компонента был создан (и данные были выпущены в ревизию этого компонента) и его состояние жизненного цикла задано на том уровне, при котором с точки зрения предприятия его можно использовать в проекте, компонент может быть повторно использован при разработке одного или множества проектов.

Тип папки

При создании папки для хранения объектов компонентов вы можете указать тип папки. Это не имеет отношения к содержимому папки – выпуск компонента всегда осуществляется в соответствующий объект компонента (Component Item). Таким образом вы лишь обеспечиваете визуальную подсказку о том, что хранится в папке, что может быть полезными при поиске определенного содержимого на сервере. Чтобы указать, что папка используется в качестве контейнера для объектов компонентов, задайте ее тип (Folder Type) как Components при определении свойств папки в диалоговом окне Edit Folder.


Определение типа папки, т.е. ее планируемого использования, предоставляет визуальную индикацию содержимого этой папки при просмотре данных на сервере.

Другим важным аспектом родительской папки является используемая для нее схема именования объектов (Item Naming Scheme), которая определяет формат уникального идентификатора каждого объекта, создаваемого в этой папке. Доступны несколько примеров схем по умолчанию, использующих краткий код для папок каждого типа (CMPL для библиотек компонентов) или для содержимого каждого типа (CMP для компонентов):

  • $CONTENT_TYPE_CODE-001-{0000} – например, CMP-001-0001.
  • $CONTENT_TYPE_CODE-001-{A00} – например, CMP-001-A01.
  • $FOLDER_TYPE_CODE-001-{0000} – например, CMPL-001-0001.
  • $FOLDER_TYPE_CODE-001-{A000} – например, CMPL-001-A001.

Используя схему именования по умолчанию, система автоматически назначит следующий уникальный идентификатор на основе этой схемы, просканировав весь сервер и идентификаторы существующих объектов. Это может значительно сэкономить время при создании объектов компонентов вручную.

Для папки также можно определить пользовательскую схему путем ее ввода в поле, с переменной частью в фигурных скобках (например, DES-CMP-{0000}).


Схема именования объектов родительской папки применяется к уникальным идентификаторам всех объектов, которые создаются в этой папке.

Схему Item Naming Scheme, примененную к родительской папке, можно в любой момент изменить. Измененная схема будет применяться ко всем создаваемым далее в этой папке объектам.

Тип объекта

При создании целевого объекта компонента (Component Item), в котором будет храниться компонент, убедитесь, что в диалоговом окне Create New Item его тип содержимого (Content Type) определен как Component. Если вы создаете объект в папке с типом Components, то объект этого типа будет доступен в контекстном меню при создании объекта.

Сервер управляемых данных поддерживает безобъектное создание компонента. При использовании команды Create Item » Component меню вы перейдете непосредственно в данный режим. Чтобы сначала открыть диалоговое окно Create New Item, необходимо использовать команду Create Item » Other Item Type. Для получения более подробной информации о первом варианте перейдите в раздел Безобъектное создание компонента.


Создание объекта компонента в папке Components. Хотя в контекстном меню доступен корректный тип содержимого (команда Component), при ее использовании вы перейдете в режим безобъектного создания компонента. Чтобы создать традиционный объект с помощью диалогового окна Create New Item, вместо этого выберите команду Other Item Type из меню.

Чтобы увидеть новый объект компонента, который вы собираетесь определить и выпустить, отключите опцию Show only latest (доступный в меню кнопки в верхней части панели Explorer) либо переключите вид папки с Components View на Classic View (доступно в том же меню).

При определении объекта компонента убедитесь, что указан тип управления жизненным циклом для его использования с этим объектом и схема именования ревизий этого объекта.

Поддержка управления ревизиями и жизненным циклом компонентов не включена в Altium 365 Standard. Соответственно, при этом уровне доступа к Altium 365, данная функциональность не будет доступна при подключении к Altium 365 Workspace.

Управление тем, какие типы объектов могут использовать конкретное определение жизненных циклов или схему именования ревизий, осуществляется на глобальном уровне в диалоговом окне Content Types, при определении схемы. Схемами по умолчанию, которые назначаются объекту компонента, являются Component Lifecycle и 1-Level Revision Scheme соответственно.

После того, как определение компонента было выпущено в начальную ревизию объекта компонента, эти схемы не могут быть изменены для этого конкретного объекта.

Укажите нужные схемы в диалоговом окне Create New Item с помощью полей Lifecycle Definition и Revision Naming Scheme соответственно.

Если включена опция для управления использованием определений жизненных циклов и схем именования ревизий по типу содержимого и для типа Component Item не задано использование конкретного определения/схемы, то это определение/схема будет не доступно в соответствующем выпадающем списке.


Выбор определения жизненного цикла и схемы именования ревизий для создаваемого вручную объекта.

Придерживаясь стандартных схем именования ревизий и определений жизненных циклов для различных типов проектных объектов на сервере управляемых данных, вы обеспечите понятное и надежное управление этими объектами.
Хорошей идеей является добавление названия и описания в определение объекта. Эта информация используется при поиске на сервере и позволяет быстро идентифицировать, что предлагает тот или иной объект компонента.

Выпуск определения компонента

До сих пор рассматривалась поддержка объекта компонента на сервере с точки зрения соответствующих типов папки и объекта. Выпуск определенного компонента в ревизию такого объекта может быть выполнен удобным способом.

Компонент может быть отредактирован и выпущен в начальную ревизию нового объекта компонента с помощью прямого редактирования, поддерживаемого сервером. Прямое редактирование избавляет от ограничений отдельных исходных данных под контролем версий. Вы можете просто изменить объект поддерживаемого типа с помощью временного редактора, в который загружена самая новая версия исходных данных непосредственно с сервера. По завершении редактирования, сущность выпускается (или выпускается повторно) в последующую запланированную ревизию родительского объекта, и временный редактор закрывается. Нет файлов на вашем жестком диске, не нужно задаваться вопросом о том, работаете ли вы с корректными и самыми новыми данными, нет необходимости в обслуживании отдельного программного обеспечения для контроля версий. Всем этим управляет сервер, с высокой степенью целостности, для значительного ускорения внесения изменений в данные.

После создания объекта компонента вы можете изменить его и выпустить компонент в начальную ревизию этого объекта. Для этого включите опцию Open for editing after creation в нижней части диалогового окна Create New Item (опция включена по умолчанию). Объект будет создан, и откроется временный редактор Component Editor в режиме Single Component Editing, с элементами управления для определения компонента в главном окне приложения. Вкладка документа редактора отражает название (Name), которое вы назначили компоненту.


Пример редактирования начальной ревизии объекта компонента непосредственно с сервера управляемых данных. Временный редактор Component Editor предоставляет элементы управления, с помощью которых вы определяете компонент (по умолчанию отображается в режиме Single Component Editing).

Используйте редактор Component Editor для определения компонента необходимым образом. Редактор поддерживает два режима работы: Single Component Editing (редактирование отдельного компонента, по умолчанию) и Batch Component Editing (пакетное редактирование компонентов). Для получения более подробной информации перейдите в раздел Определение компонента.

Существует три элемента управления, доступные в панели быстрого доступа Quick Access Bar (вверху слева окна приложения) и в панели инструментов Component Library Standard:

  • Save Active Document (Сохранить активный документ). Используйте эту кнопку, чтобы сохранить все изменения компонента. Это позволит вам сохранить текущие изменения и позже вернуться к внесению дальнейших изменений перед выпуском на сервер управляемых данных.
  • Save to Server (Сохранить на сервер). Используйте эту кнопку, чтобы выпустить (по сути, сохранить и выпустить) определенный компонент на сервер управляемых данных в начальную (запланированную) ревизию целевого объекта компонента. Будет открыто диалоговое окно Edit Revision, в котором вы можете изменить название и описание и добавить информацию о выпуске. После выпуска редактор будет закрыт. Определение исходного компонента будет сохранено в ревизию этого объекта.
  • Cancel Editing (Отменить редактирование). Используйте эту кнопку, если вы хотите отменить редактирование. Редактор будет закрыт, и в целевой объект компонента ничего не будет выпущено.

Эти элементы управления также доступны в качестве команд главного меню File: Save (сочетание клавиш Ctrl+S), Save to Server (сочетание клавиш Alt+Ctrl+S) и Cancel Edit.

Выпущенные данные, которые хранятся на сервере, состоят из определения исходного компонента. В панели Explorer переключитесь на вкладку аспектного вида Preview, чтобы увидеть полные данные определения, в том числе модели, на которые указаны ссылки, шаблон компонента (если используется) и параметрическую информацию.

Просмотр выпущенной ревизии объекта компонента в панели Explorer. Переключитесь на вкладку аспектного вида Preview, чтобы увидеть полные данные определения, в том числе модели, на которые указаны ссылки, шаблон компонента (если используется) и параметрическую информацию.

Безобъектное создание компонента

Использование шаблона компонентов предоставляет эффективные средства для создания компонента с помощью утвержденных шаблонов, однако у этого есть недостаток. Поскольку сначала создается объект, информация в шаблоне (т.е. схема именования, схема ревизий и определение жизненного цикла) не назначается, так как объект компонента уже создан. Чтобы упростить это, сервер управляемых данных в сочетании с Altium Designer поддерживают безобъектное создание компонента. Это не означает, что объект не создается. Осуществляется непосредственный доступ к экземпляру редактора Component Editor, что позволяет применить информацию из шаблона перед добавлением и выпуском нужного компонента. Сам объект компонента (и запланированная ревизия) создается в рамках подготовки выпуска.

В панели Explorer, безобъектное создание компонента доступно из существующей папки для объектов компонентов (должен быть задан тип папки Components). Существует два способа перейти в режим безобъектного создания компонента:

  • С помощью команды Create Item » Component контекстного меню области объекта.
  • С помощью кнопки , расположенной в верхней правой части панели.
Новый компонент также может быть создан таким образом с помощью команды File » New » Component, доступной из любого редактора, или с помощью команды Operations » Create, расположенной в контекстном меню при просмотре управляемых компонентов через панель Components. В обоих случаях вы сможете выбрать один из доступных шаблонов компонентов, которые в данный момент определены для различных типов компонентов, и применить информацию из шаблона при определении компонента во временном экземпляре редактора Component Editor в режиме Single Component Editing.

Доступ к безобъектному режиму создания компонента из панели Explorer. Текущей папке должен быть задан тип Components.

При входе в этот режим будет открыт временный экземпляр редактора Component Editor (в его режиме Single Component Editing по умолчанию), готовая к определению компонента. Представление и загруженная информация по умолчанию зависит от того, был ли использован шаблон компонентов.

  • Если редактор был открыт из папки компонентов, которой назначен шаблон компонентов, то из этого шаблона будут взяты модели и параметры, а также заданные определение жизненного цикла, схема именования ревизий и схема именования компонентов. Папкой по умолчанию (Default Folder) будет папка, из которой был запущен редактор. Если в шаблоне было указано название (Name) по умолчанию, то оно будет использоваться для именования компонента и оно также будет отображено на вкладке документа редактора Component Editor. Если название по умолчанию не указано, вкладка будет отображаться как New Component, и название компонента (Name) будет пустым.
  • Если редактор был открыт из папки компонентов, которой не назначен шаблон компонентов, то будет представлен шаблон по умолчанию с настройками по умолчанию. Если у исходной папки задана схема именования объектов, то она будет использоваться для создания уникального идентификатора компонента. Папкой по умолчанию (Default Folder) будет папка, из которой был запущен редактор. Вся остальная информация для определения (модели, параметры, тип компонента) должна быть указана вручную. На вкладке документа редактора Component Editor будет отображено New Component, и название компонента (Name) будет пустым.

В качестве примера рассмотрим только первый сценарий. В конце концов, именно для использования шаблонов был создан этот режим. Помните, что хотя этот процесс очень схож со вторым сценарием, вам понадобится проделать больше ручной работы, если шаблон не используется.

Пример компонента, созданного после запуска режима безобъектного создания компонента из папки (Schottky), которой назначен шаблон компонента. В определении компонента доступна информация из шаблона. Наведите курсор мыши на изображение, чтобы увидеть шаблон компонентов, на который указана ссылка.

Внесите необходимые изменения в компонент, в том числе добавьте нужные варианты выбора компонента.

Если вы создаете множество компонентов в режиме Batch Component Editing редактора Component Editor, дополнительные определения компонентов будут созданы с соответствии с этим шаблоном компонентов.

Когда компонент определен, нажмите кнопку (в панели быстрого доступна Quick Access Bar), чтобы выпустить компонент на сервер. Будет открыто диалоговое окно Edit Revision, в котором вы можете изменить название и описание и добавить информацию о выпуске. После выпуска редактор будет закрыт.

Если вы используете редактор Component Editor в режиме Batch Component Editing, диалоговое окно Release Manager будет открыто с уже подготовленным компонентом. В рамках этой автоматической подготовки, будет создан сам объект Component Item, с запланированной ревизией, в которую будет размещено выпущенное определение. Нажмите кнопку Release Items и подтвердите выпуск, когда это будет запрошено. После выпуска редактор будет закрыт.

Новый компонент будет доступен для просмотра в панели Explorer, а также для просмотра и работы через панель Components.

Определение компонента

Главные страницы: Редактор Component Editor – режим Single Component Editing, Редактор Component Editor – режим Batch Component Editing

Определение/редактирование компонента осуществляется с помощью редактора Component Editor. У этого редактора есть два режима работы:

  • Режим Single Component Editing – обеспечивает удобный интерфейс для определения/редактирования отдельного компонента. Это режим по умолчанию при создании нового объекта компонента или при редактировании отдельной ревизии существующего объекта компонента.

    Пример, где показано определение компонента с помощью редактора Component Editor в режиме Single Component Editing.

    Новый компонент можно быстро создать в редакторе Component Editor в режиме Single Component Editing с помощью команды File » New » Component, доступной из любого редактора или с помощью команды Operations » Create, расположенной в контекстном меню при просмотре управляемых компонентов в панели Components.
  • Режим Batch Component Editing – обеспечивает интерфейс для определения/редактирования множества компонентов. Вы можете открыть этот режим, выбрав команду Tools » Switch to Batch Editor из главного меню редактора Component Editor. Этот режим также открывается, если вы выбрали на редактирование множество ревизий объектов компонентов в панели Explorer. У каждого определения компонента будет общий набор параметров и ссылок на нужные доменные модели. Пакетное редактирование проявляет себя, когда имеет смысл управлять компонентами как набором, например набором чип-резисторов.
    Вы можете использовать режим Batch Component Editing для определения/редактирования отдельного компонента, если это необходимо.

    Пример, где показано определение компонента с помощью редактора Component Editor в режиме Batch Component Editing. Хотя вы можете использовать этот режим для редактирования отдельного компонента (как показано здесь), он наиболее эффективен при редактировании множества компонентов с общими параметрами и моделями.

Создание ссылки на шаблон компонента

Связанная страница: Управляемые шаблоны компонентов

Для упрощения создания управляемых компонентов, Altium Designer в сочетании с сервером управляемых данных поддерживает использование шаблонов компонентов (Component Templates). Подобно тому, как шаблоны схем можно использовать для предварительного определения информации на листах схем, которые ссылаются на эти шаблоны, управляемый компонент ссылается на шаблон компонента, который предоставляет заранее определенные настройки для их использования этим компонентом.

Поддержка шаблонов компонентов не включена в Altium 365 Standard. Соответственно, при этом уровне доступа к Altium 365, данная функциональность не будет доступна при подключении к Altium 365 Workspace.

Ревизия объекта шаблона компонентов, или, точнее, ссылка на нее ревизии объекта компонента, который вы в данный момент редактируете, может использоваться способами, которые приведены ниже.

Компонент может одновременно ссылаться только на один шаблон компонентов.

При создании нового компонента

При создании нового компонента с помощью команды File » New » Component из главного меню вы можете выбрать шаблон в диалоговом окне Create new component.

Быстрая настройка связи с шаблоном компонентов из списка всех доступных шаблонов при создании нового компонента.

Вручную из редактора Component Editor

Повторное использование ревизии объекта шаблона компонентов из редактора Component Editor зависит от режима работы редактора.

В режиме Single Component Editing

При редактировании отдельного компонента в этом режиме редактора Component Editor выберите нужный шаблон компонентов из выпадающего меню, связанного с полем Template, которое находится в группе Advanced Settings в области Component редактора. Будет приведен список названий всех объектов шаблонов компонентов, доступных на том же сервере управляемых данных, где находится сам объект компонента, с самыми новыми ревизиями, указанными в скобках. Выберите нужный шаблон, чтобы применить его.

Быстрая привязка объекта шаблона компонентов из меню всех доступных шаблонов при редактировании ревизии объекта компонентов с помощью редактора Component Editor в режиме Single Component Editing.

В режиме Batch Component Editing

Существует два способа применить ревизию объекта шаблона компонентов для редактируемой ревизии объекта компонента:

  • Из вкладки Template диалогового окна Document Options (Edit » Document Options). Нажмите кнопку Choose справа от поля Item Revision. Будет открыто диалоговое окно Choose Item (аналог панели Explorer). Используйте его, чтобы найти и выбрать ревизию нужного объекта шаблона компонентов. После нажатия OK, будет создана ссылка между ревизией объекта компонента и целевой ревизией объекта шаблона компонентов. Эта ссылка будет отображена на вкладке Template диалогового окна Document Options.

    Создание вручную ссылки из компонента на ревизию объекта шаблона компонентов на целевом сервере.

    Используемый объект шаблона компонентов можно изменить в любой момент – нажмите Choose и выберите ревизию другого объекта шаблона компонентов.
    Состояние связанной ревизии объекта шаблона компонентов отражено на вкладке Template диалоговому окна Document Options. Если доступна более новая ревизия связанного объекта, нажмите кнопку , чтобы использовать эту более новую ревизию.
  • Из меню Add, связанного с областью Required Models/Parameters редактора Component Editor. В подменю Templates приводится список названий всех объектов шаблонов компонентов, доступных в данный момент на том же сервере управляемых данных, в котором находится сам объект компонента, с указанием в скобках их самых новых ревизий. Щелкните ЛКМ по записи, чтобы создать ссылку на самую новую ревизию этого объекта шаблона компонентов. Опять же, верификацию ссылки можно увидеть на вкладке Templates диалогового окна Document Options.

    Быстрая привязка к объекту шаблона компонентов из меню всех доступных шаблонов.

Наследование из серверной папки компонентов

Вы можете задать, чтобы объект шаблона компонентов автоматически использовался всеми объектами компонентов (и их всеми ревизиями), которые хранятся в папке компонентов на сервере.

Объект шаблона компонентов по умолчанию может быть определен только папке с типом Components.

Укажите нужный шаблон с помощью поля Component Template при определении свойств папки в диалоговом окне Edit Folder. В связанном с полем выпадающем списке приводится список названий всех объектов шаблонов компонентов, доступных в данный момент на том же сервере управляемых данных, где находится сама папка компонентов, с указанием в скобках их самых новых ревизий. Выберите запись, чтобы создать ссылку на самую новую ревизию этого объекта шаблона компонентов для всех объектов компонентов, которые созданы в этой папке.

Укажите объект шаблона компонентов для его применения ко всем объектам компонентов, созданных в родительской папке компонентов.

Чтобы не использовать эту функциональную возможность, оставьте/задайте в поле Component Template значение None.

Если шаблон компонентов выбран на уровне папки, по умолчанию этот же шаблон будет использоваться при создании объектов компонентов в дочерних подпапках. Это упрощает быстрое наследование шаблонов всеми объектами в дочерних папках.

При выпуске ревизии объекта компонента, она будет, по сути, закреплена на определенной ревизии шаблона компонентов. Тем самым будет создана сильная ссылка на эту ревизию, если она не будет изменена вручную.

Влияние использования шаблона компонентов на модели и параметры компонента

При редактировании ревизии объекта компонента и ревизии объекта шаблона компонентов, с которым она связана, в редакторе Component Editor в отношении моделей и параметров произойдет следующее:

  • Модели, определенные в связанном шаблоне, будут добавлены в область Models (режим Single Component Editing) и область Model Links (режим Batch Component Editing).
  • Будет сохранена существующая связанная модель, и компонент сохранит использование этой модели, если она не будет целенаправленно изменена вручную.
  • Параметры, определенные в связанном шаблоне, будут добавлены в область Parameters (режиме Single Component Editing) и область Required Models/Parameters (режим Batch Component Editing).

    Пример параметров после привязки ревизии объекта шаблона компонентов при использовании редактора Component Editor в режиме Single Component Editing (слева) и в режиме Batch Component Editing (справа).

    Все параметры, поступившие из связанного объекта шаблона компонентов, отличаются иконкой (режим Single Component Editing) и иконкой (режим Batch Component Editing). Кроме того, только для режима Batch Component Editing, опция Show для каждого параметра из шаблона будет соответствовать состоянию соответствующей опции Visible в шаблоне.
    Параметры из шаблонов не могут быть удалены.
    Вы можете беспрепятственно добавлять дополнительные пользовательские параметры необходимым образом.
  • Все существующие пользовательские параметры с теми же именами, что и у параметров в связанном объекте шаблоне компонентов, будут заменены их версиями из шаблона. Все существующие значения таких параметров будут сохранены, а не перезаписаны значениями из шаблона.
  • Только в режиме Batch Component Editing, параметры из шаблона, которые были заданы как видимые, будут сгруппированы в области определений компонентов редактора, с текстом заголовка Template Parameters.

    Пример параметров из шаблона в области, где определяются сами компоненты, при использовании редактора Component Editor в режиме Batch Component Editing.

  • Поля значений параметров из шаблонов, которые были помечены как только для чтения, будут не доступны для редактирования. Для всех прочих параметров из шаблонов, которые не были помечены как только для чтения, вы можете беспрепятственно изменять значения необходимым образом.
    Когда редактор Component Editor находится в режиме Single Component Editing, параметры из шаблона, доступные только для чтения, будут отличаться в области Parameters иконкой .
  • Если параметр из шаблона был помечен как обязательный, но ему не было задано значение в шаблоне, поле этого значения будет отображено с красной границей (в режиме Batch Component Editing) или будет содержать иконку (в режиме Single Component Editing), что просигнализирует вам о том, что необходимо указать значение этого параметра. Вы не сможете выпустить компонент, пока не будут определены значения для всех обязательных параметров.
    В редакторе Component Editor в режиме Single Component Editing обязательные параметры из шаблона отличаются в области Parameters иконкой .

Шаблоны списков параметров

Если вы не используете объекты шаблонов компонентов, вы всё ещё можете создавать предварительно определенные списки параметров благодаря поддержке настраиваемых шаблонов списков параметров (Parameter List Templates) в редакторе Component Editor. Эти простые, удобочитаемые с человеческой точки зрения файлы могут быть созданы в качестве списков необходимых параметров, которые затем можно загрузить в редактор в один клик.

Использование шаблонов списков параметров поддерживается редактором Component Editor только в режиме Batch Component Editing.
Шаблоны компонентов предлагают намного более эффективный подход к организации не только набора параметров, но и требуемых моделей. Также с их помощью можно определять типы компонентов. Кроме того, только с помощью шаблонов компонентов вы можете определять параметры с единицами измерения, которые необходимы для расширенного поиска компонентов. В связи с этим, если на сервере управляемых данных присутствует хотя бы один объект шаблона компонентов, возможность использования шаблонов списков параметров будет отключена, и вы не сможете видеть и загружать эти шаблоны в редактор Component Editor.

Шаблоны списков параметров можно найти в подменю Templates, которое открывается щелчком ЛКМ по элементу управления Add в нижней части области Required Models/Parameters. Доступно несколько предварительно определенных шаблонов с наборами параметров для конденсаторов (Capacitor), резисторов (Resistor), диодов (Diode) и транзисторов (Transistor).

Доступ к шаблонам параметров из меню, связанного с элементом управления Add.

Щелкните ЛКМ по шаблону, который вы хотите использовать. Параметры, определенные в этом шаблоне, будут добавлены в область.

Добавление набора параметров для использования компонентом(-ами) можно ускорить с помощью шаблонов параметров.

Определение шаблона

Шаблон параметров определяется в файле шаблона библиотеки компонентов (*.cmplib_template). Чтобы эти файлы были опознаны системой и, соответственно, появились в подменю Templates в редакторе Component Editor, они должны располагаться в папке Templates вашей установки Altium Designer (\Users\Public\Documents\Altium\AD<НомерВерсии>\Templates для установки по умолчанию).

Определение шаблона достаточно простое: оно состоит из названия шаблона (которое должно появится в подменю), заключенного в квадратные скобки, после чего приводится список нужных параметров в формате <ИмяПараметра>=. В качестве примера, ниже приведен предопределенный шаблон параметров для резисторов resistor.cmplib_template:

[Resistor]
Category=
Manufacturer=
Manufacturer Part Number=1
Mounting Type=
Temperature=
Package Type=
Package Reference=
RoHS=
Temperature Coefficient=
Tolerance=
Weight=
Height=
Value=
Power=
Resistance=
Composition=

Знак '=' необходим, чтобы параметр был добавлен в список в области Required Models/Parameters при использовании шаблона. Если удалить этот знак из файла шаблона, оставив только название параметра, то этот параметр будет исключен при добавлении шаблона.
В одном файле шаблона может быть добавлено любое количество шаблонов параметров. Это можно увидеть в файле group.cmplib_template, который содержит в себе шаблоны для конденсаторов и диодов.
Если один и тот же шаблон ([<НазваниеШаблона>]) определен больше одного раза в одном файле .cmplib_template, будет использоваться только его первый экземпляр. Система также обеспечивает отсутствие дубликатов параметров, если добавляются параметры из более чем одного шаблона. Если параметр, который должен быть добавлен, уже существует с точно таким же именем, при загрузке шаблона он будет проигнорирован.

Повторный выпуск объекта компонента

На любом этапе вы можете вернуться к любой ревизии объекта компонента на сервере и напрямую отредактировать ее:

  • Из панели Components – щелкните ПКМ по записи управляемого компонента и выберите команду Edit из контекстного меню.
  • Из панели Explorer – щелкните ПКМ по ревизии и выберите команду Edit из контекстного меню.

Будет открыт временный редактор Component Editor в режиме Single Component Editing, с определением компонента из открытой на редактирование ревизии. Внесите необходимые изменения, затем выпустите компонент в следующую ревизию объекта.

В панели Explorer щелкните ПКМ по записи верхнего уровня самого объекта, чтобы изменить самую новую ревизию этого объекта.

Доступ к команде для запуска прямого редактирования существующей ревизии объекта компонента, из панели Components или из панели Explorer.

Если вы выбрали для редактирования множество компонентов в панели Components, то для каждого из них будет открыт отдельный временный экземпляр редактора Component Editor в режиме Single Component Editing. Если вы выбрали для редактирования множество компонентов в панели Explorer, будет открыт временный редактор Component Editor в режиме Batch Component Editing.

Загрузка исходных данных компонента

Вы также можете загружать один или множество компонентов с сервера управляемых данных в zip-архив, содержащий в себе исходные библиотеки символов и моделей и исходный пакет интегрированной библиотеки (*.LibPkg). Это можно использовать для быстрого формирования интегрированной библиотеки выбранных компонентов. При размещении компонентов из этой интегрированной библиотеки их ссылки будут вести к объектам компонентов на сервере. Это позволят использовать управляемые компоненты предприятия офлайн, при этом сохранив связь этих компонентов с проекте с исходным сервером управляемых данных.

Процесс загрузки компонентов в zip-архив из панели Components выглядит следующим образом:

  1. Найдите/отфильтруйте управляемые компоненты с помощью функциональных возможностей панели (категории, параметрическая фильтрация и т.д.).
  2. Выберите управляемые компоненты, которые вы хотите загрузить. Вы можете включить в загрузку любое необходимое количество различных управляемых компонентов.
  3. Щелкните ПКМ по какой-либо выбранной записи и выберите команду Operations » Download из контекстного меню.
  4. В диалоговом окне Save As укажите название и расположение формируемого zip-архива. По умолчанию этот файл будет иметь название в формате Components - <Дата> - <Время>.zip.
  5. Нажмите кнопку Save, чтобы начать загрузку и формирование zip-архива. Будет создан пакет интегрированной библиотеки (*.LibPkg), в котором будут сформированы и добавлены исходные файлы SchLib (с символами, параметрами и ссылками на модели) и PcbLib (с моделями посадочных мест). Затем в указанной папке будет сформирован zip-архив. Информационное диалоговое окно подтвердит успешное формирование файла.

Процесс загрузки компонентов в zip-архив из панели Explorer выглядит следующим образом:

  1. Перейдите к папке, содержащей в себе компоненты, которые вы хотите загрузить.
  2. Выберите ревизии объектов компонентов, которые вы хотите загрузить. Вы можете выбрать только одну ревизию определенного объекта компонента (как правило, это самая новая ревизия), но вы можете включить в загрузку любое необходимое количество различных объектов компонентов.
  3. Щелкните ПКМ по какой-либо выбранной записи и выберите команду Operations » Download из контекстного меню (при загрузке множества компонентов эта команда будет отображена как Operations » Download selected component to zip).
  4. В диалоговом окне Save As укажите название и расположение формируемого zip-архива. По умолчанию этот файл будет иметь название в формате Components - <Дата> - <Время>.zip.
  5. Нажмите кнопку Save, чтобы начать загрузку и формирование zip-архива. Будет создан пакет интегрированной библиотеки (*.LibPkg), в котором будут сформированы и добавлены исходные файлы SchLib (с символами, параметрами и ссылками на модели) и PcbLib (с моделями посадочных мест). Затем в указанной папке будет сформирован zip-архив. Информационное диалоговое окно подтвердит успешное формирование файла.

Пример загрузки (хоть и для одного компонента!) zip-архива из панели Components.

Обратимое удаление

При использовании Altium 365 Workspace в качестве сервера управляемых данных, доступны гибкие функциональные возможности для удаления объекта компонента непосредственно из Altium Designer, из панели Explorer. Щелкните ПКМ по строке объекта в панели и выберите команду Delete Item из контекстного меню. Будет открыто диалоговое окно Delete Items для подтверждения удаления. Будет выполнено обратимое удаление, где компонент будет перемещен в область Trash в Workspace. Эта область является, по сути, корзиной, в которую можно переместить (через обратимое удаление) любой управляемый объект в Workspace. Эта область изолирована от остальной части Workspace.

С помощью обратимого удаления, вы можете удалить используемый объект. Для объекта компонента, вы также можете удалить связанные с компонентом объекты (символ, посадочные места, имитационную модель, даташиты). Обратите внимание, что их можно удалить, только если они не используются где-либо еще (одним или множеством других компонентов).
Множество объектов компонентов можно удалить в одно действие. Выберите все нужные объекты с помощью стандартных сочетаний клавиш (Shift+ЛКМ, Ctrl+ЛКМ), щелкните ПКМ и выберите команду Delete Items из контекстного меню.

Обратимое удаление объекта компонента со связанными с ним объектами символа и посадочного места. Все объекты будут перемещены в область Trash в Workspace.

Чтобы начать удаление, нажмите кнопку . Объект будет удален, и диалоговое окно Deletion Summary подтвердит успешное удаление. Если при удалении возникнет какая-либо проблема, вы будете оповещены об этом.

Все объекты, удаленные таким образом, можно найти на странице Trash веб-интерфейса Workspace. Обратите внимание, что вы можете просматривать только те объекты, которые вы сами удалили. Администраторы смогут увидеть полное содержимое страницы Trash, т.е. все объекты, которые были обратимо удалены.

Что следует иметь в виду касательно обратимо удаленных объектов:

  • Объект станет недоступным в системе проектирования и в веб-интерфейсе.
  • Везде, где использовался объект, будет отражено, что компонент был удален.

    Пример отображения в системе компонента как обратимо удаленного.

  • Компонент можно восстановить или удалить полностью со страницы Trash. Полное удаление возможно только в том случае, если он не используется родительским объектом (на управляемом листе схемы или в проекте).
Обратите внимание, что если вы удалили объект с возможностью восстановления, т.е. переместили его в область Trash, вы можете создать новый объект с тем же именем. Если вы затем восстановите изначальный объект, будет взято изначальное имя и к нему будет добавлен целочисленный суффикс, чтобы обеспечить уникальность имен в Workspace.
Компонент также можно обратимо удалить со страницы Components веб-интерфейса Workspace. Для получения более подробной информации перейдите в раздел Удаление компонента.

Миграция существующих библиотек моделей

Главная страница: Миграция существующих библиотек на сервер управляемых данных

Altium Designer в сочетании с сервером управляемых данных обеспечивает простой процесс для быстрой миграции существующих библиотек на этот сервер. Пользовательский интерфейс этого процесса – Library Migrator – представляет интуитивно понятный порядок действий, который мигрирует изначально выбранные библиотеки на ваш сервер. Средство Library Migrator позволяет обрабатывать все типы библиотек, связанных со старыми методологиями управления компонентами (SCHLIB, PCBLIB, INTLIB, DBLIB, SVNDBLIB), что делает его идеальным решением для быстрого создания набора управляемых компонентов предприятия и последующего использования всех преимуществ таких компонентов: высокая целостность данных, управление жизненными циклами, централизованное хранение и управление, изучение применяемости, простота повторного использования.

Средство Library Migrator предлагает минималистический простой режим интерфейса (Simple), где выбранные файловые библиотеки компонентов мигрируют на сервер в управляемые компоненты в один этап. При этом средство миграции берет на себя классификацию по типам, назначение целевых папок, добавление параметров и типов значений, а также передачу всех связанных данных. Также доступен расширенный режим интерфейса (Advanced), где доступен полный предварительный просмотр планируемой миграции библиотек и все соответствующие данные и настройки. И хотя миграция по умолчанию осуществляется в один клик, средство миграции также предлагает расширенные настройки в панели Properties для лучшего контроля над тем, как будет осуществлена миграция.

Чтобы открыть средство Library Migrator, используйте команду File » Library Migrator из главного меню любого редактора.

Вся информация, которая присутствует в исходной библиотеке, будет мигрирована в серверные компоненты (управляемых компонентов, которым назначены варианты выбора), со всеми доменными моделями (схемные символы, посадочные места, 3D-модели, имитационные модели), параметрами, назначенными вариантами выбора компонентов, даташитами и т.д. Также при необходимости будут созданы шаблоны компонентов, которые можно настроить и которые можно будет использовать при следующей миграции. Если в изначальных компонентах определено множество посадочных мест, вы можете быть уверены, что средство Library Migrator перенесет их и сохранит текущее посадочное место по умолчанию. И если вы работаете только с библиотеками посадочных мест (например, если вас интересует только конструирование плат), то Library Migrator поддерживает миграцию только таких библиотек, либо это средство можно переключить в режим миграции только моделей, при котором из интегрированных библиотек и библиотек на основе баз данных будут мигрированы модели указанных типов. Библиотеки, которые включают в себя компоненты множества типов (монолитные библиотеки), также автоматически выявляются и обрабатываются.


Library Migrator в режиме Advanced – полный пользовательский интерфейс процесса миграции компонентов.

Хотя процесс миграции может показаться пугающим, заданные по умолчанию настройки позволяют получить набор управляемых компонентов без внесения каких-либо изменений – запустите процесс, чтобы воспользоваться преимуществами работы средства миграции. Система проведет ряд проверок, чтобы, например, убедиться в отсутствии дублирующихся идентификаторов получаемых управляемых компонентов или в том, что не будут созданы дубликаты моделей и шаблонов компонентов, и эти записи будут связаны с компонентами, где это необходимо. И если возникнут какие-либо проблемы, система оповестит о них и предложит пути их устранения для быстрого и беспрепятственного возвращению к миграции.
Обнаружили проблему в этом документе? Выделите область и нажмите Ctrl+Enter, чтобы оповестить нас.

Связаться с нами

Связаться с нашими Представительствами напрямую

We're sorry to hear the article wasn't helpful to you.
Could you take a moment to tell us why?
Вы сообщаете о проблеме, связанной со следующим выделенным текстом
и/или изображением в активном документе:
Бесплатная пробная версия Altium Concord Pro

Заполните форму ниже, чтобы получить бесплатную пробную версию Altium Concord Pro