Altium Designer Documentation

Работа с интегрированными библиотеками

Последнее изменение: Pavel Demidov; 22.10.2020

Главная страница: Подробнее о компонентах и библиотеках

Интегрированные библиотеки являются вторым поколением методологии управления компонентами Altium Designer, т.е. они отражают модель интегрированных компонентов. Согласно этой модели, в схемном символе в файле библиотеки моделируется компонент более высокого уровня. В символ добавляются параметры компонента и ссылки на другие модели. Все исходные библиотеки: символ и подключенные модели – определяются в проекте пакета интегрированной библиотеки (Integrated Library Package), который затем компилируется в единый файл интегрированной библиотеки (Integrated Library, или IntLib).

В этом документе рассмотрены различные способы создания интегрированной библиотеки, а также размещения из нее компонентов и внесения в нее изменений.

Преимущества интегрированных библиотек

Ключевые преимущества компиляции в интегрированную библиотеку:

  • Вся информация о компонентах доступна в едином переносимом файле. Поскольку все модели упакованы в интегрированную библиотеку, для проекта должен быть доступен только один файл, и только его необходимо перемещать вместе с проектом. Эта переносимость крайне полезна, если вы работаете на нескольких компьютерах или если вы хотите отправить свои проекты коллегам.
  • Если компонент размещен на листе схемы проекта из интегрированной библиотеки, Altium Designer точно найдет нужную модель в ней, если эта библиотека доступна, поскольку в этом случае отсутствует какая-либо работа с отдельными файлами библиотек и моделей, где ссылки на модели легко нарушить при выполнении повседневных задач, таких как переименование папок на жестком диске).
  • Интегрированные библиотеки надежны с точки зрения безопасности. После того, как интегрированная библиотека сформирована, в нее нельзя внести изменения. По сути, изменение интегрированной библиотеки означает ее полную замену. Необходимо специально загрузить изначальный пакет библиотеки, внести изменения в исходные документы и провести повторную компиляцию.
  • Целостность интегрированных библиотек проверяется при компиляции. Это значит, что осуществляется не только проверка работоспособности, но и корректности сопоставления выводов. Если вы хотите продолжить использовать отдельные библиотеки, рекомендуется скомпилировать схемные библиотеки в пакете интегрированной библиотеки, чтобы убедиться, что исходные компоненты корректно сопоставлены целевыми моделями. Если всё хорошо, вы можете не использовать созданную интегрированную библиотеку, а продолжить размещать компоненты из схемных библиотек.

Создание IntLib с помощью пакета библиотеки

Пакет интегрированной библиотеки (*.LibPkg) – это тип проекта Altium Designer, который используется для сбора набора проектных документов, необходимых для формирования интегрированной библиотеки. Схемный символ создается в редакторе схемных библиотек, и для каждого из них определяются параметры и ссылки на модели. Эта информация хранится в одном или множестве файлов схемных библиотек. Моделями, на которые заданы ссылки, могут быть посадочными местами, моделями имитатора и моделями целостности сигналов.

Единственный документ, который обязательно следует добавить в пакет интегрированной библиотеки, это схемная библиотека (или библиотеки). Файлы, содержащие в себе посадочные места или модели имитатора, могут быть расположены в любом доступном для поиска расположении в проекте, в файлах из списка установленных библиотек или по пути (путям) поиска, указанного в пакете.

Затем пакет библиотеки компилируется в единый файл интегрированной библиотеки (*.IntLib).

Добавление библиотек моделей в проект или их размещение по путям поиска зависит от вашего стиля работы. Если вы редактируете и проверяете модели при подготовке пакета интегрированной библиотеки, может быть удобнее, чтобы библиотеки моделей были у вас под рукой – тогда добавляйте их в сам проект. Если вы постоянно добавляете библиотеки моделей в определенные папки на жестком диске или в сети, может быть удобнее использовать пути поиска, чтобы компилятор автоматически искал новые библиотеки.

Четыре основных этапа создания интегрированной библиотеки приведены ниже:

  1. Создание исходного пакета библиотеки.
  2. Создание и добавление нужных файлов исходных схемных библиотек.
  3. Создание и добавление нужных файлов доменных моделей (или определение ссылок на них).
  4. Компиляция пакета библиотеки для формирования файла интегрированной библиотеки.

Создание исходного пакета библиотеки

Чтобы создать новый пакет интегрированной библиотеки, выберите команду File » New » Library » Integrated Library из главного меню. В панель Projects будет добавлен новый пустой проект пакета библиотеки.

Создание и добавление исходной схемной библиотеки

Создайте исходную схемную библиотеку (*.SchLib), содержащую в себе нужные компоненты. Добавьте в компоненты параметры и ссылки на нужные модели. Существует два способа создания исходной схемной библиотеки:

  • С нуля, с помощью команды File » New » Library » Schematic Library. Создайте новые компоненты с помощью редактора схемных библиотек или скопируйте компоненты из других открытых схемных библиотек.
  • Из компонентов, которые уже были размещены в документах схем проекта, с помощью команды Design » Make Schematic Library.
При создании схемной библиотеки из компонентов, размещенных в существующем проекте, все исходные документы схем будут открыты автоматически. Сформированная библиотека будет названа в соответствии с проектом (<НазваниеПроекта>.SchLib).

После подготовки исходной схемной библиотеки (или библиотек) добавьте их в пакет библиотек, используя один из приведенных ниже способов:

SchLib, добавленная в пакет библиотеки
Исходная библиотека SchLib, добавленная в пакет библиотеки.

Создание и добавление файлов доменных моделей

Создайте модели, ссылки на которые будут заданы в схемных компонентах, в соответствующих файлах: посадочные места в библиотеке посадочных мест (*.PcbLib), моделей имитатора в файлах (*.Mdl) и файлах подсхем (*.Ckt). Очень важны здесь, конечно же, модели посадочных мест, поскольку они являются ответными частями схемных компонентов, и их можно создать двумя способами:

  • С помощью команды File » New » Library » PCB Library создайте новые 2D-посадочные места (и добавьте 3D-модели) с помощью редактора библиотек посадочных мест или скопируйте компоненты из других библиотек посадочных мест.
  • Из компонентов, которые уже были размещены в документе платы, с помощью команды Design » Make PCB Library.
При создании библиотеки посадочных мест из существующего документа платы убедитесь, что нужный документ открыт и активен. Сформированная библиотека будет названа в соответсвии с документом платы (<ИмяДокументаПлаты>.PcbLib).

Определение того, где искать модели

После определения файлов моделей их необходимо сделать доступными для пакета библиотеки, чтобы их можно было легко найти, когда это будет необходимо. Имейте в виду, что в схемных компонентах задаются ссылки на модели. Altium Designer использует стандартную систему доступа к моделям, независимо от того, создаете ли вы пакет интегрированной библиотеки или работаете со схемой. Существует три способа, как можно сделать модели доступными:

  • Добавление библиотеки/модели в проект.
  • Добавление библиотеки/модели в список установленных библиотек, которые доступны всем проектам.
  • Определение пути поиска библиотеки/модели.

У каждого из этих способов есть свои преимущества, в зависимости от стиля вашей работы или типа моделей. Например, может быть неудобно, чтобы в панели Projects отображалось большое количество моделей имитатора при открытии пакета библиотеки, но здесь может быть лучше отображать библиотеки посадочных мест. В этом случае, определите путь поиска к папке, где находятся модели имитатора, и добавьте библиотеки посадочных мест в пакет библиотеки.

Эти три метода в совокупности образуют систему доступных для проекта файловых библиотек (Available File-based Libraries), и их можно задать в диалоговом окне Available File-based Libraries. Чтобы открыть это диалоговое окно, нажмите Кнопка доступа к диалоговым окнам библиотек в правой верхней части панели Components и выберите File-based Libraries Preferences.

Открытие диалогового окна Available File-based Libraries
Настройте доступные модели с помощью диалогового окна Available File-based Libraries.

Библиотеку посадочных мест (и другие файлы моделей) также можно добавить непосредственно в пакет библиотеки с помощью команды Add Existing to Project, которая доступна в главном меню Project и в контекстном меню строки пакета библиотеки в панели Projects.

Библиотека PCBLib, добавленная в пакет библиотеки
Исходная библиотека PcbLib, добавленная в пакет библиотеки.

При определении путей поиска файлов моделей с вкладки Search Path диалогового окна Available File-based Libraries открывается вкладка Search Paths диалогового окна Options for Integrated Library (Project » Project Options). Добавьте один или несколько путей. Имейте в виду, что поиск моделей осуществляется по этим путям от верхнего к нижнему. Нажмите кнопку Refresh List, чтобы убедиться, что нужный файлы моделей найдены, и измените путь при необходимости.

Заданный путь поиска и доступные файловые библиотеки
Пример заданного пути поиска, в котором найден нужный файл библиотеки.

Компиляция пакета библиотеки

Когда исходные библиотеки добавлены в пакет библиотеки и все пути к файлам моделей заданы нужным образом, пакет можно скомпилировать для формирования интегрированной библиотеки. Как при компиляции других проектов, компилятор пакета интегрированной библиотеки сформирует список предупреждений и ошибок, например, предупреждения о моделях, которые не были найдены. Кроме того, осуществляется проверка ошибок сопоставления выводов, если, например, задано сопоставление с контактными площадками 1 и 2, в то время как посадочное место содержит, на самом деле, контактные площадки A и K.

Даже если вы хотите продолжить использовать отдельные библиотеки, рекомендуется скомпилировать схемные библиотеки в пакете интегрированной библиотеки, чтобы убедиться, что исходные компоненты корректно сопоставлены целевыми моделями.

Перед запуском компиляции целесообразно задать настройки, при каких условиях будут выдаваться сообщения об ошибках, на вкладке Error Reporting диалогового окна Options for Integrated Library.

Вкладка Error Reporting диалогового окна Options for Integrated Library
Перед компиляцией пакета библиотеки задайте настройки и уровни отчетов об ошибках.

Чтобы запустить компиляцию, используйте команду Compile Integrated Library из главного меню Project или контекстного меню строки пакета библиотеки в панели Projects. Исходные библиотеки и файлы моделей будет скомпилированы в интегрированную библиотеку, названную в соответствии с исходным пакетом библиотеки (<ИмяПакетаБиблиотеки>.IntLib). Компилятор проведет проверку нарушений, и все найденные ошибки и предупреждения будут приведены в панели Messages. Исправьте проблемы в исходных библиотеках, затем выполните повторную компиляцию.

В панели Messages отображены ошибки компиляции
Пример ошибок, найденных при компиляции пакета интегрированной библиотеки.

Интегрированная библиотека сохраняется в выходную папку, указанную на вкладке Options диалогового окна Options for Integrated Library (по умолчанию это подпапка в расположении проекта: \Project Outputs for <ИмяПроекта>). Библиотека автоматически добавляется на вкладку Installed диалогового окна Available File-based Libraries.

Скомпилированная библиотека IntLib добавляется на вкладку Installed диалогового окна Available File-base Libraries
Скомпилированная интегрированная библиотека добавляется на вкладку Installed диалогового окна Available File-based Libraries.

Создание IntLib из документов проекта

Интегрированную библиотеку также можно создать непосредственно из документов, входящих в проект (исходных схем и документа платы). Используйте команду Make Integrated Library, которая доступна в главном меню Design редактора схем и редактора плат.

Процесс включает в себя следующие этапы:

  1. Открытие всех исходных документов схем и создание схемной библиотеки.
  2. Создание библиотеки посадочных мест из документа платы.
  3. Компиляция этих библиотек в интегрированную библиотеку, названную в соответствии с проектом (<НазваниеПроекта>.IntLib).

Библиотека IntLib будет добавлена в проект (в раздел Libraries\Compiled Libraries в панели Projects), в установленные библиотеки (т.е. в список Installed в диалоговом окне Available File-based Libraries – библиотек, доступных для всех проектов), и она станет доступна из панели Components.

Создание интегрированной библиотеки из документов схемы и платы
Простое создание интегрированной библиотеки непосредственно из документов схемы и платы активного проекта.

Создание IntLib из библиотеки на основе базы данных

Связанная страница: Работа с библиотеками на основе баз данных

Библиотеки на основе баз данных идеально подходят в тех случаях, когда вы хотите, чтобы компоненты Altium Design были тесно связаны с базой данных предприятия. Если необходимо передать проект за пределы предприятия либо если вы хотите, чтобы проектировщики работали с безопасными интегрированными библиотеками, этого можно добиться. Система предоставляет возможность скомпилировать интегрированную библиотеку непосредственно из библиотеки на основе базы данных – либо из стандартной библиотеки на основе базы данных (DbLib), либо из библиотеки на основе базы данных в системе контроля версий (SVNDbLib). Таким образом, библиотекари могут продолжать использовать библиотеки на основе баз данных, а проектировщики – использовать периодически повторно формируемые интегрированные библиотеки, работая как бы автономно.

Преобразование осуществляется с помощью мастера Offline Integrated Library Maker. Процесс осуществляется для каждой каждой таблицы базы данных, с полным контролем над тем, какие таблицы в базе данных следует учитывать. Для каждой включенной таблицы будет создана отдельная интегрированная библиотека.

Offline Integrated Library Maker
Преобразование библиотек на основе баз данных (DbLibs или SVNDbLibs) в "автономные" интегрированные библиотеки с помощью мастера Offline Integrated Library Maker.

Процесс включает в себя следующие шаги:

  1. Когда файл Database Library (*.DbLib) или SVN Database Library (*.SVNDbLib), который вы хотите преобразовать, открыт в качестве активного документа, выберите команду Tools » Offline Integrated Library Maker из главного меню, чтобы открыть Offline Integrated Library Maker.
  2. На странице Library to Convert укажите файл DbLib или SVNDbLib, который следует обработать. По умолчанию в качестве библиотеки для преобразования будет указана активная библиотека, из которой был запущен Offline Integrated Library Maker. При необходимости вы можете найти и выбрать другую библиотеку на основе базы данных.
  3. На странице Options укажите, какие таблицы в подключенной базе данных следует включить в процесс преобразования. По умолчанию будут включены все таблицы базы данных. Чтобы исключить какую-либо таблицу, убедитесь, что соответствующий параметр Convert отключен. На этой странице мастера Offline Integrated Library Maker вы также можете указать выходную директорию, в которую будут сохранены сформированные интегрированные библиотеки. Введите путь к этой директории напрямую или нажмите иконку Иконка Browse справа от поля, чтобы открыть диалоговое окно, из которого вы можете перейти к нужной директории и выбрать ее. Сформированный выходной файл (интегрированная библиотека) для каждой включенной таблицы базы данных будет сохранен в собственную подпапку внутри указанной выходной папки, с тем же названием, что и у таблицы.
  4. После выбора библиотеки на основе базы данных и настройки соответствующих параметров преобразования необходимым образом нажмите Next, чтобы начать процесс преобразования. Будет отображен индикатор выполнения, а также информация о преобразуемой в данный момент библиотеке. Помните, что процесс преобразования осуществляется для каждой таблицы базы данных, которую вы указали для преобразования. Этот процесс включает в себя следующие шаги:
    1. В панели Projects создается и открывается пакет интегрированной библиотеки (*.LibPkg). Название пакета соответствует имени таблицы. Например, для таблицы под названием Capacitor - Ceramic будет создан пакет с названием Capacitor - Ceramic.LibPkg.
    2. Будет создан и добавлен в пакет LibPkg документ схемной библиотеки. Опять же, эта библиотека будет названа в соответствии с именем таблицы (например, Capacitor - Ceramic.SchLib).
    3. Каждая запись в таблице затем рассматривается как компонент Altium, который нужно создать. Для этого из соответствующей исходной библиотеки извлекается схемный символ, который добавляется в качестве компонента в новую библиотеку. Затем в этот компонент добавляется информация о параметрах и ссылках на модели, определенная в записи.
    4. Модели посадочных мест, на которые приведены ссылки, извлекаются и добавляются в документ библиотеки посадочных мест. Опять же, название этого документа соответствует названию таблицы (например, Capacitor - Ceramic.PcbLib). Документ библиотеки посадочных мест затем добавляется в пакет LibPkg.
    5. Если исходной библиотекой является DbLib и в записи базы данных определены ссылки на модели PCB3D или имитационные модели, соответствующие файлы моделей PCB3D или имитационных моделей также добавляются в LibPkg. Расположение этих моделей остается неизменным. Полный путь к модели указывается в ссылке на соответствующую модель.
    6. Происходит компиляция LibPkg, результатом которой является интегрированная библиотека (например, Capacitor - Ceramic.IntLib), после чего эта библиотека добавляется в список установленных библиотек Altium Designer.
Установленные в данный момент библиотеки можно увидеть на вкладке Installed диалогового окна Available File-based Libraries, доступ к которому осуществляется нажатием кнопки Кнопка доступа к диалоговым окнам библиотек в верхней правой части панели Components и выбором команды File-based Libraries Preferences.

Results of the conversion process - LibPkg projects created and compiled IntLib files
Результат процесса преобразования – проекты пакетов библиотек с входящими в их состав документами библиотек символов и посадочных мест, а также скомпилированные библиотеки IntLib, которые добавляются в список установленных библиотек.

Создание IntLib путем заимствования компонентов

Связанная страница: Работа с Content Cart

У вас также есть возможность получить компоненты с сервера управляемых данных в интегрированную библиотеку. При размещении компонентов из такой интегрированной библиотеки ссылки будут указывать на объекты компонентов на этом сервере. Это предоставляет вам возможность использовать управляемые компоненты компании без подключения к серверу, при этом сохранив связь проекта с компонентами на исходном сервере управляемых данных. Также будет продолжено использование информации о цепочке поставок, заданная в этих компонентах с помощью списков вариантов выбора компонентов.

Процесс получения библиотек IntLib с помощью диалогового окна Content Cart осуществляется следующим образом:
  1. Щелкните ЛКМ по ссылке Select target Server и выберите IntLib file из меню.

    Настройка получения в файл IntLib
    Определение файла IntLib в качестве цели Content Cart.

  2. Укажите имя и расположение сформированного файла IntLib. По умолчанию файлу будет задано имя в формате Integrated_Library - <Дата> - <Время>.IntLib, и он будет сформирован в папке \Users\Public\Documents\Altium\AD<Версия>\Library\ExportCmpLib. Измените эти параметры необходимым образом с помощью диалогового окна Save As – чтобы открыть его, нажмите Change.

    Изменение целевой папки
    Примените имя файла и целевую папку по умолчанию либо измените их необходимым образом.

  3. Если необходимо получить дополнительные компоненты в ту же библиотеку IntLib, щелкните ЛКМ по ссылке Add More Items, затем используйте открывшееся диалоговое окно Choose Item, чтобы выбрать эти компоненты.
  4. Нажмите кнопку Deliver Cart, чтобы начать формирование IntLib. Будет создан временный пакет интегрированной библиотеки (*.LibPkg), в который будут добавлены сформированные исходные файлы SchLib (с символами, параметрами и ссылками на модели) и PcbLib (с посадочными местами). Затем этот пакет будет скомпилирован для создания файла IntLib, который будет сформирован в заданной папке. Информационное диалоговое окно подтвердит успешное создание файла.

    Получение корзины в целевую папку
    Получение корзины в целевую папку, которая будет содержать в себе файл интегрированной библиотеки.

После формирования файла библиотеки IntLib он добавляется в список установленных библиотек диалогового окна Available File-based Libraries, т.е. он становится доступной для системы библиотекой.

Размещение компонентов из интегрированной библиотеки

Размещение компонентов из интегрированной библиотеки осуществляется с помощью панели Components. Размещение можно выполнить в активный документ схемы или активный документ платы. Размещение может быть выполнено следующими способами:

  • Выберите нужный файл *.IntLib в выпадающем списке панели Components, затем щелкните ПКМ по компоненту, который следует разместить, и выберите команду Place <НазваниеКомпонента> из контекстного меню. Наведите компонент на нужное место в документе схемы, затем щелкните ЛКМ для размещения.
  • Перетащите нужный компонент в рабочую область документа с зажатой ЛКМ.
С помощью кнопки Place можно разместить множество экземпляров компонента, поскольку при использовании этого способа режим размещения будет активен до нажатия клавиши Esc или щелчка ПКМ. Перетаскивание с помощью ЛКМ может быть быстрее, но с его помощью можно разместить только один экземпляр компонента за раз.

Хотя схемная библиотека и интегрированная библиотека могут включать в себя один и тот же компонент (с одними и теми же ссылками на модели), размещенные из этих библиотек компоненты будут работать по-разному при извлечении информации о моделях. Компоненты, размещенные из интегрированных библиотек, будут искать свои модели в изначальной интегрированной библиотеке, в то время как у компонентов, размещенных из схемных библиотек, нет доступа к моделям, сохраненным в интегрированных библиотеках.

Изменение интегрированной библиотеки

Интегрированные библиотеки используются для размещения компонентов, и их нельзя изменить напрямую. Чтобы внести изменения в интегрированную библиотеку, сначала измените исходные библиотеки, затем проведите повторную компиляцию, чтобы сформировать новую интегрированную библиотеку, включающую в себя эти изменения.

Чтобы изменить интегрированную библиотеку:

  1. Откройте исходный проект пакета библиотеки нужной интегрированной библиотеки.
  2. Откройте исходные схемные библиотеки или библиотеки моделей, которые необходимо изменить.
  3. Внесите нужные изменения, сохраните измененные библиотеки и закройте их.
  4. Повторно скомпилируйте пакет библиотеки. Сформированная новая библиотека заменит собой старую, существующую версию.

Декомпиляция интегрированной библиотеки

Может случиться, что необходимо получить доступ к исходным библиотекам интегрированной библиотеки для их изменения, но, по какой-то причине, проект пакета исходной библиотеки, с помощью которого это можно было бы сделать, больше не доступен. Здесь будет полезным еще одно свойство единого переносимого файла библиотеки. Хотя интегрированные библиотеки нельзя изменять напрямую, их можно декомпилировать для получения исходных библиотек символов и моделей.

Для этого выполните следующее:

  1. Откройте интегрированную библиотеку, включающую в себя исходные библиотеки, которые необходимо изменить. Сделать это можно одним из двух следующих способов:
    1. Выберите команду File » Open, найдите интегрированную библиотеку в диалоговом окне Choose Document to Open и нажмите Open.
    2. Перетащите с зажатой ЛКМ файл IntLib из Проводника Windows в окно Altium Designer.
  2. В открывшемся диалоговом окне Extract Sources or Install нажмите кнопку Extract Sources.

    Необходимо нажать именно кнопку Extract Sources. При нажатии кнопки Install Library библиотека IntLib будет добавлена на вкладку Installed диалогового окна Available File-based Libraries.

Исходные библиотеки символов и моделей будут извлечены и сохранены в новую подпапку, названную в соответствии с именем файла интегрированной библиотеки, в папке, где находится изначальная интегрированная библиотека. Затем будет создан пакет библиотеки (<ИмяФайлаИнтегрированнойБиблиотеки>.LibPkg), который будет отображен в панели Projects и в который будут добавлены исходные библиотеки схемных символов и посадочных мест. Файлы имитационных моделей и подсхем не добавляются в проект автоматически.

Диалоговое окно Extract Sources or Install
Извлечение исходных библиотек из интегрированной библиотеки, т.е. ее декомпиляция для создания проекта пакета библиотеки.

Путь к папке, содержащей в себе файлы исходных библиотек и моделей (где это применимо), будет автоматически добавлен на вкладку Search Paths диалогового окна Options for Integrated Library (Project » Project Options). Таким образом, модели (в частности, файлы .mdl и .ckt) будут доступны для поиска.
Пакет библиотеки не сохраняется автоматически. Задайте, где и под каким именем проект будет сохранен. По умолчанию, файл будет предложено сохранить в той же папке, где находятся извлеченные исходные файлы.
Обнаружили проблему в этом документе? Выделите область и нажмите Ctrl+Enter, чтобы оповестить нас.

Связаться с нами

Связаться с нашими Представительствами напрямую

We're sorry to hear the article wasn't helpful to you.
Could you take a moment to tell us why?
Вы сообщаете о проблеме, связанной со следующим выделенным текстом
и/или изображением в активном документе:
Бесплатная пробная версия Altium Concord Pro

Заполните форму ниже, чтобы получить бесплатную пробную версию Altium Concord Pro