Altium Designer Documentation

Представление платы_AD

Created: 28.05.2021 | Updated: 28.05.2021

Работа в режимах 2D и 3D

Традиционно разметка плат осуществлялась в двумерном пространстве проектирования, где для представления различных слоев платы используются различные цвета. Однако, физическая плата является трехмерным объектом, что требует сопоставления множества слоев и 2D-отображения платы с ее трехмерным представлением в сознании конструктора.

Существенные улучшения 3D-видеокарт и поддержка программных технологий позволили Altium разработать решение этой проблемы. Этим решением стал по-настоящему трехмерная среда редактирования плат. Возможности 3D в Altium Designer выходят за рамки простой визуализации и делают доступным следующее:

  • Проведение 3D-проверок зазоров. Компоненты могут быть размещены друг относительно друга и относительно корпуса так, как это необходимо.
  • Визуальное определение положения соединителей и прочих компонентов, требующих доступа для обслуживания.
  • Производственные процессы и порядок сборки могут быть определены лучше при учете механических ограничений.
  • Можно сформировать более подробные инструкции с помощью намного более реалистичных изображений.
  • Можно провести эксперименты с паяльными масками различных цветов для создания более эстетичного изделия, которое будет хорошо сочетаться с корпусом и окружением.

2D- и 3D-представление одного и того же участка платы.
2D- и 3D-представление одного и того же участка платы.

Режимы отображения Altium Designer

Altium Designer поддерживает отображение и редактирование платы в 2D и в 3D. Это называется режимами отображения. Выберите нужный режим в меню View или используйте клавиши 1, 2 и 3.

Есть три режима отображения, каждый с определенными функциями.

  • Board Planning Mode (режим планирования платы, клавиша 1) – используйте его определения формы платы и для размещения и настройки линий разделения и линий сгиба гибко-жесткой платы. Линии разделения используются для разделения платы на регионы, где каждому региону может быть назначен отдельный стек слоев. Чтобы узнать больше о регионах платы и линиях разделения и сгиба, перейдите на страницу Определение стека слоев.
  • 2D Layout Mode (режим 2D-разметки, клавиша 2) – традиционное 2D-представление платы со множеством слоев. Altium Designer включает в себя набор функциональных возможностей, которые позволяют управлять представлением платы – так называемая система Board Insight (рассмотрена подробнее далее).
  • 3D Layout Mode (режим 3D-разметки, клавиша 3) – настоящая трехмерная конструкция. Используйте 3D-режим отображения в сочетании с 3D-мышью, чтобы просматривать 3D-плату с компонентами и управлять ее видом так, будто вы держите ее в своей руке.

    Для режима 3D Layout Mode необходима графическая карта с поддержкой DirectX 9 или более новой версии и Shader Model 3 или более новой версии.

Одна и та же плата, показанная в режимах планирования платы, 2D-разметки и 3D-разметки. Одна и та же плата, показанная в режимах планирования платы, 2D-разметки и 3D-разметки.

Режим одного слоя

Режим 2D-отображения одного слоя

В Board Insight интегрированы функциональные возможности режима одного слоя, которые настраиваются на странице PCB Editor - Board Insight Display диалогового окна Preferences. Режим одного слоя отображает содержимое текущего слоя и скрывает или затеняет содержимое остальных слоев. Помимо скрытия объектов на всех остальных слоях для отображения содержимого только текущего слоя, у режима одного слоя есть режим отображения в оттенках серого и режим монохромного отображения. Отображение остальных слоев в оттенках серого или в монохромном режиме позволит сохранить представление о расположении остальных объектов, при этом не отвлекая вас от нужного слоя. Для переключения между полным отображением и включенными режимами одного слоя нажимайте сочетание клавиш Shift+S. При каждом нажатии Shift+S система переходит к следующему доступному режиму, в конечном итоге возвращаясь режиму полного отображения. Включение режимов одного слоя осуществляется на странице PCB Editor - Board Insight Display диалогового окна Preferences. Отключите режимы, которые вы не хотите использовать при нажатии Shift+S. Эти настройки будут применены ко всем проектам в текущей установке Altium Designer.

Доступные режимы одного слоя:

  • Hide Other Layers – все остальные слои скрыты; отображается содержимое только активного (текущего) слоя.
  • Gray Scale Other Layers – все остальные слои отображаются в оттенках серого, взятыми из их текущих цветов; активный слой показан в своем стандартном цвете.
  • Monochrome Other Layers – все остальные слои отображаются в одном оттенке серого; активный слой показан в своем стандартном цвете.

На изображениях ниже показано обычное отображение множества слоев и три режима отображения одного слоя.

Выбранный в данный момент режим одного слоя отображен в разделе General Settings вкладки View Options панели View Configuration.

Режим 3D-отображения одного слоя

Режим одного слоя также доступен при отображении платы в режиме 3D Layout Mode. Используйте его для для таких задач, как проверка качества определенного слоя или качества слоя питания. В режиме одного слоя используйте сочетание Ctrl + Shift + Вращение колеса мыши для переключения между слоями.

Работа с системой Board Insight

Board Insight – это настраиваемая система функциональных возможностей, которая позволяет полностью управлять отображением и работой конструкции платы. В сложных многослойных платах проектая область может быть визуально загроможденной и сложной для восприятия. Система Board Insight в Altium Designer упрощает просмотр и понимание объектов в конструкции. Она состоит из набора интегрированных функциональных возможностей, разработанных для удовлетворения ваших требований в управлении видом.

С Board Insight интегрированы расширенные функциональные возможности отображения одного слоя. В режиме одного слоя вы можете ясно увидеть, что находится на данном слое, но у вас также есть представление, что находится на остальных слоях.

Для стороннего наблюдателя конструкция печатной платы выглядит совершенно непонятно и представляет собой массу линий, кругов, дуг и строк разного цвета, наложенных друг на друга. Даже с хорошо натренированным глазом может быть трудно разобраться в огромном количестве деталей конструкции. Altium Designer включает в себя ряд функциональных возможностей, которые помогают находить и определять различные объекты и управлять их отображением. В совокупности эти функции называются системой Board Insight.

Всплывающий режим Board Insight

Опции Board Insight доступны по нажатию клавиши F2 в проектном пространстве. Будет открыто всплывающее меню Board Insight (также доступно при выборе View » Board Insight). Выберите нужную команду в этом меню. Сочетания клавиш, которые вы можете использовать в проектном пространстве без доступа к меню, приведены справа.

Всплывающий режим Board Insight – это отличный инструмент для просмотра объектов под курсором. Нажмите Shift+X, чтобы отобразить подробную информацию обо всех компонентах и цепях, расположенных под курсором, а также об объектах, которые принадлежат им, таких как контактные площадки и трассы. Используйте Shift+V для отображения информации о нарушениях, которые находятся под курсором. Также во всплывающем окне отображается графика выбранного в данный момент объекта или нарушения. Вы можете просмотреть подробную информацию об объекте/нарушении, выделить его или приблизиться к нему, щелкнув ЛКМ по объекту/нарушению, чтобы открыть всплывающее меню, или использовать иконки справа. Доступные опции:

  • Properties или – открыть панель Properties для этого объекта или диалоговое окно Violation Details для нарушения.
  • Select или – выделить объект или нарушение в проектном пространстве.
  • Zoom или – приблизиться к объекту/нарушению.

Информационное окно Heads Up Display

Информационное окно Heads Up Display в режиме реального времени предоставляет обратную связь об объектах, которые в данный момент находятся под курсором в проектном пространстве редактора плат. Окно Heads Up Display доступно для настройки, и оно может отображать положение курсора, информацию о дельте (расстоянии от положения последнего щелчка ЛКМ), текущий слой и текущую сетку привязки. Помимо содержимого, так же можно настроить шрифт и цвета. Окно Heads Up Display можно разместить в любом месте экрана либо сделать так, чтобы оно следовало за курсором.

Если остановить перемещение курсора, окно Heads Up Display перейдет в режим Hover mode, в котором отображается дополнительная информация, такая как сводка, доступные сочетания клавиш, нарушения правил, информация о цепи, компоненте и примитиве.

Вы можете настроить информационное окно Heads Up Display на странице PCB Editor - Board Insight Modes диалогового окна Preferences.

В столбце Heads Up таблицы включите нужные опции, которые вы хотите отображать в Heads Up Display. Настройки шрифта Font для этих опций также можно настроить в таблице.

Для конфигурации Heads Up Display можно использовать следующие сочетания клавиш:

  • Shift+H – включает и отключает Heads Up Display.
  • Shift+G – переключает между фиксированным положением Heads Up Display на плате и перемещением вслед за курсором.
  • Shift+D – включает и отключает отображение координат дельты. Эти координаты отображают горизонтальное (dx) и вертикальное (dy) расстояние от исходных координат дельты. Используйте их в качестве индикатора относительного расстояния на плате.
  • Insert – сбрасывает исходные координаты дельты до текущих координат мыши. В Heads Up Display можно отобразить расстояние по горизонтали и вертикали, на которое мышь перемещается от исходной точки дельты. Эту настройку можно изменить на странице PCB Editor - Board Insight Modes диалогового окна Preferences.

Динамическая подсветка

Понимание сложных конструкций плат с плотной трассировкой и размещением компонентов и множеством сигнальных слоев может быть непростой задачей. Altium Designer включает в себя ряд функциональных возможностей по подсветке цепей, которые помогут при изучении трассировки.

Используйте раздел Live Highlighting страницы PCB Editor - Board Insight Display диалогового окна Preferences для настройки этой функциональной возможности.

Используйте Ctrl+ЛКМ, чтобы подсветить любую цепь на плате. Всё в конструкции, что не входит в эту цепь, будет затенено, что выделит трассировку на всех сигнальных слоях, как показано на изображении ниже. Чтобы подсветить множество цепей, удерживайте клавишу Shift при использовании Ctrl+ЛКМ для отдельных цепей. Используйте Ctrl+ЛКМ в свободном месте, чтобы восстановить отображение.

Подсветку цепей также можно использовать динамически, то есть подсвечивать цепь при перемещении курсора над ней. Этот метод использует подсветку контуром, что доступно для настройки и что не затрагивает отображение остальной части платы. На изображении ниже показана цепь, подсвеченная с помощью динамической подсветки.

На изображении ниже показана цепь, подсвеченная с помощью Ctrl+ЛКМ.

Всплывающее окно визуального выбора

Всплывающее окно визуального выбора упрощает выбор нужного объекта в проектной области со множеством объектов. В конструкции многослойной платы может быть большое количество плотно расположенных объектов друг над другом. Всплывающее окно визуального выбора упрощает выделение объектов. Чтобы отобразить всплывающее окно визуального выбора, дважды щелкните ЛКМ, когда под курсором находится множество объектов. При перемещении курсора по списку текущий объект будет отображен во всплывающем окне, что упрощает его идентификацию. Объекты во всплывающем окне визуального выбора сортируются по слоям.

Управление активным слоем

Редактор плат является средой работы со множеством слоев, где только один слой может быть активным в данный момент. Существует несколько способов изменить активный в данный момент слой. Обратите внимание, что выбор активного слоя применим только к 2D-режиму отображения.

  • Щелкните ЛКМ по вкладке слоя под проектной областью.
  • Используйте выпадающиее меню Active Layer в разделе Layers на вкладке Layers & Colors панели View Configuration.
  • Перемещайтесь по слоям с помощью сочетаний клавиш:

    • Ctrl + Shift + Вращение колеса мыши – следующий/предыдущий слой
    • + (на цифровом блоке клавиатуры) – следующий слой
    • - (на цифровом блоке клавиатуры) – предыдущий слой
    • * (на цифровом блоке клавиатуры) – следующий сигнальный слой

Имена цепей на трассах

Еще одной удобной функциональной возможностью, которая позволит работать более эффективно, является отображение имен цепей на трассах (настраивается в разделе Additional Options вкладки View Options панели View Configuration). Для использования этой функциональной возможности включите опцию Repeated Net Names on Tracks в разделе Additional Options. При работе с платой вы можете сразу понять, какой цепи принадлежит интересующая вас трассировка.

Отображение имен цепей на трассах упрощает Отображение имен цепей на трассах упрощает "чтение" трассировки.

Опции отображения информации о контактных площадках и переходных отверстиях

Вы можете управлять отображением информации о контактных площадках и переходных отверстиях с помощью раздела Pad and Via Display Options страницы PCB Editor - Board Insight Display диалогового окна Preferences. Вы можете настроить цвет, фон и шрифт информации о контактных площадках и переходных отверстиях. Строки автоматически отображаются в направлении, которое максимизирует область, доступную для их отображения. Опция Use Smart Display Color автоматически выбирает цвет шрифта, который хорошо отображается для простого чтения текста.

В зависимости от режима отображения (DirectX или GDI), будет отображаться не вся информация о контактных площадках и переходных отверстиях.

Опции отображения заблокированных объектов

Вы можете управлять тем, как заблокированные объекты отображаются в проектном пространстве, для их простой визуальной идентификации. Используйте элементы управления в разделе Show Locked Texture on Objects страницы PCB Editor - Board Insight Display диалогового окна Preferences.

Опции Show Locked Texture on Objects доступны только в режиме DirectX.

Пример включенной опции Only When Live Highlighting. Пример включенной опции Only When Live Highlighting.

3D Board Insight

Система 3D Board Insight включается в себя режимы проекции, при которых плата отображается в режиме перспективы (Perspective) или ортогональной проекции (Orthographic). Когда включено 3D-представление, используйте раздел Projection вкладки View Options панели View Configuration для выбора нужного режима.

Выберите Orthographic, чтобы видеть точное положение объектов и текста на плате без перекрытия их другими объектами. Выберите Perspective, чтобы видеть более реалистичное 3D-представление платы.

Прозрачность объектов и слоев платы

Раздел Object Visibility панели View Configuration можно использовать для настройки прозрачности объектов платы. Используйте ползунок Transparency, чтобы определить процент прозрачности, или введите нужное значение непосредственно в соответствующее поле.

Altium Designer также поддерживает определение прозрачности отдельно для каждого типа объектов и для каждого слоя, который может использоваться в проекте. Это предоставляет вам более широкий контроль над отображением объектов в проектном пространстве. Для настройки уровня прозрачности в соответствии со своими требованиями используйте диалоговое окно Object Visibility, которое открывается по нажатию кнопки Advanced внизу раздела Object Visibility вкладки View Options панели View Configuration.

Хотя настройки прозрачности могут быть заданы для любой конфигурации 2D-вида, Altium Designer включает в себя доступную по умолчанию конфигурацию 2D-представления под названием Altium Transparent 2D, где настроена прозрачность объектов. С точки зрения остальных аспектов, она идентична конфигурации Altium Standard 2D. Используйте выпадающий список Configuration в разделе General Settings вкладки View Options панели View Configuration, чтобы задать конфигурацию вида. Эти конфигурации можно найти в папке \Templates общих документов этой установки Altium Designer (C:\Users\Public\Documents\Altium\AD<Версия> по умолчанию).

Для конфигурации Altium Standard 2D (\Templates\Altium Standard 2D.config_2dsimple), каждому типу объектов задана прозрачность 0% по умолчанию на всех слоях (кроме объектов Room, которым по умолчанию задана прозрачность 60%).

Слои и объекты

В таблице диалогового окна Object Visibility строки представляют слои, а столбцы – типы объектов. Это позволяет не только задать уникальные настройки для определенного объекта на разных слоях, но также позволяет определить различные настройки видимости разных объектов на определенном слое.

По умолчанию будут показаны только слои в текущем стеке слоев платы. Чтобы показать все слои, поддерживаемые для плат в Altium Designer, отключите опцию Only show used layers.

Сами слои сгруппированы по своим функциональным типам:

  • Signal Layers (Сигнальные слои)
  • Internal Planes (Внутренние слои)
  • Other Layers (Прочие слои)
  • Silkscreen Layers (Слои шелкографии)
  • Mask Layers (Слои масок)
  • Mechanical Layers (Механические слои)

Для слоев, которые в данный момент не используются в конструкции, имена и значения прозрачности отображаются серым цветом. Вы всё ещё сможете настраивать прозрачность неиспользуемых слоев нужным образом.

Если вы хотите задать глобальную конфигурацию прозрачности, которая будет использоваться во всех платах, рекомендуется отключить опцию Only show used layers и задать настройки для всех слоев. Таким образом, при добавлении дополнительных слоев в определенную конструкцию платы настройки видимости будут уже определены и готовы к использованию.

Определение прозрачности

Чтобы задать значение прозрачности объекта на одном слое, выберите ячейку, где пересекаются нужный объект и слой и используйте ползунок Transparency for selected либо введите нужное значение.

Прозрачность задается в процентном значении с шагом 1%, где 0% соответствует полной видимости, 100% – полной прозрачности.

Используйте следующие элементы управления множественным выбором для выделения множества объектов и задайте общую прозрачность для выбранных объектов.

  • Ctrl+ЛКМ для выделения множества ячеек в одном столбце.
  • Shift+ЛКМ (или Shift+Стрелка) для выделения смежных ячеек во множестве столбцов и/или строк.
  • Перетаскивание с зажатой ЛКМ для выделения смежных ячеек в одной строке.

Чтобы быстро задать прозрачность для всех типов объектов на определенном слое, щелкните ЛКМ по названию слоя для выделения всей строки и задайте нужную прозрачность.

Чтобы быстро задать прозрачность для объектов на множестве смежных слоев, используйте элементы управления множественным выделением для выделения ячеек нужных слоев и задайте нужную прозрачность.

Чтобы быстро задать прозрачность для определенного типа объектов на всех слоях, щелкните ЛКМ по ячейке названия объекта для выделения всего столбца и задайте нужную прозрачность.

Прозрачность в действии

На изображении ниже показан пример настроек прозрачности. Как вы можете видеть, в конфигурации Altium Standard 2D полигоны на верхнем слое не позволяют больше ничего увидеть.

На изображении ниже показан результат некоторых настроек прозрачности для различных типов объектов на разных слоях в конфигурации вида Altium Transparent 2D. При использовании этой конфигурации, к полигонам применяется прозрачность 70%, что позволяет увидеть другие объекты за ними. Конечно же, настройки представления объектов можно изменить в соответствии со своими предпочтениями. Суть в том, что благодаря полностью настраиваемой прозрачности вы можете получить именно то представление, которое необходимо.

Чтобы получить действительное представление слоя маски без объектов слоя Multi-Layer, таких как контактные площадки и переходные отверстия, увеличьте прозрачность этих объектов или сделайте их полностью (100%) прозрачными. Это может оказаться очень полезным, если вы уменьшили размер вскрытий в маске.

Обнаружили проблему в этом документе? Выделите область и нажмите Ctrl+Enter, чтобы оповестить нас.

Связаться с нами

Связаться с нашими Представительствами напрямую

We're sorry to hear the article wasn't helpful to you.
Could you take a moment to tell us why?
200 characters remaining
Вы сообщаете о проблеме, связанной со следующим выделенным текстом
и/или изображением в активном документе: