Altium NEXUS Documentation

Altium 365 - Публикация проекта из Altium NEXUS

Главная страница: Глобальная публикация

В поддержку парадигмы глобальной публикации (Global Sharing) платформы Altium 365, Altium NEXUS поддерживает возможность публикации проектов другим пользователям, где бы они ни находились, непосредственно из системы. Это дополняет возможность публикации проектов из веб-интерфейса самой платформы Altium 365. Поддерживаются следующие уровни публикации из Altium NEXUS:

  • Публикация текущего проекта – динамический проект, находящийся в процессе разработки, который может быть опубликован:

    • Другим членам вашей команды Workspace – для редактирования и/или просмотра. Для публикации на этом уровне необходима как регистрация на AltiumLive, так и активная подписка на лицензии Altium NEXUS. Также необходимо подключение к своему Altium 365 Workspace. Приглашенный член команды может просматривать проект через Altium NEXUS либо через интерфейс платформы Altium 365. Редактирование осуществляется только через Altium NEXUS.
    • Людям вне команды вашего Workspace – для просмотра или редактирования, по email-приглашению. Для публикации на этом уровне необходима как регистрация на AltiumLive, так и активная подписка на лицензии Altium NEXUS. Также необходимо подключение к своему Altium 365 Workspace. Это позволяет приглашенным заинтересованным лицам просматривать/редактировать (в зависимости от настроек) динамический, находящийся в процессе разработки проект без получения доступа ко всем вашим проектным данным на сервере.

      Если предоставлен доступ только для просмотра, то приглашенные участники могут просматривать и комментировать проект из Altium NEXUS либо через интерфейс платформы Altium 365. При внесении в проект изменений пользователями с правами на редактирование и фиксации этих изменений они будут отображены у людей извне. Для просмотра опубликованного проекта через веб-интерфейс, откуда угодно, всё, что необходимо для получения доступа, это регистрация на AltiumLive.

      Если приглашенному участнику были предоставлены права на редактирование проекта, то он сможет открыть и редактировать его из Altium NEXUS, что отлично подходит для внешних подрядчиков.

  • Публикация слепка проекта – статичный слепок проекта в определенный момент времени. Может быть опубликован:

    • По ссылке – доступ кого угодно через веб-браузер. Для публикации на этом уровне не нужна ни регистрация на AltiumLive, ни активная подписка на лицензии Altium NEXUS. Получатели общей ссылки используют Altium 365 Viewer для просмотра проекта (но не его комментирования). Для просмотра не нужна регистрация на AltiumLive, ссылка доступна в течение 48 часов.
    • Определенным людям – доступ определенных людей по email-приглашению. Для публикации на этом уровне необходима регистрация на AltiumLive, но не активная подписка на лицензии Altium NEXUS. Получатели открывают слепок проекта в интерфейсе платформы Altium 365 через email-приглашение. Для просмотра нужна регистрация на AltiumLive, но слепок доступен постоянно. Также доступно комментирование проекта.
Если у получателя динамического проекта (или слепка проекта), который был опубликован ему, нет учетной записи AltiumLive, ему сначала будет необходимо зарегистрироваться – на странице Altium 365 Sign In будет представлена соответствующая ссылка.
Для получения более подробной информации о выгрузке слепка проекта из интерфейса платформы Altium 365 и его последующей публикации другим пользователям перейдите на страницу Публикация слепков проектов. Для получения более подробной информации о публикации динамического проекта за пределы команды Workspace при просмотре проекта в веб-браузере перейдите на страницу Публикация динамических проектов за пределы Workspace.

Вызов элементов управления публикацией

Элементы управления для публикации проекта из Altium NEXUS можно найти в диалоговом окне Share, которое может быть открыто следующими способами:

  • Для активного проекта – нажмите кнопку в верхней правой части окна приложения или выберите команду Project » Share из главного меню.
  • Для проекта в фокусе в панели Projects – щелкните ПКМ по записи проекта и выберите команду Share из контекстного меню.
Если активного проекта нет, т.е. не открыто никакого документа проекта, то кнопка сработает для проекта, который в данный момент находится в фокусе в панели Projects.

Вызов диалогового окна Share – центра управления публикацией проекта из Altium NEXUS.Вызов диалогового окна Share – центра управления публикацией проекта из Altium NEXUS.

Публикация динамического проекта

Если проект зарегистрирован в Altium 365 Workspace (доступен в нем), вы можете опубликовать его для других пользователей. Это могут быть другие члены вашей команды Workspace или люди вне команды. Для публикации таким образом нажмите по записи в левой части диалогового окна Share.

Администраторы команды Workspace всегда могут опубликовать проект другим для редактирования или просмотра. Участники команды Workspace, не являющиеся администраторами, или пользователи, которым был опубликован проект за пределы команды Workspace, могут опубликовать проект другим для редактирования или просмотра в зависимости от уровня доступа, который есть у них самих самого. Если у них есть права на редактирование, они могут опубликовать проект другим для редактирования или просмотра. Если у них есть только права на просмотр, они могут опубликовать проект другим только для просмотра и комментирования.

Доступ к элементам управления для публикации динамического проекта другим пользователям. Обратите внимание, что на изображении показан случай, когда проект уже доступен в подключенном Workspace.Доступ к элементам управления для публикации динамического проекта другим пользователям. Обратите внимание, что на изображении показан случай, когда проект уже доступен в подключенном Workspace.

Для публикации проекта необходимо следующее:

  • Вы должны войти в свою учетную запись Altium (с помощью учетных данных AltiumLive).
  • У вас должна быть активная (действующая) подписка Altium Subscription на лицензии Altium NEXUS.
  • Вы должны быть подключены к своему Altium 365 Workspace.
  • Проект должен быть зарегистрирован в Workspace (доступен в нем).

В диалоговом окне Share будут представлены указания для корректной подготовки выбранного проекта. Примеры таких указаний:

  • Если вы не вошли в свою учетную запись Altium, в диалоговом окне будет представлена ссылка для этого (которая открывает диалоговое окно Sign In) или для регистрации на AltiumLive, если у вас еще нет учетных данных. Вы будете подключены к Workspace (если он у вас есть) после входа в свою учетную запись, если этот Workspace задан по умолчанию.

  • Если вы вошли в свою учетную запись Altium и пытаетесь опубликовать открытый проект, который не зарегистрирован в Workspace (т.е. который является неуправляемым локальным проектом или находится под управлением системы контроля версий), но у вас нет доступного Workspace, в диалоговом окне будет представлен элемент управления для активации Workspace для вашей компании.

    Для отдельной организации может быть активирован только один Altium 365 Workspace.

  • Если вы вошли в учетную запись Altium и пытаетесь опубликовать открытый проект, который зарегистрирован в Workspace, но вы не подключены в данный момент к этому Workspace, в диалоговом окне будет представлен элемент управления для подключения к этому Workspace или для переключения на него, если в подключены к другому Workspace.

  • Если вы вошли в свою учетную запись Altium и пытаетесь опубликовать открытый проект, который не зарегистрирован в Workspace (т.е. который является неуправляемым локальным проектом или находится под управлением системы контроля версий), но вы не подключены в данный момент к Workspace, в диалоговом окне будет представлен список доступных вам Workspace, чтобы вы могли выбрать, в каком Workspace вы хотите зарегистрировать проект.

    Если вы уже подключены к какому-либо Workspace, то именно он будет использован в качестве целевого Workspace для регистрации проекта. Обратите внимание, что проект станет доступен в целевом Workspace при публикации проекта указанным людям.

Публикация новым людям

Когда подготовка завершена, проект выбран и целевой Workspace подключен, вы можете указать человека (или людей), которым следует опубликовать проект. Чтобы проверить, у кого уже есть доступ к проекту, нажмите по элементу управления справа от поля Shared with. Будет открыта область со списком тех, кому опубликован проект, и где будет отображено, есть ли у этих пользователей права на редактирование (Can Edit) или только на просмотр и комментирование проекта (Can View).

Проверьте, кому в данный момент опубликован проект, щелкнув ЛКМ по элементу управления справа от поля Share with. Наведите курсор мыши на изображение, чтобы увидеть результат.Проверьте, кому в данный момент опубликован проект, щелкнув ЛКМ по элементу управления справа от поля Share with. Наведите курсор мыши на изображение, чтобы увидеть результат.

Вы можете опубликовать проект кому угодно – другим пользователям AltiumLive вашей организации, пользователям AltiumLive других организаций и пользователям без учетной записи AltiumLive (которым сначала будет необходимо зарегистрироваться на AltiumLive). Чтобы добавить запись, начните вводить нужное имя/email/роль в этом поле, и будет открыт динамический список соответствующих пользователей/ролей. Здесь будут представлены только пользователи в вашей команде Workspace или в вашей организации, а также существующие в Workspace роли. Можно выбрать множество пользователей/ролей. Чтобы удалить введенного пользователя/роль, нажмите у соответствующей записи.

Чтобы опубликовать проект человеку за пределами вашей организации, независимо от того, есть у него учетная запись AltiumLive или нет, вам необходимо ввести его полный email-адрес и нажать Enter.

Задайте права доступа для добавленных людей/ролей из соответствующего выпадающего меню, выбрав Can View (Может просматривать, ) или Can Edit (Может редактировать, ), где вторая опция также включает в себя возможности просмотра. Изначально настройка будет применена ко всем записям (людям/ролям), добавленным в поле. Используйте поле опционального примечания, чтобы добавить информацию, относящуюся к публикации этого проекта.

Администраторы команды Workspace всегда могут опубликовать проект другим для редактирования или просмотра. Участники команды Workspace, не являющиеся администраторами, или пользователи, которым был опубликован проект за пределы команды Workspace, могут опубликовать проект другим для редактирования или просмотра в зависимости от уровня доступа, который есть у них самих самого. Если у них есть права на редактирование, они могут опубликовать проект другим для редактирования или просмотра. Если у них есть только права на просмотр, они могут опубликовать проект другим только для просмотра и комментирования.

Когда получатели определены и права доступа заданы, нажмите кнопку , чтобы подтвердить публикацию проекта.

Если вы попытаетесь опубликовать проект человеку вне команды, будет открыто диалоговое окно Sharing Outside of the Workspace, предлагающее следующие опции:

  • Share for Viewing (Опубликовать для просмотра) – выберите эту опцию, чтобы продолжить публикацию проекта, но с правами только на просмотр.
  • Share for Editing (Опубликовать для редактирования) – выберите эту опцию, чтобы продолжить публикацию проекта, с правами на редактирование.

Вы можете опубликовать проект кому угодно за пределами своей команды, для редактирования или просмотра.Вы можете опубликовать проект кому угодно за пределами своей команды, для редактирования или просмотра.

Публикация пользователю за пределами команды Workspace с правами на редактирование отлично подходит для подрядчиков, если вы хотите, чтобы они активно работали над проектом, но при этом оставались вне команды.

Если вы публикуете неуправляемый локальный проект (не под управлением внешней системы контроля версий), проект станет доступен в подключенном в данный момент Workspace при публикации этого проекта указанным людям. Что именно произойдет, зависит от того, осуществляется ли публикация для просмотра или для редактирования:

  • При публикации только на просмотр проект станет доступен с использованием простой синхронизации (Simple Sync). В этом режиме проект может быть изменен только одним человеком – владельцем этого проекта. Простая синхронизация полезна, если вы не хотите, чтобы проект мог редактировать кто-то другой, но при этом хотите воспользоваться преимуществами парадигмы глобальной публикации платформы Altium 365 и иметь возможность публикации этого проекта другим людям для просмотра и комментирования. Для получения более подробной информации перейдите в раздел Преобразование существующего проекта для онлайн-доступа.
  • При публикации на редактирование проект необходимо добавить в проектный Git-репозиторий Versioned Storage Workspace. В этом режиме проект можно опубликовать на редактирование множеству людей, а также доступно использование поддержки глобальной публикации платформы Altium 365 для общего просмотра и комментирования. Будет открыто диалоговое окно, оповещающее вас об этом и предлагающее соответствующую опцию.

При публикации пользователю неуправляемого локального проекта (не под управлением внешней системы контроля версий) на редактирование этот проект необходимо передать в контроль версий, добавив его в проектный Git-репозиторий Versioned Storage Workspace.При публикации пользователю неуправляемого локального проекта (не под управлением внешней системы контроля версий) на редактирование этот проект необходимо передать в контроль версий, добавив его в проектный Git-репозиторий Versioned Storage Workspace.

Если неуправляемый проект уже находится под управлением системы контроля версий (во внешнем проектном репозитории), он останется под управлением внешнего проектного репозитория системы контроля версий и не будет добавлен во встроенный в Workspace проектный репозиторий (Git). Будет применена простая синхронизация, но множество сотрудников смогут продолжить работу над проектом, поскольку он находится под управлением системы контроля версий. В некоторых случаях, функциональные возможности, доступные из платформы Altium 365 (или, точнее, Altium 365 Workspace), можно использовать только тогда, когда проект полностью управляется и хранится под управлением собственной системы контроля версий Workspace (в его репозитории Git Versioned Storage). Вы можете создать слепок проекта, разорвать его связь с внешней системой контроля версий и с Workspace (если он уже доступен там) и затем снова сделать его доступным в Workspace, но под управлением системы контроля версий Workspace, т.е. как бы начать с нуля. Для получения более подробной информации перейдите в раздел Переход от внешней системы контроля версий к собственной системе контроля версий Workspace.

Что произойдет дальше, зависит от типа приглашаемого пользователя:

  • Пользователь, который уже является членом команды Workspace, будет добавлен непосредственно в список доступа этого проекта. Он получит email-уведомление о том, что ему был опубликован проект (и какие права доступа к этому проекту у него есть). Он может открыть проект в Altium NEXUS или получить доступ к нему через интерфейс платформы Altium 365 (со страницы Projects).
  • Существующая в Workspace роль будет добавлена непосредственно в список доступа этого проекта. Все участники этой роли получат email-уведомления о том, что им был опубликован проект (и какие права доступа к этому проекту у них есть). Они могут открыть проект в Altium NEXUS или получить доступ к нему через интерфейс платформы Altium 365 (со страницы Projects).
  • Человеку вне команды Workspace будет опубликован проект, и он получит email-уведомление о том, что ему был опубликован проект. Он может открыть проект в Altium NEXUS или получить доступ к нему через интерфейс платформы Altium 365 (со страницы Shared with Me). Получить доступ к этому проекту в Altium 365 можно прямо из email. После нажатия кнопки в email пользователь перейдет на страницу Altium 365 Sign In (если он еще не вошел в платформу или в свою учетную запись AltiumLive). После входа пользователь перейдет в средство просмотра с загруженным опубликованным проектом.

    Если у человека нет учетной записи AltiumLive, ему сначала будет необходимо зарегистрироваться – на странице Altium 365 Sign In будет представлена соответствующая ссылка.

    Доступ к динамическому проекту из email-приглашения, полученного пользователем, которому проект был опубликован.Доступ к динамическому проекту из email-приглашения, полученного пользователем, которому проект был опубликован.

Изменение прав доступа для существующих людей

В любой момент администратор (или член команды Workspace с правами на редактирование) может изменить существующие права доступа к проекту. Чтобы открыть список людей и ролей, которым на текущий момент опубликован проект, нажмите в левой части диалогового окна Share, затем разверните поле Shared with справа.

Открытие списка людей и ролей, которым на текущий момент опубликован проект.Открытие списка людей и ролей, которым на текущий момент опубликован проект.

Что следует иметь в виду:

  • В точки зрения прав доступа, у человека/роли есть полные права на редактирование проекта, когда выбрана опция Can Edit (). В противном случае, у человека/роли будет доступ только на просмотр ().
  • У владельца (Owner) и роли администраторов (Administrators) всегда есть полные права на редактирование (Can Edit).
  • Кроме как для владельца и роли администраторов, можно задать права на чтение (Can View) или редактирование (Can Edit) для отдельных добавленных людей/ролей либо совсем удалить их права доступа. Щелкните ЛКМ по текущему состоянию прав доступа, чтобы открыть соответствующие элементы управления.

  • Проект может быть явно опубликован определенному пользователю и/или роли или всем членам команды Workspace. Для публикации всей команде задайте требуемый уровень доступа для записи Everyone in the team. Чтобы не публиковать проект всей команде, задайте для этой записи None.

Внесите необходимые изменения в права доступа. Каждая измененная запись выделяется в списке более светлым фоном.

Пример изменений прав доступа для двух существующих пользователей, которым опубликован проект.Пример изменений прав доступа для двух существующих пользователей, которым опубликован проект.

Чтобы применить изменения, нажмите кнопку . Изменения будут применены, и в диалоговом окне будет отображено соответствующее подтверждение. Чтобы увидеть обновленный список доступа, нажмите ссылку Who has access.

После сохранения изменений прав доступа вы можете увидеть результат непосредственно в диалоговом окне Share.После сохранения изменений прав доступа вы можете увидеть результат непосредственно в диалоговом окне Share.

Помните, что если вы изменяете права доступа для кого-либо за пределами команды Workspace на Can Edit, вы будете оповещены об этом через диалоговое окно Sharing Outside of the Workspace, для подтверждения, предоставить ли им права только для просмотра или права на редактирование.

Доступ к опубликованному динамическому проекту в любой момент

Доступ к проекту зависит от того, входите ли в команду Workspace или проект был опубликован за пределы команды Workspace.

Участник команды Workspace

Участник команды Workspace может получить доступ к опубликованному проекту из Altium NEXUS либо из интерфейса платформы Altium 365 (со страницы Projects интерфейса Workspace). Обратите внимание, что редактирование проекта (при наличии прав на редактирование) возможно только из Altium NEXUS.

В Altium NEXUS доступ к проекту осуществляется с помощью команды File » Open Project. Будет открыто диалоговое окно Open Project, где вы можете выбрать, какой управляемый проект следует открыть из Workspace (когда Workspace подключен, он будет отображен в области Locations с иконкой и названием этого Workspace). Будут отображены только опубликованные для вас проекты (те, к которым у вас есть права доступа).

Открытый проект будет отображен под строкой Workspace в панели Projects.

Выберите, какой управляемый проект следует открыть в Altium NEXUS из тех, которые доступны вам.Выберите, какой управляемый проект следует открыть в Altium NEXUS из тех, которые доступны вам.

Вы можете открыть проект по пути извлечения по умолчанию либо использовать выпадающее меню для указания пользовательского пути. Путь извлечения по умолчанию берется из поля Document Path на странице System - Default Locations диалогового окна Preferences.
При просмотре проекта через панель Explorer в Altium NEXUS, которая по умолчанию отображается в режиме Project View, а не Classic View, нажмите кнопку в верхней правой части панели, чтобы открыть проект в Altium NEXUS (добавить его в панель Projects).

Приглашенный участник за пределами команды Workspace

Пользователь вне команды Workspace, которому был опубликован проект, может получить доступ к этому проекту из Altium NEXUS либо из интерфейса платформы Altium 365 (со страницы Shared with Me интерфейса Workspace). Обратите внимание, что редактирование проекта (при наличии прав на редактирование) возможно только из Altium NEXUS.

На странице Shared with Me интерфейса, динамический проект обозначается иконкой в своей плитке. Чтобы открыть нужный проект во встроенном средстве просмотра, выберите его, нажмите кнопку в его плитке и выберите команду Open из открывшегося меню. Либо дважды щелкните ЛКМ по плитке.

В Altium NEXUS доступ к проекту осуществляется с помощью команды File » Open Project. Будет открыто диалоговое окно Open Project, где вы можете выбрать, какой управляемый проект следует открыть, из области Shared With Me.

Открытый проект будет отображен под строкой Shared with me в панели Projects. От предоставленных вам прав доступа к проекту зависит, что вы можете с ним сделать. Если вам были предоставлены права на редактирование, вы сможете редактировать проект как обычно. Если у вас есть только права на просмотр, вы сможете комментировать разрабатываемый проект.

Выберите, какой управляемый проект следует открыть в Altium NEXUS из тех, которые опубликованы вам как внешнему подрядчику. Обратите внимание, что доступ к таким проектам осуществляется без доступа к Workspace.Выберите, какой управляемый проект следует открыть в Altium NEXUS из тех, которые опубликованы вам как внешнему подрядчику. Обратите внимание, что доступ к таким проектам осуществляется без доступа к Workspace.

Вы можете открыть проект по пути извлечения по умолчанию либо использовать выпадающее меню для указания пользовательского пути. Путь извлечения по умолчанию берется из поля Document Path на странице System - Default Locations диалогового окна Preferences.

Публикация слепка проекта

Создание слепка проекта позволяет вам быстро опубликовать этот проект в состоянии на определенный момент времени для расширенной совместной работы над ним с другими пользователями через веб. Это может быть полезно на быстрого контроля проекта, публикации проекта на определенном этапе разработки или даже для проведения предметного обсуждения. Чтобы опубликовать проект таким образом, щелкните ЛКМ по записи в левой части диалогового окна Share.

Доступ к элементам управления для публикации слепка проекта.Доступ к элементам управления для публикации слепка проекта.

Любой пользователь, который просматривает в данный момент проект в Altium NEXUS, может опубликовать слепок этого проекта.

Публикация по ссылке

По умолчанию в диалоговом окне задано Share By Link, что означает, что любой, у кого есть ссылка, сможет открыть слепок проекта для его просмотра через веб-браузер в течение 48 часов. Комментирование проекта для этого уровня публикации не доступно.

Этот уровень публикации не требует входа в учетную запись Altium через Altium NEXUS.

Нажмите кнопку , чтобы сформировать ссылку на слепок проекта. Сам проект будет в фоновом режиме упакован в Zip-архив с помощью средства Project Packager Altium NEXUS. Когда ссылка готова, нажмите кнопку , чтобы скопировать ее и передать ее нужным людям.

Публикация временной ссылки, которую можно передать кому угодно, где угодно.Публикация временной ссылки, которую можно передать кому угодно, где угодно.

При использовании этой ссылки получатель перейдет в экземпляр средства просмотра Altium 365 Viewer на сайте altium.com с обработанным и загруженным проектом.

С помощью общей ссылки получатель может просматривать слепок проекта с помощью Altium 365 Viewer на altium.com. Здесь показана схема; наведите курсор мыши на изображение, чтобы увидеть плату.С помощью общей ссылки получатель может просматривать слепок проекта с помощью Altium 365 Viewer на altium.com. Здесь показана схема; наведите курсор мыши на изображение, чтобы увидеть плату.

При выгрузке проекта (в Zip-архиве) в Altium 365 Viewer он удаляется сразу после обработки. Поэтому просмотр проекта является временным – он доступен только в рамках сеанса браузера (и не будет доступен после того, как вы закроете вкладку браузера). Либо снова используйте ссылку в течение 48 часов.

Публикация определенным людям

Нажмите Share with specific people, чтобы переключиться в режим публикации слепка проекта, который позволит осуществить публикацию определенному человеку (или людям) через email-приглашение. Получатели смогут просматривать слепок проекта через веб-интерфейс платформы Altium 365. Такой слепок проекта доступен в платформе на постоянной основе, и для этого уровня публикации доступно комментирование проекта.

Для этого уровня публикации необходим вход в учетную запись Altium через Altium NEXUS (с помощью учетных данных AltiumLive). Если вы не вошли в свою учетную запись Altium, в диалоговом окне будет представлена ссылка для этого (которая открывает диалоговое окно Sign In) или для регистрации на AltiumLive, если у вас еще нет учетных данных.

Переключите режим для публикации слепка проекта определенным людям на постоянной основе.Переключите режим для публикации слепка проекта определенным людям на постоянной основе.

Введите полный email-адрес человека, которому вы хотите опубликовать слепок, и нажмите Enter. При необходимости может быть указано множество людей. Вы также можете добавить опциональное примечание о публикуемом слепке.

Пример публикации слепка проекта определенному человеку по email.Пример публикации слепка проекта определенному человеку по email.

После этого нажмите кнопку . Сам проект будет упакован в Zip-архив с помощью средства Project Packager Altium NEXUS, после чего он будет выгружен в платформу Altium 365. По завершении выгрузки будет представлено соответствующее подтверждение.

Опубликованный слепок упаковывается и выгружается в платформу Altium 365, где он доступен на постоянной основе.Опубликованный слепок упаковывается и выгружается в платформу Altium 365, где он доступен на постоянной основе.

Человек, которому был опубликован выгруженный слепок проекта, получит email-приглашение для доступа к этому слепку через Altium 365. После нажатия кнопки в email он перейдет на страницу Altium 365 Sign In (если он еще не вошел в платформу или в свою учетную запись AltiumLive). После входа пользователь перейдет в средство просмотра с загруженным опубликованным слепком проекта.

Если у пользователя нет учетной записи AltiumLive, ему сначала будет необходимо зарегистрироваться – на странице Altium 365 Sign In будет представлена соответствующая ссылка.

Доступ к слепку проекта из email-приглашения, полученного пользователем, которому слепок был опубликован.Доступ к слепку проекта из email-приглашения, полученного пользователем, которому слепок был опубликован.

Помимо использования ссылки в email-приглашении, пользователь, которому был опубликован слепок проекта, может открыть этот слепок со страницы Shared with Me интерфейса платформы Altium 365. Слепок проекта отмечен иконкой в своей плитке. Чтобы открыть интегрированное средство просмотра, выберите интересующий слепок проекта, нажмите кнопку в его плитке и выберите команду Open в открывшемся меню. Либо дважды щелкните ЛКМ непосредственно по плитке.

Доступ к слепку проекта со страницы Shared With Me интерфейса платформы Altium 365.Доступ к слепку проекта со страницы Shared With Me интерфейса платформы Altium 365.

Пользователь, изначально опубликовавший слепок проекта, который был выгружен в платформу Altium 365, также сможет получить доступ к этому слепку со страницы Uploads интерфейса.

Отключение публикации

Чтобы полностью отключить публикацию, снимите флажок Altium Cloud на странице System - Network Activity диалогового окна Preferences. Если вы попытаетесь опубликовать проект через диалоговое окно Share, будь то динамический проект или его слепок, будет открыто диалоговое окно с оповещением, что эта опция отключена.

Отключение от Altium Cloud не позволит публиковать проекты.Отключение от Altium Cloud не позволит публиковать проекты.

Обнаружили проблему в этом документе? Выделите область и нажмите Ctrl+Enter, чтобы оповестить нас.

Связаться с нами

Связаться с нашими Представительствами напрямую

We're sorry to hear the article wasn't helpful to you.
Could you take a moment to tell us why?
200 characters remaining
Вы сообщаете о проблеме, связанной со следующим выделенным текстом
и/или изображением в активном документе: