Altium NEXUS Documentation

Управляемые проекты в Altium 365 Workspace

Created: 25.05.2020 | Updated: 08.06.2021

Главная страница: Altium 365 Workspace

Altium NEXUS в сочетании с Altium 365 Workspace обеспечивает поддержку управляемых проектов (Managed Projects). Для управляемых проектов определяется этап жизненного цикла, что упрощает создание и текущий рабочий процесс для проектов в системе контроля версий. Централизованное хранение под управлением Workspace также позволяет этой функциональной возможности быть основой других служб для совместной работы.

Ключевые преимущества использования полностью управляемых проектов:

  • Упрощенное хранение. Нет необходимости принимать решения о месте хранения. Поддерживаются резервное копирование и прочие базовые службы.
  • Основа других служб для совместной работы.
  • Контроль версий.
  • Специальная система комментирования.
  • Уведомления и состояния. Состояние документа, в том числе локальные изменения, видимы всей проектной группе.
  • Одновременная работа над проектом платы без необходимости в сложной настройке.
  • Возможность опубликовать проект множеству пользователей на редактирование или только на просмотр и комментирование.
  • Полнофункциональное использование истории проекта, включающей в себя события фиксаций в системе контроля версий.

Технически управляемый проект является сочетанием мета-информации, которая хранится в Workspace, вместе с тесной интеграцией со встроенным в Workspace контролем версий на основе GIT. Типовой рабочий процесс:

  1. Пользователь создает новый управляемый проект: через диалоговое окно Create Project в Altium NEXUS, из веб-интерфейса Workspace или путем преобразования существующего неуправляемого проекта в доступный в Workspace (из Altium NEXUS). В процессе создания проекта пользователь определяет название и описание проекта.
  2. В веб-интерфейсе Workspace или непосредственно в Altium NEXUS определяются права доступа к проекту.
  3. Все сотрудники выбирают проект на открытие (из Altium NEXUS или из веб-интерфейса Concord Pro), после чего он автоматически извлекается.
Преимуществом управляемых проектов является то, что они по умолчанию находятся под управлением контроля версий, и совместную работу над ними можно осуществлять, не беспокоясь об общих дисках, серверах, соглашениях и т.д. Контроль версий осуществляется встроенной в Workspace службой GIT. Все управляемые проекты хранятся в Workspace в едином проектном репозитории под названием Versioned Storage (репозиторий Git). Если проект находится под управлением внешней системы контроля версий, вы можете мигрировать его, чтобы он стал полностью управляемым проектом в Workspace, который содержит проектные файлы в собственном Git-репозитории сервера (по сути, этот процесс переключает проект на использование собственной системы контроля версий Workspace). Для получения более подробной информации перейдите на страницу Переход от внешней системы контроля версий к собственной системе контроля версий Workspace.
Ваши проекты также могут быть неуправляемыми (т.е. быть обычными проектами или проектами под управлением VCS), но вы можете создать синхронизированную копию проекта, доступную онлайн, отправив ее в облачный Workspace. Эта простая синхронизация (Simple Sync) позволит вам воспользоваться преимуществами совместной работы, предлагаемыми Altium 365.

В этом документе рассмотрена работа с управляемыми проектами через веб-интерфейс Workspace. Для получения информации о работе с управляемыми проектами из системы проектирования перейдите на страницу Управление проектами из Altium NEXUS.

Создание нового управляемого проекта

Управляемый проект может быть создан непосредственно со страницы Projects веб-интерфейса Workspace. На этой странице представлен список всех проектов, которые доступны в Workspace и которые опубликованы подключенному пользователю. Чтобы создать новый проект, нажмите кнопку над списком проектов и выберите Create Project – будет открыто окно Create Project.

Создание нового управляемого проекта через веб-интерфейс Workspace.Создание нового управляемого проекта через веб-интерфейс Workspace.

Окно Create Project будет изначально представлено в упрощенном виде со следующими полями:

  • Project Name – введите требуемое название проекта.

    Название проекта должно начинаться с A-Z, a-z или 0-9, и оно может содержать эти символы. Допустимы подчеркивания, дефисы и пробелы, но пробелы могут быть только в середине имени (пробелы в начале и в конце будут игнорироваться). Вы не можете использовать следующие слова: AUX, COM1-COM9, LPT1-LPT9, CON, NUL и PRN. Кроме того, название не может содержать в себе следующие символы: \ . / ? % * : | " < >.
  • Template – выберите доступный шаблон проекта. В соответствующем выпадающем списке будут представлены все управляемые шаблоны проектов, которые существуют в Workspace (в формате <Комментарий> (<ItemID>)). Выбор шаблона определит тип проекта. Если вы не хотите, чтобы новый проект был основан на каком-либо существующем шаблоне проекта, укажите только тип создаваемого проекта (выберите доступную в списке запись PCB Project или Multiboard).
  • Description – введите опциональное описание проекта.

Чтобы открыть дополнительные элементы управления, нажмите кнопку . Будет представлено следующее поле:

  • Parent Folder – используйте это поле, чтобы указать, где в структуре папок Workspace будет создана проектная папка. По умолчанию это будет Projects\<НазваниеПроекта>. Путь по умолчанию для новых проектов указывается на странице Admin - Settings - Projects в веб-интерфейсе Workspace. Нажмите Change справа от поля, чтобы открыть структуру серверных папок Workspace, где вы можете выбрать другую папку для хранения проекта. Если необходимо, вы можете систематизировать проекты в иерархии подпапок. Для получения более подробной информации перейдите в раздел Создание иерархии проектных папок.

После определения нового проекта необходимым образом нажмите . Вы вернетесь в общий список проектов, где увидите запись нового проекта.

Новый проект, отображаемый на странице Projects веб-интерфейса Workspace.Новый проект, отображаемый на странице Projects веб-интерфейса Workspace.

Изначально проект будет опубликован с правами на редактирование проектировщику, который создал его (владельцу), администраторам Workspace и всем участникам команды Workspace. Для получения более подробной информации о настройке прав доступа к проекту перейдите в раздел Публикация проекта.

Выгрузка существующего неуправляемого проекта

Вы также можете выгрузить существующий проект в Workspace. Для этого:

  1. Нажмите кнопку на списком проектов и выберите Upload Project. В диалоговом окне Select Folder to Upload найдите и выберите папку, содержащую проект, который нужно выгрузить и нажмите Upload.

  2. Будет открыто всплывающее окно с информацией о количестве файлов, участвующих в выгрузке (содержащихся в выбранной папке) и запрашивающее подтверждения на продолжение. Нажмите .
  3. Будет открыто окно Upload Project. По умолчанию названием проекта Project Name будет то, которое задано существующему проекту – измените его, если нужно, и добавьте подходящее описание. В качестве родительской папки Parent Folder будет задана та, которая была активна при запуске процесса выгрузки. Нажмите Change справа от поля, чтобы открыть структуру серверных папок Workspace, где вы можете выбрать другую папку для хранения проекта. Если необходимо, вы можете систематизировать проекты в иерархии подпапок. Для получения более подробной информации перейдите в раздел Создание иерархии проектных папок. Когда настройки заданы нужным образом, нажмите кнопку .

  4. Начнется выгрузка, после которой проект будет отображен в обзорном списке проектов.

Все существующие ссылки на контроль версий в локальном проекте будут проигнорированы, и выгруженный проект станет полностью управляемым серверным проектом под управлением контроля версий. Исходный локальный проект не меняется каким-либо образом.

Создание иерархии проектных папок

Workspace также позволяет создавать проектные папки и управлять ими в структуре сервера. Затем проекты могут быть созданы в любой папке этой иерархии или перемещены в любую из них.

Чтобы создать новую папку в папке верхнего уровня Project (по умолчанию), нажмите кнопку над списком проектов и выберите Create Folder. В открывшемся окне Create Folder укажите название новой папки, ее родительскую папку и опциональное описание. Новая папка всегда создается в выбранной в данный момент папке, которая становится родительской папкой.

Если уже есть заданная иерархия проектных папок, нажмите Change справа от поля Parent Folder, чтобы открыть структуру серверных папок Workspace, откуда вы можете выбрать другую родительскую папку, в которой будет создан проект.

Когда атрибуты заданы нужным образом, нажмите . Будет создана и открыта новая папка (подпапка).

Пример создания новой папки (подпапки) для хранения проектов.Пример создания новой папки (подпапки) для хранения проектов.

Продолжайте создание других папок для формирование иерархии, в которой будут размещаться ваши управляемые проекты. Эти папки будут доступны для выбора в качестве родительских папок при создании следующих папок, как показано на изображении ниже.

Пример заданной иерархии проектных папок.Пример заданной иерархии проектных папок.

Навигация по иерархии папок

При открытии страницы Projects в ее графическом представлении по умолчанию будут представлены проекты папки Projects верхнего уровня. Также в верхней части страницы будут показаны все дочерние папки проектов на один уровень ниже. В зависимости от длины названия папки может понадобиться навести курсор мыши на папку, чтобы увидеть ее название во всплывающей подсказке. В этом отношении, может быть проще переключиться в представление списка (нажмите ), чтобы увидеть доступные папки подчиненного уровня. Выберите папку, чтобы отобразить информацию по ней в панели справа.

Чтобы выбрать папку в графическом представлении, щелкните ЛКМ по ее плитке вне названия папки.

Пример подчиненных проектных папок, отображенных в графическом представлении страницы Projects по умолчанию. Наведите курсор мыши на изображение, чтобы увидеть папки в представлении списком.Пример подчиненных проектных папок, отображенных в графическом представлении страницы Projects по умолчанию. Наведите курсор мыши на изображение, чтобы увидеть папки в представлении списком.

Откройте папку, щелкнув ЛКМ по ее названию (в графическом представлении) или дважды щелкнув ЛКМ по ней (в представлении списком). Используйте навигацию в верхней части, чтобы быстро перейти вверх по иерархии папок.

Быстрый переход вверх по иерархии проектных папок с помощью навигации.Быстрый переход вверх по иерархии проектных папок с помощью навигации.

Вы можете быстро вернуться к папке Projects верхнего уровня, нажав Projects в дереве навигации слева.

Редактирование папки

Чтобы изменить свойства существующей проектной папки, выберите ее на странице Projects, нажмите над списком проектов/папок и выберите Edit из открывшегося меню. В окне Edit Folder вы можете изменить название и описание папки.

Корневую папку Projects нельзя изменить.
Это также доступно в графическом представлении страницы Projects – выберите плитку нужной папки, затем нажмите и выберите команду Edit из открывшегося меню. Когда страница Projects отображена в представлении списка, нажмите справа от записи нужной папки и выберите команду Edit из открывшегося меню.

Вы в любой момент можете изменить поля Name и Description проектной папки.Вы в любой момент можете изменить поля Name и Description проектной папки.

Нажмите кнопку , чтобы подтвердить выполненные изменения.

Перемещение папки по иерархии

Чтобы переместить папку в другую родительскую папку в иерархии, выберите папку на странице Projects, нажмите над списком проектов/папок и выберите Move из открывшегося меню.

Корневую папку Projects нельзя переместить.
Это также доступно в графическом представлении страницы Projects – выберите плитку нужной папки, затем нажмите и выберите команду Move из открывшегося меню. Когда страница Projects отображена в представлении списка, нажмите справа от записи нужной папки и выберите команду Move из открывшегося меню.

Будет открыто окно Move folder, в котором вы можете выбрать новую родительскую папку.

Вы в любой момент можете переместить папку в иерархии папок.Вы в любой момент можете переместить папку в иерархии папок.

Нажмите кнопку для перемещения. Папка будет перемещена, и она станет подпапкой выбранной новой родительской папки вместе со своими проектами, и вы перейдете в эту новую родительскую папку.

Удаление папки

Чтобы удалить существующую проектную папку из Workspace, выберите папку на странице Projects, нажмите над списком проектов/папок и выберите Delete из открывшегося меню.

Корневую папку Projects нельзя удалить.
Это также доступно в графическом представлении страницы Projects – выберите плитку нужной папки, затем нажмите и выберите команду Delete из открывшегося меню. Когда страница Projects отображена в представлении списка, нажмите справа от записи нужной папки и выберите команду Delete из открывшегося меню.

Будет открыто окно Delete для подтверждения удаления. Это действие фактически выполнит обратимое удаление, поскольку папка и всех хранящиеся в ней проекты будут перемещены в область Trash Workspace.

Удаление проектной папки, т.е. ее отправка в изолированную область Trash Workspace.Удаление проектной папки, т.е. ее отправка в изолированную область Trash Workspace.

Чтобы выполнить удаление, нажмите кнопку . Папка будет удалена из иерархии папок вместе с входящими в нее проектами, и вы перейдете в родительскую папку удаленной папки. Проектную папку можно восстановить или удалить навсегда со страницы Trash. Проект, удаленный вместе с папкой, можно восстановить или удалить навсегда со страницы Trash, и сделать это может владелец этого проекта или администратор Workspace.

Просмотр управляемых проектов

Список проектов на странице Projects веб-интерфейса Workspace включает в себя все проекты, которые опубликованы вам, и здесь предлагается ряд элементов управления для доступа к управлению проектами. Используйте кнопку , чтобы переключить страницу в представление списка, и кнопку , чтобы переключить страницу в графическое представление (представление по умолчанию).

Страница Projects веб-интерфейса Workspace – центр управления работой с управляемыми проектами. Здесь показано графическое представление страницы. Наведите курсор мыши на изображение, чтобы увидеть представление списка.Страница Projects веб-интерфейса Workspace – центр управления работой с управляемыми проектами. Здесь показано графическое представление страницы. Наведите курсор мыши на изображение, чтобы увидеть представление списка.

Список управляемых проектов автоматически отсортирован по дате последнего изменения, где вверху слева (в графическом представлении) или вверху (в представлении списка) отображается проект, который был изменен последним. В графическом представлении вы можете нажать кнопку для быстрого переключения сортировки проектов по названию, автору или даты последнего изменения. В представлении списка вы можете использовать заголовки столбцов для сортировки по названию (Name), автору (Author) или дате последнего изменения (Last Modified). Щелкните ЛКМ один раз для сортировки по возрастанию, щелкните ЛКМ еще раз для сортировки по убыванию. Стрелки справа от названия столбца укажут текущее направление сортировки. Выбранная сортировка в одном представлении применяется сразу к обоим представлениям.

Сортировка применяется к проектам в активной папке. Если необходимо быстро просмотреть и отсортировать все проекты во всех папках, введите * в поле поиска в верхней части страницы. Затем можно применить сортировку нужным образом.

В графическом представлении плитка управляемого проекта включает в себя название проекта и дату последнего изменения. В плитке также автоматически отображается 3D-представление платы проекта, если она доступна.

Пример плитки управляемого проекта, когда страница Projects находится в графическом представлении.Пример плитки управляемого проекта, когда страница Projects находится в графическом представлении.

Запись каждого проекта в представлении списка включает с себя следующую информацию:

  • Name – название проекта.
  • Description – заданное для проекта описание.
  • Author – пользователь, который создал проект.
  • Last Modified – дата и время, когда проект был последний раз изменен.

В обоих представлениях проектов (список и графика) вверху справа от списка доступны следующие элементы управления (описаны в соответствующих разделах ниже). Они работают для выбранного в данный момент в списке проекта:

Share (Опубликовать) – открыть окно Share с элементами управления, необходимыми для публикации проекта другим пользователям.

More (Больше) – доступ к дополнительным опциям:

  • Open (Открыть) – нажмите, чтобы открыть страницу подробного управления проекта в отдельной вкладке браузера.
  • Move (Переместить) – нажмите, чтобы вызвать окно Move project. Отсюда из всех папок, доступных в иерархии папок, вы можете выбрать другую родительскую папку, в которую нужно переместить проект.
  • Edit (Редактировать) – нажмите, чтобы открыть окно Edit Project, где вы можете изменить название проекта (Name) его описание (Description) и серверные параметры (Parameters). Поле Parent Folder является информационными, оно доступно только для чтения. Для изменения родительской папки используйте команду Move.
  • Clone (Клонировать) – выберите эту команду, чтобы открыть окно Clone Project, в котором находятся элементы управления для создания идентичной копии проекта.
  • Watch (Отслеживать) – выберите эту команду для отслеживания проекта. Вы будете получать на email соответствующие уведомления, которые касаются проекта (например, при его обновлении, выпуске, изменении прав доступа), отправленные из Workspace (доступно, если администратор включил email-уведомления). Создатель проекта автоматически отслеживает проект.
  • UnWatch (Прекратить отслеживание) – выберите эту команду, чтобы остановить отслеживание проекта и получение уведомлений о событиях, связанных с проектом.
  • Delete (Удалить) – выберите эту команду, чтобы удалить проект. Будет открыто окно Delete для подтверждения удаления. Будет выполнено обратимое удаление, при котором репозиторий проекта будет перемещен в область Trash в Workspace. Это не затронет локальную рабочую копию.
В графическом представлении доступ к этим командам осуществляется непосредственно из плитки проекта – нажмите , чтобы открыть соответствующее меню. Кроме того, вы можете дважды щелкнуть ЛКМ по плитке проекта в этом представлении (или нажать по его названию), чтобы открыть страницу подробного управления этого проекта. В представлении списка любую команду можно вызвать из меню элемента управления , расположенного справа от записи проекта.

Также доступна возможность поиска (Search), которая позволяет проводить поиск проектов во всех папках проектов. Поиск может проводиться по следующим параметрам:

  • Название
  • Описание
  • Автор
  • Параметр проекта – поскольку доступен поиск по всем параметрам, это позволяет проводить собственный оптимальный поиск (например, по имени заказчика или номеру проекта).

Введите любую часть поисковой строки в поле в верхней части веб-интерфейса. Список будет обновлен, и он будет включать в себя только те проекты, атрибуты которых включают в себя поисковую строку. Чтобы отобразить список всех проектов из всех папок введите в поле символ '*'.

При поиске по параметру проекта вы можете проводить поиск по названию параметра или определенному значению существующего параметра. В случае названия параметра, если оно не содержит пробелы, введите в поле поиска строку <НазваниеПараметрв> =. Если название параметра содержит пробелы, введите строку в формате "<НазваниеПараметрв>" =. Обычно используется значение параметра, например название заказчика (в параметре, таком как Customer, Customer Name и т.п.). Тем не менее, параметр может использоваться в качестве "метки", и, соответственно, для возможности поиска любого проекта, который включает в себя определенный параметр.

Пример использования поиска, где проект найден по значению параметра проекта (Customer Name).Пример использования поиска, где проект найден по значению параметра проекта (Customer Name).

Чтобы очистить фильтр, щелкните ЛКМ по записи страницы Projects в дереве навигации слева либо очистите поле поиска.

Область Properties

Если область свойств Properties не отображена, нажмите Properties в верхней части области справа, чтобы отобразить ее. В этой области отображается подробная информация о свойствах выбранного в данный момент проекта.

Откройте более подробную информацию о выделенном в данный момент проекте в области Properties.Откройте более подробную информацию о выделенном в данный момент проекте в области Properties.

Свойства, которые доступны в области Properties, извлечены или сформированы Workspace из выделенного в данный момент проекта. В верхней части этой области отображено 3D-представление платы (если плата доступна в проекте), вместе с общей информацией, такой как название проекта, его описание, когда он был создан и последний раз изменен, а также ссылка на родительскую проектную папку.

Дополнительные свойства расположены под сворачиваемыми заголовками, которые описаны ниже (с изображениями для примера):

  • Shared With – пользователи и/или роли, у которых есть доступ к проекту. Наведите курсор мыши на запись, чтобы увидеть полное имя пользователя/роли.

  • Parameters – обширный набор данных, извлеченных или вычисленных из самого проекта. Нажмите Show, чтобы развернуть полный список; нажмите Hide, чтобы свернуть его.

  • Releases – список выпусков проекта. Множество выпусков отображается последовательно, где вверху отображает самый новый выпуск. Щелкните ЛКМ по записи, чтобы открыть этот выпуск в отдельной вкладке в Manufacturing Portal. Из этого портала вы можете просматривать и осуществлять навигацию по выпущенным данным, изучать состав изделия, просматривать и комментировать слепок проекта-источника выпущенных данных. Также здесь вы можете получить доступ к элементам управления на загрузку различных производственных данных – от полных наборов данных до отдельных сформированных выходных файлов. Выбранный выпуск также можно отправить в виде пакета для производства (Manufacturing Package) непосредственно производителю.

Область Activity

Если область свойств Activity не отображена, нажмите Activity в верхней части области справа, чтобы отобразить ее. В этой области отображается информация об активностях, связанных с выбранным в данный момент проектом. Каждое сообщение относится к событию, которое произошло в отношении к проекту (изменение свойства, новая фиксация, выпуск и т.д). Самое новое событие отображается в верхней части списка.

Откройте историю событий, связанных с выбранным проектом, в области Activity.Откройте историю событий, связанных с выбранным проектом, в области Activity.

Нажмите по записи проекта в любом сообщении о событии, чтобы открыть страницу подробного управления проекта.

Публикация управляемого проекта

Если проект является управляемым (доступен в Workspace), вы можете определить, у каких пользователей есть доступ к этому проекту. Это осуществляется путем публикации проекта, т.е. настройкой прав доступа к нему.

Права доступа по умолчанию

Управляемый проект, вновь созданный или преобразованный для доступа к нему в Workspace, по умолчанию опубликован для следующих лиц:

  • Владельцу проекта, который, как правило, является проектировщиком, который создал (или преобразовал) проект: полные права на редактирование.
  • Участникам роли Administrators: полные права на редактирование.
  • Любому участнику команды Workspace: полные права на редактирование.

Права доступа по умолчанию для новых проектов могут быть заданы/изменены на странице Admin - Settings - Projects веб-интерфейса Workspace. Обратите внимание, что владелmцу проекта права доступа к нему назначаются автоматически, и поэтому он не представлен в этом списке.

Управление правами доступа по умолчанию для новых проектов из области Admin веб-интерфейса Workspace.Управление правами доступа по умолчанию для новых проектов из области Admin веб-интерфейса Workspace.

Обратите внимание, что корневая папка Projects по умолчанию опубликована на редактирование всем участникам команды Workspace и что задано применение этих прав доступа всем дочерним элементам, т.е. всем всем создаваемым подпапкам. Измените права доступа к папке для управления проектами в ней.

Помните, что папка Projects доступна на редактирование всем участникам команды. Измените доступ к ней и ко всем создаваемым в ней папкам нужным образом.Помните, что папка Projects доступна на редактирование всем участникам команды. Измените доступ к ней и ко всем создаваемым в ней папкам нужным образом.

Обзор публикации

Чтобы настроить права доступа к проекту из веб-интерфейса Workspace, выберите запись проекта на странице Projects и нажмите кнопку .

Это также можно сделать в графическом представлении страницы Projects – выберите плитку нужного проекта, затем нажмите и выберите команду Share из открывшегося меню. Когда страница Projects отображена в представлении списка, нажмите справа от записи нужного проекта и выберите команду Share из открывшегося меню.

Будет открыто окно Share, в котором находятся все элементы управления, необходимые для публикации проекта другим пользователям.

Когда проект централизованно управляется сервером Workspace, его публикация другим пользователям осуществляется путем настройки прав доступа к этому проекту.Когда проект централизованно управляется сервером Workspace, его публикация другим пользователям осуществляется путем настройки прав доступа к этому проекту.

Что следует иметь в виду:

  • С точки зрения прав доступа, у пользователя/роли есть полные права на редактирование, когда включена опция Can Edit. Если эта опция отключена, у пользователя/роли есть только права на чтение.
  • У владельца (Owner) и администраторов (Administrators) всегда есть полные права на редактирование (Can Edit).
  • Кроме как для владельца и администраторов, можно задать права на чтение (Can View) или редактирование (Can Edit) для отдельных добавленных пользователей/ролей либо совсем удалить их права доступа.
  • Проект может быть явно опубликован определенному пользователю и/или роли или всем в команде.
  • Вы можете опубликовать проект пользователям вне вашей команды Workspace на редактирование или только на просмотр и комментирование. Вы можете опубликовать другим пользователям AltiumLive своей организации, пользователям AltiumLive других организаций, пользователям без учетной записи AltiumLive (которым будет необходимо зарегистрироваться на AltiumLive). Для пользователя вне вашей команды появится окно Sharing Outside of the Workspace, предлагающее следующие опции:

    • Share for Viewing – выберите эту опцию, чтобы опубликовать проект, но с правами доступа только на просмотр.
    • Share for Editing – выберите эту опцию, чтобы опубликовать проект с правами доступа на редактирование.

    Вы можете опубликовать проект кому угодно за пределами своей команды, для редактирования или для просмотра.Вы можете опубликовать проект кому угодно за пределами своей команды, для редактирования или для просмотра.

    Публикация на редактирование пользователю за пределами команды Workspace отлично подходит для подрядчиков, если необходимо, чтобы они активно работали над проектом, но при этом не были добавлены в команду.
    Поддержка публикации проекта за пределы Workspace из Altium NEXUS (только для просмотра и комментирования) стала доступна в Altium NEXUS 20.1. Для публикации проекта за пределы Workspace для редактирования из Altium NEXUS и, соответственно, открытия такого проекта для редактирования, необходим Altium NEXUS 20.2 или более новая версия.

Публикация определенному пользователю или роли

Процедура публикации управляемого проекта в Workspace определенным пользователям и/или ролям выглядит следующим образом:

  1. Добавьте нужных пользователей/роли в поле Share Project With в окне Share. Чтобы добавить запись, начните вводить нужное имя/email/роль в поле, и соответствующие пользователи/роли будут отображены для выбора в динамическом списке, который будет содержать только отфильтрованных пользователей в команде или в вашей организации и существующие роли, заданные в Workspace. Может быть выбрано множество пользователей/ролей. Чтобы удалить введенного пользователя/роль, нажмите соответствующий элемент управления .

    Чтобы опубликовать проект пользователю вне организации, независимо от того, есть ли у него учетная запись AltiumLive, необходимо ввести его полный email-адрес и нажать Enter.

  2. Задайте права доступа для добавленных пользователей/ролей, выбрав Can View (Может просматривать) или Can Edit (Может редактировать) из соответствующего выпадающего меню. Второй вариант включает в себя возможность просмотра. Эта настройка изначально применяется ко всем записям (пользователям/ролям), которые находятся в поле Share Project With.

  3. Нажмите , чтобы открыть текстовую область, если вы хотите включить какую-либо информацию, относящуюся к публикации этого проекта.

  4. Нажмите Shared With, чтобы отобразить пользователей/роли, которым проект опубликован на данный момент и который по умолчанию включает в себя владельца (Owner) и роль администраторов (Administrators).

    Кроме как для владельца и администраторов, можно задать права на чтение (Can View) или редактирование (Can Edit) для отдельных добавленных пользователей/ролей либо совсем удалить их права доступа. Нажмите по текущему состоянию прав доступа, чтобы открыть элементы управления.

  5. Чтобы открыть доступ всем пользователям, включите опцию Everyone in the team и выберите нужный уровень прав доступа – Can View (доступ только на чтение) или Can Edit (полные права на чтение/запись). По умолчанию эта опция включена с полными правами доступа (Can Edit).

  6. Нажмите Advanced Settings, чтобы открыть окно для определения расширенных настроек. Для пользователей с правами на редактирование вы можете определить, может ли пользователь публиковать проект другим. Это позволяет ограничить дальнейшую публикацию, например, внешними подрядчиками. Для пользователей с правами только на просмотр вы можете управлять, могут ли они загружать исходные данные (сам проект) и производные данные (например, сформированные файлы Gerber или PDF). Они смогут просматривать данные в веб-интерфейсе и оставлять комментарии, как и прежде. В каждом из случаев, вы может задать отдельные права доступа для людей в Workspace и вне Workspace.

    Если у пользователя с правами только на просмотр нет разрешения на загрузку, он сможет просматривать проект только через веб-интерфейс. Он не сможет просматривать проект из Altium NEXUS, поскольку для этого проект должен быть сначала загружен.
    Для доступа к расширенным настройкам при публикации проекта из ПО для проектирования необходим Altium NEXUS 21.3 или более новая версия.
  7. Нажмите кнопку , чтобы подтвердить измененные права доступа к проекту. Что произойдет дальше, зависит от типа приглашенного пользователя:

    • Пользователь, который уже входит в команду вашего Workspace, будет добавлен непосредственно в список тех, кому доступен проект. Этот пользователь получит email-уведомление о том, что проект был опубликован для него (и какие права доступа у него есть). Он сможет открыть проект в Altium NEXUS (если у него есть права на это) и получить доступ к нему через интерфейс платформы Altium 365 (со страницы Projects).
    • Существующая в Workspace роль будет добавлена непосредственно в список тех, кому доступен проект. Все члены этой роли получат email-уведомление о том, что проект был опубликован для них (и какие права доступа у них есть). Они смогут открыть проект в Altium NEXUS (если у него есть права на это) и получить доступ к нему через интерфейс платформы Altium 365 (со страницы Projects).
    • Пользователю за пределами вашей команды Workspace, проект будет опубликован, и он получит email-уведомление. Он сможет открыть проект в Altium NEXUS (если у него есть права на это) и получить доступ к нему через интерфейс платформы Altium 365 (со страницы Shared with Me). В email есть ссылка для прямого доступа к проекту через Altium 365. После того, как пользователь нажмет кнопку в email, он перейдет на страницу Altium 365 Sign In (если он уже не вошел в платформу или свою учетную запись AltiumLive). После входа пользователь перейдет в средство просмотра, где будет загружен опубликованный проект.

      Если у пользователя нет учетной записи AltiumLive, ему будет необходимо сначала зарегистрироваться – для этого на странице Altium 365 Sign In доступна соответствующая ссылка.
В Altium NEXUS доступ к проекту осуществляется с помощью команды File » Open Project и соответствующего диалогового окна Open Project. Если вы входите в команду Workspace, вы можете выбрать, какой управляемый проект нужно открыть из подключенного Workspace (подключенный Workspace отображается в разделе Locations диалогового окна с иконкой и своим названием). Здесь будет приведен список только тех управляемых проектов, которые были опубликованы вам (к которым у вас есть права доступа). Если вы не входите в команду Workspace, вы можете выбрать, какой управляемый проект нужно открыть, из раздела Shared With Me диалогового окна (необходима версия Altium NEXUS 20.2 или более новая).

Доступ к странице подробного управления проекта

Главная страница: Управление определенным проектом

Workspace предлагает расширенное представление проекта. Чтобы открыть его, выберите нужный проект, нажмите кнопку над списком проектов и выберите Open из открывшегося меню. Либо дважды щелкните ЛКМ непосредственно по записи нужного проекта в списке.

Это также доступно в графическом представлении страницы Projects – выберите плитку нужного проекта, нажмите и выберите команду Open из открывшегося меню. Либо щелкните ЛКМ по названию проекта в плитке. Когда страница Projects отображается в представлении списка, нажмите справа от записи нужного проекта и выберите команду Open из открывшегося меню.

Страница подробного управления проекта будет открыта в новой вкладке браузера, с вариантами представления Design, Supply, Releases и History:

  • Design (Проект) – позволяет просматривать исходные документы проекта и свойства объектов и размещать комментарии. Это представление использует интерфейс Web Viewer, где отображаются исходные схемы проекта, плата в 2D, плата в 3D и состав изделия. Это представление самой новой версии исходных проектных данных, а не определенного выпуска этого проекта, поэтому его следует рассматривать как представление проекта, находящегося в процессе разработки. Вы можете просматривать базовый проект или любой из его вариантов.

    Вы можете проводить поиск, выполнять перекрестный переход и изучать компоненты и цепи в проекте и между его представлениями, где это применимо. При просмотре платы в 2D вы также можете проводить измерения.

  • Supply (Поставка) – позволяет изучать информацию о составе изделия разрабатываемого проекта, извлеченную из проектных документов, в том числе записей для компонентов производителей и поставщиков из документа ActiveBOM проекта.

  • Releases (Выпуски) – позволяет просматривать выпуски проекта. Доступ осуществляется путем открытия полного выпуска или определенного пакета для сборки, который будет представлен на отдельной вкладке в Manufacturing Portal. Из этого портала вы можете просматривать и осуществлять навигацию по выпущенным данным, изучать состав изделия, просматривать и комментировать слепок проекта-источника выпущенных данных. Из представления Releases или с помощью Manufacturing Portal для определенного выпуска вы можете получить доступ к элементам управления на загрузку различных производственных данных – от полных наборов данных до отдельных сформированных выходных файлов. Выбранный выпуск также можно отправить в виде пакета для производства (Manufacturing Package) непосредственно производителю. Вы также можете сравнивать данные Gerber для различных выпусков или с локально сформированным набором файлов.

    Платформа Altium 365 предоставляет специальное средство просмотра пакетов для производства Manufacturing Package Viewer – элемент поддержки глобальной публикации (Global Sharing) платформы, который позволяет просматривать пакет для производства из любого веб-браузера, из любой точки мира, но за пределами вашего Workspace, что позволит скрыть сами проекты и прочую ценную интеллектуальную собственность. Для получения более подробной информации перейдите на страницы Глобальная публикация и Средство просмотра пакетов для производства Manufacturing Package Viewer.

  • History (История) – позволяет просматривать временную шкалу основных событий, связанных с проектом: его создание, фиксации, выпуски, клонирования и обмены данными с MCAD-системой. Для этих событий поддерживаются различные действия, где это применимо. Для выпусков вы также можете сравнивать данные Gerber для различных выпусков или с локально сформированным набором файлов.

Страницу подробного управления проекта также можно открыть из Altium NEXUS. Для активного управляемого проекта используйте команду Project » Show in Web Browser из главного меню. Либо щелкните ПКМ по записи проекта в панели Projects и выберите команду Show in Web Browser из контекстного меню. При просмотре проекта через панель Explorer в Altium NEXUS, которая по умолчанию отображается в представлении Project View, а не Classic View, откройте страницу подробного управления проекта нажатием кнопки .

Перемещение управляемого проекта

Чтобы переместить проект в другую родительскую папку с иерархии папок, выберите этот проект на странице Projects, нажмите над списком проектов/папок и выберите Move из открывшегося меню.

Это также доступно в графическом представлении страницы Projects – выберите плитку нужного проекта, затем нажмите и выберите команду Move из открывшегося меню. Когда страница Projects отображена в представлении списка, нажмите справа от записи нужного проекта и выберите команду Move из открывшегося меню.

Будет открыто окно Move project, в котором вы можете выбрать новую родительскую папку. Нажмите , чтобы применить перемещение. Проект будет перемещен в выбранную папку, и вы перейдете в нее.

Вы в любой момент можете переместить проект в любую папку в иерархии папок.Вы в любой момент можете переместить проект в любую папку в иерархии папок.

Редактирование управляемого проекта

Для изменения свойств проекта в Workspace выберите его запись на странице Projects, нажмите над списком проектов и выберите запись Edit в соответствующем меню. В открывшемся окне Edit Project, которое будет открыто упрощенном представлении, вы можете изменить название (Name) и описание (Description) проекта.

Это также доступно в графическом представлении страницы Projects – выберите плитку нужного проекта, затем нажмите и выберите команду Edit из открывшегося меню. Когда страница Projects отображена в представлении списка, нажмите справа от записи нужного проекта и выберите команду Edit из открывшегося меню.

Вы можете изменить название (Name) и описание (Description) управляемого проекта на любом этапе.Вы можете изменить название (Name) и описание (Description) управляемого проекта на любом этапе.

Нажмите кнопку , чтобы открыть дополнительные поля.

Дополнительные поля доступны по нажатию кнопки Advanced.Дополнительные поля доступны по нажатию кнопки Advanced.

  • Parent Folder – в этом поле отображено название папки, в котором находится проект в в иерархии проектных папок Workspace. Это поле не доступно для редактирования, оно является только информационным. Чтобы сменить родительскую папку, необходимо использовать команду Move.
  • Parameters – нажмите, чтобы раскрыть область, в которой вы можете управлять серверными параметрами проекта. Вы можете добавлять пары названий и значений параметров (), редактировать их (по месту) и удалять ().

    Вносите изменения в серверные параметры проекта.Вносите изменения в серверные параметры проекта.

    Серверные параметры проекта сохраняются в Workspace с проектом, и их можно изменить только в Workspace. Напротив, проектные параметры хранятся в файле проекта (*.PrjPcb), и их можно изменить в Altium NEXUS. Параметры обоих типов могут использоваться в Altium NEXUS в качестве специальных строк – откройте панель Properties, когда размещенный объект Text String выделен в рабочей области. Все заданные для проекта параметры, как проектные, так и серверные, можно просмотреть на вкладке Parameters диалогового окна Project Options (Project » Project Options).

Нажмите кнопку , чтобы подтвердить внесенные изменения.

Клонирование управляемого проекта

Чтобы клонировать существующий управляемый проект, выберите его запись на странице Projects, нажмите кнопку и выберите запись Clone из соответствующего меню. Будет открыто окно Clone Project.

Это также доступно в графическом представлении страницы Projects – выберите плитку нужного проекта, затем нажмите и выберите команду Clone из открывшегося меню. Когда страница Projects отображена в представлении списка, нажмите справа от записи нужного проекта и выберите команду Clone из открывшегося меню.

Вы можете клонировать управляемый проект для создания его идентичной копии, а также его рабочих файлов.Вы можете клонировать управляемый проект для создания его идентичной копии, а также его рабочих файлов.

Используйте окно Clone Project для указания названия проект и опционального описания. По умолчанию будет использовать имя изначального проекта с суффиксом ' - Copy' и будет добавлено описание по умолчанию.

Обратите внимание, что название клонированного проекта должно начинаться с A-Z, a-z или 0-9, и оно может содержать эти символы. Допустимы подчеркивания, дефисы и пробелы, но пробелы могут быть только в середине имени (пробелы в начале и в конце будут игнорироваться). Вы не можете использовать следующие слова: AUX, COM1-COM9, LPT1-LPT9, CON, NUL и PRN. Кроме того, название не может содержать в себе следующие символы: \ . / ? % * : | " < >.

Нажмите кнопку для доступа к полю Parent Folder. По умолчанию здесь будет задана папка, в которой расположен изначальный проект. Нажмите Change справа от поля для вызова структуры серверных папок Workspace, где можно выбрать другую папку для хранения клонированного проекта. Вы можете организовать проекты в желаемую иерархию подпапок. Для получения более подробной информации перейдите в раздел Создание иерархии проектных папок.

После настройки полей нужным образом нажмите кнопку . Исходный проект и входящие в него файлы и данные будут клонированы, и этот проект будет добавлен в список страницы Projects (в выбранную родительскую папку).

Удаление управляемого проекта

Связанная страница: Trash (Корзина)

Чтобы удалить существующий управляемый проект из Workspace, выберите его запись на странице Projects, нажмите кнопку над списком проектов и выберите запись Delete из открывшегося меню.

Удаление доступно только в том случае, если вы являетесь владельцем проекта или администратором Workspace.
Это также доступно в графическом представлении страницы Projects – выберите плитку нужного проекта, затем нажмите и выберите команду Delete из открывшегося меню. Когда страница Projects отображена в представлении списка, нажмите справа от записи нужного проекта и выберите команду Delete из открывшегося меню.

Будет открыто окно Delete для подтверждения удаления. Это действие выполнит, по сути, обратимое удаление, поскольку репозиторий проекта будет перемещен в область Trash Workspace. Представление окна Delete будет зависеть от того, был выпущен проект или нет:

  • Выпуск проекта не осуществлялся – в этом случае, окно Delete оповещает, что репозиторий проекта будет перемещен в область Trash.

  • Проект был выпущен – в этом случае, окно Delete оповещает, что репозиторий проекта будет перемещен в область Trash, и отображает количество выпусков и пакетов для производства, которые также будут удалены.

    Если вы хотите обратимо удалить определенный пакет для производства, связанный с определенным проектом, то это можно сделать из представления Manufacture страницы подробного управления проекта. Чтобы открыть это представление, нажмите Show details в окне Delete.

Чтобы выполнить удаление, нажмите кнопку . Проект будет удален из списка. Локальная рабочая копия не будет затронута этим действием, но вы больше не сможете выполнять фиксацию изменений на сервер. В Altium NEXUS вы можете закрыть и повторно открыть локальную рабочую копию проекта, чтобы вызвать ряд доступных действий, поскольку локальный проект теперь ссылается на репозиторий системы контроля версий, который больше не существует.

Все проекты, удаленные таким образом, можно найти на странице Trash интерфейса. Обратите внимание, что вы можете просматривать только те проекты (и прочие объекты), которые вы сами удалили. Администраторы смогут увидеть полное содержимое страницы Trash, т.е. все объекты, которые были обратимо удалены.

Что следует иметь в виду касательно проектов, удаленных таким способом:

  • Проект станет недоступным для открытия и просмотра в системе проектирования и в веб-интерфейсе.
  • Если проект был опубликован за пределы команды Workspace, соответствующая плитка будет удалена со страницы Shared with Me интерфейса платформы Altium 365 у всех пользователей, которым был опубликован этот проект.
  • Опубликованные пакеты для производства, которые были удалены с проектом, также будут удалены со страницы Shared with Me интерфейса платформы Altium 365 у всех пользователей, которым были опубликованы эти пакеты.
  • При просмотре объектов, которые использовались в проекте, запись Where Used для этого проекта покажет, что проект был удален.
  • Проект можно восстановить или удалить полностью со страницы Trash. Сделать это может только владелец этого проекта или администратор Workspace.
Обратите внимание, что если вы удалили проект с возможностью восстановления, т.е. переместили его в область Trash, вы можете создать новый проект с тем же именем. Если вы затем восстановите изначальный проект, будет взято изначальное имя и к нему будет добавлен целочисленный суффикс, чтобы обеспечить уникальность имен в Workspace.
Обнаружили проблему в этом документе? Выделите область и нажмите Ctrl+Enter, чтобы оповестить нас.

Связаться с нами

Связаться с нашими Представительствами напрямую

We're sorry to hear the article wasn't helpful to you.
Could you take a moment to tell us why?
200 characters remaining
Вы сообщаете о проблеме, связанной со следующим выделенным текстом
и/или изображением в активном документе: