Altium NEXUS Documentation

Аннотирование компонентов_AD

Содержание

Полное содержание

Аннотирование проекта – это систематический и планомерный процесс, который позволяет обеспечить идентификацию всех компонентов в проекте с помощью уникальных обозначений. Хотя Altium NEXUS может идентифицировать компоненты с помощью глобальных уникальных идентификаторов (GUID), большинство проектировщиков исторически используют позиционные обозначения компонентов в качестве основного средства для привязки к ним на схеме (логическое представление) и на плате (физическое представление), а также в выходных документах, таких как состав изделия.

Существует три подхода к аннотированию проекта. Выбор инструмента аннотирования зависит от ряда факторов, в том числе от типа проекта, личных предпочтений, политики компании и применяемой методологии.

Аннотирование на уровне схемы

Аннотирование на уровне схемы использует чисто логический вид схемы для определения позиционных обозначений компонентов. Это наиболее полезно для простых проектов, в которых не используются листы устройств, но поскольку это аннотирование позволяет задать порядок обработки, а также опции завершения существующих корпусов многосекционных компонентов, оно также является необходимым условием для аннотирования на уровне платы.

Таким образом, используйте аннотирование на уровне схемы в следующих случаях:

  • Для упаковки многосекционных компонентов.
  • Для аннотирования компонентов в зависимости от их положения на схеме.
  • Для аннотирования многоканальных проектов с использование схемы именования по умолчанию, указанной в опциях проекта.
  • Для подготовки проекта к дополнительному аннотированию.

Аннотирование платы

Аннотирование платы использует физическое положение компонентов на плате для определения их обозначений. Это позволяет, по сути, кодировать информацию о местоположении компонента в его обозначение, что может быть очень полезным при отладке печатного узла. В общем, вам следует использовать этот процесс для аннотирования компонентов в зависимости от их положения на плате.

Аннотирование на уровне платы

Аннотирование на уровне платы обеспечивает сопоставление обозначений, используемых на схеме (в логическом представлении проекта), и их физическими ответными частями на плате (в физическом представлении проекта). Хотя аннотирование на уровне платы можно использовать в любом проекте, это особенно полезно для многоканальных проектов или проектов, которые включают в себя листы устройств, где позиционные обозначения нельзя изменить. Таким образом, весь проект можно переаннотировать без изменения изначальных листов устройств. Аннотирование на уровне платы решает любые проблемы конфликтного аннотирования, которые могут возникнуть из-за дубликатов позиционных обозначений в проекте, и сохраняет изменения в текстовом файле *.Annotation. Оно включает в себя дополнительные ключевые слова для кастомизации схем именования и позволяет применить их ко всем компонентами или к их выделенному набору.

Таким образом, используйте аннотирование на уровне платы в следующих случаях:

  • Для аннотирования скомпилированных компонентов на листах устройств.
  • Для уникального именования всех компонентов во множестве каналов с помощью схем именования, которые включают в себя позиционное обозначение, глобальное индексирование и другие настройки.
  • Для именования компонентов вручную.

Аннотирование схемы

Команда аннотирования схемы упорядоченно присваивает обозначения всем выделенным компонентам на выбранных листах проекта и обеспечивает уникальность этих обозначений и их порядок на основе их местоположения. Можно настроить опции аннотирования для упаковки многосекционных компонентов, задать опции индексов и суффиксов, сбросить обозначения на схеме, в том числе дублирующиеся, и выполнить обратное аннотирование из платы.

Чтобы вызвать команду аннотирования схемы, выберите в главном меню Tools » Annotation » Annotate Schematics.

Диалоговое окно Annotate открывается с помощью команды Annotate Schematics.
Диалоговое окно Annotate открывается с помощью команды Annotate Schematics.

Диалоговое окно Annotate разделено на две основных области:

  • Левая часть служит для настройки порядка обработки (Order of Processing), настройки опций сопоставления (Matching Options) для многосекционных компонентов, настройки процесса обработки по положению обозначения или компонента, настройки области действия аннотирования, в том числе определения для отдельных листов схемы индекса и добавления суффикса позиционных обозначений.
  • В правой части приведен список предлагаемых изменений, которые будут применены после нажатия кнопки Accept Changes (Create ECO). Он включает в себя текущие (Current) и планируемые (Proposed) обозначения, с возможностью заблокировать (исключить) определенные обозначения и/или секции компонентов для аннотирования.

Order of Processing (Порядок обработки)

Направление позиционного аннотирования задается опцией Order of Processing. Для управления тем, как будут читаться документы схемы, доступны четыре опции, которые показаны ниже.

Укажите порядок, в котором будут обрабатываться компоненты. Укажите порядок, в котором будут обрабатываться компоненты. Укажите порядок, в котором будут обрабатываться компоненты. Укажите порядок, в котором будут обрабатываться компоненты.
Укажите порядок, в котором будут обрабатываться компоненты.

Когда Altium NEXUS обрабатывает компоненты для аннотирования, используется граничный прямоугольник, который описывает весь компонент и все видимые параметры. Если порядок обработки не совпадает с ожидаемым, проверьте положение параметров компонентов, чтобы убедиться, что они не могут повлиять на результат.

Matching Options (Опции сопоставления)

Сопоставление компонентов в многосекционных корпусах.
Сопоставление компонентов в многосекционных корпусах.

При использовании многосекционных пакетов, зачастую желательно упаковывать секции в минимальное количество физических компонентов, чтобы снизить общую стоимость состава изделия. Основными соображениями по аннотированию многосекционных компонентов является то, как эти секции будут сопоставлены и сгруппированы вместе, а также то, какие критерии используются для определения корректного группирования.

Complete Existing Packages (Завершение существующих корпусов)

Чтобы упаковывание многосекционных компонентов было включено в процесс аннотирования, в выпадающем списке Complete Existing Packages, должно быть задано что-то, отличное от None.

  • None – существующие корпуса не будут завершены, и все новые секции будут размещены в новые корпуса.
  • Per Sheet – существующие корпуса будут включать в себя только новые секции на том же листе схемы.
  • Whole Project – существующие корпуса будут включать в себя новые секции из любых листов схем проекта.
При выборе опции Completing Existing Packages следует учитывать то, как в активных компонентах были заданы выводы питания. Например, многие проектировщики включают выводы VCC/GND в первую секцию многосекционного компонента, но затем не включают эти выводы в последующие секции. Если первая секция в многосекционном компоненте упакована в альтернативный корпус, и ее подсекция обновляется, это может привести к неподключенным (или плавающим) соединениям питания.

Lock Components (Заблокировать компоненты)

Для негомогенных многосекционных компонентов убедитесь, что иконка блокировки включена, для предотвращения изменения подсекций при аннотировании.

Component Parameters (Параметр компонента)

Список Component Parameter включает в себя все параметры, найденные в компонентах в текущем проекте. Если многосекционные компоненты используют один и тот же доступный параметр с общим значением, то они будут упакованы вместе (в предположении, что опции Complete Existing Packages не задано None).

Настройкой по умолчанию в диалоговом окне Annotate является завершение существующих корпусов по библиотечной ссылке и комментарию, однако вы можете выбрать любую комбинацию параметров.

Опция Strictly (Строго)

Если флажок Strictly включен для параметра компонента (Component Parameter), то у всех компонентов, которые должны быть упакованы в один корпус, этот параметр должен совпадать. Компоненты, у которых этот параметр отсутствует, будут аннотированы как отдельные компоненты и не будут упакованы вместе.

В рассмотренном ниже примере показано, как комбинации этих опций дают определенный результат.

Рассмотрим пример, где находится восемь элементов ИЛИ и восемь резисторов (как показано на изображении ниже). Элементы ИЛИ содержат в себе параметр под названием QuadOrGate, и у одной группы из четырех элементов ИЛИ этот параметр имеет значение Package1, а у другой группы из четырех элементов ИЛИ – значение Package2. У резисторов нет этого параметра. При включении флажка QuadOrGate в Component Parameter этот параметр будет использоваться для управления тем, как будут упаковываться компоненты. В этом случае, флажок Strictly не включен.

После запуска команды Tools » Annotation » Annotate Schematics секции с параметром QuadOrGate = Package1 будут упакованы в один физический компонент, а секции с параметром QuadOrGate = Package2 будут упакованы отдельно. Остальные компоненты, у которых нет параметра QuadOrGate будут упакованы вместе. В этом случае, резисторы упаковываются вместе, поскольку они все не содержат параметр QuadOrGate.

Пример упакованных компонентов с отключенной опцией Strictly.
Пример упакованных компонентов с отключенной опцией Strictly.

Если аннотировать тот же проект, но с включенной опцией Strictly, то только компоненты с параметром QuadOrGate будут упакованы. В этом случае, элементы ИЛИ будут упакованы, а резисторы – нет. Таким образом, опция Strictly позволяет крайне точно управлять процессом упаковки, в большинстве случае ее следует оставить отключенной.

Пример упакованных компонентов с включенной опцией Strictly.
Пример упакованных компонентов с включенной опцией Strictly.

Многосекционные компоненты могут использовать как буквенный, так и цифровой идентификационный суффикс секции, т.е. U1:1, U1:2 или U1:A, U1:B. Стиль этого суффикса определяется на странице Schematic - General диалогового окна Preferences. Обратите внимание, что эти настройки являются глобальными, и они применяются ко всем открытым листам схем.

Schematic Sheets to Annotate (Листы схем для аннотирования)

Доступна тонкая настройка того, на какие листы схем и компоненты повлияет аннотирование, и особенностей того, как будут рассчитываться изменения.

Определение области действия аннотирования.
Определение области действия аннотирования.

  • Флажок слева от записи листа схемы в списке определяет, будет ли этот лист обрабатываться в рамках процесса аннотирования.
  • Область действия аннотирования определяется выпадающим списком Annotation Scope, с помощью которого можно включить в процесс весь лист схемы или ограничить его только (не)выделенными компонентами. При использовании опции Ignore Selected Parts и Only Selected Parts необходимо, чтобы компоненты были выделены в проекте перед запуском команды на аннотирования.
  • Настройке порядок, в котором листы схем будут аннотированы, с помощью поля Order. Введите значение в поле или используйте стрелки, которые появляются при щелчке ЛКМ в поле, чтобы задать нужное значение.
  • Если опция Designator Index включена, позиционное обозначение будет начинаться со значения Start Index. Значение Start Index ни на что не повлияет, если опция Designator Index Control отключена.
  • Дополнительный суффикс можно добавить в конец каждого позиционного обозначения, указав строку/значение в столбце Suffix. Избегайте использования суффиксов из одного символа, таких как 'A' или '1', поскольку их можно легко перепутать со значением секции или другого позиционного обозначения.

Proposed Change List (Список планируемых изменений)

Нажмите кнопку Update Changes List, чтобы обновить список планируемых изменений (Proposed Change List), чтобы изменения всех можно было проверить перед их изменением. Будут изменены только те позиционные обозначения, которые не были определены ранее (т.е. R?, C? и т.д.). Соответственно, если вы планируете обновить все позиционные обозначения в проекте, их необходимо сначала сбросить нажатием кнопки Reset All.

Сброс позиционных обозначений перед применением настроек аннотирования.
Сброс позиционных обозначений перед применением настроек аннотирования.

Выпадающее меню кнопки Reset All также можно использовать, чтобы сбросить дубликаты (Reset Duplicates).

В списке Proposed Change List приведены все позиционные обозначения компонентов, которые находятся на листах, выбранных для аннотирования. Для каждой записи приводятся текущее (Current) и планируемое (Proposed) значение позиционного обозначения, а также секция компонента (Sub) и его исходное расположение (Location of Part).

Включите флажок, связанный с позиционным обозначением (Designator), чтобы заблокировать это определенное позиционное обозначение от изменений. Аналогично, включите флажок Sub, чтобы предотвратить изменение этого определенного многосекционного компонента. Эту опцию можно использовать в качестве альтернативы иконки Lock в панели Properties.

После проверки списка планируемых изменений нажмите кнопку Accept Changes (Create ECO), чтобы открыть диалоговое окно Engineering Change Order. После выполнения ECO изменения аннотирования будут применены к проекту.

Дополнительные команды аннотирования схемы

Меню Tools » Annotation содержит ряд команд аннотирования схемы. Первая команде в группе, Annotate Schematic, описана выше.

Различные команды аннотирования
Различные команды аннотирования

Reset Schematic Designators (Сброс позиционных обозначений на схеме)

Если в новый проект были добавлены большие участки схемы, скопированные из различных источников, может быть необходимо сбросить все позиционные обозначения. Поскольку эта команда использует настройки, взятые из диалогового окна Annotate, она будет применена к объектам, заданным в этом диалоговом окне. Например, если ранее были выбраны все листы схем для аннотирования (Schematic Sheets To Annotate), то команда Reset Schematic Designators будет применена ко всему проекту, независимо от того, открыты листы в редакторе или нет. Если были выбраны только некоторые листы для аннотирования, то команда Reset Schematic Designators будет применена только к ним.

Заблокированные позиционные обозначения не будут сброшены или каким-либо образом изменены.

Reset Duplicate Schematic Designators (Сбросить дубликаты позиционных обозначений на схеме)

При дублировании частей проекта добавленные компоненты будут иметь те же значения позиционных обозначений, что и у скопированных компонентов. Команда Reset Duplicate Schematic Designators позволяет быстро сбросить дублирующиеся позиционные обозначения на '?'. Поскольку эта команда использует настройки, взятые из диалогового окна Annotate, она будет применена к объектам, заданным в этом диалоговом окне. Например, если ранее были выбраны все листы схем для аннотирования (Schematic Sheets To Annotate), то команда Reset Duplicate Schematic Designators будет применена ко всему проекту, независимо от того, открыты листы в редакторе или нет. Если были выбраны только некоторые листы для аннотирования, то команда Reset Schematic Designators будет применена только к ним.

Заблокированные позиционные обозначения не будут сброшены или каким-либо образом изменены.

Annotate Schematics Quietly (Тихое аннотирование схем)

Команда Annotate Schematics Quietly позволяет применить все предыдущие настройки диалогового окна Annotate без необходимости повторно открывать это диалоговое окно.

Force Annotate All Schematics (Принудительное аннотирование всех схем)

Запуск команды Force Annotate All Schematics эквивалентен последовательному запуску команд Reset Schematic Designators и Annotate Schematics Quietly. Соответственно, при определении того, какие компоненты и листы будут обновлены, команда Force Annotate All Schematics использует настройки, заданные ранее в диалоговом окне Annotate.

После запуска команды будет открыт запрос на подтверждение с информацией о количестве позиционных обозначений, которые будут обновлены при утверждении.

Back Annotate Schematics (Обратное аннотирование схем)

До реализации в Altium NEXUS механизмов компиляции и синхронизации изменения аннотирования передавались из схемы в плату через файл списка цепей (*.net). Изменения аннотирования, которые было необходимо передать в обратном направлении, из платы в схему, обрабатывались процессом обратного аннотирования. Этот процесс использует файл *.WAS (Was-Is, Было-Стало), или файл *.ECO (Engineering Change Order, Запрос на инженерные изменения) для применения изменений к позиционным обозначениям на плате.

Number Schematic Sheets (Нумерация листов схем)

Команда Number Schematic Sheets меняет не позиционные обозначения компонентов, а обозначения (номера) листов схем. Соответственно, она связана с общей концепцией аннотирования проекта.

Нумерация листов схем в проекте позволяет вам управлять обозначением листов и сохранять их в качестве параметров в соответствующих документах схем. Затем вы можете использовать возможности специальных строк Altium NEXUS (=SheetNumber, =DocumentNumber, =SheetTotal) для отображения их значений на листе (например, в основной надписи) в качестве текстовых объектов.

Нумерация листов схем.
Нумерация листов схем.

Процесс нумерации листов описан в следующих разделах.

Auto Sheet Number (Автоматическая нумерация листов)

Откройте выпадающее меню кнопки Auto Sheet Number, чтобы открыть опции нумерации листов.

Доступны следующие опции для схемы нумерации (Select Numbering Scheme):

  • Display Order – выберите для нумерации листов в том порядке, в котором они отображаются.
  • Sheets Hierarchical Structure - Depth First – выберите для нумерации листов с верхнего уровня в каждой ветви. Сначала нумеруется верхний уровень, после чего полностью нумеруется первая ветвь под первым уровнем, затем вторая ветвь и т.д.
  • Sheets Hierarchical Structure - Breadth First – выберите для нумерации листов в соответствии с их уровнем в иерархии. Сначала нумеруется верхний уровень, затем нумеруются все вторые уровни и т.д.

В области Select Numbering Method выберите, хотите ли вы осуществить нумерацию по возрастанию (Increasing) или по убыванию (Decreasing).

Auto Document Number (Автоматическая нумерация документов)

Откройте выпадающее меню кнопки Auto Document Number, чтобы вызвать выпадающее окно опций нумерации документов. По сути, это те же самые опции, что и опции в окне Auto Sheet Number, за исключением дополнительных значений Prefix и Postfix.

Используйте опции Parameters, чтобы задать параметры нумерации документов.

  • Prefix – выберите префикс, который будет добавлен перед номером документа. Поддерживаются буквенные (A, B, C и т.д.), цифровые (1, 2, 3 и т.д.) и небуквенно-цифровые (_, *, ., % и т.д.) префиксы, а также любые их комбинации (например, буквенно-цифровые).
  • Start – выберите числовое значение, с которого будет начинаться нумерация документов.
  • Postfix – выберите постфикс, который будет добавлен после номера документа. Поддерживаются буквенные (A, B, C и т.д.), цифровые (1, 2, 3 и т.д.) и небуквенно-цифровые (_, *, ., % и т.д.) постфиксы, а также любые их комбинации (например, буквенно-цифровые).
  • Step – выберите значение, на которое будет увеличиваться каждый номер документа. Например, если индекс Start задан 1, а значение Step задано 100, номером первого документа будет 1, номером следующего документа будет 101 (Start + Step), затем 201 и т.д.

Update Sheet Count (Обновить количества листов)

Нажмите кнопку Update Sheet Count, чтобы подсчитать общее количество листов в текущем проекте и поместить результат в столбец SheetTotal. Это будет общее количество листов в проекте, независимо от схемы нумерации, выбранной в каких-либо предыдущих опциях.

Move Up/Down (Переместить вверх/вниз)

Используйте кнопки Move Up и Move Down для перемещения выбранного документа схемы вверх и вниз по списку. Это имеет смысл при использовании схемы нумерации Display Order для определения номеров листов или документов.

Пользовательская нумерация/именование

Если в вашей организации используется специфическая система нумерации, которую нельзя автоматизировать с помощью команд Auto Sheet Number или Auto Document Number, пользовательские номера листов и документов могут будет записаны непосредственно в поля SheetNumber и DocumentNumber соответственно.

Нумерация листов схем и листы устройств

Нумерация листов или документов не может быть задана для листов устройств, когда они доступны только для чтения (состояние по умолчанию) – в диалоговом окне Sheet Numbering For Project они будут отображены штриховкой, что означает, что их нельзя обновить. Если листы устройств заданы как доступные для редактирования, штриховка не будет отображена, и нумерацию листов и документов можно задать обычным образом.

Аннотирование на уровне платы

Аннотирование на уровне платы – это процесс аннотирования скомпилированных компонентов (физического вида компонентов) в вашем проекте через редактор схем. Аннотирование на уровне платы позволяет задать имена компонентов на основе ряда схем именования либо указать пользовательские имена.

Аннотирование на уровне платы предоставляет вам полный контроль над аннотированием в проекте с помощью настроек аннотирования, сохраненных в текстовом файле *.Annotation, который отображается в подпапке Settings\Annotation Documents в панели Projects. Altium NEXUS управляет файлами аннотирования автоматически.

Вы можете задать имена всем компоненты в проекте, выделенным компонентам либо только компонентам без обозначений. Для аннотирования скомпилированных компонентов в проекте через редактор схем необходимо выполнить следующее:

  • Убедитесь, что компоненты были аннотированы на уровне схемы, чтобы исходные данные схемы, в том числе опции упаковывания для многосекционных компонентов, были доступны в качестве входных данных для аннотирования на уровне платы.
  • Выберите команду Tools » Annotation » Board Level Annotate (сочетание клавиш Ctrl+L), чтобы открыть диалоговое окно Board Level Annotate. Левая часть диалогового окна предназначена для фильтрации и настройки области действия аннотирования; в правой части показаны планируемые изменения.

В диалоговом окне Board Level Annotate отображены все документы схем проекта.
В диалоговом окне Board Level Annotate отображены все документы схем проекта.

Filter Options (Опции фильтра)

В левой части вы можете управлять областью действия аннотирования на уровне листов, каналов и компонентов. Столбцы в области Filter Options не изменяются.

Schematic Sheet (Лист схемы)

В столбце Schematic Sheet приведен список всех документов схем в вашем проекте. Один документ схемы может быть приведен в списке несколько раз, если проект включает в себя множество каналов.

Channel Name (Имя канала)

В столбце Channel Name приведен список всех применимых каналов в проекте. Если в проекте нет каналов, в этом столбце будет отображено имя листа схемы.

Enabled (Включено)

Поставьте флажок, чтобы включить соответствующий лист схемы определенного канала в аннотирование на уровне платы. Снимите флажок, чтобы исключить этот лист из аннотирования на уровне платы.

Annotation Scope (Область действия аннотирования)

Выберите область действия для компонентов, которые необходимо аннотировать:

  • All – будут аннотированы все компоненты на листе схемы.
  • Ignore Selected Parts – будут аннотированы все компоненты, кроме выделенных.
  • Only Selected Parts – будут аннотированы только выделенные компоненты.
Компоненты, которые следует включить в аннотирование на уровне платы или исключить из него, необходимо выделить перед открытием диалогового окна Board Level Annotate.

Кнопки All On (Включить все), All Off (Отключить все)

При нажатии кнопки All On будут поставлены флажки Enabled для всех листов схем в проекте. Кнопка All Off снимает флажки Enabled для всех листов схем в проекте.

Proposed Change List (Список планируемых изменений)

Правая часть диалогового окна позволяет просмотреть исходные компоненты на схеме (Schematic Source Components), просмотреть рассчитанные проектные данные (Calculated Design Data), используемые в текущей схеме именования, будь то схема именования по умолчанию для скомпилированных компонентов или примененная схема именования (подсвечена зеленым). Примените схему именования (Naming Scheme) и просмотрите результирующие экземпляры компонентов на плате (PCB Component Instance).

Schematic Source Component (Исходный компонент на схеме)

Область Schematic Source Component состоит из трех столбцов:

  • Hierarchy Path – путь исходной схемы в формате Имя файла\Канал.
  • Prefix – буквенно-цифровой префикс, извлеченный из позиционного обозначения на уровне схемы. Например, если позиционным обозначением на уровне схемы является R13, префиксом будет R.
Если у компонента нет позиционного обозначения, у него будет иконка компонента с вопросительным знаком (). После выполнения первого аннотирования на уровне платы иконка изменится на для обозначения, что у компонента есть позиционное обозначение. Если сбросить позиционные обозначения, иконка вернется в состояние .
  • Local Index – индекс, указанный после буквенного префикса, извлеченный из позиционного обозначения на уровне схемы. Например, если позиционным обозначением на уровне схемы является R13, значением Local Index будет 13.

Calculated Design Data (Рассчитанные проектные данные)

При первом открытии диалогового окна Board Level Annotate, в области Calculated Design Data будет отображен столбец Room name, который соответствует выбранной опции аннотирования (Annotate Option) по умолчанию. После выполнения аннотирования на уровне схемы в столбце Calculated Design Data будет представлено ключевое слово, выбранное в схеме именования в опциях аннотирования (Annotate Options). Эти столбцы динамически обновляются на основе вашего выбора. Например, если вы зададите, чтобы схемой именования (Naming Scheme) была $GlobalIndex.$SheetDesignator, будут отображены столбцы глобального индекса и обозначения листа.

Naming Scheme (Схема именования)

Поставьте флажок, чтобы включить схему именования (Naming Scheme) для этого компонента; снимите флажок, чтобы отключить. Обратите внимание, что когда флажок в этом поле снят, столбец PCB Component Instance доступен для редактирования, чтобы вы могли указать пользовательское позиционное обозначение компонента.

PCB Component Instance (Экземпляр компонента на плате)

В столбце PCB Component Instance отображены планируемые позиционные обозначения. Это поле определяется выбранной схемой именования (Naming Scheme) либо пользовательским значением, которое может быть указано, только если флажок в поле Naming Scheme снят. Пользовательское имя может включать в себя любую комбинацию буквенно-цифровых и небуквенно-цифровых символов.

Annotate Options (Опции аннотирования)

Опции аннотирования (доступны по нажатию кнопки Annotate Options в диалоговом окне Board Level Annotate) позволяют осуществить дальнейшую кастомизацию аннотирования с использованием предопределенных или пользовательских схем именования (Naming Schemes).

Предопределенные схемы именования

Чтобы применить предопределенную схему именования:

  • В диалоговом окне Board Level Annotate нажмите кнопку Annotate Options, чтобы открыть диалоговое окно Board Level Annotation Options.
  • Выберите предопределенную схему именования из выпадающего списка Naming Scheme.
  • После выбора схемы именования настройте прочие опции, такие как Global Index Options (Опции глобального индексирования) или Room Name Options (Опции именования комнат), нажмите OK. Опции кастомизации отличаются для различных схем именования.
  • Обратите внимание, что столбцы Calculated Design Data обновляются в соответствии с ключевыми словами, используемыми в схеме именования.

Пользовательские схемы именования

Чтобы применить пользовательскую схему именования:

  • В диалоговом окне Board Level Annotate нажмите кнопку Annotate Options, чтобы открыть диалоговое окно Board Level Annotation Options.
  • Задайте собственную схему именования путем ввода корректных ключевых слов непосредственно в поле Naming Schemes. Вы можете задать любую комбинацию корректных ключевых слов для определения собственной схемы именования. Для разделения ключевых слов в схеме именования вы можете использовать любые небуквенно-цифровые символы, например "_", "*", ".", и "@".
  • Выберите ключевые слова из приведенного ниже списка:

Ключевое слово

Определение

$RoomName

Название соответствующей комнаты, определенное стилем, выбранным в опциях именования комнат.

$ComponentPrefix

Префикс логического позиционного обозначения (например, U для U1).

$ComponentIndex

Индекс логического позиционного обозначения (например, 1 для U1).

$ChannelPrefix

Логическое обозначение символа листа.

$ChannelIndex

Индекс, указанный для отличия различных каналов.

$ChannelAlpha

Индекс канала, выраженный буквенным символом. Этот формат полезен, только если проект содержит в общей сложности менее 26 каналов либо если вы используете иерархический формат обозначений.

$SheetDesignator

Обозначение, присвоенное символу листа.

$SheetNumber

Номер листа, присвоенный листу. Если скомпилированные листы были аннотированы, будет использоваться эта информация.

$DocumentNumber

Номер документа, указанный в опциях документа.

$GlobalIndex

Индекс, заданный пользователем. Вы можете указать порядок, начальный индекс и/или суффикс в опциях глобального индекса каждого документа схемы. Эти опции отображаются в диалоговом окне Board Level Annotation Options. Глобальный индекс вычисляется для всех компонентов без позиционного обозначения. Если вы добавляете новые компоненты после выполнения аннотирования на уровне платы, эти компоненты будут аннотированы с новым глобальным индексом, а у существующих компонентов глобальный индекс сохранится. Чтобы выполнить повторное вычисление глобального индекса для всех компонентов, нажмите сначала Reset All.

Либо, если вы хотите указать пользовательское имя для всех компонентов или отдельного компонента, снимите флажок Apply в столбце Naming Scheme, чтобы отключить схему именования для выбранных компонентов и измените столбец PCB Component Instance.

Annotate (Аннотировать)

Чтобы завершить аннотирование на уровне платы:

  • Нажмите по выпадающему меню кнопки Annotate и выберите, хотите ли вы аннотировать компоненты без обозначений (Annotate Undesignated), аннотировать все компоненты (Annotate All) или аннотировать выделенные компоненты (Annotate Selected).
  • Столбец обновится, и каждый компонент будет аннотирован соответствующим обозначением.
  • Нажмите кнопку Accept Changes (Create ECO). Будет открыто диалоговое окно Engineering Change Order, которое позволит провести валидацию и выполнение ECO и получить отчет.
  • Нажмите кнопку Execute Changes, затем кнопку Close, чтобы выполнить аннотирование на уровне платы.
  • Нажмите кнопку Close в диалоговом окне Board Level Annotate. Файл *.Annotation будет обновлен, и вы сможете увидеть аннотирование на уровне платы в документах. Чтобы завершить аннотирование на уровне платы, синхронизируйте документы схем с документами плат с помощью команды Design » Update PCB Document <ИмяФайла>.

Reset All (Сбросить все)

Используйте кнопку Reset All в диалоговом окне Board Level Annotate, чтобы сбросить все позиционные обозначения до имен по умолчанию для скомпилированных компонентов. После сброса компонентов, в столбце Prefix будет отображена иконка компонента со знаком вопроса , чтобы показать, что у компонента теперь нет обозначения.

Back Annotation (Обратное аннотирование)

После нажатия кнопки Back Annotate будет открыто диалоговое окно Choose WAS-IS File for Back-Annotation from PCB, где вы можете выбрать файл для аннотирования. Обратное аннотирование для аннотирования на уровне платы выполняет то же самое, что аннотирование на уровне схемы.

Обратите внимание, что обратное аннотирование является устаревшим инструментом и лучше использовать Design » Update для передачи изменений аннотирования из платы обратно в схему.

Аннотирование скомпилированных листов

Вы можете аннотировать скомпилированные листы с помощью команды Tools » Annotation » Annotate Compiled Sheets. Эта функция позволяет уникальным образом именовать документы (физическое представление проекта). Эти значения отображаются в специальную строку SheetNumber, и они хранятся в файле *.Annotation. Этот файл отображается в подпапке Settings\Annotation Documents в панели Projects, поэтому эта информация об аннотировании сохраняется при закрытии проекта. Команда Annotate Compiled Sheets воспринимает листы устройств так же, как любые другие листы в проекте, и аннотирует их в соответствии с опциями аннотирования.

Опции аннотирования скомпилированных листов

Нажмите по выпадающему меню кнопки Annotate Sheet, чтобы открыть опции аннотирования скомпилированных листов.

Numbering Order (Порядок нумерации)

  • Display Order – листы будут аннотированы в том порядке, в котором они отображаются.
  • Sheets Hierarchical Structure - Depth First – листы будут аннотированы с верхнего уровня в каждой ветви. Сначала нумеруется верхний уровень, после чего полностью нумеруется первая ветвь под первым уровнем, затем вторая ветвь и т.д.

    Вид навигатора проекта отображает скомпилированное (физическое) представление листов. При аннотировании проекта в режиме Depth First вы за раз аннотируете отдельную ветвь в структуре иерархии.

  • Sheets Hierarchical Structure - Breadth First – листы будут аннотированы в соответствии с их уровнем в иерархии. Сначала нумеруется верхний уровень, затем нумеруются все вторые уровни и т.д.

    Вид навигатора проекта отображает скомпилированное (физическое) представление листов. При аннотировании проекта в режиме Breadth First вы аннотируете листы на основе их положения в иерархии, т.е. сначала будет аннотирован верхний лист, затем все листы второго уровня.

Numbering Method (Метод нумерации)

Выберите, хотите ли вы осуществить компиляцию скомпилированных листов по возрастанию (Increasing) или по убыванию (Decreasing) в соответствии с выбранным порядком нумерации (Numbering Order).

Annotate Sheet (Аннотировать лист)

После определения опций:

  • Нажмите кнопку Annotate Sheet. Поле Sheet Number будет обновлено в соответствии с заданными настройками.
  • Нажмите OK, чтобы принять изменения.

Пользовательское аннотирование скомпилированных листов

Вы можете создать пользовательские имена скомпилированных листов путем ввода непосредственно в поле Sheet Number. Вы можете использовать любые комбинации буквенно-цифровых и небуквенно-цифровых символов. После ввода пользовательских имен нажмите OK, чтобы применить пользовательское аннотирование.

Использование аннотирования скомпилированных листов схем в аннотировании на уровне платы

После аннотирования скомпилированных листов используйте ключевое слово $SheetNumber в схеме именования при выполнении аннотирования на уровне платы для использования этой информации в аннотировании. Если вы не аннотировали скомпилированные листы, будет использоваться информация о нумерации листов схем (Tools » Number Schematic Sheets).

Использование аннотирования скомпилированных листов в проекте

После аннотирования скомпилированных листов вы можете разместить в проекте специальную строку SheetNumber для ссылки на эту информацию.

  • Специальная строка отображается всегда. Если значение отсутствует, будет отображено имя параметра.
  • Разместите специальную строку со значением =SheetNumber для использования значений аннотирования скомпилированных листов. Вы можете использовать специальные строки в значениях свойств параметров, текстовых строках, меток цепей и т.д.

Аннотирование на уровне платы и листы устройств

Листы устройств можно повторно использовать в разных проектах. В большинстве случаев, названия компонентов на листах устройств ограничены областью действия этого листа, и для них необходимо использовать аннотирование на уровне платы для включения в проект, в котором они размещены.

Аннотирование на уровне платы применимо к листам устройств, поскольку различные листы устройств, включенные в один проект, могут использовать дублирующиеся позиционные обозначения, что приведет к ошибкам компиляции. Аннотирование на уровне платы может исправить конфликтующие имена путем сохранения изменений в файл *.Annotation, который отображается в подпапке Settings\Annotation Documents.

Имена скомпилированных компонентов по умолчанию

Имена по умолчанию необходимы для возможности отличия различных экземпляров физических представлений компонентов. Эти имена по умолчанию отображаются в документах и используются, если вы не выполнили аннотирование на уровне платы для аннотирования скомпилированных (физических) компонентов. При первом запуске диалогового окна Board Level Annotate имена по умолчанию будут отображены в столбце PCB Component Instance.

Имена по умолчанию скомпилированных компонентов также применимы для многоканальных проектов, которые ссылаются на один лист в проекте множество раз. Это выполняется путем размещения в документе схемы множества символов листов, которые ссылаются на один лист, либо путем включения ключевого слова Repeat в обозначение символа листа для создания множества экземпляров листа.

Хотя это упрощает повторение участка схемы, это также создает сложность с точки зрения аннотирования. В многоканальном проекте может быть только один логический экземпляр каждого компонента с собственным уникальным позиционным обозначением, независимо от того, сколько его "копий" существует на плате. Вкладка Multi-Channel диалогового окна Project Options (Project » Project Options) обеспечивает аннотирование каждого канала уникальным образом с помощью имени по умолчанию на основе стиля именования комнаты (Room Naming Style) и формата обозначений имен компонентов (Component Naming Designator Format).

Вкладка Multi-Channel

Комнаты – это области, которые помогают с размещением и аннотированием компонентов в многоканальном проекте. Говоря конкретнее, канал на схеме – это экземпляр повторяемого листа, а на плате каждый канал представлен комнатой. После назначения компонентов комнате они перемещаются вслед за комнатой, что позволяет легко контролировать и идентифицировать отдельные каналы.

Комнаты играют важную роль в обозначениях каналов, что обеспечивает их уникальные имена.

Логические обозначения присваиваются компонентам на виде редактора схем. Физические обозначения присваиваются компонентам, когда они размещены в проекте или при выполнении аннотирования на уровне платы. В многоканальном проекте логические обозначения компонентов в повторяемых каналах могут быть одинаковыми, но у каждого компонента должно быть уникальное физическое обозначение в проекте. Этого можно достичь, добавив название комнаты к имени компонента, как показано в поле Component Naming ниже.

Вкладка Multi-Channel диалогового окна Project Options позволяет вам определить стиль именования комнат (Room Naming Style) и формат обозначений имен компонентов (Component Naming Designator Format) проекта. Путем управления форматом многоканальных обозначений в этом диалоговом окне вы управляете отображением из одного логического компонента на виде редактора схем во множество физических экземпляров на плате. Вкладка разделена на две области: Room Naming и Component Naming.

Вкладка Multi-Channel позволяет гибко настраивать форматы имен по умолчанию в многоканальных проектах.
Вкладка Multi-Channel позволяет гибко настраивать форматы имен по умолчанию в многоканальных проектах.

Room Naming (Именование комнат)

Используйте выпадающее меню Room Naming Style для определения формата именования, который необходим для комнат в проекте. Эти комнаты создаются по умолчанию при передаче данных из схем в плату. Доступны пять стилей – два плоских и три иерархических.

Плоские форматы имен комнат

Иерархические форматы имен комнат

Flat Numeric With Names
Плоский, цифровой с именами

Numeric Name Path
Цифровой путь имени

 

Flat Alpha With Names
Плоский, буквенный с именами

Alpha Name Path
Буквенный путь имени

Mixed Name Path
Смешанный путь имени

Иерархические имена комнат формируются путем конкатенации всех обозначений канализированных символов листов (ChannelPrefix + ChannelIndex) в подходящей иерархии пути канала.

При выборе стиля именования комнат из списка графическое представление будет динамически обновлено для отображения способа именования, которое будет применено к проекту. Крупные заштрихованные области представляют каналы верхнего уровня (или банки), а затененные внутренние области представляют каналы более низкого уровня. При компиляции проекта, для каждого листа в проекте будет создана комната, в том числе для каждого банка и каждого канала более низкого уровня.

Используйте поле Level Separator for Paths для определения нужного символа для разделения информации о пути при использовании иерархического стиля именования. Нет каких-либо ограничения на символ, используемый в качестве разделителя уровне, но один небуквенно-цифровой символ будет проще для чтения.

Component Naming (Именование компонентов)

Существует несколько форматов позиционных обозначений, доступных для именования компонентов. Вы можете выбрать формат или определить свой собственный с помощью корректных ключевых слов. Определите формат именования компонентов, выбрав его из выпадающего списка Designator Format. Существует восемь предопределенных форматов – пять плоских и три, которые могут использоваться в контексте иерархии:

Плоские форматы обозначений

$Component$ChannelAlpha

$Component_$ChannelPrefix$ChannelAlpha

$Component_$ChannelIndex

$Component_$ChannelPrefix$ChannelIndex

$ComponentPrefix_$ChannelIndex_$ComponentIndex

Иерархические форматы обозначений

$Component_$RoomName

$RoomName_$Component

$ComponentPrefix_$RoomName_$ComponentIndex

Плоские форматы обозначений именуют каждое обозначение компонента в линейной прогрессии, начиная от первого канала и не допуская дублирования обозначений. Форматы иерархических проектов включают имя комнаты в позиционное обозначение компонента. Если выбран один из двух плоских стилей Room Naming Style, то стиль обозначений компонентов также будет плоским. Если был выбран иерархический стиль Room Naming Style, позиционное обозначение компонента также будет иерархическим, поскольку в формат будет включена информация о пути.

Определение собственного формата обозначений

Вы можете определить собственный формат обозначений путем ввода корректных ключевых слов непосредственно в поле Designator Format. Вы можете задать любую комбинацию из ключевых слов, приведенных ниже, для определения строки формата.

Ключевое слово

Определение

$RoomName

Имя соответствующей комнаты, определенное стилем, выбранным в поле Room Naming Style.

$Component

Логическое позиционное обозначение компонента (например, U1)

$ComponentPrefix

Префикс логического позиционного обозначения компонента (например, U для U1).

$ComponentIndex

Индекс логического позиционного обозначения компонента (например, 1 для U1).

$ChannelPrefix

Логическое обозначение символа листа.

$ChannelIndex

Индекс, указанный для отличия различных каналов.

$ChannelAlpha

Индекс канала, выраженный буквенным символом. Этот формат полезен, только если проект содержит в общей сложности менее 26 каналов либо если вы используете иерархический формат обозначений.

Стиль именования комнат Room Naming Style применим к именованию компонентов, только если строка $RoomName включена в формат обозначений Designator Format.

Отображение физических имен в документах

Создание проекта осуществляется на вкладке Editor. Скомпилированные документы (физическое представление проекта) можно отобразить, щелкнув ЛКМ по вкладке Compiled Document, расположенной под рабочей областью документа схемы.

Пример вкладок рабочей области.
Пример вкладок рабочей области.

Вы можете задать настройки отображения физических имен в скомпилированных документах на странице Schematic - Compiler диалогового окна Preferences. В области Compiled Names Expansion включите отображение скомпилированных (физических) имен для позиционных обозначений (Designators), меток цепей (Net Labels), портов (Ports), номеров листов (Sheet Number) и/или номеров документов (Document Number).

Вы также можете использовать соответствующие выпадающие меню для выбора способа отображения объектов. Доступные варианты выбора: Never display superscript (расширенные имена никогда не отображаются), Always display superscript (расширенные имена всегда отображаются) или Display superscript if necessary (расширенные имена отображаются, только если они отличаются от исходных).

Опции верхних надписей применимы как ко вкладке Editor, так и ко вкладкам Compiled Document. На вкладке Editor скомпилированные имена отображаются в верхних надписях и на вкладках Compiled Document логическое имя (имя на вкладке Editor) отображается в верхней надписи.

Используйте команду Design » Update PCB Document для запуска процесса передачи, который автоматически создаст класс компонентов для каждого листа схемы в проекте, комнату для каждого класса компонентов и группу компонентов в каждом классе в соответствующих комнатах, готовую к размещению.

Аннотирование платы

Позиционное аннотирование на плате

Ключевым элементом успешного проектирования платы является размещение компонентов. В большом проекте положение компонента на плате может не иметь отношения к его позиционному обозначению. Например, R1 может находиться на другом конце платы от R2. Чтобы упростить поиск компонентов на плате, вы можете переопределить позиционные обозначения (повторно аннотировать плату) на основе положения компонентов. Для планомерного назначения позиционных обозначений в редакторе плат на основе их положения выберите команду Tools » Re-Annotate, чтобы открыть диалоговое окно Positional Re-Annotate, показанное ниже.

Диалоговое окно Positional Re-Annotate включает в себя графическое представление каждого метода.
Диалоговое окно Positional Re-Annotate включает в себя графическое представление каждого метода.

Каждый компонент определяется своим граничным прямоугольником, в который не входят строки. Компоненты сортируются в список, и нумерация в этом списке переопределяется для создания новых обозначений компонентов. Для сравнения двух компонентов по оси X используется левая сторона граничного прямоугольника. Для сравнения двух компонентов по оси Y используемая сторона зависит от направления перенумерации: при возрастании по оси Y используется нижняя сторона, при убывании по оси Y используется верхняя сторона.

Опцию Comparison Threshold можно использовать в качестве буферного значения при сравнении двух сторон для определения, являются ли они равными. Например, если левые стороны двух компонентов находятся на расстоянии 75 милов друг от друга, а порог сравнения задан 100 милов, то считается, что эти два компонента находятся в одном положении X (их левые стороны). Это позволяет перенумеровывать несколько смещенные компоненты в логическом порядке, как показано на изображении ниже. Здесь R27 находится ниже, чем другие резисторы, для поддержания его корректного аннотирования с соседними резисторами (значение Comparison Threshold задано 10mils).

Ряд резисторов, которые были повторно аннотированы на основе положения. Обратите внимание, что R27 сохранил последовательность аннотирования, хотя он находится ниже, чем другие резисторы.Ряд резисторов, которые были повторно аннотированы на основе положения. Обратите внимание, что R27 сохранил последовательность аннотирования, хотя он находится ниже, чем другие резисторы.

Опции Annotate Scope также позволяет управлять процессом аннотирования платы с компонентами, размещенными на обеих сторонах платы. Компоненты на нижней стороне платы аннотируются так, если бы вы смотрели на перевернутую плату. Соответственно, для сравнения по оси X на обратной стороне система использует правый край граничного прямоугольника, помня, что при просмотре с обратной стороны этот край будет выглядеть как левый.

Если включена опция Selected Only и при повторном аннотировании выделенному компоненту задается позиционное обозначение, дублирующее обозначение существующего невыделенного компонента, то к позиционному обозначению невыделенного компонента будет добавлено _1, чтобы обеспечить уникальность всех обозначений.

Обратите внимание, что повернутый компонент определяется наименьшим граничным прямоугольником, который описывает изначальный граничный прямоугольник в его новом положении, как показано ниже.

На первом изображении показан граничный прямоугольник R2. На втором изображении показан новый граничный прямоугольник, когда R2 повернут. На первом изображении показан граничный прямоугольник R2. На втором изображении показан новый граничный прямоугольник, когда R2 повернут.На первом изображении показан граничный прямоугольник R2. На втором изображении показан новый граничный прямоугольник, когда R2 повернут.

В папке документа платы формируется текстовый ASCII-файл (DesignName[Дата][Время].WAS). В файле приводится список начальных и повторно аннотированных позиционных обозначений. После выполнения в плате повторного аннотирования вы можете передать изменения в схему с помощью команды Design » Update. Также для загрузки изменений в схему можно использовать файл *.WAS, если файлы платы и схемы находятся в разных расположениях.

Чтобы предотвратить повторное назначение позиционного обозначения компонента, поставьте флажок Protect Locked Designators в диалоговом окне Positional Re-Annotate и убедитесь, что в соответствующей панели Properties включена иконка блокировки Strings, как показано ниже.

Управление отображением позиционного обозначения на плате

Размещение на плате строк расширенных обозначений в многоканальном проекте может быть утомительным. Вы можете выбрать опции именования, при которых будут отображены короткие имена, или отображать вместо них изначальные логические обозначения компонентов. Например, C30_CIN1 может быть отображен как C30. При этом понадобится добавить на плату некоторые другие обозначения отдельных каналов, например, границы вокруг каналов на слое шелкографии.

Вы можете выбрать отображение на плате логических или физических обозначений с помощью выпадающего меню Designator Display в разделе Other в панели Properties в режиме Board. Если вы выберите отображение логических обозначений компонентов в многоканальном проекте, они будут отображены на плате и во всех сформированных выходных документах, таких как распечатки и файлы Gerber. Однако при формировании состава изделия (Bill of Materials) всегда используются уникальные физические обозначения.

Синхронизация проекта – Завершение процесса аннотирования

Для поддержания соответствия обозначений на схеме и на плате предпочтительным методом является прямая синхронизация, если у вас есть доступ как к редактору схем, так и к редактору плат. Синхронизация проектов сравнивает компоненты и связность схемы непосредственно с платой и формирует список различий. Список изменений, требуемых для устранения этих различий, формируется в виде запроса на инженерные изменения (ECO, Engineering Change Order). Файл ECO описывает различия между текущим и нужным состояниями проекта, и его можно применить для синхронизации проекта.

Прямая и обратная синхронизация

Термины "прямая синхронизация" и "обратная синхронизация" описывают направление, в котором передается аннотирование и проектные изменения при синхронизации данных. Если представлять процесс проектирования, который начинается со схемы и управляется ей, то прямая синхронизация – это процесс передачи изменений, сделанных в редакторе схем, в плату. Обратная синхронизация – это процесс передачи изменений, сделанных в плате, в редактор схем.

Прямая синхронизация

Некоторые причины, по которым следует применять синхронизацию из схемы в плату:

  1. В редактор схем добавлен новый компонент, и он нужен в плате.
  2. Вы аннотировали схему первый раз или изменили аннотирование с момента последней синхронизации.
  3. В многоканальном проекте вы поменяли опции проекта (Project Options) для изменения стиля физического именования.
  4. Вы выполнили аннотирование на уровне платы первый раз или изменили аннотирование с момента последней синхронизации.

Для синхронизации проекта из схемы в плату

Для синхронизации проекта из схемы в плату выберите один из следующих способов:

  1. Выберите команду Design » Update PCB Document из главного меню редактора схем. Если есть какие-либо различия между схемой и целевым документом платы, будет открыто диалоговое окно Engineering Change Order со списком изменений, необходимых для синхронизации платы и схемы. Нажмите Execute Changes для синхронизации проекта.
  2. Выберите команду Design » Import Changes из главного меню редактора плат, что импортирует изменения из документов схем в документ платы.

Обратная синхронизация

Обратная синхронизация выполняется, когда вы аннотировали или изменили плату и хотите обновить схему.

Для синхронизации проекта из платы обратно в схему

Для синхронизации проекта из платы обратно в схему выберите один из следующих способов:

  1. В редакторе плат выберите команду Design » Update Schematics из главного меню. По умолчанию на вкладке ECO Generation диалогового окна Project Options включена опция Push Component Designator Changes to Annotation File (if any), поэтому изменения, сделанные в редакторе плат, будут переданы только в файл аннотирования и, в конечном итоге, в скомпилированные документы при компиляции. Отключение эту опцию для передачи изменений только в исходный документ схемы (вид Editor).

  2. В редакторе схем выберите команду Tools » Annotation » Annotate Schematics, затем нажмите кнопку Back Annotate в диалоговом окне Annotate. Выберите файл WAS-IS, сформированный при повторном аннотировании обозначений в среде платы.

    Это устаревший инструмент. Предпочтительным способом синхронизации проекта является использование команды Design » Update Schematics.
  3. В редакторе схем выберите команду Tools » Annotation » Board Level Annotate, затем нажмите кнопку Back Annotate в диалоговом окне Board Level Annotate. Выберите файл WAS-IS, сформированный при повторном аннотировании обозначений в среде платы.

    Это устаревший инструмент. Предпочтительным способом синхронизации проекта является использование команды Design » Update Schematics.
  4. В редакторе схем выберите команду Tools » Annotation » Back Annotate Schematics. Выберите файл WAS-IS, сформированный при повторном аннотировании обозначений в среде платы.

    Это устаревший инструмент. Предпочтительным способом синхронизации проекта является использование команды Design » Update Schematics.
    Команда Back Annotate Schematics синхронизирует изменения аннотирования, выполненные в редакторе плат, со схемой. Эта возможность полезна, если невозможно одновременно открыть схему и плату, например, при разработке схемы и платы людьми в разных расположениях.

Традиционные способы синхронизации

Altium NEXUS поддерживает традиционное использование промежуточного файла (список цепей и WAS/IS) для синхронизации проекта. Прямая синхронизация данных аннотирования может быть выполнена путем использования файла списка цепей, а обратная синхронизация может быть выполнена путем использования файла WAS/IS (со списком предыдущего и текущего состояния каждого обозначения). Предпочтительным способом синхронизации является прямая синхронизация проекта.

Связывание компонентов с помощью уникальных идентификаторов

Если вы повторно аннотировали проект, позиционные обозначения компонентов на схеме или скомпилированные позиционные обозначения компонентов больше не совпадают с позиционными обозначениями компонентов на плате, поэтому для успешного завершения проекта необходима синхронизация проекта. Вместо того, чтобы полагаться на само позиционное обозначение в качестве ключевого поля, которое связывает схемный символ с соответствующим посадочным местом, Altium NEXUS может поддерживать синхронизацию проекта с помощью системы уникальных идентификаторов (UID). Уникальный идентификатор – это сформированное системой значение, которое уникальным образом идентифицирует исходный компонент и сопоставляет каждый компонент на схеме с соответствующим компонентом на плате.

Когда компонент размещается на листе схемы, ему автоматически назначается UID. При передаче информации о компонентах из исходных документов схемы в пустую плату информация о UID из каждого компонента на схеме назначается соответствующему компоненту на плате.

Реструктуризация позволяет преобразовывать листы устройств в листы схем и наоборот с сохранением уникальных идентификаторов листа и его компонентов. Кроме того, вы можете переместить участок цепи на другой лист схемы в текущем проекте, сохранив уникальный идентификатор участка цепи. Команда реструктуризации Refactor расположена в меню Edit.

Функциональная возможность синхронизации Altium NEXUS, запускаемая при выборе команды Design » Update, использует эти UID для сопоставления каждого компонента на схеме с его эквивалентом на плате. Затем обновления/изменения проекта могут быть применены с помощью запросов на инженерные изменения (ECO). В ECO приведен список всех изменений, необходимых для применения к одному или множеству проектных документов для синхронизации. Запросы ECO используются для обновления проекта в различных ситуациях, таких как:

  1. Передача обновлений из схемы в плату.
  2. Выполнение обновлений аннотирования обозначений компонентов на схеме и скомпилированных обозначений компонентов.
  3. Применение изменений к параметрам с помощью Parameter Manager (Tools » Parameter Manager).
  4. Обновление информации о параметрах информацией, сохраненной в исходных библиотеках или в базе данных предприятия. При сравнении схемы и платы (например, при выборе команды Design » Update) Altium NEXUS сначала сопоставляет компоненты с общим UID. При обнаружении компонентов без общего UID вы получите сообщение об этом, и приложение предложит попробовать сопоставить их по позиционным обозначениям. Пока вы не назначите соответствующие UID для схемы и платы, вы продолжите получать это сообщение. Управление уникальными идентификаторами и их взаимосвязью осуществляется в диалоговом окне Edit Component Links (Project » Component Links).

    Обратите внимание, что это диалоговое окно можно открыть, когда активен документ платы, поскольку изменения UID всегда применяются к плате, а не к схеме. Используйте это диалоговое окно на любой стадии проектирования для просмотра связи между компонентами и проверки того, что компоненты сопоставлены между схемой и платой, а также для назначения соответствующих UID несопоставленным компонентам.

Если вы планируете повторно аннотировать схему или плату, сначала важно убедиться, что идентификаторы UID сопоставлены, поскольку при изменении всех позиционных обозначений на схеме или плате идентификатор UID будет единственной информацией, которую можно использовать для связывания компонента на схеме с его эквивалентом на плате.
Обнаружили проблему в этом документе? Выделите область и нажмите Ctrl+Enter, чтобы оповестить нас.

Связаться с нами

Связаться с нашими Представительствами напрямую

We're sorry to hear the article wasn't helpful to you.
Could you take a moment to tell us why?
200 characters remaining
Вы сообщаете о проблеме, связанной со следующим выделенным текстом
и/или изображением в активном документе: