Altium NEXUS Documentation

Настройка распечаток платы_AD

Created: 10.06.2021 | Updated: 11.06.2021

Вывод распечаток проекта платы в Altium NEXUS доступен путем создания файла OutputJob (*.OutJob). Для вывода доступен ряд производственных документов, в том числе общие двумерные распечатки, такие как составные чертежи и схемы. Вывод 2D-распечатки настраивается в диалоговом окне PCB Printout Properties. 3D-распечатка платы настраивается в диалоговом окне PCB 3D Print Settings.

Чтобы создать новый файл OutputJob, выберите команду File » New » Output Job File главного меню. Новый файл будет открыт в окне редактора OutJob.

Настройка заданий на вывод данных настраивается в файле OutJob, что предоставляет вам полный контроль над выводом распечаток.
Настройка заданий на вывод данных настраивается в файле OutJob, что предоставляет вам полный контроль над выводом распечаток.

Настройка вывода 2D-распечаток

Когда вы готовы распечатать документацию из файла OutJob, вызовите диалоговое окно PCB Printout Properties (щелкните ПКМ по нужному заданию и выберите Page Setup, чтобы открыть соответствующее диалоговое окно Print Properties, и нажмите кнопку Advanced). В открывшемся диалоговом окне PCB Printout Properties вы можете определять распечатки и управлять ими для определенной документации, которую вы хотите сформировать.

Основная область диалогового окна разделена на три столбца:

  • Printouts & Layers – здесь приведен список заданных распечаток и входящих в них слоев.
  • Include Components – позволяет управлять, какие компоненты включены в соответствующую распечатку.

    Опция Include Components ориентирована на компоненты (для поверхностного или сквозного монтажа). Поэтому механические слои, используемые в посадочных местах, должны быть добавлены в пары, если эти слои используются для создания распечаток.
  • Printout Options – позволяет задать дополнительные опции для соответствующей распечатки.

Добавление новой распечатки

Новую распечатку можно добавить в текущую конфигурацию с помощью команды Insert Printout из контекстного меню диалогового окна PCB Printout Properties.

Распечатка будет добавлена ниже существующих распечаток и ей будет задано название по умолчанию New PrintOut 1. По умолчанию будут включены все опции в столбце Include Components.

Дважды щелкните ЛКМ по распечатке, чтобы открыть диалоговое окно Printout Properties, в котором вы можете настроить свойства распечатки/набора распечаток.

Настройка распечатки

Вновь добавленная распечатка может быть настроена (и настройки существующей распечатки могут быть изменены) в соответствующем диалоговом окне Printout Properties. Вызов этого диалогового окна осуществляется двойным щелчком ЛКМ по полю названия распечатки (в столбце Printouts & Layers) либо щелчком ПКМ по полю названия и выбором Properties из открывшегося меню.

  • Поле Printout Name позволяет изменить название распечатки нужным образом, чтобы задать более осмысленное название для быстрого определения сути и назначения распечатки. Вы также можете изменить название распечатки непосредственно в диалоговом окне PCB Printout Properties. Щелкните ЛКМ один раз по полю названия нужной распечатки для ввода нового названия.
  • Раздел Components позволяет управлять, какие компоненты включены в распечатку. Например, если распечатка относится только к слоям на верхней стороне платы, вам может понадобиться отобразить только компоненты на верхнем слое и компоненты, у которых есть контактные площадки на верхних и нижних слоях (например, краевые разъемы платы).
  • Раздел Options предлагает расширенные опции распечатки, такие как использование подстановки шрифта, если для распечатки используются альтернативные шрифты вместо трех шрифтов по умолчанию, используемых в редакторе плат (Default, Serif, Sans Serif). Настройка использования этих шрифтов осуществляется в диалоговом окне PCB Print Preferences (см. раздел Определение настроек печати).
  • Раздел Pad Display Options предлагает опции, которые позволяют управлять отображением контактных площадок в распечатке, т.е. отображением номером контактных площадок и связанных цепей и размером шрифта, используемого для текста.
  • Раздел Layers является самой сутью настройки распечаток, где доступны необходимые элементы управления для добавления, редактирования, упорядочения слоев, которые составляют распечатку. При добавлении нового слоя (нажмите Add) или редактирования существующего (нажмите Edit) будет открыто диалоговое окно Layer Properties, в котором вы можете настроить слой нужным образом.
Новый дополнительный слой добавляется в конец списка слоев. Это значит, что этот слой будет отрисован в памяти принтера первым при формировании изображения. Затем будут по очереди формироваться изображения выше. Используйте кнопки Move Up и Move Down для изменения положения слоя в порядке отрисовки.

Добавление нового слоя

Новый слой может быть добавлен в распечатку одним из следующих способов:

  • При настройке родительской распечатки с помощью диалогового окна Printout Properties – используйте кнопку Add, чтобы добавить новый слой в список Layers. Новый слой появится в конце списка, но вы можете изменить порядок слоев с помощью элементов управления в этом диалоговом окне.
  • Непосредственно из диалогового окна PCB Printout Properties – щелкните ПКМ в области распечатки, в которую вы хотите добавить новый слой, и выберите Insert Layer из открывшегося меню. Новый слой будет добавлен ниже всех существующих слоев этой распечатки. Вы не можете изменить порядок слоев в диалоговом окне PCB Printout Properties, это можно сделать только в диалоговом окне Printout Properties.

Настройка слоя

Вновь добавленный слой может быть настроен (и настройки существующего слоя могут быть изменены) в соответствующем диалоговом окне Layer Properties. Диалоговое окно открывается при добавлении нового слоя. Вызвать диалоговое окно для существующего слоя можно следующими способами:

  • Откройте диалоговое окно Printout Properties родительской распечатки, выберите слой и нажмите кнопку Edit.
  • Дважды щелкните ЛКМ по названию слоя в столбце Printouts Layers диалогового окна PCB Printout Properties.

Если вы добавляете в распечатку новый слой, сначала выберите слой, который вы хотите добавить, в выпадающем списке Print Layer Type. Этот список содержит все заданные слои исходного документа платы, что позволяет включить в распечатку любой слой платы. В центральной части диалогового окна доступны элементы управления для определения того, как примитивы этого слоя должны отображаться в распечатке – в полном режиме (Full), контуром (Draft) или они должны быть отключены (Hide). Это позволяет полностью управлять тем, что будет отображено на распечатанной странице.

В качестве примера рассмотрим сборочный чертеж, который включает следующие слои:

  • Шелкография компонентов
  • Верхний слой (для контактных площадок поверхностного монтажа)
  • Слой Multi-Layer (для контактных площадок сквозного монтажа)

Верхний слой может быть настроен для отображения примитивов компонентов, чтобы контактные площадки для поверхностного монтажа были видны, и скрытия свободных примитивов, чтобы трассировка не была видна. Слой Multi-Layer также может быть настроен для отображения примитивов компонентов, чтобы сквозные контактные площадки компонентов были видны, и скрытия свободных примитивов, чтобы переходные отверстия не были видны.

Определение настроек печати

Нажмите кнопку Preferences в нижней левой части диалогового окна PCB Printout Properties, чтобы открыть диалоговое окно PCB Print Preferences. Все опции, заданные в этом диалоговом окне, применяются ко всем распечаткам, которые могут быть сформированы.

Colors & Gray Scales – Цвета и оттенки

Этот раздел позволяет управлять цветами всех возможных слоев, которые могут быть выведены на печать. Для каждого слоя вы можете определить цвет, используемый при печати, в оттенке серого или в цвете. Щелкните ЛКМ по левой цветовой иконке, чтобы выбрать оттенок серого.

Щелкните ЛКМ по правой цветовой иконке, чтобы открыть диалоговое окно Choose Color, где вы можете выбрать один из предопределенных цветов или задать пользовательский цвет.

Нажмите кнопку Retrieve Layer Colors From PCB в диалоговом окне PCB Print Preferences, если вы хотите вывести распечатку с теми же цветами, которые настроены для платы в редакторе плат.

Эта функция перезапишет цвета в правых цветовых иконках для всех слоев. Определения цветов в оттенках серого останутся неизменными, пока вы не измените их вручную. Для вывода на печать в цвете или в оттенках серого должна быть включена соответствующая опция Color или Gray в диалоговом окне настройки страницы для выходного документа печати. Также должен быть настроен режим цвета печати для указанного устройства печати в соответствующем диалоговом окне свойств.

Include on New Printouts – Включить в новые распечатки

Помимо добавления механических слоев в распечатку по отдельности, вы также можете автоматически включить их во все распечатки при отправке заданий на печать для родительского типа документа на указанное устройство печати. Используйте этот раздел диалогового окна для включения/отключения механических слоев для печати.

Font Substitutions – Подстановки шрифтов

Каждый из трех стандартных шрифтов, используемых в редакторе плат (Default, Serif и Sans Serif), может быть заменен на другой шрифт Windows при формировании распечатки. Используйте опции в этом разделе диалогового окна, чтобы указать и включить подстановки шрифтов.

Нажмите кнопку возле поля нужного шрифта, чтобы открыть стандартное для Windows диалоговое окно Font, в котором вы можете выбрать нужный подстановочный шрифт.

При нажатии OK название шрифта будет добавлено в поле шрифта.

Подстановкой шрифтов (независимо от того, включены или отключены они в диалоговом окне PCB Print Preferences на глобальном уровне) можно управлять на уровне отдельных распечаток для каждого отдельного выходного документа печати с помощью опции Enable Font Substitution в соответствующем диалоговом окне Printout Properties.

Options – Опции

Опция Print Keepout Objects позволяет управлять тем, следует ли включать в распечатанный документ проектные объекты, назначенные как области Keepout.

Включите опцию Use Net override color, если вы хотите использовать цвет переопределения цепей в распечатке.

Контекстное меню

В контекстном меню, которое вызывается из любого места в диалоговом окне PCB Printout Properties, доступны следующие команды:

  • Create Final – используйте для быстрого создания полного предопределенного набора распечаток для фотошаблонов из исходного документа платы.
  • Create Composite – используйте для быстрого создания предопределенной многослойной составной распечатки из исходного документа платы.
  • Create Power-Plane Set – используйте для быстрого создания предопределенных чертежей экранов питания из исходного документа платы.
  • Create Mask Set – используйте для быстрого создания предопределенных чертежей паяльной маски и паяльной пасты из исходного документа платы.
  • Create Drill Drawings – используйте для быстрого создания предопределенного набора чертежей сверловки из исходного документа платы.
  • Create Assembly Drawings – используйте для быстрого создания предопределенных сборочных чертежей из исходного документа платы.
  • Create Composite Drill Guide – используйте для быстрого создания предопределенного составного чертежа сверловки из исходного документа платы.
  • Insert Printout – используйте для вставки новой распечатки для настраиваемого в данный момент вывода на печать.
  • Insert Printout Set – используйте для создания распечатки, которая будет включать в себя все слои, объединенные в один слой. Затем могут быть добавлены дополнительные слои и классы слоев.
  • Insert Drill Printout Set – используйте для создания новой распечатки сверловки. Затем в распечатку сверловки могут быть добавлены слои и классы слоев.
  • Insert Layer – используйте для вставки нового слоя в распечатку в фокусе. Слой будет добавлен в конец текущего списка слоев, которые существуют в этой распечатке.
  • Insert Layer Class – используйте для вставки нового класса слоев в распечатку в фокусе.
  • Move Up – используйте для перемещения объектов вверх в столбце.
  • Move Down – используйте для перемещения объектов вниз в столбце.
  • Delete – используйте для удаления слоя в фокусе из родительской распечатки или распечатки в фокусе из настраиваемого задания на печать. Будет запрошено подтверждение на удаление. Вы не сможете удалить все слои из распечатки и все распечатки из задания на печать.
  • Properties – используйте для вызова диалогового окна Layer Properties или диалогового окна Printout Properties, в зависимости от того, что находится в фокусе – слой или распечатка.
  • Preferences – используйте для вызова диалогового окна PCB Print Preferences, в котором вы можете определить глобальные опции, применимые ко всем заданиям на печать.

Настройка вывода 3D-распечаток

Диалоговое окно PCB 3D Print Settings позволяет вам выбрать или создать 3D-распечатки платы для включения в файл OutJob. Помните, что вы можете создать множество экземпляров любой распечатки (для этого используйте Add New Documentation Output из раздела Output Containers в файле OutJob), что особенно полезно для 3D, поскольку может понадобиться распечатать представления платы с различных ракурсов.

Диалоговое окно содержит четыре раздела:

  • Render Resolution – включает в себя опции для определения качества изображения 3D-модели для печати. Доступные разрешения не зависят от принтера.
  • View to Print – позволяет выбрать вид платы сверху или снизу (т.е. когда камера перпендикулярна плате) или пользовательский вид (Custom).
  • View Configuration – позволяет применить текущую конфигурацию вида ко внешним слоям, видимости, прозрачности и толщине платы.
  • Preview – показывает, что именно будет напечатано.

Создание пользовательских 3D-распечаток

В пользовательском виде плата может быть повернута, приближена, иметь различные настройки цветов внешних слоев, видимости, прозрачности и толщины платы. Вы можете использовать эти опции для формирования видов, где будут подробно показаны нужные области конструкции.

Для создания пользовательского 3D-вида платы в виде распечатки выполните следующие шаги:

  1. Перейдите в окно редактора плат и переключитесь в 3D-режим (клавиша 3).
  2. Используйте элементы управления 3D-видом, чтобы добиться нужной перспективы.
  3. Вернитесь в файл OutJob и дважды щелкните ЛКМ по строке PCB 3D Print (или щелкните ПКМ по ней и выберите Configure из меню), чтобы открыть диалоговое окно PCB 3D Print Settings.
  4. Выберите опцию Custom, затем нажмите кнопку Take Current Camera Position. Перспектива будет обновлена в области Preview.
  5. Нажмите OK, чтобы применить пользовательскую настройку к текущей 3D-распечатке платы.

Если вы хотите применить пользовательские цвета внешних слоев и т.д. выполните следующее:

  1. Перейдите в окно редактора плат и откройте панель View Configuration. Для этого выберите команду View » Panels » View Configuration из главного меню, нажмите кнопку Panels внизу слева от проектной области и выберите View Configuration или используйте клавишу L.
  2. Задайте нужные опции. Обратите внимание, что не нужно сохранять опции, чтобы применить их к 3D-рапечатке платы.
  3. Вернитесь в файл OutJob, откройте диалоговое окно PCB 3D Print Settings, включите опцию Custom и нажмите кнопку Take Current View Configuration. Новые настройки будут отражены в области Preview. После применения конфигурации вида она будет применена ко всем опциям View to Print.
  4. Нажмите OK, чтобы применить конфигурацию вида к текущей 3D-распечатке платы.
  5. Сохраните файл OutJob с новыми 3D-распечатками.

Советы

Вывод на печать может быть сформирован следующими способами:

  • С помощью настроенного генератора выходных документов, заданного в файле Output Job (*.OutJob) – вывод будет сформирован при запуске настроенного генератора выходных документов.
  • Непосредственно из активного документа платы с помощью команды File » Print – вывод будет сформирован для включенного в данный момент набора печати по умолчанию.

    При формировании вывода непосредственно из редактора плат с помощью команды File » Print будут использоваться настройки, отличные от тех, которые заданы в файле OutJob. В этом случае, используйте вкладку Default Prints диалогового окна Project Options (Project » Project Options) для настройки конфигурации печати по умолчанию и разметки страницы для каждого выходного документа печати, который может быть сформирован.

Заданные здесь опции не зависят от опций, заданных для того же типа выходных документов в файле Output Job. В первом случае настройки хранятся в файле проекта, во втором – в файле Output Job.

Опции, связанные с меню File редактора плат касательно страницы и принтера, тоже определяются отдельно от тех, которые доступны в файле. Опять же, в первом случае настройки хранятся в файле проекта, во втором – в файле Output Job.

Обнаружили проблему в этом документе? Выделите область и нажмите Ctrl+Enter, чтобы оповестить нас.

Связаться с нами

Связаться с нашими Представительствами напрямую

We're sorry to hear the article wasn't helpful to you.
Could you take a moment to tell us why?
200 characters remaining
Вы сообщаете о проблеме, связанной со следующим выделенным текстом
и/или изображением в активном документе: