Altium NEXUS Documentation

Создание схемного символа

Последнее изменение: Pavel Demidov; 25.10.2020

Схемный символ, как правило, включает в себя фигуру, которая отражает назначение компонента, и один или множество выводов. Каким образом представлен компонент, т.е. его вид и расположение выводов, определяет проектировщик. Это необходимо делать в соответствии с требованиями вашего предприятия и принятыми вами стандартами. Один символ компонента может представлять целое физическое устройство, либо компонент можно определить множеством секций, каждая из которых представляет логическую ячейку физического компонента (например, ячейка И в компоненте 4И или катушка и наборы контактов реле). Компоненты этого типа также называется многосекционными.

Создание схемного символа осуществляется путем размещения графических объектов, которые представляют тело компонента, и выводов, которые представляют физические контакты компонента. Схемные символы создаются в библиотеке схемных символов (Schematic Library) редактора библиотек схемных символов Altium с расширением файлов *.SchLib. В библиотеке схемных символов можно создать любое количество символов компонентов. Организация символов в библиотеки должна соответствовать как требованиям предприятия, так и типу библиотеки компонентов, в которой должны находиться символы.

Независимо от способа хранения определений моделей и компонентов, после размещения компонента на схеме он становится унифицированным компонентом. Символ появится на схеме; при его редактировании отображается полный набор параметров компонента, в том числе ссылки на модели и список параметров компонента.

Физический компонент, который монтируется на плату, представляется множеством способов. На схеме компонент представляется логическим символом. В процессе симуляции SPICE используется SPICE-модель; в конструкции платы компонент представляется своим посадочным местом. Каждое из этих представлений называется доменной моделью, и каждый унифицированный компонент является совокупностью своих доменных моделей.

Схемный символ является одной из доменных моделей, которая вместе с другими доменными моделями определяет унифицированный компонент. По сути, схемный символ имеет двойственную природу: он может выступать в роли простой доменной модели, созданной в редакторе библиотек, когда в нем нет ничего, кроме графики и набора выводов, и его также можно использовать как унифицированный компонент с прочими доменными моделями, такими как посадочное место, на которое задана ссылка в редакторе библиотек. Режим, который вы используете, будет зависеть от способа хранения и организации компонентов. Существует ряд способов хранения и организации компонентов, в том числе:

  • Простые библиотеки схемных символов и посадочных мест
  • Интегрированные библиотеки
  • Библиотеки на основе баз данных
  • Управляемые сервером компоненты
Для получения информации о создании управляемых компонентов перейдите на страницу Работа с управляемыми компонентами.

Подготовка рабочей области

Настройка размера листа осуществляется на вкладке General в разделе Page Options панели Properties в режиме Document Options. Перед размещением объектов следует приближать вид, чтобы была видна сетка.


Используйте раздел Page Options панели Properties в режиме Document Options для задания размера листа.

Всегда чертите символ компонента рядом к началом координат листа (центр листа).

Системой единиц измерения по умолчанию для сетки документа схемы и схемной библиотеки является британская. Хотя все компоненты Altium созданы в дюймовой сетке, может быть полезным перейти на метрическую сетку, поскольку может быть сложно корректно соединить компоненты, созданные в различных сетках. Обратите внимание, что дюймовые сетки можно использовать с метрическими размерами листов, такими как A3, поэтому нет необходимости переключаться в метрическую сетку при работе с такими листами. Единицы измерения текущего листа определяются на вкладке General в разделе General панели Properties в режиме Document Options.


Используйте раздел General панели Properties в режиме Document Options, чтобы задать единицы измерения для текущего листа.

Единицы измерения для новых листов (схем и библиотек) определяются на странице Schematic – General диалогового окна Preferences.

Размещение объектов осуществляется в текущей сетке привязки. Текущая сетка отображается внизу рабочей области в левой части строки состояния.

Нажмите клавишу G для циклического переключения между доступными настройками сетки привязки. Эти настройки задаются на странице Schematic – Grids диалогового окна Preferences.


Используйте страницу Schematic – Grids диалогового окна Preferences для определения настроек сетки привязки.

Как правило, объекты и выводы размещаются в сетке 5 мм или 2,5 мм, в то время как строковые объекты можно размещать в более мелкой сетке.

Создание схемного символа

После задания настроек рабочей области необходимым образом следующим шагом является формирование графического представления компонента, т.е. создание графики компонента, которая будет представлять компонент при его размещении на листе схемы. Важно решить, по каким стандартам следует создавать компонент. Это обеспечит единообразие графики символов и согласованность результата. Методология проектирования Altium следует стандарту IEEE 315, который не только охватывает большинство элементов, но и четко определяет, как можно комбинировать полупроводниковые элементы для обозначения любых устройств.

Создание тела символа осуществляется размещением графических объектов в рабочей области редактора схемных символов с помощью меню Place, панели инструментов Utilities или панели Active Bar. Дважды щелкните мышью по размещенному схемному объекту, чтобы открыть панель Properties для дальнейшей настройки объекта.

Altium NEXUS включает в себя ряд замкнутых фигур, в том числе прямоугольник (Rectangle), полигон (Polygon), эллипс (Ellipse) и прямоугольник со скругленными углами (Round Rectangle), как показано ниже.

Линейные фигуры включают в себя дугу (Arc), линию/полилинию (Line/Polyline), линию Безье (Bezier) и эллиптическую дугу (Elliptical Arc). Линии/полилинии могут включать в себя законцовки. Дважды щелкните мышью, чтобы открыть панель Properties для определения этих законцовок.

Настройки свойств всех объектов по умолчанию, такие как ширина и цвет линий, определяются на странице Schematic – Defaults диалогового окна Preferences.


Используйте страницу Schematic - Defaults диалогового окна Preferences для определения свойств схемных объектов по умолчанию.

Свойства объектов также можно редактировать в процессе размещения. Нажмите клавишу Tab для редактирования свойств, когда объект прикреплен к курсору, до размещения объекта. Обратите внимание, что изменения, внесенные в процессе размещения, становятся новыми свойствами по умолчанию, если на странице Schematic - Defaults диалогового окна Preferences не включен параметр Permanent.

Редактирование схемного символа

Для перемещения объекта после его размещения зажмите ЛКМ на объекте и перемещайте мышь для размещения объекта в новое место.

Чтобы изменить размер объекта после его размещения щелкните мышью по объекту, чтобы выделить его и отобразить ручки управления, затем зажмите мышь на одной из этих ручек управления, чтобы изменить размер объекта.

Добавление и удаление вершин из полилиний

Вершины (ручки управления) можно добавлять и удалять из полилиний. Выделите полилинию, зажмите ЛКМ на линии или вершине и нажмите Insert или Delete, чтобы добавить или удалить вершину.

Добавление выводов в символ

Именно выводы компонентов определяют его электрические свойства и точки подключения входных и выходных сигналов. Вывод размещается для представления контакта физического компонента.

Вывод можно разместить в рабочей области документа схемной библиотеки одним из следующих способов. В каждом случае, вывод прикрепляется к курсору электрическим концом. Поверните и/или отразите вывод, если необходимо, и щелкните мышью для размещения.

  • Используйте команду Place » Pin (или последовательность P, P).
  • Нажмите кнопку в выпадающем меню объектов панели инструментов Utilities.
  • Нажмите кнопку на панели Active Bar.
  • Когда панель Properties находится в режиме Component (дважды щелкните по компоненту в рабочей области), нажмите кнопку на вкладке Pins, чтобы открыть диалоговое окно Component Pin Editor, в котором вы можете добавлять (или редактировать) выводы.


    Используйте выделенную кнопку на вкладке Pins панели Properties, чтобы открыть диалоговое окно Component Pin Editor.


    Используйте диалоговое окно Component Pin Editor для добавления (или редактирования) выводов.

Настройка свойств выводов

Нажмите Tab, чтобы открыть панель Properties в режиме Component для редактирования свойств вывода перед его размещением. Числовые значения будут увеличиваться при размещении последующих выводов. Это автоматическое увеличение настраивается в области Auto-Increment During Placement на странице Schematic – General диалогового окна Preferences. Используйте отрицательные значения для автоматического уменьшения.


Используйте страницу Schematic - General диалогового окна Preferences для определения автоматического увеличения значений.

В процессе размещения или перемещения вывода он привязывается к курсору электрическим концом (также называется электрической точкой вывода). Вывод следует размещать таким образом, чтобы его электрическая точка была обращена от тела компонента. Нажимайте Пробел для поворота вывода в процессе его перемещения.

Выводы также можно размещать для представления электромеханических точек компонента, таких как вставка регулятора напряжения.

У вывода есть набор свойств, в том числе название (Name) и обозначение (Designator). Именно обозначение используется для отображения вывода в контактную площадку посадочного места. Расстояние, на котором свойства Designator и Name отображаются от конца вывода, является настройкой редактора схем и схемных символов на системном уровне. Задайте Pin Margin на странице Schematic – General диалогового окна Preferences.

Отдельные настройки для свойства Name можно задать в диалоговом окне Component Pin Editor.

У вывода есть электрический тип (Electrical Type), который используется системой проверки электрических правил Altium для проверки корректности соединений выводов. Задайте этот параметр в диалоговом окне Component Pin Editor в соответствии с электрическим типом этого вывода компонента. Длина вывода Pin Length должна соответствовать выбранной сетке привязки.

Для представления электрической информации вывода можно добавлять символы (Symbols) с помощью диалогового окна Component Pin Editor.

Использование панели SCH Library для создания схемных символов

Создание компонентов осуществляется с помощью объектов в редакторе библиотек схемных символов. Компоненты можно копировать и вставлять из одной библиотеки в другую или из редактора схем в редактор схемных символов.

Общим подходом к созданию символа является копирование компонента из существующей библиотеки. Для этого необходимо:

  1. Открыть исходную библиотеку схемных символов и панель SCH Library (нажмите кнопку Panels в нижней правой части окна приложения и выберите SCH Library из выпадающего меню).
  2. Выберите нужный компонент (или компоненты). Используйте стандартные методики Windows для выделения множества компонентов.
  3. Щелкните ПКМ по выделенному компоненту и выберите команду Copy из контекстного меню.
  4. Откройте целевую схемную библиотеку, щелкните ПКМ где-либо в списке компонентов в панели SCH Library и выберите команду Paste из контекстного меню.

Для создания новой библиотеки схемных символов:

  1. Выберите команду File » New » Library » Schematic Library. Будет открыт пустой документ под названием Schlib1.SchLib, который отображает пустой компонент под названием Component_1.
  2. Нажмите File » Save As и переименуйте и сохраните новый документ схемной библиотеки в подходящее расположение с соответствующим именем.

Используйте панель SCH Library для просмотра и управления символами компонентов открытой схемной библиотеки. Если панель не отображается, нажмите кнопку Panels в правой нижней части окна приложения и выберите SCH Library, чтобы открыть ее.

Определение свойств символа

Свойства символов, такие как позиционное обозначение и описание, редактируются в панели Properties в режиме Component (дважды щелкните по названию компонента в панели SCH Library).


Режим Component панели Properties

  • Если символ компонента был создан как доменная модель, необходимо задать только следующие настройки:
    • Design Item ID – если символ является общим, например, это символ резистора, конденсатора или транзистора, этот параметр можно оставить пустым. Если это специальный символ определенного компонента, отредактируйте параметр, чтобы он отображал строку комментария на схеме необходимым образом. Имейте в виду, что этот параметр также передается на плату.
    • Designator – введите нужный префикс позиционного обозначения со знаком вопроса ?.
    • Description – эта строка полезна при поиске компонента.
  • Если символ компонента не является чисто доменной моделью, необходимо добавить дополнительные параметры. Для общих символов параметр Design Item ID можно использовать для добавления определенного значения (в зависимости от рабочего процесса или концепции библиотеки). Также в раздел Parameters можно добавить дополнительную информацию.

  • Параметр Type определяет тип компонента, который представляет символ. Нестандартный компонент, такой как логотип компании (Graphical) или радиатор (Mechanical), можно создать как схемный символ и разместить в проекте.

Задача создания схемных символов и определение свойств его выводов становится все более сложной, поскольку возрастает сложность компонентов. Например, для создания корректных символов больших компонентов в корпусах BGA, требующих размещения и настройки сотен выводов, могут понадобиться значительное время и ресурсы.

Средство создания схемных символов Schematic Symbol Generation Tool

Для упрощения задачи создания схемных символов Altium предлагает эффективное средство создания схемных символов Schematic Symbol Generation Tool, основанный на интерфейсе мастера символов и диалогового окна редактора выводов. Средство обладает возможностью автоматического формирования графики символа, таблицами выводов и возможностями умной вставки данных.

Средство Schematic symbol generation tool поставляется как дополнительный программный модуль, и он устанавливается в систему автоматически. Модуль отображается на вкладке Installed страницы Extensions & Updates.

Чтобы создать новый символ компонента с помощью средства Schematic symbol generation tool, добавьте новый библиотечный компонент с помощью кнопки Add в панели SCH Library. Будет открыто диалоговое окно New Component, в котором вы можете ввести подходящее имя. Новый символ можно затем задать с помощью диалогового окна Symbol Wizard (Tools » Symbol Wizard).


Диалоговое окно Symbol Wizard

Настройки диалогового окна определяют базовую конфигурацию символа, в том числе его стиль (Layout Style) и количество выводов (Number of Pins).

Параметр Layout Style позволяет выбрать один из предопределенных шаблонов с автоматически заданным расположением выводов. Используйте выпадающее меню для выбора предварительно заданных расположений. Предварительный просмотр справа и данные в столбце Side будут обновлены соответствующим образом.

Обнаружили проблему в этом документе? Выделите область и нажмите Ctrl+Enter, чтобы оповестить нас.

Связаться с нами

Связаться с нашими Представительствами напрямую

We're sorry to hear the article wasn't helpful to you.
Could you take a moment to tell us why?
Вы сообщаете о проблеме, связанной со следующим выделенным текстом
и/или изображением в активном документе:
Бесплатная пробная версия Altium Concord Pro

Заполните форму ниже, чтобы получить бесплатную пробную версию Altium Concord Pro