Altium NEXUS Documentation

Формирование производственных данных для устройства из нескольких электронных модулей_AD

Created: 08.05.2020 | Updated: 08.05.2020

Главная страница: Проектирование устройств из нескольких электронных модулей

Основной целью проектов Multi-board является объединение всех элементов электронного изделия в виде системы, готовой к производству. Выходные документы для изготовления печатной платы и печатного узла из дочерних проектов служат для производства этих конкретных модулей, но не всей системы, которая будет собрана как единое изделие. Помимо проектных определений модулей и требуемых корпусов, оборудования и проводки, системное проектирование также должно включать в себя ключевые производственные данные, которые относятся к изделию в целом, такие как отдельные определения его элементов и сборки.

Состав изделия на системном уровне

Для производственных данных крайне важны корректные записи об используемых в проекте компонентах и связанных с ними данных, зафиксированные в виде состава изделия (Bill Of Materials – BOM). Altium NEXUS предлагает мощные функциональные возможности ActiveBOM, которые также предоставляют актуальную информацию о физических компонентах и поставщиках, характеристиках компонентов, состоянии жизненного цикла, доступности и т.д. Сбор всей этой информации и управление ей осуществляется в документе ActiveBOM проекта.

► Для получения более подробной информации по работе с документами состава изделия перейдите на страницу Управление составом изделия с помощью ActiveBOM.

В системном проекте документы ActiveBOM могут быть добавлены в сам проект Multi-board для обеспечения единого исходного определения состава изделия для всего проекта Multi-board, без необходимости вручную собирать эти данные из отдельных составов изделия дочерних проектов.

Чтобы создать документ состава изделия на системном уровне, щелкните ПКМ по названию проекта Multi-board в панели Projects и выберите команду Add New to Project » ActiveBOM из контекстного меню. На верхний уровень иерархии проекта Multi-board будет добавлен файл <НазваниеПроекта>.BomDoc.

Состав изделия на системном уровне берет параметры компонентов из документа Multi-board Assembly, который, в свою очередь, получает информацию о компонентах из дочерних проектов Multi-Board, заданных в документе Multi-board Schematic. Поэтому дочерние проекты должны быть актуальны, а их схемы и платы должны быть синхронизированы. То же самое относится к документам схемы и сборки проекта Multi-board (Design » Update Assembly - <ДокументСборки> и Design » Import Changes From <НазваниеПроекта> соответственно).

Для обеспечения того, что сборка Multi-board содержит корректные данные о компонентах, выберите команду Edit » Update All Parts из главного меню либо щелкните ПКМ в редакторе сборки и выберите Update All Parts.

Состав изделия верхнего уровня проекта Multi-board также включает в себя информацию об исходном проекте для каждого элемента в списке в виде столбцов Module. Столбец ModuleAssembly включен по умолчанию, остальные столбцы можно отобразить с помощью вкладки Columns панели Properties.

В качестве агрегированного справочника информации о компонентах всего проекта изделия – по сути, набора соединенных модулей проектов плат – состав изделия на системном уровне включает в себя информацию о компонентах и цепочке поставок из всех дочерних проектов и сводную информацию, такую как общую цену определенных компонентов и цену всех компонентов во всем проекте Multi-board.

Обратите внимание, что документ состава изделия на системном уровне не использует данные из документов состава изделия в дочерних проектах. Однако изменения, выполненные в документе BomDoc дочернего проекта, например изменение позиционного обозначения компонента или варианта выбора компонента, будут приняты самим проектом, и затем эти изменения будут отражены в документе BomDoc проекта Multi-board.

Как обозначено выше, любые проектные изменения, выполненные в дочернем проекте, должны быть переданы в документ сборки Multi-board (Update All Parts), чтобы эти изменения были отражены в документе BomDoc проекта Multi-Board.

Варианты выбора компонентов

Преимуществом ActiveBOM является возможность предоставления актуальной информации о цепочке поставок проектных компонентов, включающей в себя данные о физическом компоненте и проверенных поставщиков. Эта информация хранится в виде вариантов выбора компонентов (Part Choices) и реализуется в документе BomDoc в виде сопоставленных решений (Solutions). Документ состава изделия на системном уровне может включать в себя дополнительные данные о компонентах, которые относятся к общему проекту изделия, такие как механические/мехатронные компоненты, соединительные кабели, монтажные жгуты и т.п.

Например, информация о соединительных кабелях модуля Multi-board может быть выражена в виде их оконечных компонентов в схеме Multi-board. Эти компоненты могут быть включены в состав изделия на системном уровне вместе со связанным решением цепочки поставок или с определенным компонентом/ссылкой на поставщика, добавленной в виде ручного решения.

► Для получения более подробной информации перейдите на страницу Создание решений в составе изделия.

Выходные данные системного уровня

Помимо выходных данных для изготовления и сборки дочерних проектов, входящих в конструкцию Multi-board, для системного проектирования необходима возможность формирования выходных данных, которые относятся к изготовлению общей сборки Multi-board. Altium NEXUS позволяет создавать эти выходные данные системного уровня путем формирования отчетов и графических документов.

Отчет о составе изделия

Выходной отчет о составе изделия может быть сформирован непосредственно из документа ActiveBOM через диалоговое окно Report Manager, которое открывается с помощью команды Reports » Bill of Materials главного меню.

Диалоговое окно Bill of Materials for BOM Document <BomDoc> позволяет настроить отчет о составе изделия на системном уровне и сформировать его в одном из выходных форматов, в том числе csv, xml, pdf и .тд. Этот отчет будет включать в себя все данные ActiveBOM, в том числе слепок данных о цепочке поставок каждого объекта.

Таблица состава изделия редактора Draftsman

Таблица состава изделия BOM Table, добавленная в документ Draftsman на системном уровне, берет и выводит данные из документа ActiveBOM проекта Multi-board. Чтобы создать документ Draftsman на системном уровне, щелкните ПКМ по названию проекта Multi-board и выберите Add New to Project » Draftsman Document из контекстного меню (выберите любой дочерний проект в качестве источника).

При размещении таблицы состава изделия в этом документе верхнего уровня (Place » Bill Of Materials) в нее будут включены все объекты компонентов общего проекта Multi-board. Как и в документе ActiveBOM, доступны дополнительные столбцы справочных параметров, которые относятся к модулям (Module Assembly, Module Designator, Module Source и Module Title). Управление столбцами таблицы осуществляется на вкладке Columns в панели Properties, когда таблица выделена в редакторе Draftsman.

Экспорт сборки Multi-board

Представление сборки Multi-board можно экспортировать с помощью меню File » Export, которое доступно, когда сборка Multi-board является активным документом. Варианты экспорта включают в себя PARASOLID (*.x_t), STEP 3D (*.step) и PDF3D (*.pdf). Ниже показан пример интерактивного документа PDF 3D.

Файлы Output Job

Все типы выходных данных, о которых говорилось выше, могут быть добавлены в файл Output Job Altium NEXUS для формирования производственных данных в форматах контейнеров, которые предназначены для определенных форматов файлов, доступных принтеров и т.д. Файл OutJob добавляется в проект Multi-board, и полученные с его помощью выходные файлы будут представлять проект на системном уровне.

Чтобы добавить файл Output Job в проект Multi-board, щелкните ПКМ по его названию и выберите Add New to Project » Output Job File из контекстного меню. В файле OutJob проекта Multi-board будут предложены варианты формирования выходных документов, которые применимы только к проектам на системном уровне, такие как выходная документация и выходные отчеты, обозначенные выше.

Обнаружили проблему в этом документе? Выделите область и нажмите Ctrl+Enter, чтобы оповестить нас.

Связаться с нами

Связаться с нашими Представительствами напрямую

We're sorry to hear the article wasn't helpful to you.
Could you take a moment to tell us why?
200 characters remaining
Вы сообщаете о проблеме, связанной со следующим выделенным текстом
и/или изображением в активном документе: