Altium NEXUS Documentation

Управляемые шаблоны схем_AD

Главная страница: Объекты сервера

Altium NEXUS в сочетании с сервером управляемых данных позволяет создавать объекты управляемых шаблонов схем (Schematic Template Item) и управлять ими на этом сервере. Такие объекты могут быть созданы непосредственно с сервера. После того, как объект Schematic Template Item был создан (и в его ревизию были выпущены данные) и его состояние жизненного цикла задано на том уровне, при котором этот объект можно использовать при проектировании, объект можно повторно использовать на уровне проектирования плат.

Кроме того, объект Schematic Template Item можно использовать как объект данных конфигурации в одной или нескольких заданных конфигурациях среды (Environment Configurations). Конфигурация среды используется, чтобы ограничить рабочую среду средства проектирования Altium NEXUS использованием только утвержденных компанией проектных элементов. Конфигурации среды определяются и хранятся в Team Configuration Center – службе, которая устанавливается вместе с NEXUS Server и которая отвечает за концепцию управления конфигурацией среды.

Тип папки

При создании папки, в которой будут храниться объекты Schematic Template Item, вы можете указать тип этой папки. Это не имеет отношения к содержимому папки – выпуск шаблона схем всегда осуществляется в соответствующий объект Schematic Template Item. Таким образом вы лишь обеспечиваете визуальную подсказку о том, что хранится в папке, что может быть полезными при поиске определенного содержимого на сервере. Чтобы указать, что папка используется в качестве контейнера для объектов Schematic Template Item, задайте ее тип (Folder Type) как Schematic Templates при определении свойств папки в диалоговом окне Edit Folder.

Определение типа папки, т.е. ее планируемого использования, предоставляет визуальную индикацию содержимого этой папки при просмотре данных на сервере.
Определение типа папки, т.е. ее планируемого использования, предоставляет визуальную индикацию содержимого этой папки при просмотре данных на сервере.

Другим важным аспектом родительской папки является используемая для нее схема именования объектов (Item Naming Scheme), которая определяет формат уникального идентификатора каждого объекта, создаваемого в этой папке. Доступны несколько примеров схем по умолчанию, использующих краткий код для папок каждого типа (STC для набора шаблонов схем) или для содержимого каждого типа (SCHDOT для шаблона документа схемы):

  • $CONTENT_TYPE_CODE-001-{0000} – например, SCHDOT-001-0001.
  • $CONTENT_TYPE_CODE-001-{A00} – например, SCHDOT-001-A01.
  • $FOLDER_TYPE_CODE-001-{0000} – например, STC-001-0001.
  • $FOLDER_TYPE_CODE-001-{A000} – например, STC-001-A001.

Используя схему именования по умолчанию, система автоматически назначит следующий уникальный идентификатор на основе этой схемы, просканировав весь сервер и идентификаторы существующих объектов. Это может значительно сэкономить время при создании объектов шаблонов схем вручную.

Для папки также можно определить пользовательскую схему путем ее ввода в поле, с переменной частью в фигурных скобках (например, SCH-TMP-{0000}).

Схема именования объектов родительской папки применяется к уникальным идентификаторам всех объектов, которые создаются в этой папке.
Схема именования объектов родительской папки применяется к уникальным идентификаторам всех объектов, которые создаются в этой папке.

Схему Item Naming Scheme, примененную к родительской папке, можно в любой момент изменить. Измененная схема будет применяться ко всем создаваемым далее в этой папке объектам.

Тип объекта

При создании целевого объекта Schematic Template Item, в котором будет храниться шаблон схем, убедитесь, что в диалоговом окне Create New Item тип содержимого этого объекта (Content Type) определен как Schematic Template. Если вы создаете объект в папке с типом Schematic Templates, то объект этого типа будет доступен в контекстном меню при создании объекта.

Создание объекта Schematic Template Item в папке Schematic Templates. Нужный тип содержимого (Content Type) доступен в контекстном меню.
Создание объекта Schematic Template Item в папке Schematic Templates. Нужный тип содержимого (Content Type) доступен в контекстном меню.

При определении объекта Schematic Template Item, убедитесь, что указан тип управления жизненным циклом для его использования с этим объектом и схема именования ревизий этого объекта.

Управление тем, какие типы объектов могут использовать конкретное определение жизненных циклов или схему именования ревизий, осуществляется на глобальном уровне в диалоговом окне Content Types, при определении схемы. Схемами по умолчанию, которые назначаются объекту Schematic Template Item, являются Generic Lifecycle и 1-Level Revision Scheme.

После того, как файл был выгружен в начальную ревизию объекта Schematic Template Item, эти схемы не могут быть изменены для этого конкретного объекта.

Укажите нужные схемы в диалоговом окне Create New Item с помощью полей Lifecycle Definition и Revision Naming Scheme соответственно.

Если включен параметр для управления использованием определений жизненных циклов и схем именования ревизий по типу содержимого и для типа Schematic Template Item не задано использование конкретного определения/схемы, то это определение/схема будет не доступно в соответствующем выпадающем списке.

Выбор определения жизненного цикла и схемы именования ревизий для создаваемого вручную объекта.
Выбор определения жизненного цикла и схемы именования ревизий для создаваемого вручную объекта.

Придерживаясь стандартных схем именования ревизий и определений жизненных циклов для различных типов проектных объектов на сервере управляемых данных, вы обеспечите понятное и надежное управление этими объектами.
Хорошей идеей является добавление названия и описания в определение объекта. Эта информация используется при поиске на сервере и позволяет быстро идентифицировать, что предлагает тот или иной объект Schematic Template Item.

Выпуск шаблона схем

До сих пор рассматривалась поддержка сервером объекта Schematic Template Item с точки зрения соответствующих типов папки и объекта. Выпуск шаблона схем в ревизию такого объекта может быть выполнен несколькими способами.

Шаблон схем может быть отредактирован и выпущен в начальную ревизию нового объекта Schematic Template Item с помощью прямого редактирования, поддерживаемого сервером. Прямое редактирование избавляет от ограничений отдельных исходных данных под контролем версий. Вы можете просто изменить объект поддерживаемого типа с помощью временного редактора, в который загружена самая новая версия исходных данных непосредственно с сервера. По завершении редактирования, сущность выпускается (или выпускается повторно) в последующую запланированную ревизию родительского объекта, и временный редактор закрывается. Нет файлов на вашем жестком диске, не нужно задаваться вопросом о том, работаете ли вы с корректными и самыми новыми данными, нет необходимости в обслуживании отдельного программного обеспечения для контроля версий. Всем этим управляет сервер, с высокой степенью целостности, для значительного ускорения внесения изменений в данные.

После создания объекта Schematic Template Item вы можете изменить и выпустить шаблон схем в начальную ревизию этого объекта. Для этого включите параметр Open for editing after creation в нижней части диалогового окна Create New Item (параметр включен по умолчанию). Объект будет создан, и откроется временный редактор схем, с соответствующим документом .SchDot в качестве активного документа в главном окне приложения. Этот документ будет назван в соответствии с объектом-ревизией, в формате <Объект><Ревизия>.SchDot (например SCHDOT-0010-1.SchDot).

Пример редактирования начальной ревизии объекта Schematic Template Item непосредственно с сервера управляемых данных. Временный редактор схем предлагает документ для определения шаблона схем.
Пример редактирования начальной ревизии объекта Schematic Template Item непосредственно с сервера управляемых данных. Временный редактор схем предлагает документ для определения шаблона схем.

Используйте этот документ для определения шаблона схем необходимым образом. Для получения более подробной информации об этом перейдите на страницу Создание шаблонов и работа с ними.

При прямом редактировании есть три элемента управления, доступных в панели быстрого доступа (Quick Access Bar, в верхней левой части окна приложения) и в панели инструментов Schematic Standard:

  • Save Active Document (Сохранить активный документ). Используйте эту кнопку, чтобы сохранить все изменения документа. Это позволит вам сохранить текущие изменения и позже вернуться к внесению дальнейших изменений перед выпуском на сервер управляемых данных.
  • Release Document (Выпуск документа). Используйте эту кнопку, чтобы выпустить (по сути, сохранить и выпустить) определенный шаблон схем на сервер управляемых данных в начальную (запланированную) ревизию целевого объекта Schematic Template Item. Будет открыто диалоговое окно Edit Revision, в котором вы можете изменить название и описание и добавить информацию о выпуске. После выпуска документ и редактор будут закрыты. Документ *.SchDot, содержащий в себе исходный шаблон схем, будет сохранен в ревизию объекта.
  • Cancel Editing (Отменить редактирование). Используйте эту кнопку, если вы хотите отменить редактирование. Документ и редактор будут закрыты, и в целевой объект Schematic Template Item ничего не будет выпущено.

Эти элементы управления также доступны в качестве команд главного меню File: Save (сочетание клавиш Ctrl+S), Release to Server (сочетание клавиш Alt+Ctrl+S) и Cancel Edit.

Выпущенные данные, которые хранятся на сервере, состоят из исходного шаблона схем, заданного в файле шаблона (<Объект><Ревизия>.SchDot). В панели Explorer переключитесь на вкладку аспектного вида Preview, чтобы увидеть графику шаблона.

Просмотр выпущенной ревизии объекта Schematic Template Item в панели Explorer. Переключитесь на вкладку аспектного вида Preview, чтобы увидеть графику шаблона.
Просмотр выпущенной ревизии объекта Schematic Template Item в панели Explorer. Переключитесь на вкладку аспектного вида Preview, чтобы увидеть графику шаблона.

Отправка на сервер существующего шаблона

Хотя прямое редактирование является предпочтительным (и единственным) подходом для большинства проектных объектов, которые хранятся на сервере управляемых данных, вы также можете отправить непосредственно на сервер существующий шаблон схем. Для этого нужна запланированная ревизия существующего объекта Schematic Template Item, в которую этот шаблон будет выпущен. Процесс выглядит следующим образом:

  1. Создайте новый объект Schematic Template Item и его начальную запланированную ревизию либо создайте запланированную ревизию другого, существующего объекта.
  2. Откройте шаблон схем (*.SchDot) в Altium NEXUS.
  3. Выберите команду File » Send to server из главного меню.
  4. Будет открыто диалоговое окно Choose Planned Item Revision. Используйте его, чтобы выбрать целевую ревизию нужного объекта Schematic Template Item (которая должна быть в состоянии Planned), и нажмите OK.
    Если целевого объекта Schematic Template Item не существует, вы можете создать его на лету с помощью диалогового окна Choose Planned Item Revision. В этом случае, отключите параметр Open for editing after creation (в диалоговом окне Create New Item), иначе вы перейдете в режим прямого редактирования.
  5. Будет открыто диалоговое окно Edit Revision, в котором вы можете изменить название и описание и добавить необходимую информацию о выпуске.
  6. После нажатия OK, проект будет выпущен и сохранен в ревизию объекта.

Пример отправки существующего шаблона схем на сервер управляемых данных, в который вы вошли. Выпуск должен быть осуществлен в существующую ревизию объекта Schematic Template Item, которая должна быть в состоянии Planned.Пример отправки существующего шаблона схем на сервер управляемых данных, в который вы вошли. Выпуск должен быть осуществлен в существующую ревизию объекта Schematic Template Item, которая должна быть в состоянии Planned.

Повторное использование объекта Schematic Template Item

Связанные страницы: Управляемые листы схем, Управление доступом к данным на сервере

После того, как шаблон схем был выпущен на сервер управляемых данных и состояние его жизненного цикла было задано на том уровне, при котором его можно использовать на уровне проекта, этот шаблон можно повторно использовать при создании проектов плат.

Когда вы вошли на сервер управляемых данных, использование доступных объектов Schematic Template Item осуществляется автоматически. Если существуют выпущенные ревизии объектов Schematic Template Item, то только доступные шаблоны (те, которые были опубликованы для вас), будут представлены в следующих местах, где можно выбрать шаблон схем.

При создании нового документа схемы с помощью команды File » New » Schematic главного меню или команды Add New to Project » Schematic контекстного меню проекта, будет открыто диалоговое окно Select configuration item (Schematic Templates). Используйте это диалоговое окно, чтобы выбрать шаблон для нового листа схемы из тех, которые опубликованы для вас на сервере.

Будет использоваться самая новая ревизия доступного объекта.

Выберите самую новую объекта Schematic Template Item, опубликованную для вас, при создании нового документа схемы.
Выберите самую новую объекта Schematic Template Item, опубликованную для вас, при создании нового документа схемы.

Откройте панель Properties активного документа схемы, когда в рабочей области нет открытых документов, чтобы отобразить свойства документа (Document Options). В области Formatting and Size раздела Page Options (на вкладке General панели), выберите режим Template и используйте поле Template, чтобы выбрать шаблон для листа схемы из тех, которые опубликованы для вас на сервере.

Выбранная ревизия объекта Schematic Template Item отображается в панели Properties при просмотре свойств активного листа схемы.
Выбранная ревизия объекта Schematic Template Item отображается в панели Properties при просмотре свойств активного листа схемы.

Переключитесь на другой доступный шаблон с помощью выпадающего меню поля Template. Либо вы можете применить другой доступный шаблон, выбрав его в меню Design » Templates » Configuration Templates. Чтобы отказаться от использования шаблона, переключитесь на другой режим Formatting and Size (Standard или Custom) с помощью раздела General - Page Options панели Properties. Либо используйте команду Design » Templates » Remove Current Template.

В подменю Design » Templates редактора схем, возможность выбора файлового шаблона проекта или общего шаблона будет отключена. Вместо этого, в подменю Configuration Templates будут представлены все самые новые ревизии объектов Schematic Template Item, которые опубликованы для вас.

Только самые новые ревизии шаблонов схем, опубликованных для вас, будут доступны для использования.
Только самые новые ревизии шаблонов схем, опубликованных для вас, будут доступны для использования.

Если на сервере нет выпущенных ревизий объектов Schematic Template Item либо если вы вышли с сервера, вы сможете использовать локальные, файловые шаблоны.

Если вы не вошли на сервер управляемых данных, вы всё же можете работать в Altium NEXUS (под активной лицензией Altium NEXUS), но вы не сможете получить доступ к серверу управляемых данных организации и к его службам. Соответственно, вы не сможете повторно использовать объекты Schematic Template Item. Вы сможете использовать только файловые шаблоны, определенные локально.
Выпущенный шаблон схем также можно использовать как объект данных конфигурации в одной или множестве конфигурациях среды (Environment Configurations). Конфигурация среды используется для ограничения рабочей среды средства проектирования Altium NEXUS использованием только тех проектных элементов, которые утверждены компанией. Определение конфигураций среды и их хранение осуществляется в Team Configuration Center – службе, которая устанавливается вместе с NEXUS Server. После того, как вы вошли в NEXUS Server и выбрали доступную вам конфигурацию среды, в Altium NEXUS будет настроено соответствующее использование шаблонов схем. Если в выбранной конфигурации среды определен один или множество объектов Schematic Template Item, то только эти шаблоны будут доступны для использования. Если в выбранной конфигурации среды нет объектов Schematic Template Item либо если в ней задано Do Not Control, то шаблоны останутся доступными для определения вручную, т.е. вы сможете использовать локальные, файловые шаблоны. Для получения более подробной информации перейдите на страницу Управление конфигурацией среды.

Повторное использование вручную

При подключении к NEXUS Server и использовании конфигурации среды, в которое не задано управление использованием шаблонов схем, вы можете вручную выбрать ревизию объекта Schematic Template Item. Для этого используйте команду Design » Templates » Set Template from server. Будет открыто диалоговое окно Choose Template, в котором вы можете найти и выбрать нужную ревизию объекта на сервере.

Используйте команду Set Template from server, чтобы вручную задать повторное использование управляемых шаблонов схем (или для переключения между ними), которые доступны вам.
Используйте команду Set Template from server, чтобы вручную задать повторное использование управляемых шаблонов схем (или для переключения между ними), которые доступны вам.

Помимо управляемых шаблонов на серере, вы также можете использовать локальные, неуправляемые шаблоны схем, если в этом возникает необходимость.

Повторный выпуск объекта Schematic Template Item

В любой момент вы можете вернуться к ревизии объекта Schematic Template Item на сервере и напрямую отредактировать ее. Щелкните ПКМ по ревизии и выберите команду Edit из контекстного меню. Будет открыт временный редактор с шаблоном из этой ревизии. Внесите необходимые изменения, затем выпустите документ в следующую ревизию объекта.

Щелкните ПКМ по записи верхнего уровня самого объекта, чтобы изменить самую новую ревизию этого объекта.

Доступ к команде для запуска прямого редактирования существующей ревизии объекта Schematic Template Item.
Доступ к команде для запуска прямого редактирования существующей ревизии объекта Schematic Template Item.

Загрузка выпущенных данных

Чтобы загрузить данные, которые хранятся в ревизии объекта Schematic Template Item, щелкните ПКМ по ревизии этого объекта и выберите команду Operations » Download из контекстного меню. Файл шаблона схем будет загружен в подпапку выбранной директории, названную в соответствии с идентификатором ревизии объекта. Этот файл можно найти здесь в папке Released.

Запустите команду Download для записи верхнего уровня объекта Schematic Template Item, чтобы загрузить файл шаблона, который хранится в самой новой ревизии этого объекта.
Нажмите кнопку Explore в диалоговом окне Download from Server, чтобы быстро открыть папку загрузки.
Обнаружили проблему в этом документе? Выделите область и нажмите Ctrl+Enter, чтобы оповестить нас.

Связаться с нами

Связаться с нашими Представительствами напрямую

We're sorry to hear the article wasn't helpful to you.
Could you take a moment to tell us why?
200 characters remaining
Вы сообщаете о проблеме, связанной со следующим выделенным текстом
и/или изображением в активном документе: