Altium NEXUS Documentation

Что нового в Altium NEXUS

Created: 26.11.2020 | Updated: 31.08.2021

Улучшения Altium NEXUS 4

На этой странице описаны улучшения начального выпуска Altium NEXUS 4, а также последующих обновлений. Наряду с улучшениями, развивающими и совершенствующими существующие технологии, в обновлениях устраняются многие проблемы, о которых сообщали пользователи в системе BugCrunch сообщества AltiumLive, что позволяет вам продолжать создавать передовые электронные устройства.

Вы можете продолжить использовать текущую версию, обновить текущую версию или установить Altium NEXUS 4 наряду со своей текущей версий, чтобы получить доступ к самым новым возможностям. Вы можете обновить текущую версию непосредственно из системы, на странице Extensions and Updates. Если вы хотите установить Altium NEXUS 4 наряду со своей текущей версией, перейдите на страницу Загрузки Altium, чтобы загрузить установщик, и выберите New Installation на странице Installation Mode в ходе установки.

Altium NEXUS 4.6

Выпущен: 20 августа 2021 - Версия 4.6.4 (сборка 35)

Выпущен: 22 июля 2021 – Версия 4.6.1 (сборка 21)

Информация о выпуске Altium NEXUS версии 4.6 

 


Altium NEXUS 4.5

Выпущен: 22 июня 2021 – Версия 4.5.1 (сборка 15)

Информация о выпуске Altium NEXUS версии 4.5

Обновление Update 5 для Altium NEXUS 4 продолжает развивать базовые технологии системы, предлагая новые функции и улучшения, а также реализует многие идеи, предложенные пользователями через систему BugCrunch сообщества AltiumLive.


Ввод схем

Добавлена возможность переключения в ECO

Добавлена возможность использовать клавишу Пробел для включения/отключения действия (Action) в диалоговом окне Engineering Change Order.


Конструирование плат

Возможность отображения компонента из выделенного посадочного места

В подменю Component Actions контекстного меню добавлена команда Show <компонент> in <сервер>, которая открывает панель Explorer с компонентом, который был выделен. Эта команда доступна только в документе платы, который входит в управляемый проект.

Добавлена проверка отключенных полигонов при выводе файла

Добавлено диалоговое окно, которое перед формированием определенных выходных документов оповещает вас о наличии отключенных полигонов. Эти выходные документы включают в себя Gerber, Gerber X2, ODB++, распечатки плат и IPC2581. Нажмите Generate Output, чтобы продолжить, или Cancel, чтобы прервать формирование документа. Если формирование было прервано, перезалейте полигоны и запустите формирование выходного документа снова.

Угол поворота примитивов при размещении

При размещении примитивов в документе платы или документе библиотеки посадочных мест угол поворота теперь по умолчанию равен нулю. Измените угол поворота при размещении на нужный.


Управление данными

Улучшено удаление документа проекта

Добавлено диалоговое окно, которое позволяет выбрать, как нужно удалить документ. Вы можете выбрать между полным удалением документа или лишь исключением этого документа из проекта без его полного удаления. Чтобы открыть диалоговое окно, выберите команду Remove from Project из контекстного меню выбранного документа.


Имитатор электрических цепей

В диалоговое окно Add Wave to Plot добавлены дополнительные математические функции

В существующий список в диалоговом окне Add Wave to Plot добавлены новые математические функции. Для вызова диалогового окна выберите Wave » Add Wave из главного меню, когда активным документом является файл *.sdf.

Значения по умолчанию в диалоговом окне Sim Model

В диалоговом окне Sim Model теперь используются значения по умолчанию для параметров имитационных моделей, которые отображаются как затененный текст. Пользовательские значения отображаются белым текстом. При удалении пользовательского значения будет восстановлено значение по умолчанию. Пустые значения недопустимы.


Altium NEXUS 4.4

Выпущен: 25 мая 2021 – Версия 4.4.1 (сборка 18)

Информация о выпуске Altium Altium NEXUS версии 4.4

Обновление Update 4 для Altium NEXUS 4 продолжает развивать базовые технологии системы, предлагая новые функции и улучшения, а также реализует многие идеи, предложенные пользователями через систему BugCrunch сообщества AltiumLive.


Конструирование плат

Интерактивная трассировка

Перемещение трассировки с компонентом

Редактор плат может помочь с управлением трассировкой при перемещении растрассированного компонента. Опция Component re-route на странице PCB Editor - Interactive Routing диалогового окна Preferences указывает модулю трассировки попытаться перетрассировать соединения, затронутые перемещением, сразу по завершении перемещения компонента, а опция Move component with relevant routing указывает модулю трассировки переместить соответствующую трассировку вместе с перемещаемым компонентом (или компонентами). Соответствующая трассировка включает в себя фэнауты, трассировку за пределы посадочного места и межсоединения между выводами компонентов. Используйте Shift+Tab для включения/отключения этой опции при перемещении компонента.

Если компонент включает в себя большое число выводов с подключенной трассировкой, это может стать ресурсоемкой задачей. Чтобы помочь в управлении этим, была добавлена опция up to. Используйте эту опцию, чтобы определить максимальное количество выводов, которое может быть у перемещаемого компонента, свыше которого модуль трассировки не будет перемещать соответствующую трассировку вместе с компонентом.

Правила SMD при сглаживании 'Any Angle'

Добавлена возможность учитывать правила SMD (SMD Entry и SMD to Corner) при сглаживании под произвольным углом ('Any Angle'). При наличии этих правил проектирования, трассировка теперь выходит из контактных площадок ортогонально и не поворачивает на определенном расстоянии, что позволяет трассе выйти за пределы вскрытия в паяльной маске перед приближением к соседней контактной площадке. Это позволяет избежать проблем близкого расстояния к открытому металлу и рисков возникновения перемычек при пайке.

Возможность отключить анимацию

На страницу PCB Editor - Display диалогового окна Preferences добавлена опция Use Animation, которая позволяет включать и отключать анимацию при приближении, перевороте платы и переключении слоев.

Восстановлена возможность изменять цвет покровного слоя

В панели View Configuration восстановлена возможность изменять цвет покровного слоя.

Улучшенные свойства групповых заготовок Embedded Board Array

В панель Properties для объектов Embedded Board Array добавлены новые элементы управления, которые позволяют лучше определять групповую заготовку платы. Раздел Additional Options вкладки General позволяет включать/отключать таблицу сверловки, таблицу стеков слоев и размеры. Новые вкладки Parameters и Layers позволяют выбрать параметры и/или слои, которые должны быть переданы. Настройки, заданные на вкладке Layers, будут отражены в выходных документах, например, в распечатках платы.

Пост-обработка платы

Для улучшения отзывчивости редактора плат были добавлены следующие функции пост-обработки.

  • Проверки электрических правил проектирования не запускаются, если измененные свойства примитива компонента на плате не изменяют примитивы на сигнальном слое.
  • Проверки правил проектирования заливки полигонов не запускаются, если измененные свойства примитива компонента на плате не изменяют примитивы на сигнальном слое.
  • Проверки правил проектирования анализа цепей не запускаются, если измененные свойства примитива компонента на плате не изменяют примитивы на сигнальном слое.
Включение/отключение этой функциональной возможности осуществляется с помощью опции PCB.Optimization.CommitChanges в диалоговом окне Advanced Settings.

Управление данными

Миграция репозиториев Git/SVN

Altium NEXUS теперь предлагает возможность миграции проектов, которые используют внешнюю систему контроля версий (VCS), в полностью управляемые серверные проекты Altium, которые содержат проектные файлы в собственном Git-репозитории сервера. Полностью управляемый проект может использовать преимущества функциональных возможностей встроенной системы контроля версий сервера, таких как временная шкала истории. Диалоговое окно Make Available Online теперь предлагает опцию Migrate to <сервер> Versioned Storage, которая включает процесс миграции в VCS вместо простого зеркалирования структуры проекта на сервер.

Если проект во внешней VCS уже управляется сервером Altium как зеркальный проект (т.е. как синхронизированные локальные-серверные файлы), его файлы VCS могут быть мигрированы в собственный Git репозиторий сервера с помощью команды Migrate to Versioned Storage, доступной в представлении Project History, в диалоговом окне Project Options и в контекстном меню Version Control панели Projects.

Новая команда 'Change State' в панели Components

Добавлена возможность изменить состояние ревизии компонента в панели Components. Команда доступна щелчком ПКМ по одному или множеству компонентов и выбором Operations » Change State из контекстного меню. Будет открыто диалоговое окно Batch state change, в котором вы можете изменить состояние ревизии компонентов.

Улучшенный интерфейс сохранения на сервере

Сохранение документов

После внесения изменений, если вы еще не сохранили документ (плату, схему, компонент и т.д.), будет открыто диалоговое окно, которое показано ниже. При включении опции Save to Server и нажатии Save, изменения будут сохранены локально и на сервере.

Если вы внесли изменения в документ и сохранили изменения локально, будет открыто диалоговое окно, которое показано ниже, предупреждающее вас, что изменения также нужно сохранить на сервере (если это необходимо). Нажмите Do nothing, если вы не хотите сохранять изменения на сервере.

Улучшения диалогового окна подтверждения сохранения

Диалоговое окно Confirm Save for Modified Documents было улучшено, чтобы позволить при закрытии Altium NEXUS выбрать, хотите ли вы сохранить на сервере несохраненные измененные документы или нет. Используйте выпадающее меню, чтобы выбрать определенные документы, которые нужно сохранить, или нажмите Save All to Server, чтобы сохранить все перечисленные документы на сервере.

Если локальный документ также был изменен, эти документы также будут приведены в диалоговом окне Confirm Save for Modified Documents, как показано ниже.


Документы Draftsman

Добавлена опция 'Show No BOM' для вида Board Isometric View

Добавлена опция Show No BOM, при включении которой компоненты отображаются на виде Board Isometric View, даже если их нет в BOM.

Добавлена опция 'Override Color' для вида Board Fabrication View

Добавлена опция Override Color для вида Board Fabrication View, которая позволяет задать цвет по умолчанию для всех слоев.

Улучшенные свойства отображения компонентов

В выпадающий список в диалоговом окне Component Display Properties были добавлены параметры Comment и Design Item ID (диалоговое окно вызывается нажатием кнопки Components в режиме Board Assembly View панели Properties).


Модули импорта/экспорта

Добавлен импорт файлов посадочных мест Allegro

Добавлена возможность импортировать файлы посадочных мест Allegro (*.dra) с помощью Import Wizard для более оптимального процесса импорта.

Добавлено диалоговое окно 'Ansys EDB Export Options'

Было добавлено диалоговое окно Ansys EDB Export Options, которое позволяет настроить экспорт ANSYS. Вызов диалогового окна осуществляется выбором команды File » Export » Ansys EDB из документа платы и выбором папки в открывшемся диалоговом окне Windows.

Для доступа к модулю экспорта ANSYS должно быть установлено расширение Ansys EDB Exporter со страницы Extensions & Updates.

Имитатор электрических цепей

В диалоговое окно Sim Model добавлен список имитационных моделей по умолчанию

В диалоговое окно Sim Model добавлен набор имитационных моделей по умолчанию, что позволяет быстро выбирать модели по умолчанию из списка. Выберите нужную модель из выпадающего списка Model Type.



Altium NEXUS 4.3

Выпущен: 29 апреля 2021 – Версия 4.3.2 (сборка 12) - Hot Fix
Выпущен: 22 апреля 2021 – Версия 4.3.1 (сборка 11)

Информация о выпуске Altium NEXUS версии 4.3

 

Обновление Update 3 для Altium NEXUS 4 продолжает развивать базовые технологии системы, предлагая новые функции и улучшения, а также реализует многие идеи, предложенные пользователями через систему BugCrunch сообщества AltiumLive.

Конструирование плат

Интерактивная трассировка

Включение скосов при перетаскивании

Скосы – это короткие диагональные сегменты, которые автоматически добавляются в процессе трассировки для предотвращения создания прямых углов. Размер скоса определяется текущим значением свойства Miter Ratio. По умолчанию, при перетаскивании сегмента все соседние скосы также перетаскиваются.

В новой версии вы можете выбрать, включать или исключать скосы при перетаскивании, с помощью опции Include Miters в режиме Interactive Sliding панели Properties. Нажмите клавишу C в процессе перетаскивания, чтобы осуществлять перетаскивание без скосов. Нажмите C еще раз, чтобы снова включить перетаскивание со скосами.

Интерактивное изменение размера паттернов Sawtooth

Паттерн Sawtooth теперь поддерживает использование клавиш и для интерактивного уменьшения/увеличения высоты подстроечного паттерна при размещении.

Rigid-Flex 2

Блокирование регионов 3D-платы

Для упрощения контроля над процессом складывания гибко-жесткой платы, в режим Board Region платы Properties был добавлен флажок 3D Locked. Может быть заблокирован только один регион платы. Он будет неподвижен при складывании платы в режиме 3D-представления.

Заблокируйте регион платы, который должен быть неподвижен при складывании гибко-жесткой платы.

Для перехода в режим Rigid-Flex 2 включите следующие опции в диалоговом окне Advanced Settings:

  • PCB.RigidFlex2.0 – включает функциональные возможности Rigid-Flex 2 в режиме Board Planning Mode. Обратите внимание, что в предыдущих версиях Altium NEXUS эта опция называлась Legacy.PCB.RigidFlex. Вместе изменением названия изменилось поведение – при включении старой опции восстанавливался старый режим (Rigid-Flex1.0), в то время как новая опция включает новый режим (Rigid-Flex2.0).
  • PCB.RigidFlex.SubstackPlanning – включает представление Board в Layer Stack Manager.

Узнайте больше о Конструировании гибко-жестких плат.

Добавлена опция перетаскивания множества выделенных объектов

В диалоговое окно Advanced Settings добавлена опция PCB.Rendering.MultiselectionDrag, которая позволяет управлять количеством примитивов, отображаемых при перетаскивании множества выделенных объектов.


Управление данными

Улучшения комментариев

В новой версии были улучшены комментарии – появилась возможность экспортировать комментарии, а также было добавлено новое диалоговое окно, позволяющее настраивать экспорт комментариев. Новые функциональные возможности описаны далее.

Экспорт комментариев

Была добавлена возможность экспортировать комментарии в виде отдельного документа. Это позволяет вам сформировать полную историю контроля проекта, так что больше нет необходимости вести отдельный документ и дублировать работу.

Доступ к этой функциональной возможности осуществляется следующими способами:

  • Из файла Outjob – щелкните ПКМ по строке [Add New Report Output] и выберите Export Comments. Вы можете выбрать документы из списка для экспорта.
  • Из документа схемы или платы – выберите Reports » Project Reports » Export Comments. Будет открыто диалоговое окно Export Comments Properties, в котором вы можете настроить экспорт.

Если вы добавили новый выходной отчет Export Comments, щелкните ПКМ и выберите Page Setup, чтобы открыть диалоговое окно Export Comments Properties, котором вы можете настроить экспорт.

Новое диалоговое окно Comment Export Configuration

Было реализовано новое диалоговое окно Comment Export Configuration, которое позволяет задать интервал для экспорта комментариев и включить скриншоты при экспорте, если они необходимы. Вызов диалогового окна осуществляется щелчком ПКМ по строке Export Comments в разделе Report Outputs файла Outjob и выбором Configure из контекстного меню. Нажмите Export для экспорта и открытия документа в соответствующем приложении.

Улучшенное быстродействие панели Manufacturer Part Search

Время поиска в панели Manufacturer Part Search было улучшено для более быстрого предоставления результатов при выборе категории или поиске внутри категории.

Если необходимо, вы можете включить опцию ComponentPartSearch.PerformanceMetrics в диалоговом окне Advanced Settings для отображения времени поиска в нижней части панели Manufacturer Part Search.

Улучшения ECAD/MCAD

Отображение применяемой сетки

Зачастую компоненты размещаются в различных сетках. Это может быть радиальная сетка, определенная для круговой платы, пользовательская сетка для компонентов в определенной области платы или механическая сетка, определенная инженером-механиком и отправленная в редактор плат с помощью CoDesigner – решения для совместного проектирования ECAD-MCAD от Altium.

Информация о положении пользовательской сетки, такой как сетки, определенной в MCAD, отображается в разделе Location панели Properties, когда компонент выделен. Пользовательская сетка может использовать единицы измерения, отличные от тех, которые использует глобальная сетка, но всегда отображается в единицах измерения, выбранных в редакторе плат.

Определение и редактирование пользовательских сеток осуществляется в режиме Board панели Properties (отображается, когда нет выделенных объектов).


Документы Draftsman

Опция Display Holes для вида Board Isometric View

В режим Board Isometric View панели Properties добавлена опция Display holes, позволяющая выбрать, должны ли отображаться отверстия. Используйте выпадающее меню, чтобы выбрать нужный режим отображения: None, All или Pads only.


Имитатор электрических цепей

Добавлены поля интервала и периода для расчета переходного процесса

В панель Simulation Dashboard добавлена возможность настройки интервала и периода для расчета переходного процесса. Используйте новые поля, чтобы задать интервал и количество периодов и точек на период.

Добавлены значения по умолчанию для расчета по переменному току

В диалоговом окне Advanced Analysis Settings теперь используются значения по умолчанию для расчета по переменному току (вызов диалогового окна осуществляется нажатием Settings в панели Simulation Dashboard).

Добавлена поддержка переменной 'temper' и функции 'idtmod'

Для моделей LTSPICE теперь поддерживаются переменная 'temper' и функция 'idtmod' в математических выражениях.

Добавлены настройки для групповых допусков методов Монте-Карло

Для более точного определения расчетов в диалоговое окно Advanced Analysis Settings были добавлены настройки Group Tolerances для расчетов методами Монте-Карло.

Расширенный параметр 'RNODETOGND'

В диалоговое окно Advanced Analysis Settings добавлен расширенный параметр 'RNODETOGND' со значением по умолчанию '1e12'. Этот параметр используется для обработки пути постоянного тока к земле.

Altium NEXUS 4.2

Выпущен: 19 марта 2021 – Версия 4.2.2 (сборка 21) - Hot Fix 2
Выпущен: 11 марта 2021 – Версия 4.2.1 (сборка 18) - Hot Fix
Выпущен: 4 марта 2021 – Версия 4.2.0 (сборка 16)

Информация о выпуске Altium NEXUS версии 4.2

Обновление Update 2 для Altium NEXUS 4 продолжает развивать базовые технологии системы, предлагая новые функции и улучшения, а также реализует многие идеи, предложенные пользователями через систему BugCrunch сообщества AltiumLive.


Конструирование плат

Улучшения трассировки

В этом обновлении выделенная команда разработки технологий трассировки Altium продолжает улучшать функции интерактивной трассировки и перетаскивания.

Дуги при трассировке дифференциальных пар

Была улучшена обработка дифференциальных пар с дугами в изломах. Дуги в изломах теперь являются концентричными (имеют одну точку центра), что обеспечивает постоянство зазора в дифференциальной паре в изломе.

Более качественные входы в круглые контактные площадки

Были улучшены алгоритмы формирования входов в круглые контактные площадки для выравнивания входящих трасс ортогонально или диагонально при перетаскивании и уменьшения тенденции к добавлению малых отрезков в контактных площадках при перетаскивании.

Наведите курсор мыши на изображение, чтобы увидеть поведение в предыдущих версиях.

Перемещение компонента с трассировкой

Сочетание клавиш Ctrl+Стрелка является распространенным способом перемещения выделенного компонента на один шаг сетки (зажмите клавишу Shift для перемещения на десять шагов сетки). Этот способ теперь поддерживает опцию Component re-route (страница Interactive Routing диалогового окна Preferences) – при перемещении компонента трассировка будет обновлена.

Rigid-Flex 2

Возможности конструирования гибко-жестких плат находятся в непрерывное развитии. Недавние обновления включают в себя новые функциональные возможности определения регионов платы и линий сгиба при работе в режиме Board Planning Mode редактора плат и новый режим Board в Layer Stack Manager. Этот набор новых функциональных возможностей имеет общее название Rigid-Flex 2.0.

Для переключения между Rigid-Flex 1.0 и Rigid-Flex 2.0 задайте в диалоговом окне Advanced Settings опции, приведенные ниже:

  • PCB.RigidFlex2.0 – включает функциональные возможности Rigid-Flex 2.0 в Board Planning Mode. Обратите внимание, что в предыдущих версиях Altium NEXUS эта опция называлась Legacy.PCB.RigidFlex. Работа была изменена в соответствии со сменой названия – включение старой опции восстанавливало старый режим (Rigid-Flex 1.0), в то время как включение новой опции включает новый режим (Rigid-Flex 2.0).
  • PCB.RigidFlex.SubstackPlanning – включает режим Board в Layer Stack Manager.

Узнайте больше о Конструировании гибко-жестких плат

Возможность масштабирования толщины слоев в режиме Board в Layer Stack Manager

В режиме Board в Layer Stack Manager слои отображаются для приблизительного представления их физической толщины (используйте Ctrl + Вращение колеса мыши для изменения масштаба этого вида). Для упрощения работы с платами большой толщины, с большим количеством слоев была добавлена опция Realistic Ratio. Когда эта опция отключена, слои продолжают отображаться с толщиной, которая пропорциональна их доле общей толщины, но с меньшим коэффициентом.

Толщина слоев представляет их фактическую толщину. Наведите курсор мыши на изображение, чтобы увидеть разницу при включенной и отключенной опции Realistic Ratio.

Улучшения объекта Rectangle

Добавлена возможность заблокировать соотношение сторон

Добавлена возможность заблокировать ширину и высоту прямоугольника. Переключайте иконку цепи в режиме Rectangle панели Properties для блокирования/разблокирования соотношения сторон при изменении ширины/высоты прямоугольника. Иконка изменится для отображения текущего состояния блокирования.

Прямоугольник с заблокированным соотношением сторон. Наведите курсор мыши на изображение, чтобы увидеть иконку разблокированного состояния.

Добавлена возможность преобразования прямоугольников

В меню Tools » Convert была добавлена команда Explode Rectangles to Free Primitives, которая позволяет преобразовать объект Rectangle в изначальный набор примитивов.


Управление данными

Новое диалоговое окно и команда в панели Projects – Save to Server

When a document that belongs to a project on a server has been modified and saved locally, the Projects panel entry displays a Save to Server link, which alerts you to also save the modifications to the server. Clicking the link opens the Save to Server dialog in which you can select the documents to be saved. After clicking OK, the documents are saved to the server and the Save to Server link disappears from the Projects panel.

Добавлена команда Exclude from Project

Команда Remove from Project, которая была исключена ранее, была восстановлена и переименована в Exclude from Project, чтобы сделать функцию этой команды более очевидной. Эта команда находится в контекстном меню панели Projects (проекты должны быть под управлением контроля версий).

Улучшенная команда Delete для проектов

Команда Delete контекстного меню панели Projects теперь доступна для проектов всех типов, т.е. не только для проектов под управлением контроля версий.

Добавлены новые типы нарушений дублирования компонентов

Для предотвращения создания дубликатов компонентов в редакторе Single Component Editor, на страницу Data Management - Component Rule Checks диалогового окна Preferences были добавлены новые типы нарушений: Duplicate component by Name (Дубликат компонента по названию) и Duplicate component by PCL (Дубликат компонента по списку вариантов выбора). По умолчанию режимом отчета (Report Mode) для обоих нарушений является No Report.

Изменение режима Report Mode нарушений этих типов повлияет на производительность выпуска компонентов, поскольку будут произведены дополнительные запросы к серверу для поиска дубликатов.

Модули импорта/экспорта

Улучшения экспорта файлов Hyperlynx

Был улучшен модуль экспорта Hyperlynx (*.HYP) – теперь включаются номиналы компонентов (параметр Value компонентов) и номера компонентов (параметр Comment компонентов). Ранее экспортированные файлы включали в себя только информацию о слоях и позиционных обозначениях. Эта информация упрощает процесс назначения моделей компонентов в Hyperlynx.


Имитатор электрических цепей

Добавлена поддержка размещения символов на основе модели SPICE

Добавлено формирование специальных символов для компонентов SPICE, описанных командой .MODEL. Обратите внимание на изображение ниже, где активной библиотекой является файл модели models3.mdl. Когда в списке выделена модель поддерживаемого типа, подходящий символ компонента автоматически выбирается из библиотеки Simulation Generic Components. Это позволяет разместить выбранную модель в виде символа прямо на схеме.

В таблице ниже приведен список поддерживаемых типов моделей и библиотечных компонентов, из которых размещается символ.

Компонент Текст модели Символ
(Design Item ID в библиотеке имитационных моделей)
Резистор .MODEL <название модели> RES Resistor
Конденсатор .MODEL <название модели> CAP Capacitor
Индуктивность .MODEL <название модели> IND Inductor
Диод .MODEL <название модели> D Diode
Биполярный транзистор .MODEL <название модели> NPN BJT NPN 4 MGP
Биполярный транзистор .MODEL <название модели> PNP BJT PNP 4 MGP
Полевой транзистор с управляющим p-n-переходом .MODEL <название модели> NJF JFET N-ch Level2
Полевой транзистор с управляющим p-n-переходом .MODEL <название модели> PJF JFET P-ch Level2
Полевой МОП-транзистор .MODEL <название модели> NMOS MOSFET N-ch Level1
Полевой МОП-транзистор .MODEL <название модели> PMOS MOSFET P-ch Level1

Добавлена поддержка файлов *.CIR

Добавлена поддержка файлов *.cir в качестве файлов библиотек SPICE.

Значения по умолчанию для анализа AC, DC и Transient

Теперь поддерживаются значения по умолчанию для полей входных данных анализов AC, DC и Transient Analysis.


Altium NEXUS 4.1

Выпущен: 12 февраля 2021 – Версия 4.1.1 (сборка 18)

Информация о выпуске Altium NEXUS версии 4.1

Обновление Update 1 для Altium NEXUS 4 продолжает развивать базовые технологии системы, предлагая новые функции и улучшения, а также реализует многие идеи, предложенные пользователями через систему BugCrunch сообщества AltiumLive.


Ввод схем

Упрощенная замена компонентов общего вида

Компоненты общего вида – это базовые компоненты, которые можно быстро разместить в проекте без необходимости искать и выбирать определенные компоненты от производителей из доступных источников. Используйте их в качестве местозаменителей, которые можно легко заменить на подходящие компоненты на более поздних этапах процесса проектирования. Их также можно считать виртуальными или параметрическими компонентами.

Поле Design Item ID в режиме Generic Component панели Properties было заменено на кнопку Replace. Кнопка Replace работает так же, как кнопка в предыдущем поле Design Item ID, которая была заменена для более точного отражения своей работы. При нажатии на кнопку Replace будет открыто диалоговое окно Replace Generic Component, в котором вы можете выбрать нужный компонент. После выбора нажмите OK в диалоговом окне Replace Generic Component, и компонент общего вида на схеме будет заменен на выбранный компонент.

В режим Generic Component панели Properties было также добавлено поле Comment, доступное только для чтения. В этом поле по умолчанию отображается значение ComponentType и значения других параметров, если они заданы.

Настройка посадочного места для компонента общего вида – только закрытая бета

Компоненты общего вида могут использоваться в качестве местозаменителей компонентов, и их свойства можно определить в процессе проектирования. Чтобы упростить этот процесс, теперь доступен список всех посадочных мест из подключенного Workspace.

Список посадочных мест включает в себя:

  • Посадочные места в подключенном в данный момент Workspace.
  • Посадочные места, используемые в других компонентах с тем же значением ComponentType.

Прочие обновления интерфейса компонентов общего вида включают в себя (только в закрытой бете):

  • При щелчке ЛКМ по плитке компонента общего вида в панели Components будет открыт список всех доступных компонентов этого типа.
  • Нажатие кнопки в плитке компонента общего вида в панели Components запускает режим размещения – наведите курсор мыши на плитку, чтобы увидеть эту кнопку.

Узнайте больше о компонентах общего вида.

Работа с шаблонами схем

При выборе локального шаблона листа схемы (Design » Sheet Templates » Local), опция Choose another file была переименована на Load From File для лучшего отражения функции этой команды.

Видимость параметра перекрестной ссылки

Для параметра CrossRef объектов Port и Offsheet Connector была добавлена иконка видимости (). Включите/отключите эту иконку в панели Properties для объектов в соответствии со своими потребностями. На изображении ниже показана иконка видимости, включенная для параметра CrossRef порта, который выделен на листе схемы.


Конструирование плат

Rigid-Flex 2.0 с усовершенствованным управлением стеком слоев

Rigid-Flex 2.0 обеспечивает поддержку всех существующих типов конструкций гибко-жестких плат. Первым этапом была реализация улучшений для регионов плат и линий сгиба. В этом обновлении реализован режим Board в Layer Stack Manager, который значительно упрощает определение и структурирование различных сабстеков, необходимых в гибко-жесткой конструкции.

Ключевые улучшения в Rigid-Flex 2.0:

  • Новый режим Board в Layer Stack Manager, предоставляющий разрез платы для структурирования различных сабстеков (становится доступным после включения режима Rigid-Flex в Layer Stack Manager).
  • Определение перекрывающихся гибких регионов (часто называемых гибко-жесткими платами типа "книжный переплет").
  • Определение гибкой секции, которая перекрывает жесткий регион.
  • Возможность выделения определенных слоев в сабстеке с помощью Shift+ЛКМ.
  • Перетаскивание с зажатой ЛКМ и команды копирования/вставки в контекстном меню для созданию нового сабстека из выбранных слоев/сабстека.
  • Определение расстояния проникновения гибких регионов для любого сабстека (задайте для опции Material Usage значение Individual).

Новый режим Board в Layer Stack Manager наглядно предоставляет всю структуру платы. Поскольку во многих гибко-жестких конструкциях могут использоваться одни и те же конфигурации сабстеков для различных регионов платы, были добавлены команды для быстрого дублирования существующего сабстека в новое положение. Выберите сабстек и щелкните ПКМ, чтобы добавить копию этого сабстека до или после любого существующего сабстека или скопировать и вставить сабстек в новое место (с помощью диалогового окна Insert Selected Layers).

Помимо выделения сабстека, вы также можете выделить определенные слои в сабстеке и скопировать/вставить их в новое место. Зажмите Shift при щелчке ЛКМ по слою, чтобы выделить отдельный слой. Продолжайте использовать Shift+ЛКМ для других слоев, чтобы сформировать набор выделенных слоев. Либо используйте Shift+ЛКМ для первого нужного слоя, затем перейдите сразу к последнему нужному слою и используйте Shift+ЛКМ, чтобы выделить его – все слои между ними также будут выделены.

Затем вы можете перетащить набор выделенных слоев с зажатой ЛКМ в горизонтальном направлении в режиме Board, чтобы создать новый сабстек из этих слоев либо щелкнуть ПКМ и использовать команды контекстного меню (как показано на видео ниже).

Функциональные возможности режима Board находятся на стадии открытого бета-тестирования. Включите опцию PCB:RigidFlex.SubstackPlanning в диалоговом окне Advanced Settings, чтобы сделать их доступными.

Новая команда управления 3D-представлением

В набор доступных предопределенных 3D-видов был добавлен обратный изометрический вид Flipped Isometric View. Используйте команду View » 3D View Control » Flipped Isometric View главного меню или сочетание клавиш Ctrl+Num0.


Управление данными и совместное проектирование

Улучшения уведомлений сотрудников

Панель сотрудников и уведомления пользователей были обновлены для предоставления дополнительной информации о проектировщиках, работающих над одним и тем же проектом, где к редактируемым документам применяется "мягкая блокировка". Эта блокировка относится к проектировщику, который первый внес изменение в документ, и другие проектировщики могут ее переопределить. Текущее состояние совместной работы отображается в панели Projects и в панели сотрудников, где пользователи теперь показаны в отдельных группах просмотра и редактирования.

Обновления пользовательского интерфейса также касаются диалоговых окон, которые появляются при наступлении ключевых событий, связанных с совместной работой, таких как попытка внесения локальных изменений в документ, который редактируется (находится в измененном состоянии) другим пользователем. В этом случае, скорее всего, возникнет конфликт версий, поэтому в диалоговом окне будет предложено отменить локальные изменения или проигнорировать (переопределить) эту мягкую блокировку. Это диалоговое окно заменяет собой предыдущее диалоговое окно Edit Document.

Отображение двух проектировщиков, работающих над одним документом.

Перейдите на страницу Визуализация сотрудников и предотвращение конфликтов для получения более подробной информации.

Обратите внимание, что уведомления о совместной работе можно отключить, сняв флажок Enable Conflict Prevention Notifications на вкладке General диалогового окна Project Options (Project » Project Options).

Сравнение файлов Gerber между двумя выпусками

Распространенной проверкой готовности к выпуску, используемой многими проектировщиками, является сравнение файлов Gerber, сформированных текущим выпуском, и файлов Gerber из предыдущего выпуска. Эту проверку можно выполнить в средстве Project Releaser после подготовки к выпуску. Сравнение осуществляется в Altium 365. В вашем веб-браузере по умолчанию будет открыт Workspace компании и будут показаны результаты.

Перейдите в раздел Сравнение Gerber, чтобы узнать больше.

Работа с шаблонами

Если шаблон был задан на странице Data Management - Templates диалогового окна Preferences в качестве шаблона по умолчанию, он будет отображен как My Default вместо Default, чтобы отличать его от шаблона по умолчанию, заданного системой.

Локальные и серверные шаблоны теперь можно вызывать и выбирать для документов схем Multi-board.


Имитатор электрических цепей

Компоненты и модели

Отображение локальных и общих библиотек имитационных моделей было объединено для упрощения работы с источниками моделирования и компонентами общего вида. Это изменение отражено в пользовательском интерфейсе тем, что удалена кнопка Generic из опций выбора источника в диалоговом окне Sim Model. Оба типа локальных библиотек доступны при выборе опции Local.

Анализ

В качестве изменяемых переменных для анализа по постоянному току теперь доступно больше объектов цепи. Для выбора в выпадающем списке переменных доступны объекты, такие как резисторы, но не конденсаторы и индуктивности.

Имитатор теперь поддерживает функции sdt, ddt и функцию LTspice delay для анализа переходных процессов.

Графики и результаты

Теперь можно переименовывать строки собранных результатов моделирования в панели Simulation Dashboard и добавлять описания.

В диалоговое окно Add Output Expression было добавлено поле Plot Number, которое позволяет выбрать график, в котором будут отображены данные моделирования.

Узнайте больше об имитаторе электрических цепей со смешанными сигналами и недавних обновлениях интерфейса пользователя имитатора.

 


Altium NEXUS 4.0

Выпущен: 11 января 2021 – Версия 4.0.9 (сборка 70) Hot Fix
Выпущен: 17 декабря 2020 – Версия: 4.0.8 (сборка 67)

Информация о выпуске Altium NEXUS версии 4.0

Улучшенные функции комментирования документов

В сочетании с недавними обновлениями функций комментирования в Altium 365 Workspace, Altium NEXUS теперь предлагает подобный набор обновленных и улучшенных возможностей комментирования, доступных при подключении к серверу Altium.

 

Комментирование в редакторах проекта было значительно улучшено с точки зрения графики, удобства использования и получения связанной информации, с сохранением обратной совместимости с комментариями, размещенными ранее. Комментарии теперь размещаются непосредственно из панели Comments, они включают в себя возможность захвата экрана для предварительного просмотра, добавление нарисованных от руки пометок, назначение/упоминание пользователей и гибкие опции настройки видимости и фильтрации.

 

Читать далее...

Улучшения производительности редактора схем

Новые и улучшенные средства упрощают анализ связности в проекте. Наведите курсор мыши на цепь, чтобы узнать логическое (схема) и физическое (плата) имя цепи. Щелкните ЛКМ по цепи с зажатой клавишей Alt, чтобы подсветить эту цепь во всем проекте. Дважды щелкните ЛКМ по цепи с зажатой клавишей Alt, чтобы отобразить древо всех листов схем, на которых эта цепь находится, затем щелкните ЛКМ, чтобы увидеть цепь на одном из этих листов.

  • Упрощенный анализ цепи и улучшенное получение информации о цепи.
  • Автоматическая нумерация листов в панели Projects.
  • Перекрестные ссылки для межлистовых соединителей.

Читать далее...

Визуализация сотрудников и предотвращение конфликтов

Чтобы восполнить необходимость в получении динамической информации о состоянии общего документа и в контроле над ним в среде редактирования Altium NEXUS, в проектную и серверную платформы был внесен ряд обновлений, реализующих новую систему визуализации текущего состояния общих документов и реагирования на него.

 

Эта система позволяет вам в режиме реального времени видеть, кто просматривает или редактирует общий документ, и она доступна благодаря свободному обмену данными о публикации документов между клиентскими приложениями через сервер Altium Workspace (необходим). Визуализация сотрудников реализована с помощью новых иконок статуса, панели сотрудников и дополнительной логики блокирования файлов.

 

Читать далее...

Компоненты общего вида - только закрытая бета

В новой версии Altium NEXUS реализована концепция стандартных компонентов общего вида, которые можно быстро разместить в проекте без необходимости искать и выбирать определенные компоненты производителя.

 

Компонент общего вида выполняет роль местозаменителя, который легко заменить на подходящий физический компонент с соответствующими параметрами на более поздних стадиях разработки.

 

Обновления интерфейса SPICE-моделирования

Вслед за недавней реализацией нового, улучшенного ядра моделирования SPICE для Altium NEXUS, которое обеспечивает более высокую сходимость, точность и надежность результатов, в новой версии сделан упор на улучшения интерфейса пользователя, связанных с рабочим процессом проведения смешанного SPICE-моделирования.

 

Изменения интерфейса имитатора включают в себя: новую интуитивно понятную панель Simulation Dashboard, обновленное диалоговое окно Sim Model и общие изменения интерфейса. Новый рабочий процесс моделирования, основанный на панели Simulation Dashboard, предлагает альтернативу существующему подходу, основанному на диалоговом окне Analyses Setup. Также теперь доступен широкий набор готовых к использованию компонентов общего вида для моделирования.

 

Читать далее...

Новый редактор правил проектирования

Новый редактор правил Rules Editor предлагает альтернативный подход к просмотру, созданию и управлению правилами проектирования, которые используются в документах плат. Редактор правил Rules Editor, интерфейс которого представлен в виде вкладки документа, существует совместно с диалоговым окном Rules and Constraints Editor, но предлагает подход к управлению правилами, ориентированный на проект, а не только на сами правила.

 

Новый редактор правил Rules Editor, вызываемый из существующего диалогового окна Rules and Constraints Editor, использует более простой и интуитивно понятный подход к созданию правил проектирования, без определения области действия правил с помощью запросов, с объединением множества правил по типу объектов, автоматическим определением и применением приоритетов правил и т.д.

 

Читать далее...

Новые паттерны подстройки длины цепей

В новой версии реализованы значительные улучшения возможностей подстройки длины одиночных цепей и дифференциальных пар – были добавлены новые паттерны: "тромбон" и "зубья пилы". Эти паттерны отображаются внутри подстроечного рукава, что упрощает перетаскивание паттерна вдоль трасс и изломов.

 

Читать далее...

Улучшения интерактивного перетаскивания

Была улучшена работа перетаскивания переходных отверстий: было добавлено управление эффективностью сглаживания как для редактируемой цепи, так и для соседних цепей. Также было улучшено перетаскивание дифференциальных пар, которые теперь остаются сцепленными независимо от направления перетаскивания. Переходные отверстия в дифференциальных парах также остаются сцепленными в процессе перетаскивания.

 

Читать далее...

Улучшения конструирования гибко-жестких плат

В новой версии Altium NEXUS реализованы значительные улучшения в процесс работы с конструкциями гибко-жестких плат. Помимо большого количества улучшений и исправлений ошибок, этот новый этап развития технологий проектирования гибко-жестких плат в Altium – Rigid-Flex 2.0 – вносит улучшения в следующие области:

  • Возможность создания формы платы путем интерактивного определения отдельных регионов в режиме Board Planning Mode. Читать далее...
  • Упрощенное определение линий сгиба. Читать далее...
  • Улучшенное редактирование регионов и линий сгиба в панели Properties.
  • В разработке – реалистичная визуализация стекапа в Layer Stack Manager.

Дополнительные изменения и улучшения

Помимо крупных обновлений, перечисленных выше, в новой версии был сделан упор на совершенствование и улучшение существующих функциональных возможностей. В новой версии был добавлен ряд улучшений на основе обратной связи с форума и системы BugCrunch от Altium. Некоторые из этих улучшений:

  • Теперь в редакторе Single Component Editor доступно сопоставление выводов компонентов множеству контактных площадок с помощью новой панели Pins.
  • Альтернативным схемным символам компонентов теперь могут быть заданы пользовательские имена.
  • Дополнительные опции для правила проектирования Component Clearance – теперь вы можете исключить из проверки компоненты без 3D-моделей, а также задать проверку расстояния по границе компонента.
  • Внутренние экранные слои теперь могут использовать те же самые алгоритмы заливки, что и полигоны, размещенные на сигнальных слоях, что обеспечивает улучшенное определение контуров и подключение контактных площадок/переходных отверстий.
  • Групповые заготовки теперь поддерживают размещение под произвольным углом.
  • Новые специальные строки редактора плат для толщины слоев.
  • Команды быстрой трассировки и быстрой трассировки дифференциальных пар для более отзывчивой интерактивной трассировки.
  • Обновленное диалоговое окно ODBᐩᐩ Setup, позволяющее лучше управлять тем, как механические слои будут объединены в выходных документах.
  • В меню Place редактора плат добавлен новый объект "прямоугольник".
  • Упрощенное размещение графики на плате с помощью команды Place » Graphic.
  • Поддержка цифрового блока клавиатуры для управления перемещением и вращением 3D-вида.
  • Механические слои теперь могут быть включены в 3D, что отлично подходит для аннотирования 3D-изображения.
  • Новая команда экспорта 3D-платы как изображения с возможностью определения формата и разрешения изображения.

Читать далее...


 

Обнаружили проблему в этом документе? Выделите область и нажмите Ctrl+Enter, чтобы оповестить нас.

Связаться с нами

Связаться с нашими Представительствами напрямую

We're sorry to hear the article wasn't helpful to you.
Could you take a moment to tell us why?
200 characters remaining
Вы сообщаете о проблеме, связанной со следующим выделенным текстом
и/или изображением в активном документе: