Altium NEXUS Documentation

Шаблоны и библиотеки контактных площадок и переходных отверстий_AD

Последнее изменение: Pavel Demidov; 04.05.2021
Полное содержание

Наряду с трассами (объектами Track), контактные площадки (Pad) и переходные отверстия (Via) являются фундаментальными элементами всех конструкций печатных плат. Задать настройки любой контактной площадки или переходного отверстия можно во время или после размещения.

     Контактная площадка и переходное отверстие в 3D

Для лучшего повторного использования проектных данных и управления контактными площадками (КП) и переходными отверстиями (ПО) в проектах плат, Altium NEXUS также поддерживает автоматизированное создание шаблонов КП и ПО, библиотеки КП и ПО и набор панелей для управления КП и ПО.

Концепция шаблонов КП и ПО, которые можно собрать в библиотеку, мало чем отличается от концепции библиотек посадочных мест, хоть она и несколько проще. Библиотека шаблонов КП и ПО хранит в себе не сами КП и ПО, а их предварительно настроенные определения, которые применяются к экземпляру размещаемой контактной площадки или переходного отверстия. Сохраненные библиотеки шаблонов КП и ПО могут быть загружены и использованы в любом проекте платы или библиотеке посадочных мест для размещения экземпляров предварительно настроенных контактных площадок и переходных отверстий.

Создание и редактирование библиотеки шаблонов КП и ПО

Библиотека шаблонов КП/ПО – это тип проектных документов с расширением файла *.PvLib, который может быть создан в Altium NEXUS. Библиотеки шаблонов КП/ПО могут быть добавлены в состав проекта – в этом случае, эти шаблоны всегда будут доступны в проекте через панель PCB Pad Via Templates. Библиотеки шаблонов также могут быть установлены в панели, что сделает их доступными для любого открытого проекта. Чтобы узнать больше о том, как сделать шаблоны доступными, перейдите в раздел Работа с шаблонами КП/ПО.

Создание и редактирование шаблонов КП и ПО осуществляется путем открытия файла PvLib. Список шаблонов КП и ПО в библиотеке PvLib приведен в панели Pad Via Library, а выделенный шаблон КП или ПО отображается в редакторе шаблона КП/ПО, как показано ниже.


Шаблоны КП и ПО редактируются в файле PvLib. Опции редактора меняются в зависимости от типа редактируемого объекта.

Создание библиотеки шаблонов КП/ПО

Чтобы создать новую библиотеку шаблонов, выполните следующее:

  1. Выберите команду File » New » Library » Pad Via Library из главного меню. Новой библиотеке шаблонов КП/ПО будет задано имя по умолчанию PvLib1.PvLib. На этом этапе, файл не сохраняется на жестком диске – он существует только в оперативной памяти. Поскольку файл не сохранен, при первом сохранении файла будет открыто диалоговое окно Save As, предлагающее сохранить файл в расположение по умолчанию, заданное в поле Default Location на странице System - Default Locations диалогового окна Preferences.
  2. Новую библиотеку шаблонов КП/ПО также можно добавить в текущий проект, щелкнув ПКМ по строке проекта в панели Projects и выбрав команду Add New to Project » Pad Via Library из контекстного меню. Файл появится в разделе Libraries \ Pad Via Library Documents в структуре проекта. При сохранении файла, его расположением по умолчанию будет папка проекта.
  3. Библиотеку шаблонов КП/ПО также можно создать из контактных площадок и переходных отверстий в открытом документе плате с помощью панели PCB в режиме Pad & Via Templates. С помощью стандартных методов выделения, используемых в Windows, выделите шаблоны КП/ПО, которые нужно сохранить в библиотеку, и нажмите кнопку Save as Library. Будет открыт новый файл PvLib, готовый к редактированию, но который еще не сохранен на жестком диске. Сохраните файл в подходящее расположение, задав ему нужное имя. При первом открытии библиотеки шаблонов КП/ПО в редакторе шаблонов, в панели Pad Via Library может отобразиться только один шаблон контактной площадки (шаблон по умолчанию). В этом случае, сохраните, закройте и снова откройте файл, чтобы обновить список шаблонов в панели Pad Via Library.

    Библиотеку шаблонов КП/ПО можно создать из контактных площадок/переходных отверстий, выбранных в текущем документе платы.

Панель Pad Via Library

В панели Pad Via Library приведен список шаблонов КП и ПО, которые находятся в текущей библиотеке шаблонов КП/ПО. Выбор единиц измерения, предпочтительных для текущего сеанса редактирования, осуществляется в выпадающем меню Display Units в верхней части панели.

Чтобы создать новый шаблон контактной площадки или переходного отверстия, щелкните ПКМ в панели в выберите соответственно команду Add Pad Template или Add Via Template из контекстного меню. Используйте команду Delete, чтобы удалить шаблон из библиотеки.


Панель предоставляет доступ к шаблонам из текущей библиотеки КП/ПО. Щелкните ПКМ для добавления нового шаблона.

Редактор Pad/Via Template Editor

Редакторы Pad Template Editor и Via Template Editor используются для настройки базовых опций шаблона КП или ПО соответственно, которые затем могут быть применены к контактной площадке или переходному отверстию в документе платы или в библиотеке посадочных мест. К ним относятся основные свойства КП/ПО, в то время как свойства, относящиеся к документу (расположение, ориентация, слой и т.д.) определяются при размещении контактной площадки или переходного отверстия в документе.


Редактор шаблонов используется для настройки шаблона КП или ПО, выбранного в данный момент в панели Pad Via Library.

Большинство опций КП/ПО – это стандартные для Altium NEXUS настройки объектов Pad и Via (размер, отверстие, маска и т.д.). Оба редактора Pad Template Editor и Via Template Editor используют схожие интерфейс и опции. Разделы редактора шаблонов описаны ниже, где даны соответствующие примечания по опциям, специфичным для контактных площадок или переходных отверстий.

General (Общие)

  • Name (Название) – по умолчанию название КП/ПО задается автоматически, исходя из ее свойств, в соответствии со стандартом IPC-7251/7351 Padstack naming conventions (см. этот раздел). При необходимости можно задать название вручную и удалить его снова с помощью кнопки . Если шаблон с пользовательским названием был использован в проекте и затем связь с шаблоном была удалена (для возможности редактирования свойств объекта), это название будет удалено и заменено автоматически сформированным названием.
  • Description (Описание) – опциональное описание.
  • Pad Type (Тип КП, только для КП) – выбор между КП для поверхностного (SMT) и сквозного (Through hole) монтажа.

Hole Information (Информация об отверстии)

  • Hole Size (Размер отверстия) – диаметр отверстия, обозначается как h<Значение> в названии.
  • Tolerance (Предельные отклонения) – верхнее и нижнее предельные отклонения отверстия, обозначаются как Tol в названии. Введите N/A, если неприменимо.
  • Hole Type (Тип отверстия, только для КП) – круглое (Round), квадратное (Square) или паз (Slot).
  • Length (Длина, только для КП) – длина квадратного отверстия или паза, обозначается как _<Значение> после размера отверстия в названии.
  • Rotation (Поворот, только для КП) – угол поворота квадратного отверстия или паза.
  • Plated (Металлизация, только для КП) – наличие или отсутствие металлизации (неметаллизированные отверстия обозначаются как n в названии).

Paste Mask (Паяльная паста, только для КП)

  • Manual Expansion (Заданный вручную припуск) – обозначается как p<Значение> в названии.
  • Expansion (Припуск) – радиальное значение расширения (значение +ve) или сужения (значение -ve) вскрытия паяльной пасты.

Solder Mask (Паяльная маска)

  • Manual Expansion (Заданный вручную припуск) – обозначается как m<Значение> в названии, где m<Значение> – это общий размер вскрытия паяльной маски. Эта часть названия обозначается как m<Значение>mx<Значение>, если значения вскрытий для верхнего и нижнего слоя не связаны между собой.
  • Top/Bottom (Верхний/нижний слой) – величина вскрытия, измеренная от края контактной площадки, если не включена опция Solder mask from the hole edge.
  • – значения для верхнего и нижнего слоя связаны между собой (одинаковы). Нажмите, чтобы определить различные значения для верхнего и нижнего слоя.
  • Tented (Тентирование) – включите, чтобы закрыть вскрытие паяльной маски (т.е. чтобы задать размер вскрытия, равным нулю).
  • Solder mask from the hole edge (Паяльная маска от края отверстия) – включите, чтобы задать величину вскрытия от края отверстия, а не от края контактной площадки.

Size and Shape (Размер и форма)

  • Offset From Hole Center (X/Y) (Отступ от центра отверстия по X/Y, только для КП) – величина отступа отверстия контактной площадки от ее центра, обозначается как o<ЗначениеX>_<ЗначениеY> в названии.
  • Mode (Режим) – тип стека КП/ПО. Доступные опции: Simple (Простой), Top-Middle-Bottom (Верхний-Средние-Нижний слои) и Full Stack (Полный стек – для контактных площадок эта опция доступна, только когда для Pad Type выбрано Through hole). Позволяет задавать различные свойства размера и формы КП/ПО на соответствующих слоях. При определении отличных размеров/формы для нижнего слоя в название добавляется x<ЗначениеX_ЗначениеY>. При определении отличных размеров/формы для средних слоев в название добавляется z<ЗначениеX_ЗначениеY>.
  • Attributes on Layer (Атрибуты для слоев) – стандартные атрибуты КП/ПО.
    • Shape (Форма, только для КП) – обозначается в названии как c<ВеличинаРазмера> (Round, круглая); s<ВеличинаРазмера> (квадратная) или r<xВеличинаРазмера_yВеличинаРазмера> (Rectangular, прямоугольная), в зависимости от того, отличаются ли размеры по X и Y или нет; s<ВеличинаРазмера>c<Значение> (Octagonal, восьмиугольная); s<ВеличинаРазмера>r<ВеличинаРадиуса> или r<xВеличинаРазмера_yВеличинаРазмера>r<ВеличинаРадиуса> (Rounded Rectangle, прямоугольная со скругленными углами).
    • X & Y Size (Размеры по X и Y, только для КП) – размер контактной площадки по осям X и Y.
    • Corner Radius (Радиус скругления, только для КП) – процент скругления углов контактной площадки, где 100% соответствует полному скруглению по короткой стороне КП. Применимо только к форме Rounded Rectangle.
    • Diameter (Диаметр, только для ПО) – диаметр переходного отверстия (переходные отверстия могут быть только круглыми).
  • Thermal Relief (Термобарьер) – настройки термобарьера этой контактной площадки для окружающего полигона той же цепи. Снимите флажок From Rule, чтобы задать локальные настройки.
    • From Rule (Из правила) – когда эта опция включена, локальные настройки не применяются. Отключите, чтобы задать локальные настройки.
    • Connect Style (Стиль подключения) – стиль термобарьера.
    • Air Gap (Воздушный зазор) – расстояние от края контактной площадки для окружающего полигона.
    • Conductors (Проводники) – количество проводников из контактной площадки до окружающего полигона.
    • Width (Ширина) – ширина проводников из контактной площадки до окружающего полигона.
    • Angle (Угол) – угол паттерна проводников термобарьера.
  • Layer (Слой) – слои в стеке КП/ПО. Доступные слои зависят от текущего режима (Mode). Щелкните ПКМ, чтобы добавить слой (Add Layer), удалить слой (Remove Layer) или сбросить настройки (Reset layer list), когда выбран режим Full Stack.

Работа с шаблонами КП/ПО

Как упоминалось ранее, можно сохранять существующие шаблоны в библиотеки шаблонов КП/ПО, а также создавать новые шаблоны. Использование шаблонов в этих библиотеках осуществляется через панель PCB Pad Via Templates. Локальные шаблоны также приведены в этой панели, что делает их панель центральным расположением для работы с библиотеками шаблонов КП/ПО.

Панель PCB Pad Via Templates

Страница панели: PCB Pad Via Templates

Панель PCB Pad Via Templates – это специальная панель, в которой приводятся как шаблоны КП/ПО, сохраненные в текущем документе платы (локальные), так и шаблоны из библиотек КП/ПО, которые были установлены или добавлены в текущий проект (доступные библиотеки).

Нажмите кнопку внизу справа от области проектирования и выберите PCB Pad Via Templates, чтобы открыть панель.


Панель позволяет получить доступ как к локальным шаблонам, так и к шаблонам в библиотеках.

Две концепции библиотек, представленных в панели, можно обобщить следующим образом:

  • Available Pad/Via Template Libraries (Доступные библиотеки шаблонов КП/ПО) – загруженные или установленные библиотеки КП/ПО (файловые наборы шаблонов КП/ПО). В этом разделе панели приведены шаблоны, которые содержатся в выбранной в данный момент библиотеке КП/ПО.
  • Local Pad & Via Library (Локальные библиотеки шаблонов КП/ПО) – собирательный термин для шаблонов КП/ПО, используемых в текущем проекте платы, в том числе те, которые были взяты или добавлены из библиотеки КП/ПО. В этом разделе панели приведен список шаблонов, которые применены к КП/ПО в текущем проекте платы.

Локальная библиотека КП и ПО

Строки, приведенные в разделе Local Pad & Via Library панели, представляют настройки (шаблоны) КП/ПО, используемые в текущей плате и сохраненные в ней. Предварительный просмотр выбранного шаблона отображается внизу раздела.

Шаблоны, приведенные здесь, – это шаблоны КП/ПО, сохраненные в файле платы, они не содержатся в отдельной "библиотеке" как таковой. Выбранный шаблон можно использовать повторно в текущей плате как новый экземпляр КП или ПО путем перетаскивания мышью в область проектирования и с помощью команды Place из контекстного меню панели.


Размещение экземпляра локального шаблона контактной площадки.

Поскольку названия шаблонов, приведенные в локальной библиотеке, образованы КП и ПО в текущей плате, то при удалении всех экземпляров определенной локальной конфигурации КП/ПО из платы будет удален и соответствующий шаблон из списка локальных шаблонов КП/ПО.

Однако если размещенная КП или ПО была взята из библиотеки КП/ПО, то после удаления всех экземпляров этого КП/ПО из платы соответствующий шаблон останется в списке локальных шаблонов. Экземпляры шаблонов из библиотеки КП/ПО, которые больше не нужны, можно удалить из списка локальных шаблонов с помощью кнопки Remove Unused Pad/Via.

Доступные файловые библиотеки шаблонов КП и ПО

Раздел Available Pad/Via template Libraries панели используется для работы с файловыми библиотеками шаблонов КП/ПО.

Шаблон может быть размещен из выбранной библиотеки на плате путем перетаскивая из панели с зажатой ЛКМ или с помощью контекстного меню. Поскольку КП/ПО размещается из внешней файловой библиотеки шаблонов, свойства объекта не доступны для редактирования в плате, что можно увидеть на изображении панели Properties ниже, справа. Чтобы изменить свойства КП/ПО из библиотеки, необходимо удалить связь с шаблоном – подробнее об этом см. в разделе Удаление связи с библиотечным шаблоном.

    
Шаблоны из активной библиотеки КП/ПО, Preferred.PvLib в этом примере. Справа показаны свойства размещенного экземпляра выделенной контактной площадки. Обратите внимание, что физические свойства, такие как форма и размер отверстия КП, не доступны для редактирования.

При размещении в плате шаблона КП/ПО из файловой библиотеки объект остается связанным с шаблоном в исходной библиотеке и с ее названием. Поскольку шаблон находится во внешнем файле, свойства КП или ПО, использующего этот шаблон, невозможно изменить для обеспечения целостности исходного шаблона во внешнем файле библиотеки. Чтобы изменить КП/ПО, взятую из файлового шаблона, необходимо удалить связь с шаблоном – подробнее об этом см. в разделе Удаление связи с библиотечным шаблоном.

Выпадающее меню в верхней части панели используется для выбора активной библиотеки из доступных. На изображении ниже это библиотека ExampleViaLib.PvLib. Кнопка используется для открытия диалогового окна Available Libraries, где вы можете добавлять и удалять файлы библиотек шаблонов. Информация по доступным библиотекам приведена ниже. Используйте поле Filter для отображения только тех шаблонов, название (Name) которых начинается с введенной строки.

Как сделать библиотеки шаблонов КП/ПО доступными

Термин "доступные библиотеки" (Available Libraries) означает библиотеки шаблонов КП/ПО, шаблоны которых доступны для использования в текущей плате. Эти библиотеки шаблонов, включенные в текущий проект, а также библиотеки шаблонов, которые были установлены в Altium NEXUS. Управление библиотеками обоих типов доступно в диалоговом окне Available Libraries. Чтобы открыть это диалоговое окно, нажмите кнопку в верхней части панели PCB Pad Via Templates.


Установите внешнюю библиотеку КП/ПО или используйте вкладку Project, чтобы добавить внешнюю библиотеку в текущий проект.

  • На вкладке Project приведен список всех файлов PvLib, включенных в проект. Здесь также доступны кнопки для добавления и удаления библиотек из проекта.
  • На вкладке Installed приведен список всех библиотек шаблонов КП/ПО, доступных в данный момент в установке Altium NEXUS.

Использование шаблона в проекте

Шаблоны, приведенные в панели PCB Pad Via Templates, могут быть использованы в текущем документе платы следующими способами:

  • Размещение – разместите локальный или библиотечный шаблон КП/ПО непосредственно из панели.
  • Выбор из выпадающего списка Template в панели Properties, когда КП или ПО выделена. Используйте этот способ, чтобы изменить используемый шаблон выделенной КП или ПО.
  • В качестве ограничения в правиле – шаблон КП/ПО можно выбрать в качестве ограничения в правиле проектирования Routing Via Style (показано ниже).
  • В качестве области действия правила – при определении области действия правила проектирования (например, правила Testpoint Style) могут быть использованы следующие ключевые слова языка запросов:
  • Для сшивки/экранирования переходными отверстиями (Via Stitching/Shielding) – выберите нужный шаблон ПО (Via Template) в диалоговом окне Add Stitching to Net или Add Shielding to Net.


Используйте шаблоны ПО в правиле Routing Via Style или в настройке сшивки переходными отверстиями.

Шаблон КП/ПО и его именование

Для каждой уникальной контактной площадки и переходного отверстия, размещаемого на плате, автоматически создается шаблон КП и ПО, которому задается определенное название и который сохраняется в файле платы. Шаблон хранит базовую конфигурацию КП/ПО, в том числе размер, форму, тип структуры, информацию о паяльной пасте/маске и отверстии и т.п. Конфигурации автоматически присваивается название в соответствии со стандартами IPC (в частности, со стандартом IPC-7251/7351 Padstack naming conventions). Каждая КП и ПО, используемая в плате, ссылается на свой шаблон, который отображается в панели Properties, как показано ниже.

Система именования IPC основана на метрических единицах, где одна единица изменения равна одной тысячной доле миллиметра (10-5 метра, 10 мкм). Например, шаблон круглой контактной площадки 1,5 мм с отверстием 0,8 мм будет назван c150h80, где c означает круглую форму КП, а после h находится размер отверстия. Контактная площадка с именем r155_125 является прямоугольной КП для поверхностного монтажа размером 1,55 x 1,25 мм, а контактная площадка с именем s160h100 – это квадратная КП для выводного монтажа размером 1,6 мм с отверстием 1,0 мм. Для заданных свойств паяльной маски/пасты добавляются другие цифро-буквенные комбинации.

Чтобы увидеть, как это работает, проверьте свойства существующей КП или ПО в ее панели Properties, дважды щелкнув ЛКМ по объекту или выделив объект и выбрав Properties из его контекстного меню.


Автоматически сформированное название КП или ПО отображается в панели Properties.

Обратите внимание на назначенное название шаблона (Template) в разделе Pad/Via Template панели. Это название задается в соответствии со стандартами IPC исходя из свойств КП/ПО, таких как размеры, форма, отверстия и параметры паяльной пасты/маски. Изменения свойств будут отражены в названии шаблона. Конечно же, связь свойств КП или ПО и названием шаблона менее очевидна при работе с британской, а не метрической системой единиц измерения.

Поиск КП и ПО в области проектирования

Главная страница: PCB - Pad & Via Templates

При размещении КП или ПО с уникальными размерами в плате с помощью меню Place или панели инструментов Active Bar, в файле платы автоматически создается новый шаблон КП/ПО. Такие шаблоны называются локальными (<Local>). Список всех используемых шаблонов КП/ПО текущей платы можно увидеть в панели PCB в режиме Pad & Via Templates.

Назначением панели PCB является отображение размещенных объектов платы. Как правило, это текстовое отображение всех объектов, находящихся в данный момент в области проектирования. Панель поддерживает различные режимы, в каждом из которых объекты собраны по категориям. Выберите нужный режим в верхней части панели.

Включите опцию Zoom в панели, чтобы приближать объекты, которые вы выбираете. Нажмите кнопку Zoom Level, чтобы задать требуемый уровень приближения. Включите опцию Select, чтобы загружать эти объекты в панель Properties, где можно изучить и изменить их свойства. Панель PCB также содержит в себе опции для затенения (Dim) или маскирования (Mask) всех объектов, которые не представляют интереса, чтобы упростить визуальный поиск объектов в области проектирования. Нажмите F1, когда курсор наведен на панель, чтобы узнать больше.

Используйте режим Pad & Via Templates панели PCB, чтобы найти и выбрать нужную контактную площадку или переходное отверстие. Выбранные КП или ПО затем можно изменить для использования другого шаблона в панели Properties – выберите нужный шаблон в выпадающем списке Template. Панель PCB также можно использовать для сохранения выбранных КП и ПО в библиотеку шаблонов КП и ПО – подробнее об этом см. в разделе Создание и редактирование библиотеки шаблонов КП и ПО.

Для размещения выбранного шаблона КП/ПО можно использовать кнопку Place, если этот шаблон находится в библиотеке шаблонов КП/ПО. Чтобы разместить локальную КП/ПО, используйте панель PCB Pad Via Templates, как описано ниже.

Задачи управления и редактирования шаблонов КП/ПО

В этом разделе приведены различные сценарии, при которых необходимо изменить шаблон контактной площадки или переходного отверстия.

Применение другого шаблона к существующим КП/ПО

Может понадобиться применить другой шаблон к существующим КП/ПО (например, для уменьшения количества уникальных переходных отверстий, используемых в конструкции платы). В этом случае, используйте панель PCB в режиме Pad & Via Templates, чтобы найти и выделить КП/ПО, которые вы хотите изменить. Чтобы использовать другой шаблон для выделенных объектов, выберите нужный шаблон в выпадающем списке Template в панели Properties.


Применение другого шаблона.

Удаление связи с библиотечным шаблоном

Изменить свойства КП/ПО, использующего шаблон из файловой библиотеки, невозможно, поскольку в противном случае локальный экземпляр не соответствовал бы шаблону в библиотеке, на который он ссылается, после его изменения. Чтобы изменить КП или ПО, ссылающуюся на шаблон в библиотеке, связь с шаблоном необходимо удалить.

Нажмите кнопку Кнопка связи; нажмите, чтобы скопировать шаблон из файловой библиотеки в локальную библиотеку и задать связь с локальным шаблоном, чтобы удалить связь с шаблоном. При нажатии на эту кнопку, шаблон будет скопирован в локальную библиотеку, и выделенным экземплярам КП/ПО будет задана ссылка на этот локальный шаблон.

Демонстрация копирования шаблона из файловой библиотеки в локальную библиотеку для возможности редактирования свойствНажмите кнопку, чтобы удалить связь с шаблоном из файловой библиотеки. Шаблон будет скопирован в локальную библиотеку, и будет задана ссылка на этот локальный шаблон.

Если у КП/ПО, связь с которым удаляется, было задано пользовательское название в библиотеке шаблонов КП/ПО, это название будет удалено, и локальному шаблону будет присвоено название в соответствии со стандартом именования IPC.

Добавление библиотечного шаблона в локальную библиотеку

Если необходимо, библиотечный шаблон можно добавить в локальную библиотеку. Для этого щелкните ПКМ по названию шаблона и выберите команду Add to Internal Library из контекстного меню либо перетащите шаблон из раздела библиотеки КП/ПО панели в пустую область раздела Local Pad & Via Library. Неиспользуемые библиотечные шаблоны КП/ПО можно удалить из локальной библиотеки с помощью кнопки Removed Unused Pad/Via.

Чтобы получить информацию о том, как заменить локальный шаблон, а не добавить еще один шаблон в список локальных шаблонов, перейдите в раздел Замена локального шаблона ниже.

Демонстрация добавления файлового шаблона в локальную библиотеку КП и ПО

Обновление из библиотеки КП/ПО

Если шаблон КП/ПО был обновлен в библиотеке и этот шаблон уже используется в документе платы, нажмите кнопку Update в панели PCB Pad Via Templates, чтобы обновить шаблон КП/ПО в плате. Изменения будут автоматически применены ко всем экземплярам КП/ПО, использующим этот шаблон в плате.

При запуске обновления будет открыто диалоговое окно Update Pads/Vias on Board со списком обнаруженных изменений, которые будут применены.


Шаблоны КП/ПО, в которых были найдены отличия от своих версий в исходной библиотеке, можно обновить из библиотеки в плате.

Для управления процессом обновления, в диалоговом окне предлагается три опции:

  • Update locked objects – шаблоны объектов КП/ПО будут обновлены независимо от их состояния блокировки.
  • Update free objects – обновить только те шаблоны, которые применены к свободным КП/ПО.
  • Update component objects – обновить только те шаблоны, которые применены к КП/ПО, используемым в компонентах.

Синхронизации осуществляется на основе свойства Library контактной площадки или переходного отверстия, которое отображается в панели Properties при просмотре свойств выделенной КП или ПО соответственно. Обнаружение различий между локальной версией шаблона и исходным шаблона отображается в столбце Changed раздела Pads/Vias в панели PCB в режиме Pad & Via Templates.

Даже если название шаблона в исходной библиотеке КП/ПО было изменено, ссылка на то, где он применен к КП/ПО в документе платы, поддерживается идентификатором GUID шаблона, который хранится в документе платы.

Замена локального шаблона

Шаблоном КП/ПО из библиотеки также можно заменить локальный шаблон, что обновит контактные площадки или переходные отверстия на плате, использующие этот локальный шаблон.

Для этого перетащите нужный библиотечный шаблон из раздела Available Pad/Via template Libraries панели в раздел Local Pad & Via Library, но в этом случае, опустите ЛКМ, когда курсор находится над строкой существующего локального шаблона. Все экземпляры свободных КП/ПО и КП/ПО в компонентах, которые используют этот шаблон, будут обновлены в соответствии с новым стилем библиотечного шаблона.

На видео, показанном ниже, обратите внимание, что контактные площадки компонентов C1 и C2 физически меняются на тип, определенный библиотечный шаблоном, с r110_100 на s120.

Видео-демонстрацияПеретащите шаблон из библиотеки на строку локального шаблона, чтобы заменить все его экземпляры в плате.

Обнаружили проблему в этом документе? Выделите область и нажмите Ctrl+Enter, чтобы оповестить нас.

Связаться с нами

Связаться с нашими Представительствами напрямую

We're sorry to hear the article wasn't helpful to you.
Could you take a moment to tell us why?
200 characters remaining
Вы сообщаете о проблеме, связанной со следующим выделенным текстом
и/или изображением в активном документе:
Бесплатная пробная версия Altium Concord Pro

Заполните форму ниже, чтобы получить бесплатную пробную версию Altium Concord Pro