Altium NEXUS Documentation

Экспорт в PDF3D_AD

Created: 13.06.2021 | Updated: 13.06.2021

Пользователи Altium NEXUS уже давно используют возможность интерактивного просмотра конструкций печатных плат в полностью визуализированном 3D, что дает представление о реальной структуре конструкции платы, ее компонентах и связанных с ней механических деталей.

Существенные преимущества обеспечивает возможность предоставить эти 3D-возможности тем, кто непосредственно не входит в команду проектировщиков, например, производству и, не в последнюю очередь, заказчикам. Это стало возможным благодаря использованию возможности в Altium NEXUS экспорта в PDF 3D. Этот интерактивный 3D-формат доступен каждому, у кого есть новая версия повсеместно используемого ПО Adobe® Acrobat® Reader.

Интерактивное представление экспортированной 3D-конструкции в Adobe Reader, где вы можете масштабировать, вращать и выбирать конструктивные элементы, которые хотите увидеть.
Интерактивное представление экспортированной 3D-конструкции в Adobe Reader, где вы можете масштабировать, вращать и выбирать конструктивные элементы, которые хотите увидеть.

3D в Acrobat Reader

Интерактивный 3D-просмотр стал возможен для файлов PDF с появлением расширенных возможностей 3D-просмотра в Acrobat Reader, начиная с версии 7. Высокоуровневая детализация и опции конфигурации, которые постепенно улучшались в последующих версиях Acrobat Reader и которые создаются экспортом в PDF 3D из Altium NEXUS, совместимы с версиями 9 и выше.

Основой этих новых возможностей 3D является разработанный индустрией формат Universal 3D (U3D) для файлов компьютерной графики, который был стандартизирован Европейской ассоциацией производителей компьютеров (European Computer Manufacturers Association, ECMA) в качестве стандарта Standard ECMA-363 - Universal 3D File Format. U3D имеет собственную поддержку форматом PDF, и его можно легко встроить (и сжать) в файл PDF для интерактивного 3D-просмотра в Acrobat Reader.

Результатом является кроссплатформенный компактный формат 3D-файлов, не требующий специализированного программного обеспечения для просмотра 3D. В случае PDF 3D файлов, экспортированных из Altium NEXUS, встроенное содержимое включает в себя большинство данных, которые доступны для просмотра в собственном 3D в Altium NEXUS, в том числе трассы, контактные площадки, переходные отверстия, полигоны и т.д., все компоненты и полный набор слоев платы.

Расширение для экспорта в 3D

Возможности экспорта в PDF 3D становятся доступными в Altium NEXUS благодаря установке расширения PDF3D Exporter.

Это расширение устанавливается по умолчанию вместе с системой, но в случае его непреднамеренного удаления вы можете вернуться на вкладку Purchased страницы Extensions & Updates (нажмите вверху справа от проектной области и выберите Extensions and Updates из открывшегося меню). Нажмите , чтобы загрузить расширение, и перезапустите Altium NEXUS, когда будет запрошено. Когда расширение установлено и готово к использованию, оно отображается на вкладке Installed страницы Extensions & Updates.

Формирование PDF

Чтобы экспортировать файл PDF 3D, откройте нужный документ платы в проектной области и выберите команду File » Export » PDF3D из главного меню.

В отличие от экспорта фиксированного представления 3D-конструкции платы под определенным ракурсом, экспорт в PDF 3D можно назвать эквивалентным собственному интерактивному 3D-представлению в Altium NEXUS.

Соответственно, результат экспорта в PDF 3D предлагает те же возможности вращения, масштабирования и панорамирования и может принимать любую из цветовых схем, определенных активной конфигурацией представления. Чтобы просмотреть или изменить текущую конфигурацию и, следовательно, доступные цвета визуализации для экспортированного PDF, переключитесь на просмотр платы в 3D (клавиша 3) и откройте панель View Configuration. Цвета визуализации можно посмотреть в разделе 3D Settings вкладки View Options панели.

Вкладку View Options панели View Configuration можно быстро открыть с помощью сочетания клавиш Ctrl+D.
Файл PDF 3D будет создан в формате 3D независимо от активного в данный момент режима представления редактора плат (2D или 3D).

 

Опции экспорта

После того, как экспорт в PDF 3D был запущен (File » Export » PDF3D) и название/расположение целевого файла определено в стандартном для Windows диалоговом окне Export File, открывается диалоговое окно Export 3D для определения настроек визуализации, поведения и проектных данных, которые будут включены в PDF.

Диалоговое окно Export 3D позволяет настроить, как будет работать и выглядеть экспортированный PDF.
Диалоговое окно Export 3D позволяет настроить, как будет работать и выглядеть экспортированный PDF.

Используйте диалоговое окно Export 3D, чтобы настроить опции экспорта нужным образом, и нажмите кнопку Export, чтобы сформировать файл 3D PDF.

3D-файлы могут иметь большой размер, даже с учетом присущего этому формату сжатия данных, поэтому определите, какой уровень детализации данных о конструкции важен для целевого пользователя. Например, включение проводящих слоев (трасс, контактных площадок и т.д.) может не понадобиться тому, кто изучает механические аспекты конструкции платы.

Обратите внимание, что Acrobat Reader позволяет управлять отображением элементов модели (их групп или по отдельности) в соответствии с потребностями пользователя – см. далее.

 

При выборе того, какие 3D-данные будут включены, стоит также учитывать возможности 3D-визуализации на компьютере того, кто будет просматривать файл. Хотя размер итогового файла PDF 3D может быть приемлемым, процессор и графическая система целевой машины могут не справиться с плавной визуализацией сложной многослойной конструкции.

Эти опции определяют начальные настройки при открытии файла PDF в Acrobat Reader, и их можно легко изменить с помощью панели инструментов 3D в этом средстве просмотра. Обратите внимание, что если панель инструментов отключена в опциях экспорта PDF 3D, пользователь не сможет изменить представление.

 

Просмотр 3D PDF

Как вы можете себе представить, просмотр 3D PDF в Acrobat Reader довольно прост, где команды и меню являются логическим продолжением привычных 2D-функций.

3D-объекты можно панорамировать, масштабировать и вращать с помощью простых операций перетаскивания мышью и вращения колеса мыши, причем выбор функций осуществляется из плавающей панели инструментов 3D.

В панели инструментов 3D в Acrobat Reader доступны элементы управления для 3D-навигации и настройки освещения/представления.
В панели инструментов 3D в Acrobat Reader доступны элементы управления для 3D-навигации и настройки освещения/представления.

Особенно полезной функцией в этом средстве просмотра является область навигации Model Tree, которую можно открыть (если она еще не открыта) с помощью кнопки . Это позволяет пользователю осуществлять навигацию по всем объектам в 3D PDF, выбирать и подсвечивать интересующие объекты и управлять их видимостью.

Область навигации Model Tree особенно полезна для управления определенными компонентами и цепями.
Область навигации Model Tree особенно полезна для управления определенными компонентами и цепями.

Область навигации Model Tree является эффективным инструментом для изучения всех аспектов 3D-конструкции с высокой степенью детализации. Будь то подробное изучение расположения компонентов и компоновки или детальный осмотр внутренней структуры платы, дерево навигации можно использовать для поиска и отображения соответствующих объектов.

Отображение конструкции с отключенными компонентами и шелкографией, что показывает степень возможностей управления 3D, доступного в Acrobat Reader.
Отображение конструкции с отключенными компонентами и шелкографией, что показывает степень возможностей управления 3D, доступного в Acrobat Reader.

При выборе отдельных объектов в области Model Tree они подсвечиваются в окне просмотра цветом, выбранным в верхней части область (в данном случае, красным). Это упрощает определение положения отдельного объекта или цепи и позволяет не переключать видимость объекта для определения его положения. Аналогичным образом, при выборе объекта в окне 3D-просмотра его строка будет подсвечена в области Model Tree.

Для получения более подробной информации об использовании различных элементов управления, функций и настроек в Acrobat Reader см. соответствующий раздел справки Adobe: Отображение 3D-моделей в файлах PDF.

В экспортированный документ PDF 3D также включаются основные метаданные о конструкции из Altium NEXUS, такие как исходный файл конструкции, его автор, версия Altium NEXUS, даты создания/изменения и т.д. Эту информацию можно просмотреть в Adobe Reader на вкладке Description в диалоговом окне Document PropertiesFile » Properties.

Экспорт PDF 3D из файла OutJob

Чтобы включить экспорт PDF 3D в файл OutJob проекта, нажмите Add New Documentation Output в разделе Documentation Outputs и выберите PDF3D и нужный источник данных – определенный документ платы или [PCB Document], чтобы файл OutJob можно было повторно использовать в других проектах.

Добавление генератора выходных документов PDF3D в файле OutputJob.Добавление генератора выходных документов PDF3D в файле OutputJob.

Настройки формирования PDF 3D могут быть предварительно заданы путем выбора записи генератора выходных документов, щелчка ПКМ и выбора Configure из контекстного меню. Будет открыто диалоговое окно настроек Export 3D (как описано ранее).

При выполнении или ручном запуске OutputJob файл PDF 3D будет экспортирован в соответствии с разделом Output Containers файла OutJob, в настроенный сервер управляемых данных и путь или локальный/удаленный путь публикации, настроенный на странице Data Management - Publishing Destinations диалогового окна Preferences.

Формирование файла 3D PDF в заданный контейнер выходных документов PDF из настроенного файла OutJob.
Формирование файла 3D PDF в заданный контейнер выходных документов PDF из настроенного файла OutJob.

Обнаружили проблему в этом документе? Выделите область и нажмите Ctrl+Enter, чтобы оповестить нас.

Связаться с нами

Связаться с нашими Представительствами напрямую

We're sorry to hear the article wasn't helpful to you.
Could you take a moment to tell us why?
200 characters remaining
Вы сообщаете о проблеме, связанной со следующим выделенным текстом
и/или изображением в активном документе: