Altium NEXUS Documentation

Перестановка эквивалентных выводов, пар и секций

Последнее изменение: Pavel Demidov; 04.11.2020

Содержание

Полное содержание

В тесной интеграции с возможностями интерактивной трассировки и создания трассировки, выходящей за пределы корпусов BGA, в Altium NEXUS работает система перестановки эквивалентных выводов, дифференциальных пар и секций. Эта система предоставляет все преимущества традиционных возможностей перестановки эквивалентных выводов, но также использует преимущества глубокого понимания Altium NEXUS назначения цепей в проекте. При перестановке эквивалентных выводов Altium NEXUS анализирует цепь, назначенную выбранному выводу, и динамически переназначает цепь выводу и подключенным проводящим объектам.

Этот уровень функциональности означает, что перестановка доступна для частично растрассированных цепей и предварительно растрассированных цепей на множестве слоев для сложных устройств в корпусах BGA. Также благодаря информации о дифференциальных выводах-парах в ПЛИС доступна перестановка эквивалентных дифференциальных пар.

На уровне плат, эти система включает в себя эффективный модуль автоматической оптимизации, который использует эту информацию для переназначения цепей и упрощения трассировки. Например, система может выполнить обновление соединений множества устройств, для которых была создана трассировка за пределы корпуса на множестве слоев, на основе соответствующих слоев, где эта трассировка расположена, кратчайшей манхэттенской длины трассировки и минимального количества пересечений на каждом слое.

Возможность перестановки частично растрассированных цепей вместе с модулем автоматической оптимизации позволяет использовать иерархическую и итеративную стратегию трассировки: сначала создать трассировку за пределы посадочного места, затем трассировку к краю заданной области для соединения этих двух областей. Автоматическую перестановку можно запустить в любой момент для повторной оптимизации на основе обновленной информации из частично растрассированных цепей.

Существуют три категории перестановки:

  • Перестановка эквивалентных выводов
  • Перестановка эквивалентных дифференциальных пар
  • Перестановка эквивалентных секций

Настройка групп перестановок

Для каждой из категорий перестановки, группы перестановок (swap groups) определяют, что может и что не может быть переставлено в компоненте. В случае с эквивалентными выводами, перестановка доступна для выводов с одним значением группы выводов (pin group). Аналогичным образом, для перестановки эквивалентных пар и секций, значения групп пар (pair group) и групп секций (part group) определяют, какие дифференциальные пары и секции соответственно могут быть переставлены. Эти группы перестановок компонента настраиваются в диалоговом окне Configure Pin Swapping, показанном на изображении ниже. Открыть это диалоговое окно можно следующими способами:

  • В документе платы щелкните ПКМ по компоненту и выберите команду Component Actions » Configure Pin/Part Swapping.
  • В документе схемы щелкните ПКМ по компоненту и выберите команду Part Actions » Configure Pin Swapping.
  • Нажмите кнопку Configure Component в нижней части диалогового окна Configure Swapping Information In Components (Tools » Configure Pin Swapping).
  • Дважды щелкните ЛКМ по какому-либо компоненту в диалоговом окне Configure Swapping Information In Components.

Группы выводов

Вывод компонента доступен для перестановки с другим выводом этого же компонента, если он принадлежит той же группе выводов (т.е. если у них одинаковы значения pin group). Pin group – это атрибут каждого вывода в компоненте, и его значением может быть любая буквенно-цифровая строка. Группы выводов всего компонента могут быть заданы в диалоговом окне Configure Pin Swapping.

Схема с компонентом, состоящим из двух логических элементов ИЛИ-НЕ с пятью входами. Все входные выводы любой из секций логически эквивалентны, что представляет собой идеальную ситуацию для перестановки эквивалентных выводов.

Обратите внимание на схему на изображении выше, которая содержит два логических элемента ИЛИ-НЕ с пятью входами компонента SNJ54S260. Все цепи логического элемента ИЛИ-НЕ, от INA0 до INA4, могут быть переставлены друг с другом. Аналогичным образом, могут быть переставлены цепи от INB0 до INB4, однако цепь INAx не может быть переставлена с цепью INBx.

Ограничения перестановки для элемента ИЛИ-НЕ определяются в диалоговом окне Configure Pin Swapping. Если задать цепям INAx группу перестановок 1, а цепям INBx группу перестановок 2, то перестановка будет выполняться системой только таким образом, что это будет совместимо с логикой компонента. Если для вывода оставить значение группы выводов пустым, то это будет означать, что вывод не доступен для перестановки.

Группы секций и идентификаторы последовательности

Зачастую компоненты состоят из множества эквивалентных секций. Перестановка эквивалентных секций позволяет выполнить перестановку цепей таких эквивалентных секций. Еще раз обратите внимание на компонент, показанный на изображении выше. Оба элемента ИЛИ-НЕ работают одинаково, и цепи (INA0, INA1, INA2, INA3, INA4, OUTA) могут быть переставлены с цепями (INB0, INB1, INB2, INB3, INB4, OUTB).

Настройка перестановки эквивалентных секций компонента осуществляется с помощью групп секций (part group) и идентификаторов последовательности (sequence ID). Это текстовые атрибуты, доступные на вкладке Part Swapping диалогового окна Configure Pin Swapping, как показано ниже. Поскольку две секции могут быть переставлены друг с другом, их группам секций присвоено значение 1, как показано на изображении ниже.

Атрибут sequence ID определяет эквивалентность выводов в секциях, доступных для перестановки. Например, в элементах ИЛИ-НЕ важно, чтобы входные выводы не были переставлены с выходными при перестановке эквивалентных секций. На изображении ниже показано, что значения sequence ID заданы так, чтобы OUTA менялся с OUTB, INA0 менялся с INB0, INA1 менялся с INB1 и т.д.

Настройка групп перестановок эквивалентных секций в диалоговом окне Configure Pin Swapping для компонента с двумя логическими элементами ИЛИ-НЕ с пятью входами.

Обратите внимание, что перестановка эквивалентных секций доступна только для компонентов, созданных в виде секций, поскольку осуществляется перестановка всех цепей между двумя секциями.

Группы пар

Перестановка эквивалентных дифференциальных пар управляется значениями групп пар (pair group), заданными дифференциальным парам. Атрибут pair group доступен на вкладке Differential Pair Swapping диалогового окна Configure Pin Swapping. На вкладке Differential Pair Swapping доступны три режима, которые могут быть заданы с помощью выпадающего списка в левом нижнем углу диалогового окна.

  • Show Pairs From Directives (Отображать пары из директив) – для отображения в таблице дифференциальных пар система будет использовать директивы дифференциальных пар, размещенные в схеме.
  • Show Pairs From FPGA (Отображать пары из ПЛИС) – система будет использовать данные о дифференциальных парах, взятую из информации о ПЛИС. Обратите внимание, что этот режим доступен, если компонент является ПЛИС.
  • Show All Pins (Отображать все выводы) – система будет отображать все выводы компонентов.

Настройка групп перестановок эквивалентных пар в диалоговом окне Configure Pin Swapping.

Управление перестановкой в схеме

В редакторе плат перестановка эквивалентных выводов, пар и секций выполняется путем перестановки цепей контактных площадок компонентов и подключенных проводящих объектов. При передаче этих изменений в схему, существуют два способа обработки перестановки выводов: перестановка выводов в соответствующем символе или перестановка меток цепей на проводах, присоединенных к выводам. У каждого из этих способов есть свои преимущества и недостатки.

Перестановка эквивалентных выводов всегда работает в схеме, но это может означать, что экземпляр символа компонента больше не соответствует символу, заданному в библиотеке. В этом случае, символ не может быть обновлен из библиотеки, и это также означает, что прочие экземпляры этого компонента в проекте имеют другое расположение выводов. Таким образом, этот способ идеально подходит для простых компонентов, таких как резисторные матрицы.

Выполнение перестановки на схеме путем перестановки меток цепей возможно только в том случае, когда связность задана с помощью меток цепей и если между выводами не заданы проводные связи. Преимуществом этого подхода является то, что символ компонента не изменяется, и его можно будет обновить из библиотеки на более позднем этапе. Этот подход отлично подходит для сложных компонентов, таких как ПЛИС, где физическое перемещение двух выводов символа может привести к некорректному представлению входов/выходов символа.

Вы можете определить, как будут выполняться перестановки, выбрав Adding / Removing Net-Labels или Changing Schematic Pins в разделе Allow Pin Swapping Using these Methods диалогового окна Project Options - Options, как показано ниже.

Эти опции проекта управляют тем, как перестановка эквивалентных выводов будет выполняться на схеме.

Включение перестановки эквивалентных выводов, пар и секций на плате

Атрибуты групп перестановок, необходимые для перестановки эквивалентных выводов, пар и секций в компоненте, хранятся в компонентах на схеме. Тем не менее, эта информация используется именно в редакторе плат. У каждого компонента на плате есть опция, допускающая перестановку эквивалентных выводов.

Опции перестановок компонента на плате доступны в панели Properties, где отображены свойства компонента, когда он выделен в рабочей области. Эти опции находятся в разделе Swapping Options вкладки General.

В диалоговом окне Configure Swapping Information in Components приведен список всех компонентов, используемых в проекте (включая библиотеки SCHlib/PCBlib) с их текущими настройками перестановок. При открытии диалогового окна Configure Swapping Information in Components из редактора плат оно будет включать в себя дополнительный столбец под названием Enable in PCB для включения/отключения перестановок каждого компонента на плате. Чтобы открыть диалоговое окно Configure Swapping Information in Components, используйте команду Tools » Configure Pin Swapping.

Диалоговое окно Configure Swapping Information In Components.

Диалоговое окно Configure Swapping Information in Components включает в себя мощные возможности контекстного меню, что упрощает быстрое копирование настроек из одного компонента в другой и включение/отключение множества компонентов в один клик.

Дважды щелкните ЛКМ по компоненту в диалоговом окне Configure Swapping Information in Components, чтобы открыть диалоговое окно Configure Pin Swapping для этого компонента, где вы можете задать группы перестановок эквивалентных выводов, дифференциальных пар и секций.

Выполнение перестановки эквивалентных выводов, пар и секций

Интерактивная перестановка эквивалентных выводов, пар и секций

Интерактивная перестановка позволяет выполнять в редакторе плат перестановки выводов, дифференциальных пар и секций по одной. Команды интерактивной перестановки находятся в меню Tools » Pin/Part Swapping. После выбора команды из этого меню выводы, доступные для перестановки, будут подсвечены. Шаги, необходимые для выполнения перестановки, отображаются в строке состояния:

  1. Первый шаг – выберите один из подсвеченных выводов, который станет источником перестановки выводов. В случае перестановки пар или секций, будет переставлена соответственно дифференциальная пара или секция, к которой принадлежит вывод.
  2. Второй шаг – выберите целевой вывод для эквивалентной перестановки. Для перестановки эквивалентных пар или секций, этот вывод будет представлять дифференциальную пару или секцию.

Шаги по интерактивной перестановке секций компонента с двумя логическими элементами ИЛИ-НЕ с пятью входами показаны на двух изображениях ниже. Здесь есть две секции, которые могут быть переставлены, что означает, что можно выбрать любой из их пяти выводов, как показано на изображении выше. Выбранный вывод 8 соответствует секции U2B. Затем система подсветит выводы секции U2A, перестановку с которыми можно выполнить.

На изображении слева показан шаг 1 – выбор вывода для перестановки; доступные выводы подсвечиваются. На изображении справа показан шаг 2 – выбор целевого вывода.

Автоматическая оптимизация выводов/цепей

Модуль автоматической оптимизации выводов/цепей работает в два этапа. Выберите команду Tools » Pin/Part Swapping » Automatic Pin/Net Optimizer из меню редактора плат, чтобы выполнить автоматическую оптимизацию.

Сначала модуль автоматической оптимизации выводов/цепей запускает быструю однократную оптимизацию, которая пытается минимизировать количество пересечений и длину соединений, но может и увеличить их. После этого у вас будет запрошено, хотите ли вы запустить итеративную оптимизацию, которая проводит множество циклов для уменьшения количества пересечений и длины соединений.

Передача изменений обратно в схему

После настройки групп перестановок в диалоговом окне Configure Pin Swapping, изменения сразу же применяются к схемному компоненту, независимо от того, какой редактор был активен при запуске команды. Однако изменения проекта, которые являются результатом выполнения перестановки эквивалентных выводов, дифференциальных пар и секций в редакторе плат, необходимо передать обратно в схему с помощью стандартного процесса Design Update.

Отправка изменений из платы в схему

Перестановки выводов, пар и секций передаются в схему таким же образом, как и другие проектные изменения – с помощью команды Design » Update из главного меню. В зависимости от того, как заданы опции перестановок выводов в диалоговом окне Project Options - Options, перестановки будут выполнены следующим образом:

  • Изменение имен выводов – это изменение переместит выводы в символе. На самом деле, выводы не будут перемещены в символе, но будет видно, что два контакта переместились или поменялись местами.
  • Перемещение выводов к другим цепям – это изменение поменяет местами метки цепей на присоединенных проводах.
  • Изменение идентификатора секции – это изменит индекс секции при выполнении перестановки эквивалентных секций.

На изображении слева показана перестановка эквивалентных выводов, выполненная на схеме путем перестановки выводов. На изображении справа показана перестановка эквивалентных выводов, выполненная перемещением меток цепей.

Если на схеме не отображается результат перестановки эквивалентных выводов или секций, нажмите клавишу End, чтобы обновить вид.

Использование преимуществ новой системы перестановки эквивалентных выводов/секций для проектов ПЛИС

Помимо очевидных преимуществ, предлагаемых перестановкой эквивалентных выводов, пар и секций, возможность перестановки частично растрассированных подцепей обеспечивает новое измерение перестановки, которая идеально подходит для работы с большими ПЛИС. Динамическое переназначение цепей позволяет применять итеративный процесс проектирования с постепенными улучшениями в назначениях выводов/цепей.

Начальное назначение входов/выходов

На этом этапе, выводы ПЛИС и других устройств имеют назначение цепей, наиболее простое для уровня схемы. Обычно это означает простое добавление меток цепей для выводов ПЛИС в числовом порядке шин. Для этого идеально подходит возможность Smart Paste (Умная вставка) редактора схем.

Начальная оптимизация соединений

Проект может быть передан в редактор плат, где будет большое количество пересечений соединений из-за назначения цепей на схеме случайным образом. Запустите команду Automatic Net/Pin Optimizer для быстрого уменьшения большого числа пересечений. На этом этапе результат не должен быть идеальным, поскольку это используется в основном для того, чтобы упростить визуальное управление соединениями на уровне платы.

Трассировка за пределы посадочного места

Теперь может быть выполнено создание фэнаутов и трассировка за пределы посадочного места для больших устройств на плате (щелкните ПКМ по компоненту для выборочного создания фэнаутов/трассировки за пределы посадочного места). Это может ухудшить ранее оптимизированные назначения цепей, но на данном этапе это не существенно.

Оптимизация трассировки за пределы посадочного места

Снова запустите автоматическую оптимизацию. На этот раз, она будет использовать преимущества предварительно растрассированных частей фэнаутов/трассировки за пределы посадочного места.

Трассировка вручную

Теперь вы можете рассматривать концы трассировки за пределы посадочного места в качестве "целей" дальнейшей трассировки. Игнорируйте текущие линии подключения, поскольку вы можете трассировать от других концов цепей в направлении ближайшей входной/выходной трассы за пределы посадочного места (в пространственном отношении и по слоям) на плате, а не в направлении трассы, принадлежащей той же цепи. Соединения не будут совпадать. Вместо этого вы получите ряд малых зазоров между трассировкой из входных/выходных выводов ПЛИС и трассировкой из других компонентов на плате. На изображении ниже слева показан простой пример этого.

Финальная оптимизация

Запустите автоматическую оптимизацию снова, чтобы растрассированные подцепи были назначены ближайшим входным/выходным выводам ПЛИС. Получится набор очень коротких соединений, которые нужно завершить. Модуль автоматической оптимизации использует специальные алгоритмы для получения хороших результатов. Теперь эти соединения можно растрассировать в интерактивном или автоматическом режиме.

Перестановка эквивалентных выводов вручную

Используйте инструменты интерактивной переставноки, чтобы выполнить перестановку определенных выводов, если необходимо.

Передача изменений обратно на схему

Когда вы готовы передать эти назначения цепей выводам обратно на схему, рекомендуется отключить изменения выводов схемных символов, поскольку ПЛИС зачастую представлены многосекционными компонентами, где каждый банк выводов является отдельной секцией на схеме. Перемещение выводов из одной секции в другую приведет к тому, что эти символы станут логически некорректными, поскольку символ банка будет включать в себя выводы, которые не принадлежат этому банку. В этом случае, правильным подходом будет выполнение перестановки выводов путем изменения меток цепей.

Повторяйте столько, сколько необходимо

Этот процесс можно повторить столько раз, сколько необходимо, и на любом этапе процесса проектирования.

Обнаружили проблему в этом документе? Выделите область и нажмите Ctrl+Enter, чтобы оповестить нас.

Связаться с нами

Связаться с нашими Представительствами напрямую

We're sorry to hear the article wasn't helpful to you.
Could you take a moment to tell us why?
Вы сообщаете о проблеме, связанной со следующим выделенным текстом
и/или изображением в активном документе:
Бесплатная пробная версия Altium Designer
Бесплатная пробная версия Altium Designer
Давайте приступим. Для начала, Вы или Ваше предприятие уже используете Altium Designer?

Если Вы хотите поговорить с представителем, пожалуйста, свяжитесь с местным офисом Altium.
Copyright © 2019 Altium Limited

В таком случае, для чего Вам необходима пробная лицензия?

Если Вы хотите поговорить с представителем, пожалуйста, свяжитесь с местным офисом Altium.
Copyright © 2019 Altium Limited

Вам для этого не нужна пробная лицензия.

Нажмите кнопку ниже, чтобы загрузить установщик самой новой версии Altium Designer

Загрузить установщик Altium Designer

Если Вы хотите поговорить с представителем, пожалуйста, свяжитесь с местным офисом Altium.
Copyright © 2019 Altium Limited

Пожалуйста, заполните форму ниже, чтобы получить ценовое предложение.

Нажимая [Получить бесплатнную пробную версию], Вы соглашаетесь с нашей Политикой конфиденциальности. Вам могут приходить сообщения от компании Altium, и Вы можете изменить настройки уведомлений в любой момент.

Если Ваша подписка Altium активна, у Вас нет необходимости в пробной лицензии.

Если у Вас нет активной подписки Altium, пожалуйста, заполните форму ниже, чтобы получить пробную версию.

Нажимая [Получить бесплатнную пробную версию], Вы соглашаетесь с нашей Политикой конфиденциальности. Вам могут приходить сообщения от компании Altium, и Вы можете изменить настройки уведомлений в любой момент.

Для чего Вы хотите попробовать Altium Designer?

Если Вы хотите поговорить с представителем, пожалуйста, свяжитесь с местным офисом Altium.
Copyright © 2019 Altium Limited

Вы нашли нужное место! Пожалуйста, заполните форму ниже, чтобы начать использование пробной версии.

Нажимая [Получить бесплатнную пробную версию], Вы соглашаетесь с нашей Политикой конфиденциальности. Вам могут приходить сообщения от компании Altium, и Вы можете изменить настройки уведомлений в любой момент.

Great News!

Valid students can get their very own 6-month Altium Designer Student License for FREE! Just fill out the form below to request your Student License today.

Нажимая [Получить бесплатнную пробную версию], Вы соглашаетесь с нашей Политикой конфиденциальности. Вам могут приходить сообщения от компании Altium, и Вы можете изменить настройки уведомлений в любой момент.

Вы можете загрузить бесплатную лицензию средства просмотра Altium Designer Viewer сроком действия 6 месяцев.

Пожалуйста, заполните форму ниже, чтобы запросить эту лицензию.

Нажимая [Получить бесплатнную пробную версию], Вы соглашаетесь с нашей Политикой конфиденциальности. Вам могут приходить сообщения от компании Altium, и Вы можете изменить настройки уведомлений в любой момент.

Замечательно! Создавать новое - отличное занятие. У нас есть превосходная программа для Вас.

Upverter - бесплатная платформа, разработанная специально для любителей проектирования.

Нажмите здесь, чтобы попробовать!

Если Вы хотите поговорить с представителем, пожалуйста, свяжитесь с местным офисом Altium.
Copyright © 2019 Altium Limited

Вы можете загрузить бесплатную лицензию средства просмотра Altium Designer Viewer сроком действия 6 месяцев.

Пожалуйста, заполните форму ниже, чтобы запросить эту лицензию.

Нажимая [Получить бесплатнную пробную версию], Вы соглашаетесь с нашей Политикой конфиденциальности. Вам могут приходить сообщения от компании Altium, и Вы можете изменить настройки уведомлений в любой момент.