Altium NEXUS Documentation

Подготовка множества выходных документов с помощью OutputJob

Последнее изменение: Pavel Demidov; 01.03.2021

Для конструкции платы могут быть сформированы различные выходные документы, у каждого из которых есть собственные настройки. Управлять настройками разнообразных выходных документов лучше с помощью файла Output Job, или сокращенно OutJob.

Файл OutJob – это предварительно настроенный набор выходных документов. Каждый выходной документ имеет собственные настройки и выходной формат, например, вывод в файл или на принтер. Файлы OutJob очень гибки, поскольку они могут включать в себя любое необходимое количество выходных документов, и любое необходимое количество файлов OutJob может быть добавлено в проект. Наилучшим подходом является использование отдельных файлов OutJob для настройки всех выходных документов определенного типа, которые необходимо сформировать из проекта. Например, все выходные документы, необходимые для изготовления печатной платы, задаются в одном файле OutJob, все выходные документы, необходимые для сборки печатного узла, задаются в другом файле OutJob, и т.д.

Файлы OutJob также могут включать в себя валидационные проверки, такие как отчеты ERC и DRC. Эти отчеты полезны для финальной валидации проекта перед формированием выходных документов, и они могут содержать отметку, что проект готов к выпуску.

Файлы OutJob портируемы по своей природе, и их можно использовать в различных проектах путем копирования файла из одного проекта в другой и настройки источника данных необходимым образом.

Для Altium NEXUS существует обширная онлайн-документация. Когда курсор находится над командой меню, диалоговым окном, панелью или объектом, нажмите F1, чтобы открыть соответствующую страницу документации.

Добавление и определение файла Outjob

Управление файлами OutJob осуществляется в редакторе OutputJob. Чтобы создать новый файл Output Job:

  • Используйте команду File » New » Output Job File главного меню.
  • Щелкните ПКМ по названию проекта в панели Projects и выберите команду Add New to Project » Output Job File из появившегося меню.

Файлы Output Job, добавленные в проект, отображаются в панели Projects, в подпапке Settings\Output Job Files. Три этапа настройки файла OutJob:


Составные элементы файла OutJob, определение и настройка которых осуществляется в редакторе OuputJob Editor.

  1. Добавление и настройка необходимых выходных документов – выходные документы разбиты на функциональные категории, такие как выходные документы для изготовления печатной платы, выходные документы для изготовления печатного узла, отчеты. Строго говоря, выходные документы формируются при запуске соответствующего генератора выходных документов Output Generator, настроенного нужным образом и использующего указанный документ проекта (или сам проект) в качестве источника данных.
  2. Добавление и настройка нужных форматов выходных документов – для формирования выходного документа необходимо его сопоставление нужному (и подходящему) формату, т.е. одному из поддерживаемых контейнеров выходных документов (Output Containers – PDF, структура папок, видео) или твердой копии (Hard Copy – вывод на печать). Одному контейнеру или твердой копии может быть сопоставлено множество выходных документов, и пользователь управляет тем, где и как выходные документы будут сформированы (т.е. определяет настройки, относящиеся к контейнеру/твердой копии).
  3. Определение выбора варианта – Altium NEXUS позволяет формировать выходные документы проекта платы для базового проекта или определенного варианта этого проекта, указанного пользователем. Вы можете выбрать вариант для каждого подходящего выходного документа или применить единый вариант ко всем подходящим выходным документам в файле.

Добавление выходных документов в файл OutJob

Чтобы добавить новый выходной документ нужного типа, щелкните ЛКМ по соответствующего тексту Add New [type] Output внизу категории и выберите нужный тип выходных документов из открывшегося меню. Либо выберите соответствующую команду из главного меню Edit.

   
Для добавления нужного выходного документа выберите подходящий источник данных.

Типы выходных документов, для которых доступен соответствующий источник данных, будут приведены в списке как доступные, в то время как прочие типы выходных документов будут недоступны (отображаться серым цветом).

Из второго меню вы можете выбрать источник данных, т.е. исходный документ(ы), который будет использоваться при формировании выходного документа. Для каждого выходного документа доступны только подходящие источники данных, что позволяет минимизировать ошибки.

Источник данных зависит от определенного выходного документа. Выходные документы, относящиеся к платам, такие как распечатки платы, файлы Gerber и отчеты о контрольных точках, будут использовать документ платы в качестве источника данных. Источником данных для состава изделия может быть отдельный исходный документ схемы, документ платы или все исходные документы схем. Последний вариант представлен строкой [Project].

Источник данных можно изменить в любой момент после добавления выходного документа. Щелкните ЛКМ по текущему источнику данных, и появится стрелка выпадающего списка, из которого можно выбрать другой источник.

Для определенных выходных документов доступен источник данных [Project Physical Documents]. Используйте эту опцию, если физический проект (проект, который будет реализован на плате) должен быть аннотирован отличным от логического проекта (исходных схем) образом. Это необходимо, если проект включает в себя листы устройств или если он использует многоканальность и необходима простая, плоская схема аннотирования.

Термин "физические документы проекта" относится к физическому, или скомпилированному представлению схем. В редакторе схем, ему соответствуют скомпилированные документы, которые отображаются после компиляции документа/проекта.
При настройке источника данных для выходных распечаток схем, опция All SCH Documents относится к распечатке набора всех логических схем в проекте (нескомпилированному представлению "Editor" каждой схемы). Чтобы распечатать набор всех физических схем проекта (скомпилированные представления схем), задайте в качестве источника данных [Project Physical Documents].

Настройка выходных документов

В зависимости от определенного типа выходного документа, могут быть доступны опции для настройки соответствующего генератора выходных документов, что предоставляет больше возможностей для настройки выходного документа. Когда опции доступны, их можно вызвать одним из следующих способов:

  • Дважды щелкните ЛКМ по строке нужного выходного документа.
  • Щелкните ПКМ по нужному выходному документу и выберите Configure из контекстного меню.
  • Выделите нужный выходной документ и используйте сочетание клавиш Alt+Enter.
  • Выделите нужный выходной документ и выберите команду Edit » Configure.

Если выделено множество выходных документов, будет открыто диалоговое окно настройки последнего выделенного выходного документа (который находится в фокусе).


Для различных генераторов выходных документов доступны собственные диалоговые окна для точной настройки того, что будет сформировано.

Для выходных документов, которые могут использоваться для формирования твердой копии (т.е. отправки на печатающее устройство), можно также открыть диалоговое окно для определения свойств страницы. Щелкните ПКМ по выходному документу и выберите Page Setup из контекстного меню либо выберите выходной документ и используйте команду File » Page Setup.

Выходные документы экспорта в файле OutJob

При настройке выходных документов экспорта в области Outputs вы также можете указать нужный тип экспорта прямо в области Outputs. Щелкните ПКМ по строке [Add New Export Output] в области Export Outputs, чтобы открыть меню доступных опций. После выбора нового типа экспорта щелкните ЛКМ по доступному варианту выбора (например, [PCB Document], [Project] и т.д.) из открывшегося меню. Настройте выходной документ, щелкнув ПКМ по новому экспорту и выбрав Configure – будет открыто диалоговое окно Export, связанное с этим типом экспорта.

Определение формата выходного документа

Добавление и настройка выходных документов в файл OutJob определяет, что и как будет сформировано. Также необходимо определение того, где будет записан выходной документ, т.е. в каком формате он будет сформирован. В зависимости от типа формируемых выходных документов, этим можно управлять с помощью контейнеров (Output Containers) и твердых копий (Hard Copy).

Контейнеры выходных документов

Выходные документы могут быть записаны (где это применимо) в контейнеры трех типов: PDF, выходные файлы определенного формата (например, Gerber) и видео.

Новый файл OutJob по умолчанию включает в себя по одному контейнеру каждого из этих типов, которые названы PDF, Folder Structure и Video. С помощью строки [Add New Output Container] может быть добавлено любое количество дополнительных контейнеров, и им можно задать подходящие имена для более простой идентификации.


Контейнеры "получают" выходные документы.

Для получения более подробной информации по настройкам контейнеров выходных документов перейдите на страницы диалоговых окон PDF Settings, Folder Structure Settings и Video Settings.

Настройка контейнера

Щелкните ЛКМ по контейнеру, чтобы вызвать дополнительные элементы управления, в том числе для настройки контейнера. После щелчка ЛКМ по нужному контейнеру щелкните ЛКМ по ссылке Change, чтобы открыть диалоговое окно Settings, соответствующее контейнеру этого типа.

Открыть диалоговое окно Settings также можно дважды щелкнув ЛКМ по контейнеру либо выделив его, щелкнув ПКМ и выбрав команду Properties.

Диалоговое окно Settings будет изначально открыто в режиме Basic для настройки выходного расположения, т.е. где будет создан контейнер.


Откройте диалоговое окно Settings контейнера, чтобы настроить его нужным образом. Используйте диалоговое окно в режиме Basic для определения выходного расположения контейнера.

Для доступа к другим, расширенным настройкам, относящимся к формированию выходных документов в контейнер, нажмите кнопку Advanced в нижней части диалогового окна.


Дополнительные опции доступны в диалоговом окне в режиме Advanced.

Расположение выходных документов

Расположение выходных документов, т.е. где будет создан контейнер, определяется в области Output Management диалогового окна настроек контейнера. Расположение включает в себя несколько разделов, каждое из которых определяется с помощью соответствующего выпадающего списка.

  • Базовый путь – этот этап определяет "корневой" путь контейнера выходных документов.


    Опции для определения базового пути расположения выходных документов.

    По умолчанию задано [Release Managed], что означает, что базовый путь будет автоматически управляться процессом выпуска платы, который осуществляется с помощью средства Project Releaser.

    Локальный выходной путь может быть определен путем выбора [Manually Managed] и указания соответствующего пути (который можно задать относительно проекта).

  • Папка типа контейнера – этот раздел используется для определения подпапки на основе типа формируемого контейнера. Использовать эту дополнительную вложенную папку не обязательно. Если она используется, ее название может быть задано системой (с использованием имени или типа контейнера) либо вы можете задать ей нужное пользовательское имя.


    Опции для определения подпапки контейнера в расположении выходных документов.

  • Папка выходных документов / Имя файла выходных документов – функция этого раздела зависит от типа выходного контейнера, для которого определяется расположение выходных документов. Для контейнера типа PDF или Video в этом разделе требуется указать нужное имя файла. По умолчанию множество выходных документов, формируемых в контейнер, будут объединены в один файл, но при необходимости вы можете сформировать отдельный файл для каждого выходного документа.

    При формировании отдельного файла для каждого выходного документа станет доступна дополнительная опция для размещения каждого файла в отдельную подпапку. Если эта опция включена, имена этих папок могут быть заданы автоматически исходя из имени или типа выходного документа либо им можно задать определенный пользовательский префикс.


    Опции для определения имени файла и подпапки.

    Для контейнера типа Folder Structure этот раздел используется для определения папки каждого типа формируемого выходного документа. Опять же, имя папки может быть задано автоматически исходя из имени или типа выходного файла, либо ей можно задать определенный пользовательский префикс. При внесении изменения в любой из разделов расположения выходных документов, окно предварительного просмотра диалогового окна будет автоматически обновлено, что позволит быстро определить нужную структуру папки выходных документов. Для каждого заданного контейнера, эти пути, как серверные (управляемые выпуском), так и локальные (управляемые вручную), отображаются в главной области контейнера в файле OutJob.

Твердая копия – задания на печать

Определенные выходные документы, такие как распечатка схемы, сборочный чертеж и состав изделия, также могут быть отправлены непосредственно на печатающее устройство в качестве твердой копии. Для управления тем, как будет обрабатываться твердая копия, осуществляется добавление и настройка задания на печать (Print Job).

Новый файл OutJob по умолчанию включает в себя одно задание на печать под названием Print Job, и в качестве целевого принтера для него будет задан тот, который является принтером по умолчанию для компьютера, где запущен Altium NEXUS. С помощью строки [Add New Print Job] может быть добавлено любое количество дополнительных заданий на печать, и им можно задать подходящие имена для более простой идентификации (например, имя печатающего устройства, с которым связано задание).


Задания на печать обрабатывают твердые копии выходных документов.

Настройка задания на печать

Щелкните ЛКМ по заданию на печать, чтобы вызвать дополнительные элементы управления, в том числе для настройки задания на печать. Для этого щелкните ЛКМ по ссылке Change, чтобы открыть диалоговое окно Printer Configuration, связанное с определенным заданием. Диалоговое окно Printer Configuration также можно открыть, дважды щелкнув ЛКМ по заданию на печать либо выделив его, щелкнув ПКМ и выбрав команду Properties.


Откройте диалоговое окно Printer Configuration, чтобы настроить задание на печать нужным образом.

В диалоговом окне Printer Configuration нажмите кнопку Properties, чтобы открыть стандартное диалоговое окно Properties для целевого принтера. В этом диалоговом окне задайте источник бумаги и разметку и откройте расширенные настройки свойств принтера.

Определение связи выходных документов с выходными контейнерами и заданиями на печать

Когда в файле OutJob добавлены и настроены выходные документы и определены необходимые контейнеры выходных документов и задания на печать, их необходимо сопоставить между собой, т.е. определить, какие выходные документы будут сформированы с помощью каких контейнеров и/или заданий на печать.

У каждого выходного документа есть поле Enabled. Это поле управляет тем, будет ли определенный выходной документ включен (опция включена) или нет (опция отключена) для выбранного выходного контейнера или задания на печать.

Поле Enabled доступно только в том случае, если поддерживается формирование выходного документа выбранным контейнером или его печать выбранным печатающим устройством.

После включения этой опции будет отображена зеленая линия, соединяющая выходной документ с выделенным контейнером/заданием на печать. Один и тот же выходной документ может быть включен в различные контейнеры или задания на печать – например, состав изделия может быть сформирован и выведен как отдельный файл PDF или отправлен на принтер для получения твердой копии.


Выберите контейнер или задание на печать, затем включите выходные документы, которые должны быть сформированы с помощью этого контейнера или задания на печать.

На изображении выше показаны три выходных документа, которые включены для формирования с помощью контейнера с именем PDF. Обратите внимание, что у отчета о контрольных точках, файлов Pick and Place и Gerber поле Enabled недоступно, поскольку выходные документы этих типов не могут быть записаны в файл PDF.

По мере включения выходных документов они последовательно нумеруются. Этот порядок используется для определения последовательности, в которой выходные документы будут формироваться. При создании единого файла PDF для множества различных выходных документов этот порядок определит последовательность содержимого этих выходных документов в файле PDF.

При удалении выходного документа из контейнера или задания на печать порядок чисел обновляется соответствующим образом. Чтобы изменить порядок включенных выходных документов, щелкните ЛКМ по числу в поле Enabled выходного документа и используйте доступные элементы управления для изменения этого числа или повторно включите выходные документы в нужном порядке.

Выбор варианта

В зависимости от требований к изделию, может потребоваться производство различных схожих между собой печатных плат, которые немного отличаются от базовой конструкции. Например, стандартная и расширенная версии коммерческого электронного изделия могут отличаться по предлагаемым функциональным возможностям, где стандартная версия включает в себя некоторые из компонентов, используемые в расширенной версии.

На уровне проекта, Altium NEXUS позволяет определить один или множество вариантов проекта платы с помощью вариантов (Variants). Вариант – это альтернативно собранная "версия" изначального проекта.

Как правило, варианты влияют на выходные документы для изготовления печатного узла (сборки), и они определяют только исполнения печатного узла (т.е. какие компоненты будут смонтированы, а какие нет). Однако Altium NEXUS также позволяет, чтобы варианты управляли определенными выходными документами для изготовления печатной платы, что допускает вариации комментария компонента и применение этого изменения в выходных документах, таких как файлы Gerber и ODB++, составные чертежи для сверловки и распечатки шаблонов.

Хотя варианты могут управлять выходными документами для изготовления печатной платы, они изменяют только выходные документы в зависимости от вариаций на уровне компонента – в этом случае, параметра Comment компонента. Никакие другие аспекты изготавливаемой платы (физические свойства печатной платы), такие как трассировка, расположение компонентов или стек слоев, не могут быть изменены.

В файле OutJob у вас есть возможность управлять тем, как будут формироваться выходные документы – для базового проекта или для указанного варианта этого проекта.

Если выходные документы формируются для определенного варианта, то этот вариант должен быть указан в рамках настройки файла OutJob. Выберите вариант для каждого выходного документа, где это применимо, либо укажите один вариант для применения ко всем допустимым выходным документам в файле. Эта "область действия варианта" определяется с помощью опций Variant Choice в верхней части файла Output Job.


Опции Variant Choice определяют уровень использования вариантов для настроенных выходных документов в файле Output Job.

  • Choose a single variant for the whole outputjob file – когда включена эта опция, выберите один вариант, который будет управлять всеми допустимыми выходными файлами в файле Output Job. Укажите вариант в выпадающем списке справа. В выпадающем списке приведены все варианты, определенные для активного проекта, а также запись [No Variations].
  • Choose a different variant for each output – когда включена эта опция, в область Outputs файла OutJob будет добавлен столбец Variant. Используйте это поле, чтобы указать вариант, который следует использовать для каждого отдельного выходного документа. Опять же, в выпадающем списке приведены все варианты, определенные для активного проекта, а также запись [No Variations]. С помощью этой настройки возможно назначение различных вариантов для различных выходных документов.

Для формирования выходных документов с использованием базового проекта используйте строку [No Variations].

При определении использования вариантов для отдельных выходных документов, если выбранный вариант не допускает вариации выходных документов для изготовления печатной платы и этот вариант указан для использования в выходном документе для изготовления печатной платы, название варианта в файле OutJob будет подсвечено красным, и эта ситуация будет обозначена во всплывающей подсказке. Формирование выходного документа с использованием выбранного варианта будет осуществлено как при выбранной настройке [No Variations]. Иными словами, в качестве источника выходного документа будет использоваться базовый проект.

Формирование выходных данных

Выходные документы, настроенные в файле OutJob, могут быть сформированы следующим образом:

  • Непосредственно из файла OutJob.
  • Из средства Project Releaser.

Из контейнеров выходных документов

При выделении контейнера выходных документов станет доступен элемент управления Generate content, если этому контейнеру назначен хотя бы один выходной документ.


Формирование данных выделенного контейнера выходных документов.

Щелкните ЛКМ по этому элементу управления, чтобы сформировать выходные документы, включенные в этот контейнер, в указанной последовательности. Либо используйте один из следующих методов формирования выходных данных, когда контейнер выделен:

  • Нажмите клавишу F9.
  • Щелкните ПКМ и выберите команду Generate из контекстного меню (команду Run для контейнера типа Folder Structure).
  • Используйте команду Tools » Generate (для контейнера типа PDF или Video) или Tools » Run (для контейнера типа Folder Structure).

Прогресс можно увидеть в строке состояния. Сформированный выходной документ будет открыт, если в расширенных настройках контейнера была включена соответствующая опция.

Нет процесса пакетного формирования множества контейнеров. Будут сформированы только выходные документы, назначенные выделенному в данный момент контейнеру. Чтобы сформировать все выходные документы, выделите и сформируйте выходные данные для каждого заданного контейнера по отдельности.

При формировании выходных документов Gerber, ODB++, NC Drill или IPC-356-D в контейнер типа Folder Structure они могут быть автоматически импортированы в новый документ редактора CAM (*.cam). Соответствующая опция находится в диалоговом окне Files Settings контейнера.

Публикация сформированных данных

Второй элемент управления – Generate and publish – позволяет вам сформировать выходные документы, назначенные выбранному контейнеру, и опубликовать их в определенное расположение для публикации (Publishing Destination).

Расположение для публикации предоставляет возможность опубликовать данные в хранилище, такое как Box.net, Amazon S3, FTP-сервер или общая папка в сети. С точки зрения распределения данных и совместной работы, это предоставляет преимущества в современном мире, где все те, кто участвуют в создании продукта – проектировщики, производители и т.д. – зачастую находятся в разных местах земного шара. У всех есть общий (и контролируемый) доступ к данным для их просмотра, обсуждения и использования.

Для публикации щелкните ЛКМ по команде и выберите одно из заданных расположений из появившегося меню. Выходные документы будут сначала сформированы по локальному пути, затем они будут опубликованы. В рамках процесса публикации будет запрошена папка (в целевом расположении для публикации), в которую будут сохранены выходные документы. Перейдите к существующей папке, укажите новую папку или примите папку по умолчанию, которой будет задано имя исходя из типа данных для контейнера и даты и времени (например, PDFs - 10-24-2011 11-32-33 AM).

Используйте команду Manage Publishing из меню, чтобы открыть страницу Data Management – Publishing Destinations диалогового окна Preferences. Здесь можно определить новые расположения или изменить подключения к существующим расположениям.


Расположения для публикации определяются в настройках управления данными.

Для опубликованных данных, сформированных из проекта платы, сервер поддерживает возможность публикации этих выпущенных документов, т.е. выходных данных, сформированных из файлов Output Job, которые назначены конфигурации выпущенного проекта для любой ревизии объекта, в определенное расположение для публикации.

Публикация данных непосредственно из файла OutJob размещает копию сформированных файлов в указанную подпапку целевого расположения. Для обеспечения высокой степени целостности данных и возможности их отслеживания сформированные данные следует опубликовать после выпуска в ревизию целевого объекта на сервере. Эти выходные данные помечаются (в имени файла) объектом и ревизией, что позволяет всем участникам процесса быстро понять, какой выходной объект связан с какой ревизией объекта, который должен быть создан (печатная плата или печатный узел).

Из заданий на распечатку

При выборе задания на распечатку будет предоставлен доступ к элементам управления предварительным просмотром и печатью. Эти элементы управления будут доступны, если заданию назначен хотя бы один выходной документ.


Элементы управления предварительным просмотром и печатью выбранного задания на печать.

Предварительный просмотр печати

Нажмите Preview, чтобы загрузить выходные документы, назначенные заданию на печать, в предварительный просмотр печати. Либо, когда задание на печать выбрано, используйте один из следующих способов для вызова предварительного просмотра:

  • Щелкните ПКМ и выберите Print Preview из контекстного меню.
  • Используйте команду Tools » Print Preview.
  • Нажмите кнопку Preview в диалоговом окне Page Setup (File » Page Setup) для выбранного выходного документа (который находится в фокусе). Обратите внимание, что при этом будут загружены страницы только выбранного выходного документа, а не все страницы всех выходных документов, назначенного заданию на печать.

Исходные документы будут загружены в заданной последовательности и в соответствии с опциями, заданными в связанном диалоговом окне Page Setup.

В нижней части предварительного просмотра отчета и в контекстном меню доступны элементы управления для управления видом, вызова диалоговых окон настройки принтера, копирования страницы в Буфер обмена Windows и экспорта активной страницы как метафайла Windows.

Печать

Нажмите Print, чтобы отправить выходные документы непосредственно на указанное печатающее устройство. Либо используйте один из следующих способов для печать назначенных выходных документов:

  • Нажмите клавишу F9.
  • Щелкните ПКМ и выберите команду Print из контекстного меню.
  • Используйте команду Tools » Print.
  • Нажмите кнопку Print в диалоговом окне Page Setup выбранного выходного документа (который находится в фокусе). Обратите внимание, что при этом будут распечатаны только страницы этого определенного выходного документа, а не все страницы всех выходных документов, назначенных заданию на печать.
  • Нажмите кнопку Print в диалоговом окне Print Preview.

Элемент управления Print и первые три способа, перечисленные выше, обеспечивают прямую печать. Последние два способа обеспечивают печать через диалоговое окно Printer Configuration.

Нет процесса пакетной печати множества заданий на печать. Будут распечатаны только выходные документы (либо открыт предварительный просмотр для документов), назначенные выделенному в данный момент задания на печать. Чтобы распечатать все выходные документы, выделите и распечатайте выходные данные для каждого задания на печать по отдельности.

Из средства Project Releaser

Выходные данные, определенные в одном или множестве файлов Output Job, которые назначены конфигурации проекта платы, формируются при выпуске этой конфигурации. Формирование выходных документов происходит в рамках процесса выпуска, и выпущенные данные сохраняются в новую запланированную ревизию целевого объекта на сервере. Для этого используется интерфейс средства Project Releaser.

Средство Project Releaser можно вызвать следующими способами:

  • Выберите команду Project » Project Releaser главного меню, когда какой-либо документ нужного проекта открыт в качестве активного документа.
  • Щелкните ПКМ по строке нужного проекта в панели Projects и выберите команду Project Releaser из контекстного меню.

Если перед запуском средства Project Releaser выходные документы не были определены, это можно сделать в рамках процесса выпуска.

Для объектов данных для изготовления печатной платы и данных для изготовления печатного узла, которые должны быть включены в выпуск, необходимо, чтобы им был назначен по крайней мере один файл OutputJob. Если имена файлов Output Job начинаются с подстрок 'fab' и 'ass', эти файлы будут автоматически назначены соответствующим разделам при первом открытии представления Release. В противном случае, необходимо назначить нужные файлы OutJob вручную.


Пример списка выходных документов, которые будут сформированы для выбранной конфигурации.

В Project Releaser нажмите кнопку Options (в нижнем левом углу), чтобы открыть диалоговое окно Project Release Options. Это диалоговое окно используется для назначения нужных файлов OutJob и определения того, какие имена получат целевые объекты данных на сервере (ревизии которых получат сформированные данные) при выпуске проекта. Вкладка Release Options включает в себя несколько опций в разделе Output Jobs для включения нужных выходных данных.

Вкладка Release Options диалогового окна Project Release Options.

Если в проекте в данный момент нет файла(-ов) Output Job, средство Project Releaser обнаружит это и будет запрошено добавить файлы по умолчанию. Если вы согласитесь, будут созданы следующие файлы:

  • Fabrication.OutJob, в котором определены следующие выходные документы:
    • Documentation Outputs: распечатки платы
    • Fabrication Outputs: Gerber, NC Drill и IPC-2581
    • Validation Outputs: проверка правил проектирования, отчет о сравнении посадочных мест
    • Export Outputs: сохранить/экспортировать плату (в формат ASCII)
  • Assembly.OutJob, в котором определены следующие выходные документы:
    • Documentation Outputs: 3D-распечатка платы, распечатки схем, составной чертеж
    • Assembly Outputs: отчет Pick and Place, сборочные чертежи, отчет о контрольных точках
    • Report Outputs: состав изделия, перекрестные ссылки на компоненты, документы GOST BOM

      Формирование выходных документов GOST BOM доступно, если установлено расширение GOST 2.701-2008/2.106-1996. Чтобы установить расширение, перейдите на вкладку Purchased страницы Extensions & Updates. Найдите иконку расширения GOST, которая показана ниже.

      Наведите курсор мыши на иконку, затем нажмите кнопку загрузки, чтобы установить расширение. Будет запрошено перезапустить Altium NEXUS, чтобы завершить установку. Если необходимо, расширение GOST 2.701-2008/2.106-1996 можно удалить. Для этого перейдите на вкладку Installed страницы Extensions & Updates и найдите иконку GOST 2.701-2008/2.106-1996, затем наведите курсор мыши на иконку и нажмите для удаления.

      Чтобы узнать больше о расширении GOST 2.701-2008/2.106-1996, откройте Руководство пользователя по расширению GOST 2.701-2008/2.106-1996

  • Export Outputs: экспорт в STEP

    Если в проекте есть хотя бы один файл OutJob, автоматическое создание этих файлов не будет предложено.

Для получения более подробной информации о процессе выпуска перейдите на страницу Работа со средством Project Releaser.

Обнаружили проблему в этом документе? Выделите область и нажмите Ctrl+Enter, чтобы оповестить нас.

Связаться с нами

Связаться с нашими Представительствами напрямую

We're sorry to hear the article wasn't helpful to you.
Could you take a moment to tell us why?
Вы сообщаете о проблеме, связанной со следующим выделенным текстом
и/или изображением в активном документе:
Бесплатная пробная версия Altium Designer
Бесплатная пробная версия Altium Designer
Давайте приступим. Для начала, Вы или Ваше предприятие уже используете Altium Designer?

Если Вы хотите поговорить с представителем, пожалуйста, свяжитесь с местным офисом Altium.
Copyright © 2019 Altium Limited

В таком случае, для чего Вам необходима пробная лицензия?

Если Вы хотите поговорить с представителем, пожалуйста, свяжитесь с местным офисом Altium.
Copyright © 2019 Altium Limited

Вам для этого не нужна пробная лицензия.

Нажмите кнопку ниже, чтобы загрузить установщик самой новой версии Altium Designer

Загрузить установщик Altium Designer

Если Вы хотите поговорить с представителем, пожалуйста, свяжитесь с местным офисом Altium.
Copyright © 2019 Altium Limited

Пожалуйста, заполните форму ниже, чтобы получить ценовое предложение.

Нажимая [Получить бесплатнную пробную версию], Вы соглашаетесь с нашей Политикой конфиденциальности. Вам могут приходить сообщения от компании Altium, и Вы можете изменить настройки уведомлений в любой момент.

Если Ваша подписка Altium активна, у Вас нет необходимости в пробной лицензии.

Если у Вас нет активной подписки Altium, пожалуйста, заполните форму ниже, чтобы получить пробную версию.

Нажимая [Получить бесплатнную пробную версию], Вы соглашаетесь с нашей Политикой конфиденциальности. Вам могут приходить сообщения от компании Altium, и Вы можете изменить настройки уведомлений в любой момент.

Для чего Вы хотите попробовать Altium Designer?

Если Вы хотите поговорить с представителем, пожалуйста, свяжитесь с местным офисом Altium.
Copyright © 2019 Altium Limited

Вы нашли нужное место! Пожалуйста, заполните форму ниже, чтобы начать использование пробной версии.

Нажимая [Получить бесплатнную пробную версию], Вы соглашаетесь с нашей Политикой конфиденциальности. Вам могут приходить сообщения от компании Altium, и Вы можете изменить настройки уведомлений в любой момент.

Great News!

Valid students can get their very own 6-month Altium Designer Student License for FREE! Just fill out the form below to request your Student License today.

Нажимая [Получить бесплатнную пробную версию], Вы соглашаетесь с нашей Политикой конфиденциальности. Вам могут приходить сообщения от компании Altium, и Вы можете изменить настройки уведомлений в любой момент.

Вы можете загрузить бесплатную лицензию средства просмотра Altium Designer Viewer сроком действия 6 месяцев.

Пожалуйста, заполните форму ниже, чтобы запросить эту лицензию.

Нажимая [Получить бесплатнную пробную версию], Вы соглашаетесь с нашей Политикой конфиденциальности. Вам могут приходить сообщения от компании Altium, и Вы можете изменить настройки уведомлений в любой момент.

Замечательно! Создавать новое - отличное занятие. У нас есть превосходная программа для Вас.

Upverter - бесплатная платформа, разработанная специально для любителей проектирования.

Нажмите здесь, чтобы попробовать!

Если Вы хотите поговорить с представителем, пожалуйста, свяжитесь с местным офисом Altium.
Copyright © 2019 Altium Limited

Вы можете загрузить бесплатную лицензию средства просмотра Altium Designer Viewer сроком действия 6 месяцев.

Пожалуйста, заполните форму ниже, чтобы запросить эту лицензию.

Нажимая [Получить бесплатнную пробную версию], Вы соглашаетесь с нашей Политикой конфиденциальности. Вам могут приходить сообщения от компании Altium, и Вы можете изменить настройки уведомлений в любой момент.