Altium NEXUS Documentation

Преимущество 3D в интеграции ECAD-MCAD_AD

Последнее изменение: Pavel Demidov; 09.03.2021

Содержание

Полное содержание

Главная страница: Совместное проектирование ECAD-MCAD

Преимущество 3D

В сфере проектирования говорят, что стоимость устранения ошибки увеличивается 10-кратно на каждом последующем этапе. Соответственно, устранить ошибку на этапе прототипирования стоит в 10 раз дороже, чем устранить ее на этапе проектирования; устранить ошибку на этапе производства стоит еще в 10 раз дороже, и еще в 10 раз – на этапе после отгрузки изделия. Это грубые оценки, но стоимость устранения ошибки возрастает примерно в 1000 раз, когда изделие находится в руках заказчика, по сравнению с ее устранением в процессе проектирования. Это сильный стимул сделать всё правильно на этапе проектирования!

Одной из самых сложный областей является обеспечение того, что печатный узел подойдет корпусу изделия. Современные изделия – это не большие прямоугольные коробки с кучей свободного места. Зачастую они имеют нестандартную форму, они компактны, имеют плотно упакованную внутреннюю структуру и могут включать в себя множество печатных плат, соединенных между собой. И платы должны подходить корпусным деталям, чтобы крепежные отверстия, дисплеи и элементы управления точно совпадали с соответствующими вырезами и точками крепления.

Почему это так сложно? Потому что плату нужно передавать между областями электронного и механического проектирования, т.е. между системами ECAD и MCAD.

Как правило, ECAD-инженер конструирует плату в 2D-среде, определяя размер платы и размещая критически важные элементы на основе размеров, предоставленных MCAD-инженером. По другую сторону процесса, MCAD-инженер моделирует плату и размещает важные компоненты на основе размеров, предоставленных ECAD-инженером. Все надеются, что всё сделано верно, и плата подойдет!

Во избежание ошибок и этого ужасающего множителя затрат, распространенным подходом было создание макета печатного узла для его помещения в корпус. Макет платы создавался с помощью печати рисунка и контактных площадок компонентов и наклеивания этих распечаток на тонкий картон. После чего приклеивались критически важные компоненты, а также всё, что должно было проецироваться на корпус или быть близким к нему, например, соединители и дисплей. Корпус моделировался с помощью картона или пенопласта, и в него помещалась плата. Такой подход зачастую просто не практичен для многих конструкций, например, если корпус имеет нестандартную форму.

Моделирование конструкции из картона для обеспечения того, что электроника подходит корпусуПрототип устройства Ambient Stack Machine, созданный в рамках практического курса программирования в Мюнхенском университете имени Людвига и Максимилиана (изображение предоставлено: FredericPK из SketchingWithHardware)

Подобно всем областям конструирования, обеспечение соответствия платы корпусу – это поиск компромиссных решений: отрегулировать положение этого крепежного отверстия, переместить этот компонент, затем изменить вырез в корпусе под дисплей, когда этот дисплей будет снят с поставки.

Самое лучшее решение здесь – устранить препятствие и создать связь между областями проектирования ECAD и MCAD. Связь, которая позволит легко передавать печатный узел между системами ECAD и MCAD.

Для этого необходимы трехмерные системы ECAD и MCAD. Также необходимо, чтобы у платы и ее компонентов были 3D-модели, понятные обеим системам проектирования, которые поддерживают критические изменения формы платы, положения компонентов и вырезов в корпусе.

Соответственно, вам необходим трехмерный редактор плат, который позволяет:

  • Создавать 3D-модели компонентов
  • Импортировать 3D-модели компонентов в стандартных форматах
  • Импортировать модели корпуса устройства
  • Проводить трехмерные проверки на пересечения в редакторе плат
  • Экспортировать модель печатного узла в файл стандартного формата

Совместное проектирование ECAD-MCAD

На этой странице описаны функциональные возможности Altium NEXUS, доступные для 3D-проектирования плат. Для поддерживаемых MCAD-систем также доступна передача платы и компонентов непосредственно между системами MCAD и ECAD с использованием CoDesigner – технологии взаимодействия ECAD с MCAD от Altium. Интерфейс CoDesigner, работающий через сервер управляемых данных Altium, такой как Altium 365 Workspace, может передавать форму платы и размещенные на ней компоненты непосредственно между MCAD-системой и Altium NEXUS.

Функциональные возможности, доступные в Altium CoDesigner, зависят от вашего плана подписки Altium Subscription. Чтобы узнать больше о функциональных возможностях, доступных в этих планах, перейдите на страницу планов Altium Subscription.

► Узнайте больше о Совместном проектировании ECAD-MCAD с использованием Altium CoDesigner.

Трехмерный редактор плат

Иногда конструктор, видя свою плату в редакторе плат в 3D-режиме первый раз, говорит: "Но это же не более чем красивая картинка. Мне это не нужно!"

Да, плата выглядит хорошо, но это точно не просто картинка для красоты. Конечно, конструктор плат отлично решает задачи трехмерного конструирования, перенося их в среду многослойного 2D-проектирования, и такие задачи, как трассировка, эффективно решаются в 2D-пространстве. Но 3D-режим редактора плат предлагает конструктору намного больше, чем просто красивую картинку.

Возможность отобразить плату в реалистичном 3D-режиме позволяет конструктору увидеть печатный узел, готовый к размещению в корпусе. Вместе с 3D-мышью, такой как SpaceMouse®, реализм выходит на новую ступень – вы как будто держите плату в руках, можете поворачивать ее и изучать в подробностях. Теперь вы сразу видите, что, например, компонент закрыл позиционное обозначение или что вы забыли тентировать переходные отверстия.


Помимо красивой картинки, существует множество причин работать в поистине трехмерном редакторе плат. Движение на этой анимации было создано с помощью возможностей создания роликов в редакторе плат.

Вместе с поддержкой импорта моделей компонентов вы сможете использовать компоненты нестандартной формы, размер которых критически важен, таких как соединители. Вместе с поддержкой 3D-проверки на пересечения вы сможете быть уверены, что компоненты будут корректно размещены на плате, а печатный узел подойдет корпусу.

И последний кусочек мозаики – поддержка экспорта печатного узла в MCAD, чтобы инженер-механик смог проверить его на собираемость в корпусе, с учетом крепежа, отступов и множества других аспектов, которые позволят создать конечное изделие.

Импорт и экспорт 3D-данных механики в/из редактора плат может быть выполнен с помощью формата Parasolid или STEP.

STEP (Standard for the Exchange of Product Model Data, стандарт обмена данными модели изделия) – это неофициальное название международного стандарта обмена трехмерными механическими данными ISO 10303. Описать объект в 3D-пространстве достаточно сложно, и поэтому формат STEP также очень подробен и сложен. Стандарт поддерживает различные типы геометрических моделей, такие как геометрически ограниченная поверхностная модель, топологически ограниченная поверхностная модель, фасетно ограниченная модель и другие. Поддержка этих типов геометрических моделей обеспечена набором прикладных протоколов (Application Protocol). Первым из них, получившим широкое применение, стал AP203. Следующим протоколом стал AP214, который является предпочтительным форматом импорта и экспорта данных для редактора плат (AP203 не поддерживает цвет).

Для обеспечения поддержки более широкого набора моделей компонентов, помимо формата STEP (*.Step и *.Stp), компоненты также могут быть импортированы в форматах Parasolid (*.x_t и *.x_b) и файлов деталей SolidWorks (*.SldPrt).

Режимы отображения редактора плат

Для поддержки различных задач конструирования, в редакторе плат присутствуют три режима отображения (меню View):

  • Board Planning Mode (Режим планирования платы) – используйте этот режим для определения формы платы, а также регионов платы и линий сгиба для гибко-жесткой конструкции. Нажмите клавишу 1 для переключения в этот режим.
  • 2D Layout Mode (Режим 2D-отображения) – стандартный режим двухмерного конструирования платы, используемый для размещения компонентов и трассировки, а также для прочих общих задач конструирования платы. Нажмите L, чтобы настроить отображаемые слои. Нажмите клавишу 2 для переключения в этот режим.
  • 3D Layout Mode (Режим 3D-отображения) – реалистичное 3D-представление платы. Нажмите L для настройки режима проекции, видимых слоев, их цветов и отображения 3D-моделей. Нажмите клавишу 3 для переключения в этот режим.

Режим отображения Board Planning редактора плат Режим отображения 2D Layout редактора плат Режим отображения 3D Layout редактора платИспользуйте клавиши 1, 2 и 3 для переключения в требуемый режим отображения: режим планирования платы, режим 2D-отображения или режим 3D-отображения.

Управление 3D-видом

В режиме 3D-отображения редактора плат вы можете беспрепятственно изменять масштаб вида, поворачивать его и даже перемещаться внутрь платы с помощью следующих сочетаний клавиатуры и мыши:

Масштабирование

  • Ctrl + Перетаскивание с зажатой правой кнопкой мыши (ПКМ)
  • Ctrl + Вращение колеса мыши
  • Клавиши PgUp / PgDn

Панорамирование (перемещение вида)

  • Перетаскивание с зажатой ПКМ
  • Вращение колеса мыши (прокрутка по вертикали) и Shift + Вращение колеса мыши (прокрутка по горизонтали).
  • Цифровой блок клавиатуры в сочетании с клавишей Ctrl:
    • Ctrl+4 – панорамировать влево
    • Ctrl+6 – панорамировать вправо
    • Ctrl+8 – панорамировать вверх
    • Ctrl+2 – панорамировать вниз

Вращение

  • Shift + Перетаскивание с зажатой ПКМ. При зажатии клавиши Shift под текущим положением курсора появляется сфера со стрелками (как показано на видео ниже). Вращение модели осуществляется относительно центра сферы (наведите курсор в нужное место перед тем как зажать клавишу Shift, чтобы отобразить сферу) с помощью элементов управления, обозначенных ниже. Переместите мышь для подсветки определенного элемента управления и выберите нужный из них на сфере перед щелчком ПКМ:
    • Перетаскивание мыши с зажатой ПКМ, когда подсвечена центральная точка – вращение вида в любом направлении.
    • Перетаскивание мыши с зажатой ПКМ, когда подсвечена горизонтальная стрелка – вращение вида вокруг оси Y.
    • Перетаскивание мыши с зажатой ПКМ, когда подсвечена вертикальная стрелка – вращение вида вокруг оси X.
    • Перетаскивание мыши с зажатой ПКМ, когда подсвечен круговой сегмент – вращение вида в плоскости Z.
  • Цифровой блок клавиатуры:
    • 4 – повернуть влево
    • 6 – повернуть вправо
    • 8 – повернуть вверх
    • 2 – повернуть вниз

Изменение вида – основной блок клавиатуры

  • 0 (ноль) – вид платы сверху
  • 9 – вид платы сверху, повернутый на 90 градусов
  • 8 – ортогональный вид платы

Изменение вида – цифровой блок клавиатуры

  • 1 – вид платы сверху
  • Ctrl+1 – вид платы снизу
  • 3 – вид платы слева
  • Ctrl+3 – вид платы справа
  • 7 – вид платы спереди
  • Ctrl+7 – вид платы сзади
  • 9 – вид платы сверху, повернутый на 90 градусов
Когда редактор плат находится в режиме 3D-отображения, вы можете увидеть список сочетаний клавиш, вызвав меню View » 3D View Control.

На видео ниже продемонстрировано большинство из этих способов управления видом.

Используйте клавиши и правую кнопку мыши для управления видом в 3D-режиме.

Управление видом при переключении между режимами отображения 2D и 3D

При переключении между режимами отображения 2D и 3D, по умолчанию будет отображен вид, который был задан в целевом режиме предыдущий раз. То есть если в 2D-режиме была отображена вся плата, затем вы переключились в 3D-режим и приблизили вид, то при переключении обратно в 2D-режим будет отображена вся плата. Наведите курсор мыши на изображение ниже, чтобы увидеть работу системы при нажатии клавиши 3.

При переключении режима отображения, по умолчанию будет отображен вид, который был задан здесь предыдущий раз

Чтобы переключить режим отображения и оставить место, которое приближено в данный момент, зажмите клавиши Ctrl+Alt при нажатии 2 или 3. Наведите курсор мыши на изображение ниже, чтобы увидеть работу системы при нажатии сочетания клавиш Ctrl+Alt+2.

Для переключения между режимами отображения и сохранения текущего масштаба зажмите Ctrl+Alt при использовании клавиш

Если вы собираетесь использовать 3D-режим постоянно, рассмотрите использование 3D-мыши, например SpaceMouse® от 3Dconnexion, которая значительно упрощает процесс перемещения и вращения платы в 3D-режиме. Многие видео на этой странице, которые включают в себя движение в 3D, были записаны с использованием 3D-мыши.

Посадочное место и компонент

Главная страница: Создание посадочного места

В редакторе плат область, которую занимает компонент на плате, определяется посадочным местом компонента. Создание и изменение посадочных мест компонентов осуществляется в редакторе библиотек посадочных мест. Перейдите на страницу Создание посадочного места для получения более подробной информации.

Типовое посадочное место включает в себя контактные площадки и рисунок на слое шелкографии, но оно также может включать в себя любую необходимую информацию о механике. В примере посадочного места, показанном ниже, большая часть контура компонента определена на механическом слое (зеленые линии), а не на слое шелкографии (желтые линии), поскольку компонент будет установлен таким образом, что он будет располагаться над вырезом в печатной плате.

Посадочное место в 2D-режиме отображения Посадочное место в 3D-режиме отображенияПосадочное место определяет пространство, которое занимает компонент, а также точки подключения выводов/контактных площадок компонента к трассам на плате.

Компонент, который монтируется на это посадочное место, можно смоделировать с помощью объектов 3D Body, размещаемых в редакторе библиотек посадочных мест. Объект 3D Body поддерживает ряд простых форм, в том числе вытянутый полигон, цилиндр и сферу, которые можно сочетать между собой для создания необходимой формы компонента, как показано на изображении первом изображении ниже.

Объект 3D Body также можно использовать в качестве контейнера для импорта в него модели в формате MCAD. С импортированной MCAD-моделью можно взаимодействовать таким же образом, как и со стандартными объектами 3D Body. На втором изображении ниже показана STEP-модель светодиода.

Физическое представление светодиода, созданное из объектов 3D Body Физическое представление светодиода, импортированное из MCAD-системы в виде файла формата STEPОбъекты 3D Body можно использовать для создания формы компонента (первое изображение). Если доступна подходящая модель из MCAD, ее можно импортировать в объект 3D Body (второе изображение).

Создание формы из объектов 3D Body

Если размеры компонента не являются критически важными либо если нет подходящей MCAD-модели, форму компонента можно определить путем размещения одного или множества объектов 3D Body.

Существует три стиля объекта 3D Body, которые можно разместить:

Generic
(Общая модель)
Модель общего вида, например, модель компонента в формате STEP, размещенная путем определения ссылки в объекте 3D Body или встроенная в него.
Extruded
(Вытянутая модель)
Вытянутая модель определяется интерактивно, в плоскости X-Y (вид сверху), таким же образом, как в редакторе плат определяются другие полигональные объекты. Затем объект вытягивается вниз (или вверх) по вертикали, на основе свойств Overall Height (Общая высота) и Standoff Height (Высота отступа), определяемых в режиме 3D Body панели Properties, и опции Body Projection (Проекция модели). Для поверхности такой модели вы можете использовать файл текстуры, например, логотип.
Cylindrical
(Цилиндр)
Свойства этой модели определяются в режиме 3D Body панели Properties.
Spherical
(Сфера)
Свойства этой модели определяются в режиме 3D Body панели Properties.

Демонстрационное видео, где показано размещение объектов 3D Body для создания физического представления светодиодаФорму компонента можно определить множеством объектов 3D Body.

► Узнайте больше о размещении и редактировании объектов 3D Body.

Панель Properties в режиме 3D Body позволяет эффективно редактировать свойства множества объектов 3D Body, например, их цвет. Выделите объекты в режиме 2D- или 3D-отображения и нажмите клавишу F11 (либо нажмите кнопку Panels в нижней правой части приложения), чтобы открыть панель Properties в режиме 3D Body.

Создание объектов 3D Body из посадочного места

Для ускорения процесса создания модели компонента система позволяет создавать наборы вытянутых объектов 3D Body на основе фигур, найденных в посадочном месте. Эта функция может быть полезной, если компонент имеет нестандартную форму, которая уже отражена в фигуре, определенной на слое шелкографии посадочного места. Вы также можете добавлять дополнительные объекты на механические слои посадочного места и затем использовать их для создания дополнительных объектов 3D Body, таких как выводы компонента.

На изображениях ниже показано посадочное место транзистора TO-92. Из контура, созданного на верхнем слое шелкографии, сформирован корпус транзистора на выбранной паре слоев 3D Body (обозначена в диалоговом окне как Registration Layer). Также на механическом слое были размещены три небольших квадрата (каждый из которых создан с помощью четырех линий), которые были использованы для формирования выводов компонента на выбранной паре слоев 3D Body. Настройки показаны на изображении диалогового окна ниже.

Посадочное место транзистора TO-92 3D-модель транзистора TO-92, сформированная из объектов 3D Body, первое изображение 3D-модель транзистора TO-92, сформированная из объектов 3D Body, второе изображение Существующие в посадочном месте объекты можно использовать для создания новых объектов 3D Body.

Для создания объектов 3D Body из фигур в посадочном месте запустите команду Tools » Manage 3D Bodies for Current Component. Будет открыто диалоговое окно Component Body Manager. Обратите внимание на столбец Body State, где показано, что планируется создание четырех 3D-моделей.

Система может создавать объекты 3D Body на основе фигур из существующих объектов.

Примечания об использовании этого диалогового окна:

  • Алгоритм обнаружения предлагает создание прямоугольной формы на основе описанного прямоугольника либо создание полигональной формы, которая следует контуру примитивов (вдоль центральной линии трасс/дуг, если их конечные точки совпадают).
  • Для создания объекта 3D Body из существующего объекта щелкните ЛКМ по синему тексту в столбце Body State.
  • Значение Overall Height (Общая высота) по умолчанию совпадает со значением Height (Высота), определенным в диалоговом окне PCB Library Footprint.
  • Для вывода компонента, который проходит через плату, задайте опции Body Projection значение Bottom Side.
  • Объекты 3D Body будут созданы после нажатия кнопки Close диалогового окна. Если вид уже переключен в 3D-режим, для отображения новых объектов может понадобиться обновление вида (клавиша End) либо переключение в 2D, затем обратно в 3D.
Перейдите на страницу диалогового окна Component Body Manager для получения более подробной информации о создании объектов 3D Body из существующих фигур в посадочном месте.

Создание объектов 3D Body из выделенных примитивов

В редакторе библиотек посадочных мест вы можете создавать 3D-модели с помощью команды Tools » Convert » Create 3D Body From selected primitives. Эта команда отлично подходит для создания простых моделей.

Одним из способов создания 3D-модели является использование выделенных 2D-примитивов

► Узнайте больше о создании объектов 3D Body из выделенных примитивов.

Использование 3D MCAD-моделей компонентов

Предпочтительным подходом является использование точной 3D-модели. Она не только лучше выглядит, но и позволяет проводить более точную проверку на пересечения в редакторе плат.

Примечания касательно использования 3D MCAD-моделей:

  • Чтобы разместить MCAD-модель с сервера управляемых данных, необходимо выбрать команду Place » 3D Extruded Body из главного меню. Эта команда позволяет получить доступ к серверу управляемых данных (через панель Properties), в то время как команда Place » 3D Body позволяет разместить MCAD-модель только из файла на жестком диске.
  • После выбора команды нажмите клавишу Tab, чтобы открыть панель Properties в режиме 3D Body, где опцию 3D Model Type (Тип 3D-модели) можно переключить с Extruded по умолчанию на Generic (Общая MCAD-модель).
  • В панели появится поле Source. Выберите Server, чтобы получить доступ к серверу управляемых данных, затем нажмите кнопку Choose, чтобы открыть диалоговое окно Choose Item. В этом диалоговом окне будет показано содержимое вашего сервера управляемых данных.
  • Найдите на сервере управляемых данных нужную MCAD-модель, выберите ее и нажмите OK.
  • Вы вернетесь в режим размещения в рабочей области редактора библиотек. Нажмите кнопку "паузы" (Кнопка паузы, которая появляется при нажатии клавиши Tab для открытия панели Properties в процессе редактирования), чтобы вернуться к размещению, и разместите MCAD-модель.
  • Система останется в режиме размещения. Нажмите клавишу Esc, чтобы выйти из режима размещения модели. В следующем разделе сказано, как ориентировать и позиционировать модель, которая размещена в посадочном месте.
  • Чтобы узнать больше о хранении MCAD-моделей на сервере управляемых данных, перейдите на страницу Управляемые 3D-модели.
  • 3D-модель импортируется в объект 3D Body редактора плат или редактора библиотек посадочных мест. Если вы щелкнете ЛКМ по MCAD-модели (например, по модели STEP) в редакторе посадочных мест, чтобы выделить ее, в панели Properties будут отображены свойства объекта 3D Body, который содержит в себе MCAD-модель.

Режим 3D Body панели Properties, где показано, как загрузить файл MCAD-модели3D MCAD-модель загружена из сервера управляемых данных в объект 3D Body.

  • Компонент может быть импортирован в формате STEP (*.Step и *.Stp), Parasolid (*.x_t и *.x_b) или файла детали SolidWorks (*.SldPrt).
  • Некоторые 3D-модели можно найти у производителя компонентов.
  • Существуют различные веб-сайты, такие как 3D Content Central и GrabCAD, где конструкторы публикуют модели.
  • Также существуют коммерческие сайты, где вы можете найти 3D-модели, такие как Ultra Librarian и PCB 3D.

Ориентирование и позиционирование 3D-модели

После того, как MCAD-модель была размещена рядом с посадочным местом компонента, ее можно позиционировать. Как правило, положение 3D MCAD-модели необходимо изменить в соответствии с посадочным местом.

Существует ряд средств и функций, которые могут помочь в этом процессе:

  • В модель могут быть добавлены дополнительные точки привязки, которые затем можно использовать для точного позиционирования модели в посадочном месте.
    • Точки привязки можно размещать интерактивно, с помощью команды Tools » 3D Body Placement » Add Snap Point from Vertices. У команды есть два режима: создание точки в месте щелчка ЛКМ и создание точки по середине между двумя местами щелчка ЛКМ. Нажимайте клавишу Пробел, чтобы переключаться между этими режимами после выбора STEP-модели. Следите за строкой состояния, чтобы знать, на каком этапе процесса вы находитесь и какой режим сейчас активен. На видео ниже показано использование этой команды.
    • Точку привязки также можно определить путем ввода ее значений X, Y и Z в панели Properties в режиме 3D Body (дважды щелкните ЛКМ по модели, чтобы открыть панель в этом режиме).
  • Для вращения модели вокруг осей и определения ее вертикального положения можно использовать панель Properties в режиме 3D Body (показано на видео ниже).
  • Модель также можно выровнять с посадочным местом с помощью команды Tools » 3D Body Placement » Orient and Position 3D Body. В этой команде необходимо сначала указать три исходных точки в посадочном месте, затем три соответствующих вершины в модели. Система переориентирует модель и разместит эти три вершины модели в эквивалентных исходных точках, указанных в посадочном месте.
  • Как правило, поворот модели проще выполнять в режиме 3D-отображения, а позиционирование в плоскости X-Y, например с помощью совмещения точки привязки с посадочным местом, в режиме 2D-отображения.

Панель Properties можно использовать для визуального позиционирования модели.

Привязки к 3D-модели

Для повышения удобства и точности добавления точек привязки в 3D-модель, в процессе их определения происходит автоматическая привязка к следующим точкам:

  • Центры отверстий
  • Точки пересечения ортогональных осей с ребром отверстия
  • Середина ребра
  • Оси тела модели
  • Центры линий между двумя точками привязки (при переключении режима с помощью клавиши Пробел).

Сложная 3D-модель компонента, где определено несколько точек привязкиЭти точки привязки были добавлены с помощью автоматической привязки к центрам отверстий.

Привязка к этим точкам также доступна при использовании команды Reports » Measure Distances в режиме 3D-отображения.

Управление видимостью начала координат и точек привязки 3D-моделей

В разделе System Colors панели View Configuration находятся элементы управления видимостью начала координат и точек привязки 3D-моделей.

Из MCAD в ECAD – корпус и форма платы

Для поддерживаемых MCAD-систем также доступна передача платы и компонентов непосредственно между системами MCAD и ECAD с использованием CoDesigner. Интерфейс CoDesigner, работающий через сервер управляемых данных Altium, такой как Altium 365 Workspace, может передавать форму платы и размещенные на ней компоненты непосредственно из MCAD-системы в Altium NEXUS.

► Узнайте больше о Совместном проектировании ECAD-MCAD.

Главная страница: Импорт и экспорт STEP

Общим подходом является проектирование конструктором-механиком изначальной концепции модели, чтобы все участники процесса понимали, как будет выглядеть изделие. Здесь конструктор-механик определяет корпус и изначальную форму платы.

Корпус и форму платы можно передать в ECAD-систему, сохранив их в MCAD-системе в формат STEP и разместив в рабочей области редактора плат. Altium NEXUS включает в себя команду, которая позволяет переопределить форму платы ECAD непосредственно по форме платы из MCAD.

Экспорт корпуса из MCAD

STEP является сложным и подробным форматом файлов. Чтобы получить максимальную пользу от передачи проектных данных, помните о следующем:

  • Форму платы можно экспортировать внутри корпуса, если она является отдельной подсборкой. В этом случае, вы сможете определить форму платы в редакторе плат ECAD за несколько кликов.
  • Используйте формат AP214, где это возможно.
  • Используйте поверхностную и твердотельную геометрию, если возможно.

Диалоговое окно SOLIDWORKS Export Options, где настраивается экспорт в STEP Диалоговое окно PTC Creo Export STEP, где настраивается экспорт в STEPПодходящие настройки экспорта для SolidWorks (первое изображение) и PTC Creo (второе изображение).

Импорт корпуса в редактор плат

Помимо импорта модели компонента в редактор библиотек, вам также доступен импорт корпуса в редактор плат. Это позволяет провести точную 3D-проверку на пересечения печатного узла, который находится в корпусе.

3D-изображение, где показана плата сложной формы в корпусеИмпорт корпуса в редактор плат для проведения 3D-проверки на пересечения в процессе проектирования платы.

Когда вы импортируете MCAD-модель компонента, вы импортируете ее в посадочное место в редакторе библиотек. Модель корпуса импортируется в объект 3D Body в редакторе плат, с помощью команды Place » 3D Body. В режиме 3D Body панели Properties необходимо задать источник модели: Server, Embed Model или Link to Model. При выборе варианта Embed Model MCAD-модель будет сохранена в файле платы. При выборе Server или Link to Model будет дана ссылка на модель в файле платы.

Процесс импорта MCAD-модели корпуса в редактор плат показан на видео ниже.

Задать ссылку или встроить?

Embed Model – MCAD-модель хранится в файле платы. Преимуществом является то, что ее можно переносить вместе с файлом платы. Недостатком является то, что MCAD-модель (в формате STEP) может быть большим файлом, который увеличит размер файла платы.

Link to Model – MCAD-модель не хранится в файле платы, поэтому файл модели должен быть доступен при открытии файла платы. Преимуществом является то, что если файл MCAD-модели, на который указывает ссылка, обновится, то редактор плат обнаружит это изменение и позволит повторно загрузить модель. Чтобы использовать ссылку на модель, определите место, где хранятся MCAD-модели, на странице PCB Editor - Models диалогового окна Preferences.

Управление отображением корпуса

Главная страница: PCB - 3D Models

Большим преимуществом определения формы платы в редакторе плат по модели STEP является то, что плата в точности соответствует корпусу и размещена в нем. Для переопределения формы платы вам необходимо увидеть плату внутри модели STEP, что можно сделать, скрыв часть корпуса или весь корпус (показано на видео ниже).

Режим 3D Models панели PCB, где настраивается отображение импортированного 3D-корпусаКорпус или его часть можно скрыть из вида, а также скрыть для проверок правил проектирования.

Управление видимостью всех 3D-моделей осуществляется в режиме 3D Models панели PCB.

Чтобы скрыть часть модели:

  1. Выберите Free Models в разделе Components панели.
  2. Выберите корпус в разделе Model панели. Если он содержит детали, вы сможете раскрыть его, как показано на изображении выше.
  3. Щелкните ЛКМ по названию нужной детали, чтобы выделить ее. Станет активным выпадающее меню под этим разделом панели, с помощью которого вы можете настроить прозрачность этой детали либо скрыть ее. Здесь также присутствует флажок, который можно использовать для отключения проверки правил проектирования для любой модели STEP.

Определение формы платы по MCAD-модели

  • Как и модели компонентов, MCAD-модели корпусов можно хранить на сервере управляемых данных. В этом случае, вместо команды Place » 3D Body используйте команду Place » Extruded 3D Body для размещения корпуса. В процессе размещения нужно нажать клавишу Tab и использовать панель Properties для размещения модели с сервера управляемых данных.
  • Размещение с сервера управляемых данных показано на видео в разделе Ориентирование и позиционирование 3D-модели.
  • Обратитесь к странице Управляемые 3D-модели, чтобы узнать больше о хранении MCAD-моделей на сервере управляемых данных.

Если импортированный корпус включает в себя форму платы и эта форма включена в качестве отдельной подсборки, то форму платы в ECAD можно легко переопределить непосредственно по форме платы из MCAD, как показано ниже.

Если импортированная модель STEP включает в себя форму платы, ее можно использовать для переопределения формы платы в редакторе плат.

Чтобы определить форму платы в редакторе плат по импортированной модели STEP, выполните следующее:

  1. При необходимости вы можете скрыть деталь корпуса, чтобы получить доступ к форме платы (как показано на видео выше).
  2. В режиме 3D-отображения запустите команду Design » Board Shape » Define from 3D Body.
  3. Эта команда выполняется в два этапа. Сначала выберите модель.
  4. Затем выберите грань, по которой будет определена форма платы.
  5. Будет открыто диалоговое окно Board Outline Creation Successful, где вы можете определить, с какой стороной платы будет выровнена грань, которую вы выбрали. Под верхней поверхностью платы (top PCB board surface) здесь понимается верхняя поверхность проводящего слоя Top Layer, которая является началом отсчета для оси Z редактора плат, поэтому хорошим подходом здесь является выбор верхней поверхности формы платы в модели STEP и ее выравнивание с верхней поверхностью платы.
  6. Вы также можете скрыть MCAD-модель платы для проверки правил проектирования. Это может быть хорошей идеей, поскольку форма платы теперь точно определена, и теперь эта форма платы будет использоваться для размещения компонентов и проверок правил проектирования.
  • В редакторе плат, нулевой точкой отсчета оси Z является верхняя поверхность верхнего проводящего слоя.
  • После определения формы платы вы можете настроить структуру слоев.

Проведение 3D-проверки на пересечения в редакторе плат

Главная страница: Определение ограничений конструкции – Правила проектирования

Возможно, самым большим преимуществом редактора плат является возможность проведения 3D-проверок на пересечения. Помимо поиска типичных пересечений между компонентами, теперь вы также можете с уверенностью размещать один компонент под другим и проверять, что плата корректно установлена в корпус.

Проверка на пересечения основана на правиле проектирования Component Clearance. Это бинарное правило, т.е. оно проверяет ограничение между одним объектом (набором объектов) и другим объектом (набором объектов).

Правило проектирования Component Clearance, задающее проверку на пересеченияДля точного управления процессом проверки пересечений можно задать множество правил Component Clearance.

Вызывающие нарушения объекты и расстояние между этими двумя объектами отображаются по умолчанию. Чтобы увидеть точное место минимального расстояния между объектами, включите опцию Show actual violation distances в правиле проектирования Component Clearance.

Проверка пересечений осуществляется динамически, в процессе вашей работы. Правило, примененное в этой анимации, показано на предыдущем изображении. Это правило позволяет разместить кнопку под дисплеем.

Редактор плат может проводить проверку пересечений между моделями STEP, в одной плате. Для проведения проверки на пересечения между множеством печатных узлов используйте сборку Multi-board.

Ссылка на 3D-модель в правиле проектирования

Главная страница: Определение области действия правил проектирования

Для получения максимальной пользы от системы правил проектирования важно понимать, как наилучшим образом задавать область действия правил проектирования. Область действия правила определяет набор объектов, на которое это правило действует. Например, правило, область действия которого определена ключевым словом InPolygon, будет применено ко всем примитивам внутри всех полигонов на плате. Чтобы правило действовало на объекты внутри определенного полигона, следует использовать ключевое слово InNamedPolygon('ИмяПолигона').

Если вы создаете правило, которое должно действовать на определенный компонент, вы можете использовать ключевое слово InComponent('ПозиционноеОбозначениеКомпонента'). Например, в область действия InComponent('C1') будут попадать все объекты внутри компонента C1, в том числе контактные площадки, трассы на слое шелкографии, 3D-модели и т.д.

Если необходимо, чтобы правило действовало только на 3D-модель компонента, вы можете использовать ключевое слово id в правиле проектирования. Например, на видео выше дисплей является отдельной подсборкой с позиционным обозначением LCD1. Значением идентификатора 3D-модели, используемой в этом компоненте, является LCD_2x16, как показано на первом изображении ниже. Чтобы использовать этот идентификатор, правило было настроено, как показано на втором изображении ниже.

Режим 3D Body панели Properties, где настраивается идентификатор, который можно использовать для определения области действия правила Использование идентификатора 3D-модели для определения области действия правилаИдентификатор 3D-модели можно использовать для определения области действия правила, чтобы оно действовало только на эту 3D-модель компонента.

Чтобы узнать больше, перейдите на страницу Определение области действия правил проектирования.

Проведение измерений в 3D

Помимо проверки на пересечения, другой задачей, которую часто необходимо выполнять конструктору, является измерение расстояния между двумя 3D-объектами. Какой зазор между соединителем и корпусом? Сколько пространства между этой микросхемой и соединителем, который расположен выше?

Команда Measure 3D Objects (меню Reports) позволяет получить информацию о расстояниях по осям X, Y и Z, а также кратчайшем расстоянии между выбранными объектами.

У команды есть два режима выбора целевого объекта:

  • Наведите курсор на нужный объект (он будет подсвечен зеленым)
  • Зажмите клавишу Ctrl при наведении, чтобы подсветить только определенную грань на целевом 3D-объекте.

На изображении ниже была выбрана поверхность на синем соединителе, а также ближайшая поверхность на белом корпусе. На изображение было наложено диалоговое окно 3D Distance.

Проведение измерений в 3D-режиме отображенияПроведите точное измерение расстояния между объектами в режиме 3D-отображения. Кратчайшее расстояние между выбранными объектами (или поверхностями, как в этом примере) показано желтым.

  • Нажмите клавишу Q переключения единиц измерения, в которых отображаются результаты измерения.
  • Нажмите сочетание клавиш Shift+C, чтобы удалить отображение измерения. Дважды щелкните ЛКМ по результату в панели Messages, чтобы отобразить результат снова.
  • Курсор при измерении будет автоматически привязываться к различным точкам 3D-модели.

Из ECAD в MCAD – экспорт печатного узла

Для поддерживаемых MCAD-систем также доступна передача платы и компонентов непосредственно между системами MCAD и ECAD с использованием CoDesigner. Интерфейс CoDesigner, работающий через сервер управляемых данных Altium, такой как Altium 365 Workspace, может передавать форму платы и размещенные на ней компоненты непосредственно в MCAD-систему.

► Узнайте больше о Совместном проектировании ECAD-MCAD.

Главная страница: Импорт и экспорт STEP

Чтобы экспортировать печатный узел для MCAD-системы, используйте команду File » Export » STEP 3D. После ввода имени файла будет открыто диалоговое окно Export Options.

Диалоговое окно Export Options используется для настройки того, какие данные будут экспортированы в сформированном файле STEP
Задайте настройки экспорта STEP необходимым образом.

Примечания касательно использования этого диалогового окна:

  • Если вы хотите экспортировать только выделенные компоненты, то их, как правило, проще выделять в режиме 2D-отображения.
  • Свободными 3D-моделями (Free 3D Bodies) являются дополнительные модели, которые размещены в редакторе плат, такие как модели корпуса.
  • Плата экспортируется всегда. Чтобы исключить компоненты (экспортировать только плату), включите опцию Export Selected и не выделяйте компоненты.
  • Опции экспорта 3D-моделей (3D Bodies Export Options) применимы к 3D-моделям, которые добавлены в посадочные места компонентов в редакторе библиотек. Простыми моделями (simple bodies) здесь называются вытянутые, цилиндрические и сферические объекты 3D Body.
  • В файле STEP, компоненты идентифицируются по своим позиционным обозначениям. Если конструктору-механику необходимо импортировать множество плат в один файл MCAD, могут возникнуть конфликты позиционных обозначений. Чтобы избежать их, включите суффиксы компонентов (Component Suffix).
  • Используйте опцию Export As Single Part, чтобы экспортировать плату как деталь, а не как сборку.
  • Опция Export Folded Board (Экспортировать сложенную плату) работает, только если в конструкции определены линии сгиба. Чтобы экспортировать частично сложенную плату, перед запуском команды на экспорт задайте степень сгиба с помощью ползунка Fold State в режиме Layer Stack Region панели PCB. Заданное значение будет автоматически применено в диалоговом окне Export Options.

Экспортированный файл STEP завершенной платы, загруженный в MCAD-систему (Rhinoceros 3D)Частично сложенная гибко-жесткая плата, экспортированная из редактора плат и импортированная в 3D-систему проектирования Rhinoceros.

  • Функциональная возможность экспорта в STEP доступна в качестве расширения платформы. Если экспорт в STEP отсутствует в меню Export, проверьте, что он включен в разделе Platform Extensions.
  • Вместо формата STEP 3D вы также можете использовать Parasolid и VRML. Разные форматы имеют схожие опции, за исключением того, что Parasolid включает в себя возможность экспортировать проводящий рисунок. Перейдите на страницу диалогового окна Export Options, чтобы узнать больше.

Формирование выходных файлов

Доступно формирование выходных 3D-документов различных типов. В таблице ниже приведена сводка по доступным выходным документам, их настройке и формированию.

Нажмите Ctrl+C в 3D-режиме отображения, чтобы сделать снимок платы в высоком разрешении3D-снимок с разрешением 300dpi, полученный из редактора плат, который затем был смаштабирован в редакторе изображений до максимального размера, поддерживаемого веб-документацией.

Тип выходного документа Откуда формировать Примечания
Захват экрана Редактор плат Когда редактор находится в режиме 3D-отображения, нажмите Ctrl+C, чтобы сделать снимок текущего вида. Будет открыто диалоговое окно 3D Snapshot Resolution, где нужно задать необходимое разрешение (Render Resolution) и нажать OK, чтобы скопировать изображение в буфер обмена Windows. Затем это изображение можно вставить в любой графический редактор.
Экспорт в виде изображения Редактор плат Выберите команду File » Export » PCB 3D Print. После выбора места сохранения файла изображения будет отрыто диалоговое окно PCB 3D Print Settings, где вы можете задать разрешение, то, как плата будет отображена, и формат изображения.
PCB 3D Print
(3D-распечатка платы)
Файл OutputJob

Настраивается в диалоговом окне PCB 3D Print Settings. В файле OutputJob назначьте выходной документ контейнеру New PDF или непосредственно на принтер. Задайте вид платы необходимым образом перед формированием выходного документа, затем нажмите кнопки Take Current Camera Position и Take Current View Configuration, чтобы сформировать распечатку того, что вы видите на экране. Вы также можете создать файл изображения, сопоставив задание на вывод документа контейнеру Folder Structure.

PCB 3D Video
(3D-видео платы)
Файл OutputJob

Настраивается в диалоговом окне PCB 3D Video. В файле OutputJob назначьте выходной документ контейнеру New Video. Выходной документ может быть в одном из множества форматов. Чтобы сформировать этот выходной документ, необходимо сначала определить 3D-фильм в панели PCB 3D Movie Editor. Перейдите на страницу 3D PCB Video, чтобы узнать больше.

PDF 3D Файл OutputJob / Редактор плат Настраивается в диалоговом окне PDF3D. В файле OutputJob назначьте выходной документ контейнеру New Folder Structure. Для поддержки 3D-движения необходим Adobe Acrobat v9 или более новый. Выходной документ может также включать в себя ключевые кадры из 3D-фильма, если он был создан. Перейдите на страницу PDF3D Exporter, чтобы узнать больше.

Включение механических слоев в режим 3D-отображения

Механические слои можно отобразить в 3D, если в настройках 3D используется опция Colors - By Layer. Будут отображены слои, заданные в данный момент как видимые, как показано на изображении ниже (наведите курсор мыши на изображение, чтобы увидеть настройки отображения).

При отображении платы в 3D с использованием цветов слоев будут также отображены механические слои.

Печать из редактора плат

Редактор плат также позволяет формировать распечатки как из 2D-, так и из 3D-вида. Также возможно определение множества 3D-распечаток, с различными включенными слоями и объектами – например, распечатки шаблонов, комбинированные распечатки, распечатки экранных слоев и т.д.

Поскольку доступно множество распечаток плат, распечатка, которая формируется при выборе команды File » Print из меню редактора плат, определяется выбранной в данный момент распечаткой по умолчанию (Default Print), которая задается с помощью команды File » Default Prints.

Печать из файла OutputJob

Главная страница: Подготовка множества выходных документов в файле OutputJob

Поскольку доступно множество распечаток плат, многие конструкторы предпочитают использовать файл OutputJob, где можно легко добавить и настроить выходной документ каждого типа и из которого затем можно сформировать выходной документ.

3D-распечатки добавляются в разделе Documentation Outputs файла OutputJob. Нажмите [Add New Documentation Output], чтобы отобразить меню и выбрать необходимый тип выходного документа, как показано на изображении ниже.

Добавление 3D-распечатки в файл OutputJobНажмите по нужной ссылке Add New, чтобы добавить новый выходной документ в файл, как показано выше. Для настройки выходного документа любого типа выделите его название в списке, щелкните ПКМ и выберите Configure (или дважды щелкните ЛКМ по его названию).

► Узнайте больше о Подготовке множества выходных документов в файле OutputJob.

► Узнайте больше о выпуске выходных данных с помощью средства Project Releaser.

Обнаружили проблему в этом документе? Выделите область и нажмите Ctrl+Enter, чтобы оповестить нас.

Связаться с нами

Связаться с нашими Представительствами напрямую

We're sorry to hear the article wasn't helpful to you.
Could you take a moment to tell us why?
200 characters remaining
Вы сообщаете о проблеме, связанной со следующим выделенным текстом
и/или изображением в активном документе:
Бесплатная пробная версия Altium Designer
Бесплатная пробная версия Altium Designer
Давайте приступим. Для начала, Вы или Ваше предприятие уже используете Altium Designer?

Если Вы хотите поговорить с представителем, пожалуйста, свяжитесь с местным офисом Altium.
Copyright © 2019 Altium Limited

В таком случае, для чего Вам необходима пробная лицензия?

Если Вы хотите поговорить с представителем, пожалуйста, свяжитесь с местным офисом Altium.
Copyright © 2019 Altium Limited

Вам для этого не нужна пробная лицензия.

Нажмите кнопку ниже, чтобы загрузить установщик самой новой версии Altium Designer

Загрузить установщик Altium Designer

Если Вы хотите поговорить с представителем, пожалуйста, свяжитесь с местным офисом Altium.
Copyright © 2019 Altium Limited

Пожалуйста, заполните форму ниже, чтобы получить ценовое предложение.

Нажимая [Получить бесплатнную пробную версию], Вы соглашаетесь с нашей Политикой конфиденциальности. Вам могут приходить сообщения от компании Altium, и Вы можете изменить настройки уведомлений в любой момент.

Если Ваша подписка Altium активна, у Вас нет необходимости в пробной лицензии.

Если у Вас нет активной подписки Altium, пожалуйста, заполните форму ниже, чтобы получить пробную версию.

Нажимая [Получить бесплатнную пробную версию], Вы соглашаетесь с нашей Политикой конфиденциальности. Вам могут приходить сообщения от компании Altium, и Вы можете изменить настройки уведомлений в любой момент.

Для чего Вы хотите попробовать Altium Designer?

Если Вы хотите поговорить с представителем, пожалуйста, свяжитесь с местным офисом Altium.
Copyright © 2019 Altium Limited

Вы нашли нужное место! Пожалуйста, заполните форму ниже, чтобы начать использование пробной версии.

Нажимая [Получить бесплатнную пробную версию], Вы соглашаетесь с нашей Политикой конфиденциальности. Вам могут приходить сообщения от компании Altium, и Вы можете изменить настройки уведомлений в любой момент.

Great News!

Valid students can get their very own 6-month Altium Designer Student License for FREE! Just fill out the form below to request your Student License today.

Нажимая [Получить бесплатнную пробную версию], Вы соглашаетесь с нашей Политикой конфиденциальности. Вам могут приходить сообщения от компании Altium, и Вы можете изменить настройки уведомлений в любой момент.

Вы можете загрузить бесплатную лицензию средства просмотра Altium Designer Viewer сроком действия 6 месяцев.

Пожалуйста, заполните форму ниже, чтобы запросить эту лицензию.

Нажимая [Получить бесплатнную пробную версию], Вы соглашаетесь с нашей Политикой конфиденциальности. Вам могут приходить сообщения от компании Altium, и Вы можете изменить настройки уведомлений в любой момент.

Замечательно! Создавать новое - отличное занятие. У нас есть превосходная программа для Вас.

Upverter - бесплатная платформа, разработанная специально для любителей проектирования.

Нажмите здесь, чтобы попробовать!

Если Вы хотите поговорить с представителем, пожалуйста, свяжитесь с местным офисом Altium.
Copyright © 2019 Altium Limited

Вы можете загрузить бесплатную лицензию средства просмотра Altium Designer Viewer сроком действия 6 месяцев.

Пожалуйста, заполните форму ниже, чтобы запросить эту лицензию.

Нажимая [Получить бесплатнную пробную версию], Вы соглашаетесь с нашей Политикой конфиденциальности. Вам могут приходить сообщения от компании Altium, и Вы можете изменить настройки уведомлений в любой момент.