Altium NEXUS Documentation

Работа со средством выпуска Project Releaser_AD

Главная страница: Выпуск проекта платы

Перед тем, как отправить проект на производство, его необходимо выпустить, а значение процесса выпуска зачастую недооценивается.

Altium NEXUS предлагает мощные интегрированные инструменты управления выпуском проектов через собственное средство Project Releaser. Благодаря интуитивно понятному интерфейсу, пользователи могут создать сразу все данные для производства – данные для изготовления, сборки и т.д. Это средство выпуска также позволяет одновременно создавать данные для сборки множества вариантов проекта. Вам даже не нужно беспокоиться о создании файлов Output Job – средство выпуска сделает это при необходимости.

Средство Project Releaser позволяет управлять выпуском всех типов проектов PCB: неуправляемые/не в системе контроля версий, под управляемой внешней системы VCS или управляемые сервером данных – и предлагает два режима работы:

  • Управляемый (онлайн) режим – выпуск всех созданных данных в ревизии объектов на активный сервер управляемых данных. Нет необходимости запоминать ревизии объектов – средство выпуска контролирует их самостоятельно.
  • Неуправляемый (офлайн) режим – выпуск всех созданных данных в структуру папок, которую можно упаковать в единый zip-архив.

С помощью средства Project Releaser вы можете легко создать полный набор данных для производства. Вы также сможете указать желаемые результаты этого процесса перед подтверждением выпуска (например, просмотрев данные Gerbers/ODB++ в редакторе CAM), чтобы убедиться, что создаваемые данные – это именно те данные, которые необходимы для производства платы.

В этом документе рассматривается процесс выпуска на сервер управляемых данных. Если вы не используете сервер управляемых данных или не вошли на сервер, вы будете использовать средство выпуска Project Releaser в неуправляемом (офлайн) режиме, который рассматривается здесь.

Доступ к средству выпуска Project Releaser

Графическим интерфейсом средства Project Releaser является страница Release, доступ к которой осуществляется одним из следующих способов:

  • Выбор команды Project » Project Releaser из главного меню (исходный документ требуемого проекта должен быть открыт и активирован).
  • Щелчок правой кнопкой мыши по пункту требуемого проекта в панели Projects и выбор команды Project Releaser из контекстного меню.

Открытие страницы Release – интерфейса пользователя средства выпуска Project Releaser.Открытие страницы Release – интерфейса пользователя средства выпуска Project Releaser.

Режим выпуска/Цель

Средство выпуска Project Releaser пытается автоматически определить, какой режим выпуска использовать – управляемый (онлайн) или неуправляемый (офлайн) – и место выпуска данных. Если существует выбор, например, когда проект был выпущен на один сервер управляемых данных, а вы в данный момент подключены к другому, система предложит доступные опции.

При выпуске на сервер управляемых данных, в файле проекта в качестве атрибута сохраняется целевой сервер. Таким образом, целевой сервер, сохраненный с проектом, может отличаться от сервера, к которому вы в данный момент подключены.
Если у вас обычный проект (не управляемый и не под контролем VCS) и вы подключены только к Altium Content Vault, будет автоматически выбран офлайн-режим выпуска.

Обнаружение файлов Output Job

Если ваш проект не содержит связанных с ним файлов Output Job, средство выпуска Project Releaser обнаружит это и предложит создать файлы по умолчанию. Если вы согласитесь, будут созданы следующие файлы:

  • Fabrication.OutJob – с заданными выходными данными:
    • Documentation Outputs: PCB Prints
    • Fabrication Outputs: Gerber Files, NC Drill Files и IPC-2581
    • Validation Outputs: Design Rules Check, Footprint Comparison Report
    • Export Outputs: Save As/Export PCB (в формате ASCII)
  • Assembly.OutJob – с заданными выходными данными:
    • Documentation Outputs: PCB 3D Print, Schematic Prints
    • Assembly Outputs: Generates pick and place files, Assembly Drawings
    • Report Outputs: Bill of Materials
    • Export Outputs: Export STEP

Эти файлы Output Job по умолчанию находятся в папке установки: \Users\Public\Documents\Altium\Nexus<Version>\OutputJobs.

Вы можете использовать эти файлы по умолчанию как они есть, настроить их под собственные требования либо создать дополнительные файлы Output Job – создайте их в папке по умолчанию или в собственной папке. Если вы используете собственную папку, укажите ее расположение в поле OutputJob Path на странице System - Default Locations диалогового окна Preferences. Все файлы Output Job, заданные в этой папке, будут добавлены в проект.
Если в вашем проекте есть хотя бы один файл OutJob, автоматическое создание этого файла предлагаться не будет.

Поддержка Web Review

Altium NEXUS предоставляет инструменты создания пометок и комментирования на основе веб-технологий с помощью концепции Web Review. Это средство, не требующее больших затрат вычислительных ресурсов, предназначено для всех участников процесса проектирования для получения информации и задания вопросов по проекту. Нет необходимости в загрузке и установке сторонних средств, а также в изучении инструментов проектирования – эти возможности работают в любом веб-браузере.

Эта функциональность может быть добавлена в процессе выпуска для любого набора создаваемых данных проекта.

Создание данных Web Review требует наличия файла Output Job (с именем WebReview.OutJob) с заданным типом выходных данных экспорта Web Review. При открытии средства Project Releaser вы будете уведомлены, если такой файл не существует. Вы можете добавить в проект файл WebReview.OutJob по умолчанию либо продолжить без него, но в этом случае функциональность Web Review не будет доступна. Если файл WebReview.OutJob добавлен, данные Web Review доступны для создания по умолчанию, для всех наборов создаваемых данных: исходные данные, данные для производства, данные для сборки (для базового проекта и всех обнаруженных вариантов исполнения).

Возможность добавления файла WebReview.OutJob по умолчанию – автоматическое создание данных Web Review с помощью добавления этого файла OutJob для каждого набора данных.Возможность добавления файла WebReview.OutJob по умолчанию – автоматическое создание данных Web Review с помощью добавления этого файла OutJob для каждого набора данных.

Файл WebReview.OutJob по умолчанию находится в папке установки: \ProgramData\Altium\Altium NEXUS <GUID>\Extensions\ManagedFlows\OutputJobs.

Обнаружение вариантов исполнения

Очень мощным аспектом средства выпуска Project Releaser является обнаружение вариантов исполнения, заданных в проекте, и создание для каждого из них набора данных для сборки. У каждого такого набора будет имя целевого объекта по умолчанию в формате:

PCBA-[НазваниеПроекта]-[НазваниеВарианта]

Набор данных для базового проекта будет PCBA-[НазваниеПроекта]-[NO VARIATIONS].

Суффикс [НазваниеВарианта] обеспечивает использование правильного варианта для создания набора данных по назначенному файлу OutJob.

Дополнительные наборы данных для сборки, созданные на основе найденных вариантов исполнения проекта.Дополнительные наборы данных для сборки, созданные на основе найденных вариантов исполнения проекта.

Настройка схем именования объектов сервера

При первом выпуске проекта на активный сервер управляемых данных, вы можете задать именование объектов целевых данных на этом сервере. Это делается на вкладке Item Naming диалогового окна Project Release Options, открытие которого осуществляется нажатием кнопки в левом нижнем углу страницы (или нажатием по ссылке Target Revision для выпускаемого набора данных и выбором Edit из контекстного меню). На этой вкладке вы можете:

  • Определить имя проекта. По умолчанию будет использоваться текущее имя проекта.
  • Определить целевую папку верхнего уровня (на сервере), в которую будут выпущены данные.
  • Определить схему именования по умолчанию для различных объектов данных, которые могут быть созданы в процессе выпуска.
Сам проект не является объектом, получающим данные выпуска – он является своего рода опорной точкой, представляющей объекты выпущенных данных с точки зрения всего проекта, а также связь этих объектов при просмотре управляемого проекта в панели Explorer. Для получения более подробной информации см. Просмотр выпущенного управляемого проекта.

Чтобы изменить любую из схем именования, нажмите по кнопке Settings – откроется диалоговое окно Naming Template Settings.

Задайте целевую папку и именование создаваемых объектов на сервере управляемых данных.Задайте целевую папку и именование создаваемых объектов на сервере управляемых данных.

Поддерживаются следующие форматы шаблонов именования:

  • На основе параметров – использование параметров, заключенных в квадратные скобки (например [ProjectName], [VariantName], [ProjectParameter]).
  • На основе чисел – использование чисел, заключенных в фигурные скобки (например {0000}, {9000}).
На вкладке Item Naming диалогового окна Project Release вы можете нажать по полю схемы именования и изменить его необходимым образом. Либо вы можете нажать кнопку в правой части поля, чтобы открыть диалоговое окно Choose Item (инкарнация панели Explorer), где вы можете указать существующий объект на активном сервере управляемых данных.
Именование объектов может быть в любой момент изменено на первом этапе страницы Release, при настройке выпускаемых на сервер данных. После того, как данные для определенного набора созданы и загружены на сервер, соответствующие имена нельзя изменить.

Процесс выпуска

После того, как именование объектов сервера было задано желаемым образом, вы можете начать выпуск. Это поэтапный процесс, пункты которого находятся в левой части страницы Release, что позволяет быстро определить, на каком этапе вы в данный момент находитесь.

Этап 1 – Configure Vault Release (Настройка выпуска в хранилище)

На этом этапе процесса выпуска вы задаете тип(ы) данных, которые хотите создать. Объекты данных, которые могут быть выпущены:

  • Source Data (Исходные данные) – «снимок» (состояние на данный момент) исходного проекта.
  • Fabrication Data (Данные для производства) – данные, необходимые производству для изготовления платы (без компонентов).
  • Assembly Data for the Base Design (no variations) (Данные сборки для базового проекта – без вариантов) – данные, необходимые производству для монтажа компонентов на плату в соответствии со спецификацией базового проекта, без вариантов исполнения.
  • Assembly Data for Design Variant n (Данные сборки для варианта n проекта) – данные, необходимые производству для монтажа компонентов на плату в соответствии со спецификацией проекта в определенном варианте исполнения.

Число наборов данных для сборки соответствует базовому проекту и всем обнаруженным вариантам исполнения этого проекта.

Кроме того, вы можете добавить и настроить раздел пользовательских данных Custom Data. Это может быть необходимо для обратной совместимости или для собственных рабочих процессов. Ссылки не будут созданы, кроме ссылок на исходные данные. Для выпуска может быть создано и настроено любое количество пользовательских наборов данных (нажмите Add Section под списком заданных объектов).

Этап 1 процесса выпуска – настройка данных, которые будут включены в выпуск (какие данные будут созданы).Этап 1 процесса выпуска – настройка данных, которые будут включены в выпуск (какие данные будут созданы).

Объект Source Data (Исходные данные) всегда включен в выпуск. Остальные данные могут быть добавлены по необходимости.

Для данных производства и сборки, включенных в выпуск, необходим по крайней мере один назначенный им файл OutputJob. Если у вас есть файлы Output Job files, имена которых начинаются с подстрок 'fab' и 'ass', то эти файлы будут автоматически назначены разделам Fabrication Data и Assembly Data соответственно при первом открытии страницы Release. В противном случае вам необходимо назначить необходимые файлы OutJob вручную. Это можно сделать на вкладке Release Options диалогового окна Project Release Options (кнопка в нижней левой части страницы).

Назначение файлов OutJob соответствующим наборам данных.Назначение файлов OutJob соответствующим наборам данных.

На вкладке Release Options диалогового окна Project Release Options вы также можете изменить назначение выпуска, переключаясь между управляемым (онлайн) и неуправляемым (офлайн) режимами. Доступны три варианта:

  • Unmanaged - Folder (Неуправляемый режим – Папка): созданные данные будут выпущены в локальную папку. Путь к корневой папке указан на вкладке Output Path диалогового окна. По умолчанию он задан [OutputPath] (используется путь, заданный в поле Output Path на вкладке Options диалогового окна Project Options).
  • Unmanaged - Zip (Неуправляемый режим – Zip-архив): созданные данные будут выпущены в локальную папку. Данные будут упакованы в единый zip-архив. Путь и название архива задается на вкладке Output Path диалогового окна. По умолчанию он задан [OutputPath][ProjectName].zip (используется путь, заданный в поле Output Path вкладки Options диалогового окна Project Options).
  • Managed - <ИмяСервера> (Управляемый режим – Сервер): созданные данные будут выпущены на сервер управляемых данных, к которому вы в данный момент подключены.

Выберите назначение выпуска – место, куда будут отправлены созданные данные.Выберите назначение выпуска – место, куда будут отправлены созданные данные.

Нажмите по ссылке в пункте Target Revision на главной странице, чтобы открыть меню команд, показанных на рисунке и описанных ниже.

Открытие элементов управления для указания ревизии набора данных, создаваемых в процессе выпуска – наведите курсор мыши на изображение, чтобы увидеть.Открытие элементов управления для указания ревизии набора данных, создаваемых в процессе выпуска – наведите курсор мыши на изображение, чтобы увидеть.

  • Auto <RevisionID> – эта команда позволяет системе управлять ревизиями. Здесь указана следующая ревизия для объекта на том же уровне в рамках назначенной системы именования ревизий (например, если текущей ревизией является A.1, то команда назначит целевую ревизию A.2).
  • Next <RevisionID> – эта команда позволяет увеличить целевую ревизию на следующий уровень в рамках назначенной схемы именования ревизий (например, если текущей ревизией является A.1, то команда назначит целевую ревизию B.1).
  • Custom – эта команда позволяет назначить специальную ревизию целевому объекту заданием пользовательского идентификатора ревизии в диалоговом окне Custom Revision ID.
  • Browse – эта команда позволяет указать существующий целевой объект и ревизию, в который следует произвести выпуск. Чтобы сделать это, появится диалоговое окно Choose Target Item (инкарнация панели Explorer).
  • Edit – эта команда позволяет открыть вкладку Item Naming диалогового окна Project Release Options, из которого вы можете изменить имя целевого объекта (и его начальную ревизию), который будет создан.
  • Navigate – эта команда позволяет быстро перейти к объекту в панели Explorer (где он уже выпущен и существует следующая ревизия в запланированном состоянии).

Пункт наверху меню показывает текущую выбранную/заданную целевую ревизию.

Нажмите Details справа от заголовка набора данных, чтобы открыть подробную информацию о том, что именно будет создано для этого набора. Чтобы свернуть эту часть, нажмите Hide Details. Набор создаваемых данных определяется одним или несколькими файлами Output Job (за исключением набора Source Data). Вы можете быстро открыть исходный файл OutJob, нажав Configure.

Открытие подробной информации о наборе создаваемых данных – наведите курсор на изображение, чтобы увидеть.Открытие подробной информации о наборе создаваемых данных – наведите курсор на изображение, чтобы увидеть.

Существует ряд дополнительных настроек, относящихся к процессу выпуска, которые задаются на странице Data Management - Servers диалогового окна Preferences:

  • Папку, используемую для временного хранения созданных файлов перед их загрузкой на активный сервер управляемых данных, можно использовать по умолчанию (\Users\<ProfileName>\AppData\Local\Temp) или задать вручную.
  • Включите параметр Delete contents after exiting release mode, чтобы очищать папку временного хранения по окончании процесса выпуска.
  • Название каждого создаваемого выходного документа можно предварительно задать с использованием идентификаторов объекта и ревизии (например, [FAB-Bluetooth_Sentinel-A.1] Validation.PDF). Для этого включите параметр Prepend revision HRID to file names.

Дополнительные настройки процесса выпуска.Дополнительные настройки процесса выпуска.

После того, как объекты данных, которые будут созданы в процессе выпуска, настроены необходимым образом, нажмите кнопку в правой нижней части страницы, чтобы начать процесс.

Кнопка имеет два состояния. Нажмите на нее, чтобы выполнить стандартную команду Prepare – вы перейдете на этап Review Data, где вы сможете снова проверить, что все в порядке, до подтверждения. Если вы не хотите останавливаться на проверку, используйте выпадающее меню кнопки и выберите команду Prepare & Release.

Перед выпуском производится несколько проверок:

  • Проект и все файлы были сохранены.
  • Проект и все файлы переданы в VCS, если применимо.
  • Каждому объекту задано имя.
  • У пользователя есть права на создание целевого объекта (и ревизий).
  • Создание требуемых целевых объектов (и запланированных ревизий) на сервере управляемых данных, где они в данных момент не существуют, и проверка того, что для объектов используется следующая ревизия, если они существуют.

Если будет обнаружена какая-либо проблема, будет предложено ее решение (например, сохранение локально измененных файлов и их передача в VCS).

В этот момент создается объект исходных данных, со снимком файлов исходного проекта, выпускаемых в ревизию целевого объекта.

Этап 2 – Validate Project (Проверка проекта)

После того, как этап 1 завершен без ошибок, вы автоматически перейдете на следующий этап, если в назначенных файлах OutJob будет обнаружен один или несколько отчетов для проверки. Будут запущены все заданные генераторы выходных файлов проверки, определенные в файле Output Job, назначенном объекту выпускаемых данных. Они могут включать в себя:

  • Отчет о различиях – использование компаратора для определения того, что документы схемы и платы корректно синхронизированы.
  • Проверка электрических правил – проверка корректности схемы с точки зрения размещения электрических и графических объектов.
  • Проверка конструкторских правил – проверка корректности документа платы с точки зрения ограничений, заданных на уровне платы.
  • Отчет сравнения посадочных мест – сравнение посадочных мест на плате и в исходных библиотеках для проверки их актуальности и соответствия.
  • Проверка состояния компонентов – проверка того, что компоненты находятся в разрешенных состояниях. В ходе настройки вы можете задать предпринимаемое действие для каждого заданного в данный момент состояния каждой определенной на сервере стадии жизненного цикла: не предпринимать действие, выдать предупреждение или ошибку. Последний вариант не допустит дальнейший процесс выпуска. Кроме того, при проверке будет создан HTML-отчет, позволяющий быстро увидеть, какие компоненты имеют недопустимое состояние.
  • Проверка соответствия настройки среды – проверка того, что используются только объекты, разрешенные настройкой среды, доступной для использования назначенной вам ролью (если применимо). Также проверяется, что источником всех объектов является сервер управляемых данных.

Если проверка проходит успешно, будет показана иконка и текст Passed. В противном случае, будет показана иконка и текст Failed.

Выпуск не будет завершен, если какая-либо из проверок не будет пройдена.
Нажмите в правой нижней части страницы, чтобы остановить процесс выпуска.

Этап 3 – Generate Data (Создание данных)

Если этап 2 завершается без ошибок, будет автоматически запущен этот следующий этап. Здесь будет запущено создание всех прочих выходных документов, определенных в назначенных объектам файлах OutJob, для выпуска соответствующих объектов на сервер.

Для обозначения процесса создания используются следующие иконки:

– не запущено/не создано.

– запущено/создается.

– создание завершено успешно.

– создание завершено неудачей.

Нажмите в правой нижней части страницы, чтобы остановить процесс выпуска.

Этап 4 – Review Data (Просмотр данных)

После того, как все проверки пройдены и выходные данные созданы, вы можете просмотреть созданные документы на этом этапе.

Если вы использовали команду Prepare & Release, этот этап будет недоступен – данные сразу будут выпущены.

Просмотр созданных данных перед подтверждением их выпуска и загрузкой на сервер управляемых данных, чтобы убедиться, что все в порядке.Просмотр созданных данных перед подтверждением их выпуска и загрузкой на сервер управляемых данных, чтобы убедиться, что все в порядке.

По умолчанию на странице показан простой (компактный) вид созданных данных. Чтобы просмотреть более подробную информацию, нажмите Details у необходимого раздела.

Нажмите Details, чтобы переключить простой вид отображения созданных данных на подробный. Чтобы перейти обратно, нажмите Hide Details.Нажмите Details, чтобы переключить простой вид отображения созданных данных на подробный. Чтобы перейти обратно, нажмите Hide Details.

В таблице ниже приведены возможные состояния выходных документов в режиме просмотра подробных данных:

Состояние

Описание

Выходной документ еще не был создан/не существует.

Выходной документ создан, но был изменен в проекте, что делает его состояние проверки неактуальным.

Выходной документ находится в процессе создания.

Выходной документ является проверяющим, и в процессе его создания не возникло ошибок. Для отчета проверки электрических правил, ошибок не возникло, либо уровень ошибок попадает в указанный предельно допустимый уровень для этого отчета.

Выходной документ (за исключением проверяющих документов) создан успешно.

Выходной документ не был создан успешно. Для проверяющих документов это означает, что существуют ошибки исходных проектных документах, которые не прошли проверки. Для обычного выходного документа это значит, что он не может быть создан. Возможно, существуют критические ошибки при компиляции, либо что-то не так с настройкой генератора в файле Output Job.

В компактном виде отображения созданных данных нажмите ссылку View, чтобы открыть связанный файл или набор файлов в соответствующем редакторе Altium NEXUS (например, редакторе CAM) или внешнем приложении (например, Microsoft Excel). В подробном виде дважды щелкните по пункту, чтобы открыть только один файл.

В компактном режиме отображения раздела Source Data нажмите ссылку View, чтобы открыть Проводник Windows временную папку хранения снимка исходных файлов проекта. То же самое происходит при нажатии по ссылке Explore справа от заголовка раздела. У каждого раздела есть такая ссылка для быстрого перехода в главную папку данных во временной директории.
В подробном режиме отображения, команды контекстного меню позволяют открыть документ и открыть временную папку, в которой он был создан. Вы также можете добавить столбцы данных о расположении папки и дате создания – щелкните правой кнопкой мыши по строке заголовка таблицы и выберите команду Select Columns – будет открыто диалоговое окно, в котором вы можете настроить отображение данных.

Если в ходе просмотра вы обнаружили, что необходимо внести изменения в данные, нажмите кнопку в правой нижней части страницы. Появится диалоговое окно для подтверждения, предупреждающее о том, что все созданные данные будут потеряны – нажмите OK, чтобы отменить выпуск и вернуться к первому этапу процесса.

Система не позволяет вносить изменения в проектные файлы между подготовкой выпуска и выпуском данных на сервер управляемых данных. Если вы все же внесете изменения, процесс выпуска будет прерван, и вы вернетесь на начальный этап, предшествующий подготовке выпуска.

Если с созданными данными все в порядке, нажмите кнопку (в правой нижней части страницы). Появится диалоговое окно Confirm Release со сводкой конфигурации проекта, который будет выпущен на сервер управляемых данных. Здесь у вас есть возможность добавить имя Name (по умолчанию [ProjectName]), описание Description, а также подходящую информацию о выпуске.

Подтверждение выпуска, касательно созданных объектов и ревизий, с возможностью изменить имя/описание и добавить информацию о выпуске.Подтверждение выпуска, касательно созданных объектов и ревизий, с возможностью изменить имя/описание и добавить информацию о выпуске.

Этап 5 – Upload Data (Загрузка данных)

После подтверждения выпуска на предыдущем шаге, следующий этап будет запущен автоматически. Здесь представлен прогресс загрузки данных в ревизии соответствующих объектов на сервере управляемых данных.

На этом этапе показан прогресс загрузки созданных данных в связанные объект-ревизии на сервер управляемых данных.На этом этапе показан прогресс загрузки созданных данных в связанные объект-ревизии на сервер управляемых данных.

Этап 6 – Execution Report (Отчет о выполнении)

На этом финальном этапе предоставляется отчет о результатах выпуска.

Финальный отчет о выпуске.Финальный отчет о выпуске.

Используйте ссылки в разделе Navigation Links для быстрого доступа к связанным ревизиям объектов, содержащим выпущенные данные (данные для производства, данные для сборки, пользовательские наборы данных), в панели Explorer – портал в сервер управляемых данных.

Просмотр выпущенных данных проекта на сервере управляемых данных в панели Explorer.Просмотр выпущенных данных проекта на сервере управляемых данных в панели Explorer.

Если ваш проект является управляемым, то вам доступна еще одна функциональная возможность по окончании процесса выпуска. Нажмите по ссылке Project Page (последняя в разделе Navigation Links страницы Execution Report), чтобы открыть панель Explorer, где будет представлен проект в виде Project View, доступном только для управляемых проектов.

Если ранее вы просматривали проект в классическом отображении Classic View, необходимо вручную переключиться на вид Project View с помощью команды доступной из меню кнопки .

Вы можете получить подробную информацию об управляемом проекте в режиме Explorer панели Project View.Вы можете получить подробную информацию об управляемом проекте в режиме Explorer панели Project View.

Этот вид аналогичен подробному отображению управляемого проекта на странице Projects веб-интерфейса сервера. На виде доступны следующие вкладки:

  • Stream – подробности о недавней активности с проектом.
  • Parameters – список параметров, заданных на уровне проекта.
  • Releases – что было выпущено, представленное в виде собранных пакетов (в том числе данные для сборки, изготовления, а также исходные данные).
  • Working Files – исходные файлы проекта, которые можно загрузить в единый zip-архив.
  • Structure – графическое представление связи созданных данных между собой в проекте.
  • Activities – список активностей, связанных с проектом. Проектировщик может начать определенную активность для управляемого проекта, с помощью предопределенного рабочего процесса Project Activity предприятия. Нажмите по пункту этой активности, чтобы отобразить диаграмму рабочего процесса (на вкладке Diagram под списком), где показано, что необходимо для завершения активности, и на каком этапе процесса эта активность находится, кому назначена задача для продвижения этой активности дальше. Также доступны вкладки для просмотра данных, приложенных к активности (вкладка Data ) и истории действий в процессе активности (вкладка History). Доступны элементы управления для переключения списка между активными (Active) и завершенными (Closed) активностями, а также поиск интересующей активности.
Администратору сервера доступна возможность прекратить активный процесс с помощь кнопки .

После того, как проект выпущен, закройте страницу Release с помощью кнопки внизу справа. Когда понадобится выполнить повторный выпуск проекта в будущем, Project Releaser позволит сделать это легко и быстро и автоматически увеличит целевую ревизию объекта.

Неуправляемый (офлайн) режим выпуска

Наряду с управляемым (онлайн) режимом выпуска, Project Releaser также позволяет осуществлять локальный, неуправляемый (офлайн) выпуск. Обычно этот режим используется, если у вас нет сервера управляемых данных либо если вы в данный момент не можете подключиться к серверу. Хотя Project Releaser определяет режим автоматически, где это возможно, либо предлагает выбор, когда нет однозначности, вы всегда можете задать использование офлайн-режима настройкой Release Target на вкладке Release Options диалогового окна Project Release Options (нажмите кнопку на этапе 1 процесса выпуска), выбрав один из следующих вариантов:

  • Unmanaged - Folder (Неуправляемый режим – Папка): созданные данные будут выпущены в локальную папку. Путь к корневой папке указан на вкладке Output Path диалогового окна. По умолчанию он задан [OutputPath] (используется путь, заданный в поле Output Path на вкладке Options диалогового окна Project Options).
  • Unmanaged - Zip (Неуправляемый режим – Zip-архив): созданные данные будут выпущены в локальную папку. Данные будут упакованы в единый zip-архив. Путь и название архива задается на вкладке Output Path диалогового окна. По умолчанию он задан [OutputPath][ProjectName].zip (используется путь, заданный в поле Output Path вкладки Options диалогового окна Project Options).

Вы можете быстро определить, что Project Releaser настроен на офлайн-режим, следующим образом:

  • В заголовке этапа 1 написано Configure Local Release вместо Configure Vault Release (как при онлайн-режиме).
  • В заголовке этапа 5 написано Pack Data вместо Upload Data (как при онлайн-режиме).

Средство выпуска Project Releaser настроено в локальный, неуправляемый (офлайн) режим.Средство выпуска Project Releaser настроено в локальный, неуправляемый (офлайн) режим.

Процесс выпуска схож с описанным выше для управляемого (онлайн) режима, только данные выпускаются в локальную папку. Чтобы не повторять информацию, указанную выше, здесь обозначим только задействованные этапы с указанием различий.

Этап 1 – Configure Local Release (Настройка локального выпуска)

Здесь вы настраиваете, какие данные необходимо создать из проекта. Исходные данные всегда включаются в выпуск, с возможностью добавить данные для изготовления, сборки (базового проекта и/или вариантов исполнения) и любые другие пользовательские данные, которые необходимы.

Для каждого создаваемого набора данных необходимо указать папку, в которую они будут сохранены. Названия папок, используемые по умолчанию:

  • Source Data (Исходные данные) – будут созданы в папке Sources.
  • Fabrication Data (Данные для производства) – будут созданы в папке Fabrication.
  • Assembly Data for no variant (Данные сборки для базового проекта – без вариантов) – будут созданы в папке Assembly.
  • Assembly Data for <VariantName> (Данные сборки для варианта n проекта) будут созданы в папке Assembly <VariantName>.
  • Custom Data <Custom - n> (Пользовательские данные n) будут созданы в папке <Custom - n>.

Вы можете изменить это именование по умолчанию как необходимо. Для этого нажмите по текущему пункту Target Folder, введите новое имя папки и нажмите Enter.

При выпуске в локальную папку или zip-архив имейте в виду, что повторный выпуск в папки с теми же именами перезапишет существующие в этих папках данные.

После настройки данных, которые будут созданы в процессе выпуска, нажмите кнопку в правой нижней части страницы.

Кнопка имеет два состояния, которые отличаются для двух возможных вариантов неуправляемого выпуска:
  • Unmanaged - Folder (Неуправляемый режим – Папка): нажмите эту кнопку, чтобы запустить стандартную команду Prepare. Процесс перейдет на этап Review Data , что позволит вам повторно проверить, что все в порядке, перед выпуском в целевые папки. Если вы не хотите останавливаться на проверку, откройте выпадающее меню кнопки и выберите команду Prepare & Explore.
  • Unmanaged - Zip (Неуправляемый режим – Zip-архив): нажмите эту кнопку, чтобы запустить стандартную команду Prepare. Процесс перейдет на этап Review Data, что позволит вам повторно проверить, что все в порядке, перед упаковкой данных в zip-архив. Если вы не хотите останавливаться на проверку, откройте выпадающее меню кнопки и выберите команду Prepare & Pack.

Перед выпуском производится несколько проверок:

  • Проект и все файлы были сохранены.
  • Проект и все файлы переданы в VCS, если применимо.
  • Для каждого объекта данных задана целевая папка.

Если будет обнаружена какая-либо проблема, будет предложено ее решение (например, сохранение локально измененных файлов и их передача в VCS).

На этом этапе создаются исходные данные, со снимком файлов исходного проекта, выпускаемых в ревизию целевого объекта.

Этап 2 – Validate Project (Проверка проекта)

После того, как этап 1 завершен без ошибок, вы автоматически перейдете на следующий этап, если в назначенных файлах OutJob будет обнаружен один или несколько отчетов для проверки. Будут запущены все заданные генераторы выходных файлов проверки, определенные в файле Output Job, назначенном объекту выпускаемых данных. Этот этап проходит аналогично этапу в управляемом (онлайн) режиме.

Выпуск не будет завершен успешно, если какая-либо из проверок не будет пройдена.
Нажмите в правой нижней части страницы, чтобы остановить процесс выпуска.

Этап 3 – Generate Data (Создание данных)

Если этап 2 завершается без ошибок, будет автоматически запущен этот следующий этап. Здесь будет запущено создание всех прочих выходных документов, определенных в назначенных объектам файлах OutJob, для выпуска данных в соответствующие папки. Этот этап проходит аналогично этапу в управляемом (онлайн) режиме.

Нажмите в правой нижней части страницы, чтобы остановить процесс выпуска.

Этап 4 – Review Data (Просмотр данных)

После того, как все проверки пройдены и выходные данные созданы, вы можете просмотреть созданные документы на этом этапе. Этот этап проходит аналогично этапу в управляемом (онлайн) режиме.

Если вы использовали команду Prepare & Explore (для опции Unmanaged - Folder) или Prepare & Pack (для опции Unmanaged - Zip), то этот этап будет недоступен – данные сразу будут выпущены, т.е. соответственно выпущены в папки или упакованы в архив.

Просмотр созданных данных перед подтверждением их выпуска и передачей в целевые папки или упаковкой в zip-архив, в соответствии с выбранным вариантом неуправляемого режима.Просмотр созданных данных перед подтверждением их выпуска и передачей в целевые папки или упаковкой в zip-архив, в соответствии с выбранным вариантом неуправляемого режима.

В компактном виде отображения созданных данных нажмите ссылку View, чтобы открыть связанный файл или набор файлов в соответствующем редакторе Altium NEXUS (например, редакторе CAM) или внешнем приложении (например, Microsoft Excel). В подробном виде дважды щелкните по пункту, чтобы открыть только один файл.

Если в ходе просмотра вы обнаружили, что необходимо внести изменения в данные, нажмите кнопку в правой нижней части страницы. Появится диалоговое окно для подтверждения, предупреждающее о том, что все созданные данные будут потеряны – нажмите OK, чтобы отменить выпуск и вернуться к первому этапу процесса.

Система не позволяет вносить изменения в проектные файлы между подготовкой выпуска и выпуском данных в целевые папки. Если вы все же внесете изменения, процесс выпуска будет прерван, и вы вернетесь на начальный этап, предшествующий подготовке выпуска.

Если с созданными данными все в порядке, нажмите кнопку (в правой нижней части страницы). Что произойдет дальше, зависит от варианта режима выпуска:

  • Unmanaged - Folder: созданные файлы будут выпущена в целевые папки, и процесс перейдет на завершающий этап – просмотр отчета Execution Report.
  • Unmanaged - Zip: процесс перейдет на следующий этап Pack Data.

Этап 5 – Pack Data (Упаковка данных)

После подтверждения выпуска на предыдущем этапе, вы автоматически перейдете на этот этап, и данные будут упакованы в единый локальный zip-архив. Путь и название архива задается на вкладке Output Path диалогового окна Project Release Options. По умолчанию он задан [OutputPath][ProjectName].zip (используется путь, заданный в поле Output Path вкладки Options диалогового окна Project Options).

Этот этап применим только в случае использования варианта выпуска Unmanaged - Zip.

Этап 6 – Execution Report (Отчет о выполнении)

На этом финальном этапе предоставляется отчет о результатах выпуска.

Финальный отчет о выпуске при использовании варианта выпуска Unmanaged - Folder. Наведите курсор мыши на изображение, чтобы увидеть отчет при использовании варианта Unmanaged - Zip.Финальный отчет о выпуске при использовании варианта выпуска Unmanaged - Folder. Наведите курсор мыши на изображение, чтобы увидеть отчет при использовании варианта Unmanaged - Zip.

С помощью ссылки Navigation Link вы можете быстро перейти к выходной папке или к архиву в Проводнике Windows.

Быстрый переход к локальной папке, непосредственно из этапа Execution Report. Наведите курсор мыши на изображение, чтобы увидеть пример отображения локально выпущенного zip-архива.Быстрый переход к локальной папке, непосредственно из этапа Execution Report. Наведите курсор мыши на изображение, чтобы увидеть пример отображения локально выпущенного zip-архива.

Обнаружили проблему в этом документе? Выделите область и нажмите Ctrl+Enter, чтобы оповестить нас.

Связаться с нами

Связаться с нашими Представительствами напрямую

We're sorry to hear the article wasn't helpful to you.
Could you take a moment to tell us why?
200 characters remaining
Вы сообщаете о проблеме, связанной со следующим выделенным текстом
и/или изображением в активном документе: