Altium NEXUS Documentation

Работа со средством выпуска Project Releaser

Последнее изменение: Pavel Demidov; 06.07.2019
Эта страница документации относится к Altium Vault – продукту, который больше не поддерживается. Altium Vault и его функциональные возможности по управлению компонентами теперь доступны в Altium Concord Pro.
Полное содержание

Главная страница: Выпуск проекта платы

Перед тем, как отправить проект на производство, его необходимо выпустить, а значение процесса выпуска зачастую недооценивается.

Altium NEXUS предлагает мощные интегрированные инструменты управления выпуском проектов, доступные через Project Releaser. Благодаря интуитивно понятному интерфейсу, вы можете сформировать все данные для производства одновременно – данные для изготовления, данные для сборки, исходные данные и т.д. Project Releaser также позволяет формировать данные для сборки одновременно множества вариантов проекта. Вам даже не нужно беспокоиться о создании файлов Output Job – средство выпуска сделает это при необходимости.

Средство Project Releaser позволяет управлять выпуском всех типов проектов платы: неуправляемые/не в системе контроля версий, под управляемой внешней системы VCS или управляемые сервером данных – и предлагает два режима работы:

  • Управляемый (онлайн) режим – выпуск всех сформированных данных в ревизии объектов на активный сервер управляемых данных. Нет необходимости запоминать ревизии объектов – средство выпуска контролирует их самостоятельно.
  • Неуправляемый (офлайн) режим – выпуск всех сформированных данных в структуру папок, которую опционально можно упаковать в единый zip-архив.

С помощью средства Project Releaser вы можете легко сформировать целостный набор данных для производства. Вы также сможете указать желаемые результаты этого процесса перед подтверждением выпуска (например, просмотрев данные Gerbers/ODB++ в редакторе CAM), чтобы убедиться, что сформированные данные – это именно те данные, которые необходимы для производства платы.

В этом документе рассматривается процесс выпуска на сервер управляемых данных. Если вы не используете сервер управляемых данных или не вошли на сервер, вы будете использовать средство выпуска Project Releaser в неуправляемом (офлайн) режиме, который рассматривается здесь.

Доступ к Project Releaser

Графическим интерфейсом средства Project Releaser является страница Release, доступ к которой осуществляется одним из следующих способов:

  • Выбор команды Project » Project Releaser из главного меню (исходный документ требуемого проекта должен быть открыт и активирован).
  • Щелчок правой кнопкой мыши по пункту требуемого проекта в панели Projects и выбор команды Project Releaser из контекстного меню.

Открытие страницы Release – интерфейса пользователя средства выпуска Project Releaser.

Режим выпуска/Цель

Средство выпуска Project Releaser пытается автоматически определить, какой режим выпуска использовать – управляемый (онлайн) или неуправляемый (офлайн) – и место выпуска данных. Если существует выбор, например, когда проект был выпущен на один сервер управляемых данных, а вы в данный момент подключены к другому, система предложит доступные опции.

При выпуске на сервер управляемых данных, в файле проекта в качестве атрибута сохраняется целевой сервер. Таким образом, целевой сервер, сохраненный с проектом, может отличаться от сервера, к которому вы в данный момент подключены.
Если у вас обычный проект (не управляемый и не под контролем VCS) и вы подключены только к Altium Content Vault, будет автоматически выбран офлайн-режим выпуска.

Обнаружение файлов Output Job

Если ваш проект не содержит связанных с ним файлов Output Job, средство выпуска Project Releaser обнаружит это и предложит создать файлы по умолчанию. Если вы согласитесь, будут созданы следующие файлы:

  • Fabrication.OutJob – с заданными выходными данными:
    • Documentation Outputs (Выходные документы): PCB Prints
    • Fabrication Outputs (Выходные данные для изготовления печатной платы): Gerber Files, NC Drill Files и IPC-2581
    • Validation Outputs (Выходные данные валидации): Design Rules Check, Footprint Comparison Report
    • Export Outputs (Выходные данные экспорта): Save As/Export PCB (в формате ASCII)
  • Assembly.OutJob – с заданными выходными данными:
    • Documentation Outputs (Выходные документы): PCB 3D Print, Schematic Prints
    • Assembly Outputs (Выходные данные для изготовления печатного узла): Generates pick and place files, Assembly Drawings
    • Report Outputs (Выходные отчеты): Bill of Materials
    • Export Outputs (Выходные данные экспорта): Export STEP

Эти файлы Output Job находятся в папке установки по умолчанию: \Users\Public\Documents\Altium\Nexus<Версия>\OutputJobs.

Вы можете использовать эти файлы по умолчанию как они есть, настроить их под собственные требования либо создать дополнительные файлы Output Job – создайте их в папке по умолчанию или в собственной папке. Если вы используете собственную папку, укажите ее расположение в поле OutputJob Path на странице System - Default Locations диалогового окна Preferences. Все файлы Output Job, заданные в этой папке, будут добавлены в проект.
Если в вашем проекте есть хотя бы один файл OutJob, автоматическое создание этого файла предлагаться не будет.

Обнаружение вариантов

Очень мощным аспектом средства Project Releaser является обнаружение заданных в проекте вариантов и формирование для каждого из них набора данных для сборки. У каждого такого набора будет имя целевого объекта по умолчанию в формате:

PCBA-[НазваниеПроекта]-[НазваниеВарианта]

Набор данных для базового проекта будет PCBA-[НазваниеПроекта]-[NO VARIATIONS].

Суффикс [НазваниеВарианта] обеспечивает использование правильного варианта для формирования набора данных по назначенному файлу OutJob.

Дополнительные наборы данных для сборки, сформированные на основе найденных вариантов исполнения проекта.

Настройка схем именования объектов сервера

При первом выпуске проекта на активный сервер управляемых данных вы можете задать именование целевых объектов данных на этом сервере. Это осуществляется на вкладке Item Naming диалогового окна Project Release Options, которое открывается нажатием кнопки  в левом нижнем углу страницы (или нажатием по ссылке Target Revision для выпускаемого набора данных и выбором Edit из контекстного меню). На этой вкладке вы можете:

  • Определить имя проекта. По умолчанию будет использоваться текущее имя проекта.
  • Определить целевую папку верхнего уровня (на сервере), в которую будут выпущены данные.
  • Определить схему именования по умолчанию для различных объектов данных, которые могут быть сформированы в процессе выпуска.
Объект проекта не является объектом, созданным для получения выпущенных данных – он является своего рода опорной точкой для представления общего вида выпущенных данных с точки зрения проекта, а также связи этих объектов при просмотре управляемого проекта в панели Explorer. Для получения более подробной информации см. Просмотр выпущенного управляемого проекта.

Чтобы изменить любую из схем именования, нажмите по кнопке Settings – будет открыто диалоговое окно Naming Template Settings.

Задайте целевую папку и именование формируемых объектов на сервере управляемых данных.

Поддерживаются следующие форматы шаблонов именования:

  • На основе параметров – использование параметров, заключенных в квадратные скобки (например [ProjectName], [VariantName], [ProjectParameter]).
  • На основе чисел – использование чисел, заключенных в фигурные скобки (например {0000}, {9000}).
На вкладке Item Naming диалогового окна Project Release вы можете нажать прямо в поле схемы именования и изменить его необходимым образом. Либо вы можете нажать кнопку в правой части поля, чтобы открыть диалоговое окно Choose Item (инкарнация панели Explorer), где вы можете указать существующий объект на активном сервере управляемых данных.
Именование объектов может быть в любой момент изменено на первом этапе страницы Release при настройке выпускаемых на сервер данных. После того, как данные для определенного набора сформированы и загружены на сервер, соответствующие имена нельзя изменить.

Процесс выпуска

После того, как именование объектов сервера было задано необходимым образом, вы можете начать выпуск. Это поэтапный процесс, пункты которого обозначены в левой части страницы Release, что позволяет быстро определить, на каком этапе вы в данный момент находитесь.

Онлайн-этап 1 – Configure Vault Release (Настройка выпуска в хранилище)

На этом этапе процесса выпуска вы задаете тип(ы) данных, которые хотите сформировать. Объекты данных, которые могут быть выпущены:

  • Source Data (Исходные данные) – слепок исходного проекта.
  • Fabrication Data (Данные изготовления печатной платы) – данные, необходимые производству для изготовления платы (без компонентов).
  • Assembly Data for the Base Design (no variations) (Данные базового проекта для изготовления печатного узла (без вариаций)) – данные, необходимые производству для монтажа компонентов на плату в соответствии с составом базового проекта, без вариаций.
  • Assembly Data for Design Variant n (Данные варианта n проекта для изготовления печатного узла) – данные, необходимые производству для монтажа компонентов на плату в соответствии со составом проекта в определенном варианте.

Число наборов данных для изготовления печатного узла соответствует базовому проекту (без вариаций) и всем обнаруженным вариантам этого проекта.

Кроме того, вы можете добавить и настроить разделы Custom Data для формирования пользовательских наборов выпускаемых данных. Это может быть необходимо для обратной совместимости или для собственных рабочих процессов. Ссылки не будут созданы, кроме ссылок на исходные данные. Для выпуска может быть сформировано и настроено любое количество пользовательских наборов данных (нажмите Add Section под списком заданных объектов данных).

Этап 1 процесса выпуска проекта – настройка данных, которые будут включены в выпуск (какие данные будут сформированы).

Объект Source Data (Исходные данные) всегда включен в выпуск. Остальные данные могут быть добавлены опционально.

Для данных производства и сборки, включенных в выпуск, необходим по крайней мере один назначенный им файл OutputJob. Если у вас есть файлы Output Job files, имена которых начинаются с подстрок 'fab' и 'ass', то эти файлы будут автоматически назначены разделам Fabrication Data и Assembly Data соответственно при первом открытии страницы Release. В противном случае вам необходимо назначить необходимые файлы OutJob вручную. Это можно сделать на вкладке Release Options диалогового окна Project Release Options (нажмите кнопку  в нижней левой части страницы, чтобы открыть его).

Назначьте файлы OutJob соответствующим наборам данных.

На вкладке Release Options диалогового окна Project Release Options вы также можете изменить назначение выпуска, переключаясь между управляемым (онлайн) и неуправляемым (офлайн) режимами. Доступны три варианта:

  • Unmanaged - Folder (Неуправляемый режим – Папка): сформированные данные будут выпущены в локальную папку. Путь к корневой папке указан на вкладке Output Path диалогового окна. По умолчанию он задан [OutputPath] (используется путь, заданный в поле Output Path на вкладке Options диалогового окна Project Options).
  • Unmanaged - Zip (Неуправляемый режим – Zip-архив): сформированные данные будут выпущены в локальную папку. Данные будут упакованы в единый zip-архив. Путь и название архива задается на вкладке Output Path диалогового окна. По умолчанию он задан [OutputPath][ProjectName].zip (используется путь, заданный в поле Output Path вкладки Options диалогового окна Project Options).
  • Managed - <ИмяСервера> (Управляемый режим – Сервер): сформированные данные будут выпущены на сервер управляемых данных, к которому вы в данный момент подключены.

Выберите режим выпуска – место, куда будут отправлены сформированные данные.

Нажмите по ссылке возле записи Target Revision на главной странице, чтобы открыть меню команд, показанных на рисунке и описанных ниже.

Открытие элементов управления для указания целевой ревизии набора данных, которые будут сформированы в процессе выпуска – наведите курсор мыши на изображение, чтобы увидеть.

  • Auto <RevisionID> – эта команда позволяет системе управлять ревизиями, поэтому вам не нужно создавать запланированные ревизии, которых на данный момент не существует. RevisionID показывает следующую ревизию для объекта на том же уровне в рамках назначенной системы именования ревизий (например, если текущей ревизией является A.1, то команда назначит целевую ревизию A.2).
  • Next <RevisionID> – эта запись позволяет увеличить целевую ревизию на следующий уровень в рамках назначенной схемы именования ревизий. RevisionID показывает следующую ревизию (например, если текущей ревизией является A.1, то команда назначит целевую ревизию B.1).
  • Custom – эта запись позволяет назначить специальную ревизию целевому объекту заданием пользовательского идентификатора ревизии в диалоговом окне Custom Revision ID.
  • Browse – эта запись позволяет указать существующий целевой объект и ревизию, в который следует произвести выпуск. Для этого будет открыто диалоговое окно Choose Target Item (инкарнация панели Explorer).
  • Edit – эта запись открывает вкладку Item Naming диалогового окна Project Release Options, из которого вы можете изменить имя целевого объекта (и его начальную ревизию), который будет создан.
  • Navigate – эта запись позволяет быстро перейти к объекту в панели Explorer (где он уже выпущен и существует следующая ревизия в запланированном состоянии).

Пункт наверху меню показывает текущую выбранную/заданную целевую ревизию.

Нажмите Details справа от заголовка набора данных, чтобы открыть подробную информацию о том, что именно будет сформировано для этого набора. Чтобы свернуть эту часть, нажмите Hide Details. Набор формируемых данных определяется одним или несколькими файлами Output Job (за исключением набора Source Data). Вы можете быстро открыть исходный файл OutJob, нажав Configure.

Откройте подробную информации о наборе формируемых данных. Наведите курсор на изображение, чтобы увидеть.

Существует ряд дополнительных настроек, относящихся к процессу выпуска, которые задаются на странице Data Management - Servers диалогового окна Preferences:

  • Папку, используемую для временного хранения сформированных файлов перед их загрузкой на активный сервер управляемых данных, можно использовать по умолчанию (\Users\<ИмяПользователя>\AppData\Local\Temp) или задать вручную.
  • Включите параметр Delete contents after exiting release mode, чтобы очищать папку временного хранения по окончании процесса выпуска.
  • Название каждого формируемого выходного документа можно предварительно задать с использованием идентификаторов объекта и ревизии (например, [FAB-Bluetooth_Sentinel-A.1] Validation.PDF). Для этого включите параметр Prepend revision HRID to file names.

Дополнительные настройки, относящиеся к процессу выпуска проектов.

После того, как объекты данных, которые будут сформированы в процессе выпуска, настроены необходимым образом, нажмите кнопку  в правой нижней части страницы, чтобы начать процесс.

У кнопки есть два состояния. Нажмите на нее, чтобы выполнить стандартную команду Prepare – вы перейдете на этап Review Data, где вы сможете снова проверить, что все в порядке, до подтверждения выпуска данных. Если вы не хотите останавливаться на проверку, используйте выпадающее меню кнопки и выберите команду Prepare & Release.

Перед выпуском производится несколько проверок в рамках подготовки, в том числе:

  • Проверка того, что проект и все файлы были сохранены.
  • Проверка того, что проект и все файлы зафиксированы в VCS, если применимо.
  • Проверка того, что каждому объекту задано имя.
  • Проверка того, что у пользователя есть права на создание целевого объекта (и ревизии).
  • Создание требуемых целевых объектов (и запланированных ревизий) на сервере управляемых данных, где они в данных момент не существуют, а также проверка того, что для объектов используется следующая ревизия, если они существуют.

При обнаружении какой-либо проблемы будет предложено ее решение (например, сохранение локально измененных файлов и их фиксация в VCS).

В этот момент создается объект исходных данных, со слепком исходных файлов проекта, выпускаемых в ревизию целевого объекта.

Онлайн-этап 2 – Validate Project (Валидация проекта)

После завершения этапа 1 без ошибок вы автоматически перейдете на следующий этап, если в назначенных файлах OutJob будет обнаружен один или несколько отчетов для валидации. Будут запущены все заданные генераторы выходных файлов валидации, которые определены в файле Output Job, назначенном объекту выпускаемых данных. Они могут включать в себя:

  • Differences Report (Отчет о различиях) – использование компаратора для определения того, что документы схемы и платы корректно синхронизированы.
  • Electrical Rules Check (Проверка электрических правил) – проверка корректности схемы с точки зрения размещения электрических и графических объектов.
  • Design Rules Check (Проверка правил проектирования) – проверка корректности документа платы с точки зрения ограничений, заданных на уровне платы.
  • Footprint Comparison Report (Отчет о сравнении посадочных мест) – сравнение посадочных мест на плате и в исходных библиотеках для проверки их актуальности и соответствия.
  • Component State Checking (Проверка состояния компонентов) – проверка того, что компоненты находятся в разрешенных состояниях. В ходе настройки вы можете задать предпринимаемое действие для каждого заданного в данный момент состояния каждой определенной на сервере стадии жизненного цикла: не предпринимать действие, выдать предупреждение или выдать ошибку. Последний вариант не допустит дальнейший процесс выпуска. Кроме того, при проверке будет создан HTML-отчет, позволяющий быстро увидеть, какие компоненты имеют недопустимое состояние.
  • Environment Configuration Compliance Check (Проверка соответствия настройки среды) – проверка того, что используются только объекты, разрешенные настройкой среды, доступной для использования назначенной вам ролью (если применимо). Также проверяется, что источником всех объектов является сервер управляемых данных.

Если проверка проходит успешно, будут показаны иконка  и текст Passed. В противном случае, будут показаны иконка  и текст Failed.

Выпуск не будет завершен, если какая-либо из проверок не будет пройдена.
Нажмите  в правой нижней части страницы, чтобы остановить процесс выпуска.

Онлайн-этап 3 – Generate Data (Формирование данных)

После завершения этапа 2 без ошибок будет автоматически запущен этот следующий этап. Здесь будет запущено формирование всех прочих выходных документов, определенных в назначенных объектам файлах OutJob, для выпуска соответствующих объектов на сервер.

Для обозначения процесса формирования используются следующие иконки:

– не запущено/не сфомировано.

– запущено/формируется.

– сформировано успешно.

– формирование не удалось.

Нажмите  в правой нижней части страницы, чтобы остановить процесс выпуска.

Онлайн-этап 4 – Review Data (Просмотр данных)

После того, как все проверки пройдены и выходные данные сформированы, вы можете просмотреть на этом этапе сформированные документы.

Если вы использовали команду Prepare & Release (из меню кнопки ), средство Project Releaser не будет останавливаться на этапе Review Data.

Просмотр сформированных данных перед подтверждением их выпуска и фиксацией на сервере управляемых данных, чтобы убедиться, что всё в порядке.

По умолчанию на странице показан простой (компактный) вид сформированных данных. Чтобы просмотреть более подробную информацию, нажмите Details у необходимого раздела.

Нажмите Details, чтобы переключить простой вид отображения сформированных данных на подробный. Чтобы переключиться обратно, нажмите Hide Details.

В таблице ниже приведены возможные состояния выходных документов в режиме просмотра подробных данных:

Состояние

Описание

Выходной документ еще не был сформирован/не существует.

Выходной документ сфомирован, но был изменен в проекте, что делает его состояние проверки неактуальным.

Выходной документ находится в процессе формирования.

Документ является выходным документом валидации, и в процессе его формирования не возникло ошибок. Для отчета проверки электрических правил, ошибок не возникло, либо уровень ошибок попадает в указанный предельно допустимый уровень для этого отчета.

Выходной документ (за исключением выходных документов валидации) сфомирован успешно.

Выходной документ не был сфомирован успешно. Для выходных документов валидации это означает, что существуют ошибки в исходных проектных документах. Для обычного выходного документа это значит, что он не может быть сфомирован. Возможно, существуют критические ошибки при компиляции, либо что-то не так с настройкой генератора в файле Output Job.

В компактном виде отображения сформированных данных нажмите ссылку View, чтобы открыть связанный файл или набор файлов в соответствующем редакторе Altium NEXUS (например, редакторе CAM) или внешнем приложении (например, Microsoft Excel). В подробном виде дважды щелкните по пункту, чтобы открыть только этот файл.

В компактном режиме отображения раздела Source Data нажмите ссылку View, чтобы открыть в Проводнике Windows временную папку хранения слепка исходных файлов проекта. То же самое происходит при нажатии по ссылке Explore справа от заголовка раздела. У каждого раздела есть такая ссылка для быстрого перехода в главную папку данных во временной директории.
В подробном режиме отображения, команды контекстного меню позволяют открыть документ и открыть временную папку, в которой он был сфомирован. Вы также можете добавить столбцы данных о расположении папки и дате создания – щелкните правой кнопкой мыши по строке заголовка таблицы и выберите команду Select Columns – будет открыто диалоговое окно, в котором вы можете настроить отображение данных.

Если в ходе просмотра вы обнаружили, что необходимо внести изменения в данные, нажмите кнопку  в правой нижней части страницы. Появится диалоговое окно для подтверждения, предупреждающее о том, что все сформированные данные будут потеряны – нажмите OK, чтобы отменить выпуск и вернуться на этап 1.

Система не позволяет вносить изменения в проектные файлы между подготовкой выпуска и выпуском данных на сервер управляемых данных. Если вы всё же внесете изменения, процесс выпуска будет прерван, и вы вернетесь на начальный этап, предшествующий подготовке выпуска.

Если с сформированными данными всё в порядке, нажмите кнопку  (в правой нижней части страницы). Появится диалоговое окно Confirm Release со сводкой конфигурации проекта, который будет выпущен на сервер управляемых данных. Здесь у вас есть возможность добавить имя Name (по умолчанию [ProjectName]), описание Description, а также подходящую информацию о выпуске.

Подтверждение выпуска, касательно созданных объектов и ревизий, с возможностью изменить имя/описание и добавить информацию о выпуске.

Онлайн-этап 5 – Upload Data (Загрузка данных)

После подтверждения выпуска на предыдущем шаге, следующий этап будет запущен автоматически. Здесь представлен прогресс загрузки данных в ревизии соответствующих объектов на сервере управляемых данных.

На этом этапе показан прогресс загрузки сформированных данных в связанные объект-ревизии на сервер управляемых данных.

Онлайн-этап 6 – Execution Report (Отчет о выполнении)

На этом финальном этапе предоставляется отчет о результатах выпуска.

Финальный отчет о выпуске

Используйте ссылки в разделе Navigation Links для быстрого доступа к связанным ревизиям объектов, содержащим выпущенные данные (данные для изготовления печатной платы, данные для изготовления печатного узла, пользовательские наборы данных), в панели Explorer, который является порталом в сервер управляемых данных.

Просмотр выпущенных данных проекта на сервере управляемых данных в панели Explorer.

Если ваш проект является управляемым проектом, то по окончании процесса выпуска вам доступна еще одна функциональная возможность. Нажмите по ссылке Project Page (последняя в разделе Navigation Links страницы Execution Report), чтобы открыть панель Explorer, где будет представлен проект в виде Project View, доступном только для управляемых проектов.

Если ранее вы просматривали проект в виде Classic View, необходимо вручную переключиться на вид Project View с помощью команды доступной из меню кнопки .

Вы можете получить подробную информацию об управляемом проекте в режиме Project View панели Explorer.

Этот вид аналогичен подробному отображению управляемого проекта на странице Projects веб-интерфейса сервера. На виде доступны следующие вкладки:

  • Stream (Поток) – подробности о недавней активности с проектом.
  • Parameters (Параметры) – список параметров, заданных на уровне проекта, либо в Altium Designer (на вкладке Parameters диалогового окна Project Options), либо через сервер (не доступно на данный момент).
  • Releases (Выпуски) - отображает каждый выпуск проекта. Самый новый выпуск отображен вверху списка. Записи слева показывают отметку о дате/времени выпуска, а также включенные в выпуск пакеты. Используйте поле Search для быстрого поиска определенного выпуска (очень полезно, если проект был выпущен множество раз). Если щелкнуть мышью по записи выпуска слева, подвкладки справа будут заполнены следующей информацией об этом выпуске:
    • Details (Подробности) – графическое представление того, как сформированные данные связаны друг с другом, в рамках родительского проекта. Нажмите по ссылке, чтобы открыть этот объект-ревизию сервера NEXUS Server на странице Explorer веб-интерфейса. Также представлены дата и время выпуска, кем был произведен выпуск и ревизия VCS.
    • Parameters (Параметры) – список параметров, заданных на уровне проекта, либо в Altium Designer (на вкладке Parameters диалогового окна Project Options), либо через сервер (не доступно на данный момент), а также системно созданные параметры, специфичные для данного выпуска.
    • Preview (Предварительный просмотр) – интерактивный предварительный просмотр выпущенных исходных данных. Масштабируйте, изучайте, используйте двойной щелчок мышью по записи в главном окне предварительного просмотр для навигации по выпущенным исходным данным.
    • Part List (Список компонентов) – простой список всех управляемых компонентов в выпущенном проекте, со следующей информацией:
      • Название
      • ID объекта
      • Описание
      • Позиционное обозначение
      • Количество
      • Статус ревизии

Обратите внимание, что список показывает все компоненты, используемые в выпущенном проекте, независимо от сформированных пакетов вариантов сборки. Иными словами, список не отфильтрован по вариантам.

  • Working Files (Рабочие файлы) – исходные файлы проекта, которые можно загрузить в единый zip-архив.

После того, как проект выпущен, закройте страницу Release с помощью кнопки  внизу справа. Когда понадобится выполнить повторный выпуск проекта в будущем, Project Releaser позволит сделать это легко и быстро, и он автоматически увеличит целевую ревизию объекта.

Неуправляемый (офлайн) режим выпуска

Наряду с управляемым (онлайн) режимом выпуска, Project Releaser также позволяет осуществлять локальный, неуправляемый (офлайн) выпуск. Обычно этот режим используется, если у вас нет сервера управляемых данных либо если вы в данный момент не можете подключиться к серверу. Хотя Project Releaser определяет режим автоматически, где это возможно, либо предлагает выбор, когда нет однозначности, вы всегда можете задать использование офлайн-режима настройкой Release Target на вкладке Release Options диалогового окна Project Release Options (нажмите кнопку  на этапе 1 процесса выпуска), выбрав один из следующих вариантов:

  • Unmanaged - Folder (Неуправляемый режим – Папка): сформированные данные будут выпущены в локальную папку. Путь к корневой папке указан на вкладке Output Path диалогового окна. По умолчанию он задан [OutputPath] (используется путь, заданный в поле Output Path на вкладке Options диалогового окна Project Options).
  • Unmanaged - Zip (Неуправляемый режим – Zip-архив): сформированные данные будут выпущены в локальную папку. Данные будут упакованы в единый zip-архив. Путь и название архива задается на вкладке Output Path диалогового окна. По умолчанию он задан [OutputPath][ProjectName].zip (используется путь, заданный в поле Output Path вкладки Options диалогового окна Project Options).
Вы можете использовать записи [ProjectName], [<VariantParameterName>], [<ProjectParameterName>] при определении выходного пути.

Вы можете быстро определить, что Project Releaser настроен на офлайн-режим, следующим образом:

  • В заголовке этапа 1 написано Configure Local Release вместо Configure Vault Release (как при онлайн-режиме).
  • В заголовке этапа 5 написано Pack Data вместо Upload Data (как при онлайн-режиме).

Средство выпуска Project Releaser в локальном, неуправляемом (офлайн) режиме.

Процесс выпуска схож с описанным выше для управляемого (онлайн) режима, только данные выпускаются в локальную папку. Чтобы не повторять информацию, указанную выше, здесь обозначим только задействованные этапы с указанием различий.

Офлайн-этап 1 – Configure Local Release (Настройка локального выпуска)

Здесь вы настраиваете, какие данные необходимо сформировать из проекта. Исходные данные всегда включаются в выпуск, с возможностью добавить данные для изготовления печатной платы, изготовления печатного узла (для базового проекта и/или вариантов) и любые другие пользовательские данные, которые необходимы.

Для каждого формируемого набора данных необходимо указать папку, в которую они будут сохранены. Названия папок, используемые по умолчанию:

  • Source Data (Исходные данные) – будут сформированы в папке Sources.
  • Fabrication Data (Данные изготовления печатной платы) – будут сформированы в папке Fabrication.
  • Assembly Data for no variant (Данные для изготовления печатного узла без вариаций) – будут сформированы в папке Assembly.
  • Assembly Data for <VariantName> (Данные варианта n проекта для изготовления печатного узла) – будут сформированы в папке Assembly <VariantName>.
  • Custom Data <Custom - n> (Пользовательские данные) – будут сформированы в папке <Custom - n>.

Вы можете изменить это именование по умолчанию необходимым образом. Для этого щелкните мышью по записи Target Folder, введите новое имя папки и нажмите Enter.

При выпуске в локальную папку или zip-архив имейте в виду, что повторный выпуск в папки с теми же именами перезапишет существующие в этих папках данные.

После настройки данных, которые будут сформированы в процессе выпуска, нажмите кнопку  в правой нижней части страницы.

У кнопки есть два состояния, которые отличаются для двух возможных вариантов неуправляемого выпуска:
  • Unmanaged - Folder (Неуправляемый режим – Папка): нажмите эту кнопку, чтобы запустить стандартную команду Prepare. Процесс перейдет на этап Review Data, что позволит повторно проверить, что всё в порядке, перед выпуском в целевые папки. Если вы не хотите останавливаться на проверку, откройте выпадающее меню кнопки и выберите команду Prepare & Explore.
  • Unmanaged - Zip (Неуправляемый режим – Zip-архив): нажмите эту кнопку, чтобы запустить стандартную команду Prepare. Процесс перейдет на этап Review Data, что позволит повторно проверить, что всё в порядке, перед упаковкой данных в zip-архив. Если вы не хотите останавливаться на проверку, откройте выпадающее меню кнопки и выберите команду Prepare & Pack.

Будет произведено несколько предварительных проверок, в том числе:

  • Проверка того, что проект и все файлы были сохранены.
  • Проверка того, что проект и все файлы зафиксированы в VCS, если применимо.
  • Проверка того, что каждому объекту данных задана целевая папка.

При обнаружении какой-либо проблемы будет предложено ее решение (например, сохранение локально измененных файлов и их фиксация в VCS).

На этом этапе формируются исходные данные, со слепком исходных файлов проекта, выпускаемых в целевую папку.

Офлайн-этап 2 – Validate Project (Валидация проекта)

После завершения этапа 1 без ошибок вы автоматически перейдете на следующий этап, если в назначенных файлах OutJob будет обнаружен один или несколько отчетов для валидации. Будут запущены все заданные генераторы выходных файлов валидации, которые определены в файле Output Job, назначенном объекту выпускаемых данных. Этот этап проходит аналогично этапу в управляемом (онлайн) режиме.

Выпуск не будет завершен, если какая-либо из проверок не будет пройдена.
Нажмите  в правой нижней части страницы, чтобы остановить процесс выпуска.

Офлайн-этап 3 – Generate Data (Формирование данных)

После завершения этапа 2 без ошибок будет автоматически запущен этот следующий этап. Здесь будет запущено формирование всех прочих выходных документов, определенных в назначенных объектам файлах OutJob, для выпуска объектов в соответствующие целевые папки. Этот этап проходит аналогично этапу в управляемом (онлайн) режиме.

Нажмите  в правой нижней части страницы, чтобы остановить процесс выпуска.

Офлайн-этап 4 – Review Data (Просмотр данных)

После того, как все проверки пройдены и выходные данные сформированы, вы можете просмотреть на этом этапе сформированные документы. Этот этап проходит во многом аналогично этапу в управляемом (онлайн) режиме.

Если вы использовали команду Prepare & Explore (для варианта Unmanaged - Folder) или Prepare & Pack (для варианта Unmanaged - Zip), то этот этап будет недоступен – данные сразу будут выпущены, т.е. соответственно выпущены целевые в папки или упакованы в целевой архив.

Просмотр сформированных данных перед подтверждением их выпуска и передачей в целевые папки или упаковкой в zip-архив, в соответствии с выбранным вариантом неуправляемого режима.

В компактном виде отображения сформированных данных нажмите ссылку View, чтобы открыть связанный файл или набор файлов в соответствующем редакторе Altium NEXUS (например, редакторе CAM) или внешнем приложении (например, Microsoft Excel). В подробном виде дважды щелкните по пункту, чтобы открыть только этот файл.

Если в ходе просмотра вы обнаружили, что необходимо внести изменения в данные, нажмите кнопку  в правой нижней части страницы. Появится диалоговое окно для подтверждения, предупреждающее о том, что все сформированные данные будут потеряны – нажмите OK, чтобы отменить выпуск и вернуться на этап 1.

Система не позволяет вносить изменения в проектные файлы между подготовкой выпуска и выпуском данных в целевые папки. Если вы всё же внесете изменения, процесс выпуска будет прерван, и вы вернетесь на начальный этап, предшествующий подготовке выпуска.

Если с сформированными данными всё в порядке, нажмите кнопку  (в правой нижней части страницы). Что произойдет дальше, зависит от выюранного варианта выпуска:

  • Unmanaged - Folder: сформированные файлы будут выпущены в целевые папки, и процесс перейдет на завершающий этап – Execution Report.
  • Unmanaged - Zip: процесс перейдет на следующий этап – Pack Data.

Офлайн-этап 5 – Pack Data (Упаковка данных)

После подтверждения выпуска на предыдущем этапе, вы автоматически перейдете на этот этап, и данные будут упакованы в единый локальный zip-архив. Путь и название архива задается на вкладке Output Path диалогового окна Project Release Options. По умолчанию он задан [OutputPath][ProjectName].zip (используется путь, заданный в поле Output Path вкладки Options диалогового окна Project Options).

Этот этап применим только в случае использования варианта выпуска Unmanaged - Zip.

Офлайн-этап 6 – Execution Report (Отчет о выполнении)

На этом финальном этапе предоставляется отчет о выпуске.

Финальный отчет о выпуске при использовании варианта выпуска Unmanaged - Folder. Наведите курсор мыши на изображение, чтобы увидеть отчет при использовании варианта Unmanaged - Zip.

С помощью ссылки Navigation Link вы можете быстро перейти к выходной папке или к архиву в Проводнике Windows.

Быстрый переход к локальной папке, непосредственно из этапа Execution Report. Наведите курсор мыши на изображение, чтобы увидеть пример отображения локально выпущенного zip-архива.

Обнаружили проблему в этом документе? Выделите область и нажмите Ctrl+Enter, чтобы оповестить нас.

Связаться с нами

Связаться с нашими Представительствами напрямую

Вы сообщаете о проблеме, связанной со следующим выделенным текстом
и/или изображением в активном документе:
Бесплатная пробная версия Altium Designer
Бесплатная пробная версия Altium Designer
Давайте приступим. Для начала, Вы или Ваше предприятие уже используете Altium Designer?

Если Вы хотите поговорить с представителем, пожалуйста, свяжитесь с местным офисом Altium.
Copyright © 2019 Altium Limited

В таком случае, для чего Вам необходима пробная лицензия?

Если Вы хотите поговорить с представителем, пожалуйста, свяжитесь с местным офисом Altium.
Copyright © 2019 Altium Limited

Вам для этого не нужна пробная лицензия.

Нажмите кнопку ниже, чтобы загрузить установщик самой новой версии Altium Designer

Загрузить установщик Altium Designer

Если Вы хотите поговорить с представителем, пожалуйста, свяжитесь с местным офисом Altium.
Copyright © 2019 Altium Limited

Пожалуйста, заполните форму ниже, чтобы получить ценовое предложение.

Нажимая [Получить бесплатнную пробную версию], Вы соглашаетесь с нашей Политикой конфиденциальности. Вам могут приходить сообщения от компании Altium, и Вы можете изменить настройки уведомлений в любой момент.

Если Ваша подписка Altium активна, у Вас нет необходимости в пробной лицензии.

Если у Вас нет активной подписки Altium, пожалуйста, заполните форму ниже, чтобы получить пробную версию.

Нажимая [Получить бесплатнную пробную версию], Вы соглашаетесь с нашей Политикой конфиденциальности. Вам могут приходить сообщения от компании Altium, и Вы можете изменить настройки уведомлений в любой момент.

Для чего Вы хотите попробовать Altium Designer?

Если Вы хотите поговорить с представителем, пожалуйста, свяжитесь с местным офисом Altium.
Copyright © 2019 Altium Limited

Вы нашли нужное место! Пожалуйста, заполните форму ниже, чтобы начать использование пробной версии.

Нажимая [Получить бесплатнную пробную версию], Вы соглашаетесь с нашей Политикой конфиденциальности. Вам могут приходить сообщения от компании Altium, и Вы можете изменить настройки уведомлений в любой момент.

Great News!

Valid students can get their very own 6-month Altium Designer Student License for FREE! Just fill out the form below to request your Student License today.

Нажимая [Получить бесплатнную пробную версию], Вы соглашаетесь с нашей Политикой конфиденциальности. Вам могут приходить сообщения от компании Altium, и Вы можете изменить настройки уведомлений в любой момент.

Вы можете загрузить бесплатную лицензию средства просмотра Altium Designer Viewer сроком действия 6 месяцев.

Пожалуйста, заполните форму ниже, чтобы запросить эту лицензию.

Нажимая [Получить бесплатнную пробную версию], Вы соглашаетесь с нашей Политикой конфиденциальности. Вам могут приходить сообщения от компании Altium, и Вы можете изменить настройки уведомлений в любой момент.

Замечательно! Создавать новое - отличное занятие. У нас есть превосходная программа для Вас.

Upverter - бесплатная платформа, разработанная специально для любителей проектирования.

Нажмите здесь, чтобы попробовать!

Если Вы хотите поговорить с представителем, пожалуйста, свяжитесь с местным офисом Altium.
Copyright © 2019 Altium Limited

Вы можете загрузить бесплатную лицензию средства просмотра Altium Designer Viewer сроком действия 6 месяцев.

Пожалуйста, заполните форму ниже, чтобы запросить эту лицензию.

Нажимая [Получить бесплатнную пробную версию], Вы соглашаетесь с нашей Политикой конфиденциальности. Вам могут приходить сообщения от компании Altium, и Вы можете изменить настройки уведомлений в любой момент.