Updating schematic component footprints from the PCB Document.

Created: 25.03.2021 | Updated: 01.12.2021

For designs where the footprints in the PCB do not match the footprint configured in the schematic component, this will show you how to get them in sync.

Starting in Version: 18.0
Up to Version: Current

Solution Details

There are a few ways to update the schematic components.
It is always a best practice to make changes in your schematic libraries and then update your schematics.

NOTE: If you are using components from a Managed content server, these are locked and the footprint is not able to be changed directly.

Updating from Libraries:
Schematic components can be updated directly from configured libraries as follows.
From an open schematic document, select Tools Update from Libraries.

Note: There is an option from a schematic library  Tools Update Schematics, but this does a full replacement of the selected part to all open schematic documents. For more control, use the Update from Libraries option from within your schematic.

Properties Panel:
Footprints can be added to schematic components using the Properties Panel.
Selecting the schematic component, under the Parameters section, click the Add button and select Footprint.

Updating From the PCB:
If a footprint is changed in the PCB document, associated schematic components can have their footprint reference updated by running the command from the PCB document, Design ► Update Schematics. This will update the configured footprint in an existing schematic component. This command will not add a new schematic component. 

Using the Footprint Manager:
If the schematic libraries do not have the configured footprint, or you need to set something on the fly, footprints can be managed using the Footprint Manager. You can access the Footprint Manager from an open schematic and selecting Tools ► Footprint Manager.

  • To add a footprint
    • Select the component in the Component List and click the Add... button.
  • To copy a footprint to a component from  a similar component
    • In the Footprint Manager, select two components in the left pane, one of which has the footprint you wish to add to the other selected footprints. 
    • Right-click on the footprint in the upper right pane and select Add to all parts.

A special case is when there is no footprint associated with the schematic component, which may happen with imported designs. In order for the update from the PCB, the process will only work if there is a configured footprint in the associated schematic symbol. 

In such cases, a temporary footprint can be added from another part if needed as mentioned above. If there was originally no footprint attached to a component, any footprint can be temporarily added (referred to below in the image as a "temporary"), and then updating from the PCB will change the configured footprint to the correct one. The steps below describe the process:

  • Open a Schematic Document in your project.
  • Place a component that has a footprint, or use an existing component in the design if one already exists.
  • In the Footprint Manager, we will first add a temporary footprint, then we will be able to update to the correct footprint from the PCB to get the correct footprint:
    • Select Tools ► Footprint Manager
    • Sort the listed components by the Current column by clicking on the header.
    • Select all the components that have a blank value for Current. This can be done by clicking the first column, then shift-clicking the last (or just control-click to multi-select).
    • Careful not to lose your initial selection, control-click on one additional component that has a footprint to add it to the selection. This will be the temporary footprint we will add to the other parts.
    • On the right side of the dialog, right-click on the footprint to add in the upper right View and Edit Footprints pane, then select Add to all parts, see the image below.
      • If there is more than one footprint configured for a component, right-click on the footprint you wish to use and select Set as Current.
    • Click Accept Changes (Create ECO) and click execute the ECO...

Updating from the PCB document:
  • Now that the components all have a configured footprint, the next step is to open the PcbDoc file.
  • It is a good idea to validate Component Links per the steps below:
    • In the PCB document, select Project ► Component Links
    • Ensure that all the footprints are matched. If not, click the Add Pairs Matched by button, ensuring the Designator field is checked. Then click the Perform Update button.
    • Update the schematics by selecting Design ► Update Schematics and clicking Execute Changes. Once executed, the footprint references in the schematic will match those in the PCB. 
Generating a new library from the updated parts on the schematic:
  • To generate a new schematic library, select Design ► Make Schematic Library. This will include the modified parts with the footprints configured matching the schematic.

NOTE: Verifying Pin to Pad mapping. At this point, the Schematic to Footprint Pads should be verified, as there is automatically assumed that the referenced footprint Pad will match the schematic designator value. When Editing the schematic component’s PCB footprint, click the Pin Map… button. The Footprint Pin Designator (Pad) will need to be manually checked in the PcbLib or in the Pcb Document, as the Pin Map does not reflect the true value.

Was this article helpful?
0
0
Обнаружили проблему в этом документе? Выделите область и нажмите Ctrl+Enter, чтобы оповестить нас.

Связаться с нами

Связаться с нашими Представительствами напрямую

We're sorry to hear the article wasn't helpful to you.
Could you take a moment to tell us why?
200 characters remaining
Вы сообщаете о проблеме, связанной со следующим выделенным текстом
и/или изображением в активном документе: