База знаний: линии сетки не отображаются в редакторе печатных плат

Altium Designer Altium Designer
Если линии или точки сетки не видны в редакторе печатных плат, это может быть связано с настройками назначения сетки, ее глобальной видимости, параметрами отображения или цветом. Видимость сетки определяется ее параметрами Comp и Non Comp, глобальной опцией Show Grid, а также настройками отображения Fine и Coarse. В некоторых случаях привязка объектов к сетке продолжает действовать, даже если сама сетка не отображается. В этой статье объясняется, как проверить настройки сетки, восстановить ее видимость и изменить параметры отображения, чтобы сетка была видна в рабочей области редактора печатных плат.

Подробное описание решения

Линии сетки не видны

Сетка в редакторе печатных плат не отображается, хотя она настроена и документ печатной платы открыт. Ожидаемые линии или точки сетки могут отсутствовать при обычном редактировании, при перемещении компонентов или в обоих случаях. При этом объекты могут по-прежнему привязываться к сетке, даже если сама сетка не отображается.

Отображением сетки управляют несколько настроек

Видимость сетки зависит от нескольких настроек. Сетка может быть скрыта в зависимости от настроек Comp и Non Comp, глобального параметра Show Grid или индивидуальных настроек отображения. Если параметры Comp и Non Comp отключены, сетка не видна, но привязка к ней может по-прежнему действовать в соответствии с текущими настройками привязки. Сетка также не отображается, если для обоих параметров отображения Fine и Coarse выбрано значение Do Not Draw. Недостаточный контраст цветов сетки может затруднять её восприятие, даже если она отображается.

Проверьте настройки видимости и отображения

  • Убедитесь, что для нужной сетки включён параметр Non Comp, если сетка должна быть видна при обычном редактировании.
  • Если сетка должна быть видна при перемещении компонентов, убедитесь, что для неё включён параметр Comp.
  • Убедитесь, что глобальный параметр Show Grid включён.
  • Задайте хотя бы для одного из параметров отображения Fine или Coarse значение Lines или Dots, а не Do Not Draw.
  • Убедитесь, что настроенные цвета сетки хорошо различимы на фоне рабочей области.
  • Если сетка отображается, но плохо различима, переключите стиль её отображения с линий на точки или наоборот.

Проверьте настройки сетки

  1. Откройте документ печатной платы.
  2. При необходимости снимите текущее выделение с помощью Shift+C.
  3. Откройте панель Properties.
  4. Убедитесь, что панель находится в режиме Board .
  5. Выберите вкладку General и найдите раздел Grid Manager.
  6. Найдите нужную сетку. Сетка по умолчанию называется Global Board Snap Grid.
  7. Убедитесь, что параметр Non Comp включён, если сетка должна быть видна при обычном редактировании.
    Properties panel, Grid Manager section showing Global Board Snap Grid with Comp and Non Comp options enabled.
  8. Откройте панель View Configuration. Нажмите Ctrl+D, чтобы открыть панель на вкладке View Options, или L, чтобы открыть её на вкладке Layers & Colors.
  9. Выберите вкладку View Options.
  10. В разделе General Settings убедитесь, что параметр Show Grid включён.
    View Configuration panel, View Options tab, showing General Settings with Show Grid enabled.
  11. Если сетка по-прежнему не отображается, вернитесь к Properties » Board » General » Grid Manager.
  12. Дважды щёлкните нужную сетку или нажмите Ctrl+G, когда курсор находится над областью сетки в редакторе печатных плат.
  13. В диалоговом окне редактора сетки проверьте настройки Display.
  14. Убедитесь, что для параметров отображения Fine и Coarse не выбрано значение Do Not Draw.
  15. При необходимости проверьте настройки цветов сетки с помощью доступных элементов управления цветом.
    Cartesian Grid Editor dialog showing Global Board Snap Grid display settings, with Fine and Coarse grid styles set to Lines and Multiplier set to 10x Grid Step.
  16. Если проблема возникает только при перемещении компонентов, убедитесь в Properties » Board » General » Grid Manager, что для нужной сетки включён параметр Comp. 

Дополнительные примечания

Сетка по умолчанию Global Board Snap Grid существует всегда и действует во всём пространстве проектирования, хотя отображается только в пределах контура платы. Эту сетку можно изменять, но нельзя переименовать, удалить или отключить. Её приоритет всегда остаётся самым низким.

Справочные материалы

AI-LocalizedЛокализовано с помощью ИИ
Если вы обнаружили проблему, выделите текст/изображение и нажмитеCtrl + Enter, чтобы отправить нам свой отзыв.