Version not supported despite valid subscription - Refresh PLS license

Created: 27.03.2021 | Updated: 12.08.2021

We updated Altium Designer to a newer version, but now the client says our licenses do not support it. Our subscription for our private server license is current and the future date is displayed on the license management page subscription status column.

Starting in Version: 18.0
Up to Version: Current

Solution Details



To "Refresh" or update a license on your PLS:
You must first delete the expired one, then click the "Activate" button at the bottom left. You will then be prompted to log in with your AltiumLive account. At the next screen, find the license and click the Activate button.
 
If your PLS is not connected to the internet, use the "Add Licenses" button after you have the *.alf file downloaded from AltiumLive Dashboard. This video covers how to get your license (*.alf) file(s):
https://youtu.be/5_NQg-Sf1eE?t=310
 
It may be necessary to use the refresh option while the license is highlighted in the license management page of Altium Designer to see the new expiration date.  Here is our Legacy Private License Server (PLS) documentation if you are interested in more detail: 
https://techdocs.altium.com/display/ADOH/Using+a+Private+Server+License#UsingaPrivateServerLicense 
 
If you are still having issues. There may be an *.alf file somewhere on the server that is old, and it's getting confused. But first, at your client, try this:
1. In Altium Designer release any licenses 
2. Close Altium Designer 
3. browse to C:\ProgramData\Altium\ (may have to view hidden files to see the ProgramData folder)
4. Delete *_Security folder(s)
5. Restart Altium Designer
 
If that didn't help, delete the current licenses, then search the server's hard drive for *.alf, and delete them all, then activate the current licenses. If that doesn't help, uninstall the PLS and re-install it.  You can download the installer from here:
https://www.altium.com/documentation/other_installers#miscellaneous
 
You could also install our current version of license server Altium Infrastructure Server (AIS) which you can get from our downloads page:
https://www.altium.com/products/downloads
 
Altium Infrastructure Server (AIS) documentation (uses port 9780):
https://www.altium.com/documentation/altium-designer/altium-infrastructure-server-ad
Notice in the left column, you can click on links to sub-pages for System Requirements & Installation
(Don't install on a machine that is running SQL)
 
Was this article helpful?
0
0
Обнаружили проблему в этом документе? Выделите область и нажмите Ctrl+Enter, чтобы оповестить нас.

Связаться с нами

Связаться с нашими Представительствами напрямую

We're sorry to hear the article wasn't helpful to you.
Could you take a moment to tell us why?
200 characters remaining
Вы сообщаете о проблеме, связанной со следующим выделенным текстом
и/или изображением в активном документе: