You must have Microsoft(R) Excel installed on your machine

Created: 25.03.2021 | Updated: 12.08.2021

I can no longer generate any outputs that require MS-Excel since there seems to be an issue with Altium's ability to open the program. MS-Excel is working just fine for me and no other applications I use have issue with it, but I get this error, "You must have Microsoft® Excel installed on your machine to be able to generate a Board Stack Report."

Starting in Version: 18.0
Up to Version: Current

Solution Details

If you see this error:


It could be that your Office needs to be repaired. 

When computers get confused about whether some part of an office program is installed or not, performing a repair usually resolves this issue.  Different methods are required based on the version you are using.   Here is a link to a Microsoft Office support article that should help:
https://support.microsoft.com/en-us/office/repair-an-office-application-7821d4b6-7c1d-4205-aa0e-a6b40c5bb88b
 
You may find a 3rd party web page that has more explanation and images covering several versions and how to run the repair, if you perform a simple web search for "Repairing Excel 2016, 2013, 2010 or 2007"
 
Generally it's something like this:  Open the Windows Control Panel to run Programs and Features (formerly Add or Remove Programs) (If you are using the category view you will find "Uninstall a program under Programs), click Modify on the Office version installed on your machine (click OK) and choose the repair option. 
 
If your version gives you the option for "Quick Repair" or "Online Repair"  Choose Online Repair.  It will take longer, but it saves you the trouble of having to do it later after the Quick Repair didn't work.
 
Here's an alternate approach that you may want to try:
The Report Manager's Export Options includes two XLS File Format options:
 
-MS-Excel (*.xls, *.xlsx) - requires Microsoft Excel
 
-Generic XLS (*.xls, *.xlsx) - uses a built-in XLS file generator, Microsoft Excel is not required
 
If the issue is regarding existing templates, it is probable that the path is not properly configured.

You may also see an error like this one if you have a 32-bit version of Office because Altium 18 and newer expects the 64-bit database Engine installed on the machine.

This Knowledge Base Article goes into some detail regarding this issue:

Working with 32-bit and 64-bit software compatibility
Was this article helpful?
0
0
Обнаружили проблему в этом документе? Выделите область и нажмите Ctrl+Enter, чтобы оповестить нас.

Связаться с нами

Связаться с нашими Представительствами напрямую

We're sorry to hear the article wasn't helpful to you.
Could you take a moment to tell us why?
200 characters remaining
Вы сообщаете о проблеме, связанной со следующим выделенным текстом
и/или изображением в активном документе: