PLM-Integration
Die kombinierte Designlösung aus Altium Designer und einem Altium 365 Workspace bietet eine konfigurierbare PLM-Integration mit verfügbarer Unterstützung für Windchill®, Arena®, Oracle® Agile™, Aras Innovator® und Siemens Teamcenter® (mit zusätzlicher Einrichtung). Die Einrichtung der PLM-Integration erfolgt über die Browser-Oberfläche des Altium 365 Workspace, die eine automatisierte Oberfläche zur einfachen Konfiguration der Verbindung, zur Zuordnung von Parameterdaten und zur Festlegung der Richtung der Datensynchronisierung bereitstellt. Nach Einrichtung und Konfiguration der Oberfläche stehen die Funktionen und Merkmale der PLM-Integration bei der Arbeit in den folgenden klar abgegrenzten Bereichen zur Verfügung:
-
Library (Komponenten) – für die uni- oder bidirektionale Synchronisierung Ihrer Komponenten, Komponentenparameter und Teileauswahlen zwischen Ihrem Altium 365 Workspace und Ihrer PLM-Instanz. In der Konfiguration können Sie festlegen, welche Parameter in welchem System führend sind. Darüber hinaus ermöglichen Elementparameter das Aktualisieren von Eigenschaften auf der Workspace-Seite (pro Feld konfigurierbar), ohne dass hierfür formell eine neue Revision dieses Component Item freigegeben werden muss. Außerdem steht ein dedizierter Part Request workflow zur Verfügung, der die automatische Erstellung einer Komponente in Ihrer PLM-Instanz unterstützt und auch die Rückübertragung generierter PLM-Teilenummern an Komponenten auf der Workspace-Seite ermöglicht.
-
Design (Projekte) – es steht ein dedizierter Project Creations workflow zur Verfügung, der ebenfalls die automatische Erstellung von Teilenummern in Ihrer PLM-Instanz unterstützt und anschließend die Rückübertragung dieser Parameter an das Designprojekt ermöglicht. Solche Parameter können in speziellen Strings verwendet werden (z. B. für Blattumrandungs-Anmerkungen). Sie können Ihr Design in Ihre PLM-Instanz veröffentlichen, als Teil der Ausführung des Project Releaser in Altium Designer. Der Veröffentlichungsvorgang verwendet eine publishing template – definiert als Teil der Integrationskonfiguration der PLM-Instanz – um zu steuern, wie Daten an das PLM übertragen werden sollen. Wenn Sie zum ersten Mal veröffentlichen und Teilenummern (auf der PLM-Seite) noch nicht mit dem Projekt verknüpft sind, werden diese Teilenummern im PLM erstellt und im Rahmen dieser Erstveröffentlichung mit dem Projekt verknüpft. Sie können außerdem Komponenteneinträge für Komponenten in der PLM-Instanz als Teil des Veröffentlichungsvorgangs definieren (optional, abhängig von der Konfiguration). Und Sie können jederzeit genau sehen, was erstellt wurde, etwa Teilenummern in der PLM-Instanz, als Teil des process workflow's history (History Registerkarte).
PLM-Unterstützung
Der Altium 365 Workspace unterstützt die folgenden PLM-Systeme:
-
PTC Windchill® PLM Version 12, 13 und PTC Windchill+ (die SaaS variant von Windchill).
-
Arena® PLM.
-
Oracle® Agile™ PLM.
-
Aras Innovator® Release 30.
Additional Setup for Aras Innovator
Um die PLM-Integration mit Aras Innovator zu erreichen, muss Ihr Altium Workspace-Server bei der Aras Authentication setup registriert werden, indem ein neuer Knotenabschnitt zur Client-Registry hinzugefügt wird. Nach der Registrierung wird Ihrem verbundenen Workspace ein eindeutiges OAuth-Token zugewiesen, um den Zugriff zu authentifizieren.
Die erforderlichen Änderungen an der Konfiguration von Aras Innovator werden durch Bearbeiten seiner OAuth-Client-Registry-Datei vorgenommen:
-
Öffnen Sie auf dem Aras-Host-Rechner die Datei
\OAuthServer\OAuth.configzur Bearbeitung. -
Suchen und kopieren Sie den Abschnitt IOMApp – von der Zeile
<clientRegistry id="IOMApp" enabled="true">bis zur Zeile</clientRegistry>. -
Fügen Sie den kopierten IOMApp-Abschnitt direkt dahinter ein, um einen neuen (duplizierten) Abschnitt zu erstellen.
-
Benennen Sie in diesem neuen Knotenabschnitt
IOMAppinNEXUSum – was zu<clientRegistry id="NEXUS" enabled="true">führt.
-
Speichern Sie anschließend und starten Sie den Aras-Rechner neu.
- Siemens Teamcenter®, mit zusätzlicher integration setup.
- Duro PLM, implementiert als PLM-Instanz eines Drittanbieters – siehe Third Party PLM Support unten.
Auswahl der PLM-Einrichtungsoberfläche
Die Verbindung des Altium 365 Workspace zu einem unterstützten PLM-System kann über eine weiterentwickelte halbautomatisierte Benutzeroberfläche hergestellt werden, wie unten beschrieben, oder über einen manuellen Prozess auf Basis der Bearbeitung von XML-Konfigurationsdateien für das PLM. Letzteres erfordert Kenntnisse der Datenstrukturen des Ziel-PLM-Systems und Vertrautheit mit dem XML-Format, während das unten vorgestellte aktualisierte System die erforderlichen Daten automatisch aus dem PLM und dem Altium Workspace abruft, um die Auswahlmenüs in der Oberfläche zu füllen.
Sie können den Workplace so neu konfigurieren, dass die previous PLM interface angezeigt wird – basierend auf der manuellen Bearbeitung von XML-Dateien – indem Sie die Option Enable new PLM Configuration page auf der Seite Admin – Settings – PLM Integration page der Workspace-Oberfläche deaktivieren. Achten Sie darauf, die Änderung zu speichern und sich anschließend ab- und wieder anzumelden.
Verbindung zu Ihrer PLM-Instanz herstellen
PLM-Konfigurationen werden auf der Seite Admin – PLM Integration der Browser-Oberfläche des Workspace erstellt und verwaltet. Wenn Sie erfolgreich eine Verbindung zum PLM-System hergestellt haben, stellt die Konfigurationsoberfläche eine Reihe von Integrationsoptionen bereit, die auf Daten aus dem Workspace und dem verbundenen PLM basieren.
Verwenden Sie die Schaltfläche
, um den Verbindungsprozess zu starten, und gehen Sie wie in der untenstehenden Diashow beschrieben vor.
Jegliche Verbindungsfehler werden bei der Anmeldung am Ziel-PLM-System rot hervorgehoben. Der untere Rand des Hervorhebungsfelds enthält die Fehlerdetails – Beispiel anzeigen.
PTC Windchill SSO Support
Die Möglichkeit, beim Verbinden mit einem Windchill-PLM-System eine Single Sign-On- (SSO) Autorisierung zu verwenden, ist verfügbar und wird über die Workspace-Oberfläche eingerichtet. Dies bietet eine vereinfachte und sichere Methode zur Verbindungsautorisierung bei der Ausführung von Workspace-PLM-Prozessen wie Project Creation und Publish to PLM. In der Praxis ermöglicht diese Anordnung, den Zugriff auf Windchill über den OAuth delegation standard mithilfe eines identity provider-Dienstes wie PingFederate zu gewähren.
Der Zugriff auf die SSO-Einrichtung ist im Workspace auf der Seite PLM Integration unter der Registerkarte OAuth verfügbar (Admin - PLM Integration), wo mehrere OAuth-Provider-Instanzen hinzugefügt werden können.
Die Einrichtung der OAuth-Provider-Autorisierung wird anhand der von Ihrem konfigurierten Identity-Provider verfügbaren Daten abgeschlossen. Geben Sie einen Namen und die vom Workspace benötigten Informationen – IDs, Tokens, URLs usw. – in die Felder der Seite ein und speichern Sie anschließend die vollständige Konfiguration.
Die neue OAuth-Provider-Instanz wird verfügbar, wenn die Option OAuth Connection in einer Windchill-PLM-Konfiguration aktiviert ist. Wählen Sie aus der Dropdown-Liste OAuth Provider, wenn mehrere Provider verfügbar sind. Schließen Sie die Verbindungseinrichtung mit der Schaltfläche
ab und folgen Sie bei Bedarf den Anweisungen des Providers.
Unterstützung für PLM-Systeme von Drittanbietern
Der Altium 365 Workspace bietet zusätzliche Unterstützung für Konfigurationen „nicht nativer“ PLM-Systeme, die von Drittanbietern entwickelt wurden. Diese Unterstützung wird durch Altiums Generic Connector aktiviert, wofür die Lizenz Altium 365 PLM Generic Connector Addon erforderlich ist.
Beim Hinzufügen einer Workspace-PLM-Instanz für ein solches System werden vom Drittanbieter bereitgestellte vorkonfigurierte XML-Dateien über die PLM Integration interface in die Konfiguration dieser PLM-Instanz hochgeladen.
Konfigurationseinrichtung
Nach erfolgreicher Verbindung zu einer PLM-Instanz bietet die Workspace-PLM-Oberfläche Konfigurationseinstellungen zur Definition der Durchführung der Komponentensynchronisierung, der gegenseitigen Zuordnung von Komponentenparametern und des für Part-Choices-Daten verwendeten Übertragungsansatzes. Diese Synchronisierungsoptionen sind auf der Registerkarte Configuration der Oberfläche verfügbar.
Welche Konfigurationsoptionen Ihnen zur Verfügung stehen (und ihre Bezeichnungen/Funktionalität), wird durch den Typ des PLM-Systems und die parametrischen Daten bestimmt, die sowohl aus dem Workspace als auch aus der verbundenen PLM-Instanz abgerufen werden.
Synchronisierungsparameter
Dieser Abschnitt der PLM-Oberfläche definiert, welche Komponententypen synchronisiert werden, wo und wie neue Komponenten erstellt/aktualisiert werden und welche Einschränkungen auf Basis von Parameterkriterien gelten.
Wie Komponenten synchronisiert werden, wird individuell festgelegt:
- Wählen Sie in der Parameterliste einen Altium Component Type aus und setzen Sie die zugehörige Option Sync Direction nach Bedarf (zu Altium/PLM oder beides) – die Optionen für Komponententypen stammen aus den aktuellen Workspace-Komponentendaten.
- Wählen Sie einen zugehörigen PLM-Attributnamen aus dem Menü PLM Type – die verfügbaren Optionen stammen aus der verbundenen PLM-Instanz.
- Wechseln Sie im Feld Altium Target Folder (unter Sync to Altium) zu einem Workspace-Komponentenordner und wählen Sie ihn als Synchronisierungsspeicherort für diese Komponente aus.
- Geben Sie einen Sync Mode an, um festzulegen, ob während der Synchronisierung neue Komponenten erstellt werden oder nur bestehende Komponenten aktualisiert werden – oder beides.
-
Legen Sie den Component Template fest, der verwendet wird, um Komponententypparameter bei der Synchronisierung dieser Komponente zu definieren. Diese Einstellung wird standardmäßig auf den ausgewählten Altium Component Type gesetzt (zum Beispiel:
Capacitors), wenn eine zugehörige Workspace-Vorlage verfügbar ist. - Verwenden Sie die Option Add Parameter Criteria, um einen Parameterwert anzugeben, durch den die Synchronisierung eingeschränkt wird. Eine Komponente wird nicht synchronisiert, wenn sie dieses Kriterium nicht erfüllt. Fügen Sie bei Bedarf weitere Parameterkriterien hinzu.
Zusätzliche Optionen sind verfügbar, wenn eine Verbindung zu einem PTC Windchill PLM besteht, das das PartsLInk system von Windchill unterstützt. Das System PartsLink ermöglicht die Klassifizierung von Teilen in Gruppen für eine bequemere und schnellere Zielauswahl und kann zugehörige Attribut-/Wert-Paare enthalten, um innerhalb dieser Klassifikation eine weitere Definition bereitzustellen. Weitere Informationen finden Sie im ausklappbaren Abschnitt unten.
-
Wählen Sie den Add Classification Name Criteria aus dem Menü Filter Criteria, um einen Klassifikationsfilter hinzuzufügen. Verwenden Sie das Namensmenü, um eine Klassifikationsgruppe auszuwählen, nach der die Synchronisierung gefiltert werden soll.
-
Für eine feinere Steuerung wählen Sie die Option Add Classification Attribute Criteria und geben ein Attribute einer Klassifikation sowie den zugehörigen Wert an. Im hier gezeigten Beispiel werden nur Kondensatoren aus der Klasse
102-Capacitorsmit einemCapacitance-Wert von10uFsynchronisiert.
More on Windchill PartsLink
Innerhalb von Windchill selbst wird eine PartsLink-Klassifikation durch Erstellen eines binding attribute definiert, das auf einen Teiletyp angewendet werden kann. Anschließend wird einer definierten Klassifikationsklasse ein Teile-Klassifikationsattribut hinzugefügt.
Komponenteneinträge in Windchill enthalten ihre definierte Klassifikation und alle angegebenen Parameter für Klassifikationsattribute, die wiederum dem PLM-Komponentensynchronisierungsprozess des Workspace zur Verfügung stehen.
Wenn ein Komponenteneintrag von Windchill mit dem Workspace synchronisiert wird und in der PLM-Konfiguration des Workspace eine PartsLink-Interaktion angegeben wurde, werden die Konfigurationsattribute von Windchill für dieses Teil an Altium Designer übertragen.
Wenn Sync Direction auf To PLM gesetzt ist oder für bidirektionale Synchronisierung (To PLM & To Altium), wird unter Sync To PLM eine Option Add Filter Criteria angezeigt. Verwenden Sie diese Option, um Parameter- oder Ordnerkriterien festzulegen, die steuern, welche Workspace-Komponenten an das PLM-System übertragen werden.
Es können mehrere Parameterkriterien hinzugefügt werden, um die Synchronisierung von Workspace-Komponenten mit dem PLM eng einzugrenzen. Die verfügbaren Kriterien umfassen auch die Klauseloptionen OR und NOT, um eine präzisere Steuerung der Filterung akzeptierter Komponenten für die Synchronisierung mit dem PLM zu ermöglichen.
Der Abschnitt Sync to PLM bietet zusätzliche Optionen für Teilenummerierung sowie Präfixe/Suffixe beim Einsatz mit einem Arena-PLM-System. Diese vordefinierten PLM-Schemata stehen in den Menüs Numbering Scheme und Code zur Auswahl und bestimmen das Item-Number-Format der nach Arena hochgeladenen Teile.
Zuordnung von Komponentenparametern
Führen Sie denselben Prozess wie oben fort, um die Konfiguration der Synchronisierungsparameter für alle Komponenten festzulegen, die Sie mit dem PLM synchronisieren möchten. Da Komponentenparameter auf der Workspace-Seite nicht notwendigerweise mit denen auf der PLM-Seite übereinstimmen, kann der Abschnitt Component Parameter Mapping der Oberfläche verwendet werden, um Parameter zwischen beiden zuzuordnen. Beachten Sie, dass bei zugeordneten Parametern deren Wert synchronisiert wird, als wären sie derselbe Parameter.
Verwenden Sie den Befehl Add Parameter dieses Abschnitts, um einen Eintrag zur Zuordnung eines Workspace-/PLM-Parameters zu erstellen, der für den aktuell ausgewählten Altium Component Type gilt (wie unter Sync Parameters ausgewählt). Die Optionen Parameter Name für PLM und Altium sind die in den jeweiligen Systemen verfügbaren. Eine Einstellung Revision in der Spalte Item/Revision bewirkt, dass eine neue Komponentenrevision erstellt wird, wenn sich der Parameter geändert hat, während mit der Einstellung Item während der Synchronisierung nur der Komponentenparameter aktualisiert wird.
Verwenden Sie das zugehörige Symbol
, um einen Zuordnungseintrag zu entfernen.
Es kann auf diese Weise eine beliebige Anzahl von Parametern zugeordnet werden; wahrscheinlich gibt es jedoch eine Reihe gemeinsamer Workspace-/PLM-Parameter, die für alle Komponenten zugeordnet werden müssen. Dieser globale Zuordnungsansatz steht zur Verfügung, wenn All Types als Altium Component Type ausgewählt ist.
Erstellen Sie Zuordnungseinträge (Add Parameter), die für alle Komponenten gelten, indem Sie bekannte gemeinsame Parameterübereinstimmungen einbeziehen, und setzen Sie die Optionen Item/Revision und Sync Direction nach Bedarf. Es ist außerdem wichtig, einen zugeordneten Parametereintrag als Primary Key festzulegen – dies ist ein gemeinsames Parameterpaar, das als Referenzindex zwischen den beiden Sätzen parametrischer Daten dient. Wenn dies eine PLM-Teilenummer ist (empfohlen), wird die auf der PLM-Seite erstellte Nummer zurück an die Altium-Seite übertragen und schafft so eine bekannte Referenzverknüpfung zwischen den Sätzen synchronisierter Komponentendaten.
PLM-Klassifikationsattribute
Bei verbundenen PLM-Systemen, die die Gruppierung von Komponenten als Classifications unterstützen (wie z. B. PTC Windchill), können in diesem Abschnitt die zugehörigen PLM-Attribute und Werte Workspace-Komponentenparametern zugeordnet werden.
Bei PTC Windchill zum Beispiel können Sie zum Extrahieren eines bestimmten Klassifikationsattributwerts (etwa des Kapazitätswerts für Kondensatoren in der Klasse 102-Capacitor) diese Klassifikation und ihren Wert (Capacitance) als PLM Parameter Name und den Ziel-Altium-Komponentenparameter (Value) als Altium Parameter Name hinzufügen. Definitionen können für alle Komponententypen hinzugefügt werden, einschließlich mehrerer Definitionen für denselben Komponententyp.
► Siehe die obigen PartsLink information für weitere Informationen zu Windchill-Klassifikationen.
Part Choices
Verwenden Sie das Dropdown-Menü Sync Direction, um festzulegen, in welche Richtung Hersteller-Part Choices-Daten zwischen dem Workspace und dem PLM-System synchronisiert werden, oder deaktivieren Sie die Part-Choices-Synchronisierung mit der Option OFF.
Abhängig vom verbundenen PLM-Typ bietet die Option Part Choice information eine Synchronisierung in einem Format, das mit den vom PLM selbst freigegebenen Fertigungsteilen (Native PLM Manufacturer Parts) kompatibel ist, oder als herkömmliche Komponentenparameterdaten (PLM Part Attributes). Letzteres kann aus mehreren Sätzen von Manufacturer:PartNumber-Parameterattributen bestehen – MFR1:MPN1, MFR2:MPN2 zum Beispiel.
Beispiele für „native“ (oder integrierte) PLM-Herstellerteile sind Vendor Parts in Arena und Manufacturer Parts in Windchill.
Projektkonfigurations-XML
Dieser Abschnitt bietet eine Auflistung der grundlegenden XML-Konfiguration, die die anfängliche PLM-Konfiguration für das verbundene PLM-System definiert. Die heruntergeladene Version dieser XML-Grundkonfiguration (Download Sample Configuration) enthält detaillierte Kommentare, die die Funktion der meisten Entity- und Attribute-Abschnitte hervorheben.
Letztlich wird die in der PLM-Integrationsoberfläche definierte Konfiguration als XML-Systemdateien gespeichert, die lokal über den Befehl Export Configuration gespeichert werden können, der den Server Connection Details oben auf der Konfigurationsseite zugeordnet ist.
Eine Option Import Configuration ist ebenfalls enthalten. Damit können Sie eine vorhandene XML-Konfigurationsdatei auf eine neue (oder bearbeitete) PLM-Konfiguration anwenden, wodurch diese PLM-Konfigurationseinrichtung dupliziert wird. Wenn an einer bestehenden PLM-Konfiguration spezielle Änderungen vorgenommen werden müssen, wird deren exportierte XML-Datei manuell bearbeitet und anschließend wieder in die Konfiguration importiert. Beachten Sie, dass die in einer Konfigurationsdatei enthaltenen Parameters, Attributes und Values zwischen Groß- und Kleinschreibung unterscheiden.
Hinzufügen einer Veröffentlichungsvorlage
Die PLM-Konfiguration erfordert das Hinzufügen einer XML-basierten Publishing Template, um Workspace-Prozesse zu unterstützen, die vollständige Projektdaten – Designdateien, Komponenten- und Fertigungsausgabedaten – in einer einzigen „Publish“-Aktion an das PLM-System senden. Zu diesen Prozessen gehören Publish to PLM, bei dem der Benutzer die zu sendenden Ausgabedaten angibt, sowie Project Releaser with Publish, das die erzeugten Daten als letzten Schritt in Altium Designer's Project Release process an das PLM sendet.
Fügen Sie beim Erstellen oder Bearbeiten Ihrer PLM-Konfiguration unter der Registerkarte Publish Template eine geeignete XML-Datei für die Publishing Template hinzu. Verwenden Sie den Sample Project Configurations Link, um eine archivierte Sammlung von Templates für unterstützte PLM-Systeme herunterzuladen.
Eine Publishing Template enthält Verweise auf Projektdetails, die Übertragung von Komponentendaten, Speicherorte von Datenquellen und die Dateiverteilung von Design-, Assembly- und Fabrication-Daten. Die heruntergeladenen Beispiele enthalten Templates für alle unterstützten PLMs; jedes davon enthält zusätzliche Publishing Rules, die für den jeweiligen PLM-Typ gelten, sowie ausführliche Kommentare, die Ihnen als Leitfaden dienen, was und wie zu konfigurieren ist.
Publishing Folder Support for Windchill PLM
Bei der Konfiguration einer Windchill® PLM Integration instance, die für Publish to PLM processes verwendet wird, können Sie außerdem einen Zielordner in Windchill für Dokumente angeben (und erstellen), die aus dem Workspace veröffentlicht werden.
Die zugehörigen Windchill-Ordnerparameter werden in der XML-Datei der Publishing Template definiert, die auf Ihren Windchill-PLM-Integrationseintrag im Workspace angewendet wird (siehe oben). Ordnerdefinitionsknoten haben das Tag-Format <pt:Folder>xxx</pt:Folder> – wobei pt der aktuelle Namespace und xxx der vollständige Ordnerpfad ist – und werden als Publishing Rule innerhalb des Abschnitts FileDistribution für jeden Dokumenttyp platziert (zum Beispiel für eine PCB.zip Fabrication-Ausgabe).
Ein Beispiel für die Hierarchie der Publishing-XML-Struktur wäre:
<pt:EntityRule id="FAB">
<pt:FileDistributions>
<pt:FileDistribution archiveName="PCB.zip">
<pt:Folder>PRODUCT/Projects/${project.name}/FAB data</pt:Folder>
Die letzte Zeile des Eintrags würde einen Publishing-Zielordner für die PCB.zip Fabrication-Ausgabe mit der Windchill-Ordnerstruktur angeben (oder erstellen) (wobei der Projektname MyProject lautet):
PRODUCT
Projects
MyProject
FAB data
Beachten Sie, dass der in der Publishing-XML-Datei definierte Ordnerpfad absolut (und nicht relativ) ist und andere Projekteigenschaften wie den Projektnamen (${project.name}) und die Assembly Number (${project.PLM_ASSEMBLY_NUMBER}) enthalten kann.
Publish to PLM with ECO
Die Setup-Dateien für Windchill-, Agile- und Arena-PLM-Instanzen unterstützen auch den formalisierten Change Order (ECO)-Workflow, der in der XML-Datei der Publishing Template aktiviert und in der Configuration XML file im Abschnitt der Entität altiumType="ProjectChangeOrder" definiert wird.
Je nach PLM-Instanz enthalten die XML-Konfigurationsdefinitionen ein Schema zur Identifikation von Change Orders (Nummerierung, Speicherort, ID usw.), spezifische Change-Order-Attribute wie Name/Titel, Beschreibung und Change Complexity (nur Windchill) sowie Optionseinstellungen wie die Strategie zur Erstellung von Change Orders (keine, neu oder vorhandene wiederverwenden) und die Promotion des Lifecycle-Status (nur Windchill und Agile). Die definierte Change Order wird während des Publishings durch die Deklaration ihrer publishId Referenz im zugehörigen Publishing Template aktiviert.
Das Publishing Template unterstützt außerdem Regelsätze, die definieren, wie und wo Release-Ausgaben (Projekt-, Quell-, Assembly- und Fabrication-Daten) in das PLM veröffentlicht werden.
Nach der Definition in den XML-Dateien Configuration und Publishing Template des Servers sind Change Orders während der Prozess-Workflows Project Creation und Publishing to PLM verfügbar, die aus Altium Designer oder über die Workspace PLM interface aufgerufen werden. Während des Ablaufs wird ein zugehöriges Change-Order-Formular angezeigt, in dem die Optionen der Change Order festgelegt werden.
Der Dialog in Altium Designer Change Order Required, der den anfänglichen Schritt zur Projekterstellung und die nachfolgende ECO-aktivierte Projektfreigabe zeigt.
Im hier gezeigten Beispiel wird ein Projekt in Altium Designer aus einem Template mit dem Prozess Create Project with PLM Initialize erstellt (nach Arena PLM), wobei die Option Create change order (ECO) deaktiviert ist. Anschließend wird das Projekt mit dem Prozess Publish to PLM (User selects) freigegeben, wobei die Option Create change order aktiviert ist (Yes). Auf der Arena-Seite werden die Elemente anschließend anhand einer Change Order (ECO-00042) und ihres inhärenten Genehmigungsprozesses veröffentlicht.
Laden Sie ein ZIP-Archiv herunter, das die in diesem Beispiel verwendeten XML-Dateien Arena Configuration und Publishing Template enthält.
Ändern Sie ein Beispiel-XLM-Template nach Bedarf und laden Sie die Datei über das Fenster Add Publish Template in Ihre PLM-Konfiguration hoch, das über die Schaltfläche
geöffnet wird. Beachten Sie, dass eine PLM-Konfiguration mehrere Publish Templates unterstützt.
Komponentensynchronisierung
Die Synchronisierung von Komponentendaten zwischen Ihrem Altium 365 Workspace und dem verbundenen PLM-System wird durch das oben beschriebene aktivierte Parameter-Mapping und die Richtung bestimmt und erfolgt, wenn der Synchronisierungsprozess manuell oder automatisch zu einem geplanten Zeitpunkt ausgelöst wird. Der Synchronisierungsprozess selbst wird durch einen integrierten LibSync process Workflow gesteuert.
Innerhalb einer PLM-Konfigurationsinstanz sind die zugehörigen Synchronisierungsoptionen auf der Registerkarte Component Synchronization verfügbar, wo der Prozess manuell ausgelöst oder zeitgesteuert eingerichtet werden kann. Aktivieren Sie für Letzteres die Option Synchronize on a schedule und wählen Sie ein Zeitintervall aus dem zugehörigen Dropdown-Menü aus.
Sie können die Menüoptionen
verwenden, um einen Prozess LibSync manuell entweder als Synchronisierungsereignis Incremental oder Full auszulösen:
-
Incremental – wendet nur jene Komponenten an, die seit der letzten Ausführung der Synchronisierung geändert wurden (d. h. deren Zeitstempel später als das Datum der letzten Synchronisierung ist) und die die Synchronisierungskriterien in der Konfiguration erfüllen. Beachten Sie, dass dies der Modus ist, der verwendet wird, wenn ein Synchronisierungsereignis über das Steuerelement
auf der Hauptseite PLM Integration ausgelöst wird – siehe unten.
- Full – dieser Modus erzwingt eine vollständige Synchronisierung. Alle Komponenten, die die Synchronisierungskriterien in der Konfiguration erfüllen, werden einbezogen.
Durchführen der Komponentensynchronisierung
Die Komponenten- (Bibliotheks-) Synchronisierung kann als manueller Prozess über einen PLM-Instanzeintrag auf der Workspace-Seite PLM Integration oder als im Instanz-Setup angegebener automatisierter Zyklus durchgeführt werden – siehe oben. Klicken Sie auf das der PLM-Instanz zugeordnete Steuerelement
, um den Synchronisierungsprozess manuell aufzurufen; dieser durchläuft den Workflow LibSync unter Verwendung der in der zugehörigen PLM-Konfiguration definierten Einstellungen.
Das Steuerelement Actions ändert sich zu
, sodass Sie den Synchronisierungsprozess bei Bedarf stoppen können, und der Eintrag Sync Status zeigt an, dass ein Prozess ausgeführt wird. Der Status ändert sich zu Completed, wenn der Synchronisierungsprozess abgeschlossen ist.
Wenn die Komponentensynchronisierung ausgeführt wird, entweder manuell oder als zeitgesteuertes Ereignis, durchläuft der Prozess LibSync seinen vordefinierten Workflow, bis er abgeschlossen ist oder ein Fehler auftritt. Sie können den Browser aktualisieren (F5), um den aktuellen Status des Synchronisierungsprozesses anzuzeigen.
Um auf Details eines abgeschlossenen Synchronisierungsereignisses zuzugreifen, klicken Sie auf das Symbol
in der Spalte Last Sync, um die zugehörige Protokolldatei herunterzuladen (Beispiel anzeigen), oder wählen Sie das zugehörige Datum aus, um den Ereigniseintrag auf der Registerkarte Synchronization Status zu öffnen. Beachten Sie, dass in dieser Ansicht abgeschlossene Synchronisierungsereignisse aufgelistet werden, wenn die Option Closed ausgewählt ist, und laufende oder angehaltene Ereignisse angezeigt werden, wenn der Ansichtsmodus Active ausgewählt ist.
Die Unterregisterkarten der Statusansicht bieten die folgenden Informationen:
- Diagram – eine Grafik, die den Prozess-Workflow darstellt und deren aktuelle Schrittposition hervorgehoben ist (abgeschlossen oder Fehler-/Ausfallstatus).
- Data – eine Informationszusammenfassung der Prozessaktion, einschließlich des Erfolgs oder Misserfolgs ihrer Schritte und eines Links zum protokollierten Prozessbericht – Beispiel anzeigen.
- History – ein Zeitprotokoll der wichtigsten Workspace-Synchronisierungsereignisse in sequenzieller Reihenfolge.
Alle Synchronisierungsereignisse, die vorzeitig gestoppt wurden, etwa wenn ein Fehler aufgetreten ist, werden aufgelistet, wenn sich die Ansicht im Modus Active befindet. Diese Einträge können mit dem Steuerelement Terminate entfernt werden oder – korrekter – über die zugehörige Task-Kachel in der Workspace-Tasks view geprüft und gelöst werden. Beachten Sie, dass ein beendetes/gelöstes Synchronisierungsereignis in die Liste Closed der Ansicht Synchronization Status mit einem entsprechenden Status verschoben wird, z. B. Failed.
Zugriff auf PLM-bezogene Prozesse
Beispiel-Process-Workflows im Zusammenhang mit einem verbundenen PLM-System sind unter den Registerkarten der Prozessthemen auf der Workspace Processes page verfügbar. Im Allgemeinen können die Beispiele nicht direkt verwendet werden, sondern müssen unter einem anderen Namen erneut gespeichert werden, um aktiv zu werden.
► Weitere Informationen finden Sie in der Dokumentation Processes & Workflow.
Ein Workspace-Administrator kann eine neue Instanz jeder aktivierten Prozessdefinition direkt aus der Prozessliste auf der Seite Processes starten, indem er auf das Steuerelement
klickt. Auch Nicht-Administrator-Benutzer des Workspace können aktive Prozesse aus dem Workspace heraus initiieren, wie zum Beispiel:
-
Ein Part Request with PLM Prozess über die Schaltfläche
auf der Seite Part Request page.
-
Ein Publish to PLM Prozess über die Schaltfläche
auf den Seiten Tasks und Activities eines geöffneten Projekts.
-
Ein Publish to PLM Prozess über die Schaltfläche
auf der Hauptseite Projects page.
-
Ein Project with Initialize in PLM Prozess über die Schaltfläche
auf der Hauptseite Projects page oder beim Klonen eines Projekts über das Schaltflächenmenü
.
In der Praxis werden die PLM-bezogenen Prozesse jedoch üblicherweise während des Projektdesigns und der -entwicklung aus Altium Designer heraus aufgerufen. Auf die PLM-bezogenen Prozesse wird in Altium Designer auf folgende Weise zugegriffen:
-
Part Request with PLM Part Create – Aufruf über die Bedienfelder Explorer, Manufacturer Part Search und Components von Altium Designer.
► Ausführliche Informationen finden Sie unter Process-based Part Requests. -
Publish to PLM (User selects) – Aufruf über das Untermenü Project » Project Activities für das aktive Altium-Designer-Projekt.
► Ausführliche Informationen finden Sie unter Publishing to a PLM – user-selects. -
Project Releaser with Publish – Aufruf als letzte Stufe des Project Releaser über das Untermenü Project » Project Releaser für das aktive Altium-Designer-Projekt.
► Ausführliche Informationen finden Sie unter Design Project Release – publishing to PLM. -
Project with initialise in PLM – Aufruf beim Erstellen eines neuen Altium-Designer-Projekts über das Untermenü File » New » Project in <Workspace> oder beim Klonen eines Projekts.
► Ausführliche Informationen finden Sie unter Publishing to a PLM – initialize in PLM.
Prozess-Workflows
Die folgenden Prozessdefinitionen (und zugrunde liegenden Workflows) sind über den Workspace verfügbar, um die PLM-Integration zu unterstützen:
-
Part Requests process theme:
- Part Request with PLM Part Create – unterstützt die automatische Erstellung einer Komponente in Ihrer PLM-Instanz und anschließend die Rückübertragung der generierten Teilenummer an die Workspace-Komponente. Das Workflow-Diagramm ist unten dargestellt.
Wichtig ist, dass Sie beim Anpassen dieser Beispieldefinition zur Erstellung Ihrer eigenen Definition die PLM-Instanz angeben müssen, in der Teile erstellt werden sollen. Wählen Sie die Entität Create Part in PLM im Workflow-Diagramm aus und wählen Sie die PLM-Instanz aus dem Dropdown-Menü aus, das dem Feld PLM Instance zugeordnet ist. Dieses Menü listet alle derzeit definierten PLM-Instanzen auf (wie auf der Seite PLM Integration der Schnittstelle definiert).
► Weitere Informationen zum Arbeiten mit Prozess-Workflows finden Sie unter Creating and Managing Processes.
- Project Activities process theme:
- Publish to PLM (User selects) – Veröffentlichung freigegebener Managed-Project-Ausgaben an die integrierte PLM-Instanz, wobei der Benutzer genau auswählen kann, welche Ausgaben veröffentlicht werden. Das Workflow-Diagramm ist unten dargestellt.
- Project Releaser with Publish – Veröffentlichung an die integrierte PLM-Instanz als zusätzliche Stufe des Project Releaser. Das Workflow-Diagramm ist unten dargestellt.
-
Project Creations process theme:
- Project with initialise in PLM – unterstützt die automatische Erstellung von Teilenummern in Ihrer PLM-Instanz und anschließend deren Weitergabe als Parameter des Workspace-Designprojekts. Das Workflow-Diagramm ist unten dargestellt.
























aktiviert. 












