Unlink a Managed Component to copy to Local Library

Created: August 20, 2022 | Updated: August 20, 2022

Components placed on a schematic or copied to a local schematic library from the Manufacturer Part Search (MPS) panel, Concord Pro, or NEXUS server (AD19 and newer) / Altium Content Vault (AD17 & 18) are still linked to the server and therefore are considered as Managed and can't be modified. You would not be able to remove/edit the existing footprint for example. This article explains how to break the link to the server.

Starting in Version: 18.0
Up to Version: Current

Solution Details

To break the link, first we would need to have a library with the components.  You can create one from your existing design:

  1. With the schematic document open, Design ► Make Schematic Library (Or Design ► Make PCB Library when on the PCBDoc).

  1. With the library created, save the library file.

  2. Then, to break the link to the server, within the library: Tools ► Clear Server Links ► Yes to Continue. 

  1. With the links broken, you would need to create a copy of the components to account for all scenarios and assure that no old ones still retain the link.

  2. Open the SCH Library panel from the Panels button at the lower right corner of the screen (or PCB Library if done for PCB for PCB Footprints.)

  1. Select all the components by clicking the first one in the list then hold the shift key while clicking the last component in the List.

  2. Right-Click ► Copy. You should now have the components copied.

  1. You can then Right-Click ► Delete. To remove the old Components.

  2. Then Right-Click ► Paste to add the newly copied components (without the links) back to your Library. Repeat this Process for your PCB Library.

If you do not want to create a new library and want to just add the managed component to an existing local library:

  1. Place the components from the Server to a Schematic Document (or PCB Document)

  2. With the component select, Edit ► Copy

  1. Open the existing Library and then open the SCH Library panel from the Panels button at the lower right corner of the screen (or PCB Library if done for PCB)

  1. Right-Click the list in the SCH Library ► Paste

  1. This should add the component to the Schematic Library

  2. Now, run: Tools ► Clear Server Links ► Yes to Continue.

  1. With the links broken, you would need to create a copy of the components to account for all scenarios and assure that no old ones still retain the link.

  2. In the SCH Library panel, select the component: Right-Click ► Copy.

  3. You can then Right-Click ► Delete. To remove the old Components.

  4. Then Right-Click ► Paste to add the newly copied components (without the links) back to your Library.

Was this article helpful?
0
0
Found an issue with this document? Highlight the area, then use Ctrl+Enter to report it.

Contact Us

Contact our corporate or local offices directly.

We're sorry to hear the article wasn't helpful to you.
Could you take a moment to tell us why?
200 characters remaining
You are reporting an issue with the following selected text
and/or image within the active document: