Intégration PLM

La solution de conception combinée d’Altium Designer et d’un Workspace Altium 365 offre une intégration PLM configurable, avec une prise en charge disponible pour Windchill®, Arena®, Oracle® Agile™, Aras Innovator®,  et Siemens Teamcenter® (avec configuration supplémentaire). La configuration de l’intégration PLM s’effectue via l’interface navigateur du Workspace Altium 365, qui fournit une interface automatisée permettant de configurer facilement l’interconnexion, de mapper les données de paramètres et de spécifier le sens de synchronisation des données. Une fois l’interface mise en place et configurée, les fonctionnalités d’intégration PLM sont disponibles lors du travail dans les zones distinctes suivantes :

  • Library (composants) – pour la synchronisation unidirectionnelle ou bidirectionnelle de vos composants, paramètres de composants et choix de pièces entre votre Workspace Altium 365 et votre instance PLM. La configuration vous permet de spécifier quels paramètres sont maîtres dans quel système. De plus, les paramètres d’élément vous permettent de mettre à jour les propriétés côté Workspace (configurable par champ), sans avoir à publier formellement une nouvelle révision de cet élément de composant. Un workflow de demande de pièce dédié est également disponible ; il prend en charge la création automatique d’un composant dans votre instance PLM, ainsi que la propagation des numéros de pièce PLM générés vers les composants côté Workspace.

  • Design (projets) – un workflow de création de projets dédié est également disponible ; il prend en charge la création automatique de numéros de pièce dans votre instance PLM, puis la propagation de ces paramètres vers le projet de conception. Ces paramètres peuvent être utilisés dans des chaînes spéciales (par ex. pour les annotations de cartouche de feuille). Vous avez la possibilité de publier votre conception dans votre instance PLM dans le cadre de l’exécution du Project Releaser dans Altium Designer. L’opération de publication utilise un modèle de publication – défini dans le cadre de la configuration d’intégration de l’instance PLM – pour contrôler la manière dont les données doivent être propagées vers le PLM. Et si vous publiez pour la première fois et que des numéros de pièce (côté PLM) ne sont pas encore associés au projet, ces numéros de pièce seront créés dans le PLM et associés au projet lors de cette publication initiale. Vous avez également la possibilité de définir des entrées de composant pour les composants dans l’instance PLM dans le cadre de l’opération de publication (optionnel, selon la configuration). Et vous pourrez toujours voir exactement ce qui a été créé, comme les numéros de pièce dans l’instance PLM, dans l’historique du workflow de processus (History onglet).

Prise en charge PLM

Le Workspace Altium 365 prend en charge les systèmes PLM suivants :

  • PTC Windchill® PLM version 12, 13, et PTC Windchill+ (la variante SaaS de Windchill).

  • Arena® PLM.

  • Oracle® Agile™ PLM.

  • Aras Innovator® Release 30.

  • L’intégration avec Siemens Teamcenter PLM nécessite l’installation et la configuration du logiciel Teamcenter EDA Gateway .

  • En tant que solution PLM sur site, Teamcenter doit s’interfacer avec votre Workspace Altium 365 via l’Altium Hybrid Agent, qui comble de manière sécurisée l’écart entre le cloud et le réseau local. Des liens d’instructions sont inclus sur la page Installation et configuration supplémentaires pour Siemens Teamcenter.

  • Une licence d’addon Workspace Teamcenter PLM est également requise pour activer cette fonctionnalité dans le Workspace.

Choix de l’interface de configuration PLM

La connexion du Workspace Altium 365 à un système PLM pris en charge peut être établie via une interface utilisateur avancée semi-automatisée, comme détaillé ci-dessous, ou en utilisant un processus manuel basé sur l’édition de fichiers XML de configuration PLM. Cette dernière méthode nécessite une connaissance des structures de données du système PLM cible et une familiarité avec le format XML, tandis que le système mis à jour présenté ci-dessous récupère automatiquement les données requises du PLM et de l’Altium Workspace afin d’alimenter les choix de menus de l’interface.

Vous pouvez reconfigurer le Workplace pour présenter l’ancienne interface PLM – basée sur l’édition manuelle de fichiers XML – en décochant l’option Enable new PLM Configuration page dans la page Admin – Settings – PLM Integration de l’interface Workspace. Assurez-vous d’enregistrer la modification, puis déconnectez-vous et reconnectez-vous.

Notez qu’un seul type d’interface PLM doit être utilisé (ancienne ou nouvelle). Ne modifiez pas une instance/configuration PLM créée par une autre version de l’interface.

Connexion à votre instance PLM

Les configurations PLM sont créées et gérées dans la page Admin – PLM Integration de l’interface navigateur du Workspace. Lorsque vous êtes connecté avec succès au système PLM, l’interface de configuration fournit une série d’options d’intégration basées sur des données provenant à la fois du Workspace et du PLM connecté.

Une instance d’intégration PLM du Workspace accède au service API REST du système PLM, qui doit être activé et disponible.

Utilisez le bouton pour démarrer le processus de connexion et poursuivez comme indiqué dans le diaporama ci-dessous.

Cliquez sur pour ouvrir la page Add Configuration afin de créer une nouvelle instance de configuration PLM ou d’en ajouter une autre.

Saisissez un Name/Description unique pour la nouvelle configuration, sélectionnez le type de PLM correct dans le menu déroulant Driver et (pour cet exemple Aras) une base de données de travail spécifique le cas échéant – avec Arena, il s’agit d’un “Workspace ID”. Saisissez vos identifiants Username/Password pour le système PLM puis cliquez sur pour continuer.

Une connexion PLM réussie est confirmée sous l’en-tête Server Connection, et le Workspace renseignera alors l’interface avec des options de données paramétriques provenant à la fois des données de composants du Workspace et des données d’attributs du PLM.

Une fois chargée, l’interface présente les données paramétriques et de type importées sous forme d’options de menu ou de champ sélectionnables.

 

Toute erreur de connectivité sera mise en évidence en rouge lors de la connexion au système PLM cible. La bordure inférieure de la zone de mise en évidence inclura les détails de l’erreur – voir l’exemple.

Prise en charge des PLM tiers

Le Workspace Altium 365 fournit une prise en charge supplémentaire pour les configurations de systèmes PLM “non natifs” développées par des tiers. Cette prise en charge est activée par le Generic Connector d’Altium, qui nécessite la licence Altium 365 PLM Generic Connector Addon.

Lors de l’ajout d’une instance PLM Workspace pour un tel système, les fichiers XML préconfigurés fournis par le tiers sont téléversés vers la configuration de cette instance PLM via l’interface PLM Integration.

Contactez sales.na@altium.com ou votre gestionnaire de compte Altium pour demander l’accès à la licence d’addon Altium 365 PLM Generic Connector.

Configuration

Après une connexion réussie à une instance PLM, l’interface PLM du Workspace propose des paramètres de configuration pour définir comment la synchronisation des composants est effectuée, le mappage croisé des paramètres de composants et l’approche de transfert utilisée pour les données de choix de pièces. Ces options de synchronisation sont disponibles sous l’onglet Configuration de l’interface.

Les options de paramètres de configuration à votre disposition (ainsi que leurs libellés/fonctionnalités) sont déterminées par le type de système PLM et les données paramétriques extraites à la fois du Workspace et de l’instance PLM connectée.

Si le Workspace de votre organisation se trouve dans l’environnement sécurisé Altium 365 GovCloud, un administrateur Workspace devra activer l’option PLM Integration dans la vue Outbound Traffic de la page Admin – Settings. Cela autorisera le passage des requêtes de données de synchronisation et des données de fichiers de publication vers des systèmes PLM externes, ce qui est sinon bloqué.

Consultez le contrôle d’accès du Workspace pour plus d’informations.

Paramètres de synchronisation

Cette section de l’interface PLM définit quels types de composants seront synchronisés, où et comment les nouveaux composants doivent être créés/mis à jour, ainsi que toutes les contraintes basées sur des critères de paramètres.

La manière dont les composants sont synchronisés est spécifiée individuellement :

  1. Sélectionnez un Altium Component Type dans la liste des paramètres et définissez son option Sync Direction selon le besoin (vers Altium/PLM ou les deux) – les options de type de composant proviennent des données de composants actuelles du Workspace.
  2. Choisissez un nom d’attribut PLM associé dans le menu PLM Type – les options disponibles proviennent de l’instance PLM connectée.
  3. Dans le champ Altium Target Folder (sous Sync to Altium), parcourez et sélectionnez un dossier de composants Workspace comme emplacement de synchronisation pour ce composant.
  4. Spécifiez un Sync Mode pour déterminer si de nouveaux composants seront créés pendant la synchronisation, ou si seuls les composants existants seront mis à jour – ou les deux.
  5. Définissez le Component Template qui sera utilisé pour définir les types de paramètres de composants lors de la synchronisation de ce composant. Ce paramètre prendra par défaut la valeur du Altium Component Type sélectionné (par exemple ; Capacitors) si un modèle Workspace associé est disponible.
  6. Utilisez l’option Add Parameter Criteria pour spécifier une valeur de paramètre qui servira de contrainte à la synchronisation. Un composant ne sera pas synchronisé à moins de satisfaire à ce critère. Ajoutez d’autres critères de paramètre si nécessaire.

Des options supplémentaires sont disponibles lors de la connexion à un PLM PTC Windchill prenant en charge le système PartsLInk de Windchill. Le système PartsLink permet de classer les pièces en groupes pour un ciblage plus pratique et plus rapide, et peut inclure des paires Attribut/Valeur associées afin d’apporter une définition plus détaillée au sein de cette classification. Voir la section repliable ci-dessous pour plus d’informations.

  • Sélectionnez le Add Classification Name Criteria dans le menu Filter Criteria pour ajouter un filtre de classification. Utilisez le menu de nom pour choisir un groupe de classification selon lequel la synchronisation sera filtrée.

  • Pour un contrôle plus fin, sélectionnez l’option Add Classification Attribute Criteria et spécifiez l’Attribute d’une classification ainsi que sa valeur associée. Dans l’exemple présenté ici, seuls les condensateurs de la classe 102-Capacitors ayant une valeur de Capacitance égale à 10uF seront synchronisés.

Lorsque Sync Direction est défini sur To PLM ou pour une synchronisation bidirectionnelle (To PLM & To Altium), une option Add Filter Criteria est présentée sous Sync To PLM. Utilisez cette option pour définir des critères de paramètre ou de dossier qui contrôleront quels composants Workspace seront propagés vers le système PLM.

Plusieurs critères de paramètre peuvent être ajoutés afin de contraindre étroitement la synchronisation des composants Workspace vers le PLM. Les critères disponibles incluent également les options de clause OR et NOT pour établir un contrôle plus précis du filtrage des composants acceptés pour la synchronisation vers le PLM.

Notez qu’un champ PLM Target Folder supplémentaire est présenté pour une instance Windchill PLM connectée, ce qui vous permet de spécifier un emplacement du système PLM vers lequel les composants Workspace seront propagés lors de la synchronisation.

La section Sync to PLM fournit des options supplémentaires de numérotation de pièces et de préfixe/suffixe lors du ciblage d’un système Arena PLM. Ces schémas PLM prédéfinis sont disponibles dans les menus Numbering Scheme et Code et détermineront le format du numéro d’élément des pièces téléversées dans Arena.

Mappage des paramètres de composants

Poursuivez le même processus que ci-dessus pour spécifier la configuration des paramètres de synchronisation pour tous les composants que vous souhaitez synchroniser avec le PLM. Étant donné que les paramètres de composants côté Workspace ne correspondent pas nécessairement à ceux du PLM, la section d’interface Component Parameter Mapping peut être utilisée pour mapper les paramètres entre les deux. Notez que lorsque des paramètres sont mappés, leur valeur sera synchronisée de l’un à l’autre comme s’il s’agissait du même paramètre.

Utilisez la commande Add Parameter de la section pour créer une entrée de mappage d’un paramètre Workspace/PLM qui s’applique au Altium Component Type actuellement sélectionné (comme sélectionné sous Sync Parameters). Les options PLM et Altium Parameter Name sont celles disponibles dans les systèmes respectifs. Un réglage Revision dans la colonne Item/Revision entraîne la création d’une nouvelle révision de composant lorsque le paramètre a changé, tandis qu’avec le réglage Item, seul le paramètre du composant sera mis à jour lors de la synchronisation.

Utilisez l’icône associée pour supprimer une entrée de mappage.

N’importe quel nombre de paramètres peut être mappé de cette manière ; toutefois, il est probable qu’il existe un ensemble de paramètres Workspace/PLM communs qui doivent être mappés pour tous les composants. Cette approche de mappage global est disponible lorsque All Types est sélectionné comme Altium Component Type.

Créez des entrées de mappage (Add Parameter) qui s’appliqueront à tous les composants en incluant les correspondances connues de paramètres communs, puis définissez les options Item/Revision et Sync Direction selon les besoins. Il est également important de spécifier une entrée de paramètre mappé comme Primary Key – il s’agit d’une paire de paramètres commune servant d’index de référence entre les deux ensembles de données paramétriques. Lorsqu’il s’agit d’un numéro de pièce PLM (recommandé), le numéro créé côté PLM est propagé côté Altium, créant ainsi un lien de référence connu entre les ensembles de données de composants synchronisés.

Attributs de classification PLM

Pour les systèmes PLM connectés qui prennent en charge le regroupement des composants sous forme de Classifications (comme PTC Windchill), les attributs et valeurs PLM associés peuvent être mappés aux paramètres de composants Workspace dans cette section.

Pour PTC Windchill par exemple, pour extraire une valeur d’attribut de classification spécifique (par exemple, la valeur de capacité pour les condensateurs dans la classe 102-Capacitor), ajoutez cette classification et sa valeur (Capacitance) comme PLM Parameter Name et le paramètre de composant Altium cible (Value) comme Altium Parameter Name. Des définitions peuvent être ajoutées pour tous les types de composants, y compris plusieurs définitions pour un même type de composant.

Voir ci-dessus les informations sur PartsLink pour en savoir plus sur les classifications Windchill.

Choix de pièces

Utilisez le menu déroulant Sync Direction pour spécifier dans quel sens les données de choix de pièces fabricant seront synchronisées entre le Workspace et le système PLM, ou désactivez la synchronisation des choix de pièces avec l’option OFF.

Selon le type de PLM connecté, l’option Part Choice information proposera une synchronisation dans un format compatible avec les propres pièces de fabrication approuvées du PLM (Native PLM Manufacturer Parts) ou sous forme de données de paramètres de composants conventionnelles (PLM Part Attributes). Cette dernière peut comprendre plusieurs jeux d’attributs de paramètres Manufacturer:PartNumber –  MFR1:MPN1, MFR2:MPN2, par exemple.

Parmi les exemples de pièces fabricant PLM “natives” (ou intégrées), on trouve Vendor Parts dans Arena et Manufacturer Parts dans Windchill.

 

Lorsque des données de choix de pièces sont importées dans un composant de bibliothèque Workspace, elles ne dupliqueront ni ne remplaceront un choix de pièce existant saisi manuellement. Elles seront ajoutées comme nouveau choix de pièce supplémentaire pour ce composant – lequel sera mis à jour lors des exécutions de synchronisation suivantes.

XML de configuration de projet

Cette section fournit une liste de la configuration XML de base qui définit la configuration PLM initiale pour le système PLM connecté. La version téléchargée de ce XML de configuration de base (Download Sample Configuration) inclut des commentaires détaillés qui mettent en évidence la fonction de la plupart des sections Entity et Attribute.

En définitive, la configuration que vous définissez dans l’interface PLM Integration est stockée sous forme de fichiers XML système, qui peuvent être enregistrés localement à l’aide de la commande Export Configuration associée aux détails Server Connection en haut de la page de configuration.

Une option Import Configuration est également incluse. Elle vous permet d’appliquer un fichier XML de configuration existant à une nouvelle configuration PLM (ou à une configuration modifiée), ce qui dupliquera alors cette configuration PLM. De plus, dans le cas où des modifications spécialisées doivent être apportées à une configuration PLM existante, son fichier XML exporté serait modifié manuellement puis réimporté dans la configuration. Notez que les paramètres, attributs et valeurs inclus dans un fichier de configuration sont sensibles à la casse.

Une instance d’intégration PLM peut également être ajoutée et configurée à l’aide de l’ancienne interface PLM du Workspace, qui, pendant un certain temps, reste disponible lorsque l’interface utilisateur par défaut est désélectionnée via l’option Admin – Settings – PLM Integration comme indiqué ci-dessus. Cette approche manuelle exige une connaissance complète du système PLM cible et un accès à celui-ci, afin que les fichiers XML requis soient correctement configurés avant leur téléversement. Le système fournit une aide supplémentaire grâce à la disponibilité des éléments suivants :

  • Fichiers d’exemple XML de configuration commentés pour tous les systèmes PLM pris en charge. Des fichiers d’exemple de modèle de publication sont également disponibles au téléchargement.
  • Un générateur de configuration automatisé qui récupère toutes les données de paramètres du Workspace. Le fichier XML généré est préconfiguré pour l’environnement d’intégration actuel et nécessite l’ajout des attributs de données PLM correspondants.

Ajout de modèle de publication

La configuration PLM nécessite l’ajout d’un fichier XML Publishing Template afin de prendre en charge les processus du Workspace qui envoient l’ensemble des données du projet – fichiers de conception, données des composants et données de sortie de fabrication – au système PLM en une seule action de « publication ». Ces processus incluent Publish to PLM, où l’utilisateur spécifie les données de sortie à envoyer, ainsi que Project Releaser with Publish, qui envoie les données générées au PLM comme étape finale du Project Release process d’Altium Designer.

Ajoutez un fichier XML de modèle de publication approprié dans l’onglet Publish Template lors de la création ou de la modification de votre configuration PLM. Utilisez le lien Sample Project Configurations pour télécharger une collection archivée de modèles pour les systèmes PLM pris en charge.

Un Publishing Template inclut des références pour les détails du projet, le transfert des données de composants, les emplacements des sources de données et les distributions de fichiers des données de conception, d’assemblage et de fabrication. Les exemples téléchargés incluent des modèles pour tous les PLM pris en charge ; chacun inclut des règles de publication supplémentaires propres à ce type de PLM ainsi que des commentaires détaillés pour vous guider sur ce qu’il faut configurer et comment le faire.

Modifiez un modèle XML d’exemple selon vos besoins et chargez le fichier dans votre configuration PLM via la fenêtre Add Publish Template, ouverte à partir du bouton . Notez qu’une configuration PLM prend en charge plusieurs modèles de publication.

 

Les modèles de publication fournis incluent des commentaires qui vous aideront à configurer la manière dont les données de projet du Workspace seront publiées vers le système PLM connecté. Une fois que vous avez accédé à un modèle approprié et l’avez sélectionné, utilisez les informations des commentaires pour mettre à jour le fichier XML afin qu’il corresponde à vos exigences PLM, puis chargez-le (ou rechargez-le) dans la configuration PLM.

Le Workspace prend en charge la mise à jour des éléments Arena PLM existants lors de l’utilisation des processus Altium Project Releaser et Component Sync. Cela permet de pousser vers les révisions de travail des articles de pièce BOM Arena les nouvelles données de projet et de composant publiées côté Altium (données PCBA, FAB et composants).

Lors de la publication d’un projet Altium vers Arena PLM – à l’aide du processus Project Release with Publish to PLM – la révision Arena Project BOM précédemment publiée sera mise à jour, ainsi que les mises à jour supplémentaires des pièces enfant liées à ce parent. Dans ce cas, le journal PLM inclura un avertissement indiquant qu’une révision de travail a été mise à jour et que des révisions effectives ont été ajoutées à la BOM correspondante dans Arena.

Synchronisation des composants

La synchronisation des données de composants entre votre Workspace Altium 365 et le système PLM connecté est déterminée par le mappage de paramètres activé et le sens définis ci-dessus, et s’effectue lorsque le processus de synchronisation est déclenché manuellement ou automatiquement à une heure planifiée. Le processus de synchronisation lui-même est piloté par un workflow de processus intégré LibSync.

Dans une instance de configuration PLM, les options de synchronisation associées sont accessibles sous l’onglet Component Synchronization, où le processus peut être déclenché manuellement ou planifié. Pour ce dernier cas, activez l’option Synchronize on a schedule et sélectionnez un intervalle de temps dans le menu déroulant associé.

Vous pouvez utiliser les options du menu pour déclencher manuellement un processus LibSync soit comme événement de synchronisation Incremental, soit comme événement de synchronisation Full :

  • Incremental – applique uniquement les composants qui ont été modifiés depuis la dernière exécution de la synchronisation (c’est-à-dire dont l’horodatage est postérieur à la dernière date de synchronisation), et qui satisfont aux critères de synchronisation de la configuration. Notez qu’il s’agit du mode utilisé lorsqu’un événement de synchronisation est déclenché depuis le contrôle de la page principale PLM Integration – voir ci-dessous.
  • Full – ce mode force une synchronisation complète. Tous les composants qui satisfont aux critères de synchronisation de la configuration seront inclus.

Exécution de la synchronisation des composants

La synchronisation des composants (bibliothèque) peut être effectuée comme processus manuel à partir d’une entrée d’instance PLM sur la page PLM Integration du Workspace, ou comme cycle automatisé spécifié dans la configuration de l’instance – voir ci-dessus. Cliquez sur le contrôle associé à l’instance PLM pour lancer manuellement le processus de synchronisation, qui suivra le workflow LibSync en utilisant les paramètres définis dans la configuration PLM associée.

Le contrôle Actions passera à , vous permettant d’arrêter le processus de synchronisation si nécessaire, et l’entrée Sync Status indiquera qu’un processus est en cours. Le statut passera à Completed lorsque le processus de synchronisation sera terminé.

Lorsque la synchronisation des composants est exécutée, manuellement ou en tant qu’événement planifié, le processus LibSync suit son workflow prédéfini jusqu’à son achèvement ou jusqu’à ce qu’une erreur se produise. Vous pouvez actualiser le navigateur (F5) pour afficher l’état actuel du processus de synchronisation.

La synchronisation déclenchée manuellement ou planifiée est une synchronisation Incremental (par opposition à Full) ; elle ne concernera que les composants qui ont été modifiés depuis la dernière exécution de la synchronisation (c’est-à-dire dont l’horodatage est postérieur à la dernière date de synchronisation) ; et qui respectent les critères de synchronisation spécifiés dans la configuration PLM.

Pour accéder aux détails d’un événement de synchronisation terminé, cliquez sur l’icône dans la colonne Last Sync pour télécharger le fichier journal associé (voir un exemple), ou sélectionnez la date associée pour ouvrir l’entrée de l’événement dans l’onglet Synchronization Status. Notez que dans cette vue, les événements de synchronisation terminés sont listés lorsque l’option Closed est sélectionnée, et que les événements en cours d’exécution ou suspendus apparaissent lorsque le mode d’affichage Active est sélectionné.

 

Les sous-onglets de la vue Statut fournissent les informations suivantes :

  • Diagram – un graphique représentant le workflow du processus, avec sa position d’étape actuelle mise en évidence (terminée ou état d’erreur/échec).
  • Data – un résumé d’informations de l’action du processus, y compris la réussite ou l’échec de ses étapes et un lien vers le rapport de processus journalisé – voir un exemple.
  • History – un journal chronologique des principaux événements de synchronisation du Workspace listés dans l’ordre.

Tout événement de synchronisation qui s’est arrêté prématurément, par exemple lorsqu’une erreur s’est produite, sera listé lorsque la vue est en mode Active. Ces entrées peuvent être supprimées de la liste avec le contrôle Terminate (), ou plus correctement évaluées et résolues à partir de la vignette Task associée créée dans la vue Tasks du Workspace. Notez qu’un événement de synchronisation terminé/résolu sera déplacé vers la liste Closed de la vue Synchronization Status avec un Status indicatif, tel que Failed.

 

Utilisez le bouton pour télécharger un enregistrement détaillé de toutes les activités de synchronisation listées au format fichier CSV délimité par des virgules (Synchronisation status.csv). Le contenu des activités du fichier s’appliquera au mode d’affichage actuellement sélectionné – Active ou Closed.

Accès aux processus liés au PLM

Des exemples de workflows de processus relatifs à un système PLM connecté sont disponibles sous les onglets de thème de processus sur la page Workspace Processes. En général, les exemples ne peuvent pas être utilisés directement, mais doivent être réenregistrés sous un autre nom pour devenir actifs.

Consultez la documentation Processes & Workflow pour plus d’informations.

Un administrateur Workspace peut démarrer directement une nouvelle instance de toute définition de processus activée depuis la liste des processus sur la page Processes en cliquant sur le contrôle  . Les utilisateurs Workspace non administrateurs peuvent également lancer des processus actifs depuis le Workspace, tels que :

  • Un processus Part Request with PLM depuis le bouton de la page Part Request.

  • Un processus Publish to PLM depuis le bouton des pages Tasks et Activities d’un projet ouvert.

  • Un processus Publish to PLM depuis le bouton de la page principale Projects

  • Un processus Project with Initialize in PLM depuis le bouton de la page principale Projects, ou lors du clonage d’un projet à partir du menu du bouton .

En pratique cependant, les processus liés au PLM sont généralement lancés depuis Altium Designer pendant la conception et le développement du projet. Les processus liés au PLM sont accessibles depuis Altium Designer des façons suivantes :

  • Part Request with PLM Part Create – accessibles depuis les panneaux Explorer, Manufacturer Part Search et Components d’Altium Designer.
    Consultez Process-based Part Requests pour des informations détaillées.

  • Publish to PLM (User selects) – accessibles depuis le sous-menu Project » Project Activities du projet Altium Designer actif.
    Consultez Publishing to a PLM – user-selects pour des informations détaillées.

  • Project Releaser with Publish – accessibles comme étape finale de Project Releaser depuis le sous-menu Project » Project Releaser du projet Altium Designer actif.
    Consultez Design Project Release – publishing to PLM pour des informations détaillées.

  • Project with initialise in PLM – accessibles lors de la création d’un nouveau projet Altium Designer depuis le sous-menu File » New » Project in <Workspace>, ou lors du clonage d’un projet.
    Consultez Publishing to a PLM – initialize in PLM pour des informations détaillées.

Workflows de processus

Les définitions de processus suivantes (et les workflows sous-jacents) sont disponibles via le Workspace, pour prendre en charge l’intégration PLM :

Ces définitions de processus ne peuvent pas être activées et utilisées telles quelles. Chacune d’elles s’apparente donc davantage à un « modèle » – modifiez-la selon les besoins de votre entreprise, nommez-la et enregistrez-la comme nouvelle définition de processus, que vous can pourrez ensuite activer et utiliser, avec toutes les autres définitions du thème de processus correspondant.
  • Part Requests thème de processus :
    • Part Request with PLM Part Create – prend en charge la création automatique d’un composant dans votre instance PLM, puis la propagation du numéro de pièce généré vers le composant du Workspace. Le diagramme de workflow est illustré ci-dessous.

Un point important à noter est que lorsque vous modifiez cet exemple de définition pour créer la vôtre, vous devez spécifier l’instance PLM dans laquelle les pièces doivent être créées. Sélectionnez l’entité Create Part in PLM dans le diagramme du workflow et choisissez l’instance PLM dans le menu déroulant associé au champ PLM Instance. Ce menu répertorie toutes les instances PLM actuellement définies (comme défini sur la page PLM Integration de l’interface).

► Consultez Creating and Managing Processes pour plus d’informations sur l’utilisation des workflows de processus.

  • Project Activities thème de processus :
  • Publish to PLM (User selects) – publication des sorties d’un projet géré publié vers l’instance PLM intégrée, où l’utilisateur peut sélectionner exactement quelles sorties seront publiées. Le diagramme de workflow est illustré ci-dessous.

  • Project Releaser with Publish – publication vers l’instance PLM intégrée en tant qu’étape supplémentaire du Project Releaser. Le diagramme de workflow est illustré ci-dessous.

  • Project Creations thème de processus :
    • Project with initialise in PLM – prend en charge la création automatique de numéros de pièce dans votre instance PLM, puis leur propagation en tant que paramètres du projet de conception du Workspace. Le diagramme de workflow est illustré ci-dessous.

 

AI-LocalizedLocalisé par IA
Si vous trouvez un problème, sélectionnez le texte/l’image et appuyez surCtrl + Enterpour nous envoyer vos commentaires.
Disponibilité des fonctionnalités

Les fonctionnalités auxquelles vous avez accès dépendent de la solution Altium dont vous disposez – Altium Develop, Altium Agile Teams, Altium Agile Enterprise, ou Altium Designer (avec un abonnement actif).

Si vous ne voyez pas une fonctionnalité documentée dans votre logiciel actuel, contactez le service commercial d’Altium pour en savoir plus.

Contenu