Altium Designer Documentation

Изменения интерфейса моделирования

Последнее изменение: Pavel Demidov; 09.02.2021

Вслед за недавней реализацией нового, улучшенного ядра моделирования SPICE для Altium Designer, которое обеспечивает более высокую сходимость, точность и надежность результатов, в новой версии сделан упор на улучшения интерфейса пользователя, связанных с рабочим процессом проведения смешанного SPICE-моделирования.

Изменения интерфейса имитатора включают в себя: новую интуитивно понятную панель Simulation Dashboard, обновленное диалоговое окно Sim Model и общие изменения интерфейса. Новый рабочий процесс моделирования, основанный на панели Simulation Dashboard, предлагает альтернативу существующему подходу, основанному на диалоговом окне Analyses Setup. Также теперь доступен широкий набор готовых к использованию компонентов общего вида для моделирования.

Это упрощает процесс настройки, верификации и проведения анализа непосредственно из новой панели Simulation Dashboard, как описано ниже.

► Перейдите на страницу Имитатор электрических цепей со смешанными сигналами для получения более подробной информации.

Обновленное диалоговое окно SIM Model

Диалоговое окно Sim Model было значительно переработано для упрощения работы с имитационными моделями компонентов и их добавления. Обновленный интерфейс диалогового окна, который теперь ориентирован на выполнение непосредственных задач, выполняемых в процессе моделирования схемы, оптимизирует процесс добавления модели, и теперь для него нужно меньшее количество шагов. Чтобы вызвать диалоговое окно, запустите добавление в компонент имитационной модели (опция Simulation в меню ) или изменение существующей имитационной модели компонента ().

Используйте кнопку в диалоговом окне Sim Model, чтобы выбрать подходящую имитационную модель из доступных локальных библиотек или из серверных моделей. После загрузки модели проверьте ее и, если необходимо, внесите изменения в сопоставление с выводами символа (Pin Mapping) и добавьте значения параметров модели.

Модели пассивных RLC-компонентов могут быть добавлены простым автоматизированным процессом в панели Simulation Dashboard в рамках верификации.

Либо вы можете применить общую, а не определенную имитационную модель, взятую из доступной библиотеки Simulation Generic Components. Эта библиотека общих имитационных моделей, добавленная как файловая библиотека, содержит широкий набор распространенных имитационных моделей и функций.

Обратите внимание, что общие имитационные модели могут быть размещены на схеме непосредственно из библиотеки в панели Components, но их нужно будет заменить на физические (а не виртуальные) компоненты для следующих этапов проектирования.

Интерфейс источников воздействия

Источники воздействия, используемые в проекте, теперь считаются специальными виртуальными инструментами моделирования, а не пользовательскими компонентами. Управление источниками осуществляется не через имитационную модель компонента, а в специальном режиме панели Properties, где есть прямой доступ к параметрам источника воздействия и предварительный просмотр формы сигнала.

Конфигурации источника воздействия может быть задано имя (Stimulus Name), и при необходимости могут быть добавлены другие имена (). Затем вы можете переключаться между конфигурациями источника воздействия с помощью выпадающего списка Stimulus Name.

Источники воздействия могут быть добавлены непосредственно из Active Bar, панели инструментов Mixed Sim или по запросу из панели Simulation Dashboard – см. ниже.

Панель Simulation Dashboard

Главным элементом обновленного интерфейса пользователя имитатора в Altium Designer является новая панель Simulation Dashboard. Панель предлагает подход к проверке, настройке, запуску и просмотру результатов моделирования, значительно упрощенный по сравнению с предыдущим подходом, основанным на диалоговом окне Analyses Setup. Чтобы открыть эту новую панель, выберите Simulation Dashboard из меню кнопки (внизу справа) или выберите команду View » Panels » Simulation Dashboard из главного меню.

Панель Simulation Dashboard представляет последовательность этапов интерактивного моделирования, где каждый раздел отображает информацию о состоянии и/или опции настройки. Панель может быть применена к цепям и объектам схемы всего проекта (Project) или только открытого в данный момент документа схемы (Document).

Далее приведен обзор каждого раздела панели Simulation Dashboard:

1. Verification (Верификация)

Нажмите кнопку , чтобы начать выполнение ряда автоматизированных процессов и проверок, в которые входят формирование списка цепей SPICE схемы (*.nsx), ряд проверок электрических правил, относящихся к моделированию, и валидационные проверки имитационных моделей. Проверка моделей обнаружит компоненты с отсутствующими имитационными моделями и модели с ошибками синтаксиса или сопоставления выводов. Используйте контекстные ссылки, связанные с ошибками, чтобы исправить нарушения.

Система автоматически предложит добавление имитационных моделей в пассивные компоненты, если это необходимо. Имитационные модели для этих компонентов (резисторов, индуктивностей, конденсаторов) изначально известны ядру моделирования, и они представлены в диалоговом окне Sim Model в виде набора параметров. Эти автоматически назначенные имитационные модели соответствуют большинству требований анализа, и это самый быстрый и простой способ добавления моделей в пассивные компоненты на схеме – нажмите по соответствующей ссылке Assign, чтобы начать процесс.

  

Обратите внимание, что при изменении схем появится запрос на верификацию.

2. Preparation (Подготовка)

Управляйте источниками (Sources) и пробниками (Probes) моделирования, которые присутствуют в текущей схеме. Источники и пробники можно включать/отключать (флажки), удалять (X) и создавать (+ Add). Обратите внимание, настройка источников и пробников осуществляется в панели Properties, и их также можно добавлять из Active Bar.

3. Analysis Setup & Run (Настройка и запуск анализа)

Настраивайте и запускайте основные типы имитационного анализа и опционально задавайте и применяйте вариации параметров и вариации разброса Монте-Карло. Опции настройки анализа включают в себя настройки диапазона по оси X (частота/время), настройки выходных графиков, основанных на выходных выражениях, и дополнительные процессы, такие как анализ Фурье и анализ внутренних шумов. Выражения выходных графиков можно включать/отключать, удалять и добавлять.

Нажмите по ссылке в панели, чтобы запустить анализ соответствующего типа.

После запуска анализа Operating Point для определения установившегося режима работы схемы, можно отобразить рассчитанные значения напряжений, мощностей и токов в качестве меток на соответствующих узлах с помощью кнопок Display on schematic в панели Simulation Dashboard.

Расширенные графики анализа, которые включают в себя опции вариации параметров, настраиваются на вкладке General в диалоговом окне Advanced Analysis Settings. Чтобы открыть его, нажмите по ссылке в разделе Analysis Setup & Run панели. Выберите и настройте вариацию параметров, которая будет использоваться в текущих анализах. Перейдите на вкладку Advanced диалогового окна, чтобы задать расширенные настройки и опции ядра моделирования.

4. Results (Результаты)

Управляйте результатами недавних запусков моделирования, приведенных в списке в виде доступных типов анализа. Опция Load Profile восстановит настройки анализа из этого запуска.

Вы можете включить иконку замка (), связанную со строкой результатов анализа, чтобы предотвратить изменение результатов этого запуска. Последующему запуску анализа этого типа будет задано другое имя с увеличенным числовым суффиксом.

Сторонние проекты и библиотеки

Смешанное SPICE-моделирование Altium Designer теперь поддерживает набор форматов и проектов аналоговых SPICE-моделей, в том числе PSpice® и LTSpice®.

Общие библиотеки моделей PSpice (как правило, имеют расширение .lib), могут быть добавлены как файловые библиотеки на странице Data Management - File-based Libraries диалогового окна Preferences. Для каждой модели автоматически формируется базовый символ компонента, что позволяет размещать их непосредственно на схеме.

Импорт LTSpice

Проекты моделирования, сохраненные из LTSpice®, могут быть импортированы в Altium Designer с помощью мастера LTSpice Import Wizard, который доступен при установке программного расширения LTSpice Importer.

Вызовите мастер с помощью команды File » Import Wizard, выберите LTSpice Design Files в качестве типа файлов и пройдите остальные шаги мастера. Файлы символов компонентов, на которые указаны ссылки в файле проекта LTSpice (*.asc), будут автоматически добавлены в качестве файлов библиотек, и, в свою очередь, имитационные модели, на которые указаны ссылки в файлах библиотек компонентов, также будут добавлены в импорт.

В результате импорта, будет создан проект платы Altium Designer, который также включает в себя схемную библиотеку, содержащую компоненты проекта, и набор сформированных имитационных моделей в общем формате *.mdl. Источники напряжения LTSpice импортируются в виде эквивалентных источников воздействия Altium Designer.

Файлы библиотек и моделей

  • Для успешного импорта проекта LTSpice необходимо, чтобы были доступны файлы данных библиотек компонентов проекта, такие как вспомогательные файлы символов компонентов (*.asy) и файлы имитационных моделей (*.sub, *.lib и т.п.). Все необходимые файлы должны находиться в той же исходной папке, что и импортируемый файл проекта LTSpice (*.asc).
  • Но если на том же компьютере, на котором установлен Altium Designer, установлено приложение LTSpice, то файлы библиотек будут автоматически обнаружены в установке LTSpice и добавлены в процесс импорта.
  • Обратите внимание, что мастер также поддерживает импорт только файлов библиотек компонентов LTSpice (*.asy), без необходимости в соответствующем файле проекта (*.asc).

Импорт проектов моделирования OrCAD

Проекты OrCAD™ и связанные с ними имитационные библиотеки PSpice® могут быть импортированы в Altium Designer с помощью OrCAD Import Wizard, который становится доступен при включении модуля импорта OrCAD в разделе Configure Platform на странице Extension and Updates.

Вызовите мастер с помощью команды File » Import Wizard главного меню, выберите тип OrCAD Designs and Libraries Files и пройдите шаги мастера. Будут импортированы проектные файлы (*.DSN), библиотеки (*.OLB) и имитационные модели PSpice (*.LIB) OrCAD, и в Altium Designer будут созданы соответствующие проектные файлы, файлы библиотек и файлы моделей PSpice в формате *.ckt.

Процесс импорта добавит данные импортированных имитационных моделей PSpice в компоненты проекта и преобразует источники воздействия в формат Altium Designer. В результате будет получен готовый к моделированию проект в Altium Designer.

Обнаружили проблему в этом документе? Выделите область и нажмите Ctrl+Enter, чтобы оповестить нас.

Связаться с нами

Связаться с нашими Представительствами напрямую

We're sorry to hear the article wasn't helpful to you.
Could you take a moment to tell us why?
Вы сообщаете о проблеме, связанной со следующим выделенным текстом
и/или изображением в активном документе:
Бесплатная пробная версия Altium Designer
Бесплатная пробная версия Altium Designer
Давайте приступим. Для начала, Вы или Ваше предприятие уже используете Altium Designer?

Если Вы хотите поговорить с представителем, пожалуйста, свяжитесь с местным офисом Altium.
Copyright © 2019 Altium Limited

В таком случае, для чего Вам необходима пробная лицензия?

Если Вы хотите поговорить с представителем, пожалуйста, свяжитесь с местным офисом Altium.
Copyright © 2019 Altium Limited

Вам для этого не нужна пробная лицензия.

Нажмите кнопку ниже, чтобы загрузить установщик самой новой версии Altium Designer

Загрузить установщик Altium Designer

Если Вы хотите поговорить с представителем, пожалуйста, свяжитесь с местным офисом Altium.
Copyright © 2019 Altium Limited

Пожалуйста, заполните форму ниже, чтобы получить ценовое предложение.

Нажимая [Получить бесплатнную пробную версию], Вы соглашаетесь с нашей Политикой конфиденциальности. Вам могут приходить сообщения от компании Altium, и Вы можете изменить настройки уведомлений в любой момент.

Если Ваша подписка Altium активна, у Вас нет необходимости в пробной лицензии.

Если у Вас нет активной подписки Altium, пожалуйста, заполните форму ниже, чтобы получить пробную версию.

Нажимая [Получить бесплатнную пробную версию], Вы соглашаетесь с нашей Политикой конфиденциальности. Вам могут приходить сообщения от компании Altium, и Вы можете изменить настройки уведомлений в любой момент.

Для чего Вы хотите попробовать Altium Designer?

Если Вы хотите поговорить с представителем, пожалуйста, свяжитесь с местным офисом Altium.
Copyright © 2019 Altium Limited

Вы нашли нужное место! Пожалуйста, заполните форму ниже, чтобы начать использование пробной версии.

Нажимая [Получить бесплатнную пробную версию], Вы соглашаетесь с нашей Политикой конфиденциальности. Вам могут приходить сообщения от компании Altium, и Вы можете изменить настройки уведомлений в любой момент.

Great News!

Valid students can get their very own 6-month Altium Designer Student License for FREE! Just fill out the form below to request your Student License today.

Нажимая [Получить бесплатнную пробную версию], Вы соглашаетесь с нашей Политикой конфиденциальности. Вам могут приходить сообщения от компании Altium, и Вы можете изменить настройки уведомлений в любой момент.

Вы можете загрузить бесплатную лицензию средства просмотра Altium Designer Viewer сроком действия 6 месяцев.

Пожалуйста, заполните форму ниже, чтобы запросить эту лицензию.

Нажимая [Получить бесплатнную пробную версию], Вы соглашаетесь с нашей Политикой конфиденциальности. Вам могут приходить сообщения от компании Altium, и Вы можете изменить настройки уведомлений в любой момент.

Замечательно! Создавать новое - отличное занятие. У нас есть превосходная программа для Вас.

Upverter - бесплатная платформа, разработанная специально для любителей проектирования.

Нажмите здесь, чтобы попробовать!

Если Вы хотите поговорить с представителем, пожалуйста, свяжитесь с местным офисом Altium.
Copyright © 2019 Altium Limited

Вы можете загрузить бесплатную лицензию средства просмотра Altium Designer Viewer сроком действия 6 месяцев.

Пожалуйста, заполните форму ниже, чтобы запросить эту лицензию.

Нажимая [Получить бесплатнную пробную версию], Вы соглашаетесь с нашей Политикой конфиденциальности. Вам могут приходить сообщения от компании Altium, и Вы можете изменить настройки уведомлений в любой момент.